OpenEdge® Reporting:
Deploying Crystal Reports
Copyright

© 2017 Progress Software Corporation and/or its subsidiaries or affiliates. All rights reserved.

These materials and all Progress® software products are copyrighted and all rights are reserved by Progress Software Corporation. The information in these materials is subject to change without notice, and Progress Software Corporation assumes no responsibility for any errors that may appear therein. The references in these materials to specific platforms supported are subject to change.

Business Making Progress, Corticon, DataDirect (and design), DataDirect Cloud, DataDirect Connect, DataDirect Connect64, DataDirect XML Converters, DataDirect XQuery, Deliver More Than Expected, Icenium, Kendo UI, Making Software Work Together, NativeScript, OpenEdge, Powered by Progress, Progress, Progress Software Developers Network, Rollbase, SequeLink, Sitefinity (and Design), SpeedScript, Stylus Studio, TeamPulse, Telerik, Telerik (and Design), Test Studio, and WebSpeed are registered trademarks of Progress Software Corporation or one of its affiliates or subsidiaries in the U.S. and/or other countries. AccelEvent, Analytics360, AppsAlive, AppServer, Arcade, BravePoint, BusinessEdge, DataDirect Spy, DataDirect SupportLink, DevCraft, DigitalFactory, Fiddler, Future Proof, High Performance Integration, JustCode, JustDecompile, JustMock, JustTrace, OpenAccess, ProDataSet, Progress Arcade, Progress Profiles, Progress Results, Progress RFID, Progress Software, ProVision, PSE Pro, SectorAlliance, Sitefinity, SmartBrowser, SmartComponent, SmartDataBrowser, SmartDataObjects, SmartDataView, SmartDialog, SmartFolder, SmartFrame, SmartObjects, SmartPanel, SmartQuery, SmartViewer, SmartWindow, WebClient, and Who Makes Progress are trademarks or service marks of Progress Software Corporation and/or its subsidiaries or affiliates in the U.S. and other countries. Java is a registered trademark of Oracle and/or its affiliates. Any other marks contained herein may be trademarks of their respective owners.

Please refer to the Release Notes applicable to the particular Progress product release for any third-party acknowledgements required to be provided in the documentation associated with the Progress product.

The Release Notes can be found in the OpenEdge installation directory and online at: https://community.progress.com/technicalusers/w/openedgegeneral/1329.openedge-product-documentation-overview.aspx.

For the latest documentation updates see OpenEdge Product Documentation on Progress Communities: (https://community.progress.com/technicalusers/w/openedgegeneral/1329.openedge-product-documentation-overview.aspx).

December 2014

Last updated with new content: Release 10.0B

Updated: 2017/03/24

OpenEdge Reporting: Deploying Crystal Reports
# Table of Contents

## Preface
- Purpose ................................................................. 7
- Audience .............................................................. 7
- Organization .......................................................... 8
- Typographical conventions ........................................ 8
- OpenEdge messages .................................................. 9
  - Obtaining more information about OpenEdge messages .................. 10

## Chapter 1: Introduction
- Creating a sample database ..................................... 11
- Starting the sample database ....................................... 12
- Configuring the ODBC driver ...................................... 13
  - Understanding transactions and isolation levels ................. 13
  - Adding a new data source ......................................... 15

## Chapter 2: Creating a Crystal Reports Document
- Using Crystal Reports to connect to a data source ......... 19
- Specifying report information .................................... 22
- Running a report ..................................................... 25

## Chapter 3: Crystal Reports Design Basics
- Organizing report data ........................................... 27
  - Defining a record selection criterion ......................... 28
  - Grouping records ................................................ 30
  - Setting record order ............................................. 31
  - Adding summaries .............................................. 32
- Defining report appearance ..................................... 33
  - Creating report and page headers ......................... 34
  - Arranging fields ............................................... 34
  - Modifying text .................................................. 35
  - Adding a template .............................................. 37

## Chapter 4: Crystal Reports and Database Security
- Using logon validation .......................................... 39
- Logon validation guidelines .................................... 40
- Assigning privileges ............................................. 40
Preface

For details, see the following topics:

• Purpose
• Audience
• Organization
• Typographical conventions
• OpenEdge messages

Purpose

To provide a basic introduction to using Crystal Reports® in the Progress® OpenEdge® development environment. For more detailed information, users should refer to Crystal Reports documentation and online Help. Users who require technical support should refer to Business Objects technical support.

For the latest documentation updates see the OpenEdge Product Documentation category on Progress Communities.

Audience

This manual is for OpenEdge developers who are new to Crystal Reports.
Organization

**Introduction** on page 11

Provides you with information on connecting Crystal Reports to an OpenEdge database. It also offers procedures for creating a sample database that can be used to demonstrate Crystal Reports’ capabilities.

**Creating a Crystal Reports Document** on page 19

Shows you how to use Crystal Reports to create a simple report.

**Crystal Reports Design Basics** on page 27

Shows how to format a Crystal Reports document.

**Crystal Reports and Database Security** on page 39

Provides guidelines for using logon validation, user privileges, and password protection.

Typographical conventions

This documentation uses the following typographical and syntax conventions:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Bold typeface indicates commands or characters the user types, provides emphasis, or the names of user interface elements.</td>
</tr>
<tr>
<td><strong>Italic</strong></td>
<td>Italic typeface indicates the title of a document, or signifies new terms.</td>
</tr>
<tr>
<td><strong>SMALL, BOLD CAPITAL LETTERS</strong></td>
<td>Small, bold capital letters indicate OpenEdge key functions and generic keyboard keys; for example, GET and CTRL.</td>
</tr>
<tr>
<td><strong>KEY1+KEY2</strong></td>
<td>A plus sign between key names indicates a simultaneous key sequence: you press and hold down the first key while pressing the second key. For example, CTRL+X.</td>
</tr>
<tr>
<td><strong>KEY1 KEY2</strong></td>
<td>A space between key names indicates a sequential key sequence: you press and release the first key, then press another key. For example, ESCAPE H.</td>
</tr>
<tr>
<td><strong>Syntax:</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Fixed width</strong></td>
<td>A fixed-width font is used in syntax, code examples, system output, and file names.</td>
</tr>
<tr>
<td><strong>Fixed-width italics</strong></td>
<td>Fixed-width italics indicate variables in syntax.</td>
</tr>
<tr>
<td><strong>Fixed-width bold</strong></td>
<td>Fixed-width bold italic indicates variables in syntax with special emphasis.</td>
</tr>
<tr>
<td><strong>UPPERCASE fixed width</strong></td>
<td>ABL keywords in syntax and code examples are almost always shown in uppercase. Although shown in uppercase, you can type ABL keywords in either uppercase or lowercase in a procedure or class.</td>
</tr>
<tr>
<td>Convention</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Period (.) or colon (:).</td>
<td>All statements except <strong>DO</strong>, <strong>FOR</strong>, <strong>FUNCTION</strong>, <strong>PROCEDURE</strong>, and <strong>REPEAT</strong> end with a period. <strong>DO</strong>, <strong>FOR</strong>, <strong>FUNCTION</strong>, <strong>PROCEDURE</strong>, and <strong>REPEAT</strong> statements can end with either a period or a colon.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Large brackets indicate the items within them are optional.</td>
</tr>
<tr>
<td>[]</td>
<td>Small brackets are part of ABL.</td>
</tr>
<tr>
<td>{ }</td>
<td>Large braces indicate the items within them are required. They are used to simplify complex syntax diagrams.</td>
</tr>
<tr>
<td>{}</td>
<td>Small braces are part of ABL. For example, a called external procedure must use braces when referencing arguments passed by a calling procedure.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>...</td>
<td>Ellipses indicate repetition: you can choose one or more of the preceding items.</td>
</tr>
</tbody>
</table>

**OpenEdge messages**

OpenEdge displays several types of messages to inform you of routine and unusual occurrences:

- **Execution messages** inform you of errors encountered while OpenEdge is running a procedure; for example, if OpenEdge cannot find a record with a specified index field value.

- **Compile messages** inform you of errors found while OpenEdge is reading and analyzing a procedure before running it; for example, if a procedure references a table name that is not defined in the database.

- **Startup messages** inform you of unusual conditions detected while OpenEdge is getting ready to execute; for example, if you entered an invalid startup parameter.

After displaying a message, OpenEdge proceeds in one of several ways:

- Continues execution, subject to the error-processing actions that you specify or that are assumed as part of the procedure. This is the most common action taken after execution messages.

- Returns to the Procedure Editor, so you can correct an error in a procedure. This is the usual action taken after compiler messages.

- Halts processing of a procedure and returns immediately to the Procedure Editor. This does not happen often.

- Terminates the current session.

OpenEdge messages end with a message number in parentheses. In this example, the message number is 200:

```plaintext
** Unknown table name table. (200)
```
If you encounter an error that terminates OpenEdge, note the message number before restarting.

**Obtaining more information about OpenEdge messages**

In Windows platforms, use OpenEdge online help to obtain more information about OpenEdge messages. Many OpenEdge tools include the following Help menu options to provide information about messages:

- Choose **Help > Recent Messages** to display detailed descriptions of the most recent OpenEdge message and all other messages returned in the current session.
- Choose **Help > Messages** and then type the message number to display a description of a specific OpenEdge message.
- In the Procedure Editor, press the **HELP** key or **F1**.

On UNIX platforms, use the OpenEdge **pro** command to start a single-user mode character OpenEdge client session and view a brief description of a message by providing its number.

**To use the pro command to obtain a message description by message number:**

1. Start the Procedure Editor:

   ```
   OpenEdge-install-dir/bin/pro
   ```

2. Press **F3** to access the menu bar, then choose **Help > Messages**.
3. Type the message number and press **ENTER**. Details about that message number appear.
4. Press **F4** to close the message, press **F3** to access the Procedure Editor menu, and choose **File > Exit**.
Introduction

Crystal Reports from Business Objects has been designated as a reporting tool for OpenEdge Release 10. Crystal Reports interacts with the OpenEdge RDBMS through the OpenEdge SQL interface. This chapter provides you with information on connecting Crystal Reports to an OpenEdge database. It also offers procedures for creating a sample database that can be used to demonstrate Crystal Reports’ capabilities.

For details, see the following topics:

• Creating a sample database
• Starting the sample database
• Configuring the ODBC driver

Creating a sample database

You can easily create a sample database to work with while becoming familiar with Crystal Reports. Once the database is created, you can connect to it with Crystal Reports and use the database to follow the examples in this manual. The examples demonstrate Crystal Reports basic capabilities.

In the following example, the database is created by copying the Sports2000 database and naming the new database Sports2004. Creating a copy of the Sports2000 database involves running PROENV to set up your OpenEdge environment, and then using the prodb command to copy the Sports2000 database.

To create a sample database:

1. From the Control Panel or the OpenEdge Program Group, double-click the Proenv icon. The Proenv window appears with the proenv > prompt:
2. At the proenv > prompt type the following command to create the database Sports2004, which is a copy of Sports2000:

   prodb Sports2004 Sports2000

3. Press Enter. Prodb confirms that the database has been created:

**Starting the sample database**

This section describes how to start the sample database. In the following example, the database is started with the assumption that OpenEdge is installed locally on your machine.

To start the Sports2004 database from the Proenv window:

1. At the Proenv command prompt, type:

   proserve Sports2004 -H localhost -S 5555

   The proserve command starts the Sports2004 database.

   -H is the database startup parameter that identifies localhost as the server on which the database resides.
   -S is the database startup parameter that identifies the port through which the database is connected.

   For more on starting databases, see OpenEdge Deployment: Startup Command and Parameter Reference.

2. Press Enter.
Proserve confirms that the Sports2004 database has started:

Now that you have created and started a database, you can configure the ODBC driver and use it to connect to the new sample database.

Configuring the ODBC driver

Setting the correct isolation level is an important step in the driver configuration process. Before configuring the driver it is important to understand some basic concepts about database transactions and transaction isolation levels.

This section covers the following information:

• Understanding transactions and isolation levels on page 13

• Adding a new data source on page 15

Understanding transactions and isolation levels

SQL defines isolation levels in terms of the inconsistencies they allow:

The following table identifies which inconsistencies are either permitted or prevented by each isolation level.

Table 1: Transaction isolation levels

<table>
<thead>
<tr>
<th>Isolation</th>
<th>Dirty read</th>
<th>Nonrepeatable read</th>
<th>Phantom read</th>
</tr>
</thead>
<tbody>
<tr>
<td>READ UNCOMMITTED</td>
<td>Permitted</td>
<td>Permitted</td>
<td>Permitted</td>
</tr>
<tr>
<td>READ COMMITTED</td>
<td>Prevented</td>
<td>Permitted</td>
<td>Permitted</td>
</tr>
<tr>
<td>REPEATABLE READ</td>
<td>Prevented</td>
<td>Prevented</td>
<td>Permitted</td>
</tr>
<tr>
<td>SERIALIZABLE</td>
<td>Prevented</td>
<td>Prevented</td>
<td>Prevented</td>
</tr>
</tbody>
</table>

Dirty read

A Dirty read occurs when one user is updating or inserting a record. At the same time, a different user is also reading it, but has not yet committed any work to the database.
Nonrepeatable read
A Nonrepeatable read occurs when one user is repeating a read operation on the same records but has updated values.

Phantom read
A Phantom read occurs when one user is repeating a read operation on the same records, but has new records in the results set:

- **READ UNCOMMITTED**
  Also called a Dirty read. When this isolation level is used, a transaction can read uncommitted data that later may be rolled back. A transaction that uses this isolation level can only fetch data but can't update, delete, or insert data.

- **READ COMMITTED**
  With this isolation level, Dirty reads are not possible, but if the same row is read repeatedly during the same transaction, its contents may be changed or the entire row may be deleted by other transactions.

- **REPEATABLE READ**
  This isolation level guarantees that a transaction can read the same row many times and it will remain intact. However, if a query with the same search criteria (the same WHERE clause) is executed more than once, each execution may return different set of rows. This may happen because other transactions are allowed to insert new rows that satisfy the search criteria or update some rows in such way that they now satisfy the search criteria.

- **SERIALIZABLE**
  This isolation level guarantees that none of the above happens. In addition, it guarantees that transactions that use this level will be completely isolated from other transactions.

Based on this information, we can provide basic guidelines for choosing the proper isolation level for the ODBC connection that is going to be used by Crystal Reports:

**READ UNCOMMITTED** should be used with reports that do not rely on data accuracy. Usually these same reports also process/access a high number of records. This optimizes performance while executing your report with a minimum number of database locks. Examples of reports in this category:

- Statistical information at the end of a month.
- Sales report covering a previous year.
- Reports running daily that accesses data which is rarely updated.
- Reports running daily if the values displayed are only used as indicators.

**COMMITTED READ** should be used with reports running daily on data that is frequently modified. This enables good performance while executing reports on a "live" database with an average number of record locks that are immediately released. Examples of reports in this category include:

- Daily reports on regularly updated data requiring 100 percent accuracy at the time the report is processed.
- Reports that provide snapshots of an operation at any time during the day. Such reports are used for monitoring purposes, such as stock exchange status reports.

**REPEATABLE READ** and **SERIALIZABLE** should not be used with reports as they do not add value at the time the report is generated, especially when compared to **COMMITTED READ**.
Having reviewed the transaction isolation levels, you can now configure your ODBC driver.

Adding a new data source

Once you have created your sample database and determined the proper isolation level, you can proceed to configure the ODBC Client.

To configure the ODBC client:

1. From the Windows Start menu, choose Settings > Control Panel > Administrative Tools. The Administrative Tools dialog box appears:

2. Double-click Data Sources (ODBC) in the Control Panel dialog box:
The ODBC Administrator displays the **ODBC Data Source Administrator** dialog box:

3. Click **Add** to display a list of installed drivers. The **Create New Data Source** dialog box appears:

4. Select the **DataDirect 4.20 32-BIT Progress SQL v10.0BIP** driver, then click **Finish** to display the **ODBC Progress SQL-92 Driver Setup** dialog box:
5. Specify values for the following:

- **Data Source Name**— Identifies data source configuration name. For example, **Accounting**.

- **Description** — An optional long description of the data source name. For example, **My Accounting Database**.

- **Host Name** — The name of the system where the database or database broker is located.

- **Port Number** — The system port number setup for the database listener process.

- **Database Name** — The name of the database to which you want to connect by default.

- **User ID** — The user name used to connect to your OpenEdge database. Your ODBC application can override this value, or you can override it in the Logon dialog box or connection string.

6. Click the **Advanced** tab and specify values for the following:

- **Default isolation level** — use **READ UNCOMMITTED**.

- **Fetch array size** — The number of rows the driver retrieves when fetching from the server. This is not the number of rows given to the user. The default is **50**. Enter **500**.

7. Click **Test Connect** to attempt to connect to the data source using the connection properties specified in the **Driver Setup** dialog box. the **Driver Setup** dialog box will display a logon dialog box:

8. Enter your user identification and password and Click **OK**. The OpenEdge SQL driver displays a message box that states the ODBC driver has successfully connected to the database:
Now that you have created a sample database, configured your ODBC driver and established a connection to it, you can use Crystal Reports to create a report using the sample database.
Creating a Crystal Reports Document

This chapter shows you how to create a simple report using the sample Sports2004 database.

For details, see the following topics:

- Using Crystal Reports to connect to a data source
- Specifying report information
- Running a report

Using Crystal Reports to connect to a data source

To create a report with Crystal Reports you must first connect to a database. Remember, the database must be running in order for you to connect. For information on creating and connecting to a sample database, see Introduction on page 11.

To connect to a running database:

1. Start Crystal Reports by clicking Start > Programs > Crystal Reports.
Chapter 2: Creating a Crystal Reports Document

The Welcome to Crystal Reports dialog box appears:

2. Select the As a Blank Report option in the Create a New Crystal Report Document area and click OK. The Database Expert dialog box appears:

3. Click + next to the Create New Connection folder to view subfolders. Double click the ODBC (RDO) folder. The ODBC (RDO) dialog box appears:
4. Select **Accounting** from the **Data Source Name** list and click **Next**. The **ODBC (RDO)** dialog box prompts you for logon information:

5. Enter your user identification and password and click **Finish**. The **Logon to OpenEdge SQL Driver** dialog box appears:

---

Using Crystal Reports to connect to a data source
6. Enter your user identification and password and click OK. The Database Expert dialog box appears, showing a list of tables of the database to which you connected:

Now that you are connected to the database, you can select the specific information you will need for your report.

**Specifying report information**

Once you have selected a table, you can use the Database Expert dialog box to specify the information to include in your report.

To specify your report information:

1. At the Database Expert dialog box, click + to expand the PUB folder and to view the list of tables located in the PUB schema. Click Customer to highlight it:
Note: Once you select a table to work with, then you identify the columns from which you will extract data for your report. Crystal Reports refers to table columns as data fields.

2. Click > to place Customer in the Selected Tables area and Click OK. The Crystal Reports main dialog box appears:
3. In the Field Explorer area of the Crystal Reports dialog box, click + next to the Database Fields entry to view the list of database tables. Click + next to Customer to view columns (database fields) in the Customer table. For example:

4. Drag and Drop database fields Name, City, and Balance from the Field Explorer to the Details section of the Design tab. The database fields appear in the Details section and the column headers appear directly above the fields in the Page Header section.
Running a report

Once the fields you want are placed in the Details area of the Design tab, running the report is a simple process.

To run a report:

1. Press F5 or click .

Crystal Reports generates the report on the columns you selected from the Customer table, as shown:

2. Save the report as Customer.rpt. You can use it to follow along with procedures that are described in Crystal Reports Design Basics on page 27 and in Crystal Reports and Database Security on page 39.
Crystal Reports Design Basics

Crystal Reports provides you with a variety of options for formatting your report, including grouping, sorting and totaling. Crystal Reports also enables you to format the visual elements of your report, such as fonts, character styles, borders, graphics and headers.

To demonstrate formatting features, this chapter shows how to format a report on the Customer table of the Sports2004 sample database. For procedures on creating a sample database, see Introduction on page 11.

Note: This chapter provides only introductory information on report formatting. For detailed information on formatting reports and organizing data within a report, refer to the Crystal Reports User's Guide and online Help.

For details, see the following topics:

• Organizing report data
• Defining report appearance

Organizing report data

Keeping your data well organized will help ensure that your report is easy to read. This section provides some basic procedures for organizing report data so information can be easily and clearly understood by the reader.

Specifically, this section covers:

• Defining a record selection criterion on page 28
• Grouping records on page 30
Defining a record selection criterion

The Select Expert allows you to define limitations to record selection criteria. It works similar to the `WHERE` clause of an SQL query statement. The Customer report created in the previous chapter provided information on all customers worldwide. The following set of procedures shows how to narrow that list to a specific subset.

To define a record selection criterion:

1. Click **Report > Select Expert**. The **Choose Field** dialog box appears:

2. Click **State** and then **OK**. The **Select Expert** dialog box appears:

3. From the drop down menu of the **Customer.State** tab, select **is one of**. A drop down menu for the states appears:
4. The revised report will feature information on the New England States exclusively. Select CT, MA, ME, NH, RI, and VT. The Customer. State tab is now complete:

5. If the report is designed to provide information on customers with outstanding balances, you can eliminate the customers who do not fit this profile. Click the <New> tab.

The Choose Field dialog box appears:

6. Select the Balance field and click OK. The Customer.Balance tab appears in the Select Expert dialog box:

7. Select is not equal to from the drop down list. An adjacent drop down list will appear to the right. Select 0.00 and click OK. Crystal Reports displays a warning that there has been a change to the selection criteria:
8. Click **Refresh Data**. The number of records displayed in the report drops from 1,117 worldwide customers to just 53 New England customers with outstanding accounts.

### Grouping records

A well-designed report is organized so readers can easily analyze information. Grouping similar sets of records helps readers isolate and study specific information. The following procedure shows an example of grouping using the Customer report.

To group records:

1. Click **Group > Group Expert**. The **Group Expert** dialog box appears:

![Group Expert dialog box](image)

2. Select **State** from the **Available Fields** list, click > to move the selection to the **Group By** area and click **OK**. The customer records are now grouped according to the states in which they are located.

![Grouped customer records](image)
Setting record order

Records ordering allows you to prioritize the appearance of specific pieces of information in the report. Records are sorted so information can be presented in a way that is most helpful to the reader. In the following example, records will be sorted so customers with greater outstanding balances are listed first.

To set record sort order:

1. Open the **Record Sort Order** window by clicking ![Record Sort Order](image). The **Record Sort Order** Window appears:

![Record Sort Order](image)

2. Move the fields you want to sort to the **Sort Fields** area by selecting them from the **Available Fields** list and then clicking >. The field names move to the **Sort Fields** area:

![Record Sort Order](image)

3. Select the field when it is the **Sort Fields** area, and then choose **Descending** from the **Sort Direction** options. Click **OK** when finished. Records in the report are now grouped by state and each state's records are ordered from those with the largest to smallest account balances:
Adding summaries

Crystal Reports provides many tools for analyzing information that has been drawn from a database. A good example is the ability to summarize data. To demonstrate this feature, a summary of the account balances will be added to the Customer report.

To add a summary:

1. Click \[\text{Insert Summary}\].

The Insert Summary dialog box appears:

2. Select Customer.Balance as the field to summarize, select Sum as the calculation to make to the summary, and place the summary in the Customer.State group. After making those choices, click OK. The sum of all outstanding accounts for each state appears at the end of each group:
3. Click \[\Sigma\] once more.

The **Insert Summary** dialog box appears:

4. Choose **Customer.Balance** once again as the field to summarize. Select **Sum** as the calculation to make. Select **Grand Total (Report Footer)** as the location for the summary. Click **OK**. A grand total of all outstanding accounts appears at the end of the report.

---

**Defining report appearance**

This section shows how to define the appearance of a basic report. Crystal Reports enables you to manipulate font families or character styles, add borders, pictures, coloring or shading to enhance the appearance of your report, as described in the following sections:
Creating report and page headers

Report Headers and page headers can be created by placing text objects in the header sections of the Design tab. Report headers appear at the top of the first page of the report. Page headers appear at the head of each page.

To create a header:

1. Click on the Design tab. Crystal Reports creates a text object box.

2. Drag the text object to the point in the header area where you want it to be placed and click on that spot. Crystal Reports drops the text object:

3. Enter the text you wish to appear in the box and click outside the box. The text box is placed in the header section of your choice:

Arranging fields

Fields can be arranged within a report by clicking and dragging.

To move a field in the Design tab:

1. Click on the field. The field becomes highlighted.

2. Click and drag the field to the new area, using the horizontal and vertical rulers as a guide.
Modifying text

Once you have placed a text object within your report, you can change text characteristics to fit the overall appearance of your report.

To modify text:

1. Right click within the text object. The text pop-up menu appears:

2. Click Format Text. The Format Editor dialog box appears:
3. Click on the **Font** tab. The **Font** tab appears:
4. Use the drop down menus to change font, style, size and color. Click **OK** when you have completed your selections. The remaining tabs within the Format Editor can also be used to add borders, colors, shading and other visual elements to the report:

---

**Adding a template**

Crystal Reports offers predefined report templates that can be used to apply a uniform style to the visual components of your report. The template defines a report's visual characteristics, such as font size and color, borders, and background colors or shading.

To add a template to your report:
1. Click \arrow{1}. The Template Expert dialog box appears:

![Template Expert dialog box](image)

2. Select a template from the Available Templates list and click OK. Crystal Reports applies the template to your report:

![New England Accounts](image)

When you apply a template, elements of the report may not appear exactly as you would like. Working from the Design tab, you can make any needed modifications, such as moving fields or changing font sizes.
Crystal Reports and Database Security

Because Crystal Reports provides users with database access, it is important to consider what types of access privileges are granted, and how those privileges affect database security.

For details, see the following topics:

• Using logon validation
• Assigning privileges
• Using password protection

Using logon validation

Logon validation is a mechanism that checks user identification and password at connection time using reference data stored in the OpenEdge RDBMS.

In the OpenEdge RDBMS, the reference table storing user identifications and passwords serves both OpenEdge SQL and Progress 4GL interfaces. Use the CREATE USER statement to enable logon validation from the SQL interface. Use the OpenEdge Data Administration tool to enable logon validation from the Progress 4GL interface. Logon validation can be disabled from either interface.

Creating, altering, or dropping a user via SQL is equivalent to creating, maintaining, or deleting a user with the OpenEdge Data Administration tool. The user list updated for the OpenEdge SQL interface is updated for the Progress 4GL interface and vice-versa.

In an environment where an OpenEdge RDBMS is accessed by applications using both Progress 4GL and SQL, the following conditions exist:
• If no users have been created — The Progress 4GL interface will not display a logon dialog box, but the OpenEdge SQL interface will. Anything may be entered in the user identification field and the password field may be left blank.

• If users have been created — Users accessing the database through the Progress 4GL interface are required to provide an identification and password only when the DBA has specifically mandated the practice. Furthermore, users working from the 4GL interface by default have unlimited privileges. The DBA who controls access from the 4GL interface must place limitations on user privileges or restrict access to certain database objects.

Users accessing the database through the OpenEdge SQL interface are required to provide an identification and password. Users do not have privileges until they are specified by a DBA.

Logon validation guidelines

• If your OpenEdge RDBMS is accessed only through the OpenEdge SQL interface, you should enable logon validation to ensure only authorized users have access.

• If your OpenEdge RDBMS is accessed through both the OpenEdge SQL and Progress 4GL interfaces and the 4GL does not require logon validation, then you should not enable SQL logon validation unless you intend to modify your 4GL application and make full use of this feature.

• If your OpenEdge RDBMS is accessed through the OpenEdge SQL and 4GL interfaces and the 4GL already uses logon validation, then you must use logon validation for OpenEdge SQL.

For information on creating logon validation for the OpenEdge SQL interface, see OpenEdge Data Management: SQL Development.

For information on creating logon privileges using the Progress 4GL interface, refer to the online help for the OpenEdge Data Administration tool.

Assigning privileges

Database administrators also control access to a database by assigning user privileges. SQL DBAs use the GRANT and REVOKE statements to authorize privileges for users who are working with the OpenEdge SQL interface. Privileges granted to users of the Progress 4GL interface are maintained separately using the OpenEdge Data Administration tool.

A DBA may grant specific privileges - such as selecting, updating, or deleting records - to individual users or to all users. When working through the SQL interface, all user actions against a database are prohibited unless explicitly authorized by the DBA. When users attempt to perform an action for which they do not have privileges, the OpenEdge SQL server generates an error message.

Conversely, all users working through the Progress 4GL interface have unlimited database privileges, unless those privileges are explicitly restricted by the DBA. Database privileges are defined for the Progress 4GL interface by using the OpenEdge Data Administration tool.

DBAs must exercise caution when deciding which privileges should be assigned and to whom. For example, if a table or view is selectable by all users, the DBA can grant the ability to select data to the public. Otherwise, the privilege to select data should be granted to those individuals who have a need to do so. The same principle applies to other privileges, such as updating records or executing stored procedures.

For information on user privileges and the OpenEdge SQL interface, see OpenEdge Data Management: SQL Development.
For information on user privileges and the Progress 4GL interface, refer to the online help the OpenEdge Data Administration tool.

Using password protection

Crystal Reports provides you with the ability to establish password protection for individual reports. It is independent from operating system validation or database logon validation. This mechanism ensures sensitive report data is accessed only by authorized individuals.

This section provides information on:

• Creating a new report parameter on page 41
• Creating a new password on page 42
• Verifying your new password on page 44

Creating a new report parameter

The following procedures demonstrate how to create a new report parameter that will enable password protection for the Customer report. You will need to open Customer.rpt to follow these examples.

To create a new report parameter:

1. In the Field Explorer area, right-click Parameter Fields and click New. The Create Parameter Field dialog box appears:

2. Type Password in the name field.

3. Type Enter your password to view restricted information in the Prompting text field.

4. Select String from the Value type drop-down menu.

5. Select Discrete value(s) from the Options list and click Set default values. The Set Default Values dialog box appears:
6. Type **password** in the **Edit mask** field. This will hide the entry value with asterisks. Click **OK**.

7. At the **Create Parameter Field** dialog box, click **OK**.

   Now that you have created a new parameter field, you can create a password that will be associated with it.

**Creating a new password**

Use the **Section Expert** dialog box to create the password. The **Section Expert** enables you to suppress report sections from view until a user has provided a password that enables viewing.

To create a new password:

1. From the main menu bar, click **Report > Section Expert**. The **Section Expert** dialog box appears:
2. In the **Sections** area, click the report section you wish to conditionally hide and display using the password.

   Select **Suppress (No Drill-Down)** in the Common area, then click the adjacent button.

   The **Formula Workshop** dialog box appears:

3. Double-click **password** from the **Report Fields** list. `{?password}` appears in the formula work area.

4. Type `<> "Customer"` next to `{?password}`.

5. Click the button.
Make sure your formula is correct. If your formula is correct, the following message appears:

To verify your report password works:

1. Click ![Refresh Report](image)

   The Refresh Report Data dialog box appears:

   ![Refresh Report Data](image)

2. Select Prompt for new parameter values and click OK. The Enter Parameter Values dialog box appears:
3. Enter your password in the **Discrete Value** field and click **OK**. Your report appears with all detail information:

![Password Protection Dialog](image)

4. Repeat Steps 1 and 2. At the **Enter Parameter** values dialog box, enter a value other than your password in the **Discrete Value** field and click **OK**. The **Details** section of your report remains hidden:

![Report with Details Hidden](image)
Index

A
Adding
data sources 15
summaries 32
templates 37
Administrative tools 15
Arranging
data fields 34
Assigning
data privileges 40

C
Configuring
ODBC driver 13
Connecting
data source 19
Connections
database 15
Creating
page headers 34
report headers 34
sample databases 11

D
Data fields
adding 22
arranging 34
defined 22
moving 34
Data source
connecting 19
Data sources
adding 15
Databases
connections 15
copying 11
creating samples 11
security 39
starting 12
startup commands 12
transactions 13
user privileges 40
DBAs
security responsibilities 40
Defining
record selection 28
report appearance 33
Dirty read 13

F
Format Editor 35
Formula Workshop 42

G
Group Expert
Using 30
Grouping
records 30
Guidelines
logon validation 40

H
Headers
page 34
report 34

I
Isolation level
SERIALIZABLE 14
Isolation levels
READ COMMITTED 14
READ UNCOMMITTED 13
REPEATABLE READ 14
understanding 13

L
Logon validation 39

M
Modifying
text 35
Moving
data fields 34

N
Nonrepeatable read 14

O
ODBC driver
configuring 13
Ordering records 31
Organizing report data 27

P
Passwords
  creating 41
  data security 41
  Section Expert 42
  verifying 44
Phantom Read 14
Proenv 11

R
Read
  dirty 13
  nonrepeatable 14
  phantom 14
READ COMMITTED 14
READ UNCOMMITTED 14
Records
  grouping 30
  ordering 31
  selection criteria 28
REPEATABLE READ 14
Report information specifying 22
Reports
  appearance 33
  headers 34
  organizing data 27
  page headers 34
  running 25
  summaries 32
Running reports 25

S
Section Expert passwords 42
Security
  databases 39
  DBA responsibilities 40
  logon validation 39
  password protection 41
  Progress 4GL interface 39
  user privileges 40
Select Expert
  using 28
SERIALIZABLE 14
Specifying
  report information 22
Sports2000 11
SQL
  query statement 28
  security 39
  user privileges 40
Startup commands 12
Summaries
  adding 32

T
Template Expert 37
Templates
  adding 37
Testing
  database connections 15
Text
  appearance 35
  modifying 35
Tools
  administrative 15
Transactions
  database 13
  phenomena 13

U
Using
  Select Expert 28

V
Verifying
  passwords 44

W
WHERE clause 28