OpenEdge® Management and OpenEdge Explorer: Managing Change Data Capture in Databases
OpenEdge collection: Managing Change Data Capture in Databases
# Table of Contents

**Preface**

- Purpose
- Audience
- Organization
- Using ABL documentation
  - References to ABL compiler and run-time features
  - References to ABL data types
- Typographical conventions
- Examples of syntax descriptions
  - Long syntax descriptions split across lines
  - Complex syntax descriptions with both required and optional elements
- OpenEdge messages
  - Obtaining more information about OpenEdge messages

**Chapter 1: Managing Change Data Capture in a Database**

- Enabling Change Data Capture for a database
- Creating a Change Data Capture policy
  - Selecting Change Data Capture fields
  - Generating Change Data Capture policy program
- Viewing Change Data Capture tables
- Viewing Change Data Capture policies for a table
- Editing a Change Data Capture policy
- Activating and deactivating a current Change Data Capture policy
- Deleting a Change Data Capture policy
- Dumping Change Data Capture policies
- Loading Change Data Capture policies

**Index**
Preface

For details, see the following topics:

- Purpose
- Audience
- Organization
- Using ABL documentation
- Typographical conventions
- Examples of syntax descriptions
- OpenEdge messages

Purpose

This manual describes how you can use the Database Administration Console in OpenEdge Management and OpenEdge Explorer to manage Change Data Capture in databases.

Audience

This manual is intended for OpenEdge Management and OpenEdge Explorer users as well as OpenEdge Management database and system administrators.
Organization

Managing Change Data Capture in a Database on page 15

Describes how to enable databases for Change Data Capture, and create and manage Change Data Capture policies.

Using ABL documentation

OpenEdge provides a special purpose programming language for building business applications. In the documentation, the formal name for this language is ABL (Advanced Business Language). With few exceptions, all keywords of the language appear in all UPPERCASE, using a font that is appropriate to the context. All other alphabetic language content appears in mixed case.

For the latest documentation updates see the OpenEdge Product Documentation Overview page on Progress Communities:


References to ABL compiler and run-time features

ABL is both a compiled and an interpreted language that executes in a run-time engine. The documentation refers to this run-time engine as the ABL Virtual Machine (AVM). When the documentation refers to ABL source code compilation, it specifies ABL or the compiler as the actor that manages compile-time features of the language. When the documentation refers to run-time behavior in an executing ABL program, it specifies the AVM as the actor that manages the specified run-time behavior in the program.

For example, these sentences refer to the ABL compiler's allowance for parameter passing and the AVM's possible response to that parameter passing at run time: "ABL allows you to pass a dynamic temp-table handle as a static temp-table parameter of a method. However, if at run time the passed dynamic temp-table schema does not match the schema of the static temp-table parameter, the AVM raises an error." The following sentence refers to run-time actions that the AVM can perform using a particular ABL feature: "The ABL socket object handle allows the AVM to connect with other ABL and non-ABL sessions using TCP/IP sockets."

References to ABL data types

ABL provides built-in data types, built-in class data types, and user-defined class data types. References to built-in data types follow these rules:

- Like most other keywords, references to specific built-in data types appear in all UPPERCASE, using a font that is appropriate to the context. No uppercase reference ever includes or implies any data type other than itself.

- Wherever integer appears, this is a reference to the INTEGER or INT64 data type.

- Wherever character appears, this is a reference to the CHARACTER, LONGCHAR, or CLOB data type.

- Wherever decimal appears, this is a reference to the DECIMAL data type.

- Wherever numeric appears, this is a reference to the INTEGER, INT64, or DECIMAL data type.
References to built-in class data types appear in mixed case with initial caps, for example, `Progress.Lang.Object`. References to user-defined class data types appear in mixed case, as specified for a given application example.

## Typographical conventions

This documentation uses the following typographical and syntax conventions:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Bold typeface indicates commands or characters the user types, provides emphasis, or the names of user interface elements.</td>
</tr>
<tr>
<td><em>Italic</em></td>
<td>Italic typeface indicates the title of a document, or signifies new terms.</td>
</tr>
<tr>
<td>SMALL, BOLD CAPITAL LETTERS</td>
<td>Small, bold capital letters indicate OpenEdge key functions and generic keyboard keys; for example, GET and CTRL.</td>
</tr>
<tr>
<td>KEY1+KEY2</td>
<td>A plus sign between key names indicates a <em>simultaneous</em> key sequence: you press and hold down the first key while pressing the second key. For example, CTRL+X.</td>
</tr>
<tr>
<td>KEY1 KEY2</td>
<td>A space between key names indicates a <em>sequential</em> key sequence: you press and release the first key, then press another key. For example, ESCAPE H.</td>
</tr>
</tbody>
</table>

**Syntax:**

<table>
<thead>
<tr>
<th>Fixed width</th>
<th>A fixed-width font is used in syntax, code examples, system output, and file names.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixed-width italics</td>
<td>Fixed-width italics indicate variables in syntax.</td>
</tr>
<tr>
<td>Fixed-width bold</td>
<td>Fixed-width bold italic indicates variables in syntax with special emphasis.</td>
</tr>
<tr>
<td>UPPERCASE fixed width</td>
<td>ABL keywords in syntax and code examples are almost always shown in upper case. Although shown in uppercase, you can type ABL keywords in either uppercase or lowercase in a procedure or class.</td>
</tr>
<tr>
<td>Period (.) or colon (:)</td>
<td>All statements except DO, FOR, FUNCTION, PROCEDURE, and REPEAT end with a period. DO, FOR, FUNCTION, PROCEDURE, and REPEAT statements can end with either a period or a colon.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Large brackets indicate the items within them are optional.</td>
</tr>
<tr>
<td>[]</td>
<td>Small brackets are part of ABL.</td>
</tr>
<tr>
<td>{ }</td>
<td>Large braces indicate the items within them are required. They are used to simplify complex syntax diagrams.</td>
</tr>
<tr>
<td>{}</td>
<td>Small braces are part of ABL. For example, a called external procedure must use braces when referencing arguments passed by a calling procedure.</td>
</tr>
</tbody>
</table>
Examples of syntax descriptions

In this example, `ACCUM` is a keyword, and `aggregate` and `expression` are variables:

**Syntax**

```
ACCUM aggregate expression
```

`FOR` is one of the statements that can end with either a period or a colon, as in this example:

```
FOR EACH Customer NO-LOCK:
    DISPLAY Customer.Name.
END.
```

In this example, `STREAM stream`, `UNLESS-HIDDEN`, and `NO-ERROR` are optional:

**Syntax**

```
DISPLAY [ STREAM stream ] [ UNLESS-HIDDEN ] [ NO-ERROR ]
```

In this example, the outer (small) brackets are part of the language, and the inner (large) brackets denote an optional item:

**Syntax**

```
INITIAL [ constant [, constant ] ]
```

A called external procedure must use braces when referencing compile-time arguments passed by a calling procedure, as shown in this example:

**Syntax**

```
{ &argument-name }
```
In this example, EACH, FIRST, and LAST are optional, but you can choose only one of them:

**Syntax**

```
PRESELECT [ EACH | FIRST | LAST ] record-phrase
```

In this example, you must include two expressions, and optionally you can include more. Multiple expressions are separated by commas:

**Syntax**

```
MAXIMUM ( expression, expression [ , expression ] ... )
```

In this example, you must specify MESSAGE and at least one expression or SKIP [( n )], and any number of additional expression or SKIP [( n )] is allowed:

**Syntax**

```
MESSAGE { expression | SKIP [ ( n ) ] } ...
```

In this example, you must specify {include-file, then optionally any number of argument or &argument-name = "argument-value", and then terminate with }:

**Syntax**

```
{ include-file
  [ argument | &argument-name = "argument-value" ] ... }
```

### Long syntax descriptions split across lines

Some syntax descriptions are too long to fit on one line. When syntax descriptions are split across multiple lines, groups of optional and groups of required items are kept together in the required order.

In this example, WITH is followed by six optional items:

**Syntax**

```
WITH [ ACCUM max-length ] [ expression DOWN ]
  [ CENTERED ] [ n COLUMNS ] [ SIDE-LABELS ]
  [ STREAM-IO ]
```
Complex syntax descriptions with both required and optional elements

Some syntax descriptions are too complex to distinguish required and optional elements by bracketing only the optional elements. For such syntax, the descriptions include both braces (for required elements) and brackets (for optional elements).

In this example, ASSIGN requires either one or more field entries or one record. Options available with field or record are grouped with braces and brackets:

Syntax

```
ASSIGN  { [ FRAME frame ] { field [ = expression ] } }  
        [ WHEN expression ] } . . .  
        | { record [ EXCEPT field . . . ] } 
```

OpenEdge messages

OpenEdge displays several types of messages to inform you of routine and unusual occurrences:

- **Execution messages** inform you of errors encountered while OpenEdge is running a procedure; for example, if OpenEdge cannot find a record with a specified index field value.

- **Compile messages** inform you of errors found while OpenEdge is reading and analyzing a procedure before running it; for example, if a procedure references a table name that is not defined in the database.

- **Startup messages** inform you of unusual conditions detected while OpenEdge is getting ready to execute; for example, if you entered an invalid startup parameter.

After displaying a message, OpenEdge proceeds in one of several ways:

- Continues execution, subject to the error-processing actions that you specify or that are assumed as part of the procedure. This is the most common action taken after execution messages.

- Returns to the Procedure Editor, so you can correct an error in a procedure. This is the usual action taken after compiler messages.

- Halts processing of a procedure and returns immediately to the Procedure Editor. This does not happen often.

- Terminates the current session.

OpenEdge messages end with a message number in parentheses. In this example, the message number is 200:

```
** Unknown table name table. (200) 
```

If you encounter an error that terminates OpenEdge, note the message number before restarting.
Obtaining more information about OpenEdge messages

In Windows platforms, use OpenEdge online help to obtain more information about OpenEdge messages. Many OpenEdge tools include the following Help menu options to provide information about messages:

• Choose Help > Recent Messages to display detailed descriptions of the most recent OpenEdge message and all other messages returned in the current session.

• Choose Help > Messages and then type the message number to display a description of a specific OpenEdge message.

• In the Procedure Editor, press the HELP key or F1.

On UNIX platforms, use the OpenEdge pro command to start a single-user mode character OpenEdge client session and view a brief description of a message by providing its number.

To use the pro command to obtain a message description by message number:

1. Start the Procedure Editor:

   `OpenEdge-install-dir/bin/pro`

2. Press F3 to access the menu bar, then choose Help > Messages.

3. Type the message number and press ENTER. Details about that message number appear.

4. Press F4 to close the message, press F3 to access the Procedure Editor menu, and choose File > Exit.
Managing Change Data Capture in a Database

Change Data Capture (CDC) is a tracking mechanism that enables applications to determine the changes made to user tables in a database. The changes that result from `INSERT`, `UPDATE`, and `DELETE` operations in a user table are tracked, captured and stored in relational tables called change tables. These change tables provide a view of historical data that has been changed over time.

Using CDC in OpenEdge, you can choose individual fields of a table for which you want to capture the changes and publish the data to an external data source. Thus avoiding replication of the entire database and resulting in better management of the captured data.

To manage CDC in a database, OpenEdge Management allows you to define CDC policies for tables and fields of that database. You can manage CDC table and field policies from the Database Administration page of OpenEdge Management. Before creating any CDC policies, ensure that the database is CDC enabled.

For managing Change Data Capture using Database tools, see *OpenEdge Development: Basic Database Tools*.

For Change Data Capture API references, see *OpenEdge Development: Programming Interfaces*.

For details, see the following topics:

- Enabling Change Data Capture for a database
- Creating a Change Data Capture policy
- Viewing Change Data Capture tables
- Viewing Change Data Capture policies for a table
- Editing a Change Data Capture policy
• Activating and deactivating a current Change Data Capture policy
• Deleting a Change Data Capture policy
• Dumping Change Data Capture policies
• Loading Change Data Capture policies

Enabling Change Data Capture for a database

You can enable Change Data Capture (CDC) for a database from the Database Administration Console of OpenEdge Management or from OpenEdge Explorer.

To enable CDC for a database:

1. From the console menu of OpenEdge Management or OpenEdge Explorer, select **Database Administration > Go to Database Administration**.
   
   The **Database Administration** page appears.

2. Filter or search for the required database connection and select it.
   
   The database connection home page appears.

3. Scroll through the entries in the **Database Features** section to see the **Change Data Capture** status.
   
   If CDC is already enabled for the database, a check mark in a green circle appears in the **Status** column and the word **Enable** does not appear in the **Action** column.

4. Click **Enable**.

   The **Enable Change Data Capture** page appears.

5. In the **Data area** field, type a valid area name or click **Search** to select an area in the **Area Selection** window.

6. Repeat step 5 to select an area for the **Index area** field.

   **Note:** For offline databases, search icons for the **Data area** and the **Index area** fields are disabled. So while enabling CDC for an offline database, you must enter valid area names and select the required areas.

7. (Optional) Select the **Deactivate Index** checkbox to create the change tracking table with inactive indexes.

8. Click **Enable Change Data Capture**.

   A message appears confirming that CDC is enabled for the database.

9. Click **OK**.

   The database connection home page appears, and the **Change Data Capture** status in the **Database Features** section appears as enabled.
Creating a Change Data Capture policy

You can create a Change Data Capture (CDC) policy using the Create CDC policy page.

**Note:** Before you begin, ensure that the database server is running and Change Data Capture is enabled.

To create a CDC policy:

1. For a new table, perform the following from the OpenEdge Management console menu:
   a) Select Database Administration > Go to Database Administration. The Database Administration page appears.
   b) From the list of database connections, select a connection for which you want to create a CDC policy. The selected database connection home page appears.
   c) In the Storage Management section, either click Create Change Data Capture policy or click Change Data Capture Tables List > ADD CDC POLICY.
      The Create Change Data Capture policy page appears, and the name of the selected database connection auto-populates in the Database connection field.

   For an existing table, perform the following from the OpenEdge Management console menu:
      a) Select Database Administration > Go to Database Administration. The Database Administration page appears.
      b) From the list of database connections, select the connection for which you want to create a CDC policy.
      c) In the Storage Management section, click Change Data Capture Tables List. The Change Data Capture Tables List page appears.
      d) From the list, click any table name to see its details in the Change Data Table summary page, and then click ADD CHANGE DATA CAPTURE POLICY.
         The Create Change Data Capture policy page appears, and the names of the selected database connection and the table auto-populates in their respective fields. You can use the Search icon in these fields to select a database and its corresponding table of your choice.

   Provide the following information in the Create Change Data Capture policy page:

2. In the Policy name field, provide a unique name for the policy.
   The policy name can be up to 32 characters long and must begin with a letter (A to Z). It can contain alphanumeric characters but must not contain blank spaces or special characters, except underscore ("_") and hyphen ("-").

3. (Optional) In the Description field, provide a description for the policy.

4. In the Database connection field, type the name of a database connection to which you want to add the new CDC policy or click Search to select a database connection from the Connections list dialog box.

   **Note:** When typing the name of the database connection, follow the format that OpenEdge Management and OpenEdge Explorer use to define a connection: adminserver-name.database-name. A database server must be running to connect to the database.

5. In the Table field, type the name of a table or click Search to select a table from the Table list dialog box.
The dialog box displays a list of tables including the tables that are enabled for Multi-tenancy and Table Partitioning, and their schema names, PUB or non-PUB.

6. To set the level of data you want to capture when a change occurs in the source table, select the policy **Level** value as:
   - **Minimal (0)** — Indicates that a change has occurred but does not record any values.
   - **Minimal with BitMap (1)** — Indicates the changed fields but does not record any values.
   - **Medium (2)** — Records current values only.
   - **Maximum (3)** — Records both previous and current values.

   **Note:** When creating a CDC policy with a policy level value greater than **Minimal (0)**, you must add CDC fields to create a CDC field policy for that CDC policy. For more information, see Selecting Change Data Capture fields on page 19.

   **Note:** The Encrypt policy, Identifying fields, Data area, Index area, Change table, and Change table owner options are enabled only when you select a level value greater than **Minimal (0)**.

7. Select the internal state of the policy as **Active** or **Inactive**.
   
   To create a pending policy, select **State** as **Inactive**, and to create a current policy, select **State** as **Active**.

8. Select the **Encrypt policy** check box to enable encryption on the change table using the same encryption policy that is in effect for the source table. This check box is selected by default.

9. Select the **Identifying fields** check box to mark the CDC fields as Identifying fields and create an index on the change table.

10. In the **Data area** field, type the name of a storage area where the change table is to be created or click **Search** to select an area from the Area Selection dialog box.

11. In the **Index area** field, type the name of a storage area where the change table indices are to be created or click **Search** to select an area from the Area Selection dialog box.

12. (Optional) In the **Change table** field, provide the name for the change table.

   When you create a current policy or make a pending policy to a current policy, a change table is created with **CDC_Source table name** as its name by default. However, you can choose to provide a name for the change table in this field.

   **Note:** For a source table that does not have an existing change table, creating a pending policy does not create a change table for that table.

   **Note:** Each source table contains only one change table. Once a change table is created for a source table, it will be the change table for all the CDC policies that are newly created for that source table.

13. (Optional) In the **Change table owner** field, provide the name of the owner, PUB or non-PUB, with which you want to create the change table.

   By default, the value is set to PUB.

14. (Optional) To generate an ABL API program for a CDC policy, click **GENERATE POLICY PROGRAM**, and then select a location to save the create_cdcpolicy.p file.
For more information, see Generating Change Data Capture policy program on page 20.

15. Click **SUBMIT** to create the CDC policy.

The **Change Data Capture Table Summary** page appears and displays the details of the table.

When creating a new current or pending policy for a source table that has an existing current policy and a change table, note that the change table of the existing current policy will be the change table for the new policy, and the existing current policy information is copied to the new policy. You can perform the following:

- Provide the new policy name and its description in the **Policy name** and the **Description** fields respectively.

  In the **Create Change Data Capture policy** page, all the fields for the new policy are auto-populated except these fields.

- Change the **Level** and **State** for the new policy.

  If the level of the existing current policy is **Minimal (0)**, the level of the new policy will be **Minimal (0)** and it cannot be changed to other levels. If the level of the existing current policy is greater than **Minimal (0)**, you can change the level of the new policy to any of the following levels: **Minimal with BitMap (1)**, **Medium (2)**, or **Maximum (3)**.

- Add CDC field policies to the new policy whose level is greater than **Minimal (0)**, but you cannot edit the existing CDC fields.

## Selecting Change Data Capture fields

The **Create Change Data Capture policy** page allows you to add CDC fields to a CDC policy when the policy level is defined as **Minimal with BitMap (1)**, **Medium (2)**, or **Maximum (3)**. Adding CDC fields to a CDC policy creates a CDC field policy for that policy.

To add CDC fields to a CDC policy:

1. In the **Create Change Data Capture policy** page, select **Level** as **Minimal with BitMap (1)**, **Medium (2)**, or **Maximum (3)**.

   The **Select Change Data Capture Fields** section appears and lists all the fields of the selected table and provides the following information:

   - **Field name** — The name of the field.
   - **Data type** — The type of data the data element stores.
   - **Enable identifying field** — Sets the field as an Identifying field.
   - **Field order** — Defines the order of the Identifying field.
   - **Description** — The description of the field.

2. Select the fields you want to add to the CDC policy.

3. To set the selected field as an Identifying field, click the toggle box in the **Enable identifying field** column and set it to **YES**.

   To enable this column, select the **Identifying fields** check box. Selecting this check box allows you to set the fields as Identifying fields and creates an index on the change table.

   To disable this column, clear the **Identifying fields** check box. The selected fields will no longer be set as Identifying fields.
Note: For a CDC field policy, you can add up to 15 Identifying fields.

4. To define the order of the Identifying fields, select or type a value (1 to 15) in the Field order column. The Field order column is enabled only when the Enable identifying field column is set to YES.

Note: If you deselect few CDC fields after defining the field order values, ensure that you reset the values for the selected Identifying fields in a sequential order.

Generating Change Data Capture policy program

Generating the CDC policy program creates a procedure .p file which contains the configuration of the CDC policy that you are currently creating.

You can either run the program in another database to create a new CDC policy with same configuration, or you can modify the configuration of the program and run it in the same database to create a new CDC policy with modified configuration.

You can generate policy program for both new and existing CDC policies. Note that generating the policy program does not create the CDC policy. For API references, see OpenEdge Development: Programming Interfaces.

Viewing Change Data Capture tables

You can view a list of tables that are CDC enabled in the Change Data Capture Tables List page. The list displays all the tables that have any CDC policies defined, irrespective of the policy instance being current, pending, or previous, and the policy state being active or inactive.

To view CDC enabled tables:

1. From the OpenEdge Management console menu, select Database Administration > Go to Database Administration.
   The Database Administration page appears.
2. From the list of database connections, select the required connection.
   The database connection home page appears.
3. In the Storage Management section, click Change Data Capture Tables List.
   The Change Data Capture Tables List page appears and displays the following information:
   - **Owner** — The owner of source table, PUB or non-PUB.
   - **Table name** — The name of the source table.
   - **Change Table** — The name of the change table.
   - **Current Policy**
     - **Policy name** — The name of the current policy for the source table.
     - **Policy state** — The state of the current policy—active or inactive—for the source table.
Viewing Change Data Capture policies for a table

You can view all the CDC policies defined for a table in the Change Data Capture Table Summary page. To view CDC policies for a table:

1. From the OpenEdge Management console menu, select Database Administration > Go to Database Administration.
   The Database Administration page appears.
2. From the list of database connections, select the required connection.
   The database connection home page appears.
3. In the Storage Management section, click Change Data Capture Tables List.
   The Change Data Capture Tables List page appears.
4. From the list, click the name of a table you want to view CDC policies for.
   The Change Data Capture Summary page appears and displays the following information:
   - **Policy Name** — The name of the CDC policy.
   - **Level** — The level of data that is captured on the source table. The values are Minimal (0), Minimal with Bitmap (1), Medium (2), and Maximum (3).
   - **State** — The internal state of the policy—Active or Inactive.
   - **Instance** — The instance of the policy on the source table—Current, Pending, or Previous.
   - **Last Modified** — The date and time the policy instance was last modified.
   - **Description** — The description of the policy.
Additionally, you can perform the following:

- Use the **Search Policy** field to search for a policy by its name.
- Click **ADD CHANGE DATA CAPTURE POLICY** to create a CDC policy for the selected table.
- Click the name of a policy to view and edit its details.
- Filter the list by policy name.
- Delete one or more policies at once.

## Editing a Change Data Capture policy

When editing CDC policies, the following guidelines apply:

- At any given point of time, a CDC table can have no more than one pending policy and one current policy; however, it can have any number of previous policies.
- If a current policy already exists for a CDC table, and you change the state of a pending policy to **Active** to make it a current policy, the existing current policy becomes a previous policy.
- You can change only the **Description** and **State** fields of a current policy whose state is active. However, you can also change the **Level** of a current policy whose state is inactive.
  
  To pause capturing the changes to the change table, set the state of the current policy to **Inactive**. To resume capturing the changes, you must set it back to **Active**.

- You cannot edit a previous policy.
- You cannot edit the **Policy name**, **Database connection**, and **Table** fields of a pending policy.

To edit a pending CDC policy:

1. From the OpenEdge Management console menu, select **Database Administration** > **Go to Database Administration**.
   
   The **Database Administration** page appears.
2. From the list of database connections, select a connection for which you want to edit a CDC policy.
   
   The selected database connection home page appears.
3. In the **Storage Management** section, click **Change Data Capture Tables List**.
   
   The **Change Data Capture Tables List** page appears.
4. From the list of CDC tables, click the name of the table for which you want to edit a CDC policy.
   
   The **Change Data Capture Table Summary** page appears with a list of CDC policies created for the table.
5. From the list, click the name of the pending policy you want to edit.
   
   The **Edit Change Data Capture policy** page appears. In this page, you can:

   - Edit the **Description** of the policy.
   - Change the **Level** and **State** of the policy.

**Note:** You can change the level of a pending policy but you cannot change the level of a current policy whose state is active. However, you can change the level of a current policy whose state is inactive.
• Select or clear the Identifying fields check box. For more information about CDC fields and Identifying fields, see Selecting Change Data Capture fields on page 19.

• Select or clear the CDC fields in the Select Change Data Capture Fields section.

6. Click SUBMIT.

   The Change Data Capture Table Summary page appears with the changes made to the policy.

When editing a newly created current or pending policy for a source table that has an existing current policy and a change table, note that the change table of the existing current policy will be the change table for the new policy, and the existing current policy information is copied to the new policy. You can perform the following for a newly created policy:

• Edit the Description field.

• Change the Level and State for the new policy.

   If the level of the existing current policy is Minimal (0), the level of the new policy will be Minimal (0) and it cannot be changed to other levels. If the level of the existing current policy is greater than Minimal (0), you can change the level of the new policy to any of the following levels: Minimal with BitMap (1), Medium (2), or Maximum (3).

• Add CDC field policies to the new policy whose level is greater than Minimal (0), but you cannot edit the existing CDC fields.

Activating and deactivating a current Change Data Capture policy

You can activate or deactivate a current Change Data Capture (CDC) policy based on its state—inactive or active—using the Change Data Capture Tables List page. In this page, you can also select current CDC policies in bulk and activate or deactivate them at once.

When activating or deactivating CDC policies, the following guidelines apply:

• You cannot activate or deactivate a pending or a previous policy.

• When activating current CDC policies, select only those policies whose state is Inactive as the Change Data Capture Tables List page lists both active and inactive policies.

• When deactivating current CDC policies, select only those policies whose state is Active as the Change Data Capture Tables List page lists both active and inactive policies.

To activate or deactivate a current CDC policy:

1. From the OpenEdge Management console menu, select Database Administration > Go to Database Administration.

   The Database Administration page appears.

2. From the list of database connections, select a connection for which you want to activate or deactivate a current CDC policy.

   The selected database connection home page appears.

3. In the Storage Management section, click Change Data Capture Tables List.

   The Change Data Capture Tables List page appears.
4. To activate a current CDC policy:
   a) From the list of CDC tables, select the table that has the current CDC policy that you want to activate.
      When selecting a current CDC policy to activate, you must select a table that displays a CDC policy in the Current Policy column and Inactive in the Policy state column.
   b) Click Activate, and then click YES in the confirmation dialog box.
      The state of the selected current CDC policy changes to Active and appears in the Change Data Capture Tables List page.

5. To deactivate a current CDC policy:
   a) From the list of CDC tables, select the table that has the current CDC policy that you want to deactivate.
      When selecting a current CDC policy to deactivate, you must select a table that displays a CDC policy in the Current Policy column and Active in the Policy state column.
   b) Click Deactivate, and then click YES in the confirmation dialog box.
      The state of the selected current CDC policy changes to Inactive and appears in the Change Data Capture Tables List page.

Deleting a Change Data Capture policy

You can delete a CDC policy of a table from the Change Data Capture Table summary page.

**Note:** Deleting a current CDC policy of a source table deletes the change table and all the previous policies associated with that source table.

To delete a CDC policy:
1. From the OpenEdge Management console menu, select Database Administration > Go to Database Administration.
   The Database Administration page appears.
2. From the list of database connections, select the required connection.
   The database connection home page appears.
3. In the Storage Management section, click Change Data Capture Tables list.
   The Change Data Capture Tables list page appears.
4. From the list, click the table name for which you want to delete a CDC policy.
5. In the Change Data Capture Table summary page, select the required policy and click Delete.
   You can select multiple policies or click Select All to select all available policies for that table.
6. Click Yes in the dialog box to confirm deletion.

**Note:** You cannot delete a CDC policy for a table if there are any CDC change tracking records and change records associated with it. So, ensure that you remove them from the table, if any, before deleting the CDC policy.
Dumping Change Data Capture policies

You can dump Change Data Capture (CDC) policies from your database into a .cd file using the OpenEdge Management console. You can select an individual CDC policy, a list of CDC policies, or all CDC policies irrespective of their state—current, pending, or previous—to dump, and specify the destination directory where you want to dump them. You can also select all the current or pending CDC policies defined for your database and dump them at once.

When you dump CDC policies, a .cd file is created with the name of the database, db-name.cd, from which the policies are dumped, and stored in the current OpenEdge work directory. However, you can specify a name and destination directory for the file. The .cd file contains the dump data of CDC table policies that you selected and their corresponding field policies. You can use this .cd file to load data into a database.

In case of a failure in dumping the data, an error .e file is created and stored in the same directory where the .cd file is stored.

To dump CDC policies using the OpenEdge Management console:

1. From the OpenEdge Management console menu, select Database Administration > Go to Database Administration.
   
   The Database Administration page appears.

2. From the list of database connections, select the database from which you want to dump CDC policies.
   
   The database connection home page appears.

3. In the Data Administration section, click Dump CDC policies (.cd file).
   
   The Dump Change Data Capture policies (.cd file) page appears.

4. In the File name field, specify the name you want for the .cd file or use the default name db-name.cd.

5. In the Dump directory field, enter the location of the destination directory where you want to store the .cd file or use the working directory.

6. In the Code page field, specify the code page format in which you want the CDC policies to be dumped or use the default format ISO8859-1.

7. Select the Overwrite existing file check box to allow overwriting the existing .cd file, if any, and then click NEXT.
   
   The Dump Change Data Capture policies list page appears with a list of current, pending, and previous CDC policies available for the connected database. The CDC policies are alphabetically sorted by their names.

8. From the list, select the CDC policies that you want to dump.
   
   When selecting the CDC policies, you can:
   
   • Select an individual CDC policy.
   
   • Select the All Current check box to select all current CDC policies.
   
   • Select the All Pending check box to select all pending CDC policies.

Note: When dumping multiple policies, you must select only one policy per source table as the OpenEdge Management console does not allow selecting more than one policy per source table.
9. Click **DUMP**.

    The **Confirm task for CDC dump policies** window appears.

10. Specify a name for the task of dumping the selected CDC policies or use the default name `db-name – dump CDC policies`.

11. Click:

    • **COMMIT & MONITOR** to confirm dumping the selected policies and monitor the dumping procedure in the **Change Data Capture Monitor Dump and Load** page.

        In this page, the **Data Summary** section provides details of the task such as the name of the task, the connected database, the task start and end time, and the progress percentage of the task. You can click **REFRESH** to reload the page with most current information.

        The **Monitor Database** section provides information about each policy that is dumped and their corresponding error messages, if any.

    • **COMMIT** to confirm dumping the selected policies and view the task details in the **Database Administration Tasks** page.

    • **CANCEL** to cancel the dumping procedure and return to the **Dump Change Data Capture policies list** page.

---

**Loading Change Data Capture policies**

You can load Change Data Capture (CDC) policies into a database using the OpenEdge Management console.

You can use the `.cd` file that contains the dump data of CDC table policies that you selected while dumping and their corresponding field policies, and load it into a database.

In case of a failure in loading the data, an error `.e` file is created and stored in the `$oemgmt/files.dir` directory.

To load CDC policies using the OpenEdge Management console:

1. From the OpenEdge Management console menu, select **Database Administration > Go to Database Administration**.

    The **Database Administration** page appears.

2. From the list of database connections, select the database to which you want to load CDC policies.

    The database connection home page appears.

3. In the **Data Administration** section, click **Load CDC policies (.cd file)**.

    The **Load Change Data Capture policies (.cd file)** page appears.

4. In the **Change data capture policies (.cd file)** field, click **CHOOSE FILE** to browse and select the .cd file that you want to load.

5. In the **Acceptable Error Percentage** field, either type or use the up and down arrows to specify the error rate that is acceptable to the management console to load a .cd file into a database.
For example, if you specify an error rate of 10 percent, the management console must successfully load 90 records from every set of 100 records. If the error rate exceeds, the management console terminates the loading process and places the bad records in the error file.

6. Click LOAD.

The Confirm task for CDC load policies window appears.

7. Specify a name for the task of loading or use the default name \textit{db-name - load CDC policies}.

8. Click:

- **COMMIT & MONITOR** to confirm loading the selected file and monitor the loading procedure in the Change Data Capture Monitor Dump and Load page.

  In this page, the Data Summary section provides details of the task such as the name of the task, the connected database, the task start and end time, and the progress percentage of the task. You can click REFRESH to reload the page with most current information.

  The Monitor Database section provides information about each policy that is loaded and their corresponding error messages, if any.

- **COMMIT** to confirm loading the selected file and view the task details in the Database Administration Tasks page.

- **CANCEL** to cancel the loading procedure and return to the Load Change Data Capture policies list page.
Index

.cd file 25–26
.e file 26

A
Activating CDC policy 23
Add CDC field policy 19
Add CDC policy 17

C
CDC enabled tables 20
CDC policies list for a table 21
CDC tables 20
Change Data Capture policies list 21
Change Data Capture Tables list 20
Change Table 15
Create CDC policy 17

D
Database Features 16
Deactivating CD policy 23
Delete CDC policy 24
Dump CDC 25

E
Edit a CDC policy 22
Enable CDC 16

G
Generate policy program 17

L
Load CDC policies 26

M
Manage Change Data Capture 15

S
Search CDC tables 20
Select CDC fields 19

U
Update a CDC policy 22