These materials and all Progress® software products are copyrighted and all rights are reserved by Progress Software Corporation. The information in these materials is subject to change without notice, and Progress Software Corporation assumes no responsibility for any errors that may appear therein. The references in these materials to specific platforms supported are subject to change.

Business Empowerment, Business Making Progress, Corticon, DataDirect (and design), DataDirect Cloud, DataDirect Connect, DataDirect Connect64, DataDirect XML Converters, DataDirect XQuery, Empowerment Center, Fathom, Making Software Work Together, OpenEdge,Powered by Progress, Progress Control Tower, Progress Business Empowerment, Progress Empowerment Center, Progress Empowerment Program, Progress OpenEdge, Progress RPM, Progress Software Business Making Progress, Progress Software Developers Network, Rollbase, RulesCloud, RulesWorld, SequelLink, SpeedScript, Stylus Studio, Technical Empowerment, and WebSpeed are registered trademarks of Progress Software Corporation or one of its affiliates or subsidiaries in the U.S. and/or other countries. AccelEvent, AppsAlive, AppServer, BusinessEdge, Progress Easy!, DataDirect Spy, DataDirect SupportLink, Easy!, Future Proof, High Performance Integration, OpenAccess, Pacific, ProDataSet, Progress Arcade, Progress ESP Event Manager, Progress ESP Event Modeler, Progress Event Engine, Progress Pacific, Progress Profiles, Progress Results, Progress RFID, Progress Responsive Process Management, Progress Software, ProVision, PSE Pro, SectorAlliance, SmartBrowser, SmartComponent, SmartDataBrowser, SmartDataObjects, SmartDataView, SmartDialog, SmartFolder, SmartObjects, SmartPanel, SmartQuery, SmartViewer, SmartWindow, WebClient, and Who Makes Progress are trademarks or service marks of Progress Software Corporation and/or its subsidiaries or affiliates in the U.S. and other countries. Java is a registered trademark of Oracle and/or its affiliates. Any other marks contained herein may be trademarks of their respective owners.

Please refer to the Release Notes applicable to the particular Progress product release for any third-party acknowledgments required to be provided in the documentation associated with the Progress product. The Release Notes can be found in the OpenEdge installation directory and online at: https://community.progress.com/technicalusers/w/openedgegeneral/1329.openedge-product-documentation-overview.aspx.

August 2014

Last updated with new content: Release 10.0A

For the latest documentation updates see OpenEdge Product Documentation on Progress Communities: (https://community.progress.com/technicalusers/w/openedgegeneral/1329.openedge-product-documentation-overview.aspx).
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preface</td>
<td>Preface–1</td>
</tr>
<tr>
<td><strong>1. Overview</strong></td>
<td>1–1</td>
</tr>
<tr>
<td>Tool overview</td>
<td>1–2</td>
</tr>
<tr>
<td>Task overview</td>
<td>1–3</td>
</tr>
<tr>
<td><strong>2. Getting Started</strong></td>
<td>2–1</td>
</tr>
<tr>
<td>Setting up your environment</td>
<td>2–2</td>
</tr>
<tr>
<td>Starting the Visual Translator</td>
<td>2–3</td>
</tr>
<tr>
<td>Using online help</td>
<td>2–4</td>
</tr>
<tr>
<td>Installing and opening a kit</td>
<td>2–5</td>
</tr>
<tr>
<td>Installing a Kit</td>
<td>2–5</td>
</tr>
<tr>
<td>Opening a kit in single-user mode</td>
<td>2–6</td>
</tr>
<tr>
<td>Opening a kit in multi-user mode</td>
<td>2–7</td>
</tr>
<tr>
<td>Returning a kit</td>
<td>2–8</td>
</tr>
<tr>
<td>Importing a glossary</td>
<td>2–9</td>
</tr>
<tr>
<td>Exporting a glossary</td>
<td>2–11</td>
</tr>
<tr>
<td><strong>3. Translating</strong></td>
<td>3–1</td>
</tr>
<tr>
<td>Overview</td>
<td>3–2</td>
</tr>
<tr>
<td>Pretranslation</td>
<td>3–3</td>
</tr>
<tr>
<td>Translating screen by screen</td>
<td>3–5</td>
</tr>
<tr>
<td>Opening a resource procedure</td>
<td>3–5</td>
</tr>
<tr>
<td>Opening the Properties window</td>
<td>3–7</td>
</tr>
<tr>
<td>Selecting an object</td>
<td>3–7</td>
</tr>
<tr>
<td>Entering a translation</td>
<td>3–8</td>
</tr>
<tr>
<td>Translating phrase by phrase</td>
<td>3–10</td>
</tr>
<tr>
<td>Opening the Translations tab folder</td>
<td>3–10</td>
</tr>
<tr>
<td>Opening the glossary window</td>
<td>3–11</td>
</tr>
<tr>
<td>Entering a translation</td>
<td>3–12</td>
</tr>
<tr>
<td>Global translation</td>
<td>3–13</td>
</tr>
<tr>
<td>Translation considerations</td>
<td>3–15</td>
</tr>
<tr>
<td>Punctuation</td>
<td>3–15</td>
</tr>
<tr>
<td>Accelerator keys</td>
<td>3–15</td>
</tr>
</tbody>
</table>
4. **Tracking Your Work** ................................................................. 4–1
   Checking status ........................................................................ 4–2
   Procedure status ..................................................................... 4–2
   Kit status. .............................................................................. 4–2
   Finding untranslated text phrases .............................................. 4–3
   Monitoring the glossary ............................................................ 4–5
   Printing screen captures ............................................................ 4–6
   Printing a statistics report ......................................................... 4–7

5. **Troubleshooting** ................................................................. 5–1

A. **Visual Translator Interface Reference.** .......................... A–1
   The main window ..................................................................... A–2
   Main window tab folders. ......................................................... A–2
   Main window menu bar and tool bar ........................................ A–6
   Properties window menu options and buttons ......................... A–9
Figures

Figure 3–1: Properties dialog box ............................................................... 3–7
Figure 3–2: Long String Translator dialog box ......................................... 3–12
Figure A–1: Visual Translator tab folders ................................................. A–2
Figure A–2: Procedures tab folder .............................................................. A–2
Figure A–3: Translations tab folder ............................................................ A–3
Figure A–4: Glossary tab folder ................................................................. A–4
Figure A–5: Statistics tab folder ................................................................. A–5
Figure A–6: Visual Translator menu bar .................................................... A–6
Figure A–7: Visual Translator tool bar ...................................................... A–8
Tables

Table 2–1:  Example imported glossaries ........................................ 2–9
Table 4–1:  Example glossary entries .............................................. 4–5
Table A–1:  Main window menu options and tool bar buttons .............. A–6
Table A–2:  Properties window buttons .......................................... A–9
Table A–3:  Properties window menu options .................................. A–9
This Preface contains the following sections:

- Purpose
- Audience
- Organization
- Using this manual
- Typographical conventions
- OpenEdge messages
- Third party acknowledgements
Preface

Purpose

This manual describes how to use the OpenEdge™ Visual Translator tool to translate text phrases in Progress 4GL procedures.

Audience

This book is written for the translator-the person who translates the user-interface text phrases, such as labels and messages, from the source language to a target language. The translator must have some experience with personal computers and Microsoft Windows, but might have little or no experience with application development or the procedures in the translation project.

Organization

Chapter 1, “Overview”

Describes the Visual Translator tool and provides an overview of how you can use the Visual Translator to translate the text phrases in a Progress 4GL application.

Chapter 2, “Getting Started”

Describes how to start the Visual Translator; use online help; load, open, and return a language kit; and import your own glossary.

Chapter 3, “Translating”


Chapter 4, “Tracking Your Work”

Describes how to use the Visual Translator to check the status of translations, find untranslated text phrases, monitor glossaries, and print screen captures.

Chapter 5, “Troubleshooting”

Provides answers to some common questions.

Appendix A, “Visual Translator Interface Reference”

Provides reference information for the Visual Translator tool tab folders, menu bar, and tool bar for the main window and the Properties window.

Using this manual

This book is a guide to using the Visual Translator tool. Although you can use it as a reference, it is structured so that each chapter builds on the previous chapters. Therefore, you will learn the most if you start at Chapter 1 and read through until the end.
Chapter 1 provides an overview of concepts and how the Visual Translator works with the Translation Manager tool. Subsequent chapters are task based—providing detailed instructions on how to use the Visual Translator tool. The Appendix contains reference information.

For the latest documentation updates see the OpenEdge Product Documentation category on PSDN http://www.psdn.com/library/kbcategory.jspa?categoryID=129.

Typographical conventions

This manual uses the following typographical conventions:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bold</td>
<td>Bold typeface indicates commands or characters the user types, or the names of user interface elements.</td>
</tr>
<tr>
<td><em>Italic</em></td>
<td>Italic typeface indicates the title of a document, provides emphasis, or signifies new terms.</td>
</tr>
<tr>
<td>SMALL, BOLD CAPITAL LETTERS</td>
<td>Small, bold capital letters indicate OpenEdge™ key functions and generic keyboard keys; for example, GET and CTRL.</td>
</tr>
<tr>
<td>KEY1-KEY2</td>
<td>A hyphen between key names indicates a simultaneous key sequence; you press and hold down the first key while pressing the second key. For example, CTRL-X.</td>
</tr>
<tr>
<td>KEY1 KEY2</td>
<td>A space between key names indicates a sequential key sequence: you press and release the first key, then press another key. For example, ESCAPE H.</td>
</tr>
<tr>
<td><strong>Syntax:</strong></td>
<td></td>
</tr>
<tr>
<td>Fixed width</td>
<td>A fixed-width font is used in syntax statements, code examples, and for system output and filenames.</td>
</tr>
<tr>
<td><em>Fixed-width italics</em></td>
<td>Fixed-width italics indicate variables in syntax statements.</td>
</tr>
<tr>
<td><em>Fixed-width bold</em></td>
<td>Fixed-width bold indicates variables with special emphasis.</td>
</tr>
<tr>
<td>UPPERCASE fixed width</td>
<td>Uppercase words are Progress® 4GL language keywords. Although these always are shown in uppercase, you can type them in either uppercase or lowercase in a procedure.</td>
</tr>
</tbody>
</table>
OpenEdge messages

OpenEdge displays several types of messages to inform you of routine and unusual occurrences:

- **Execution messages** inform you of errors encountered while OpenEdge is running a procedure; for example, if OpenEdge cannot find a record with a specified index field value.

- **Compile messages** inform you of errors found while OpenEdge is reading and analyzing a procedure before running it; for example, if a procedure references a table name that is not defined in the database.

- **Startup messages** inform you of unusual conditions detected while OpenEdge is getting ready to execute; for example, if you entered an invalid startup parameter.

After displaying a message, OpenEdge proceeds in one of several ways:

- Continues execution, subject to the error-processing actions that you specify or that are assumed as part of the procedure. This is the most common action taken after execution messages.

- Returns to the OpenEdge Procedure Editor, so you can correct an error in a procedure. This is the usual action taken after compiler messages.

- Halts processing of a procedure and returns immediately to the Procedure Editor. This does not happen often.

- Terminates the current session.

OpenEdge messages end with a message number in parentheses. In this example, the message number is 200:

```
** Unknown table name table. (200)
```

If you encounter an error that terminates OpenEdge, note the message number before restarting.

**Obtaining more information about OpenEdge messages**

On Windows platforms, use OpenEdge online help to obtain more information about OpenEdge messages. Many OpenEdge tools include the following Help menu options to provide information about messages:

- Choose **Help→Recent Messages** to display detailed descriptions of the most recent OpenEdge message and all other messages returned in the current session.

- Choose **Help→Messages** and then enter the message number to display a description of a specific OpenEdge message.

- In the Procedure Editor, press the help key (**F2** or **CTRL-W**).
Third party acknowledgements

One or more products in the Progress OpenEdge v11.4 release includes third party components covered by licenses that require that the following documentation notices be provided:

Progress OpenEdge v11.4 may incorporate ANT v1.5.4. Such technology is subject to the following terms and conditions: The Apache Software License, Version 1.1, applies to all versions of up to ant 1.6.0 included. The Apache Software License, Version 1.1 - Copyright (C) 2000-2003 The Apache Software Foundation. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: 1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. 2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. 3. The end-user documentation included with the redistribution, if any, must include the following acknowledgment: "This product includes software developed by the Apache Software Foundation (http://www.apache.org/)." Alternately, this acknowledgment may appear in the software itself, if and wherever such third-party acknowledgments normally appear. 4. The names "Ant" and "Apache Software Foundation" must not be used to endorse or promote products derived from this software without prior written permission. For written permission, please contact apache@apache.org. 5. Products derived from this software may not be called "Apache", nor may "Apache" appear in their name, without prior written permission of the Apache Software Foundation. THIS SOFTWARE IS PROVIDED "AS IS" AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE APACHE SOFTWARE FOUNDATION OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. This software consists of voluntary contributions made by many individuals on behalf of the Apache Software Foundation. For more information on the Apache Software Foundation, please see <http://www.apache.org/>.

Progress OpenEdge v11.4 may incorporate Apache Avalon 2002/08/06, Apache Batik v1.1, Apache Jakarta POI v1.1, Apache POI 2003/05/14, Regexp (Pure Java Regular Expression) v1.2, and XMLTask v1.15.1 from The Apache Software Foundation. Such technologies are subject to the following terms and conditions: The Apache Software License, Version 1.1 Copyright (c) 2000 The Apache Software Foundation. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: 1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. 2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. 3. The end-user documentation included with the redistribution, if any, must include the following acknowledgment: "This product includes software developed by the Apache Software Foundation (http://www.apache.org/)." Alternately, this acknowledgment may appear in the software itself, if and wherever such third-party acknowledgments normally appear. 4. The names "Apache" and "Apache Software Foundation" must not be used to endorse or promote
products derived from this software without prior written permission. For written permission, please contact apache@apache.org. 5. Products derived from this software may not be called "Apache", nor may "Apache" appear in their name, without prior written permission of the Apache Software Foundation. THIS SOFTWARE IS PROVIDED ` ` AS IS" AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE APACHE SOFTWARE FOUNDATION OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. This software consists of voluntary contributions made by many individuals on behalf of the Apache Software Foundation. For more information on the Apache Software Foundation, please see <http://www.apache.org/>. Portions of this software are based upon public domain software originally written at the National Center for Supercomputing Applications, University of Illinois, Urbana-Champaign.

Progress OpenEdge v11.4 may incorporate Apache JAXP v1.3.04 from The Apache Software Foundation. Such technology is subject to the following terms and conditions: The Apache Software License, Version 1.1 Copyright (c) 1999-2003 The Apache Software Foundation. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: 1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. 2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. 3. The end-user documentation included with the redistribution, if any, must include the following acknowledgment: "This product includes software developed by the Apache Software Foundation (http://www.apache.org/)." Alternately, this acknowledgment may appear in the software itself, if and wherever such third-party acknowledgments normally appear. 4. The names "Xalan" and "Apache Software Foundation" must not be used to endorse or promote products derived from this software without prior written permission. For written permission, please contact apache@apache.org. 5. Products derived from this software may not be called "Apache", nor may "Apache" appear in their name, without prior written permission of the Apache Software Foundation. THIS SOFTWARE IS PROVIDED ` ` AS IS" AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE APACHE SOFTWARE FOUNDATION OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. This software consists of voluntary contributions made by many individuals on behalf of the Apache Software Foundation and was originally based on software copyright (c) 1999, Lotus Development Corporation., http://www.lotus.com. For more information on the Apache Software Foundation, please see http://www.apache.org/.
Progress OpenEdge v11.4 may incorporate Crimson v1.1.3 as part of 1PDT (Progress Extensions for Eclipse) v2.4.0. Such technology is subject to the following terms and conditions: The Apache Software License, Version 1.1 Copyright (c) 1999-2003 The Apache Software Foundation. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: 1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. 2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. 3. The end-user documentation included with the redistribution, if any, must include the following acknowledgment: "This product includes software developed by the Apache Software Foundation (http://www.apache.org/)."

Alternately, this acknowledgment may appear in the software itself, if and wherever such third-party acknowledgments normally appear. 4. The names "Xerces" and "Apache Software Foundation" must not be used to endorse or promote products derived from this software without prior written permission. For written permission, please contact apache@apache.org. 5. Products derived from this software may not be called "Apache", nor may "Apache" appear in their name, without prior written permission of the Apache Software Foundation. THIS SOFTWARE IS PROVIDED ` ` AS IS" AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE APACHE SOFTWARE FOUNDATION OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. This software consists of voluntary contributions made by many individuals on behalf of the Apache Software Foundation and was originally based on software copyright (c) 1999, International Business Machines, Inc., http://www.ibm.com. For more information on the Apache Software Foundation, please see <http://www.apache.org/>.

Progress OpenEdge v11.4 may incorporate jfor v0.7.2 from jfor. Such technology is subject to the following terms and conditions: jfor Apache-Style Software License. Copyright (c) 2002 by the jfor project. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: 1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. 2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. 3. The end-user documentation included with the redistribution, if any, must include the following acknowledgment: "This product includes software developed by the jfor project (http://www.jfor.org)." Alternately, this acknowledgment may appear in the software itself, if and wherever such third-party acknowledgments normally appear. 4. The name "jfor" must not be used to endorse or promote products derived from this software without prior written permission. For written permission, please contact info@jfor.org. 5. Products derived from this software may not be called "jfor", nor may "jfor" appear in their name, without prior written permission of info@jfor.org. THIS SOFTWARE IS PROVIDED ` ` AS IS" AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE JFOR PROJECT OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Progress OpenEdge v11.4 may incorporate Apache LogKit v1.2 from The Apache Software Foundation. Such technologies are subject to the following terms and conditions: The Apache Software License, Version 1.1 -- Copyright (C) 1997-2003 The Apache Software Foundation. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: 1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. 2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. 3. The end-user documentation included with the redistribution, if any, must include the following acknowledgment: "This product includes software developed by the Apache Software Foundation (http://www.apache.org/)." Alternately, this acknowledgment may appear in the software itself, if and wherever such third-party acknowledgments normally appear. 4. The names "LogKit", "Jakarta" and "Apache Software Foundation" must not be used to endorse or promote products derived from this software without prior written permission. For written permission, please contact apache@apache.org. 5. Products derived from this software may not be called "Apache", nor may "Apache" appear in their name, without prior written permission of the Apache Software Foundation. THIS SOFTWARE IS PROVIDED ` ` AS IS" AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE APACHE SOFTWARE FOUNDATION OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. This software consists of voluntary contributions made by many individuals on behalf of the Apache Software Foundation. For more information on the Apache Software Foundation, please see <http://www.apache.org/>.

Progress OpenEdge v11.4 may incorporate Xerces for Java XML Parser v2.6.2. Such technology is subject to the following terms and conditions: The Apache Software License, Version 1.1 Copyright (c) 1999 The Apache Software Foundation. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: 1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. 2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. 3. The end-user documentation included with the redistribution, if any, must include the following acknowledgment: "This product includes software developed by the Apache Software Foundation (http://www.apache.org/)." Alternately, this acknowledgment may appear in the software itself, if and wherever such third-party acknowledgments normally appear. 4. The names "Xerces" and "Apache Software Foundation" must not be used to endorse or
promote products derived from this software without prior written permission. For written permission, please contact apache@apache.org. 5. Products derived from this software may not be called "Apache", nor may "Apache" appear in their name, without prior written permission of the Apache Software Foundation. THIS SOFTWARE IS PROVIDED ` ` AS IS" AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE APACHE SOFTWARE FOUNDATION OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. This software consists of voluntary contributions made by many individuals on behalf of the Apache Software Foundation and was originally based on software copyright (c) 1999, International Business Machines, Inc., http://www.ibm.com. For more information on the Apache Software Foundation, please see <http://www.apache.org/>.

Progress OpenEdge v11.4 may incorporate SOAP v2.3.1 from Apache Foundation. Such technology is subject to the following terms and conditions: The Apache Software License, Version 1.1

Copyright (c) 1999 The Apache Software Foundation. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. The end-user documentation included with the redistribution, if any, must include the following acknowledgment: "This product includes software developed by the Apache Software Foundation (http://www.apache.org/)."

Alternately, this acknowledgment may appear in the software itself, if and wherever such third-party acknowledgments normally appear.

4. The names "SOAP" and "Apache Software Foundation" must not be used to endorse or promote products derived from this software without prior written permission. For written permission, please contact apache@apache.org.

5. Products derived from this software may not be called "Apache", nor may "Apache" appear in their name, without prior written permission of the Apache Software Foundation.

THIS SOFTWARE IS PROVIDED ` ` AS IS" AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE APACHE SOFTWARE FOUNDATION OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This software consists of voluntary contributions made by many individuals on behalf of the Apache Software Foundation. For more information on the Apache Software Foundation, please see <http://www.apache.org/>.

Progress OpenEdge v11.4 may incorporate ANTLR (Another Tool for Language Recognition) v2.7.6. Such technology is subject to the following terms and conditions: ANTLR 3 License [The BSD License] Copyright (c) 2003-2006, Terence Parr All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. Neither the name of the author nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Progress OpenEdge v11.4 may incorporate Castor v0.9.3 from castor.org. Such technology is subject to the following terms and conditions: Original Intalio license - Copyright 1999-2004 (C) Intalio Inc., and others. All Rights Reserved. Redistribution and use of this software and associated documentation ("Software"), with or without modification, are permitted provided that the following conditions are met: 1. Redistributions of source code must retain copyright statements and notices. Redistributions must also contain a copy of this document. 2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. 3. The name "ExoLab" must not be used to endorse or promote products derived from this Software without prior written permission of Intalio Inc. For written permission, please contact info@exolab.org. 4. Products derived from this Software may not be called "Castor" nor may "Castor" appear in their names without prior written permission of Intalio Inc. Exolab, Castor and Intalio are trademarks of Intalio Inc. 5. Due credit should be given to the ExoLab Project (http://www.exolab.org/). THIS SOFTWARE IS PROVIDED BY INTALIO AND CONTRIBUTORS "AS IS" AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL INTALIO OR ITS CONTRIBUTORS BE LIABLE
FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Progress OpenEdge v11.4 may incorporate Decimal Conversion Code (dtoa.c; g_fmt.c; rnd_prod.s; dectrod.c; dectrtod.f; dmisc.c; gdtoa.c; gdtoa.h; gdtoaimp.h; gethex.c; gmisc.c; hd_init.c; misc.c; smisc.c; strtodg.c; strtord.c; sum.c; ulp.c). Such technologies are subject to the following terms and conditions: dtoa.c License: The author of this software is David M. Gay. Copyright (c) 1991, 2000, 2001 by Lucent Technologies. Permission to use, copy, modify, and distribute this software for any purpose without fee is hereby granted, provided that this entire notice is included in all copies of any software which is or includes a copy or modification of this software and in all copies of the supporting documentation for such software. THIS SOFTWARE IS BEING PROVIDED "AS IS", WITHOUT ANY EXPRESS OR IMPLIED WARRANTY. IN PARTICULAR, NEITHER THE AUTHOR NOR LUCENT MAKES ANY REPRESENTATION OR WARRANTY OF ANY KIND CONCERNING THE MERCHANTABILITY OF THIS SOFTWARE OR ITS FITNESS FOR ANY PARTICULAR PURPOSE. g_fmt.c License: The author of this software is David M. Gay. Copyright (c) 1991, 1996 by Lucent Technologies. Permission to use, copy, modify, and distribute this software for any purpose without fee is hereby granted, provided that this entire notice is included in all copies of any software which is or includes a copy or modification of this software and in all copies of the supporting documentation for such software. THIS SOFTWARE IS BEING PROVIDED "AS IS", WITHOUT ANY EXPRESS OR IMPLIED WARRANTY. IN PARTICULAR, NEITHER THE AUTHOR NOR LUCENT MAKES ANY REPRESENTATION OR WARRANTY OF ANY KIND CONCERNING THE MERCHANTABILITY OF THIS SOFTWARE OR ITS FITNESS FOR ANY PARTICULAR PURPOSE.

dectrod.c License: The author of this software is David M. Gay. Copyright (c) 1998-2001 by Lucent Technologies All Rights Reserved Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appear in all copies and that both that the copyright notice and this permission notice and warranty disclaimer appear in supporting documentation, and that the name of Lucent or any of its entities not be used in advertising or publicity pertaining to distribution of the software without specific, written prior permission. LUCENT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL LUCENT OR ANY OF ITS ENTITIES BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT,
NEGILIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. decstrtof.c
License: The author of this software is David M. Gay. Copyright (C) 1998, 2000 by Lucent Technologies All Rights Reserved Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appear in all copies and that both the copyright notice and this permission notice and warranty disclaimer appear in supporting documentation, and that the name of Lucent or any of its entities not be used in advertising or publicity pertaining to distribution of the software without specific, written prior permission. LUCENT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL LUCENT OR ANY OF ITS ENTITIES BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. dmisc.c
License: The author of this software is David M. Gay. Copyright (C) 1998 by Lucent Technologies All Rights Reserved Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appear in all copies and that both the copyright notice and this permission notice and warranty disclaimer appear in supporting documentation, and that the name of Lucent or any of its entities not be used in advertising or publicity pertaining to distribution of the software without specific, written prior permission. LUCENT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL LUCENT OR ANY OF ITS ENTITIES BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. gdtoa.c
License: The author of this software is David M. Gay. Copyright (C) 1998, 1999 by Lucent Technologies All Rights Reserved Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appear in all copies and that both the copyright notice and this permission notice and warranty disclaimer appear in supporting documentation, and that the name of Lucent or any of its entities not be used in advertising or publicity pertaining to distribution of the software without specific, written prior permission. LUCENT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL LUCENT OR ANY OF ITS ENTITIES BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. gdtoa.h
License: The author of this software is David M. Gay. Copyright (C) 1998 by Lucent Technologies All Rights Reserved Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appear in all copies and that both the copyright notice and this permission notice and warranty disclaimer appear in supporting documentation, and that the name of Lucent or any of its entities not be used in advertising or publicity pertaining to distribution of the software without specific, written prior permission. LUCENT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL LUCENT OR ANY OF ITS ENTITIES BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
SOFTWARE. strtord.c License: The author of this software is David M. Gay. Copyright (C) 1998, 2000 by Lucent Technologies All Rights Reserved Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appear in all copies and that both that the copyright notice and this permission notice and warranty disclaimer appear in supporting documentation, and that the name of Lucent or any of its entities not be used in advertising or publicity pertaining to distribution of the software without specific, written prior permission. LUCENT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL LUCENT OR ANY OF ITS ENTITIES BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

sum.c License: The author of this software is David M. Gay. Copyright (C) 1998 by Lucent Technologies All Rights Reserved Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appear in all copies and that both that the copyright notice and this permission notice and warranty disclaimer appear in supporting documentation, and that the name of Lucent or any of its entities not be used in advertising or publicity pertaining to distribution of the software without specific, written prior permission. LUCENT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL LUCENT OR ANY OF ITS ENTITIES BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

ulp.c License: The author of this software is David M. Gay. Copyright (C) 1998, 1999 by Lucent Technologies All Rights Reserved Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appear in all copies and that both that the copyright notice and this permission notice and warranty disclaimer appear in supporting documentation, and that the name of Lucent or any of its entities not be used in advertising or publicity pertaining to distribution of the software without specific, written prior permission. LUCENT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL LUCENT OR ANY OF ITS ENTITIES BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

Progress OpenEdge v11.4 may incorporate DOM4J v1.6.1 from MetaStuff, Ltd. Such technology is subject to the following terms and conditions: Copyright 2001-2005 (C) MetaStuff, Ltd. All Rights Reserved. Redistribution and use of this software and associated documentation ("Software"), with or without modification, are permitted provided that the following conditions are met: 1. Redistributions of source code must retain copyright statements and notices. Redistributions must also contain a copy of this document. 2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. 3. The name "DOM4J" must not be used to endorse or promote products derived from this Software without prior written permission of MetaStuff, Ltd. For written permission, please contact
dom4j-info@metastuff.com. 4. Products derived from this Software may not be called "DOM4J" nor may "DOM4J" appear in their names without prior written permission of MetaStuff, Ltd. DOM4J is a registered trademark of MetaStuff, Ltd. 5. Due credit should be given to the DOM4J Project - http://www.dom4j.org THIS SOFTWARE IS PROVIDED BY METASTUFF, LTD. AND CONTRIBUTORS ``AS IS'' AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL METASTUFF, LTD. OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Progress OpenEdge v11.4 may incorporate GraphicsMagick v1.3.14 from GraphicsMagick Group. Such technology is subject to the following terms and conditions:

.. This text is in reStucturedText format, so it may look a bit odd... See http://docutils.sourceforge.net/rst.html for details.

======================================
GraphicsMagick Copyrights and Licenses
======================================

This file is part of the GraphicsMagick software distributed by the GraphicsMagick Group.

["Please note that the legal community considers 15 or more total lines of code or text (not necessarily contiguous) to

be significant for the purposes of copyright. Repeated changes such as renaming a symbol has similar significance

to changing one line of code.*]

The licenses which components of this software fall under are as follows.

1) In November 2002, the GraphicsMagick Group created GraphicsMagick from ImageMagick Studio's ImageMagick and applied the "MIT" style license: Copyright (C) 2002 - 2012 GraphicsMagick Group

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions: The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software. THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

2) In October 1999, ImageMagick Studio assumed the responsibility for the development of ImageMagick (forking from the distribution by E. I. du Pont de Nemours and Company) and applied a new license:

Copyright (C) 2002 ImageMagick Studio, a non-profit organization dedicated to making software imaging solutions freely available.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files ("ImageMagick"), to deal in ImageMagick without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of ImageMagick, and to permit persons to whom the ImageMagick is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of ImageMagick.

The software is provided "as is", without warranty of any kind, express or implied, including but not limited to the warranties of merchantability, fitness for a particular purpose and noninfringement. In no event shall ImageMagick Studio be liable for any claim, damages or other liability, whether in an action of contract, tort or otherwise, arising from, out of or in connection with ImageMagick or the use or other dealings in ImageMagick.

Except as contained in this notice, the name of the ImageMagick Studio shall not be used in advertising or otherwise to promote the sale, use or other dealings in ImageMagick without prior written authorization from the ImageMagick Studio.

3) From 1991 to October 1999 (through ImageMagick 4.2.9), ImageMagick was developed and distributed by E. I. du Pont de Nemours and Company: Copyright 1999 E. I. du Pont de Nemours and Company

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files ("ImageMagick"), to deal in ImageMagick without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of ImageMagick, and to permit persons to whom the ImageMagick is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of ImageMagick.

The software is provided "as is", without warranty of any kind, express or implied, including but not limited to the warranties of merchantability, fitness for a particular purpose and noninfringement.

In no event shall E. I. du Pont de Nemours and Company be liable for any claim, damages or other liability, whether in an action of contract, tort or otherwise, arising from, out of or in connection with ImageMagick or the use or other dealings in ImageMagick.

Except as contained in this notice, the name of the E. I. du Pont de Nemours and Company shall not be used in advertising or otherwise to promote the sale, use or other dealings in
ImageMagick without prior written authorization from the E. I. du Pont de Nemours and Company.

4) The GraphicsMagick Base64Decode() and Base64Encode() functions are based on source code obtained from OpenSSH. This source code is distributed under the following license: Copyright (c) 2000 Markus Friedl. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

5) Many of the pattern images in coders/logo.c are derived from XFig, which is distributed under the following license:

| FIG : Facility for Interactive Generation of figures |

| Copyright (c) 1985-1988 by Supoj Sutanthavibul |

| Parts Copyright (c) 1989-2000 by Brian V. Smith |

| Parts Copyright (c) 1991 by Paul King |

Any party obtaining a copy of these files is granted, free of charge, a full and unrestricted irrevocable, world-wide, paid up, royalty-free, nonexclusive right and license to deal in this software and documentation files (the "Software"), including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons who receive copies from any such party to do so, with the only requirement being that this copyright notice remain intact.

6) The documentation for the composition operators is copied from the rlecomp manual page, which is authored by Rod Bogart and John W. Peterson. Rlecomp is part of the Utah Raster Toolkit distributed by the University of Michigan and the University of Utah. The copyright for this manual page is as follows: Copyright (c) 1986, University of Utah

This software is copyrighted as noted below. It may be freely copied, modified, and redistributed, provided that the copyright notice is preserved on all copies.
There is no warranty or other guarantee of fitness for this software, it is provided solely "as is". Bug reports or fixes may be sent to the author, who may or may not act on them as he desires.

You may not include this software in a program or other software product without supplying the source, or without informing the end-user that the source is available for no extra charge.

If you modify this software, you should include a notice giving the name of the person performing the modification, the date of modification, and the reason for such modification.

7) The source code comprising swab.c is originally derived from libtiff which has the following license:

| Copyright (c) 1988-1997 Sam Leffler
| Copyright (c) 1991-1997 Silicon Graphics, Inc.

Permission to use, copy, modify, distribute, and sell this software and its documentation for any purpose is hereby granted without fee, provided that (i) the above copyright notices and this permission notice appear in all copies of the software and related documentation, and (ii) the names of Sam Leffler and Silicon Graphics may not be used in any advertising or publicity relating to the software without the specific, prior written permission of Sam Leffler and Silicon Graphics.

THE SOFTWARE IS PROVIDED "AS-IS" AND WITHOUT WARRANTY OF ANY KIND, EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY THEORY OF LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

8) The C++ API known as "Magick++", and which resides in the Magick++ directory, is distributed under the following license: Copyright 1999 - 2003 Bob Friesenhahn <bfriesen@simple.dallas.tx.us>

Permission is hereby granted, free of charge, to any person obtaining a copy of the source files and associated documentation files ("Magick++"), to deal in Magick++ without restriction, including without limitation of the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of Magick++, and to permit persons to whom the Magick++ is furnished to do so, subject to the following conditions:

This copyright notice shall be included in all copies or substantial portions of Magick++. The copyright to Magick++ is retained by its author and shall not be subsumed or replaced by any other copyright.

The software is provided "as is", without warranty of any kind, express or implied, including but not limited to the warranties of merchantability, fitness for a particular purpose and noninfringement. In no event shall Bob Friesenhahn be liable for any claim, damages or other liability, whether in an action of contract, tort or otherwise, arising from, out of or in connection with Magick++ or the use or other dealings in Magick++.

9) The GraphicsMagick HaldClutImagePixels() function in magick/hclut.c is based on source code from the HaldCLUT package by Eskil Steenberg
(http://www.quelsolaar.com/technology/clut.html) which is distributed under the following license: Copyright (c) 2005 Eskil Steenberg. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR \"AS IS\" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

10) GraphicsMagick makes use of third-party "delegate" libraries to support certain optional features. These libraries bear their own copyrights and licenses, which may be more or less restrictive than the GraphicsMagick license. For convenience, when GraphicsMagick is bundled with (or compiled with) "delegate" libraries, a copy of the licenses for these libraries is provided in a "licenses" directory.

... |copy|   unicode:: U+000A9 .. COPYRIGHT SIGN

Copyright |copy| GraphicsMagick Group 2002 - 2011

OVERVIEW and LEGAL ISSUES from jpeg.txt file (from GraphicsMagick):

The Independent JPEG Group's JPEG software

README for release 6b of 27-Mar-1998

This distribution contains the sixth public release of the Independent JPEG Group's free JPEG software. You are welcome to redistribute this software and to use it for any purpose, subject to the conditions under LEGAL ISSUES, below.

Serious users of this software (particularly those incorporating it into larger programs) should contact IJG at jpeg-info@uunet.uu.net to be added to our electronic mailing list. Mailing list members are notified of updates and have a chance to participate in technical discussions, etc.
This software is the work of Tom Lane, Philip Gladstone, Jim Boucher, Lee Crocker, Julian Minguillon, Luis Ortiz, George Phillips, Davide Rossi, Guido Vollbeding, Ge' Weijers, and other members of the Independent JPEG Group. IJG is not affiliated with the official ISO JPEG standards committee.

OVERVIEW

This package contains C software to implement JPEG image compression and decompression. JPEG (pronounced "jay-peg") is a standardized compression method for full-color and gray-scale images. JPEG is intended for compressing "real-world" scenes; line drawings, cartoons and other non-realistic images are not its strong suit. JPEG is lossy, meaning that the output image is not exactly identical to the input image. Hence you must not use JPEG if you have to have identical output bits. However, on typical photographic images, very good compression levels can be obtained with no visible change, and remarkably high compression levels are possible if you can tolerate a low-quality image. For more details, see the references, or just experiment with various compression settings. This software implements JPEG baseline, extended-sequential, and progressive compression processes. Provision is made for supporting all variants of these processes, although some uncommon parameter settings aren't implemented yet.

For legal reasons, we are not distributing code for the arithmetic-coding variants of JPEG; see LEGAL ISSUES. We have made no provision for supporting the hierarchical or lossless processes defined in the standard.

We provide a set of library routines for reading and writing JPEG image files, plus two sample applications "cjpeg" and "djpeg", which use the library to perform conversion between JPEG and some other popular image file formats. The library is intended to be reused in other applications.

In order to support file conversion and viewing software, we have included considerable functionality beyond the bare JPEG coding/decoding capability; for example, the color quantization modules are not strictly part of JPEG decoding, but they are essential for output to colormapped file formats or colormapped displays. These extra functions can be compiled out of the library if not required for a particular application. We have also included "jpegtran", a utility for lossless transcoding between different JPEG processes, and "rdjpgcom" and "wrjpgcom", two simple applications for inserting and extracting textual comments in JFIF files.

The emphasis in designing this software has been on achieving portability and flexibility, while also making it fast enough to be useful. In particular, the software is not intended to be read as a tutorial on JPEG. (See the REFERENCES section for introductory material.) Rather, it is intended to be reliable, portable, industrial-strength code. We do not claim to have achieved that goal in every aspect of the software, but we strive for it.

We welcome the use of this software as a component of commercial products.

No royalty is required, but we do ask for an acknowledgement in product documentation, as described under LEGAL ISSUES.

LEGAL ISSUES
In plain English:

1. We don't promise that this software works. (But if you find any bugs, please let us know!)
2. You can use this software for whatever you want. You don't have to pay us.
3. You may not pretend that you wrote this software. If you use it in a program, you must acknowledge somewhere in your documentation that you've used the IJG code.

In legalese:

The authors make NO WARRANTY or representation, either express or implied, with respect to this software, its quality, accuracy, merchantability, or fitness for a particular purpose. This software is provided "AS IS", and you, its user, assume the entire risk as to its quality and accuracy.

This software is copyright (C) 1991-1998, Thomas G. Lane.

All Rights Reserved except as specified below.

Permission is hereby granted to use, copy, modify, and distribute this software (or portions thereof) for any purpose, without fee, subject to these conditions:

(1) If any part of the source code for this software is distributed, then this README file must be included, with this copyright and no-warranty notice unaltered; and any additions, deletions, or changes to the original files must be clearly indicated in accompanying documentation.

(2) If only executable code is distributed, then the accompanying documentation must state that "this software is based in part on the work of the Independent JPEG Group".

(3) Permission for use of this software is granted only if the user accepts full responsibility for any undesirable consequences; the authors accept NO LIABILITY for damages of any kind.

These conditions apply to any software derived from or based on the IJG code, not just to the unmodified library. If you use our work, you ought to acknowledge us.

Permission is NOT granted for the use of any IJG author's name or company name in advertising or publicity relating to this software or products derived from it. This software may be referred to only as "the Independent JPEG Group's software".

We specifically permit and encourage the use of this software as the basis of commercial products, provided that all warranty or liability claims are assumed by the product vendor.

ansi2knr.c is included in this distribution by permission of L. Peter Deutsch, sole proprietor of its copyright holder, Aladdin Enterprises of Menlo Park, CA.

ansi2knr.c is NOT covered by the above copyright and conditions, but instead by the usual distribution terms of the Free Software Foundation; principally, that you must include source code if you redistribute it. (See the file ansi2knr.c for full details.) However, since ansi2knr.c is not needed as part of any program generated from the IJG code, this does not limit you more than the foregoing paragraphs do.

The Unix configuration script "configure" was produced with GNU Autoconf.

It is copyright by the Free Software Foundation but is freely distributable.
The same holds for its supporting scripts (config.guess, config.sub, ltconfig, ltmain.sh).
Another support script, install-sh, is copyright by M.I.T. but is also freely distributable.

It appears that the arithmetic coding option of the JPEG spec is covered by patents owned by IBM, AT&T, and Mitsubishi. Hence arithmetic coding cannot legally be used without obtaining one or more licenses. For this reason, support for arithmetic coding has been removed from the free JPEG software. (Since arithmetic coding provides only a marginal gain over the unpatented Huffman mode, it is unlikely that very many implementations will support it.)

So far as we are aware, there are no patent restrictions on the remaining code.

The IJG distribution formerly included code to read and write GIF files.

To avoid entanglement with the Unisys LZW patent, GIF reading support has been removed altogether, and the GIF writer has been simplified to produce "uncompressed GIFs". This technique does not use the LZW algorithm; the resulting GIF files are larger than usual, but are readable by all standard GIF decoders.

We are required to state that "The Graphics Interchange Format(c) is the Copyright property of CompuServe Incorporated. GIF(sm) is a Service Mark property of CompuServe Incorporated."

Contents of png.txt file (from GraphicsMagick):

This copy of the libpng notices is provided for your convenience. In case of any discrepancy between this copy and the notices in the file png.h that is included in the libpng distribution, the latter shall prevail.

COPYRIGHT NOTICE, DISCLAIMER, and LICENSE:

If you modify libpng you may insert additional notices immediately following this sentence.

libpng versions 1.0.7, July 1, 2000, through 1.2.0, September 1, 2001, are Copyright (c) 2000 Glenn Randers-Pehrson and are distributed according to the same disclaimer and license as libpng-1.0.6 with the following individuals added to the list of Contributing Authors

Simon-Pierre Cadieux
Eric S. Raymond
Gilles Vollant

and with the following additions to the disclaimer:

There is no warranty against interference with your enjoyment of the library or against infringement. There is no warranty that our efforts or the library will fulfill any of your particular purposes or needs. This library is provided with all faults, and the entire risk of satisfactory quality, performance, accuracy, and effort is with the user.

libpng versions 0.97, January 1998, through 1.0.6, March 20, 2000, are Copyright (c) 1998, 1999 Glenn Randers-Pehrson, and are distributed according to the same disclaimer and license as libpng-0.96, with the following individuals added to the list of Contributing Authors:

Tom Lane
Glenn Randers-Pehrson
Willem van Schaik
libpng versions 0.89, June 1996, through 0.96, May 1997, are Copyright (c) 1996, 1997 Andreas Dilger

Distributed according to the same disclaimer and license as libpng-0.88, with the following individuals added to the list of Contributing Authors:

John Bowler
Kevin Bracey
Sam Bushell
Magnus Holmgren
Greg Roelofs
Tom Tanner

libpng versions 0.5, May 1995, through 0.88, January 1996, are Copyright (c) 1995, 1996 Guy Eric Schalnat, Group 42, Inc. For the purposes of this copyright and license, "Contributing Authors" is defined as the following set of individuals:

Andreas Dilger
Dave Martindale
Guy Eric Schalnat
Paul Schmidt
Tim Wegner

The PNG Reference Library is supplied "AS IS". The Contributing Authors and Group 42, Inc. disclaim all warranties, expressed or implied, including, without limitation, the warranties of merchantability and of fitness for any purpose. The Contributing Authors and Group 42, Inc. assume no liability for direct, indirect, incidental, special, exemplary, or consequential damages, which may result from the use of the PNG Reference Library, even if advised of the possibility of such damage. Permission is hereby granted to use, copy, modify, and distribute this source code, or portions hereof, for any purpose, without fee, subject to the following restrictions:

1. The origin of this source code must not be misrepresented.

2. Altered versions must be plainly marked as such and must not be misrepresented as being the original source.

3. This Copyright notice may not be removed or altered from any source or altered source distribution.

The Contributing Authors and Group 42, Inc. specifically permit, without fee, and encourage the use of this source code as a component to supporting the PNG file format in commercial products. If you use this source code in a product, acknowledgment is not required but would be appreciated.

A "png_get_copyright" function is available, for convenient use in "about" boxes and the like:

```c
printf("%s", png_get_copyright(NULL));
```
Also, the PNG logo (in PNG format, of course) is supplied in the files "pngbar.png" and "pngbar.jpg" (88x31) and "pngnow.png" (98x31).

Libpng is OSI Certified Open Source Software. OSI Certified Open Source is a certification mark of the Open Source Initiative.

Glenn Randers-Pehrson
randeg@alum.rpi.edu

September 1, 2001

Contents of tiff.txt file (from GraphicsMagick):

Copyright (c) 1988-1997 Sam Leffler

Copyright (c) 1991-1997 Silicon Graphics, Inc.

Permission to use, copy, modify, distribute, and sell this software and its documentation for any purpose is hereby granted without fee, provided that (i) the above copyright notices and this permission notice appear in all copies of the software and related documentation, and (ii) the names of Sam Leffler and Silicon Graphics may not be used in any advertising or publicity relating to the software without the specific, prior written permission of Sam Leffler and Silicon Graphics. THE SOFTWARE IS PROVIDED "AS-IS" AND WITHOUT WARRANTY OF ANY KIND,

EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY THEORY OF LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

Contents of zlib.txt file (from GraphicsMagick):

zlib 1.1.3 is a general purpose data compression library. All the code is thread safe. The data format used by the zlib library is described by RFCs (Request for Comments) 1950 to 1952 in the files ftp://ds.internic.net/rfc/rfc1950.txt (zlib format), rfc1951.txt (deflate format) and rfc1952.txt (gzip format). These documents are also available in other formats from ftp://ftp.uu.net/graphics/png/documents/zlib/zdoc-index.html

All functions of the compression library are documented in the file zlib.h (volunteer to write man pages welcome, contact jloup@gzip.org). A usage example of the library is given in the file example.c which also tests that the library is working correctly. Another example is given in the file minigzip.c. The compression library itself is composed of all source files except example.c and minigzip.c.

To compile all files and run the test program, follow the instructions given at the top of Makefile. In short "make test; make install" should work for most machines. For Unix: "configure; make test; make install"

For MSDOS, use one of the special makefiles such as Makefile.msc.

For VMS, use Make_vms.com or descrip.mms.
Questions about zlib should be sent to <zlib@quest.jpl.nasa.gov>, or to Gilles Vollant <info@winimage.com> for the Windows DLL version.

The zlib home page is http://www.cdrom.com/pub/infozip/zlib/

The official zlib ftp site is ftp://ftp.cdrom.com/pub/infozip/zlib/

Before reporting a problem, please check those sites to verify that you have the latest version of zlib; otherwise get the latest version and check whether the problem still exists or not.

Mark Nelson <markn@tiny.com> wrote an article about zlib for the Jan. 1997 issue of Dr. Dobb's Journal; a copy of the article is available in http://web2.airmail.net/markn/articles/zlibtool/zlibtool.htm

The changes made in version 1.1.3 are documented in the file ChangeLog.

The main changes since 1.1.2 are:

- fix "an inflate input buffer bug that shows up on rare but persistent occasions" (Mark)
- fix gzread and gztell for concatenated .gz files (Didier Le Botlan)
- fix gzseek(..., SEEK_SET) in write mode
- fix crc check after a gzeek (Frank Faubert)
- fix miniunzip when the last entry in a zip file is itself a zip file (J Lillge)
- add contrib/asm586 and contrib/asm686 (Brian Raiter)
  See http://www.muppetlabs.com/~breadbox/software/assembly.html
- add support for Delphi 3 in contrib/delphi (Bob Dellaca)
- add support for C++Builder 3 and Delphi 3 in contrib/delphi2 (Davide Moretti)
- do not exit prematurely in untgz if 0 at start of block (Magnus Holmgren)
- use macro EXTERN instead of extern to support DLL for BeOS (Sander Stoks)
- added a FAQ file

plus many changes for portability.

Unsupported third party contributions are provided in directory "contrib". A Java implementation of zlib is available in the Java Development Kit 1.1 http://www.javasoft.com/products/JDK/1.1/docs/api/Package-java.util.zip.html

See the zlib home page http://www.cdrom.com/pub/infozip/zlib/ for details.

A Perl interface to zlib written by Paul Marquess <pmarquess@bfsec.bt.co.uk> is in the CPAN (Comprehensive Perl Archive Network) sites, such as:
A Python interface to zlib written by A.M. Kuchling <amk@magnet.com> is available in Python 1.5 and later versions, see http://www.python.org/doc/lib/module-zlib.html

A zlib binding for TCL written by Andreas Kupries <a.kupries@westend.com> is available at http://www.westend.com/~kupries/doc/trf/man/man.html

An experimental package to read and write files in .zip format, written on top of zlib by Gilles Vollant <info@winimage.com>, is available at http://www.winimage.com/zLibDll/unzip.html and also in the contrib/minizip directory of zlib.

Notes for some targets:

- To build a Windows DLL version, include in a DLL project zlib.def, zlib.rc and all .c files except example.c and minigzip.c; compile with -DZLIB_DLL

  The zlib DLL support was initially done by Alessandro Iacopetti and is now maintained by Gilles Vollant <info@winimage.com>. Check the zlib DLL home page at http://www.winimage.com/zLibDll

  From Visual Basic, you can call the DLL functions which do not take a structure as argument: compress, uncompress and all gz* functions.

  See contrib/visual-basic.txt for more information, or get http://www.tcfb.com/dowseware/cmp-z-it.zip

  - For 64-bit Irix, deflate.c must be compiled without any optimization. With -O, one libpng test fails. The test works in 32 bit mode (with the -n32 compiler flag). The compiler bug has been reported to SGI.

  - zlib doesn't work with gcc 2.6.3 on a DEC 3000/300LX under OSF/1 2.1 it works when compiled with cc.

  - on Digital Unix 4.0D (formely OSF/1) on AlphaServer, the cc option -std1 is necessary to get gzprintf working correctly. This is done by configure.

  - zlib doesn't work on HP-UX 9.05 with some versions of /bin/cc. It works with other compilers. Use "make test" to check your compiler.

  - gzdopen is not supported on RISCOS, BEOS and by some Mac compilers.

  - For Turbo C the small model is supported only with reduced performance to avoid any far allocation; it was tested with -DMAX_WBITS=11 -DMAX_MEM_LEVEL=3

  - For PalmOs, see http://www.cs.uit.no/~perm/PASTA/pilot/software.html Per Harald Myrvang <perm@stud.cs.uit.no>

Acknowledgments:

The deflate format used by zlib was defined by Phil Katz. The deflate and zlib specifications were written by L. Peter Deutsch. Thanks to all the people who reported problems and suggested various improvements in zlib; they are too numerous to cite here.

Copyright notice:

(C) 1995-1998 Jean-loup Gailly and Mark Adler
This software is provided 'as-is', without any express or implied warranty. In no event will the authors be held liable for any damages arising from the use of this software.

Permission is granted to anyone to use this software for any purpose, including commercial applications, and to alter it and redistribute it freely, subject to the following restrictions:

1. The origin of this software must not be misrepresented; you must not claim that you wrote the original software. If you use this software in a product, an acknowledgment in the product documentation would be appreciated but is not required.

2. Altered source versions must be plainly marked as such, and must not be misrepresented as being the original software.

3. This notice may not be removed or altered from any source distribution.

Jean-loup Gailly       Mark Adler
jloup@gzip.org          madler@alumni.caltech.edu

If you use the zlib library in a product, we would appreciate not receiving lengthy legal documents to sign. The sources are provided for free but without warranty of any kind. The library has been entirely written by Jean-loup Gailly and Mark Adler; it does not include third-party code.

If you redistribute modified sources, we would appreciate that you include in the file ChangeLog history information documenting your changes.

Progress OpenEdge v11.4 may incorporate International Classes for Unicode (International Components for Unicode) v2.4 from IBM. Such technology is subject to the following terms and conditions:  ICU License - The ICU project is licensed under the X License (see also the x.org original), which is compatible with GPL but non-copyleft. The license allows ICU to be incorporated into a wide variety of software projects using the GPL license. The X license is compatible with the GPL, while also allowing ICU to be incorporated into non-open source products.  License ICU License - ICU 1.8.1 and later COPYRIGHT AND PERMISSION NOTICE Copyright (c) 1995-2003 International Business Machines Corporation and others All rights reserved. Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, provided that the above copyright notice(s) and this permission notice appear in all copies of the Software and that both the above copyright notice(s) and this permission notice appear in supporting documentation. THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR HOLDERS INCLUDED IN THIS NOTICE BE LIABLE FOR ANY CLAIM, OR ANY SPECIAL INDIRECT OR CONSEQUENTIAL DAMAGES, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. Except as contained in this notice, the name of a copyright holder shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization of the copyright holder.
All trademarks and registered trademarks mentioned herein are the property of their respective owners.

Progress OpenEdge v11.4 may incorporate International Components for Unicode v4.8.0. Such technology is subject to the following terms and conditions: ICU License - ICU 1.8.1 and later COPYRIGHT AND PERMISSION NOTICE Copyright (c) 1995-2011 International Business Machines Corporation and others All rights reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, provided that the above copyright notice(s) and this permission notice appear in all copies of the Software and that both the above copyright notice(s) and this permission notice appear in supporting documentation.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR HOLDERS INCLUDED IN THIS NOTICE BE LIABLE FOR ANY CLAIM, OR ANY SPECIAL INDIRECT OR CONSEQUENTIAL DAMAGES, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

Except as contained in this notice, the name of a copyright holder shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization of the copyright holder.

All trademarks and registered trademarks mentioned herein are the property of their respective owners.

Progress OpenEdge v11.4 may incorporate java.net args4j v2.0.12 from Kohsuke Kawaguchi. Such technology is subject to the following terms and conditions: Copyright (c) 2003, Kohsuke Kawaguchi All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

* Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
* Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Progress OpenEdge v11.4 may incorporate Jaxen v1.1-beta-3 from jaxen.org. Such technology is subject to the following terms and conditions: Project License $Id: LICENSE.txt 1128 2006-02-05 21:49:04Z elharo $ Copyright 2003-2006 The Werken Company. All Rights Reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. Neither the name of the Jaxen Project nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Progress OpenEdge v11.4 may incorporate Jing 20030619 as part of 1PDT (Progress Extensions for Eclipse) v2.4.0. Such technology is subject to the following terms and conditions: Jing Copying Conditions. Copyright (c) 2001-2003 Thai Open Source Software Center Ltd. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. Neither the name of the Thai Open Source Software Center Ltd nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. Third-party JARs - This distribution includes some additional JAR files, which have their own copying conditions:
saxon.jar Comes from the Saxon 6.5.2 distribution and is covered by these conditions
xercesImpl.jar xml-apis.jar Come from the Xerces-J 2.4.0 distribution and are covered by the
Apache Software License isorelax.jar Comes from ISO RELAX 2003/01/08 distribution and is
covered by the following license: Copyright (c) 2001-2002, SourceForge ISO-RELAX Project
(ASAMI Tomoharu, Daisuke Okajima, Kohsuke Kawaguchi, and MURATA Makoto)
Permission is hereby granted, free of charge, to any person obtaining a copy of this software and
associated documentation files (the "Software"), to deal in the Software without restriction,
including without limitation the rights to use, copy, modify, merge, publish, distribute,
sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is
furnished to do so, subject to the following conditions: The above copyright notice and this
permission notice shall be included in all copies or substantial portions of the Software. THE
SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
DEALINGS IN THE SOFTWARE.

Progress OpenEdge v11.4 may incorporate Sun's Jmaki framework v1.0 and Sun's Jmaki
framework v1.0.3 from Sun Microsystems, Inc. Such technology is subject to the following
terms and conditions: Copyright 1994-2006 Sun Microsystems, Inc. All Rights Reserved.
Redistribution and use in source and binary forms, with or without modification, are permitted
provided that the following conditions are met: Redistribution of source code must retain the
above copyright notice, this list of conditions and the following disclaimer. Redistribution in
binary form must reproduce the above copyright notice, this list of conditions and the following
disclaimer in the documentation and/or other materials provided with the distribution. Neither
the name of Sun Microsystems, Inc. or the names of contributors may be used to endorse or
promote products derived from this software without specific prior written permission. This
software is provided "AS IS," without a warranty of any kind. ALL EXPRESS OR IMPLIED
CONDITIONS, REPRESENTATIONS AND WARRANTIES, INCLUDING ANY IMPLIED
WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR
NON-INFRINGEMENT, ARE HEREBY EXCLUDED. SUN MICROSYSTEMS, INC.
("SUN") AND ITS LICENSORS SHALL NOT BE LIABLE FOR ANY DAMAGES
SUFFERED BY LICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING
THIS SOFTWARE OR ITS DERIVATIVES. IN NO EVENT WILL SUN OR ITS
LICENSORS BE LIABLE FOR ANY LOST REVENUE, PROFIT OR DATA, OR FOR
DIRECT, INDIRECT, SPECIAL, CONSEQUENTIAL, INCIDENTAL OR PUNITIVE
DAMAGES, HOWEVER CAUSED AND REGARDLESS OF THE THEORY OF
LIABILITY, ARISING OUT OF THE USE OF OR INABILITY TO USE THIS SOFTWARE,
EVEN IF SUN HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. You
acknowledge that this software is not designed, licensed or intended for use in the design,
construction, operation or maintenance of any nuclear facility.

Progress OpenEdge v11.4 may incorporate Jmaki framework v1.8.0 from Sun Microsystems,
Inc. Such technology is subject to the following terms and conditions: Copyright 1994-2006
Sun Microsystems, Inc. All Rights Reserved. Redistribution and use in source and binary forms,
with or without modification, are permitted provided that the following conditions are met: *
Redistribution of source code must retain the above copyright notice, this list of conditions and
the following disclaimer. * Redistribution in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in the documentation and/or other
materials provided with the distribution. Neither the name of Sun Microsystems, Inc. or the
names of contributors may be used to endorse or promote products derived from this software without specific prior written permission. This software is provided "AS IS," without a warranty of any kind. ALL EXPRESS OR IMPLIED CONDITIONS, REPRESENTATIONS AND WARRANTIES, INCLUDING ANY IMPLIED WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR NON-INFRINGEMENT, ARE HEREBY EXCLUDED. SUN MICROSYSTEMS, INC. ("SUN") AND ITS LICENSORS SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY LICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES. IN NO EVENT WILL SUN OR ITS LICENSORS BE LIABLE FOR ANY LOST REVENUE, PROFIT OR DATA, OR FOR DIRECT, INDIRECT, SPECIAL, CONSEQUENTIAL, INCIDENTAL OR PUNITIVE DAMAGES, HOWEVER CAUSED AND REGARDLESS OF THE THEORY OF LIABILITY, ARISING OUT OF THE USE OF OR INABILITY TO USE THIS SOFTWARE, EVEN IF SUN HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. You acknowledge that this software is not designed, licensed or intended for use in the design, construction, operation or maintenance of any nuclear facility.

Progress OpenEdge v11.4 may incorporate JSTL v1.0 from Sun Microsystems, Inc. Such technologies are subject to the following terms and conditions: Code sample License Copyright 1994-2006 Sun Microsystems, Inc. All Rights Reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: Redistribution of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistribution in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. Neither the name of Sun Microsystems, Inc. or the names of contributors may be used to endorse or promote products derived from this software without specific prior written permission. This software is provided "AS IS," without a warranty of any kind. ALL EXPRESS OR IMPLIED CONDITIONS, REPRESENTATIONS AND WARRANTIES, INCLUDING ANY IMPLIED WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR NON-INFRINGEMENT, ARE HEREBY EXCLUDED. SUN MICROSYSTEMS, INC. ("SUN") AND ITS LICENSORS SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY LICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES. IN NO EVENT WILL SUN OR ITS LICENSORS BE LIABLE FOR ANY LOST REVENUE, PROFIT OR DATA, OR FOR DIRECT, INDIRECT, SPECIAL, CONSEQUENTIAL, INCIDENTAL OR PUNITIVE DAMAGES, HOWEVER CAUSED AND REGARDLESS OF THE THEORY OF LIABILITY, ARISING OUT OF THE USE OF OR INABILITY TO USE THIS SOFTWARE, EVEN IF SUN HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. You acknowledge that this software is not designed, licensed or intended for use in the design, construction, operation or maintenance of any nuclear facility.

Progress OpenEdge v11.4 may incorporate Looks v2.1.2 from JGoodies. Such technology is subject to the following terms and conditions: The BSD License for the JGoodies Looks - Copyright (c) 2001-2007 JGoodies Karsten Lentzsch. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. Neither the name of JGoodies Karsten Lentzsch nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Progress OpenEdge v11.4 may incorporate OpenSSL v0.9.8 from The OpenSSL Project. Such technology is subject to the following terms and conditions: OpenSSL License. Copyright (c) 1998-2006 The OpenSSL Project. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: 1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. 2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. 3. All advertising materials mentioning features or use of this software must display the following acknowledgment: "This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit. (http://www.openssl.org/)." 4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to endorse or promote products derived from this software without prior written permission. For written permission, please contact openssl-core@openssl.org. 5. Products derived from this software may not be called "OpenSSL" nor may "OpenSSL" appear in their names without prior written permission of the OpenSSL Project. 6. Redistributions of any form whatsoever must retain the following acknowledgment: "This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/)." THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT AS IS AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OpenSSL PROJECT OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. OpenSSL includes cryptographic software written by Eric Young (eay@cryptsoft.com). This product includes software written by Tim Hudson (tjh@cryptsoft.com). Original SSLer License. Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com) All rights reserved. This package is an SSL implementation written by Eric Young eay@cryptsoft.com). The implementation was written so as to conform with Netscapes SSL. This library is free for commercial and non-commercial use as long as the following conditions are aheared to. The following conditions apply to all code found in this distribution, be it the RC4, RSA, lhash, DES, etc., code; not just the SSL code. The SSL documentation included with this distribution is covered by the same copyright terms except that the holder is Tim Hudson (tjh@cryptsoft.com). Copyright remains Eric Young's, and as such any Copyright notices in the code are not to be removed. If this package is used in a product, Eric Young should be given attribution as the author of the parts of the library used. This can be in the form of a textual message at program startup or in documentation (online or textual) provided with the package. Redistribution and use in source and binary forms, with or
without modification, are permitted provided that the following conditions are met: 1. Redistributions of source code must retain the copyright notice, this list of conditions and the following disclaimer. 2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. 3. All advertising materials mentioning features or use of this software must display the following acknowledgement: "This product includes cryptographic software written by Eric Young (eay@cryptsoft.com)." The word 'cryptographic' can be left out if the routines from the library being used are not cryptographic related :-(. 4. If you include any Windows specific code (or a derivative thereof) from the apps directory (application code) you must include an acknowledgement: "This product includes software written by Tim Hudson (tjh@cryptsoft.com)." THIS SOFTWARE IS PROVIDED BY ERIC YOUNG `AS IS' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.  The licence and distribution terms for any publically available version or derivative of this code cannot be changed. i.e. this code cannot simply be copied and put under another distribution licence [including the GNU Public Licence.]

Progress OpenEdge v11.4 may incorporate Quartz Enterprise Job Scheduler v1.3.2 from James House. Such technologies are subject to the following terms and conditions: Copyright James House (c) 2001-2003 All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: 1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. 2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS `AS IS' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION). HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. This product uses and includes within its distribution, software developed by the Apache Software Foundation (http://www.apache.org/).

Progress OpenEdge v11.4 may incorporate SLF4J v1.6.2 and SLF4J Log4J v1.6.1 from QOS. Such technology is subject to the following terms and conditions: Copyright (c) 2004-2008 QOS.ch All rights reserved. Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy,
modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to
permit persons to whom the Software is furnished to do so, subject to the following conditions:
The above copyright notice and this permission notice shall be included in all copies or
substantial portions of the Software. THE SOFTWARE IS PROVIDED "AS IS", WITHOUT
WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
to the warranties of merchantability, fitness for a particular
purpose and noninfringement. IN NO EVENT SHALL THE AUTHORS OR
COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE
OR OTHER DEALINGS IN THE SOFTWARE.

Progress OpenEdge v11.4 may incorporate SLF4J v1.7.7 from QOS. Such technology is
subject to the following terms and conditions: Copyright (c) 2004-2013 QOS.ch All rights
reserved. Permission is hereby granted, free of charge, to any person obtaining a copy of this
software and associated documentation files (the "Software"), to deal in the Software without
restriction, including without limitation the rights to use, copy, modify, publish, distribute,
sublicense, and/or sell copies of the Software, and to permit persons to whom the
Software is furnished to do so, subject to the following conditions: The above copyright
notice and this permission notice shall be included in all copies or substantial portions of the
Software. THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY
KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR
PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR
COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE
OR OTHER DEALINGS IN THE SOFTWARE.

Progress OpenEdge v11.4 may incorporate STAX API (JSR 173) v3.1.1 from Woodstox
Project. Such technology is subject to the following terms and conditions: Copyright (c)
2004-2010, Woodstox Project (http://woodstox.codehaus.org/) All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted
provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions
and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials provided
with the distribution.

3. Neither the name of the Woodstox XML Processor nor the names of its contributors may be
used to endorse or promote products derived from this software without specific prior written
permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS
BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.

Progress OpenEdge v11.4 may incorporate Trang 20030619 as part of 1PDT (Progress
Extensions for Eclipse) v2.4.0. Such technology is subject to the following terms and
conditions: Copyright (c) 2002, 2003 Thai Open Source Software Center Ltd. All rights
reserved. Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met: Redistributions of source code must
retain the above copyright notice, this list of conditions and the following disclaimer.
Redistributions in binary form must reproduce the above copyright notice, this list of conditions
and the following disclaimer in the documentation and/or other materials provided with the
distribution. Neither the name of the Thai Open Source Software Center Ltd nor the names of
its contributors may be used to endorse or promote products derived from this software without
specific prior written permission. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT
HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.

Progress OpenEdge v11.4 may incorporate Xpp3 v1.1.3.4 from Indiana University as part of
1PDT (Progress Extensions for Eclipse) v2.4.0. Such technology is subject to the following
terms and conditions: Indiana University Extreme! Lab Software License Version 1.1.1
Copyright (c) 2002 Extreme! Lab, Indiana University. All rights reserved. Redistribution and
use in source and binary forms, with or without modification, are permitted provided that the
following conditions are met: 1. Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer. 2. Redistributions in binary form
must reproduce the above copyright notice, this list of conditions and the following disclaimer
in the documentation and/or other materials provided with the distribution. 3. The end-user
documentation included with the redistribution, if any, must include the following
acknowledgment: "This product includes software developed by the Indiana University
Extreme! Lab (http://www.extreme.indiana.edu/)." Alternately, this acknowledgment may
appear in the software itself, if and wherever such third-party acknowledgments normally
appear. 4. The names "Indiana University" and "Indiana University Extreme! Lab" must not be
used to endorse or promote products derived from this software without prior written
permission. For written permission, please contact http://www.extreme.indiana.edu/. 5.
Products derived from this software may not use "Indiana University" name nor may "Indiana
University" appear in their name, without prior written permission of the Indiana University.
THIS SOFTWARE IS PROVIDED "AS IS" AND ANY EXPRESSED OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE AUTHORS, COPYRIGHT HOLDERS OR ITS
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Progress OpenEdge v11.4 may incorporate XStream v1.3.1 from XStream. Such technology is subject to the following terms and conditions: Copyright (c) 2003-2006, Joe Walnes Copyright (c) 2006-2007, XStream Committers All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. Neither the name of XStream nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Progress OpenEdge v11.4 may incorporate YAJL v0.4.0 from Lloyd Hilaiel. Such technology is subject to the following terms and conditions: Copyright 2007, Lloyd Hilaiel. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: 1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. 2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. 3. Neither the name of Lloyd Hilaiel nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission. THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
Progress OpenEdge v11.4 may incorporate GNU ZLIB v1.1.4 and GNU ZLIB v1.2.3 from Jean-loup Gailly & Mark Adler. Such technology is subject to the following terms and conditions: Copyright notice: (C) 1995-2002 Jean-loup Gailly and Mark Adler This software is provided 'as-is', without any express or implied warranty. In no event will the authors be held liable for any damages arising from the use of this software. Permission is granted to anyone to use this software for any purpose, including commercial applications, and to alter it and redistribute it freely, subject to the following restrictions: 1. The origin of this software must not be misrepresented; you must not claim that you wrote the original software. If you use this software in a product, an acknowledgment in the product documentation would be appreciated but is not required. 2. Altered source versions must be plainly marked as such, and must not be misrepresented as being the original software. 3. This notice may not be removed or altered from any source distribution.

Jean-loup Gailly        Mark Adler
jloup@gzip.org          madler@alumni.caltech.edu

Progress OpenEdge v11.4 may incorporate ZLIB.NET Free v1.0.4 from ComponentAce. Such technology is subject to the following terms and conditions: Copyright (c) 2006-2007, ComponentAce http://www.componentace.com All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. Neither the name of ComponentAce nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Progress OpenEdge v11.4 may incorporate LALR Parser Generator in Java v0.10k. Such technology is subject to the following terms and conditions:  CUP Parser Generator Copyright Notice, License, and Disclaimer – Copyright 1996-1999 by Scott Hudson, Frank Flannery, C. Scott Ananian - Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appear in all copies and that both the copyright notice and this permission notice and warranty disclaimer appear in supporting documentation, and that the names of the authors or their employers not be used in advertising or publicity pertaining to distribution of the software without specific, written prior permission. The authors and their employers disclaim all warranties with regard to this software, including all implied warranties of merchantability and fitness. In no event shall the authors or their employers be liable for any special, indirect or consequential damages or any damages whatsoever resulting from loss of
use, data or profits, whether in an action of contract, negligence or other tortious action, arising out of or in connection with the use or performance of this software.

Progress OpenEdge v11.4 includes the RSA Data Security, Inc. MD5 Message-Digest Algorithm. Copyright ©1991-2, RSA Data Security, Inc. Created 1991. All rights reserved. (MD5 Encryption Library v3.0 and MD5 Encryption vMD5C.C) These technologies are subject to the following terms and conditions: RSA Data Security MD5 message-digest algorithm RSA Data Security, Inc. MD5C.C - RSA Data Security, Inc., MD5 message-digest algorithm Copyright (C) 1991-2, RSA Data Security, Inc. Created 1991. All rights reserved. License to copy and use this software is granted provided that it is identified as the "RSA Data Security, Inc. MD5 Message-Digest Algorithm" in all material mentioning or referencing this software or this function. License is also granted to make and use derivative works provided that such works are identified as "derived from the RSA Data Security, Inc. MD5 Message-Digest Algorithm" in all material mentioning or referencing the derived work. RSA Data Security, Inc. makes no representations concerning either the merchantability of this software or the suitability of this software for any particular purpose. It is provided "as is" without express or implied warranty of any kind. These notices must be retained in any copies of any part of this documentation and/or software.

Progress OpenEdge v11.4 may incorporate Saxon XSLT and XQuery Processor v8.9; and Saxon XSLT and XQuery Processor v8.9.0.4 (saxon8.jar, saxon8-xpath.jar, saxon8-xom.jar, saxon8-sql.jar, saxon8-jdom.jar, saxon8-dom.jar) as part of 1PDT (Progress Extensions for Eclipse) v2.4.0. The contents of these files are subject to the Mozilla Public License Version 1.0 (the "License") provided below; you may not use this file except in compliance with the License. You may also obtain a copy of the License at http://www.mozilla.org/MPL/. Software distributed under the License is distributed on an "AS IS" basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License for the specific language governing rights and limitations under the License. PSC will, at Licensee's request, provide copies of the source code for this third party technology, including modifications, if any, made by PSC. PSC may charge reasonable shipping and handling charges for such distribution. Licensee may also obtain the source code through http://communities.progress.com/pcom/docs/DOC-16051 by following the instructions set forth therein.

For Saxon XSLT and XQuery Processor v8.9 – The Original Code of Saxon comprises all those components which are not explicitly attributed to other parties. The Initial Developer of the Original Code is Michael Kay. Until February 2001 Michael Kay was an employee of International Computers Limited (now part of Fujitsu Limited), and original code developed during that time was released under this license by permission from International Computers Limited. From February 2001 until February 2004 Michael Kay was an employee of Software AG, and code developed during that time was released under this license by permission from Software AG, acting as a "Contributor". Subsequent code has been developed by Saxonica Limited, of which Michael Kay is a Director, again acting as a "Contributor". A small number of modules, or enhancements to modules, have been developed by other individuals (either written specially for Saxon, or incorporated into Saxon having initially been released as part of another open source product). Such contributions are acknowledged individually in comments attached to the relevant code modules. All Rights Reserved. If you produce a product that includes or requires Saxon, please refer to it prominently as "The Saxon XSLT and XQuery Processor from Saxonica Limited", and include the URL of the home page, which is at http://www.saxonica.com/.

For Saxon XSLT and XQuery Processor v8.9.0.4 - The Original Code of Saxon comprises all those components which are not explicitly attributed to other parties. The Initial Developer of the Original Code is Michael Kay. Until February 2001 Michael Kay was an employee of
International Computers Limited (now part of Fujitsu Limited), and original code developed during that time was released under this license by permission from International Computers Limited. From February 2001 until February 2004 Michael Kay was an employee of Software AG, and code developed during that time was released under this license by permission from Software AG, acting as a "Contributor". Subsequent code has been developed by Saxonica Limited, of which Michael Kay is a Director, again acting as a "Contributor". A small number of modules, or enhancements to modules, have been developed by other individuals (either written specially for Saxon, or incorporated into Saxon having initially been released as part of another open source product). Such contributions are acknowledged individually in comments attached to the relevant code modules. All Rights Reserved.

Progress OpenEdge v11.4 may incorporate Mozilla Rhino v1.6R1; and Saxon v9. Such above-listed technologies are subject to the following terms and conditions: The contents of this file are subject to the Mozilla Public License Version 1.1 (the "License") provided below; you may not use this file except in compliance with the License. You may also obtain a copy of the License at http://www.mozilla.org/MPL/. Software distributed under the License is distributed on an "AS IS" basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License for the specific language governing rights and limitations under the License.

For Mozilla Rhino v1.6R1, The Original Code is Rhino code, released - May 6, 1999. - The Initial Developer of the Original Code is Netscape Communications Corporation. Portions created by Netscape are Copyright (C) 1997-1999 Netscape Communications Corporation. All Rights Reserved. Contributor(s): Norris Boyd, Igor Bukanov, Roger Lawrence, Mike McCabe.

For Saxon v9, The Original Code is: All this file. The Initial Developer of the Original Code is Michael H. Kay. Contributor(s): none.
This chapter provides a brief overview of the Visual Translator tool and the tasks you can perform with it. The chapter includes these sections:

- Tool overview
- Task overview

The following chapters provide detailed, step-by-step instructions.
Tool overview

The Visual Translator is a tool that helps you translate the text phrases in Progress® 4GL applications. The Visual Translator allows you to:

- **Translate screen by screen** — You can view the user interface for procedures, translate user-interface objects in context, and immediately see how your translations will appear on the screen.

- **Translate phrase by phrase** — You can select and translate a single text phrase from a list of text phrases.

- **Translate globally** — You can make global translations. For example, you can translate all instances of the text phrase “close” to “cerrar.” You can then view a particular instance of the global translation on the screen.

- **Have multiple translators** — You can choose to work in multi-user mode and have more than one translator working on the same project.

- **Use your own glossaries** — You can add your own glossary entries to the glossary provided by the project manager—the person who hires you to translate the procedures.

- **Save a screen capture** — You can save and print a copy of a user-interface window showing your translations in context.
The following steps outline the basic tasks you perform when you use the Visual Translator to translate text phrases from Progress 4GL procedures:

1. Install and open the kit you receive from the project manager—the person who hires you to translate the text phrases in an application.

The *kit* contains:

- A 4GL database that includes a glossary and the text phrases to translate. The glossary is a list of the pairings of words for two spoken languages—the source and target language. The *source language* is the language in which the source code was written. The *target language* is the language to which you translate the source code. You can import your own existing glossary entries into the kit’s glossary if the project manager has given you the appropriate permission.

- Resource procedures, which are shells or “mock-ups” of the original application source procedures; they do not contain any functionality. You use these shells to display the visual aspects of a procedure’s user interface so that you can see the results of your translation in context.

- An environment (.ini) file and image files that allow the Visual Translator to accurately display the user interface of the procedure.

The project manager sends you a kit for each target language. You can open several kits simultaneously.

2. Select each procedure and the text phrases for all procedures globally or phrase by phrase from a list.

3. When you have translated all the necessary text phrases, save the kit into a compressed (.zip) file and return it to the project manager.

The project manager reviews the translations and might return them to you for further modification. If the translations are complete, the project manager uses them to deploy a multi-lingual application.
Getting Started

This chapter explains how to get started with the Visual Translator tool. Specifically, it describes:

- Setting up your environment
- Starting the Visual Translator
- Using online help
- Installing and opening a kit
- Opening a kit in multi-user mode
- Returning a kit
- Importing a glossary
- Exporting a glossary
Setting up your environment

Before beginning, you need to prepare your computer to assure the process works correctly.

To set up the working environment:

1. Create a working directory for the kit on your hard drive.

2. Copy the kit (.db or .zip file) you received from the project manager to the directory you created for the kit.

3. Change the working directory of the OpenEdge icon to the directory you created for the kit. To change the properties for an icon, follow these steps:


   b. Click once to highlight the OpenEdge icon.

   c. Choose File → Properties.

   d. Choose the Shortcut tab folder.

   e. In the Start in field, enter the name of the directory you created for the kit in Step 1.

   f. Choose OK.
Starting the Visual Translator

You must first install a copy of OpenEdge™ that includes the Visual Translator tool before you can start the tool. See OpenEdge Getting Started: Installation and Configuration for information on system requirements and installation.

To start the Visual Translator tool:

1. Double-click the OpenEdge icon to display the Application Development Environment desktop (ADE).

2. Choose Tools → Visual Translator. The Visual Translator window appears:

Using online help

The Visual Translator has an extensive help system that provides information about the interface and simple procedures that tell you how to use the tool to perform tasks.

All help information is organized into discrete units called help topics. A help topic typically contains information about one thing, such as a dialog box or a button in a tab folder.

You can access help information in the following ways:

- Press HELP (the F1 key, by default).
- Use the Help menu.
- Click the Help button then click a button or tab folder.

The help system is hypertext based, that is, help topics not only contain information, but they also provide access to related information. Certain words and phrases in a help topic are selectable and serve as links to related information. These special words and phrases are called hypertext links. Help displays hypertext links in color or underlined, depending on your monitor. To access the information associated with a hypertext link, click the hypertext-link word or phrase.

In addition to the help system, interface buttons display ToolTips to assist you with button selection.
Installing and opening a kit

After you start the Visual Translator, your next step is to install or open the kit that you received from the project manager. The project manager will send you a separate kit for each target language.

You install a kit if the project manager sends you the kit as a compressed (.zip) file. The project manager might compress a kit to reduce the size of the database and make it easier to send. When you install a kit, the Visual Translator decompresses it. Therefore, you have to install a kit only when you first receive it from the project manager. After you install a kit, you can close and open it until you have completed translating.

You open a kit once you have initially installed it. If the project manager did not compress the kit, you can open it without first installing it. When you open a kit, the Visual Translator connects to the kit database.

The Visual Translator saves any changes as soon as you make them. To close an uncompressed kit, choose File→Close. The Visual Translator disconnects the kit database. Choose File→Return Kit only when you want to compress the kit before you return it.

Installing a Kit

Next, you need to get the kit onto your computer.

To install a kit on your computer:

1. Choose File→Install Kit. The Install Zip File dialog box appears:

   ![Install Zip File dialog box](image)

2. In the Project Directory field, type the pathname of the working directory you created for the kit in the “Setting up your environment” section on page 2–2.

3. In the Zip Filename field, enter the name of the kit (.zip) file, then choose OK. The Visual Translator automatically installs and then opens the kit.

After you install and open a kit, you can import a glossary (see the “Importing a glossary” section on page 2–9) or you can start translating procedures right away (see Chapter 3, “Translating”).
Opening a kit in single-user mode

The simplest way to work with a kit is to open it in single-user mode.

To open a decompressed kit or a previously installed kit:

1. Choose the Open button. The Open Kit Database dialog box appears:

2. Select the directory that contains the kit.

3. Select the database (.db) file that contains the kit you want, then choose OK. The Visual Translator displays the names of the application procedure (usually .p and .w) files contained in the kit in the Procedures tab folder.

After you open a kit, you can import a glossary (see the “Importing a glossary” section on page 2–9) or you can start translating procedures (see Chapter 3, “Translating”).
Opening a kit in multi-user mode

To work in multi-user mode, you must start a database server for the kit database. It is easiest if the kit database is created on a system and not moved, but it is possible to relocate the kit by zipping it up, moving the zip file, and unzipping it.

See *OpenEdge Data Management: Database Administration* for information on starting up a database server. Use the Progress Explorer or issue the proserve command from a DOS prompt. Typically, no startup parameters are necessary except for the database name, -S (service), and -H (host), and these three are mandatory.

To connect to the kit database in multi-user mode:

1. Start Visual Translator and choose **File → Open Multi-User**. The **Open Multi-User Kit Database** dialog box appears:

2. Select the name of the kit database that has a server running. Use the **Browse** button to find the database.

3. In the **Host Name** box enter the name of the computer hosting the database.

4. In the **Service Name** box enter the port of the database server.

5. Enter the translator’s **User ID** if the kit is password protected.

6. Enter the translator’s **Password** if the kit is password protected.

7. Enter **Other CONNECT Statement Parameters** as necessary and choose **OK**.

When you have filled in the appropriate values, proceed as if in single-user mode.
Returning a kit

When your work is complete, you need to recompress the files into the .zip file.

To compress a kit after translation is complete:

2. Enter the name of the kit database with a .zip extension, then click OK. The Visual Translator compresses the kit database into a zip file.
3. Send the zip file back to the project manager. You can send it over a modem or on a diskette.

Note: The tool saves any changes as soon as you make them. Choose File→Return Kit only when you want to compress the kit.
Importing a glossary

A glossary is a list of the pairings of phrases for two spoken languages. The kit the project manager gives you includes a default glossary. The default glossary might be empty or it might contain a list of suggested pairings to use.

If you already have your own glossary, you can add its contents to the default glossary and use it in the Visual Translator. The tool tags the imported glossary entries with a C (for Custom) in the Type column of the Glossaries tab folder. When you enter your new translations, the Visual Translator adds new custom entries to the glossary.

To make sure you have permission to import a glossary, choose Options → Preferences. The Preferences dialog box displays the privileges the project manager assigned to you. If the Must Use Glossary For Translations toggle box is activated, you cannot import a glossary.

The Translator Privileges section is grayed out to show that it is disabled and you cannot change it. The project manager sets privileges with the Translation Manager tool.

The glossary data you want to import must be in a text file, with the source and target phrases separated by commas or spaces.

Table 2–1 shows examples of comma-delimited and space-delimited glossaries. In both examples the glossaries order the text phrases by source language (English).

**Table 2–1: Example imported glossaries**

<table>
<thead>
<tr>
<th>Comma-delimited</th>
<th>Space-delimited</th>
</tr>
</thead>
<tbody>
<tr>
<td>add,ajouter</td>
<td>add ajouter</td>
</tr>
<tr>
<td>application,programme</td>
<td>application programme</td>
</tr>
<tr>
<td>apply,appliquer</td>
<td>apply appliquer</td>
</tr>
<tr>
<td>blank space,espace</td>
<td>&quot;blank space&quot; &quot;espace&quot;</td>
</tr>
<tr>
<td>browse,parcourir</td>
<td>browse parcourir</td>
</tr>
<tr>
<td>cancel,annuler</td>
<td>cancel annuler</td>
</tr>
<tr>
<td>capitalize,mettre en majuscules</td>
<td>&quot;capitalize&quot; &quot;mettre en majuscules&quot;</td>
</tr>
<tr>
<td>change,modifier</td>
<td>change modifier</td>
</tr>
<tr>
<td>chart,graphique</td>
<td>chart graphique</td>
</tr>
<tr>
<td>check,cocher</td>
<td>check cocher</td>
</tr>
<tr>
<td>choose,choisir</td>
<td>choose choisir</td>
</tr>
<tr>
<td>click,cliquer</td>
<td>click cliquer</td>
</tr>
<tr>
<td>&quot;city, state&quot;,&quot;ville, department&quot;</td>
<td>&quot;city, state&quot; &quot;ville, department&quot;</td>
</tr>
</tbody>
</table>

You must use quotes in an imported glossary under the following circumstances:

- If you have a comma-delimited glossary and you want to include a comma as part of the text, you must use quotes around the text. For example, to include the comma in an address, you must use quotes:

  "street, city","calle, ciudad"

- If you have a space-delimited glossary and you want to include a phrase that has more than one word, you must use quotes around the text:

  "capitalize" "mettre en majuscules"
To import glossary entries from a file to a glossary in the project database:

1. Choose the Glossaries tab to open the Glossaries tab folder.

2. Choose File → Import. The Import dialog box appears:

   ![Import dialog box]

3. Enter the name of the text file that contains the glossary.

4. Enter the code page for the glossary entries you want to import. If you need help determining the code page, contact the project manager.

5. Choose the Options button to expand the Import dialog box as shown below:

   ![Options button expanded]

6. Specify the order in which the glossary organizes the phrases. In some glossaries, the target phrase appears before the source phrase.

7. Specify whether the glossary uses a space or a comma as a delimiter between source and target phrases, then choose OK.
Exporting a glossary

You can copy the contents of the glossary to a text file to use in another kit. When you export a glossary, the Visual Translator saves it as a space-delimited data (.d) file.

To export a glossary:

1. Choose the Glossaries tab to open the Glossaries tab folder.
2. Choose File → Export. The Save As dialog box appears:

   ![Save As dialog box](image)

   3. Specify the directory in which you want to store the file.
   4. Type the name of the file with a .d extension, then choose OK.
This chapter describes how to translate text phrases with the Visual Translator tool. It provides an overview of the translation process and step-by-step instructions for several translation techniques. The chapter includes these sections:

- Overview
- Pretranslation
- Translating screen by screen
- Translating phrase by phrase
- Translation considerations
Overview

This is the basic order of tasks for translating all the text phrases in a language kit:

1. Use the pretranslation technique to review and edit translations before you start. Pretranslation lets you perform an automatic translation that uses the defined filters before you start the manual translation process. You can also generate a report of summary information on each text phrase.

2. Use the translating screen-by-screen technique to translate the user-interface objects and text phrases in the resource procedures. Translating screen by screen lets you translate text phrases within the context of the user-interface procedure.

3. Use the translating phrase-by-phrase technique to translate text phrases not shown in the resource procedures, such as error messages. Translating phrase by phrase lets you translate any text phrases from a list of all the text phrases in a kit. Also, it lets you globally translate a source phrase to the same target phrase throughout a kit.

4. Use global translation if you want to translate a text phrase in multiple procedures simultaneously.

You can switch back and forth among the three translation techniques. For example, you can translate all instances of “OK” and “Cancel” globally in the Translations tab folder, then open a resource procedure to translate the visualized text phrases, and then go back to the Translations tab folder to translate text phrases not displayed in the resource procedure.

Chapter 4, “Tracking Your Work,” describes how to verify that you have translated all of the text phrases for the kit.
Pretranslation

Before you start the translation process, you can perform a pretranslation on the text phrases in your kit. Pretranslation is a task you can perform that matches each text phrase with the first possible glossary entry. **Visual Translator translates all text phrases at once.** This task allows you to review and edit suggested translations before you start the manual translation process. To facilitate the review process, you can generate a hard-copy pretranslation exceptions report or print the information to a text file.

You can generate a pretranslation exceptions report that provides you with the following information about each string within a procedure file:

- Untranslated source strings
- Translated strings with no glossary match
- Translated strings that have more than one possible translation

The pretranslation exceptions report also provides the following summary information, by procedure and by project:

- Total number of translation strings
- Number of new translation strings
- Number of new translation strings that have more than one possible translation
- Number of previously translated strings

To pretranslate text phrases in a kit:

1. Choose **Tools**→**TranMan Utilities**→**Pre-translation**. The **PreTranslation** dialog box appears:

2. Select one of these options for pretranslating phrases:

   - **Translate case-sensitive matches** — The Translation Manager translates only the text phrases that match a glossary entry exactly. For example, the Translation Manager will not translate “Customer Name” if the glossary entry is “customer name.” Although the text phrase is the same, the case does not match the glossary entry.
- **Use case-insensitive match if necessary** — The Translation Manager searches for an exact match with a glossary entry first. If there is no glossary entry that matches the text phrase exactly, the Translation Manager searches for a match regardless of case. You should select this button if you do not want leading and trailing blanks ignored.

- **Use case-insensitive match and trim phrase if necessary** — The Translation Manager first searches for exact matches with glossary entries, then it searches for a match regardless of case. Finally, it ignores leading and trailing blanks by trimming them from the phrase before looking for a match.

3. Activate the **Exceptions Report** toggle box if you want a hard-copy report (or to save the information to a text file).

4. Select your print options. If you select the **Output To Printer** radio-set button, you do not need to enter a filename. The default filename is `pretrans.log`. If you select the **Output to A Text File** radio-set button, you must either enter a filename or use the default filename, `pretrans.log`.

5. Choose **OK**. A pretranslation report prints:

```
Visual Translator PreTranslation Report Page 1
Project: GetStart1 02/21/97  10:32 pm  
Procedure: TMsource\b-cuslkp.w

City
Country
Current record has been changed.
Name
Search On Customer Name
State
You must complete or cancel the update before leaving t...

SUMMARY:
10 Strings Total                      100 %
0 Existing Translations                0 %
1 Strings Translated                  10 %
9 Strings Untranslated                90 %
0 Strings with Multiple Translations   0 %

Procedure:
TMsource\w-ordtrk.w
&Update Customer
3,1
Customer Order Tracking
Customer|Shipment|Order lines|Catalog

SUMMARY:
4 Strings Total                      100 %
0 Existing Translations                0 %
0 Strings Translated                  0 %
4 Strings Untranslated                100 %
0 Strings with Multiple Translations   0 %

GRAND SUMMARY:
14 Strings Total                      100 %
4 Existing Translations                8 %
1 Strings Translated                  1 %
13 Strings Untranslated                91 %
0 Strings with Multiple Translations   0 %
```
Translating screen by screen

Translating within the context of the screen allows you to choose a target phrase that most accurately corresponds to the meaning of a source phrase. For example, you could translate the English source phrase “number” into the German words, “Zahl,” “Ziffer,” “Nummer,” or “Anzahl,” depending on the context. The source word can have different meanings in different procedures. For example, in one procedure you might want to use “Ziffer” for a telephone number. In another procedure you might want to use “Nummer” for a calculated number. By translating in context, you improve the quality of your translation effort.

Opening a resource procedure

First you need to locate the resource procedure.

To open a resource procedure:

1. From the Procedures tab folder, select the name of the procedure file to translate.

   **Note:** You must select a procedure name that has a resource procedure as indicated in the Resource Procedure column. Some procedures do not have resource procedures and you must translate them phrase by phrase in the Translations tab folder.

2. Choose the View button or double-click on the procedure name to display the procedure. The Visual Translator displays a resource procedure window similar to the example shown below:

   ![Resource Procedure Window](image)

   **Note:** If the resource procedure contains more than one frame, an alert box appears stating how many frames the procedure contains. To see the other frames, choose the Next Frame button.

Automatic translation

By default, the Visual Translator displays the source phrases in the resource procedure. You can set the Visual Translator to automatically add the glossary entries as translations for those text phrases displayed in the resource procedure.
To automatically translate the source procedures in a resource procedure, using the glossary translations:

1. Choose **Options ➔ Preferences**. The **Preferences** dialog box appears:

![Preferences dialog box](image)

2. Activate the **Automatic Translations When Visualized** toggle, then click **OK**.

**Note:** For automatic translation to work, you must activate the **Automatic Translations When Visualized** box and choose **OK**. You must then open and close each resource procedure you want to automatically translate.

3. From the **Procedures** tab folder, double-click a procedure to visualize it. The resource procedure appears with target phrases displayed for all those text phrases that have glossary entries. If the glossary does not contain an entry for the text phrase, the source phrase is displayed instead.

**Note:** You can visualize the glossary suggestions without saving them as translations by deactivating the **Automatic Translations When Visualized** toggle box and choosing **OK** in the **Preferences** dialog box before you proceed to Step 4.

4. Close the procedure window to automatically save the glossary suggestions as translations.

**Note:** Automatic translation works only for those text phrases you can visualize in a resource procedure. It does not apply to all the text phrases in the kit. For example, you might have a glossary suggestion for all or part of a message statement, but you cannot automatically save the glossary suggestion as a translation because the message statement does not appear in a resource procedure. For more information on translating all of the text phrases in a kit, refer to the “Pretranslation” section on page 3–3.
Opening the Properties window

To open the Properties window, double-click on an item in the resource procedure window that you want to translate. Figure 3–1 shows the Properties dialog box.

![Properties dialog box](image)

**Figure 3–1: Properties dialog box**

For information on the menu options and tool bar buttons in this window, click the help button or see the Properties window section of Appendix A, “Visual Translator Interface Reference.”

To always display the Properties window on top of other open windows:

1. Choose Options → Preferences. The Preferences dialog box appears.
2. Activate the Display Properties Window As Always On Top toggle, then click OK.

**Caution:** The Visual Translator displays warning or error message windows in the center of the computer screen. If you specify the Properties window as always on top and you place it in the center of the screen, it will hide any error messages. To work around this behavior, drag the Properties window away from the center of the screen so you can still see important messages.

**Input Method Editors** — If you choose the option to display the Properties window as always on top, it will cover the Input Method Editor. Therefore, do not use this option if you use Input Method Editors.

Selecting an object

You can use either of the following techniques to select an object from the resource procedure window:

- **Self-guided selection** — Double-click an object in the resource procedure window. If you use self-guided selection, click the Uncover Object button to expose an object hidden under the currently selected object.

- **Tool-guided selection** — Click the Next Object button. The tool determines which object is the next object according to the order in which the objects were created. If you use tool-guided selection, you do not have to use the Uncover Object button.

The major advantage to tool-guided selection is that it ensures you translate all the user-interface objects in a procedure, including those objects that might be hidden underneath other objects.
In addition to the alert box that appears when you open a resource procedure, the **Next Frame** button is an indicator of whether there is more than one frame for the procedure. If the **Next Frame** button is grayed out, there is only one frame; if it is enabled, there are at least two frames for the procedure and you can click the **Next Frame** button to see the other frames.

**Note:** The Visual Translator treats a menu bar as a separate frame. For example, if the only objects in a resource procedure are a menu bar and a frame, the tool generates an alert box when you open the procedure stating that there are two frames.

### Entering a translation

Once you select an object, you can enter your own translation, select a suggestion from the glossary, or edit a glossary selection.

**Note:** To enter your own translation, you must have the proper permissions. Choose **Option→Preferences** to check the **Privileges** section of the **Preferences** dialog box. If you want to change the privileges, contact the project manager.

To enter your own translation:

1. In the **Properties** window, type a translation in the **Target** fill-in field. The text appears in red.

2. Choose **File→Save**. The Visual Translator changes the text in the **Target** fill-in field to black to indicate that it saved your translation. It also displays your translation in the resource procedure window. In the example shown below, the Visual Translator displays “Ville” instead of “City” in the resource procedure window:

![Example of a translation in the resource procedure window](image)

**Note:** When you type in your own translation, the Visual Translator adds it to the glossary as a custom glossary entry. However, the Translation Manager does not accept glossary entries that begin with a question mark (?).
Selecting a glossary suggestion

In the Glossary field of the Properties window, the tool displays all the glossary target phrases for a source phrase. For example, if “customer number” is the source phrase, the Visual Translator displays target phrases for “customer number,” “customer,” and “number.”

If you activate the Use Word Indexing toggle box, the Visual Translator also displays all the target phrases for those source phrases that contain the word you want to translate. For example, if “customer” is the source phrase and you activate word indexing, the Visual Translator displays target phrases for every source phrase that contains “customer,” such as “customer address” and “customer number.”

Follow these steps to use a glossary suggestion for the target phrase:

1. If you use word indexing, select a source phrase or a word from the Source selection list.
2. Select a suggestion from the Glossary field. The glossary entry appears in the Target fill-in field.
3. Edit the glossary entry in the Target fill-in field if necessary, then press OK. The target phrase appears in the Procedure window.
Translating phrase by phrase

The following types of text phrases are not included in the resource procedures. You must translate them in the Translations tab folder:

- **Dynamic widgets** — User interface components that your application creates or deletes during the execution of a procedure. These components cannot be stored in resource procedures.

- **Text phrases that are not visualized at run time** — For example, in the following code, “Amsterdam” is a text phrase in the 4GL code but it is not a user-interface element such as a label:

  `FOR EACH customer-name WHERE city = "Amsterdam"`

- **Message statements** — Messages such as errors, warnings, or helpful hints. You can view a message statement in an alert box after you translate it in the Translations tab folder.

  

  Note: In the Translations tab folder, you can also make changes to any in-context translations.

You can also use the Translations tab folder for global translation to control consistency of translation throughout the procedures in a kit. You can translate text phrases into a certain target phrase, no matter what the context. For example, in the Translations tab folder, you can globally change all instances of “open” in the English source language to “ouvrir” in the French target language.

Opening the Translations tab folder

The Translations tab folder allows you to translate a text phrase by instance.

To translate a text phrase by instance:

Follow these steps to translate a text phrase by instance:

1. Click the Translations tab to open the Translations tab folder and view the text phrases for the entire kit.

2. Choose View→Sort or click on the Sort button. The Sort dialog box appears:

   ![Sort dialog box](image)

3. Specify to sort first by target phrase in ascending order, then choose OK. The untranslated text phrases appear at the top of the Translations tab folder.
Translating phrase by phrase

4. Click in the target phrase column of a row that contains a phrase you want to translate. A box appears around the target phrase fill-in area and a cursor appears in the box, as shown below. If you cannot view the entire phrase, double-click on the phrase to open a larger window:

![Image of the fill-in area]

Opening the glossary window

The **Glossary** window allows you to view glossary suggestions while you translate in the Translations tab folder.

To open and use the **Glossary** window:

1. Select a source text phrase in the **Translations** tab folder.

2. Choose **Window** → **Glossary** to open the **Glossary** window and view the glossary suggestions for the target phrase selected in the tab folder.
3. Select the combo-box button to also display glossary suggestions for each word in the text phrase:

![Glossary Window](image)

4. Activate the **Use Word Indexing** toggle box to display all target phrases that contain a translation for one of the words in the source phrase.

**Editing a glossary suggestion**

To edit a glossary suggestion:

1. In the **Glossary** window, click a glossary selection. The glossary entry appears in the **Target Phrase** column of the **Translations** tab folder.
2. Edit the entry in the **Translations** tab folder.

**Entering a translation**

Select a target suggestion from the **Glossary** window or type a target phrase directly in the target phrase fill-in area, then press **RETURN**. The Visual Translator saves the target phrase.

To edit a translation, use the **Cut**, **Copy**, and **Paste** buttons. To enable these buttons, select a cell in the **Target Phrase** column. The Visual Translator cuts and copies the entire contents of a selected cell. You can then manually edit the text using the keyboard.

To view the translation of a message in context, click the **View** button.

You can view any text phrase in a separate, larger dialog box by double-clicking on any field of the **Translation** tab folder. Figure 3–2 shows the **Long String Translator** dialog box.

![Long String Translator](image)

**Figure 3–2:** Long String Translator dialog box
The **Long String Translator** dialog box allows you to view and edit text phrases. If a string is longer than thirty-four characters and does not fit in the **Translations** tab folder, you can view it in the **Long String Translator** dialog box. The source string displays in the **Source String** viewer. The target string displays in the **Target String** viewer. You cannot edit the source string, but you can edit the target string within the **Target String** viewer.

**Global translation**

This section describes how to use the Visual Translator to translate text phrases globally.

To translate text phrases globally:

1. From the **Translations** tab folder, choose **Edit** → **Replace**. The **Replace** dialog box appears:

![Replace dialog box](image)

2. In the **Find What** field, type the source phrase you want to translate.

3. In the **Find** section, activate **Source**.

**Note:** Finding by source phrase results in optimum performance.

4. Activate the options you want to use during the Find process:

   - **Ignore Leading Spaces** — If you activate this toggle box (the default), the Visual Translator finds the phrase you specify in the **Find What** field even if it has blank spaces in front of it.

   - **Case Sensitive** — If you activate this toggle box, the Visual Translator finds the phrase only if it exactly matches the uppercase and lowercase letters you specify. For example, if you specify “Close,” it does not find “close” or “CLOSE.”

   - **Use Wildcards** — If you activate this toggle box, the Visual Translator lets you use an asterisk (*) and a period (.) as wildcards in the **Find What** field. For example, if you specify “*cat*”, it finds all phrases that contain “cat,” such as “concatenate” and “category.” If you specify “.File,” it finds all phrases that contain “File” preceded by a single character, for example, “_File.”

5. In the **Replace What** field, type the target phrase you want to replace. If you want to replace all target phrases for the specified source phrase, leave the **Replace What** field blank.
6. In the **Replace With** field, type the target phrase you want to use. In the example shown below, the translator is translating all instances of the English source phrase “File” to the German target phrase “Datei”:

![Image of Replace dialog box]

In the following example, the translator is changing the target phrase to “Datei” only for those instances of “File” that have a target phrase of “Akte”:

![Image of Replace dialog box]

1. Choose **Replace All**.

2. If the text phrase is for a user-interface object in a resource procedure or for a message and you would like to see the translation in context, select a row that contains the translation you want to view, then click the **View** button.

   The corresponding resource procedure or an alert box containing the message appears.
Translation considerations

This section describes the considerations you should keep in mind when translating while using Visual Translator.

Punctuation

If a source phrase contains punctuation, the Visual Translator does not display the glossary suggestion for the source phrase unless the glossary suggestion also contains the same punctuation. For example, if the source phrase is “Files...”, the Visual Translator does not display the “Files” glossary suggestion because the glossary suggestion does not contain ellipses.

Accelerator keys

You should always include accelerator keys as part of your translation. Check with the project manager to determine how you should define accelerator keys in the target language. The project manager might want you to use the same accelerator keys as the source language or might want you to define new mnemonic accelerator keys specifically for the target language.

For Asian target languages, you should provide an additional ASCII character in parentheses as an accelerator key since the 4GL does not support double-byte characters as accelerator keys. For example, (&A) after the translation of an Asian menu item means that &A displays next to the menu item on the interface, and the user can press alt-A to choose the menu item.
This chapter describes how to use the Visual Translator to track your work. Specifically, it discusses the following topics:

- Checking status
- Finding untranslated text phrases
- Monitoring the glossary
- Printing screen captures
- Printing a statistics report
Checking status

You can check the status of your translation effort for the entire kit or for a particular procedure within the kit.

Procedure status

The Visual Translator uses the following terms in the Current Status column of the Procedure tab folder to indicate the translation status for each procedure in the current language kit:

- **Untranslated** — You have not made any translations in the procedure.
- **x of n** — You have translated \( x \) phrases out of the \( n \) total that are in the procedure.
- **Translated** — You have translated all the text phrases in the procedure.

Kit status

To determine the percentage of the text phrases you have translated in a language kit, open the Statistics tab folder and check the % Translated entry.
Finding untranslated text phrases

This section describes how to find all untranslated text phrases in a procedure and all untranslated text phrases for a kit.

To view all untranslated phrases for a procedure:

1. Click the **Translations** tab to open the **Translations** tab folder.
2. Choose **View** → **Order Columns** or click the **Order** button. The **Order Columns** dialog box appears:

3. Move **ProcedureName**, then **SourcePhrase**, then **TargetPhrase** from the **Available** selection list to the **Selected** selection list, then choose **OK**.
4. Choose **View** → **Sort Rows** or click the **Sort** button. The **Sort** dialog box appears:

5. Specify to sort by **Procedure Name**, then by **Target Phrase**, then choose **OK**.

The Visual Translator displays all the text phrases alphabetically by procedure. First it displays the untranslated phrases, then the translated phrases.
To find all untranslated text phrases in a kit:

1. Open the Translations tab folder, then choose Edit→Goto. The Goto dialog box appears:

2. Activate the First Untranslated Target radio button, then choose Goto. The Visual Translator highlights the row in the Translations tab folder that contains the first untranslated text phrase. The Visual Translator determines which is the first untranslated text phrase by the original row order.

3. Activate the Next Untranslated Target radio button to find all subsequent untranslated text phrases.
Monitoring the glossary

The **Modified by Translator** and **Type** columns in the **Glossaries** tab folder help you keep track of changes you make to the default glossary.

While you translate, if you enter a translation instead of selecting a suggestion from the glossary, the Visual Translator adds your translation to the default glossary but marks it with a C (for custom) in the **Type** column of the **Glossaries** tab folder. For example, in Table 4–1, “Cerrar” is entered by the translator.

If you select a default glossary suggestion for a translation and edit it (for example, you change a word), the Visual Translator indicates that you changed the glossary suggestion by entering Yes in the **Modified by Translator** column of the **Glossaries** tab folder. For example, in Table 4–1, “Mapa de bits” is changed by the translator.

**Table 4–1: Example glossary entries**

<table>
<thead>
<tr>
<th>Source phrase</th>
<th>Target phrase</th>
<th>Modified by translator?</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Agregar</td>
<td>No</td>
<td>D</td>
</tr>
<tr>
<td>Bitmap</td>
<td>Mapa de bits</td>
<td>Yes</td>
<td>D</td>
</tr>
<tr>
<td>Close</td>
<td>Cerrar</td>
<td>Yes</td>
<td>C</td>
</tr>
</tbody>
</table>
Printing screen captures

You can take a screen capture of the translated user-interface procedure window to use in a hard-copy document or to illustrate an issue for the project manager.

To take a screen capture:

1. Open the window you want to capture.

2. Choose the **Print** button. The **Select Window** dialog box appears:

   ![Select Window dialog box](image)

3. Select the name of the resource procedure window, then click **OK**.
Printing a statistics report

The statistics report provides you with information on the current project database. The report contains information that helps you keep track of your translations, for example, the name of the project, creation date, date of last update, and the number of procedures.

You can generate a statistics report, or print the report to a text file, from the Statistics tab folder.

To generate or print a statistics report:

1. Choose the Print button or choose File→Print from the Statistics window. The Statistics Report Print Dialog box appears:

2. Select your print options. If you select the Output To Printer radio-set button, you do not need to enter a filename. The filename defaults to status.txt. If you select the Output to A Text File radio-set button, you must either enter a filename or use the default filename, status.txt.

3. Choose OK. A statistics report prints out that is similar to the one shown below:

<table>
<thead>
<tr>
<th>Project: GetStart1</th>
<th>03/10/97</th>
<th>Page 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project Name</td>
<td>kfrench</td>
<td></td>
</tr>
<tr>
<td>Description</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Revision</td>
<td>1.0</td>
<td></td>
</tr>
<tr>
<td>Create Date</td>
<td>01/10/97</td>
<td></td>
</tr>
<tr>
<td>Last Updated</td>
<td>03/06/97</td>
<td></td>
</tr>
<tr>
<td>Database Size (in Bytes)</td>
<td>458.8K</td>
<td></td>
</tr>
<tr>
<td>Display Type</td>
<td>Graphical</td>
<td></td>
</tr>
<tr>
<td>Number of Procedures</td>
<td>16</td>
<td></td>
</tr>
<tr>
<td>Number of Phrases</td>
<td>164</td>
<td></td>
</tr>
<tr>
<td>Number of Unique Phrases</td>
<td>109</td>
<td></td>
</tr>
<tr>
<td>Number of Words</td>
<td>347</td>
<td></td>
</tr>
<tr>
<td>Number of Unique Words</td>
<td>188</td>
<td></td>
</tr>
<tr>
<td>Current Procedure</td>
<td>None</td>
<td></td>
</tr>
<tr>
<td>Current Object</td>
<td>None</td>
<td></td>
</tr>
<tr>
<td>Number of Frames</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>Number of Objects</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>% Translated</td>
<td>9%</td>
<td></td>
</tr>
<tr>
<td># Items In Glossary</td>
<td>1063</td>
<td></td>
</tr>
</tbody>
</table>
Troubleshooting

This chapter provides answers to some common questions.
Why can’t I install a kit?

You might not need to install the kit. If the kit is not compressed, you can open it without first installing it. A compressed kit has a .zip file extension (for example, kit.zip). A decompressed kit has a .db extension (for example, kit.db).

To open a kit, click the Open button.

Why can’t I open a kit?

If the kit is compressed, you must install it before you can open it. A compressed kit has a .zip file extension (for example, kit.zip). An uncompressed file has a .db extension (for example, kt.db).

To install a kit, choose File→Install.

Why can’t I import glossary entries?

To make sure you have permission to import glossary entries, choose Options→Preferences. The Preferences dialog box displays the privileges the project manager assigned to you. If the Must Use Glossary For Translations toggle box is activated, you cannot import a glossary.

Note: The Translator Privileges section is grayed out to show that it is disabled and you cannot change it. The project manager sets privileges with the Translation Manager tool.

Why do the glossary entries I import have only numbers for source phrases?

You probably imported the entries from a dumped data file that contains line numbers in the first data column.

Why can’t I open a resource procedure?

Check the Resource Procedure column in the Procedures folder. If No is specified for the procedure you want to open, a resource procedure does not exist. You must translate all the text phrases in this procedure with the phrase-by-phrase technique.

If Yes is specified in the Resource Procedure column, click the View button to open the resource procedure or double-click on the name of the procedure. If the Properties window is open, drag it away from the center of the screen to look for an error message.

Why are the text phrases in the resource procedures in the wrong font?

You might be using the wrong progress.ini file or the project manager might have used the wrong environment (.ini) file when creating the resource procedures. Contact the project manager for assistance.

Why is the Visual Translator interface frozen?

The Visual Translator displays warnings or error messages in the center of the computer screen. If you specify the Properties window as always on top and you place it in the center of the screen, the Properties window will hide any error messages. To work around this situation, drag the Properties window away from the center of the screen so you can still see important messages.
Why can’t I type a target phrase?

To make sure you have permission to enter your own translation, choose Options→Preferences. The Preferences dialog box displays the privileges the project manager assigned to you. If the Must Use Glossary For Translations toggle box is activated, you cannot enter your own translation if there is a glossary suggestion. Contact the project manager to change your privileges.

**Note:** The Translator Privileges section is grayed out to show that it is disabled and you cannot change it. The project manager sets privileges with the Translation Manager tool.
Visual Translator Interface Reference

This appendix provides reference information for user-interface elements in the Visual Translator tool and includes the following sections:

- The main window
- Properties window menu options and buttons

For online reference information for a dialog box, click the Help button on the dialog box.
The main window

This section describes how to use the following user-interface elements of the Visual Translator’s main window:

- Tab folders
- Menu bar
- Tool bar

Main window tab folders

The main interface component of the Visual Translator tool is the tab folder. Figure A–1 shows the Visual Translator tabs.

![Visual Translator tab folders](image)

**Figure A–1:** Visual Translator tab folders

When you click one of the tabs, the Visual Translator displays a new interface within the folder. The following sections describe the four tab folders.

Procedures tab folder

The **Procedures** tab folder provides a list of the procedures in the kit. Click the **View Procedures** button to view the user interface of a procedure and translate text phrases. Figure A–2 shows the **Procedures** tab folder.

![Procedures tab folder](image)

**Figure A–2:** Procedures tab folder
The **Procedures** tab folder displays the following columns of information for each procedure in the kit:

- **Procedure Name** — Shows the name of the source-code procedure (.p or .w) file
- **Resource Procedure?** — Indicates whether a resource procedure (.rc) file exists for the source procedure; if yes, you can click the **View Procedure** button to view in-context text phrases
- **Current Status** — Indicates whether or not you have translated a text phrase in the procedure (untranslated), the number of phrases you have translated out of the total number of text phrases in the procedure \( x \) of \( n \), or whether you have translated all text phrases (translated)
- **Comments** — Presents comments about the procedure written by the project manager
- **Directory Name** — Shows the name of the directory that contains the source-code procedure (.p or .w) files

### Translations tab folder

The **Translations** tab folder lets you view the translation data for the entire kit and allows you to translate text phrases globally or by instance. Figure A–3 shows the **Translations** tab folder.

![Figure A–3: Translations tab folder](image)

The **Translations** tab folder displays the following columns of information for each text phrase:

- **Source Phrase** — The text phrase in the source language
- **Target Phrase** — The text phrase in the target language
- **Procedure Name** — The name of the application procedure (.p or .w) file that contains the source phrase
- **Last Updated** — The date the source procedure was last changed
Glossary tab folder

The Glossary tab folder lets you view the pairings for source and target phrases in the glossary. Figure A–4 shows the Glossary tab folder.

![Figure A–4: Glossary tab folder](image)

The Glossary tab folder displays the following columns of information for each text phrase:

- **Source Phrase** — Shows the text phrase in the source language
- **Target Phrase** — Shows the text phrase in the target language
- **Modified By Translator?** — Specifies whether you modified the glossary target phrase
- **Type** — Indicates whether the glossary entry was in the glossary provided by the project manager (D for default) or added by the translator (C for custom) by hand or through an imported glossary.
Statistics tab folder

The Statistics tab folder provides statistics for the language kit, such as the number of procedures, number of phrases, and number of individual words. Figure A–5 shows the Statistics tab folder.

Figure A–5: Statistics tab folder

The Statistics tab folder provides the following information to help you keep track of your translation effort:

- **Project Name** — The project database associated with the kit
- **Description** — A description of the project associated with the kit
- **Revision** — The revision number for the project associated with the kit
- **Create Date** — The date the project manager created the project
- **Last Updated** — The date you last used the kit
- **Database Size** — The size of the kit database, in bytes
- **Display Type** — Indicates whether the resource procedures for the kit display in graphical or character mode
- **Number of Procedures** — The number of source code (.p or .w) files that contain text phrases you have to translate
- **Number of Phrases** — The number of text phrases (including repetitions) in the kit
- **Number of Unique Phrases** — The number of unique text phrases in the kit
- **Number of Words** — The number of individual words (including repetitions) in the kit
- **Number of Unique Words** — The number of unique individual words in the kit
- **Current Procedure** — The name of the procedure currently selected
• **Current Object** — The type of object associated with the currently selected text phrase

• **Number of Frames** — The number of frames in the current procedure

• **Number of Objects** — The number of user-interface objects in the current procedure

• **% Translated** — The percentage of text phrases you have translated in the kit

• **# Items in Glossary** — The number of entries (pairings) in the glossary

---

**Note:** The tool updates the Statistics tab folder whenever you choose a tab folder.

### Main window menu bar and tool bar

The menu bar in the Visual Translator contains menu options that allow you to perform various tasks. The buttons in the tool bar provide quick access to some of the most commonly used menu option functions. When a menu option or tool bar button is grayed-out, it is disabled and you cannot use it.

#### Menu bar

**Figure A–6** shows the Visual Translator main window menu bar.

![Visual Translator menu bar](image)

**Figure A–6: Visual Translator menu bar**

This manual uses the following notation to represent a menu option: **File→Exit**. This notation tells you to choose the **Exit** option from the **File** menu.

Some menu options have accelerator keys assigned to them that appear to the right of menu options on pull-down menus. **Accelerator keys** are key combinations you press to select a menu option. For example, when you pull down the **File** menu, you see **CTRL-o** to the right of the **Open** option. This means that you can hold down the **CTRL** key and press **o** to open a language kit.

Each menu option has a mnemonic. A **mnemonic** is a single letter that you can press to select a menu option. The mnemonic for each menu or menu option is underlined in its label. **Table A–1** lists the menu-bar options, their associated buttons on the tool bar, descriptions of the tasks you can perform with them, and the tab folders in which they are enabled.

#### Table A–1: **Main window menu options and tool bar buttons**

<table>
<thead>
<tr>
<th>Menu options</th>
<th>Button</th>
<th>Description</th>
<th>Tab folders</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File→Install Kit</strong></td>
<td>–</td>
<td>Decompresses and opens a compressed kit</td>
<td><strong>Procedures</strong></td>
</tr>
<tr>
<td><strong>File→Return Kit</strong></td>
<td>–</td>
<td>Compresses the kit so you can return it to the Project Manager</td>
<td><strong>Procedures</strong></td>
</tr>
<tr>
<td><strong>File→Open</strong></td>
<td>🏷</td>
<td>Opens a decompressed kit that you installed previously</td>
<td><strong>All</strong></td>
</tr>
</tbody>
</table>
### Table A–1: Main window menu options and tool bar buttons (2 of 3)

<table>
<thead>
<tr>
<th>Menu options</th>
<th>Button</th>
<th>Description</th>
<th>Tab folders</th>
</tr>
</thead>
<tbody>
<tr>
<td>File→ Import</td>
<td>–</td>
<td>Imports a Glossary</td>
<td>Glossary</td>
</tr>
<tr>
<td>File→ Export</td>
<td>–</td>
<td>Exports a Glossary</td>
<td>Glossary</td>
</tr>
<tr>
<td>File→ Print Screen</td>
<td>![Print Screen]</td>
<td>Prints a screen capture of a window, for example, a translated user interface procedure</td>
<td>Procedures, Translations, Glossary</td>
</tr>
<tr>
<td>File→ Print</td>
<td>![Print]</td>
<td>Prints a hard-copy Statistics report or save the report to a text file</td>
<td>Statistics</td>
</tr>
<tr>
<td>File→ Exit</td>
<td>–</td>
<td>Exits the Visual Translator tool</td>
<td>All</td>
</tr>
<tr>
<td>Edit→ Cut</td>
<td>![Cut]</td>
<td>Cuts selected text</td>
<td>Translations, Glossary</td>
</tr>
<tr>
<td>Edit→ Copy</td>
<td>![Copy]</td>
<td>Copies selected text</td>
<td>Translations, Glossary</td>
</tr>
<tr>
<td>Edit→ Paste</td>
<td>![Paste]</td>
<td>Pastes text you cut or copied</td>
<td>Translations, Glossary</td>
</tr>
<tr>
<td>Edit→ Insert</td>
<td>![Insert]</td>
<td>Inserts a row</td>
<td>Glossary</td>
</tr>
<tr>
<td>Edit→ Delete</td>
<td>![Delete]</td>
<td>Deletes a row</td>
<td>Glossary</td>
</tr>
<tr>
<td>Edit→ Find</td>
<td>![Find]</td>
<td>Finds a text phrase</td>
<td>Translations, Glossary</td>
</tr>
<tr>
<td>Edit→ Replace</td>
<td>–</td>
<td>Finds and replaces a text phrase. Use this option for global translations</td>
<td>Translations, Glossary</td>
</tr>
<tr>
<td>Edit→ Goto</td>
<td>–</td>
<td>Goes to a specific row in a list of text phrases</td>
<td>Translations</td>
</tr>
<tr>
<td>Edit→ Exit</td>
<td>–</td>
<td>Exits the Visual Translator tool</td>
<td>All</td>
</tr>
<tr>
<td>View→ Sort Rows</td>
<td>![Sort Rows]</td>
<td>Sorts text phrases or glossary entries by row</td>
<td>Translations, Glossary</td>
</tr>
<tr>
<td>View→ Order Columns</td>
<td>![Order Columns]</td>
<td>Arranges the order of columns</td>
<td>Translations, Glossary</td>
</tr>
<tr>
<td>View→ View Procedure</td>
<td>![View Procedure]</td>
<td>Views a resource procedure</td>
<td>Procedures, Translations</td>
</tr>
</tbody>
</table>
Table A–1: Main window menu options and tool bar buttons (3 of 3)

<table>
<thead>
<tr>
<th>Menu options</th>
<th>Button</th>
<th>Description</th>
<th>Tab folders</th>
</tr>
</thead>
<tbody>
<tr>
<td>Options→Preferences</td>
<td>–</td>
<td>Specifies display and saves preferences for the Visual Translator tool</td>
<td>All</td>
</tr>
<tr>
<td>Window→Properties</td>
<td>–</td>
<td>Displays the Properties window when you view a procedure</td>
<td>Procedures</td>
</tr>
<tr>
<td>Window→Glossary</td>
<td>–</td>
<td>Displays the Glossary window when you view a procedure</td>
<td>Translations</td>
</tr>
<tr>
<td>Tools→TranMan Utilities→Cleanup Glossaries</td>
<td>–</td>
<td>Removes glossary entries that do not correspond to extracted text phrases</td>
<td>All</td>
</tr>
<tr>
<td>Tools→TranMan Utilities→Pre-translation</td>
<td>–</td>
<td>Translates all text phrases that have glossary entries. Prints a report of the Pretranslation results</td>
<td>All</td>
</tr>
<tr>
<td>Tools→</td>
<td>–</td>
<td>Open various OpenEdge tools based on your license agreement</td>
<td>All</td>
</tr>
<tr>
<td>Help</td>
<td>☑️</td>
<td>Provides online help about buttons and folders</td>
<td>All</td>
</tr>
</tbody>
</table>

**Tool bar**

*Figure A–7* shows the tool bar for the Visual Translator main window.

*Figure A–7: Visual Translator tool bar*

Click a tool-bar button for quick access to its corresponding menu option.
Properties window menu options and buttons

This section describes the menu options and buttons for the Visual Translator Properties window. Table A–2 describes the functions of the Properties window buttons.

Table A–2: Properties window buttons

<table>
<thead>
<tr>
<th>Name</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Close</td>
<td></td>
<td>Close the Properties window and return to the Visual Translator main window.</td>
</tr>
<tr>
<td>Previous Object</td>
<td></td>
<td>Move to the previous interface object in the resource procedure window.</td>
</tr>
<tr>
<td>Next Object</td>
<td></td>
<td>Move to the next interface object in the resource procedure window.</td>
</tr>
<tr>
<td>Next Frame</td>
<td></td>
<td>Display the next frame associated with the current resource procedure window.</td>
</tr>
<tr>
<td>Uncover Objects</td>
<td></td>
<td>Display an interface object hidden underneath the currently selected object.</td>
</tr>
<tr>
<td>Switch</td>
<td></td>
<td>Switch between displaying the source phrases or all the target phrases in the resource procedure window.</td>
</tr>
<tr>
<td>Help</td>
<td></td>
<td>Provide information about the buttons, tabs, and fill-in fields in the Properties Window.</td>
</tr>
</tbody>
</table>

Table A–3 describes the functions of the Properties window menu options.

Table A–3: Properties window menu options (1 of 2)

<table>
<thead>
<tr>
<th>Menu</th>
<th>Menu option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>Save</td>
<td>Saves the target phrase to the translation and glossary databases</td>
</tr>
<tr>
<td></td>
<td>Close</td>
<td>Closes the Properties window</td>
</tr>
<tr>
<td>Edit</td>
<td>Cut</td>
<td>Cuts highlighted text in the Properties window</td>
</tr>
<tr>
<td></td>
<td>Copy</td>
<td>Copies highlighted text in the Properties window</td>
</tr>
<tr>
<td></td>
<td>Paste</td>
<td>Pastes text you cut or copied in the Properties window</td>
</tr>
</tbody>
</table>
Table A–3: Properties window menu options  

<table>
<thead>
<tr>
<th>Menu</th>
<th>Menu option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>Source</td>
<td>Displays the source phrases in the resource procedure window</td>
</tr>
<tr>
<td></td>
<td>Target</td>
<td>Displays the available target phrases in the resource procedure window</td>
</tr>
<tr>
<td>Object</td>
<td>Next Frame</td>
<td>Displays the next frame associated with the current resource procedure</td>
</tr>
<tr>
<td></td>
<td>Next Object</td>
<td>Moves to the next interface object in the resource procedure window</td>
</tr>
<tr>
<td></td>
<td>Previous Object</td>
<td>Moves to the previous interface object in the resource procedure window</td>
</tr>
</tbody>
</table>
Sorting rows 10
Source languages 3
Space-delimited glossaries 9
Starting the Visual Translator 3
Statistics report 7
Statistics tab folder 5
Status of kits 2
status.txt file 7
T
Tab folders

2
Target languages 3
Target phrases
entering 12
Text phrases
editing 12

Tool bar
main window 6
Properties window 9

Tool-guided object selection 7
Translating
globally 13
Translating text phrases
preliminary translation 3
screen-by-screen 5
Translation
automatic 5
Translation considerations 15
Translations tab folder 3
Trimming blanks 4
Troubleshooting 1
Types
Glossaries tab folder 4
Translations tab folder 3
Typing translations 8
U
Unzipping kits 5
V
Viewing resource procedures 5
W
Widgets 10

Wildcards 13
Windows
  Glossary 11
  main 3, 2
  Properties 7
Word indexing 9
Working directory 2
Z
Zip files
  creating 8
  installing 5