OpenEdge® Development:
AppBuilder
# Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Pages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preface</td>
<td>13</td>
</tr>
</tbody>
</table>

1. **Introduction** .............................................. 29
   - OpenEdge Application Development Model .......................... 30
   - Concepts and terminology ...................................... 31
     - External versus internal procedures .......................... 31
     - AppBuilder objects .......................................... 31
   - What is smart about SmartObjects? ............................. 38
   - Visible versus nonvisible objects ............................. 39
   - Widgets .......................................................... 40
   - Reading and writing ABL widgets ............................... 41
   - Inter-object communication: signatures ......................... 43
   - Anatomy of a database application ............................. 44
   - Working with AppBuilder ...................................... 45
   - Single-window or multi-window design? ......................... 46
   - Designing for character-based environments .................... 47
   - Building an application in AppBuilder ....................... 48

2. **AppBuilder Interface** ......................................... 53
   - Starting and stopping AppBuilder .............................. 54
     - Starting from the operating system ........................... 54
     - Stopping AppBuilder .......................................... 54
     - AppBuilder for Web-based applications ...................... 54
   - AppBuilder main window ....................................... 55
     - Current-object fields ...................................... 55
     - Status bar ................................................... 56
   - Menu bar ........................................................ 57
     - File menu ..................................................... 57
     - Edit menu .................................................... 58
     - Compile menu ................................................ 59
     - Tools menu ................................................... 61
     - Options menu ................................................ 62
     - Layout menu .................................................. 62
     - Window menu .................................................. 63
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help menu</td>
<td>64</td>
</tr>
<tr>
<td>Tool bar</td>
<td>64</td>
</tr>
<tr>
<td>Object Palette</td>
<td>66</td>
</tr>
<tr>
<td>Placing objects from the Object Palette</td>
<td>69</td>
</tr>
<tr>
<td>Object Palette options</td>
<td>70</td>
</tr>
<tr>
<td>Customizing the Object Palette</td>
<td>70</td>
</tr>
<tr>
<td>The TEMP-DB database</td>
<td>71</td>
</tr>
<tr>
<td>Creating a TEMP-DB database</td>
<td>72</td>
</tr>
<tr>
<td>Using the TEMP-DB Maintenance tool</td>
<td>75</td>
</tr>
<tr>
<td>TEMP-DB control records</td>
<td>75</td>
</tr>
<tr>
<td>Defining a new temp-table</td>
<td>76</td>
</tr>
<tr>
<td>Importing temp-table definitions</td>
<td>78</td>
</tr>
<tr>
<td>Viewing temp-table details</td>
<td>81</td>
</tr>
<tr>
<td>Editing temp-table definitions</td>
<td>84</td>
</tr>
<tr>
<td>Verifying a definition against its source</td>
<td>84</td>
</tr>
<tr>
<td>Rebuilding the TEMP-DB schema</td>
<td>86</td>
</tr>
<tr>
<td>Setting your preferences</td>
<td>87</td>
</tr>
<tr>
<td>AppBuilder preferences</td>
<td>87</td>
</tr>
<tr>
<td>Section Editor preference options</td>
<td>91</td>
</tr>
<tr>
<td>Workspaces: design windows and source-code editors</td>
<td>97</td>
</tr>
<tr>
<td>Editing source code safely: the Section Editor</td>
<td>99</td>
</tr>
<tr>
<td>Opening the Section Editor</td>
<td>99</td>
</tr>
<tr>
<td>Choosing a section to edit</td>
<td>99</td>
</tr>
<tr>
<td>Using the Section Editor</td>
<td>100</td>
</tr>
<tr>
<td>Inserting text-string tokens from lists</td>
<td>104</td>
</tr>
<tr>
<td>Configuring look-and-feel: object properties</td>
<td>110</td>
</tr>
<tr>
<td>Inspecting a procedure file</td>
<td>112</td>
</tr>
<tr>
<td>Test-driving your design</td>
<td>113</td>
</tr>
<tr>
<td>Saving your work</td>
<td>114</td>
</tr>
</tbody>
</table>

### 3. Organizer Objects

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction to organizer objects</td>
<td>116</td>
</tr>
<tr>
<td>Organizer object roles</td>
<td>117</td>
</tr>
<tr>
<td>Creating a new procedure-based organizer instance</td>
<td>118</td>
</tr>
<tr>
<td>SmartWindows</td>
<td>120</td>
</tr>
<tr>
<td>Configuring SmartWindow visual properties</td>
<td>120</td>
</tr>
<tr>
<td>SmartDialogs</td>
<td>128</td>
</tr>
<tr>
<td>Configuring SmartDialog visual properties</td>
<td>128</td>
</tr>
<tr>
<td>Configuring SmartDialog procedure settings</td>
<td>130</td>
</tr>
<tr>
<td>SmartFrames</td>
<td>131</td>
</tr>
<tr>
<td>Configuring SmartFrame visual properties</td>
<td>131</td>
</tr>
<tr>
<td>Configuring SmartFrame procedure settings</td>
<td>133</td>
</tr>
<tr>
<td>Basic windows</td>
<td>134</td>
</tr>
<tr>
<td>Basic dialogs</td>
<td>135</td>
</tr>
<tr>
<td>Basic frames</td>
<td>136</td>
</tr>
<tr>
<td>Creating and placing a frame</td>
<td>136</td>
</tr>
<tr>
<td>Configuring frame properties</td>
<td>136</td>
</tr>
<tr>
<td>Rectangles</td>
<td>137</td>
</tr>
<tr>
<td>Creating and placing a rectangle</td>
<td>137</td>
</tr>
<tr>
<td>Configuring rectangle properties</td>
<td>137</td>
</tr>
<tr>
<td>Simple SmartContainers</td>
<td>141</td>
</tr>
<tr>
<td>Creating and populating a Simple SmartContainer</td>
<td>141</td>
</tr>
<tr>
<td>Placing and configuring a SmartContainer module</td>
<td>142</td>
</tr>
<tr>
<td>Creating paged layouts</td>
<td>145</td>
</tr>
<tr>
<td>Page identifiers</td>
<td>145</td>
</tr>
<tr>
<td>Special pages</td>
<td>145</td>
</tr>
</tbody>
</table>
Contents

Why only SmartObjects? .................................................. 147
Paging with SmartFolders .............................................. 148
Paging without SmartFolders ......................................... 151
Paging whole windows ................................................. 153

4. Data-Access Objects .................................................... 155
Introduction to data-access objects .................................. 156
DataViews ................................................................. 157
SmartDataObjects ......................................................... 158
  Static SmartDataObjects ............................................. 158
  Dynamic SmartDataObjects ......................................... 159
Creating a SmartDataObject master ................................ 159
Editing a SmartDataObject master .................................. 164
Creating a SmartDataObject instance .............................. 165
Configuring a SmartDataObject instance ......................... 166
Selecting database fields for browsing ......................... 168
Creating calculated fields .......................................... 168
Data validation limitation .......................................... 169
Using the dynamic SmartDataObject .............................. 171
SmartBusinessObject ..................................................... 172
Creating and placing a SmartBusinessObject .................... 173
Populating and configuring a SmartBusinessObject .............. 174
Synchronizing SmartDataObjects using DATA links .............. 175
Configuring a SmartBusinessObject instance .................. 178
SmartFilters .............................................................. 180
Configuring SmartFilter properties ............................... 181
Making changes to the data stream ................................. 186
Creating a freestanding query object ............................. 187
Defining and editing queries using Query Builder .......... 188
  Table mode .......................................................... 189
  Join mode .......................................................... 191
  Where mode ....................................................... 192
  Sort mode .......................................................... 193
  Options mode ...................................................... 194

5. Data-Display/Capture Objects ...................................... 197
Introduction to data-display objects .............................. 199
SmartDataBrowsers ...................................................... 200
  Dynamic SmartDataBrowser ....................................... 201
    Creating a dynamic SmartDataBrowser instance .......... 201
Static SmartDataBrowser .............................................. 204
  Creating a SmartDataBrowser master ......................... 204
  Configuring SmartDataBrowser properties .................. 207
Editing a SmartDataBrowser master ............................. 211
Creating and placing a SmartDataBrowser instance .......... 211
Configuring a SmartDataBrowser instance ..................... 211
Scrolling to the last record in the data stream .............. 212
SmartDataViewers ....................................................... 215
  Creating a SmartDataViewer master ........................... 215
  Adding and removing SmartDataViewer fields ............... 219
  Configuring SmartDataViewer properties ................... 219
SmartDataFields ........................................................ 225
  Placing and configuring a SmartDataField instance ....... 225
SmartSelects ............................................................. 228
  Placing a SmartSelect instance ................................. 228
  Configuring a SmartSelect instance .......................... 229
# 6. Data-Communication Objects

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Example: assigning a new sales rep.</td>
<td>232</td>
</tr>
<tr>
<td>Basic data browsers</td>
<td>236</td>
</tr>
<tr>
<td>Creating a basic data browser instance</td>
<td>236</td>
</tr>
<tr>
<td>Configuring a basic data browser instance</td>
<td>237</td>
</tr>
<tr>
<td>Combo boxes</td>
<td>241</td>
</tr>
<tr>
<td>Creating a basic combo box instance</td>
<td>241</td>
</tr>
<tr>
<td>Configuring a basic combo box instance</td>
<td>242</td>
</tr>
<tr>
<td>Operating a basic combo box</td>
<td>247</td>
</tr>
<tr>
<td>Creating an ActiveX combo box instance</td>
<td>251</td>
</tr>
<tr>
<td>Configuring an ActiveX combo box instance</td>
<td>251</td>
</tr>
<tr>
<td>Basic data viewers</td>
<td>254</td>
</tr>
<tr>
<td>Creating a basic data viewer instance</td>
<td>254</td>
</tr>
<tr>
<td>Configuring a basic viewer instance</td>
<td>255</td>
</tr>
<tr>
<td>Multi-line editors</td>
<td>256</td>
</tr>
<tr>
<td>Creating an editor instance</td>
<td>256</td>
</tr>
<tr>
<td>Configuring an editor instance</td>
<td>256</td>
</tr>
<tr>
<td>Fill-ins (single-line editors)</td>
<td>258</td>
</tr>
<tr>
<td>Creating a fill-in instance</td>
<td>258</td>
</tr>
<tr>
<td>Configuring a fill-in instance</td>
<td>258</td>
</tr>
<tr>
<td>Radio button sets</td>
<td>261</td>
</tr>
<tr>
<td>Creating a radio-set instance</td>
<td>261</td>
</tr>
<tr>
<td>Configuring a radio-set instance</td>
<td>262</td>
</tr>
<tr>
<td>Selection lists</td>
<td>264</td>
</tr>
<tr>
<td>Creating a selection list instance</td>
<td>264</td>
</tr>
<tr>
<td>Configuring a selection list instance</td>
<td>264</td>
</tr>
<tr>
<td>Slider controls</td>
<td>266</td>
</tr>
<tr>
<td>Creating a slider-control instance</td>
<td>266</td>
</tr>
<tr>
<td>Configuring a slider control instance</td>
<td>267</td>
</tr>
<tr>
<td>Spin controls (ActiveX)</td>
<td>269</td>
</tr>
<tr>
<td>Creating a spin control instance</td>
<td>269</td>
</tr>
<tr>
<td>Configuring a spin-control instance</td>
<td>269</td>
</tr>
<tr>
<td>Toggle boxes (check boxes)</td>
<td>271</td>
</tr>
<tr>
<td>Creating a toggle box instance</td>
<td>271</td>
</tr>
<tr>
<td>Configuring a toggle box instance</td>
<td>271</td>
</tr>
<tr>
<td>6. <strong>Data-Communication Objects.</strong></td>
<td>273</td>
</tr>
<tr>
<td>SmartB2BObjects</td>
<td>274</td>
</tr>
<tr>
<td>XML schema and mapping files</td>
<td>275</td>
</tr>
<tr>
<td>Mapping options</td>
<td>277</td>
</tr>
<tr>
<td>XML schema Mapping Tool</td>
<td>281</td>
</tr>
<tr>
<td>Starting the XML Mapping Tool</td>
<td>283</td>
</tr>
<tr>
<td>Creating an XML map file</td>
<td>283</td>
</tr>
<tr>
<td>Creating a master SmartB2BObject</td>
<td>287</td>
</tr>
<tr>
<td>Creating and placing a SmartB2BObject instance</td>
<td>288</td>
</tr>
<tr>
<td>Configuring a SmartB2BObject instance</td>
<td>288</td>
</tr>
<tr>
<td>SmartSender and SmartReceiver objects</td>
<td>293</td>
</tr>
<tr>
<td>Creating and completing a SmartSender master</td>
<td>294</td>
</tr>
<tr>
<td>Placing and configuring a SmartSender instance</td>
<td>295</td>
</tr>
<tr>
<td>SmartRouters</td>
<td>297</td>
</tr>
<tr>
<td>Handling multiple document types</td>
<td>298</td>
</tr>
<tr>
<td>Callable document-handlers</td>
<td>299</td>
</tr>
<tr>
<td>Creating a document-handling package</td>
<td>300</td>
</tr>
<tr>
<td>Creating a document-routing package</td>
<td>300</td>
</tr>
<tr>
<td>SmartProducers and SmartConsumers</td>
<td>303</td>
</tr>
<tr>
<td>Creating and placing a SmartProducer instance</td>
<td>304</td>
</tr>
<tr>
<td>Configuring a SmartProducer instance</td>
<td>305</td>
</tr>
</tbody>
</table>
B. Multiple Layouts ......................................................... 385
   Why use multiple layouts? .................................. 386
   What is a layout? ............................................. 387
   Two types of layouts ...................................... 388
      Master layout ........................................... 388
      Alternate layout ....................................... 388
   Creating alternate layouts .............................. 391
   Selecting a predefined alternate layout ............ 393
   Modifying layouts with layout inheritance ........ 394
      Layout inheritance behavior at run time .......... 394
      Layout inheritance behavior at design time .... 396
      Re-establishing layout inheritance ................. 396
   How multiple layouts work: a look at the code ...... 398
      Run-time properties and AppBuilder settings .... 398
      Layout cases internal procedure .................... 400
      Enable_UI internal procedure ....................... 401
   Alternate layout limitations ............................ 402
      Modifiable properties ................................ 402
      Text widgets in alternate layouts ................. 402
      Combo boxes in alternate layouts ................ 402
      SIZE-TO-FIT setting .................................. 402
   Switching between layouts at run time ............. 403
   Simulating character applications .................... 404
   Running character applications ....................... 405
      Character client connection issues ............... 406
      Double-byte characters ................................ 407
   Multiple layouts for SmartObjects .................... 408
      Creating SmartObject alternate layouts .......... 409
      Modifying SmartObject layouts ..................... 409
      Applying SmartObject layouts at run time ....... 413

C. Customizing AppBuilder ......................................... 417
   Custom object files and extended features .......... 418
   Creating custom object files ............................. 419
      General coding rules .................................. 419
      Entry types ............................................ 420
      Adding a button to the Object Palette ............. 420
      Adding a SmartObject to a palette button pop-up menu .............. 422
      Adding a new template ................................ 423
      Adding a widget to a palette button pop-up menu .................. 424
   Creating extended features (XFTRs) .................. 433
      The &ANALYZE-SUSPEND directive for XFTRs .... 434
      The event-mapping comment ............................ 434
      The compilable code comment .......................... 435
      The ending comment ................................... 435
      The &ANALYZE-RESUME directive for XFTRs ....... 435
   How AppBuilder runs XFTR event handlers .......... 436
   AppBuilder’s API .............................................. 437
      Context IDs ............................................. 437
      Naming convention ..................................... 437
      AppBuilder’s API summary .............................. 437
      Add/remove SmartLinks (adeuib/_ablink.p) ......... 438
      Access section (adeuib/_accsect.p) ................. 441
## Figures

<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Figure 1</td>
<td>Design-time representation of a nonvisible SmartObject</td>
<td>39</td>
</tr>
<tr>
<td>Figure 2</td>
<td>SmartObject Menu Button menu</td>
<td>39</td>
</tr>
<tr>
<td>Figure 3</td>
<td>Toy phone book application at design time</td>
<td>48</td>
</tr>
<tr>
<td>Figure 4</td>
<td>Toy phone book application at run time</td>
<td>48</td>
</tr>
<tr>
<td>Figure 5</td>
<td>SmartLinks between SmartObjects</td>
<td>50</td>
</tr>
<tr>
<td>Figure 6</td>
<td>Toy phone book links in SmartLinks Editor</td>
<td>51</td>
</tr>
<tr>
<td>Figure 7</td>
<td>AppBuilder main window</td>
<td>55</td>
</tr>
<tr>
<td>Figure 8</td>
<td>Current-object fields</td>
<td>55</td>
</tr>
<tr>
<td>Figure 9</td>
<td>Status bar</td>
<td>56</td>
</tr>
<tr>
<td>Figure 10</td>
<td>AppBuilder tool bar</td>
<td>64</td>
</tr>
<tr>
<td>Figure 11</td>
<td>Object Palette</td>
<td>66</td>
</tr>
<tr>
<td>Figure 12</td>
<td>Workspace for a visible object</td>
<td>97</td>
</tr>
<tr>
<td>Figure 13</td>
<td>Workspace element for nonvisible object</td>
<td>97</td>
</tr>
<tr>
<td>Figure 14</td>
<td>Section Editor physical interface</td>
<td>99</td>
</tr>
<tr>
<td>Figure 15</td>
<td>Field Selector dialog box</td>
<td>104</td>
</tr>
<tr>
<td>Figure 16</td>
<td>Choose Event dialog box</td>
<td>105</td>
</tr>
<tr>
<td>Figure 17</td>
<td>Insert Procedure Call dialog box</td>
<td>105</td>
</tr>
<tr>
<td>Figure 18</td>
<td>Stop button</td>
<td>113</td>
</tr>
<tr>
<td>Figure 19</td>
<td>Window property sheet</td>
<td>122</td>
</tr>
<tr>
<td>Figure 20</td>
<td>SmartDialog Property Sheet</td>
<td>129</td>
</tr>
<tr>
<td>Figure 21</td>
<td>Rectangle Property Sheet</td>
<td>138</td>
</tr>
<tr>
<td>Figure 22</td>
<td>Paging using a SmartFolder</td>
<td>148</td>
</tr>
<tr>
<td>Figure 23</td>
<td>Paging using button controls</td>
<td>151</td>
</tr>
<tr>
<td>Figure 24</td>
<td>Paging using radio-set controls</td>
<td>151</td>
</tr>
<tr>
<td>Figure 25</td>
<td>Paging a whole window</td>
<td>153</td>
</tr>
<tr>
<td>Figure 26</td>
<td>Compilation of an SDO</td>
<td>158</td>
</tr>
<tr>
<td>Figure 27</td>
<td>SBO in a Web environment</td>
<td>172</td>
</tr>
<tr>
<td>Figure 28</td>
<td>Data relationship among five tables</td>
<td>173</td>
</tr>
<tr>
<td>Figure 29</td>
<td>Resynchronization hierarchy defined by DATA SmartLinks</td>
<td>175</td>
</tr>
<tr>
<td>Figure 30</td>
<td>Query Builder in Table mode</td>
<td>189</td>
</tr>
<tr>
<td>Figure 31</td>
<td>Sample query for OF-joinable tables</td>
<td>190</td>
</tr>
<tr>
<td>Figure 32</td>
<td>Query sample with incomplete join criteria</td>
<td>190</td>
</tr>
<tr>
<td>Figure 33</td>
<td>Query Builder in Join mode</td>
<td>191</td>
</tr>
<tr>
<td>Figure 34</td>
<td>Query Builder in Where mode</td>
<td>192</td>
</tr>
<tr>
<td>Figure 35</td>
<td>Query Builder in Sort mode</td>
<td>193</td>
</tr>
<tr>
<td>Figure 36</td>
<td>Query Builder in Options mode</td>
<td>194</td>
</tr>
<tr>
<td>Figure 37</td>
<td>SmartB2BObject in inter-business communications</td>
<td>274</td>
</tr>
<tr>
<td>Figure 38</td>
<td>Simple one-to-one XML mapping in data communication</td>
<td>276</td>
</tr>
<tr>
<td>Figure 39</td>
<td>Mapping an XML node to a function</td>
<td>277</td>
</tr>
<tr>
<td>Figure 40</td>
<td>XML Mapping Tool window</td>
<td>282</td>
</tr>
<tr>
<td>Figure 41</td>
<td>The SmartSender and SmartReceiver in B2B communication</td>
<td>293</td>
</tr>
<tr>
<td>Figure 42</td>
<td>SmartRouter distributing incoming documents</td>
<td>297</td>
</tr>
<tr>
<td>Figure 43</td>
<td>Basic message-handling blocks</td>
<td>298</td>
</tr>
<tr>
<td>Figure 44</td>
<td>Message routing using SmartRouter</td>
<td>299</td>
</tr>
<tr>
<td>Figure 45</td>
<td>The Smart Message-interface objects</td>
<td>303</td>
</tr>
<tr>
<td>Figure 46</td>
<td>Outbound message-handling process</td>
<td>312</td>
</tr>
<tr>
<td>Figure 47</td>
<td>Inbound message-handling process</td>
<td>313</td>
</tr>
<tr>
<td>Figure 48</td>
<td>SmartToolbar fully enabled</td>
<td>324</td>
</tr>
<tr>
<td>Figure 49</td>
<td>SmartToolbar in record-changed state</td>
<td>324</td>
</tr>
<tr>
<td>Figure 50</td>
<td>SmartToolbar in transaction-pending state</td>
<td>324</td>
</tr>
<tr>
<td>Figure 51</td>
<td>Pages dialog box</td>
<td>351</td>
</tr>
<tr>
<td>Figure 52</td>
<td>Advanced Procedure Settings dialog box</td>
<td>353</td>
</tr>
<tr>
<td>Figure 53</td>
<td>Custom lists naming dialog box</td>
<td>362</td>
</tr>
<tr>
<td>Figure 54</td>
<td>SmartWindow main procedure settings dialog box</td>
<td>366</td>
</tr>
<tr>
<td>Figure 55</td>
<td>Properties Window</td>
<td>368</td>
</tr>
</tbody>
</table>
Figure 56: SmartLinks editor dialog box ......................................................... 369
Figure 57: String Attributes dialog box for static text ................................. 375
Figure 58: String Attributes dialog box for a combo box ............................... 375
Figure 59: Tab Editor dialog box ................................................................. 376
Figure 60: Master layout ............................................................................. 389
Figure 61: Character alternate layout ............................................................ 390
Figure 62: Alternate Layout dialog box for SmartObjects ............................... 409
Figure 63: SmartDataViewer master layout ................................................. 409
Figure 64: SmartDataViewer Address alternate layout ................................. 410
Figure 65: SmartDataViewer Balance alternate layout ................................. 410
Figure 66: SmartDataViewer menu button's pop-up menu ............................. 411
Figure 67: Menu button's pop-up menu in alternate layout ......................... 411
Figure 68: Instance property sheet in alternate layout .................................. 412
Figure 69: SmartDataViewer properties with layout options ........................ 412
Figure 70: Sample entry for SmartObject type ............................................ 421
Figure 71: Sample entries for adding a SmartObject master .......................... 422
Figure 72: Sample entries for new templates .............................................. 424
Figure 73: XFTR in browser.w template ..................................................... 433
Figure 74: Event handler components ....................................................... 434
Contents

Tables

Table 1: Basic ABL object types .................................................. 32
Table 2: SmartObject types ....................................................... 34
Table 3: ActiveX (OCX) object types ........................................... 37
Table 4: Benefits of using SmartObjects ..................................... 38
Table 5: Default object tool description ..................................... 66
Table 6: TEMP-DB control records ............................................. 75
Table 7: General preference options .......................................... 87
Table 8: Options on the Insert Procedure Call dialog box .............. 106
Table 9: How to make changes to the data stream ......................... 186
Table 10: Dynamic SmartDataBrowser display/update rules .......... 202
Table 11: SmartToolbar properties ............................................. 325
Table 12: SmartToolbar Categories options ............................... 325
Table 13: SmartPanels options .................................................. 329
Table 14: ABL color table ....................................................... 358
Table 15: Standard layouts and run-time expressions .................... 389
Table 16: Modifiable properties in alternate layouts ..................... 402
Table 17: Custom object files and their contents ......................... 419
Table 18: AppBuilder events .................................................... 435
Table 19: Naming conventions .................................................. 437
Table 20: API procedures ....................................................... 438
Preface

This Preface contains the following sections:

- Purpose
- Audience
- Organization
- Using this manual
- Typographical conventions
- Examples of syntax descriptions
- OpenEdge messages
- Third party acknowledgements
Preface

Purpose

This guide provides a basic introduction to using AppBuilder for Rapid Application Prototyping/Development (RAP/RAD).

Audience

Database programmers who appreciate the time and energy advantages of using WYSIWYG layout editors for RAP/RAD. This guide presumes that you understand programming in general, though it does not require that you know ABL (Advanced Business Language) specifically. You can create simple applications using AppBuilder alone, but you will find it hard to do sophisticated work without at least some programming ability with ABL.

Organization

Chapter 1, “Introduction”

Introduces basic terminology and concepts that are important to understand when working with AppBuilder.

Chapter 2, “AppBuilder Interface”

Walks through the user-interface elements apart from the common dialog boxes, which are collected together in Appendix A.

Chapter 3, “Organizer Objects”

Describes objects that integrate smaller objects functionally or visually. Organizer objects include Windows, Dialog Boxes, Frames, and even the Rectangle.

Chapter 4, “Data-Access Objects”

Describes objects that help read and write the logical database. These range from the basic Query object through the powerful SmartBusinessObject.

Chapter 5, “Data-Display/Capture Objects”

Describes the many objects that you can use to present the user with information from the data stream, and capture both changes and new data. They range from powerful SmartObjects to the simplest boolean Toggle Box.

Chapter 6, “Data-Communication Objects”

Describes the transformation and communication objects you can use to create, send, receive, and process data messages.

Chapter 7, “Control Objects”

Describes the few objects that provide a nearly-pure control function: SmartToolbar, SmartPanels, and the lowly button.
Chapter 8, “Other Objects”

Describes those few objects that seem not to fit well elsewhere: Static Text and Image objects, for example.

Appendix A, “Frequently Used Dialogs”

Describes the standard dialogs that you will encounter over and over again, nearly unchanged regardless of context.

Appendix B, “Multiple Layouts”

Describes how to create, from a single code base, layouts that vary in appearance across platforms and contexts.

Appendix C, “Customizing AppBuilder”

Describes ways you can change AppBuilder itself so that it will more closely meet your needs.

Using this manual

Unless you are familiar with layout or graphics editors, begin by browsing Chapter 1, “Introduction,” and studying Chapter 2, “AppBuilder Interface.” Then experiment with some trial work of your own. Use the material from Chapter 3, “Organizer Objects,” onward mainly as a convenient reference.

OpenEdge provides a special purpose programming language for building business applications. In the documentation, the formal name for this language is ABL (Advanced Business Language). With few exceptions, all keywords of the language appear in all \textit{UPPERCASE}, using a font that is appropriate to the context. All other alphabetic language content appears in mixed case.

For the latest documentation updates see the OpenEdge Product Documentation category on PSDN \url{http://www.psdn.com/library/kbcategory.jspa?categoryId=129}.

References to ABL compiler and run-time features

ABL is both a compiled and interpreted language that executes in a run-time engine that the documentation refers to as the ABL Virtual Machine (AVM). When documentation refers to ABL source code compilation, it specifies \textit{ABL or the compiler} as the actor that manages compile-time features of the language. When documentation refers to run-time behavior in an executing ABL program, it specifies \textit{the AVM} as the actor that manages the specified run-time behavior in the program.

For example, these sentences refer to the ABL compiler’s allowance for parameter passing and the AVM’s possible response to that parameter passing at run time: “ABL allows you to pass a dynamic temp-table handle as a static temp-table parameter of a method. However, if at run time the passed dynamic temp-table schema does not match the schema of the static temp-table parameter, the AVM raises an error.” The following sentence refers to run-time actions that the AVM can perform using a
particular ABL feature: “The ABL socket object handle allows the AVM to connect with other ABL and non-ABL sessions using TCP/IP sockets.”

References to ABL data types

ABL provides built-in data types, pre-defined class data types, and user-defined class data types. References to built-in data types follow these rules:

- Like most other keywords, references to specific built-in data types appear in all **UPPERCASE**, using a font that is appropriate to the context. No uppercase reference ever includes or implies any data type other than itself.
- Wherever *integer* appears, this is a reference to the **INTEGER** or **INT64** data type.
- Wherever *decimal* appears, this is a reference to the **DECIMAL** data type.
- Wherever *numeric* appears, this is a reference to the **INTEGER**, **INT64**, or **DECIMAL** data type.

References to pre-defined class data types appear in mixed case with initial caps, for example, `Progress.Lang.Object`. References to user-defined class data types appear in mixed case, as specified for a given application example.

Typographical conventions

This manual uses the following typographical conventions:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Bold typeface indicates commands or characters the user types, provides emphasis, or the names of user interface elements.</td>
</tr>
<tr>
<td><strong>Italic</strong></td>
<td>Italic typeface indicates the title of a document, or signifies new terms.</td>
</tr>
<tr>
<td>SMALL, BOLD CAPITAL LETTERS</td>
<td>Small, bold capital letters indicate OpenEdge key functions and generic keyboard keys; for example, <code>GET</code> and <code>CTRL</code>.</td>
</tr>
<tr>
<td>KEY1+KEY2</td>
<td>A plus sign between key names indicates a <strong>simultaneous</strong> key sequence: you press and hold down the first key while pressing the second key. For example, <code>CTRL+X</code>.</td>
</tr>
<tr>
<td>KEY1 KEY2</td>
<td>A space between key names indicates a <strong>sequential</strong> key sequence: you press and release the first key, then press another key. For example, <code>ESCAPE H</code>.</td>
</tr>
</tbody>
</table>

**Syntax:**

| Fixed width                 | A fixed-width font is used in syntax statements, code examples, system output, and filenames. |
| Fixed-width italics         | Fixed-width italics indicate variables in syntax statements. |
Examples of syntax descriptions

In this example, **ACCUM** is a keyword, and **aggregate** and **expression** are variables:

**Syntax**

```
ACCUM aggregate expression
```

**FOR** is one of the statements that can end with either a period or a colon, as in this example:

```
FOR EACH Customer:
  DISPLAY Name.
END.
```

In this example, **STREAM stream**, **UNLESS-HIDDEN**, and **NO-ERROR** are optional:
## Syntax

<table>
<thead>
<tr>
<th>DISPLAY</th>
<th>STREAM stream</th>
<th>UNLESS-HIDDEN</th>
<th>NO-ERROR</th>
</tr>
</thead>
</table>
In this example, the outer (small) brackets are part of the language, and the inner (large) brackets denote an optional item:

**Syntax**

\[
\text{INITIAL } [ \text{ constant } [, \text{ constant } ] ]
\]

A called external procedure must use braces when referencing compile-time arguments passed by a calling procedure, as shown in this example:

**Syntax**

\[
\{ \text{ &argument-name } \}
\]

In this example, \text{EACH}, \text{FIRST}, and \text{LAST} are optional, but you can choose only one of them:

**Syntax**

\[
\text{PRESELECT } [ \text{ EACH } | \text{ FIRST } | \text{ LAST } ] \text{ record-phrase}
\]

In this example, you must include two expressions, and optionally you can include more. Multiple expressions are separated by commas:

**Syntax**

\[
\text{MAXIMUM } ( \text{ expression } , \text{ expression } [, \text{ expression } ] ... )
\]

In this example, you must specify \text{MESSAGE} and at least one \text{expression} or \text{SKIP} \( (n) \), and any number of additional \text{expression} or \text{SKIP} \( (n) \) is allowed:

**Syntax**

\[
\text{MESSAGE } \{ \text{ expression } | \text{ SKIP } ( n ) \} ...
\]

In this example, you must specify \{\text{include-file}, then optionally any number of \text{argument} or \text{&argument-name} = "argument-value", and then terminate with \}:

**Syntax**

\[
\{ \text{ include-file } [ \text{ argument } | \text{ &argument-name} = "argument-value" ] ... \}
\]

**Long syntax descriptions split across lines**

Some syntax descriptions are too long to fit on one line. When syntax descriptions are split across multiple lines, groups of optional and groups of required items are kept together in the required order.
In this example, \texttt{WITH} is followed by six optional items:

**Syntax**

\begin{verbatim}
WITH [ ACCUM max-length ] [ expression DOWN ] [ CENTERED ] [ n COLUMNS ] [ SIDE-LABELS ] [ STREAM-IO ]
\end{verbatim}

Complex syntax descriptions with both required and optional elements

Some syntax descriptions are too complex to distinguish required and optional elements by bracketing only the optional elements. For such syntax, the descriptions include both braces (for required elements) and brackets (for optional elements).

In this example, \texttt{ASSIGN} requires either one or more \texttt{field} entries or one \texttt{record}. Options available with \texttt{field} or \texttt{record} are grouped with braces and brackets:

**Syntax**

\begin{verbatim}
ASSIGN { [ FRAME frame ] { field [ = expression ] } [ WHEN expression ] } ... 
| { record [ EXCEPT field ... ] }
\end{verbatim}

OpenEdge messages

OpenEdge displays several types of messages to inform you of routine and unusual occurrences:

- **Execution messages** inform you of errors encountered while OpenEdge is running a procedure; for example, if OpenEdge cannot find a record with a specified index field value.

- **Compile messages** inform you of errors found while OpenEdge is reading and analyzing a procedure before running it; for example, if a procedure references a table name that is not defined in the database.

- **Startup messages** inform you of unusual conditions detected while OpenEdge is getting ready to execute; for example, if you entered an invalid startup parameter.

After displaying a message, OpenEdge proceeds in one of several ways:

- Continues execution, subject to the error-processing actions that you specify or that are assumed as part of the procedure. This is the most common action taken after execution messages.

- Returns to the Procedure Editor, so you can correct an error in a procedure. This is the usual action taken after compiler messages.
• Halts processing of a procedure and returns immediately to the Procedure Editor. This does not happen often.

• Terminates the current session.

OpenEdge messages end with a message number in parentheses. In this example, the message number is 200:

```
** Unknown table name table. (200)
```

If you encounter an error that terminates OpenEdge, note the message number before restarting.

**Obtaining more information about OpenEdge messages**

In Windows platforms, use OpenEdge online help to obtain more information about OpenEdge messages. Many OpenEdge tools include the following Help menu options to provide information about messages:

• Choose Help → Recent Messages to display detailed descriptions of the most recent OpenEdge message and all other messages returned in the current session.

• Choose Help → Messages and then type the message number to display a description of a specific OpenEdge message.

• In the Procedure Editor, press the HELP key or F1.

**Third party acknowledgements**

OpenEdge includes AdventNet - Agent Toolkit licensed from AdventNet, Inc. http://www.adventnet.com. All rights to such copyright material rest with AdventNet.

OpenEdge includes ANTLR (Another Tool for Language Recognition) software Copyright © 2003-2006, Terence Parr All rights reserved. Neither the name of the author nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission. Software distributed on an “AS IS” basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License for the specific language governing rights and limitations under the License agreement that accompanies the product.

OpenEdge includes software developed by the Apache Software Foundation (http://www.apache.org/). Copyright © 1999 The Apache Software Foundation. All rights reserved (Xerces C++ Parser (XML) and Xerces2 Java Parser (XML)); Copyright © 1999-2002 The Apache Software Foundation. All rights reserved (Xerces Parser (XML); and Copyright © 2000-2003 The Apache Software Foundation. All rights reserved (Ant). The names “Apache,” “Xerces,” “ANT,” and “Apache Software Foundation” must not be used to endorse or promote products derived from this software without prior written permission. Products derived from this software may not be called “Apache”, nor may “Apache” appear in their name, without prior written
permission of the Apache Software Foundation. For written permission, please contact apache@apache.org. Software distributed on an “AS IS” basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License for the specific language governing rights and limitations under the License agreement that accompanies the product.

OpenEdge includes Concurrent Java software Copyright 1994-2000 Sun Microsystems, Inc. All Rights Reserved. -Neither the name of or trademarks of Sun may be used to endorse or promote products including or derived from the Java Software technology without specific prior written permission; and Redistributions of source or binary code must contain the above copyright notice, this notice and the following disclaimers: This software is provided “AS IS,” without a warranty of any kind. ALL EXPRESS OR IMPLIED CONDITIONS, REPRESENTATIONS AND WARRANTIES, INCLUDING ANY IMPLIED WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR NON-INFRINGEMENT, ARE HEREBY EXCLUDED. SUN MICROSYSTEMS, INC. AND ITS LICENSORS SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY LICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THE SOFTWARE OR ITS DERIVATIVES. IN NO EVENT WILL SUN MICROSYSTEMS, INC. OR ITS LICENSORS BE LIABLE FOR ANY LOST REVENUE, PROFIT OR DATA, OR FOR DIRECT, INDIRECT, SPECIAL, CONSEQUENTIAL, INCIDENTAL OR PUNITIVE DAMAGES, HOWEVER CAUSED AND REGARDLESS OF THE THEORY OF LIABILITY, ARISING OUT OF THE USE OF OR INABILITY TO USE SOFTWARE, EVEN IF SUN MICROSYSTEMS, INC. HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

OpenEdge includes DataDirect software Copyright © 1991-2007 Progress Software Corporation and/or its subsidiaries or affiliates. All Rights Reserved. (DataDirect Connect for JDBC Type 4 driver); Copyright © 1993-2009 Progress Software Corporation and/or its subsidiaries or affiliates. All Rights Reserved. (DataDirect Connect for JDBC); Copyright © 1988-2007 Progress Software Corporation and/or its subsidiaries or affiliates. All Rights Reserved. (DataDirect Connect for ODBC); and Copyright © 1988-2007 Progress Software Corporation and/or its subsidiaries or affiliates. All Rights Reserved. (DataDirect Connect64 for ODBC).

OpenEdge includes DataDirect Connect for ODBC and DataDirect Connect64 for ODBC software, which include ICU software 1.8 and later - Copyright © 1995-2003 International Business Machines Corporation and others All rights reserved. Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, provided that the above copyright notice(s) and this permission notice appear in all copies of the Software and that both the above copyright notice(s) and this permission notice appear in supporting documentation.

OpenEdge includes DataDirect Connect for ODBC and DataDirect Connect64 for ODBC software, which include software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/). Copyright © 1998-2006 The OpenSSL Project. All rights reserved. And Copyright © 1995-1998 Eric Young (eay@cryptsoft.com). All rights reserved.

OpenEdge includes DataDirect products for the Microsoft SQL Server database which contain a licensed implementation of the Microsoft TDS Protocol.
OpenEdge includes software authored by David M. Gay. Copyright © 1991, 2000, 2001 by Lucent Technologies (dtoa.c); Copyright © 1991, 1996 by Lucent Technologies (g_fmt.c); and Copyright © 1991 by Lucent Technologies (rnd_prod.s). Permission to use, copy, modify, and distribute this software for any purpose without fee is hereby granted, provided that this entire notice is included in all copies of any software which is or includes a copy or modification of this software and in all copies of the supporting documentation for such software. THIS SOFTWARE IS BEING PROVIDED "AS IS", WITHOUT ANY EXPRESS OR IMPLIED WARRANTY. IN PARTICULAR, NEITHER THE AUTHOR NOR LUCENT MAKES ANY REPRESENTATION OR WARRANTY OF ANY KIND CONCERNING THE MERCHANTABILITY OF THIS SOFTWARE OR ITS FITNESS FOR ANY PARTICULAR PURPOSE.

OpenEdge includes software authored by David M. Gay. Copyright © 1998-2001 by Lucent Technologies All Rights Reserved (decstrtod.c; strtodg.c); Copyright © 1998, 2000 by Lucent Technologies All Rights Reserved (decstrtof.c; strtod.c); Copyright © 1998 by Lucent Technologies All Rights Reserved (dmisc.c; gdtoa.h; gethex.c; gmisc.c; sum.c); Copyright © 1998, 1999 by Lucent Technologies All Rights Reserved (gdtoa.c; misc.c; smisc.c; ulp.c); Copyright © 1998-2000 by Lucent Technologies All Rights Reserved (gdtoaimp.h); Copyright © 2000 by Lucent Technologies All Rights Reserved (hd_init.c). Full copies of these licenses can be found in the installation directory, in the c:/OpenEdge/licenses folder. Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appear in all copies and that both that the copyright notice and this permission notice and warranty disclaimer appear in supporting documentation, and that the name of Lucent or any of its entities not be used in advertising or publicity pertaining to distribution of the software without specific, written prior permission. LUCENT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL LUCENT OR ANY OF ITS ENTITIES BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

OpenEdge includes http package software developed by the World Wide Web Consortium. Copyright © 1994-2002 World Wide Web Consortium, (Massachusetts Institute of Technology, European Research Consortium for Informatics and Mathematics, Keio University). All rights reserved. This work is distributed under the W3C® Software License [http://www.w3.org/Consortium/Legal/2002/copyright-software-20021231] in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

OpenEdge includes ICU software 1.8 and later - Copyright © 1995-2003 International Business Machines Corporation and others All rights reserved. Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, provided that the above copyright notice(s) and this permission
notice appear in all copies of the Software and that both the above copyright notice(s) and this permission notice appear in supporting documentation.


OpenEdge includes Infragistics NetAdvantage for .NET v2009 Vol 2 Copyright © 1996-2009 Infragistics, Inc. All rights reserved.

OpenEdge includes JSTL software Copyright 1994-2006 Sun Microsystems, Inc. All Rights Reserved. Software distributed on an “AS IS” basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License for the specific language governing rights and limitations under the License agreement that accompanies the product.

OpenEdge includes OpenSSL software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/). Copyright © 1998-2007 The OpenSSL Project. All rights reserved. This product includes cryptographic software written by Eric Young (eay@cryptsoft.com). This product includes software written by Tim Hudson (tjh@cryptsoft.com). Copyright © 1995-1998 Eric Young (eay@cryptsoft.com) All rights reserved. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to endorse or promote products derived from this software without prior written permission. For written permission, please contact openssl-core@openssl.org. Products derived from this software may not be called "OpenSSL" nor may "OpenSSL" appear in their names without prior written permission of the OpenSSL Project. Software distributed on an “AS IS” basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License for the specific language governing rights and limitations under the License agreement that accompanies the product.

OpenEdge includes Quartz Enterprise Job Scheduler software Copyright © 2001-2003 James House. All rights reserved. Software distributed on an “AS IS” basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License for the specific language governing rights and limitations under the License agreement that accompanies the product. This product uses and includes within its distribution, software developed by the Apache Software Foundation (http://www.apache.org/).

OpenEdge includes code licensed from RSA Security, Inc. Some portions licensed from IBM are available at http://oss.software.ibm.com/icu4j/.

OpenEdge includes the RSA Data Security, Inc. MD5 Message-Digest Algorithm. Copyright ©1991-2, RSA Data Security, Inc. Created 1991. All rights reserved.

OpenEdge includes Sonic software, which includes software developed by Apache Software Foundation (http://www.apache.org/). Copyright © 1999-2000 The Apache Software Foundation. All rights reserved. The names “Ant”, “Axis”, “Xalan,” “FOP,” “The Jakarta Project”, “Tomcat”, “Xerces” and/or “Apache Software Foundation” must not be used to endorse or promote products derived from the Product without prior written permission. Any product derived from the Product may not be called “Apache”, nor may “Apache” appear in their name, without prior written permission. For written permission, please contact apache@apache.org.

OpenEdge includes Sonic software, which includes software Copyright © 1999 CERN - European Organization for Nuclear Research. Permission to use, copy, modify,
distribute and sell this software and its documentation for any purpose is hereby
granted without fee, provided that the above copyright notice appear in all copies and
that both that copyright notice and this permission notice appear in supporting
documentation. CERN makes no representations about the suitability of this software
for any purpose. It is provided "as is" without expressed or implied warranty.

OpenEdge includes Sonic software, which includes software developed by ExoLab
Project (http://www.exolab.org/). Copyright © 2000 Intalio Inc. All rights reserved. The
names “Castor” and/or “ExoLab” must not be used to endorse or promote products
derived from the Products without prior written permission. For written permission,
please contact info@exolab.org. Exolab, Castor and Intalio are trademarks of Intalio
Inc.

OpenEdge includes Sonic software, which includes software developed by IBM.
Copyright © 1995-2003 International Business Machines Corporation and others. All
rights reserved. Permission is hereby granted, free of charge, to any person obtaining
a copy of this software and associated documentation files (the "Software"), to deal in
the Software without restriction, including without limitation the rights to use, copy,
modify, merge, publish, distribute, and/or sell copies of the Software, and to permit
persons to whom the Software is furnished to do so, provided that the above copyright
notice(s) and this permission notice appear in all copies of the Software and that both
the above copyright notice(s) and this permission notice appear in supporting
documentation. Software distributed on an “AS IS” basis, WITHOUT WARRANTY OF
ANY KIND, either express or implied. See the License for the specific language
governing rights and limitations under the License agreement that accompanies the
product. Except as contained in this notice, the name of a copyright holder shall not be
used in advertising or otherwise to promote the sale, use or other dealings in this
Software without prior written authorization of the copyright holder.

OpenEdge includes Sonic software, which includes the JMX Technology from Sun
Microsystems, Inc. Use and Distribution is subject to the Sun Community Source

OpenEdge includes Sonic software, which includes software developed by the
ModelObjects Group. All rights reserved. The name “ModelObjects” must not be used
to endorse or promote products derived from this software without prior written
permission. Products derived from this software may not be called “ModelObjects”, nor
may “ModelObjects” appear in their name, without prior written permission. For written
permission, please contact djacobs@modelobjects.com.

OpenEdge includes Sonic software, which includes code licensed from Mort Bay
Consulting Pty. Ltd. The Jetty Package is Copyright © 1998 Mort Bay Consulting Pty.
Ltd. (Australia) and others.

OpenEdge includes Sonic software, which includes files that are subject to the
Netscape Public License Version 1.1 (the “License”); you may not use this file except
in compliance with the License. You may obtain a copy of the License at
http://www.mozilla.org/NPL/. Software distributed under the License is distributed
on an “AS IS” basis, WITHOUT WARRANTY OF ANY KIND, either express or implied.
See the License for the specific language governing rights and limitations under the
License. The Original Code is Mozilla Communicator client code, released March 31,
1998. The Initial Developer of the Original Code is Netscape Communications
OpenEdge includes Sonic software, which includes software developed by the University Corporation for Advanced Internet Development (UCAID) project. Copyright © 2002 University Corporation for Advanced Internet Development, Inc. All rights reserved. Neither the name of UCAID nor the names of its contributors, nor Internet2, nor the University Corporation for Advanced Internet Development, Inc., nor UCAID may be used to endorse or promote products derived from this software and products derived from this software may not be called OpenSAML, Internet2, UCAID, or the University Corporation for Advanced Internet Development, or may OpenSAML appear in their name without prior written permission of the University Corporation for Advanced Internet Development. For written permission, please contact opensaml@opensaml.org.

OpenEdge includes the UnixWare platform of Perl Runtime authored by Kiem-Phong Vo and David Korn. Copyright © 1991, 1996 by AT&T Labs. Permission to use, copy, modify, and distribute this software for any purpose without fee is hereby granted, provided that this entire notice is included in all copies of any software which is or includes a copy or modification of this software and in all copies of the supporting documentation for such software. THIS SOFTWARE IS BEING PROVIDED “AS IS”, WITHOUT ANY EXPRESS OR IMPLIED WARRANTY. IN PARTICULAR, NEITHER THE AUTHORS NOR AT&T LABS MAKE ANY REPRESENTATION OR WARRANTY OF ANY KIND CONCERNING THE MERCHANTABILITY OF THIS SOFTWARE OR ITS FITNESS FOR ANY PARTICULAR PURPOSE.

OpenEdge includes Vermont Views Terminal Handling Package software developed by Vermont Creative Software. Copyright © 1988-1991 by Vermont Creative Software.

OpenEdge includes XML Tools, which includes versions 8.9 of the Saxon XSLT and XQuery Processor from Saxonica Limited (http://www.saxonica.com/) which are available from SourceForge (http://sourceforge.net/projects/saxon/). The Original Code of Saxon comprises all those components which are not explicitly attributed to other parties. The Initial Developer of the Original Code is Michael Kay. Until February 2001 Michael Kay was an employee of International Computers Limited (now part of Fujitsu Limited), and original code developed during that time was released under this license by permission from International Computers Limited. From February 2001 until February 2004 Michael Kay was an employee of Software AG, and code developed during that time was released under this license by permission from Software AG, acting as a "Contributor". Subsequent code has been developed by Saxonica Limited, of which Michael Kay is a Director, again acting as a "Contributor". A small number of modules, or enhancements to modules, have been developed by other individuals (either written especially for Saxon, or incorporated into Saxon having initially been released as part of another open source product). Such contributions are acknowledged individually in comments attached to the relevant code modules. All Rights Reserved. The contents of the Saxon files are subject to the Mozilla Public License Version 1.0 (the "License"); you may not use these files except in compliance with the License. You may obtain a copy of the License at http://www.mozilla.org/MPL/ and a copy of the license can also be found in the installation directory, in the c:/OpenEdge/licenses folder. Software distributed under the License is distributed on an "AS IS" basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License for the specific language governing rights and limitations under the License.
OpenEdge includes XML Tools, which includes Xs3P v1.1.3. The contents of this file are subject to the DSTC Public License (DPL) Version 1.1 (the “License”); you may not use this file except in compliance with the License. A copy of the license can be found in the installation directory, in the c:/OpenEdge/licenses folder. Software distributed under the License is distributed on an “AS IS” basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License for the specific language governing rights and limitations under the License. The Original Code is xs3p. The Initial Developer of the Original Code is DSTC. Portions created by DSTC are Copyright © 2001, 2002 DSTC Pty Ltd. All rights reserved.

OpenEdge includes YAJL software Copyright 2007, Lloyd Hilaiel. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: 1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. 2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. 3. Neither the name of Lloyd Hilaiel nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission. THIS SOFTWARE IS PROVIDED BY THE AUTHOR “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
The OpenEdge AppBuilder tool is a Rapid Application Prototyping/Development (RAP/RAD) tool. The main component of AppBuilder is a What-You-See-Is-What-You-Get (WYSIWYG) interface layout editor.

The following sections briefly introduce some basic concepts, and describe the AppBuilder and its place in the ABL (Advanced Business Language) application programmer’s toolkit:

• OpenEdge Application Development Model
• Concepts and terminology
• What is smart about SmartObjects?
• Visible versus nonvisible objects
• Widgets
• Reading and writing ABL widgets
• Inter-object communication: signatures
• Anatomy of a database application
• Working with AppBuilder
• Single-window or multi-window design?
• Designing for character-based environments
• Building an application in AppBuilder
AppBuilder is part of the Application Development Model (ADM) architecture.

AppBuilder simplifies your application programming effort by:

- Supporting drag-and-drop layout of interface elements.
- Creating the object description and initialization code on your behalf.
- Helping you create and manage the integrating code.

Today’s desktop computers offer more raw power than even supercomputers did thirty years ago. Programmers are now routinely being tasked to produce applications that were once hardly imaginable, and they are falling behind. The demand for new software overwhelms the capacity of programmers to create it using traditional methodologies.

The ADM addresses this issue by emphasizing object-oriented reusability.

The ADM supports the creation of large-scale, reusable application building blocks that are able to communicate with one another in well-defined ways. Once the blocks have been created, application programmers can assemble them into new applications in a fraction of the time it would require to create the applications from scratch. This is the principle of the run-time library: avoid having to repeat the same or a similar development effort each time. Spend the time and energy only once. Create sophisticated general-purpose modules, and then reuse them over and over again.

The ADM architecture has four basic components:

- A hierarchical set of object classes from which to develop reusable components.
- A defined methodology for inter-object communication.
- A way to set object properties using public data.
- “Super procedures,” analogous to dynamically linked libraries, that implement object behaviors.

For detailed information about the Application Development Model, see OpenEdge Development: ADM and SmartObjects. The related API reference is OpenEdge Development: ADM Reference.
Concepts and terminology

You will find it easier to use AppBuilder if you understand some related concepts and terminology.

External versus internal procedures

In ABL terminology, external procedure is the usual term for a separate subprogram module that exists as a set of related files on disk and can be independently developed and compiled. An external procedure is not a procedure in the sense of being a defined ABL subprogram that begins with the reserved word **PROCEDURE** or **FUNCTION**, but it is callable in much the same way. An external procedure’s main filename serves as its identifier, and you can use it in references; for example:

```
RUN example.w.
```

External procedures typically have some number of internal procedures and functions defined locally to them. Because these internal procedures and functions implement the external procedure’s repertoire of behaviors, they are often known as methods. They are defined as normal ABL subprograms and begin with one of the reserved words **PROCEDURE** or **FUNCTION**.

AppBuilder objects

AppBuilder provides for your use a full array of basic ABL objects, several powerful ADM SmartObjects, and even three ActiveX (OCX) objects.

Basic objects are objects that are available directly as part of ABL, for example in a **VIEW-AS** clause. Some are very basic indeed—static rectangles, for example—while others, such as Editors, can be quite complex underneath.
Table 1 lists the basic ABL objects available in AppBuilder. The descriptions represent how the objects appear under Windows.

<table>
<thead>
<tr>
<th>Role</th>
<th>Object</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Organizer</td>
<td>Window</td>
<td>The outermost organizer object. It is not modal, can have a menu bar and pulldowns, and can parent all other objects.</td>
</tr>
<tr>
<td></td>
<td>Dialog box</td>
<td>Technically a type of frame with its own dedicated window. Dialog boxes are modal, cannot have a menu bar, cannot be resized, and must be parented by a window. You typically use them for capturing user input on a specific issue.</td>
</tr>
<tr>
<td>Frame</td>
<td></td>
<td>An object that delimits a rectangular area and defines a TAB-traversal group. Frames can have their own border and title bar. You can use frames to organize and display other objects.</td>
</tr>
<tr>
<td>Rectangle</td>
<td></td>
<td>A static object that visually delimits a rectangular area. You can use a rectangle to group other objects for emphasis. A rectangle does not define a traversal group or have any active characteristics; it is purely a visual object.</td>
</tr>
<tr>
<td>Data access</td>
<td>Query</td>
<td>A group of related instructions that tell OpenEdge to find a subset of records from one or more database tables. This is a standalone object, but several objects have a query function embedded in them.</td>
</tr>
<tr>
<td>Data display and capture</td>
<td>Data browser</td>
<td>An object that displays the results of a database query in row/column tabular format. Each row represents a record, and each column a field. Usually called a browse widget.</td>
</tr>
<tr>
<td>Role</td>
<td>Object</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Combo box</td>
<td>An object that combines a fill-in with a selection list. The fill-in shows the current value. The user can set the value by typing into the fill-in, or by picking an item from those in the list.</td>
<td></td>
</tr>
<tr>
<td>Data viewer</td>
<td>An object that displays the results of a database query one record at a time, using one fill-in per field. Also called a DB-Fields widget.</td>
<td></td>
</tr>
<tr>
<td>Editor</td>
<td>A field-level object that allows editing of large (typically multi-line) character fields. By default, editors support features such as cut, copy, paste, and word-wrap.</td>
<td></td>
</tr>
<tr>
<td>Fill-in (Edit box)</td>
<td>A field-level object that accepts user input, typically a single line of text. The system evaluates that text, possibly performing additional processing such as type conversion and validation, and assigns the result to a database field or a variable.</td>
<td></td>
</tr>
<tr>
<td>Radio-button set</td>
<td>A group of buttons representing a set of values for a variable, only one of which can be valid at a given time. Selecting a button automatically deselects the previous choice.</td>
<td></td>
</tr>
<tr>
<td>Selection list (pick list)</td>
<td>A scrollable list of character strings. The strings are the possible values for an underlying field or variable. You can use a selection list to allow an end user to select one or several items from a predetermined list of character values.</td>
<td></td>
</tr>
<tr>
<td>Slider control</td>
<td>A virtual knob that the user moves along a track. The track represents some subrange of an integer; a built-in readout displays the current value. Note: You can assign a slider to visualize an INTEGER or INT64 field or variable. However, the slider cannot display values less than (-32,768) and greater than (32,767).</td>
<td></td>
</tr>
<tr>
<td>Toggle box (check box)</td>
<td>A small, square box that represents a logical value. You can use groups of check boxes to represent sets of properties.</td>
<td></td>
</tr>
</tbody>
</table>
SmartObjects are much more complex than the objects listed in Table 1. True subprogram modules, SmartObjects are external procedures that may contain hundreds of lines of ABL code in themselves and their superprocedures. All SmartObjects are implemented as external procedures, but only those external procedures based on the file `smart.i` qualify as SmartObjects.

Table 2 lists the SmartObjects available in the current release, and the abbreviations used elsewhere in this document.

### Table 1: Basic ABL object types

<table>
<thead>
<tr>
<th>Role</th>
<th>Object</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Action control</td>
<td>Button (button)</td>
<td>A field-level object that a user typically selects to invoke some action. AppBuilder offers one generic button plus others predefined for special purposes.</td>
</tr>
<tr>
<td>Other</td>
<td>Text object (static text)</td>
<td>Standalone text that is not bound to any other object, though it might appear to be.</td>
</tr>
<tr>
<td></td>
<td>Image object (static image)</td>
<td>A static field-level object used to display a bitmap from a graphics file. ABL supports many different graphic formats under Windows.</td>
</tr>
</tbody>
</table>

### Table 2: SmartObject types

<table>
<thead>
<tr>
<th>Role</th>
<th>SmartObject</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Organizer</td>
<td>SmartWindow (SWin)</td>
<td>Outermost Smart organizer object. Acts as a container and integrator for other objects, including other SmartContainers such as SmartFrames, etc.</td>
</tr>
<tr>
<td></td>
<td>SmartDialog (SDialog)</td>
<td>A Smart, special-purpose frame object supported by a dedicated window.</td>
</tr>
<tr>
<td></td>
<td>SmartFrame (SFrame)</td>
<td>Allows you to create reusable Smart layouts not suited to implementation as SmartDialogs.</td>
</tr>
<tr>
<td></td>
<td>SmartFolder (SFolder)</td>
<td>Implements the tabbed-file-folder metaphor for managing paged interface displays.</td>
</tr>
<tr>
<td></td>
<td>Simple SmartContainer (SSC)</td>
<td>Provides all functionality from the SmartContainer class without the overhead of a visible window. Useful for modules that can operate unattended in the background.</td>
</tr>
</tbody>
</table>
## Concepts and terminology

### DataView
An object that provides data binding between a ProDataSet and ADM visual components.

### SmartDataObject (SDO)
A query interface to a database. This object, available in both static and dynamic forms, supplies the data stream used by other objects such as the SmartDataViewer or the SmartDataBrowser. An SDO has no visible representation at run time.

### SmartBusinessObject (SBO)
A dedicated organizer object that integrates up to 20 SDOs, providing a single point of contact for other objects. In addition, the SBO allows you to update from multiple SDOs in a single server-side transaction.

### SmartFilter (SFilter)
A dynamic record-filtering object, visible at run time. Offers the user the ability to focus the associated SmartDataObject's query as tightly as desired.

### SmartDataBrowser (SDB)
Encapsulates a browse widget to view and possibly update data. Displays in a row/column format, and can present the fields for multiple records simultaneously.

### SmartDataViewer (SDV)
Presents a set of fields representing a single record. You can order and arrange the fields visually in any way that meets your needs.

### SmartDataField (SDF)
Adds special-purpose functionality to a SDV on a per-field basis. The special functionality can be of any desired sophistication.

### SmartLOBField
A specialized SmartDataField that allows users to add Large Object (LOB) fields that do not use the default visualization.

### SmartSelect (SSelect)
A specialized SmartDataField representing a data-driven pick list. You would use it for updating a field in one table based on the values drawn from a related table.

### Table 2: SmartObject types (2 of 3)

<table>
<thead>
<tr>
<th>Role</th>
<th>SmartObject</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data access</td>
<td>DataView</td>
<td>An object that provides data binding between a ProDataSet and ADM visual components.</td>
</tr>
<tr>
<td>SmartDataObject (SDO)</td>
<td></td>
<td>A query interface to a database. This object, available in both static and dynamic forms, supplies the data stream used by other objects such as the SmartDataViewer or the SmartDataBrowser. An SDO has no visible representation at run time.</td>
</tr>
<tr>
<td>SmartBusinessObject (SBO)</td>
<td></td>
<td>A dedicated organizer object that integrates up to 20 SDOs, providing a single point of contact for other objects. In addition, the SBO allows you to update from multiple SDOs in a single server-side transaction.</td>
</tr>
<tr>
<td>SmartFilter (SFilter)</td>
<td></td>
<td>A dynamic record-filtering object, visible at run time. Offers the user the ability to focus the associated SmartDataObject's query as tightly as desired.</td>
</tr>
<tr>
<td>Data display and capture</td>
<td>SmartDataBrowser (SDB)</td>
<td>Encapsulates a browse widget to view and possibly update data. Displays in a row/column format, and can present the fields for multiple records simultaneously.</td>
</tr>
<tr>
<td>SmartDataViewer (SDV)</td>
<td></td>
<td>Presents a set of fields representing a single record. You can order and arrange the fields visually in any way that meets your needs.</td>
</tr>
<tr>
<td>SmartDataField (SDF)</td>
<td></td>
<td>Adds special-purpose functionality to a SDV on a per-field basis. The special functionality can be of any desired sophistication.</td>
</tr>
<tr>
<td></td>
<td>SmartLOBField</td>
<td>A specialized SmartDataField that allows users to add Large Object (LOB) fields that do not use the default visualization.</td>
</tr>
<tr>
<td></td>
<td>SmartSelect (SSelect)</td>
<td>A specialized SmartDataField representing a data-driven pick list. You would use it for updating a field in one table based on the values drawn from a related table.</td>
</tr>
</tbody>
</table>
In addition to basic ABL objects and SmartObjects, AppBuilder also supports the ActiveX object type. ActiveX (OCX) objects resemble SmartObjects in implementing complex functionality, but are defined on Microsoft's ActiveX standard rather than the ADM. ActiveX components are available from many third-party sources.

<table>
<thead>
<tr>
<th>Role</th>
<th>SmartObject</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data communication</td>
<td>SmartB2BObject (SBB)</td>
<td>Transforms message-body blocks of data between ABL and XML representations based on a protocol (mapping) file that you create.</td>
</tr>
<tr>
<td></td>
<td>SmartSender (SSndr) and</td>
<td></td>
</tr>
<tr>
<td></td>
<td>SmartReceiver (SRcvcr)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Transforms message-body blocks of data in ways that you define. The code you write can be anything from no-ops to the most sophisticated transformations; these are very general tools.</td>
</tr>
<tr>
<td></td>
<td>SmartRouter (SRtr)</td>
<td>Determines which SBB should handle some message received by a SmartConsumer, and starts that object.</td>
</tr>
<tr>
<td></td>
<td>SmartProducer (SProdr) and</td>
<td>These objects are the SmartObject interface to the SonicMQ messaging system. The SProdr creates message bodies for use by other objects, and inserts them into the message system when complete. The SConsr watches the inbound pipelines and passes incoming messages upstream for processing.</td>
</tr>
<tr>
<td></td>
<td>SmartConsumer (SConsr)</td>
<td></td>
</tr>
<tr>
<td>Action Control</td>
<td>SmartToolbar (STB)</td>
<td>A general-purpose control object, optionally combining a menu-bar system with a toolbar object.</td>
</tr>
<tr>
<td>Other</td>
<td>Simple SmartObject (SSO)</td>
<td>An unfinished object that serves as a basis for new SmartObject types that you might wish to define.</td>
</tr>
</tbody>
</table>
Table 3 lists the ActiveX (OCX) objects AppBuilder provides for your use.

<table>
<thead>
<tr>
<th>Role</th>
<th>ActiveX object</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data display and capture</td>
<td>Combo box</td>
<td>An object that combines a fill-in with a hidden selection list. Once the user makes the selection list visible by pressing the associated button, choosing from the listed items sets the current value of the fill-in.</td>
</tr>
<tr>
<td></td>
<td>Spin control</td>
<td>Two opposed buttons and an optional readout field. Operating one of the buttons changes the value of the object either up or down.</td>
</tr>
<tr>
<td>Other</td>
<td>Timer</td>
<td>Generates an event at some regular interval that you specify.</td>
</tr>
</tbody>
</table>
What is smart about SmartObjects?

SmartObjects are not smart in any artificial-intelligence sense. They are smart only in comparison with basic objects. As ADM-compliant objects, they can all communicate with one another through SmartLinks, and as external-procedure objects, they can have any amount of sophistication the developer chooses to provide. If using ABL rather than a 3GL corresponds to using large- rather than medium-scale chip integration for building hardware, then using SmartObjects in your applications is like using VLSI chips rather than LSI. The building blocks are bigger and more capable, you can hook them together more easily, and they require less unit testing.

Table 4 summarizes some of the advantages of using SmartObjects.

Table 4: Benefits of using SmartObjects

<table>
<thead>
<tr>
<th>Benefit</th>
<th>Feature</th>
</tr>
</thead>
<tbody>
<tr>
<td>Quicker results</td>
<td>Allows you to assemble more sophisticated applications in less time, since each SmartObject master is a predefined application component that can encapsulate more complex functionality than an individual Basic object.</td>
</tr>
<tr>
<td>Easier integration</td>
<td>Makes it easier to integrate individual object instances into applications because the ADM gives SmartObjects standardized ways of interacting with each other.</td>
</tr>
<tr>
<td>More reusability</td>
<td>Creates code that can be used repeatedly because a single object can have multiple run-time instances.</td>
</tr>
<tr>
<td>Easier maintenance</td>
<td>Organizes your development process so that complex applications are easy to maintain. SmartObject code is more maintainable because:</td>
</tr>
<tr>
<td></td>
<td>• Changes to any SmartObject master files are automatically reflected in all instances of that SmartObject.</td>
</tr>
<tr>
<td></td>
<td>• Each object can be written without specific knowledge of other objects. Modules that are independent in this way are referred to as being “loosely coupled,” a desirable trait.</td>
</tr>
<tr>
<td>Greater consistency</td>
<td>Establishes a consistent look and feel across multiple applications because different applications can instantiate the same SmartObject master. This consistency makes it easier for you to create a special corporate image for your customers, if you choose.</td>
</tr>
</tbody>
</table>
Visible versus nonvisible objects

Although the majority of building blocks used in a database application might be associated with the GUI presentation, not all are. The modules that read and write the database, for example, generally operate behind the scenes. There is usually no reason to give those operations a visible representation at run time. But at design time, the situation is different. Programmers require easy access to all building blocks. For your convenience, AppBuilder makes every building block visible in some way at design time, even those that are not visible at run time.

The design-time representation of visible objects is nearly identical to their run-time representation. This means that you can usually position and size them in a WYSIWYG manner.

The design-time representation of a nonvisible SmartObject is a small, borderless area containing the object's filename, an icon that identifies the object's class, and a menu button. Figure 1 is an example of how a nonvisible SmartObject appears at design time. (The eight small black squares are the resizing handles that appear when the object is selected.)

All SmartObjects display a Menu button (sometimes called a Ventilator button) as part of their design-time representation. The menu under the Menu button, shown in Figure 2, provides access to the object's property sheets, SmartLinks, and master definition.

Other nonvisible objects are generally represented by simple, abstract icons. They exhibit little commonality in the details of their appearance.
Widgets

The word *widget* is a synonym for thing or item; it is a generic reference. In recent years, widget has become a widely used term among programmers for a user-interface element. ABL follows this convention.

In its role as a WYSIWYG layout editor, AppBuilder provides a design-time user-interface element even for objects that are neither part of the run-time user interface nor even visible at run time. In this guide, therefore, the term widget will be used freely as a synonym for object or building block, regardless of whether it is a widget in the ABL sense of the term.
Reading and writing ABL widgets

When you use AppBuilder, you manipulate widgets in a largely WYSIWYG fashion, and AppBuilder generates the ABL code later to make it all work as you intend. Because of this, it is natural and convenient to think of the widgets themselves as being the variables they represent. AppBuilder encourages this by using the widget identifier as the storage identifier. Thus, when you place into the workspace a slider widget, for example, identifying it as object iExampleSlider that displays a certain integer subrange, AppBuilder later generates an ABL statement such as the following:

```
DEFINE iExampleSlider AS INTEGER INITIAL 0
    VIEW-AS SLIDER MIN-VALUE 0 MAX-VALUE 16384.
```

The syntax of this statement can give the impression to a programmer familiar with other languages that, in the ABL Virtual Machine (AVM), basic widgets are mere visual expressions of data (VIEW-AS) handled entirely at the level of the r-code interpreter. If that were so, then an assignment statement such as:

```
iExampleSlider = 8192.
```

Would immediately cause (in this example) the knob of the slider widget to move halfway up the track.

The actual situation is slightly more complicated.

Each widget represents two storage locations, not one. There is the storage location that you identify with the widget when you create the instance—iExampleSlider in the example—plus an anonymous storage location conceptually allocated in the system display buffer. These locations—main memory and screen display—are independent of one another, from the standpoint of your code.

User keyboard and mouse actions modify the anonymous location in the display buffer; assignment statements modify the identified location in main memory. A change made to one of the locations is not automatically reflected in the other location. You must explicitly close that gap by copying changes from one storage location to the other whenever required by the logic of your program.

If you want changes made to a variable to appear on the display, use DISPLAY:

```
iExampleSlider = 8192.
DISPLAY iExampleSlider WITH FRAME fMain.
/* replace fMain with the actual identifier of the frame that encloses the iExampleSlider widget */
```

If you want changes made to the display to reflect in the variable, use ASSIGN:

```
/* copy the current value from the anonymous location */
ASSIGN iExampleSlider.
/* insert code here that uses the widget value */
```
The benefit of such a disconnected model is speed. Since device I/O is very slow compared to operations on memory, it is better not to do device I/O except when necessary. The AVM I/O model helps you manage that problem.

**Note:** ABL is much more complex, sophisticated, and adaptable than this brief introduction might imply. **DISPLAY** and **ASSIGN** are not the only routines that can move data between the two storage locations. Use this information as a way to make things happen while you are learning more subtle methods.
Inter-object communication: signatures

SmartObjects that pass database fields back and forth have embedded in them a string called a *signature*. A signature is a shorthand description of the fields the objects are prepared to supply or accept. Only if signatures match will the SmartObjects transfer data. Signature checking reduces the possibility of confusion and data corruption.

To be sure your SmartObjects can continue to successfully pass data back and forth, always recompile them after making a change to a data stream. For more information, see the “Making changes to the data stream” section on page 186.
Chapter 1: Introduction

Anatomy of a database application

Although each application differs greatly in detail, there is an underlying framework that can be represented as:

- Finding certain records in a database.
- Displaying them.
- Modifying them.
- Updating the records in the database.

Finding records involves opening a database file and searching through it for records that have certain characteristics. The desired characteristics are defined in a query. A query might be as simple as “get all records” or highly complex, involving comparisons on many different fields in a multitude of records.

Records returned by a query can be displayed in tabular format for easy browsing, formatted in a more complex way suitable for editing, or used to generate, for example, mailing labels.

Modifying a record is a simple clerical process on one level. But because humans are involved, mistakes are virtually guaranteed to occur. A careful developer will account for this fact and take steps to check the changes being made, insofar as checking is practical.

Once changes have been made, the modified records must be written back to the database. This can be done immediately, for simple updates, or buffered to a staging area as part of a more complex transaction process.

AppBuilder supports objects that address all four steps in this framework.
Working with AppBuilder

Creating an application with the help of AppBuilder is a four-step process:

1. Design your application on paper.
2. Create organizer windows and populate them.
3. Add additional glue and supporting code.
4. Test and refine the result.

AppBuilder can help with steps 2 through 4. Application design is beyond the current scope of this guide. The design process has both a technical and a usability aspect, and those developers who pay attention to both are generally the most successful.

There are a number of formal tools and methodologies that can help with technical design. Use whichever seems best. At present, however, there are no similar tools to help you make your application easy and pleasant to use. The best advice is to test your design assumptions early and often with real users. There are books on usable software design that can help acquaint you with those techniques.
Single-window or multi-window design?

A basic part of your application-design process will be to decide whether to use a single window or several. SmartWindows offer you the additional option of multiplexing your space by paging within a single window—a process that resembles using overlays.

There is no simple answer to this single-versus-many design question. A full discussion of the tradeoffs involved is beyond the current scope of this guide. One way to begin thinking about the question, though, is to consider how much natural parallelism is involved in the problem your application will address.

Single-window designs are often best for applications that deal with:

- A single, highly serial problem.
- Multiple tasks that are largely unrelated.

Multi-window designs might work well for applications that present separable but related clusters of functionality.

Multiplexed (paged, paneled) designs may seem the most natural choice for applications that require a mixed interface, where there is a certain core functionality that remains in view while another part of the window changes in a task-oriented way.

No matter what you choose, you will probably find that you can make legitimate arguments for a different choice. The advantages of one design over another are typically relative, not absolute. For example, AppBuilder itself uses a multi-window design (main, palette, workspace), yet it is not hard to imagine it as a single-window design instead.

Multi-window applications are generally somewhat more difficult to design and develop. You might decide during the design phase of the project that there are advantages to a multi-window design, but that they are outweighed by the practical difficulties. Or you might decide that the advantages you could offer your customer make a multi-window design well worth the extra effort required to create it.
Designing for character-based environments

Applications you develop using ABL are automatically capable of running in both GUI and character environments. But character environments have a much coarser granularity than GUI environments. It is simply not possible to do as much in a (typically) 80x21 character grid as in the more subtle context of a graphics display, and some widgets cannot be represented at all in a character environment. Moreover, the character environment cannot support multi-window designs. For that reason, you should pay careful attention to design when creating an application that will run in both GUI and character environments.

AppBuilder will support you whether you choose to design specifically for each environment, or create a single code base for deployment to all environments. See Appendix B, “Multiple Layouts” for a discussion of creating multiple layouts from a single code base.
Building an application in AppBuilder

Before learning more about the underlying components of AppBuilder, consider the toy application shown below. This application uses four basic ABL objects and five SmartObjects. Figure 3 shows the application as it appears at design time, and Figure 4 at run time.

This application illustrates some important features of AppBuilder:

- The SmartWindow is an organizer object and a member of the class SmartContainer. SmartContainers supply an integrating context for other SmartObjects. Higher-level organizer objects such as windows, dialogs, and frames provide an integrating context for all objects placed in them, but the level of integration depends on the objects involved.

- The SmartDataViewer, like most SmartObjects, is incorporated into the application as an instance of a master object. You create a SmartObject master in a separate operation before assembling the final application window. SmartObject masters are based on one of several SmartObject templates that are provided by AppBuilder.

- The two SmartPanels are supplied by AppBuilder predefined and precompiled. You simply select and place them.
• SmartObjects communicate smoothly with each other behind the scenes. For example, clicking on the navigation buttons in the SmartPanel causes the SmartDataViewer to display a new record. This command and data communication between SmartObjects takes place along SmartLink pathways.

AppBuilder helps create appropriate SmartLinks during the application assembly process. Each SmartLink represents a type of message to be sent when an event occurs. The messages are sent by the SmartObject experiencing the event to all other SmartObjects that are registered as being interested in events of that kind.

• Although it is not visible at run time, the SmartDataObject is a critical component of this application. It is the object that receives the navigation requests from the SmartPanel and supplies the data to the SmartDataViewer for display and, perhaps, modification.

Note that in Figure 3 the SmartDataObject widget is obscuring part of the large static text object, yet the text is completely visible in Figure 4. You can place nonvisible objects such as the SmartDataObject anywhere you like in your workspace. They are totally invisible at run time.

• The two static rectangle widgets serve to visually pull together and regularize the edges of the controls and the viewer object. Enclosing related widgets is one way to make them seem more related and reduce the sense of clutter. Even purely visual elements, used wisely, can greatly enhance the usability of your applications. Here, widening the border and filling the upper rectangle with color (modifying the colors in the Viewer to agree) creates a bit of additional visual interest, though the deep blue color might be less appropriate in a real application than in this toy one.

• The basic, static text object is an example of a special font definition. Used carefully, special fonts can add to the usability and the visual appeal of your applications.

• The **Done** button is another basic object. At run time, choosing the **Done** button ends execution and releases resources in an orderly way. AppBuilder supplies a number of predefined buttons as well as a generic one. When you add such a dedicated button to the layout, AppBuilder automatically generates appropriate trigger code. When you create your own applications, you have the option of choosing from the set of predefined buttons, or using the generic button and writing your own trigger code.

The **Done** button is an example of a custom object definition. It is defined in the `progress.cst` file. For information about creating and making available your own custom objects, see Appendix C, “Customizing AppBuilder”.
Figure 5 shows the SmartLinks connecting the SmartObjects in the toy application. Conceptually, SmartLinks are dedicated, directional message pathways between two SmartObjects. The event-Source object experiences an event, and reports that event to the event-Target object using the ABL Publish/Subscribe mechanism.

Figure 5 shows four SmartLinks. The first is a Navigation SmartLink between the Navigation SmartPanel and the SmartDataObject. When the user chooses one of the buttons in the SmartPanel array, SmartPanel sends a Navigation message to the SmartDataObject, asking it to change the position of its current-record pointer.

Whether this will mean a new read from the storage device is a matter for the SmartDataObject to decide, based on factors including the size of the RowObject temp-table you declared when creating it. The SmartPanel knows nothing about such matters; SmartObjects are only loosely coupled to one another.

When the SmartDataObject has changed its pointer in response to the request from the SmartPanel, it sends a Data message to the consumer of the data stream it supplies: the SmartDataViewer. When the user changes the data, and confirms the change using the Update Panel, the Update Panel reports that confirmation to the viewer, and the viewer sends an Update message back to the SmartDataObject.

Not shown in Figure 5 are links between the SmartContainer (the SmartWindow) and the SmartObjects that it contains, because those links are automatically created and removed by AppBuilder as you add and remove SmartObjects from the SmartContainer’s workspace. You never have to deal with them explicitly.
Figure 6 shows how these four links appear in the **SmartLinks Editor**. For further information about the editor, see the “SmartLinks editor” section on page 369.

**Figure 6:** Toy phone book links in SmartLinks Editor
AppBuilder Interface

The AppBuilder interface has a number of components:

• Main window
• Object Palette
• Workspace windows
• Source-code Section Editor
• Various dialog boxes for object properties, etc.

The following sections describe how to use the AppBuilder user interface:

• Starting and stopping AppBuilder
• AppBuilder main window
• Object Palette
• Setting your preferences
• Workspaces: design windows and source-code editors
• Editing source code safely: the Section Editor
• Configuring look-and-feel: object properties
• Inspecting a procedure file
• Test-driving your design
• Saving your work
Starting and stopping AppBuilder

Depending on the product you purchased, you might be using AppBuilder to develop standard client/server applications for GUI or character mode environments, applications for the Web, or some combination. Regardless of your development goal, you start and stop a development session the same way.

You can start AppBuilder from the Application Development Environment (ADE) Desktop or from any tool that has a Tools menu, such as the Data Dictionary or the Procedure Editor. You can also start AppBuilder directly from the operating system.

Starting from the operating system

To start AppBuilder from the operating system, enter the following command:

```
PROWIN32.EXE -p _ab.p
```

Stopping AppBuilder

You can end your development session and exit AppBuilder by any of these actions:

- Choose File → Exit from the AppBuilder main menu.
- Click on the close icon in AppBuilder's main window.
- Select Close from the pop-up menu of the small AppBuilder icon on the main window.

OpenEdge returns you to where you started AppBuilder.

AppBuilder for Web-based applications

This manual does not attempt to cover features and techniques specific to developing for the Web. For information on WebSpeed-specific features, see OpenEdge Getting Started: WebSpeed Essentials manual or the AppBuilder online help.
AppBuilder main window

From the AppBuilder main window, shown in Figure 7, you can access all of AppBuilder’s supporting functionality. The main window appears whenever you start AppBuilder.

Figure 7: AppBuilder main window

The AppBuilder main window is divided into four areas:

- Menu bar
- Tool bar
- Current object fields
- Status bar fields

See the “Menu bar” section on page 57 for a description of the menu bar and the related toolbar.

Current-object fields

The current-object fields display the Object identifier and, often, additional information such as a text or label string. Both fields are generally editable. Figure 8 shows current object fields for a SmartWindow.

Figure 8: Current-object fields

The current object is a single object that is part of the design window. Only one object can be current at a time. Thus, if you select more than one object in a design window, nothing will be listed in these fields.
The current object fields display the following information:

- **Object** — Specifies the name (identifier) of the current basic ABL widget, SmartObject instance, structured procedure file, method library, or structured include file. For character windows, this field displays the words **TERMINAL-SIMULATION** when the window is selected. No window name displays because in character mode there is never more than one window open. If some object in the window is selected instead, that object’s identifier displays here.

- **Title/Label/Text/Master/File** — For basic widgets other than text, specifies the title or label, if one is available. For text objects, which have no label or title, this field displays the text widget’s string value. For structured procedure files, method libraries, and structured include files, it specifies the pathname of the procedure file.

**Status bar**

Figure 9 shows the status bar.

![Status bar](image)

**Figure 9: Status bar**

These fields display from left to right:

- Status information about current AppBuilder activity.

- The **Design Page** in the current smart organizer object. If the current organizer/container is not smart, this field is blank.

- The name of the currently selected object type in the **Palette**. For example: SmartDataBrowser.

- The text **LOCK** if the current object icon is latched (locked) down for multiple placements. It is blank otherwise.
**Menu bar**

The menu bar provides access to nearly all the AppBuilder functionality, apart from the component objects. Note that some menu options are not available when you are working in WebSpeed development mode.

**File menu**

The **File** menu allows you to create, open, save, and print procedure files.

**File → New**

Opens the **New** dialog box. After you choose the object or component you want to create, AppBuilder reads in the appropriate template. A **template** is an incomplete procedure file for an object. After loading the template, AppBuilder will take some further, template-specific action:

- Windows, dialog boxes, and outer-level frames: AppBuilder opens a *design window* or *workspace* where you assemble and arrange the widgets that will make up your application’s user interface. AppBuilder also opens a workspace if you choose Simple SmartObject, since the majority of SmartObjects will have a visible representation.

  When designing WebSpeed applications, you do not work with a design window. See *OpenEdge Getting Started: WebSpeed Essentials* tutorial for an overview.

- SmartObjects based on a master: AppBuilder starts the design wizard for that class of object. After the design wizard runs to completion, you will have a fully defined SmartObject master that you will normally save to disk.

- Procedure, include file, or methods library: AppBuilder opens two windows. One shows a tree view of the editable sections of that file type, and the other displays the built-in source-code section editor with a code stub for the current section type.

**File → Open**

Opens an existing object file and displays its associated design window or tree view. If AppBuilder cannot determine how to present the file in a better way, it will use a procedure window.

You can also drag and drop a file from the Windows Explorer or desktop to the AppBuilder main window. AppBuilder opens the file according to type, and prompts you to connect to any necessary databases.

**File → Save**

Saves the current procedure file locally or remotely, according to your current development mode. AppBuilder prompts you for a filename only if you have not saved this file before.

**File → Save As**

Opens the **Save As** dialog box for the current procedure file. Normally you would **Save As** in order to change the filename, but you can **Save As** to the original filename if you wish.
Chapter 2: AppBuilder Interface

File → Save All

Immediately performs a save on all open files being maintained by AppBuilder.

Newly-created files are saved locally or remotely according to the Development Mode setting. Previously-existing files are saved to the locations from which they were opened, regardless of the Development Mode setting.

Caution: You must perform individual saves on any files that AppBuilder opens in a Procedure Editor window rather than a Section Editor. Use of the Procedure Editor means that AppBuilder does not maintain the file.

File → Print

Prints the source code of the current structured-procedure file, not the currently selected object specifically. If you clear the Use Print Dialog Box option in the Preferences dialog box, the file is printed to the default printer immediately, without further prompting.

Edit menu

The Edit menu allows you to perform a number of coarse-grain, generic editing operations such as cutting and pasting.

Edit → Undo

Shortcut: CTRL+Z — Undoes the most recent operation, including a Delete, if possible. The menu item text shows what that operation was. Item temporarily changes to Redo after an Undo. If undoing the most recent operation is not possible, this item is greyed out.

Edit → Cut

Shortcut: CTRL+X — Cuts the currently selected object, if any, to the clipboard.

Edit → Copy

Shortcut: CTRL+C — Copies the currently selected object, if any, to the clipboard.

Edit → Paste

Shortcut: CTRL+V — Pastes a copy of the current clipboard contents to the current workspace, at the current cursor position.

Edit → Duplicate

Creates a copy of the currently selected object without using the Clipboard. The new copy is pasted directly on top of the original. To see the original, the duplicate must first be moved out of the way.

Edit → Delete

Removes the currently selected object, if any. You can recover a deleted object if you can Undo the operation, but you cannot recover by pasting because the Clipboard is not involved.
Edit → Copy to File

Opens a dialog box to copy the source code for the currently selected object to an export (.wx) file.

Edit → Insert from File

Opens a dialog box to insert the contents of some file into the procedure editor at the current insertion point.

Edit → Tab Order

Only enabled when a frame is selected, this item opens the editor that allows you to define the TAB traversal order for objects in the frame. The editor offers five predefined orderings plus a custom ordering that you can define on a per-frame basis.

Edit → Goto Page

Only enabled when editing a SmartContainer. Opens the dialog box that lets you set the ADM Design Page. See the “Simple SmartContainers” section on page 141 for information about the meaning of the Design Page.

Edit → Assign Widget IDs

Only enabled when editing a SmartContainer. Writes Widget IDs to all frames and widgets of the currently selected container. This overwrites any existing Widget IDs. Widget IDs are used to identify the widget at runtime while testing your OpenEdge GUI application with a third-party automated test tool.

Compile menu

The Compile menu allows you to invoke the AVM to inspect, test, and debug your work.

Compile → Run

Shortcut: F2 — Compiles and runs the current workspace. While the workspace is running, no AppBuilder control is available other than the Stop button, which appears in place of the Run button in the toolbar.

Compile → Check Syntax

Shortcut: SHIFT-F2 — Does a syntax check on the current workspace without running it.

Compile → Debug

Shortcut: SHIFT-F4 — Compiles the current workspace and starts the Application Debugger.

Compile → Code Preview

Shortcut: F5 — Opens a source-code viewer on the currently selected SmartObject master. If the currently selected SmartObject is an instance rather than a master, the viewer window will instead display the source of the current container object (workspace).
Compile → Close Character Run Window

Closes the currently open character-mode test window, if any.
Tools menu

The Tools menu gives you access to several of the important AppBuilder dialog boxes as well as the other OpenEdge tools installed on your system.

Tools→ New Procedure Window

Shortcut: CTRL+F3 — Opens a version of the Procedure Editor, with a reduced number of menu items. The Procedure Editor is not AppBuilder’s built-in Section Editor, and should not be used to edit files that were created by AppBuilder. (Note that the behavior of this editor may be slightly different to that of the basic Procedure Editor—the two do not use the same underlying code.)

Tools→ New ADM Class

Opens a dialog box to allow basic definition of a new class, generating all the relevant files. Entering the class name automatically fills in the blanks for the other fields.

Tools→ TEMP-DB Maintenance Tool

Opens a tool for managing the TEMP-DB database and associated temp-table include files. See the “The TEMP-DB database” section on page 71 for more information.

Tools→ Property Sheet

Opens the appropriate base properties dialog box for the current object.

Tools→ Procedure Settings

Opens the file level properties dialog box for the current procedure file. Procedure settings include:

- The type of procedure file
- The filename
- The description
- The location of the properties for ActiveX objects, if any, in this context
- The directory in which AppBuilder compiles the procedure file
- The external tables (if any) required for the procedure file
- The settings for running from AppBuilder
- The custom lists available for the procedure file
- The relevant information about partition and pages, if the file represents a SmartObject

Additionally, if you open a template, you can access the template’s advanced procedure settings. These settings determine, among other things, what types of objects you can place in a design window. For more information, see the “Procedure settings” section on page 366.
Chapter 2: AppBuilder Interface

**Tools → Color**

Opens the color selector for the current object. Not available in Remote (WebSpeed) mode.

**Tools → Database Connections**

Opens a window to display, add to, or remove current database connections.

**Options menu**

The Options menu allows you to set both general and editor-specific preference items, and change the visibility and magnetism of the layout grid.

**Options → Preferences**

Opens the dialog box that allows you to set various preferences. See the “Setting your preferences” section on page 87 for detailed information.

**Options → Editing Options**

Opens the dialog box that allows you to set editing-environment preferences such as color-coding, tab size, etc. See the “Setting your preferences” section on page 87 for detailed information.

**Options → Snap to Grid**

Determines whether objects will snap to the nearest gridlines in frames. The gridlines need not be visible. This switch affects all layout workspaces, not just the current one.

**Options → Display Grid**

Determines whether layout gridlines will be visible. This switch affects all layout workspaces, not just the current one.

**Layout menu**

The Layout menu allows you to define additional layouts and to arrange selected objects in regular ways.

**Layout → Alternate Layout**

Opens the Alternate Layout dialog box. You can define the conditions for additional layouts using this dialog box. For more information, see Appendix B, “Multiple Layouts”.

**Layout → Center Left-to-Right in Frame**

Centers all selected objects along one axis (X or Y) within the frame, without changing their positions on the other axis.
Layout→Even Spacing Left-to-right
Layout→Even Spacing Top-to-Bottom

Evenly spaces the objects from one another along one axis (X or Y) without changing the overall space they take up, and without changing their positions on the other axis.

Layout→Move-to-Top
Layout→Move-to-Bottom

Changes the Z-axis layering order of the selected object. Moving it to the top makes it seem to overlay all other objects (that is, it makes the object seem closest to the viewer); moving it to the bottom makes it seem to be overlaid by all other objects (makes it seem furthest away). Some objects do not respond to relayering requests.

Layout→Align

Opens a submenu where you can choose the feature on which to align multiple objects. Objects can be aligned in the following ways:

- By label colons.
- By left or right edges, or horizontal center (vertical centerline).
- By top or bottom edges, or vertical center (horizontal centerline).

Window menu

The Window menu provides access to the built-in Section Editor, the common properties editor window, the OCX properties editor, and a list of current objects.

Window→Code Section Editor

Shortcut: CTRL+S — Invokes the built-in source-code editor on the current object. Unlike other editors, including the standard Procedure Editor, the built-in Section Editor will not make object source code unmanageable by AppBuilder.

Window→Hide Object Palette

Determines whether the Object Palette is visible. The menu item changes to Show Object Palette when the Object Palette is hidden.

Window→Properties Window

Opens the window that lists certain of the common properties of all selected objects. For example, all objects have an origin and a size. Where property values differ between objects, as is typically the case, the differences are represented by a range in the Properties window. You can set substitute a single value for the range, and this will affect all selected objects.

Window→OCX Property Editor

If the current object is an ActiveX object, opens an editor window for the object’s properties. If the current object is not an ActiveX object, selecting this item opens a window with no content.
Chapter 2: AppBuilder Interface

Help menu

The Help menu provides access to useful information of various kinds.

Help → OpenEdge Master Help

Opens the master online help system for the OpenEdge Application Development Environment.

Help → AppBuilder Help Topics

Opens the online help system for the AppBuilder.

Help → Messages

Opens a window that displays the text associated with the message number you enter.

Help → Recent Messages

Opens a window that allows you to review recent messages that AppBuilder generated, if any.

Help → Cue Cards

Opens a window that displays recently dismissed cue cards, if any.

Help → About AppBuilder

Opens a window that displays the version of AppBuilder you are running, the current version of the operating system, and the total and free hardware memory.

Tool bar

Most buttons on the tool bar correspond to menu options. The exceptions are the List Objects button, and the Development Mode switch. The Development Mode switch is a special option not present in all versions of AppBuilder. See Figure 10.

Figure 10: AppBuilder tool bar

You can use the Windows Tooltip feature to view the action labels for each button. For a more complete description of the button’s function, see the description for the corresponding menu item, as noted.

Click on the tool bar buttons to invoke the following AppBuilder actions:

- New — Corresponds to File → New.
• **Open** — Corresponds to **File** → **Open**.

• **Save** — Corresponds to **File** → **Save**.

• **Print** — Corresponds to **File** → **Print**.

• **Procedure Settings** — Corresponds to **Tools** → **Procedure Settings**.

• **Run** — Corresponds to **Compile** → **Run**.

• **Edit Code** — Corresponds to **Window** → **Code Section Editor**.

• **List Objects** — Invokes the **List Objects** dialog box, which lists all the objects in use in the AppBuilder session, allowing you to access their **Property Sheets**. There is no other way to open this dialog box.

• **Object Properties** — Corresponds to **Tools** → **Property Sheet**.

• **Colors** — Corresponds to **Tools** → **Color**.

• **Development Mode Switch** — If present, alternates the development mode between local and remote. These modes affect where AppBuilder compiles, runs, and saves objects. For more information on using remote (WebSpeed) development mode, see *OpenEdge Getting Started: WebSpeed Essentials*. 
Object Palette

For your convenience, the **Object Palette** makes available all the component objects supplied with AppBuilder. Only the major organizers (windows, dialogs, SmartFrame) are not on the Palette. Create them from the list in the **File → New** dialog box.

Figure 11 shows the **Object Palette**.

![Object Palette](image)

Each icon has a Tooltip that identifies it. Or, if you would prefer to work with a pulldown menu of object names instead of the icons, select the **Options → Show Menu Only** item on the Palette’s menu.

By dragging the edge of the **Palette** appropriately, you can change the shape of the **Palette** through a broad range, from one (long) row to two columns. You can also choose where to position the **Palette** within the Windows display area.

Table 5 shows the default set of object tools.

### Table 5: Default object tool description

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Pointer</strong></td>
<td>This tool does not create any object; it is part of AppBuilder itself. Use this tool when selecting, rearranging, or resizing objects in the visual-layout workspace. Also choose this tool if you wish to change your mind after selecting another tool but before placing that object.</td>
</tr>
<tr>
<td><strong>Basic data viewer</strong></td>
<td><em>(DB-Fields)</em> Prompts you to connect a database, if necessary, and then to identify first a table and then fields in the table. Creates a query based on your selection, and adds to the workspace one labelled fill-in per field, arranged in a single column.</td>
</tr>
<tr>
<td><strong>Query</strong></td>
<td>Prompts you to connect a database, if necessary, and then starts the <strong>Query Builder</strong> dialog box. This widget is visible only at design time.</td>
</tr>
<tr>
<td>Icon</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image" alt="Basic data browser" /></td>
<td><strong>Basic data browser</strong> — Prompts you to connect a database, if necessary, and then starts the <strong>Query Builder</strong> dialog box. The results of the query are automatically displayed by the widget.</td>
</tr>
<tr>
<td><img src="image" alt="Frame" /></td>
<td><strong>Frame</strong> — Adds a frame to the workspace. Use a frame to visually group other objects or, generally only in character mode, to serve as a window (viewport) into a data display.</td>
</tr>
<tr>
<td><img src="image" alt="Rectangle" /></td>
<td><strong>Rectangle</strong> — Adds a static rectangle to the workspace. Rectangles have no associated functionality. Use rectangles to visually group other objects.</td>
</tr>
<tr>
<td><img src="image" alt="Image" /></td>
<td><strong>Image</strong> — Adds a static, bitmapped Image to the workspace. AppBuilder supports many different image formats under Windows. This object is, of course, meaningless in a character environment.</td>
</tr>
<tr>
<td><img src="image" alt="Radio set" /></td>
<td><strong>Radio set</strong> — Adds a set of three radio buttons to the workspace, with generic labels. You can change the number of buttons in the set after placement. Radio-sets represent any small set of discrete values where only one can be valid at a given time.</td>
</tr>
<tr>
<td><img src="image" alt="Toggle box" /></td>
<td><strong>Toggle box</strong> — Adds a single toggle box (check box) to the workspace, with a generic label. Toggle boxes represent a single <strong>LOGICAL</strong> (Boolean) value. Generally, you should set up the box so that the unchecked condition represents No, False, Empty, Not set, etc.</td>
</tr>
</tbody>
</table>
| ![Slider control](image) | **Slider control** — Adds a slider control widget to the workspace, with optional readout. You can choose to orient this widget vertically or horizontally.  
**Note:** You can assign a slider to visualize an **INTEGER** or **INT64** field or variable. However, the slider cannot display values less than -32,768 and greater than 32,767.  
**button** — Adds a button to the workspace, with a generic label. You would typically use a button for activating some process rather than selecting a static condition. buttons are represented as momentary-on (nonlatching) devices: when released, they return to the up or inactive state. |
| ![Selection list](image) | **Selection list** — Adds a selection list to the workspace. A selection list presents a scrollable set of items displayed as character strings. |
| ![Multi-line editor](image) | **Multi-line editor** — Adds a multi-line text editor widget to the workspace. You can set the size of the edit buffer, as well as the availability of features such as wordwrap. |
| ![Combo box](image) | **Combo box** — Adds to the workspace a drop-down list, or a combo box with your choice of drop-down or visible list element. A true combo box allows the user to type a value into the fill-in component or select from the items displayed by the list component. |
| ![Fill-in](image) | **Fill-in** — Adds a single-line editor to the workspace. Although a fill-in presents its data at run-time as a character string, you can specify automatic type conversion such that, for example, the value is actually **LOGICAL** with the user’s only choice being between some two string literals you define such as “True” and “False.” |
### Table 5: Default object tool description (3 of 4)

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>Static text</strong> — Adds a string of static text to the workspace. You control font, color, and size.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>ActiveX (OCX) control</strong> — Opens a list of ActiveX controls for your selection. ActiveX controls can be broadly similar in capability to SmartObjects, but they follow Microsoft’s Component Object Model (COM) standard, not the ADM.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>Spin Buttons (ActiveX)</strong> — Adds an ActiveX spin button control to the workspace. Spin buttons allow setting an INTEGER value. They are functionally similar to a hardware thumbwheel device. You can choose the upper and lower bounds of the range and the increment/decrement value.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>Combo box (ActiveX)</strong> — Adds an ActiveX combo box to the workspace. See the description of the ABL combo box for general details about this type of object.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>Timer (ActiveX)</strong> — Adds an ActiveX timer object to the workspace. Timers are used as countdown devices that endlessly generate an event at an interval you determine. A timer has no run-time representation or associated data value.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>SmartDataObject</strong> — Adds an ADM database interface to the workspace. A SmartDataObject manages a data stream to and from disk, filtering records and responding to requests from other ADM controls residing upstream.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>DataView</strong> — Adds an ADM data binding object to the workspace. A DataView provides data binding between a ProDataSet and an ADM-based UI.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>SmartObject</strong> — Adds some SmartObject of your choosing to the workspace.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>SmartFolder</strong> — Adds an ADM tabs widget to the workspace. A SmartFolder provides a well-defined context within which you can divide your total interface into functional units.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>SmartPanel</strong> — Adds one of the predefined ADM button arrays to the workspace. SmartPanels are dedicated toolbars, providing upstream control of other SmartObjects.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>SmartDataBrowser</strong> — Adds an ADM tabular data display to the workspace. SmartDataBrowsers provide a multi-record, row/column interface to the data stream.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>SmartDataViewer</strong> — Adds an ADM data display to the workspace. SmartDataViewers provide a single-record interface to the data stream. You can arrange their layout to suit your design.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>SmartDataField</strong> — Adds special capabilities of your choosing to a SmartDataViewer on a per-field basis.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>SmartLOBField</strong> — Adds a SmartLOBField to represent an SDO LOB field in a non-standard visualization.</td>
</tr>
</tbody>
</table>
Placing objects from the Object Palette

To select an object for placement, click on its tool icon (tool button):

- All objects have a default version. Some also have special-purpose variants. To list any variants available for the object under a tool icon, right-click that icon. To select one of the listed variants, left-click it. If there is only one choice, it will be listed as Default.

- To pick up a basic ABL object for placement, left-click the icon. The icon will stay depressed to indicate that it remains selected. When you bring the cursor over a clear spot in the workspace, the cursor will change to indicate an object of the type you are placing.

  Left-click over the spot where you wish to release the object. The object will appear on the workspace at that position, and the icon and cursor will return to their usual states.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="SmartFilter" /></td>
<td><strong>SmartFilter</strong> — Adds an ADM Smart Query-By-Form capability to the workspace.</td>
</tr>
<tr>
<td><img src="image" alt="SmartToolbar" /></td>
<td><strong>SmartToolbar</strong> — Adds an ADM menu and toolbar to the workspace. The default SmartToolbar offers the same navigation and update functions that are provided by the corresponding SmartPanels.</td>
</tr>
<tr>
<td><img src="image" alt="SmartContainer" /></td>
<td><strong>SmartContainer</strong> — Allows you to add an outer-level container object, such as a SmartWindow, to another container. This creates a child-parent relationship.</td>
</tr>
<tr>
<td><img src="image" alt="SmartBusinessObject" /></td>
<td><strong>SmartBusinessObject</strong> — Adds a special ADM SmartContainer that organizes the data streams of several SmartDataObjects.</td>
</tr>
<tr>
<td><img src="image" alt="SmartProducer" /></td>
<td><strong>SmartProducer</strong> — Adds an ADM message handler that creates messages to be transmitted by an OpenEdge message service.</td>
</tr>
<tr>
<td><img src="image" alt="SmartConsumer" /></td>
<td><strong>SmartConsumer</strong> — Adds an ADM message handler that receives messages transmitted by a OpenEdge message service.</td>
</tr>
<tr>
<td><img src="image" alt="SmartRouter" /></td>
<td><strong>SmartRouter</strong> — Adds an ADM message handler that routes incoming messages from a SmartConsumer to appropriate SmartB2BObjects.</td>
</tr>
<tr>
<td><img src="image" alt="SmartB2BObject" /></td>
<td><strong>SmartB2BObject</strong> — Adds an ADM transformation object that transforms information to and from XML, based on a protocol shared between the message’s sender and recipient.</td>
</tr>
<tr>
<td><img src="image" alt="SmartSender" /></td>
<td><strong>SmartSender</strong> — Adds a customizable ADM object that transforms information according to your rules, passing the result to a SmartProducer.</td>
</tr>
<tr>
<td><img src="image" alt="SmartReceiver" /></td>
<td><strong>SmartReceiver</strong> — Adds a customizable ADM object that receives information from a SmartConsumer and then transforms it according to your rules.</td>
</tr>
</tbody>
</table>
To pick up a SmartObject for placement, left-click the icon, and do the following:

- For SmartObjects based on a master, a dialog box opens that allows you to select a master that you previously defined, or you can begin the process of defining a new master.
- SmartObjects such as the SmartFolder, which is not based on a master, can be placed immediately, as though they were basic objects.

Multiple placements

To place more than one object of the same kind without having to reselect the tool, left-click the icon a second time. For all SmartObjects based on a master, this second click must occur after you have selected the exact master you intend to use.

The image of a padlock will appear on the icon. This indicates that the object tool is latched (locked) down and will allow you to make as many placements as you like.

When you wish to release the lock on that tool, select the Pointer icon. The image of the lock goes away, and the button returns to the up position.

Locking a tool is easy to do inadvertently. If you find your cursor seems to be stuck, check for the lock icon. Clear it by selecting the pointer tool, and then delete any extra objects that the accidental lock caused you to add to the workspace.

Changing your mind

If you change your mind in the middle of the placement process, you can cancel by selecting the pointer tool. If you change your mind after placing the object, simply delete it from the workspace. There will be no residue left behind.

Object Palette options

The Object Palette menu allows you to control the following options:

- **Top-only window** — Keeps the Object Palette on top of other AppBuilder windows.
- **Show menu only** — When checked, removes all buttons from the Object Palette. You must then use the Object Palette Menu for all interactions with the Object Palette.
- **Save palette** — Saves the position, shape, and size of the Object Palette for future AppBuilder sessions.

Customizing the Object Palette

By editing or creating a custom object file, you can control how three AppBuilder interface components—the Object Palette, New dialog box, and the Choose dialog box—present objects for selection. You can specify which objects are included and how they are presented. You can select a custom object file by choosing **Menu → Use Custom**. For more information about custom object files, see Appendix C, “Customizing AppBuilder”.
The TEMP-DB database

The recommended method for working with temp-tables in the AppBuilder is to use a special database named TEMP-DB to hold your temp-table definitions. You can use this database to associate a temp-table with a source file that is referenced by the AppBuilder when you construct objects based on that temp-table. The source file is an include file that defines one or more temp-tables.

**Note:** Your TEMP-DB database must be an OpenEdge Release 10 database. If you have an existing TEMP-DB database from a previous release, you must upgrade it.

There are two standard methods for defining a temp-table. You can use the LIKE phrase to define the temp-table as a copy of a database table, as follows:

```sql
DEFINE TEMP-TABLE ttmyTable NO-UNDO LIKE myTable.
```

This approach makes any objects built from that temp-table dependent on a database connection during compilation. To avoid that problem, you can explicitly write out all the FIELD and INDEX phrases in the DEFINE statement, as follows:

```sql
DEFINE TEMP-TABLE ttMyTable
    FIELD testField1 AS CHARACTER
    FIELD testField2 AS DECIMAL
    INDEX testIndex1 IS PRIMARY testField2 ASCENDING.
```

The AppBuilder enables you to reference temp-tables using both methods. However, by default, the TEMP-DB Maintenance tool uses fully written out DEFINE statements to avoid the database dependency at compile time.

Because the TEMP-DB database associates a temp-table with an include file, the AppBuilder can write that include file into the objects that you create from that temp-table. The generated code looks like the following:

```plaintext
/* Temp-Table and Buffer definitions */
{app1/ttMyTable.i}
```

You can now maintain the temp-table definition in the include file and avoid manually updating every object that uses the temp-table.

Several AppBuilder tools, such as the Query Builder and Column Editor, rely on the TEMP-DB database connection when building objects based on temp-tables. These tools use the metaschema of the TEMP-DB database to provide lists of available fields. Therefore, it is important that the definitions in the temp-table include files always match the TEMP-DB table definitions.
To simplify using temp-tables, the AppBuilder now includes a TEMP-DB Maintenance tool. This tool enables you to:

- Define new temp-tables by associating include files of temp-table definitions with tables in the TEMP-DB database and updating the TEMP-DB database schema to match the include file definitions.
- Compare the include file for a temp-table with the TEMP-DB database definition.
- Rebuild an existing TEMP-DB schema table definition to match the associated include file for a temp-table.
- Import temp-tables into the Progress Dynamics® Repository.

Creating a TEMP-DB database

The TEMP-DB database has a control table, temp-db-ctrl, that associates temp-table definitions and their include files. When you launch the TEMP-DB Maintenance tool for the first time with your TEMP-DB database, the system adds the control table to the database schema. The tool maintains the TEMP-DB schema and control table from that point.

Caution: Never use the Data Dictionary to maintain the TEMP-DB database. The new tool works by synchronizing the contents of include files with the database. If you use the Data Dictionary to modify the TEMP-DB database, the database’s contents will not match up with the source files.

To create a TEMP-DB database:

1. Start the Data Administration tool.
2. Choose Database → Create. The Create Database dialog box appears:

   ![Create Database Dialog Box]

3. Type TEMP-DB for the New Physical Database Name. By default, the database is created in your working directory.
4. Select An EMPTY Database from the Start with radio set.
5. Click OK to create the database. The Connect Database dialog box appears:

6. Click Cancel and close the Data Administration tool.

Your TEMP-DB database is just an empty database now. The TEMP-DB Maintenance tool checks that the TEMP-DB database has the appropriate control table in the schema when you launch the tool. If the control table is not present, the tool can apply the schema for you.

Note: If you have an object open in the AppBuilder that references the TEMP-DB database, be aware that the session needs to restart after the change to the TEMP-DB database. An error box will appear when the schema change is complete. When you click OK, your session terminates and the AppBuilder restarts. In general, you should close any open objects before using the TEMP-DB Maintenance tool.

To apply the schema to your TEMP-DB database:

1. Choose Tools → TEMP-DB Maintenance Tool from the AppBuilder main window. A dialog box appears asking if you want to connect to the TEMP-DB database:

2. Click OK. The Connect Database dialog box appears.

Note: Since the TEMP-DB Maintenance tool performs online schema changes to the TEMP-DB database, you must connect to the TEMP-DB database in single-user mode.

3. Type the appropriate values for your database and click OK. A dialog box appears asking if you want the control table added to the database’s schema:
4. Click **OK** to load the control table. The **TEMP-DB Maintenance** window appears:

![TEMP-DB Maintenance Window]

Your TEMP-DB database is now ready to use.
Using the TEMP-DB Maintenance tool

Now that you have a working TEMP-DB database, you can use the TEMP-DB Maintenance tool to create and modify temp-table definitions. The tool shows all the temp-tables currently defined in the TEMP-DB database in the browser. You can add others by either creating them in the tool or importing include files that contain the definitions.

TEMP-DB control records

The browser in the upper part of the TEMP-DB Maintenance tool shows all the temp-tables defined in the database and the corresponding records in the temp-db-ctrl table. You can sort on any column by clicking its label. Table 6 describes the fields in the browser.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table Name</td>
<td>Name of the table in the TEMP-DB database.</td>
</tr>
<tr>
<td>Source File</td>
<td>Name and relative path of the include file containing the temp-table definition.</td>
</tr>
<tr>
<td>Use Include</td>
<td>Indicates whether a data object using the temp-table should use an include file reference or a LIKE construct. The default (Yes) is to use an include file reference.</td>
</tr>
<tr>
<td>Date Modified</td>
<td>Date and time the table was last rebuilt with this tool.</td>
</tr>
<tr>
<td>File Changed</td>
<td>Indicates whether the date of the current source file is different than the date of the source file used for the last rebuild. Use this information to identify which files have changed since the last rebuild.</td>
</tr>
<tr>
<td>Status</td>
<td>Provides information about events that occurred during the last rebuild of the TEMP-DB database or during the last compare operation. The possible values are as follows:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Mismatched</strong> — The source file and the TEMB-DB structure do not match. This value is assigned after a compare or rebuild operation. Records with this value show as red in the browse.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Matched</strong> — The source the TEMB-DB structure match. This value is assigned after a compare or rebuild operation. Records with this value show green in the browse.</td>
</tr>
<tr>
<td></td>
<td>• <strong>File not found in Propath</strong> — Source file could not be found in the Propath.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Control Record not found</strong> — Control record could not be found in the temp-db-ctrl table. This might occur if a temp-table was added outside of the tool.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Table Tablename not found</strong> — Table specified in the control record does not exist in the TEMP-DB database. This might occur if a temp-table was deleted outside of the tool.</td>
</tr>
</tbody>
</table>
Defining a new temp-table

Defining a new temp-table is as simple as typing the definition into the editor on the Source File tab.

To define a new temp-table:

1. Click New source file in the editor. If there are no records in the TEMP-DB database, the editor is initialized automatically.
2. Type the following code into the editor:

```plaintext
DEFINE TEMP-TABLE ttMyTest NO-UNDO
FIELD testField1 AS CHARACTER
FIELD testField2 AS DECIMAL.
```
3. Right-click in the editor and choose Check Syntax to ensure the syntax is correct.
4. Click Save. The Save File dialog box appears.
5. Save the file in your working directory as ttMyTest.i.

The tool rebuilds the TEMP-DB database to include your new temp-table and displays its control record in the browser.

If you have your application database connected, there are some options that can make defining the temp-table easier. In the following example, the DynSports sample database is used. The DynSports database is a version of the Sports database that has been rebuilt using the Progress Dynamics recommended practices.

To define a temp-table from a table in a connected database:

1. Connect to a copy of the DynSports database.
2. Click New source file on the Source File tab.
3. Right-click inside the editor and choose **Insert → Table Definition** from the pop-up menu. The **Table Selector** dialog box appears:

4. Select **arm_customer** from the **Tables** list and click **OK**. The tool creates a temp-table definition to match the selected table:

5. Change the temp-table's name to **ttCustomer**.

6. Modify the definition to suit your purpose for the temp-table. For example, if you are not going to use the Progress Dynamics key fields (_obj), you can remove them and their associated indexes.

7. Save the temp-table in your working directory as **ttCustomer.i**.
**Importing temp-table definitions**

You can also define temp-tables in the TEMP-DB database by importing existing include files. You can write many temp-table definitions in a single file and then import them all at once. You only have to rebuild the TEMP-DB database once to add all the temp-tables in one file.

To import existing temp-table definitions:

1. In the Procedure Editor, type the following code in a new file:

   ```
   DEFINE TEMP-TABLE ttImport1
   FIELD testField1 AS CHARACTER
   FIELD testField2 AS DECIMAL
   FIELD testField3 AS INTEGER.
   
   DEFINE TEMP-TABLE ttImport2
   FIELD testField1 AS CHARACTER
   FIELD testField2 AS DECIMAL
   FIELD testField3 AS INTEGER
   FIELD testField4 AS DATE.
   
   DEFINE TEMP-TABLE ttImport3
   FIELD testField1 AS CHARACTER
   FIELD testField2 AS DECIMAL
   FIELD testField3 AS INTEGER
   FIELD testField4 AS DATE
   FIELD testField5 AS LOGICAL.
   
   DEFINE TEMP-TABLE ttImport4
   FIELD testField1 AS CHARACTER
   FIELD testField2 AS DECIMAL
   FIELD testField3 AS INTEGER
   FIELD testField4 AS DATE
   FIELD testField5 AS LOGICAL.
   ```

2. Save the file in your working directory as `ttImportTest.i`.

3. Select the **File Import** tab from the TEMP-DB Maintenance tool:
Using the TEMP-DB Maintenance tool

![TEMP-DB Maintenance Tool](image)
4. Browse to your working directory and click **Fetch Files**. The **Fetched Files** list shows all the include files from your working directory.

**Note:** The **Directory** field displays the last directory you specified in this tool.

5. Double-click on `ttImportTest.i` to move it to the **Selected Files** list. The **Rebuild TEMP-DB** button is enabled:

![Image of AppBuilder Interface]

6. Click **Rebuild TEMP-DB**. The browser displays a separate record for each imported temp-table definition.
7. Select one of the imported temp-tables in the browser, and select the Source File tab:

Note that you see the full contents of ttImportTest.i in the editor. You can edit any of the definitions in the file. The appropriate record is updated when you save your changes.

Viewing temp-table details

With the TEMP-DB Maintenance tool, you can view the details of any temp-table in the TEMP-DB database. While this does not allow you to edit the temp-table definitions, it is more convenient when reviewing temp-table definitions.

To view temp-table details:

1. Click View TEMP-DB schema details. The Schema dialog box appears:
If you select another table in the **Tables** list, the other lists update to display the information for that table.

2. **Click** **Table Details**. **The Table Details** dialog box appears:
Using the TEMP-DB Maintenance tool

3. Click **Field Details** in the **Schema** dialog box. The **Field Details** dialog box appears:

![Field Details dialog box]

4. Click **Index Details** in the **Schema** dialog box. The **Index Details** dialog box appears:

![Index Details dialog box]
Editing temp-table definitions

You can edit the temp-table definitions through the TEMP-DB Maintenance tool. You can make your changes either in the tool's editor or by launching the Procedure Editor from the tool.

To edit a temp-table definition:

1. Select `ttMyTest` in the browser.
2. Add the following code to the temp-table definition in the editor:

   ```plaintext
   INDEX testIndex1 IS PRIMARY testField2 ASCENDING
   ```

   Note: Alternately, you can click Open source file in editor to launch the Procedure Editor as a separate window.

3. Click Syntax to check that the code is correct.
4. Click Save. The TEMP-DB record for that table is rebuilt. You can view the temp-table definition to verify that the index information was added to the schema.

Verifying a definition against its source

When you build an object in the AppBuilder that uses a temp-table, the run-time code references the source include file by default. But, the AppBuilder uses the definition in the TEMP-DB database during design time. Therefore, you want to be sure that the records in the TEMP-DB database match the definition in the source file. Any changes in the source file should be imported into the TEMP-DB database before you use the temp-table to build an object.

Note: If you want to automate the updating of temp-table definitions, you can configure the ADE tools to automatically rebuild the TEMP-DB database when files are saved. To set this option, choose Options → Preferences in the TEMP-DB Maintenance tool.

To verify the TEMP-DB definition against the source file:

1. Open `ttImportTest.i` in the Procedure Editor.
2. Add `testIndex1` to the definition for `ttImport1`:

   ```plaintext
   INDEX testIndex1 IS PRIMARY testField2 ASCENDING
   ```

3. Check the syntax, save your change, and close the Procedure Editor.
4. Select `ttImport1` in the browser and click **Compare source file with schema**. After the tool compares the TEMP-DB record with the source file's code, the **Compare Window** appears with the results:

5. Close the **Compare Window** and examine `ttImport1` in the browser:

Note that the **Status** field now shows a value of **Mismatched Record**. Also note that the record now appears in red to draw your attention to it. When you are maintaining a large number of temp-tables, you can use the **Filter** combo box to find all the temp-tables with a given status.
Rebuilding the TEMP-DB schema

When a mismatch occurs, you can update the TEMP-DB schema to match the source file definition.

To rebuild the schema:

1. Select `ttImport1` in the browser.
2. Click `Rebuild TEMP-DB`. A message appears to verify that you want to rebuild the record:

![Rebuild TEMP-DB dialog](image1)

3. Click `Yes` to rebuild the record.

4. Click `View TEMP-DB schema details`. Examine the new index in the `Schema` dialog box:

![Schema dialog box](image2)
Setting your preferences

AppBuilder offers a number of properties that you can set to better suit your personal style and preferences without going through the effort of total customization. See Appendix C, “Customizing AppBuilder,” for information on more extensive customization.

You can configure both AppBuilder’s behavior and that of the built-in Section Editor.

AppBuilder preferences

To begin setting AppBuilder preferences, choose Options→Preferences. The dialog box opens displaying the General tab:

Table 7 describes the General preference options.

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Create Default Window at Startup</strong></td>
<td>Normally cleared. Setting this box causes AppBuilder to offer a brand new SmartWindow workspace for your use whenever it starts up. This might be especially convenient if you typically complete work on a particular window during an edit session and are ready for a fresh workspace next time. It is less useful if you normally resume work on an existing, partly completed window.</td>
</tr>
<tr>
<td><strong>Qualify Database Fields with a Database Name</strong></td>
<td>Normally cleared. AppBuilder’s output is application source code, including references to database fields. By default, such references are not fully qualified—any database that can supply the fields will be presumed to be the correct one. This can cause subtle difficulties in some circumstances. Setting this box causes AppBuilder to write out more complete references that are less prone to such errors.</td>
</tr>
</tbody>
</table>
Table 7: General preference options

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimize Main Window while Running or Debugging</td>
<td>Normally cleared. Setting this box causes AppBuilder’s main window to go to an iconic state rather than stay open, when you start a test run or a debug session.</td>
</tr>
<tr>
<td>Default to Suppressing Database VIEW-AS Phrases</td>
<td>Normally cleared. Setting this box causes AppBuilder to generate code without including widget specifications from the Data Dictionary. If you then need to make changes in representation, you need make them in only one place (the Dictionary) rather than two (Dictionary and source).</td>
</tr>
<tr>
<td>Recently Used File List</td>
<td>Normally set with a default value of 4. As a convenience, the File pull-down menu includes menu items that point to the 4 most recently opened structured-procedure files. You can open one of the files again by selecting its menu item. If you would like more or fewer than 4 files to be listed here, change the number. If you prefer that no files be listed, clear the box.</td>
</tr>
<tr>
<td>Double-click on object for Section Editor</td>
<td>Normally cleared. By default, double-clicking an object opens its Property Sheet. You can choose to open the Section Editor instead, by setting this box.</td>
</tr>
<tr>
<td>Display multiple Section Editors</td>
<td>Normally cleared. Setting this box allows you to have a separate Section Editor open for each open workspace. By default, a single Section Editor switches context according to which workspace has focus.</td>
</tr>
<tr>
<td>Default Function Data-Type</td>
<td>Normally CHARACTER. Unlike procedures, functions return a value upon termination and a call to them can, for example, appear on the right-hand side of an assignment operator. You can choose here the default data type of the value they return. It will apply to all functions defined thereafter for which you do not specify some other data type. The other choices are COM-HANDLE, DATE, DATETIME, DATETIME-TZ, DECIMAL, HANDLE, INTEGER, INT64, LOGICAL, LONGCHAR, MEMPTR, RAM, RECID, ROWID, and WIDGET-HANDLE.</td>
</tr>
<tr>
<td>Character Terminal Colors</td>
<td>Opens the Color Selector dialog box. Use it to set the foreground and background colors for your character-window workspaces. See the “Colors selector and editor” section on page 357.</td>
</tr>
<tr>
<td>Advisor</td>
<td>Advisors are dialog boxes that appear from time to time to offer advice about how to complete certain processes. Working with AppBuilder, you will most often see Advisors appear to suggest—and offer to help with—creation of SmartLinks between SmartObjects.</td>
</tr>
<tr>
<td>Cue Cards</td>
<td>Cue cards appear when you create SmartObjects. They offer a brief definition of the object, and hints on how to use it.</td>
</tr>
</tbody>
</table>
Setting your preferences

WebSpeed tab

If you have WebSpeed installed, you can use AppBuilder as your layout editor for both standard and Web applications. If you do not have WebSpeed installed, you will not see the tab in the following example:

![WebSpeed Tab Example]

You can change any or all of the settings here, if the default values do not meet your needs:

- **Web Browser** — Enter the path to the browser you wish to use for WebSpeed development. By default, AppBuilder uses the path to the browser identified in the Registry. Click **Browse** to open the standard Windows file system navigation tool, if you want to locate your preferred browser interactively.

- **Broker URL** — Enter the URL of the WebSpeed broker you will use to run your Web objects. Choosing the **Test** button will display a test page of broker information if the URL you enter is a valid one.

- **Open new browser window for each Web-based Run** — Normally set. Clear this box to re-use a single browser window rather than generate new windows for each Web object. PSC recommends that you do **not** clear this box if using Netscape Navigator.

Grid Units tab

One of the hallmarks of good design is that things line up neatly. Graphic designers solved this problem by lining things up against a grid, originally printed on their workspace in a pale, cool-blue ink that was visible to the human designer but not to the platemaking camera.

AppBuilder provides a similar grid to help you lay out your widgets neatly in the application workspace. You can make it visible to you, but it is never visible to the users of your application. The following shows the Grid Units tab:

![Grid Units Tab Example]
You can choose a grid spacing in this tab. It will apply only to graphical frames; the character window has a fixed size. If you plan to run your application in both GUI and character-cell contexts, you might wish to define your grid to be 1.0 x 1.0 characters in size, and take care not to consume more than 80 x 21 cells for any single layout.

Once you have a grid defined, choose Options → Snap to Grid to cause your widgets to automatically jump to the closest grid intersection, if you release the widget nearby. Choose Options → Display Grid to make the grid lines visible to you as a series of dots. The two options are independent of one another.

Note that any changes you make to the grid spacing here will apply only to frame objects you create afterward, not to objects that you have already created. The Snap and Display menu item settings apply immediately to all existing and future workspaces, however.

Print tab

The Print tab gives you some control over the way AppBuilder will print the source code it generates for you. The following shows the Print tab with the options available:

The Font and Page Length items are self-explanatory. If you clear the Use Print Dialog Box setting, AppBuilder will queue all subsequent print requests to the default printer immediately, without opening the Print dialog box.

Widget ID tab

The Widget ID tab enables you to specify if and how the AppBuilder assigns widget IDs to your application objects. The following shows Widget ID tab with the options available:

When Automatically assign widget IDs is checked, the AppBuilder assigns a widget ID to each new frame and object in a static container. Starting widget ID for frame is the widget ID for the first frame in a particular static container. Frame widget ID increment is the increment between the widget IDs for each new frame in a particular static container. The AppBuilder assigns widget IDs for each object in a frame in increments of 2 from the frame’s widget ID.
Section Editor preference options

The **Section Editor** allows you to set preferences on a per-language basis in three broad areas:

- Color coding of tokens
- Token completion and macro expansion
- Block formatting and indentation style

In certain cases, **Section Editor** applies your settings to individual blocks of language statements within a file, not merely to the whole file indiscriminately. Thus, you can (for example) embed a block of JavaScript code in a file that is otherwise HTML code, and **Section Editor** correctly color-codes and formats the embedded block and the surrounding blocks differently, each in the way you have specified for the particular language.

To begin configuring your **Section Editor** preferences, choose **Options → Editing Options**. The **Editing Options** dialog box appears:

![Editing Options dialog box](image)

You can set the following preferences in this dialog:

- **Extension** — The **Section Editor** determines what settings to use for each file by looking at the filename extension. You can select particular file extensions and set different preferences for each.

- **Syntax expansion** — Normally set. Clearing this box prevents the **Section Editor** from completing partial tokens or expanding syntax macros. Example: when this box is set, if you type in `IF` and press `CTRL+SPACE`, the **Section Editor** inserts the rest of an `IF` template conforming to ABL syntax.

- **Indent style** — Determines the column where the new line starts after you press `RETURN`:
  - **None** — Line starts in left-most column.
  - **Auto** — Line starts in same column as preceding line.
  - **Syntax indent** — The **Section Editor** tries to determine where to start the line by taking current language syntax into account. The absolute integer field (default: 4) determines the amount of change for new levels of indenting.
Chapter 2: AppBuilder Interface

- **Tabs** — You can specify either of the following:
  - A tab interval by typing in an integer preceded by a + sign; for example, +3
  - Actual tab stops by typing them in as space-separated, ascending integers; for example, 3 5 8 11 16 20 30

- **Alias filename** — Enter the fully qualified filename where AppBuilder is to store alias (macro) definitions for the particular extension type. You can have as many alias files as you have languages defined. For OpenEdge file extensions, the default aliases file is p4gl.als

- **Color Coding** — Clicking this button opens the Color Coding Setup dialog box, described in the “Color Coding Setup dialog box” section on page 92.

- **Alias** — Clicking this button opens the Alias Setup dialog box, described in the “Alias setup” section on page 94.

- **Options** — Clicking this button opens a syntax-specific-formatting dialog box, described in the “Options” section on page 96.

Click **Update** to make your changes to these settings permanent.

**Color Coding Setup dialog box**

The Color Coding Setup dialog box allows you to set the color for a particular class of tokens within a particular language. You can add new tokens to the most appropriate of several lists that AppBuilder maintains for the use of the recognizer. The following shows a sample Color Coding Setup dialog box:

![Color Coding Setup dialog box]

To set color and style for some class of token:

1. Click **Colors**. The Color Settings dialog box appears:
2. Check the **Set Embedded language Color** box, if appropriate.

3. Select the class of token from the **Screen element** list for which you wish to make changes. The meaning of the following two of the listed elements might not be immediately clear to you:
   - Window text is any text not otherwise defined.
   - Attributes (HTML only) are recognized modifiers within an HTML tag. For example, in the tag `<img src="somelocation">`, “src” is an attribute.

   **Note:** There are a few categories that, while still listed, are not settable in this version of the editor: **Current Line, Cursor, No Save Line, Inserted Line, Line Number, and Message.**

4. Click on color swatches to set foreground and background colors, and select the radio button for style. The sample text immediately reflects your choices.

5. Click **Apply** to save your choices for the selected token class without also dismissing the dialog box.

6. When you have finished making changes, click **OK**.
**Alias setup**

The **Section Editor** has a powerful macro-expansion capability. AppBuilder supplies predefined tokens that expand to common ABL syntactic constructs, and using these tokens can reduce your typing effort considerably. The **Alias Editor** dialog box provides you the means to define additional tokens that the **Section Editor** will later expand in the same way:

The expansion process is straightforward. For example, when you type `IF` and press `CTRL+SPACE`, the editor adds two spaces and the keyword **THEN**, and places the cursor between the two embedded spaces in exactly the right position for you to enter the **IF** test expression. Similarly, you can type in the predefined macro `&FR`, press `CTRL+SPACE`, and the editor will expand that to be `{&FRAME-NAME}`.

You can add additional items for automatic expansion, or even correction. If there is some typing mistake that seems to be a favorite of yours, you can enter it together with the relevant correction, and not have to worry about it any more. The transposition `DIPSLAY` for `DISPLAY` is an example of this—that error is such a popular one that PSC has already included it in the list.

**To add a new expansion:**

1. Click **New**. The **Enter New Alias Name** dialog box appears:

2. Type in the token to be expanded and click **OK**. The dialog box closes and the token appears in the list of tokens.

3. Type the expansion value into the editor. The expansion value may have multiple lines. Use `%\c` (percent sign, backslash, c) to represent the final position of the edit cursor, after expansion. Click **OK**.
In addition to being able to define an alias that will place the cursor properly, you can define aliases that prompt for completion. For example, if you still do old-style debugging, using disclosure code, you might wish to define a disclosure message that would reveal the value of some variable at a certain point in your program.

To define a disclosure message that would reveal the value of some variable at a certain point in your program:

1. Follow Step 1 and Step 2, in the previous procedure, calling the new alias PEEK.
2. Type in this expansion string: MESSAGE “At %(loc) %(var) is %(val)”.
3. Click Add in the bottom row. The Enter Alias Parameter dialog box appears:

   ![Enter Alias Parameter dialog box](image)

4. Type in loc as the parameter name, and Location as the actual prompt string. You can leave Initial Value blank for this example, unless you do want some text as the initial value.
5. Repeat Step 3 and Step 4 for var and val, using Variable and Value, respectively, as the prompts. Click OK.
6. Open the Section Editor in a context suitable for testing your new alias. Type in PEEK and press CTRL+SPACE. The editor immediately opens a dialog box to prompt you for the three parameters, afterward inserting the fully expanded call to MESSAGE in place of PEEK:

   ![Parameter Entry dialog box](image)
Chapter 2: AppBuilder Interface

Options

The **Options** dialog box allows you to customize the appearance of your source code in various ways:

![Options dialog box](image)

You can change as many of the following values as you want:

- **DO/END style** — Choose between having the **DO** block begin on the same line as the **THEN** token, or on the next line at the same indent level as the **IF** (default).

- **Insert DO/END immediately** — Normally cleared. Setting this box makes the editor create every **IF** template with an attached **DO/END** block.

- **Insert blank line between DO/END** — Normally cleared. Setting this box the editor include a blank line when creating a **DO/END** block.

- **Minimum expandable keyword length** — Choose the number of characters you must type (default: 1 character) before the editor will consider it a possible alias token. The editor will ignore **CTRL+SPACE** for any string with fewer characters than this.

- **Use SmartPaste (TM)** — Normally set. Clearing this box makes the editor ignore indentation when pasting. When SmartPaste is turned on, the editor attempts to correctly indent any text that you paste.

- **Indent WHEN from CASE** — Normally set. Clearing this box makes the editor put the **WHEN** clause at the same indent level as the enclosing **CASE**. The editor will normally indent **WHENs** by one additional level.

- **Keyword Case** — Normally all-caps. Choose the style the editor uses when expanding aliases.

- **Auto case Keywords** — Normally set. Clearing this box makes the editor ignore differences between the **Keyword Case** setting and how you type keywords manually. When set, the editor changes your manual style to conform to your **Keyword Case** choice; for example, changing a lowercase keyword to all caps.
Designing an application using AppBuilder involves creating building blocks and then gluing them together with appropriate ABL code. In ABL applications that are event-driven rather than procedure-driven, many of the building blocks will be user-interface related, and involve visual layout. Other building blocks have an internal and supporting role, and do not require you to lay out a visible representation.

The workspace for laying out visible objects is a design window. Figure 12 shows a design window for a SmartWindow—it is the SmartWindow itself. SmartWindows are outer-level organizers and members of the class SmartContainer.

Figure 12: Workspace for a visible object

The workspace for non-visible objects is the built-in source-code Section Editor, together with a window that shows a tree view of the editable components. Figure 13 shows a treeview window.

Figure 13: Workspace element for nonvisible object
It is important that you use only the built-in **Section Editor** to maintain your AppBuilder objects.

All AppBuilder-generated procedure files conform to a specific format, which allows AppBuilder to read and update them. AppBuilder cannot reliably read and understand a file that does not conform to this format. Even apparently trivial changes—in some cases, adding a blank character—can render a file unopenable. For more information about editing AppBuilder-generated procedure files, see the “Editing source code safely: the Section Editor” section on page 99.

If you open in AppBuilder a procedure file that it did not generate, AppBuilder does not display a design window or tree view for it. You must maintain such files manually, so AppBuilder displays the file in a standard procedure window.
Editing source code safely: the Section Editor

The Section Editor allows you to edit individual code sections of procedure files without risk to later readability by AppBuilder. This is not true of any other editor, including the editor in the procedure window.

Opening the Section Editor

To open the Section Editor, select the object you wish to edit and do one of the following:

- Choose Window → Code Section Editor.
- Click Edit code in the toolbar.
- Type CTRL+S from the keyboard.

You can also double-click on the object if you have that preference item checked in the Options → Preferences dialog box. Figure 14 shows the user interface elements visible when editing the Triggers section. The visible elements vary from section to section.

![Figure 14: Section Editor physical interface](image)

Choosing a section to edit

There are two ways to choose a particular code section for editing:

- Select a section (Definitions, Triggers, Main Block, Procedures, or Functions) from the Section combo box. The following example shows the section list expanded:

![Example section list](image)
If you select Triggers, Procedures, or Functions as the main category, you must also select an individual Trigger, etc., or click New, Existing Triggers, etc. are listed in the combo box below the Sections list.

- Click List. The List Sections dialog box appears:

![List Sections dialog box]

This dialog box lists all the sections and subsections that you can edit, to the level of internal procedures and individual triggers. To make a selection, highlight the name and click OK.

**Using the Section Editor**

The AppBuilder Section Editor is an editing utility that offers modeless text insertion, standard Windows-style cut-and-paste, and is also capable of the following:

- Text search-and-replace.
- Transformation of selected text (indent/unindent, comment/uncomment).
- Token insertion by picking from lists.
- Whole-file insertion.
- Undo of the most recent action, for most actions.
- The ability to delete whole subsections.

**Cutting, copying, and pasting text**

To cut a block of text, highlight the block of text, then choose Edit → Cut (shortcut: CTRL+X). The Section Editor removes the block of text from the current editing area and places it in the system clipboard.

To copy a block of text, highlight the block of text, then choose Edit → Copy (shortcut: CTRL+C). The Section Editor copies the block of text and places it in the system clipboard.

Once a block of text has been cut or copied into the system clipboard, you can paste it at any current cursor location by choosing Edit → Paste (shortcut: CTRL+V).
Finding and replacing text

Within the current editing area, you can search for and replace text strings. To search for a text string, choose Search→Find (shortcut: CTRL+F). The Find dialog box appears:

In the Find What field, type the text string that you want to find. Set search options as needed:

- Activate the Match Case toggle box to make the search case-sensitive.
- Activate the Down radio button to search forward; activate the Up radio button to search backward.
- Activate the Wrap at Beginning/End toggle box to specify that when reaching the beginning or end of the current editing area, you return to the top or bottom and begin to search again.

When you click OK, the Section Editor searches for the first instance of the text string.

To find the next instance of the text string, choose Search→Find Next (shortcut: F9). To find the previous instance of the text string, choose Search→Find Previous (shortcut: SHIFT-F9).

To replace instances of the text string with a different string, choose Search→Replace (shortcut: CTRL+R). The Replace dialog box appears:

The following search and replace features are available:

- **Find What** — Enter the substring to be searched for.
- **Replace With** — Enter the replacement substring.
- **Match Case** — Activate this toggle box to match the search target’s case.
- **Search All Sections** — The default search-and-replace is local to the section being edited. To search globally within the current file, check this box.
- **Replace All** — Click on this button to replace all occurrences of the target substring without further confirmation.
When you use the **Replace All** option, a message box displays indicating the **Replace All** is complete and the number of occurrences that were replaced.

**Transforming text**

A block of selected text can be indented, unindented, commented out, or uncommented by choosing **Edit → Format Selection**, and then choosing the operation desired.

**Inserting text from lists**

The process of creating code involves entering many reserved words, identifiers, filenames, and similar tokens. The possibilities for error are numerous. To reduce error and, in most cases, save keystrokes, AppBuilder helps you insert text strings for the following token types:

- Database fields
- Event names
- Internal procedure calls
- Preprocessor names
- Queries
- Object names
- Filenames

For each of these items, AppBuilder provides a way for you to choose or specify a text string that AppBuilder inserts into the edit buffer at your cursor location. You can access this capability by right-clicking in the editing area, or by choosing from the Insert menu.

For detailed instructions, see the “Inserting text-string tokens from lists” section on page 104.

**Inserting whole files**

You can insert (merge) the contents of a whole text file into the edit buffer at the current cursor location. This is convenient if you have used another editor to write some code that you now wish to integrate into your AppBuilder file.
To insert the contents of a text file, choose Insert → File Contents. The Choose Insert File Contents dialog box appears:

![Choose Insert File Contents dialog box](image)

**Note:** Apart from the dialog box title shown by the title bar, and the end result, this is the same dialog box that appears when you choose Insert → Filename. Make sure of what you are inserting.

By default, this dialog box points to the src/template directory and lists the header and superprocedure files found there. You can list different files, or files in a different directory, by selecting from the choices in the respective drop-down lists. You can edit the list of directories by choosing Edit Path, and you can add a directory without editing by selecting a file using the Browse button, which invokes the standard Open File dialog box.

### Saving your changes

Since the Section Editor is a feature of AppBuilder rather than a separate utility, it has no Save option of its own. To save your changes, use the File → Save or File → Save As menu items in the AppBuilder main window. This will save all changes made to the current object, not just those you made using the Section Editor.

### Undoing your changes

To undo all unsaved changes made to the current editing area, choose Edit → Undo All. This restores the file to the state it was in when you entered this editing area.

To undo only your most recent unsaved change, choose Edit → Undo. This option undoes your last edit. If you use Section Editor features such as Insert or Paste, Undo undoes the most recent action. Successive Undos switch between redoing and undoing the previous edit.

### Deleting whole sections

To delete all the non-AppBuilder code in a particular subsection (an individual trigger, procedure, etc.), choose Edit → Delete Trigger (procedure, etc.) The menu item text varies according to the element you are currently editing.

**Caution:** You cannot Undo the deletion of a whole subsection, such as a trigger. If you use the Edit → Delete subsection type function, and then change your mind,
you will have to re-enter all the deleted code. It cannot be recovered by using Undo or Undo All.

Inserting text-string tokens from lists

Database field names

To insert the name of a database field into an editing area, choose Insert → Database Fields from the Section Editor menu or choose the Section Editor’s pop-up menu by right-clicking in the editing area. The Field Selector dialog box appears, as shown in Figure 15.

![Field Selector dialog box]

This dialog box lets you choose any field for any currently connected database.

To specify a database field:

1. Select a database. The Tables and Fields lists change.
2. Select a table. The Fields list changes again.
3. Select the field names that you want to insert in the current editing area:
   - The Select All button selects all of the fields for the current table.
   - The Deselect All button deselects all of the currently selected fields.
   - To select multiple fields but not all of them, hold down the CTRL key while selecting.
4. Specify a prefix (qualifier) for the field name:
   - The None radio button prefixes nothing to the field name.
   - The Table radio button prefixes the table name to the field name.
   - The Database.Table button prefixes the database and table names to the field name.
5. Click OK to insert the fields. AppBuilder inserts the field names at the cursor location in the current editing area or replaces selected text.
Event names

To insert event names in an editing area, choose **Insert → Event Name**. The **Choose Event** dialog box appears, as shown in **Figure 16**.

![Figure 16: Choose Event dialog box](image)

This dialog box displays a list of all events recognized by ABL. To choose a listed event, select it and click **OK**:

- Use the **Event Filters** radio buttons to view different types of events.
- To specify a keyboard event, click **Keyboard Event**.

Procedure/function calls

To insert a call to an internal procedure or function or to a **SUPER** procedure’s internal procedure or function in an editing area, choose **Insert → Procedure Call**. The **Insert Procedure Call** dialog box appears, as shown in **Figure 17**.

![Figure 17: Insert Procedure Call dialog box](image)
Table 8 identifies and describes the options available in the **Insert Procedure Call** dialog box.

### Table 8: Options on the Insert Procedure Call dialog box

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Procedure Object**    | Displays the name of the procedure object that is active in the code **Section Editor** as indicated by the entry **THIS-PROCEDURE**, any SmartObjects, or super procedures defined for the object. A drop-down list is available from which you can choose a different procedure object, allowing you to call the procedures and functions for a super procedure.  
To edit a Web object, choose web-utilities-hdl from the drop-down list to access the internal entries of the Web utility. The web-utilities-hdl is a procedure handle defined for all Web objects that reference event procedures, method procedures, and API functions of the Web utility object, web-util.p. |
| **Entries in Object**   | When either the Procedures option or the Functions option is selected, this option displays a list of names of the current procedure object's procedures or functions, respectively. The procedure call code that you can insert into the code **Section Editor** from this list displays in the **Code to Insert** field.  
If procedures or functions are for actively running SmartObjects and super procedures, the insert code includes any run-time parameters for that procedure or function. You might have to replace each parameter name with the appropriate expression (that is, a constant, field name, variable name, or expression) for the specific call in your code. The data type of each parameter displays in comments.  
For procedures and functions in the **THIS-PROCEDURE** object, the dialog box does not provide the run-time parameters. You can determine the appropriate run-time parameters by switching to that procedure or function in the **Section Editor** and reviewing any parameter definitions. |
| **About Entry**         | Clicking this button displays additional information about the procedure or function currently highlighted.  
If the current procedure object is a SmartObject and it has an internal procedure named object-help, click **About Entry** to run that procedure in the object, passing the current procedure name as an **INPUT** parameter. The object can provide procedure-specific help.  
If the object has no object-help procedure, the **Insert Procedure Call** dialog box runs AppBuilder online help for the selected procedure. |
| **Code to Insert**      | Displays the code that you can insert into the code **Section Editor**'s edit area. You can edit this code before inserting it into the **Section Editor**.                                                                                                                                                                                                                      |
| **V8 Call**             | Clicking this button enables you to access the **Insert Procedure Call - Version 8** dialog box to insert Version 8 style ADM **RUN**, **DISPATCH**, and **NOTIFY** procedure calls into code. You might need to use this dialog box if you maintain Version 8 style SmartObjects in the Version 9 AppBuilder.  
For more information about the Version 8 functionality associated with the **Insert Procedure Call - Version 8** dialog box, see the Progress Version 8 documentation. |
The **Procedure Object** field lists all of the procedure handles (**THIS-PROCEDURE** or SmartObject instances) referred to in the current procedure file. For a standard window procedure file, **THIS-PROCEDURE** is the only procedure handle. For a SmartContainer, each SmartObject instance has a handle that is listed, in addition to **THIS-PROCEDURE**, which is listed for the SmartContainer itself. When you choose a procedure handle in the **Procedure Object** field, all of the internal procedures or functions listed pertain to the procedure associated with the object.

**Note:** AppBuilder does not keep track of parameters needed for internal procedures in **THIS-PROCEDURE**. It does this only for procedures and functions in SmartObject instances used by **THIS-PROCEDURE**. If you insert a `RUN` statement for a procedure defined in **THIS-PROCEDURE**, you must either check to see if the correct parameters are passed or wait for the AVM to do so.

**Preprocessor names**

To insert preprocessor names in an editing area, choose **Insert → Preprocessor Name**. The Preprocessor names are listed under the **Preprocessor** tab in the **Code References** window:

![Preprocessor References Window]

To select a preprocessor name, click on the name and click **Insert**. For more information about preprocessor names, see the online help.
Queries

You can use AppBuilder’s query-building dialog boxes to generate a query definition rather than typing in the query. To do this, choose Insert → Query. The Query Builder dialog box appears:

This dialog box is the first in a series of dialog boxes that help you generate a query. For more information about building queries in AppBuilder, see the “Defining and editing queries using Query Builder” section on page 188.

When you finish generating the query, click OK. The Section Editor inserts the entire text of the query at the cursor location in the current editing area.

Object names

To insert object names in the current editing area, choose Insert → Object Name. The Code References dialog box appears, opened to the Objects tab:
The **Objects** tab displays the ABL object names of all widgets and SmartObject instances available in the procedure file, as follows:

- The left column contains the name of each widget and SmartObject instance.
- The right column contains the label or title of each widget.

To insert an object, click on it and click **Insert**. To insert more than one, hold down the **CTRL** key while selecting. The **Section Editor** will insert your choice at the cursor.

**Filenames**

To insert a file's pathname in the current editing area, choose **Insert → File Name**. The **Choose Insert File Name** dialog box appears:

![Choose Insert File Name dialog box](image)

**Note:** This is the same dialog box that appears when you wish to insert the contents of a file rather than only a filename. Make sure of what you are doing.

To insert the file's pathname, select the filename and click **OK**. The **Section Editor** inserts the file's pathname at the current cursor location in the editing area. By default, this dialog box displays all of the `.i` and `.p` files in the `src/template` directory.
Chapter 2: AppBuilder Interface

Configuring look-and-feel: object properties

AppBuilder supports application building blocks that differ significantly in their style of construction, sophistication, configurability, and functional role. Because of this, it is not possible for AppBuilder to present their properties to you in a single, unified way. You can find properties aggregated in several different ways:

- File-level property sheets, available by choosing Tools → Procedure Settings or the corresponding toolbar icon. Building blocks that exist as external procedures—such as container objects and ADM SmartObjects—will have file-level properties.

- Property sheets for SmartObjects, available by choosing Properties on the menu-button menu. To reach the Instance Properties sheet, select that menu item instead, or click on the Edit button in the main property sheet.

- SmartLinks sheet, available by choosing the button with the chain-link icon in the property sheet for a SmartObject. The sheet lists all current links to or from that object.

- Property sheets for basic widget instances, available by selecting the object and choosing Tools → Property Sheet.
• Certain object properties, such as size and position, can be examined and set by choosing **Window → Properties Window.** The exact properties visible in this window vary with the object. If you have more than one object selected, only properties common to all are displayed, and any changes affect all selected objects as well.

• Property sheets for ActiveX (OCX) objects, available by double-clicking the object representation.

For the properties that apply to a given type of object, see the discussion of that object type.
Inspecting a procedure file

When you read a procedure file into AppBuilder, it compiles the file in order to analyze its contents, and stores relevant information about the file in memory. This represents a snapshot of the procedure as it appears at compilation time. As you make changes to the procedure, AppBuilder updates this snapshot.

At any time in an AppBuilder session, you can examine the current state of a procedure file as it exists in AppBuilder’s memory. To do this, choose **Compile→ Code Preview** from the AppBuilder main menu. AppBuilder builds a readable version of the procedure file and places it into a content browser, the **Code Preview** dialog box:

![Code Preview dialog box](image)

The **Code Preview** dialog box shows the current state of the design window as ABL code. You can copy code from the **Code Preview** dialog box and paste it into the **Section Editor**.

**To copy and paste text:**

1. In the **Code Preview** dialog box, highlight the text you want to copy.
2. Press **CTRL+C** to copy the highlighted text.
3. In the **Section Editor**, move the text cursor to where you want to insert the text.
4. Press **CTRL+V** to paste the text.

You can also search for text strings in the file. To do this, press **CTRL+F**. AppBuilder displays the **Find** dialog box, where you can specify the string you want to search for. To search forward, press **F9**; to search backward, press **SHIFT-F9**.
Test-driving your design

At any time during an AppBuilder session, you can test the current design window workspace. When you run a design window, you are in fact running a temporary procedure file. If you read a procedure file into AppBuilder and make changes to the design window, the temporary file reflects those changes. However, until you save the procedure file, AppBuilder does not store the changes permanently. When you save your changes, AppBuilder overwrites the procedure file and preserves the changes. If you prefer to preserve the original state, do a Save As instead, or discard your changes by exiting without saving.

To run a design window, choose Compile → Run, click Run, or press F2. Running the design window hides all windows except AppBuilder’s main window, and disables all of AppBuilder’s functionality except for a Stop button. AppBuilder displays the Stop button (eight-sided, red; it resembles the US “STOP” traffic sign) in place of the Run button, as shown in Figure 18.

![The run-mode STOP icon replaces the edit-mode RUN](image)

Figure 18: Stop button

Choosing the Stop button stops the design window even if the window is, for example, caught in an endless loop. Choosing the Stop button always closes the run window and re-enables AppBuilder’s editing functionality.
Saving your work

The development mode in which you are using AppBuilder affects how it saves objects. If you are using the remote mode, AppBuilder saves files to your Web server or transaction server machine. If you are using the local mode, AppBuilder saves files to local or networked drives of your choice. For more information on remote development mode, see OpenEdge Getting Started: WebSpeed Essentials.

To save a procedure file, click Save or choose File→Save from the AppBuilder main menu. If the file is new, the Save As dialog box appears. This dialog box allows you to specify a name for the file. If you have previously saved the file, AppBuilder automatically saves the file using its current name. If you want to save the file using a different name, choose File→Save As.
Organizer Objects

Organizer objects provide the visual and sometimes the execution context for other objects. Organizer objects include windows, dialog boxes, frames, and even rectangles, and are discussed in the following sections:

- Introduction to organizer objects
- Organizer object roles
- Creating a new procedure-based organizer instance
- SmartWindows
- SmartDialogs
- SmartFrames
- Basic windows
- Basic dialogs
- Basic frames
- Rectangles
- Simple SmartContainers
- Creating paged layouts
- Paging with SmartFolders
- Paging without SmartFolders
- Paging whole windows
Introduction to organizer objects

Whenever you develop an ABL application, you use organizer objects to provide a context for other objects. When you create a GUI window and populate it, the widgets you use seem more related than they would without the window around and under them. The window is providing that sense of visual and purposeful organization. If you set off part of the window’s client area with a frame or rectangle, the widgets you put inside the frame/rectangle will then seem more closely related to one another than to other widgets in the same overall window. The frame/rectangle is acting as another level of organizer.

Besides providing visual/psychological integration, some organizer objects have a functional role as well. Smartwindows, for example, have built-in code to create and initialize the SmartObjects they contain, and more code to maintain the SmartLink communication pathways between the contained SmartObjects.

Part of AppBuilder’s advantage is that it allows you to treat organizer objects (except for basic frames and rectangles) as design-window workspaces. Using techniques similar to those of an interactive graphics editor, you can assemble a complete window’s worth of building blocks in the workspace and then execute the workspace.

AppBuilder currently offers the following types of organizers in the File→New list:

- SmartWindow
- SmartDialog
- SmartFrame
- Simple SmartContainer
- Basic window
- Basic dialog
- Character window
- Character dialog

In addition, AppBuilder offers the following types of component-level organizers in the Object Palette:

- SmartFolder
- Basic frame
- Basic rectangle
Each type of organizer object has different characteristics and capabilities. They are only superficially interchangeable, if at all, and you should choose accordingly.

The SmartObjects are the most capable, and you must use them if you are building ADM applications. They all incorporate the logic needed to integrate other SmartObjects, and offer considerable savings in programming time. They also are the only organizer objects that support paging. The major differences between them are:

- **SmartWindows** are general-purpose outer-level windows, and include a default frame. They are not modal, they can have a menu bar, and they can be used as the main window of your application.

- **SmartDialogs** appear to be specialized windows, but technically are specialized frames, instead. They are modal, they cannot have a menu bar, and they cannot be used as the main window of your application. You typically open them to capture specific information and then close them again.

- **SmartFrames** are frame objects that can support component SmartObjects and act as a communication pathway. To display them at run time, you must always place them in a SmartWindow.

- **SmartFolders** are a special type of component objects. Conceptually, they are most closely related to frames, in that they are component objects with an organizing role. They use ADM paging to implement the tabbed-file-folder metaphor. You can place them in SmartWindows, SmartDialogs, or SmartFrames.

- **Simple SmartContainers** are general-purpose smart organizers that offer the functionality of a SmartWindow without the actual window part. They are invisible at run time. Because they are low-overhead objects, they can be very useful for modules that can run unattended.

The basic window and dialog objects do not have ADM smart logic. Because they lack this supporting logic, you cannot place SmartObjects in them. You can place other objects in them, such as basic frames and field-level objects, and ActiveX objects. Apart from the differences in how smart they are, windows and SmartWindows serve comparable functional purposes, as do dialogs and SmartDialogs.

Basic frame objects are essentially static organizers. Their role is to provide a visual context for the field-level objects they contain. Additionally, frame objects allow you to define the order in which pressing the TAB key will traverse their contents.

Rectangles are also static organizers, used to provide a visual context for other objects. Unlike frames, Rectangles do not create a traversal group; their role is entirely visual.

The SmartContainer tool—not to be confused with the Simple SmartContainer—creates no object. AppBuilder provides the SmartContainer tool as a convenient way for you to associate independent organizer objects of the class SmartContainer, such as SmartWindows, with one another in parent/child relationships.

The balance of this chapter discusses the available organizer objects in more detail.
Creating a new procedure-based organizer instance

This section uses the SmartWindow as the example, but the process is the same for most types of procedure-based organizers. To create a different kind of object, select that kind from the list instead of selecting a SmartWindow. To create a component-level organizer—a basic frame or rectangle, or a SmartFolder—follow the steps in the appropriate section.

To create a SmartWindow workspace:

1. In the AppBuilder main window, choose File → New or the New button on the toolbar. The New dialog box appears:

![New dialog box image](image)

This dialog box contains the following user-interface elements:

- **Objects** — Lists the available types of files. The objects in this list all exist as external procedures on disk. Note that there also might be file types listed, such as Structured Include, that do not represent objects.

- **Template** — Invokes the Template dialog box, which allows you to preview a procedure template file. When you choose a template, AppBuilder adds it to the Objects selection list. Adding a procedure to this selection list allows you to open it as an untitled procedure.

- **Show** — Specifies which procedure types you want to see in the Object selection list. Depending on your license, the options in this area might be different than those shown here.

- **Description** — A description of the currently highlighted object type.
2. Select SmartWindow from the **Object** selection list, then click **OK**.

AppBuilder loads a template as an untitled procedure and opens a workspace on your screen. For visible objects such as a SmartWindow, the workspace is the actual window you will populate. In other cases, such as when you select a Structured Procedure file, Structured Include file, or Method Library, AppBuilder opens the **Section Editor** as the workspace.

3. Adjust the size and position of the new SmartWindow as needed.

Click on the title bar to select the SmartWindow, and move it to a convenient place on your display. Resize the SmartWindow by dragging its edges.
SmartWindows

SmartWindows are general-purpose, outer-level organizer objects. They have ADM Smart technology embedded in them, and can fully integrate other SmartObjects such as SmartDataObjects, SmartToolbars, and so forth. SmartWindows are members of the SmartContainer class. Unlike the other SmartContainer objects, a SmartWindow can serve as your application's main window or as one of the windows in a multi-window design.

Note that a SmartWindow comes fitted with a frame that covers the client area of the window. The frame should automatically resize as you resize the SmartWindow. You can also resize it separately, if you choose. You might wish to do that in order to have room for additional frames. Besides providing the required context for widget placement, frames also group widgets for traversal using the TAB key, and you might wish to define more than one such group. Note that, rather than resizing the default frame, you could instead add a new frame for each separate traversal group, overlaying the default frame.

SmartWindows are file-level (external procedure) objects. Unlike the objects embedded in ABL itself, objects defined by external procedures typically are complex. Such objects have a set of properties associated with their nature as a subprogram module, and additional sets—if they have a visible run-time representation—associated with whatever widgets they put up as their user interface. The sections below discuss these different properties and their meanings.

Configuring SmartWindow visual properties

Configuring the visual properties for your new SmartWindow can be simple or complex, depending on how well the default settings suit your purpose.

Whenever you create a SmartWindows object using AppBuilder, you actually create two visible elements: a window and a frame. The frame completely covers the client area of the window, and resizes itself when you resize the window. Because of that, it may not be at all obvious to you at first that you are dealing with two different elements or how to open the Properties dialog box for the underlying window rather than for the frame that covers it.

Both the window and frame elements have properties you may wish to set. This section describes the properties that apply to the window part. See the “Configuring SmartFrame visual properties” section on page 131 for a discussion of properties unique to frames.

Opening the property sheet for the underlying window

Perhaps the most common way to open the property sheet for any object is to double-click on its client area, if you have your preferences set the way. But the overlying frame will prevent you from doing that here: double-clicking will open the property sheet for the frame, not the window.
To open the **Properties** dialog box for the window part of the SmartWindow object, use one of the following methods:

- While holding down the **CTRL** key, click in the client area of the SmartWindow until you see that you have the window selected (its identifier will display in the Object field of AppBuilder’s main window). Then choose **Tools** → **Property Sheet**.

  Although this method is the preferred, you may find it requires several clicks if the window is not empty.

- Expose some of the underlying window. Then double-click on the area you exposed.

---

**Caution:** You should not leave bare window surface exposed unnecessarily, since there is a slight possibility that you might then unintentionally place an object partly outside the frame, causing it to disappear.

---

To expose some of the underlying window:

1. Select the frame part of the SmartWindow by clicking in the client area (the area below the title bar). A border with handles will appear, as shown:

2. Drag the bottom-center handle upward a bit. This exposes the surface of the underlying window widget, though there might be little or no visible difference.
Once you have the window selected, opening the property sheet will cause the dialog box shown in Figure 19 to appear.

![Figure 19: Window property sheet](image)

### Minimal configuration changes

Although you can choose to accept many default settings, you should at least ensure that each SmartWindow you create is uniquely identifiable. To individualize a SmartWindow, make the following changes:

- Change the generic instance identifier to one that more closely describes the window instance you are creating. The instance identifier is the token that will appear in the source code, and is the default value for the filename. Note that OpenEdge identifiers for window objects are conventionally prefixed with a `w`.

- Change the generic title bar text to a string that identifies the particular window, or the application if the window you are creating is its main window.

- Click each of the icon image buttons and identify the icon bitmap (.ico) files for the large (32x32) and small (16x16) icons that will be used to represent the window.

### Miscellaneous properties (other settings)

There are a number of changes to a window’s appearance or behavior that you can make, if the default settings do not suit your purposes. They are listed here:

- **3D** — Normally set. **Clearing** this box changes the color of the window’s client area, but has no other obvious effect.

- **Control-Box** — Normally set. Clearing this box clears and disables the **Max-Button** and **Min-Button** check boxes. The run-time effect is to remove all three buttons from the right end of the window’s title bar and the small icon from the left end. Only the title string remains.
• **Drop-Target** — Normally cleared. Setting this box causes the window to generate an event when some object is dragged and dropped onto it. You can write code to intercept and respond to such events under program control.

• **Explicit Position** — Normally cleared. Setting this box enables the **Column** and **Row** settings in the **Geometry** section, and initializes them to the current location of the upper-left corner of this window. You can then freely reposition the window during design time, and the window will start up in the location you choose rather than in some location determined by the operating system.

• **Hidden** — Normally cleared. Setting this box prevents this window from displaying itself in response to implicit requests. Explicit code must be used to display a **HIDDEN** window. If initializing this SmartWindow will take a noticeable amount of time, keeping the window hidden meanwhile might be less worrisome to your customer, as long as you display a progress indicator.

• **Keep-Frame-Z-Order** — Normally set by AppBuilder when generating code. Prevents nested frames from inappropriately changing their layering in response to getting the input focus.

• **Max-Button, Min-Button** — Normally set. Clearing these boxes eliminates the buttons that appear at the right end of the title bar. Those buttons allow the user to make the window go to a full-screen or iconic state, respectively.

• **Message-Area** — Normally cleared. Setting this box adds an area for messages at the bottom of the window, but above any **Status Area**. Character windows always have a Message Area.

• **Resize** — Normally cleared. Setting this box allows the user to resize the window by dragging its edges. Widgets in the client area do not respond automatically to this resizing in any way.

• **Scroll-Bars** — Normally cleared. Setting this box allows scroll bars to be automatically activated as needed.

Setting the **Scroll Bars** option gives meaning to the **Virtual Width/Height** values shown in the **Geometry** section. Scroll bars exist to move different portions of some notional space into and out of view as desired. The size of the area currently in view is reflected in the **Width** and **Height** numbers, shown in character units in the main property sheet and pixel units in the **Advanced Properties** dialog box. The total size of the logical area, both visible and scrolled-off, is shown by the **Virtual** numbers. Those dimensions are referred to as **Virtual** rather than **Total** because they could conceivably represent a much larger area than could be displayed whole by any physical device. Unless the window can be scrolled, however, the total and visible areas are effectively identical, making the **Virtual** numbers meaningless for practical purposes.

• **Sensitive** — Normally set. Clearing this box causes the window to decline the input focus when offered.

• **Show-in-Taskbar** — Normally set. Clearing this box causes the window to iconize to a position above the taskbar rather than within the taskbar itself.
• **Small-Title** — Normally cleared. Setting this box has the same effect as clearing **Control Box**, plus it reduces the height of the title bar to the minimum needed for the title.

• **Status-Area** — Normally cleared. Setting this box adds a status area at the bottom of the window.

• **Suppress Window** — Normally cleared. Setting this box effectively removes the window widget, leaving only the frame. Frames are displayed by default in the current window, which might be a scratch window created for the purpose.

• **View** — Normally set. This is useful only when the frame is **HIDDEN**.

**Menus**

Unlike SmartDialogs and SmartFrames, a SmartWindow can have a menu bar and pull-down menus. It can also have a pop-up menu. You create both types of menu using the same editor and the same procedure.

---

**Note:** You cannot use this menu if you plan to place a SmartToolbar, even if you only intend to use the toolbar element of that object. The built-in menu and the SmartToolbar are incompatible. See the description of the SmartToolbar object in *OpenEdge Development: ADM and SmartObjects*.

---

The procedure for creating a pop-up menu is identical to creating a menu bar and pull-down menus, apart from the button you choose at the start.

**To create a menu bar and pull-down menus:**

1. Click **Menu Bar** in the property sheet. The editor dialog box appears:

![Image of the editor dialog box for creating a menu bar]
2. Change the default identifier for the menu object to reflect your naming conventions, if desired.

3. Enter the label for the first menu item. A corresponding identifier will immediately be generated in the **Object** field. You can modify that identifier, if desired, using the following methods:

   - You must precede one of the letters in each label with an ampersand (&) so the user can choose the menu item from the keyboard. The choice of letter must uniquely identify the menu item within its group (bar or pull-down). If you have not determined where this item will reside, you can defer selecting a character until later.

   - By convention, a menu item on a pull-down ends in an ellipsis (...) if choosing it will open another level of pull-down or invoke a dialog box. Example: **Save As**...

   - If you wish to define string attributes for the label, enter them in the area to the right of the label. For further information, see the “String attributes” section on page 375.

4. Repeat **Step 3** until you have entered all the items that will appear anywhere in the menu system you are creating.

5. Select each menu item that is to appear in a pull-down rather than on the bar. Mark it by choosing the >> button. You will see a dash appear in front of the item. The >> button can be used more than once, and each use will prepend another dash. The number of dashes indicates the nesting level of the pull-down on which the item will appear, defined as follows:

   - No dashes means the item will be on the menu bar itself.

   - One dash means the item will be on the main pull-down menu.

   - Two dashes means the item will be on a cascade/fly-out menu off the pull-down.

   - Three dashes means the item will be on a second level of cascade menu.

   If you change your mind, remove unwanted dashes by choosing the << button.

6. Select each menu item and use the Up and Down buttons to move it into the correct position relative to the other items. The first item on a pull-down menu should appear immediately below the item that causes the pull-down to open. Example: in the figure shown in **Step 1**, the **Cut** item would be the first item in the Edit pull-down.

   If the item is a pull-down item, and is to appear with a check mark in front of it whenever selected, check the Toggle-box option.

7. Arrange pull-down items into logical groups by inserting rule lines (Rule button) and nonselectable blank items (Skip button) as appropriate.
8. Select each item that will be frequently used and define an accelerator (shortcut) key for it. Click **Key** and, when the capture dialog appears, **press the actual key** or combination (such as **CTRL+X** for **Cut**) that is to become the shortcut.

   **Note:** To create a shortcut for an item on the menu bar, you must first change it to a pull-down item using the >> button. After you have defined the shortcut, move it back to the menu bar using the << button. The shortcut will remain defined.

9. Select each item that will not be active on startup and check the **Disabled** box. Save your work.

**Context-sensitive help**

If you plan to provide context-sensitive help, check the **Context Help** box and specify the full pathname of the relevant help file.

**String attributes, window color, status area font**

You can set several other characteristics of the window, if you choose:

- String attributes.
- Font used for text written to the **Status Area**, if any.
- Colors used for the window’s foreground and background. By default, MS-Windows applications leave their window colors undefined so that the end user can set them as a preference item.

See the online help system for further information.

**Advanced properties**

Click **Advanced** to set additional properties. The **Advanced Properties** dialog box appears:
The advanced properties shown here are common to most objects. You can modify any that do not meet your needs:

- **Private Data** — Not used by AppBuilder. AppBuilder assigns the contents of this field to the window’s `PRIVATE-DATA` attribute. You can write code to read and operate on that value in any way that meets your needs.

- **Generated Code Layout Unit** — Determines whether AppBuilder uses character or pixel units when generating source code for this object.

- **Custom Lists** — Custom lists would be called macros in other languages such as C. They provide a convenient way to avoid typing a large number of identifiers when many objects are to be treated identically. For example, if you check the box for List 1, the identifier for this window is associated with List 1. Later, any time a reference to this procedure’s List 1 is encountered by the preprocessor, the identifier for this window—together with the identifiers for all other objects you associated with List 1 in this procedure—will be substituted in the source code in place of the reference. You can choose to include this window in up to six such macros.

  You can also give the macros themselves more meaningful identifiers. See the “Custom lists naming” section on page 362 for additional information.

- **Geometry - Pixels** — You can set the exact startup size and position for this window, in pixel units. Startup position is only meaningful when you set the Explicit Position box.

- **Always-on-Top, Top-Only** — You can set either of these options, but not both. Neither is set by default:
  - **Top Only** prevents this window from being occluded by other windows belonging to this session.
  - **Always on Top** prevents this window from being occluded by any other window, even those belonging to other applications.

- **Sync With Master** — Forces this layout to take on the attributes of the master layout. This button is disabled unless this layout is an alternate layout. For more information on alternate layouts, see Appendix B, “Multiple Layouts”. 
Chapter 3: Organizer Objects

SmartDialogs

SmartDialogs are special-purpose, outer-level organizer objects, technically a type of frame with a dedicated, inseparable window. They are members of the SmartContainer class, and can integrate other SmartObjects. They differ from SmartWindows in the following ways:

- They cannot serve as the main window of your application.
- They cannot have a menu bar.
- They cannot be resized at run time or scrolled.
- They cannot generate or accept SmartLinks of type Filter.
- They can accept other widgets placed directly on them (that is, without interposing a separate frame).

Because they are always modal, they must be dismissed before any other window can gain focus, so the number of roles they can play is not large. You will typically want to use them to capture user input without which your program cannot continue.

Configuring SmartDialog visual properties

Many of the properties of a SmartDialog are the same as those of a SmartWindow. The principal differences are:

- There is nothing related to resizing, scrolling, or virtual versus actual size, since the size of a SmartDialog is fixed at design time.
- There is no provision for defining a menu bar, since a SmartDialog is limited to pop-up menus.

You can invoke the Tab Editor if you wish to define a special TAB-traversal order, since a SmartDialog is technically a frame and maintains a traversal list. For information about setting traversal order, see the “Traversal-path editor” section on page 376.
To open the property sheet, shown in Figure 20, double-click on the client area of the SmartDialog, or choose Tools→Property Sheet.

![SmartDialog Property Sheet](image)

**Figure 20:** SmartDialog Property Sheet

**Minimal configuration changes**

Although you can choose to accept many default settings, you should at least ensure that each SmartDialog you create is uniquely identifiable. To individualize this SmartDialog, make these changes:

- Replace the generic instance identifier with one that more closely describes the dialog instance you are creating here. The instance identifier is the token that will appear in the source code, and is the default value for the filename. Note that OpenEdge identifiers for dialog objects are conventionally prefixed with a g.

- Change the generic title bar text to a string that identifies this particular dialog.

**Miscellaneous properties (other settings)**

Dialogs have fewer miscellaneous properties than windows do, but those they have in common have the same meaning in both contexts. Dialogs also have a few properties in common with frames:

- **No Auto Validate** — Normally cleared. Setting this box turns off, for all field-level objects in the dialog box, the automatic validation defined in the Data Dictionary.

- **Open the Query** — Normally cleared. Setting this box automatically populates the fields in this dialog box, if there is a query defined.

- **Use Dict Exps** — Normally cleared. Setting this box makes all the validation expressions and help strings defined in the Data Dictionary available to all the widgets assigned to this SmartDialog.
Advanced properties

Clicking Advanced in the property sheet opens the Advanced Properties dialog box:

The only differences between a window and a dialog in advanced properties are:

- Dialog boxes are always modal, so there is no option to make them always appear in front of other objects. Modal objects always appear in front of other objects.

- Dialog boxes have an option to allow box-selection, normally cleared. Box-selection is sometimes called marquee-selection or lasso-selection. It refers to selecting more than one object by dragging a dynamically generated box (the marquee) around them.

Configuring SmartDialog procedure settings

The SmartDialog uses the standard Procedure Settings dialogs. See the “Procedure settings” section on page 366 and the “Advanced procedure settings” section on page 353 for more information.
SmartFrames

SmartFrames are special-purpose organizer objects. They are members of the SmartContainer class and can integrate other SmartObjects.

Every SmartFrame must be supported by a SmartWindow or SmartDialog; they are not independent or outer-level objects. The principal benefit SmartFrames offer is reusability. If you have a self-contained layout that includes SmartObjects, and will be reused repeatedly but would not be appropriate to implement as a SmartDialog, consider implementing it on a SmartFrame.

Configuring SmartFrame visual properties

SmartFrames are based on the frame widget. To open the property sheet for the frame widget component, double-click the client area of the SmartFrame, or choose Tools → Property Sheet to display the frame’s property sheet:

![Property Sheet](image)

Minimal configuration changes

Although you can choose to accept many default settings, you should at least ensure that each SmartFrame instance you create is uniquely identifiable. To individualize a SmartFrame, make these changes:

- Replace the generic instance identifier with one that more closely describes the frame instance you are creating. The instance identifier is the token that will appear in the source code, and is the default value for the filename. Note that OpenEdge identifiers for frame objects are conventionally prefixed with an f.

- If your new frame will have a visible title bar, change the generic text to a string that identifies the purpose of the frame.

Miscellaneous properties (other settings)

You can make a number of changes to a frame’s appearance and behavior, if the default settings do not suit your purposes. Some properties are discussed in the
sections on SmartWindows and SmartDialogs. Listed here are the properties unique to frames:

- **Down** — Normally cleared. Setting this box allows as many frame iterations (logical lines of output) as will fit to be written to the frame before pausing. This option has no meaning if the frame is not being used for direct output.

- **No Box** — Normally set. Clearing this option causes the frame to display with a visible border.
• **Title Bar** — Normally cleared. Setting this box clears the No Box option and causes the frame to display with a border and a prominent, visible title bar. You can set the background and foreground colors of the title bar (click Title Bar Color), though the settings have no effect when the application is running under MS-Windows.

**Advanced properties**

You can make several changes to a frame’s behavior or appearance in the Advanced Properties dialog box:

Some properties are discussed in the sections on SmartWindows and SmartDialogs. The following are the properties unique to frames:

• **{&FRAME-NAME}** — Normally cleared.

• **Manual-Highlight** — Normally cleared. Setting this box allows you to use special highlighting for certain objects.

• **Movable** — Normally cleared. Setting this box allows the user to move the frame within the enclosing space (window, dialog, or other frame).

• **Page-Top, Page-Bottom** — Normally cleared.

• **Resizable** — Normally cleared. Setting both this box and the Selectable box allows the user to resize the frame, within the boundaries of the enclosing object.

• **Selectable** — Normally cleared. Setting this box allows the user to select and, if Resizable is also set, resize the frame.

**Configuring SmartFrame procedure settings**

The SmartFrame uses the standard Procedure Settings dialogs. See the “Procedure settings” section on page 366 and the “Advanced procedure settings” section on page 353 for more information.
Basic windows

Basic windows are general-purpose, outer-level organizer objects. Basic windows are SmartWindows without the ADM smart technology. They are external-procedure objects, and can be used as the main window in your non-ADM applications, but they cannot support SmartObjects.

For information about configuring your basic window objects, see the “SmartWindows” section on page 120. There are only two differences in default properties:

- Basic windows have the Keep Frame Z-Order property set; SmartWindows do not.
- Basic windows do not initialize in a Hidden state; SmartWindows do.
Basic dialogs

Basic dialogs are special-purpose, modal organizer objects. Basic dialogs are SmartDialogs without the ADM technology; they cannot support SmartObjects.

For information about configuring your basic dialog objects, see the “SmartDialogs” section on page 128. There is only a single difference in default properties: Basic dialogs have the Open Query property set; SmartDialogs do not.
Basic frames

Basic frames are non-window, component organizer objects. You can place SmartObjects on a basic ABL frame, even if it is nested in other basic frames, as long as the outer-level object that supports them all is a SmartWindow or SmartDialog.

Creating and placing a frame

Because frames are basic ABL objects, creating and placing one is quite easy.

To create and place a frame:

1. Click on the Frame icon in the Object Palette.

2. Move the mouse cursor over a bare spot in your workspace and click to place the new object. For example:

3. Configure the frame, and adjust its size and position appropriately.

Configuring frame properties

For information about configuring your basic frame objects, see the “SmartFrames” section on page 131. Basic frames are SmartFrames without the ADM Smart technology.
Rectangles

Rectangles are the simplest organizer objects. Their role is entirely visual. Rectangles can be nested within frames and can be placed within or partly within (overlapping) other rectangles. You can place SmartObjects on a rectangle as long as there is an appropriate Smart organizer (SmartWindow, SmartDialog, or SmartFrame) to support them.

By default, a rectangle appears as a figure with a closed, sunken border 2 pixels thick, as shown:

![Rectangle Example](image)

By combining a text widget with a rectangle, you can create an object similar in appearance to a Windows frame widget. For example:

![Frame Example](image)

There is no line object in ABL, but by carefully sizing, positioning, and coloring one or two rectangles, you can create the illusion of a line object. This can be convenient as a visual spacer.

Creating and placing a rectangle

Because rectangles are basic ABL objects, creating and placing one is quite easy.

To create and place a rectangle:

1. Click on the **Rectangle** icon in the **Object Palette**.

2. Move the mouse cursor over a bare spot in your workspace and click to place the new object. For example:

   ![Rectangle Placement Example](image)

3. Configure the rectangle, and adjust its size and position appropriately.

Configuring rectangle properties

Rectangles are basic objects, defined in the ABL itself. Not being objects defined by external procedures, they do not have **Procedure Settings**. Their properties are all contained in property sheets.
To open the property sheet for a rectangle, select the rectangle and choose **Tools** → **Property Sheet**. The **Property Sheet** dialog box shown in Figure 21 appears.

![Property Sheet Dialog](image)

**Figure 21:** Rectangle Property Sheet

**Minimal configuration changes**

You should change the default identifier, shown in the **Object** field, to a token that more accurately identifies the role of this rectangle in your design.

**Border width (edge pixels)**

Rectangles can be very useful as a way to visually define a special area, for example one whose appearance will change because of paging. You might wish to make such an area even more visually special by changing the thickness of the border. This rectangle shows a distinctive, eight-pixel border:

![Rectangle with Eight-Pixel Border](image)

To change the thickness of the border, enter the new value in the **Edge Pixels** field. The results of specifying too thick a border are undefined.

A value of zero (0) will cause the rectangle border to disappear, effectively making the rectangle itself disappear unless it has a fill of a contrasting color.

**Geometry**

Normally, the location of a widget is calculated at its upper-left corner. You can set the location of a rectangle to be its upper-right corner instead, if you wish, by setting the appropriate radio button.

Additionally, by setting the width or height of a rectangle to zero (0) pixels in the **Advanced Properties** dialog box, you can create the illusion of a line.
Rectangles

Miscellaneous properties (other settings)

Rectangles are such simple objects that they have very few properties. You can make changes to those few, if the default settings do not meet your needs, as follows:

- **Enable** — Normally set. Clearing this box causes the rectangle to decline input focus when offered. For this option to be meaningful, you must also set either the Movable or Resizable property. For more information, see the “Advanced properties” section on page 139.

- **Filled** — Normally cleared. Setting this box fills the rectangle with the background color.

- **Graphic Edge** — Normally set. This box interacts with the Edge Pixels (border thickness) setting as follows:
  - Specifying an Edge Pixels value of three or less causes a line-drawing character to be used for the border in character environments. Values over three clears this box and a block character is used for the border in character environments.
  - Clearing this box sets the Edge Pixels value to eight and a block character is used for the border in character environments.

- **Hidden** — Normally cleared. Setting this box prevents the rectangle from displaying itself in response to implicit requests. See the online help for further information.

Advanced properties

You can make several changes to a rectangle’s behavior or appearance in the Advanced Properties dialog:

![Advanced Properties dialog for a rectangle](image)
Four properties you may wish to modify are:

- **Manual-Highlight** — Normally cleared. Setting this box allows you to define and use a special highlighting scheme when the object is selected.

- **Movable** — Normally cleared. Setting this box plus the **Selectable** and **Enabled** boxes allows the user to move the rectangle within the bounds of the enclosing frame object.

- **Resizable** — Normally cleared. Setting this box plus the **Selectable** and **Enabled** boxes allows the user to resize the rectangle within the bounds of the enclosing frame object.

- **Selectable** — Normally cleared. Setting this box plus the **Enabled** box allows the user to select the rectangle.
Simple SmartContainers

The Simple SmartContainer provides you with a way to create smart modules that can run in batch mode without a user interface. You can see this usage illustrated in Figure 42, where loadable modules are created by packaging SmartDataObjects and SmartB2BObjects in simple SmartContainers. Since neither the SmartDataObject nor the SmartB2BObject has a run-time representation, there is no need to use a visible container. The simple SmartContainer provides the critical services encapsulated in the SmartContainer super procedure without the overhead of a visible window. This can be very convenient in selected cases.

Of course, if you prefer to use a visible SmartContainer such as a SmartWindow, you are perfectly free to do so.

Creating and populating a Simple SmartContainer

The Simple SmartContainer is supplied as a template.

To create a complete object in AppBuilder:

1. Choose File→New. Choose Simple Smart Container from the New dialog box that appears:

2. The container appears:

Note that objects of this type do not have a frame element, so you will not see a grid even if you have grid visibility turned on in your Preferences.
3. Reduce the size of the container workspace, if desired. Begin completing your new module by adding a non-visible SmartObject to the container. Shown here is a SmartDataObject:

![SmartDataObject](image)

**Caution:** If you place an object that has a visible representation at run time, the behavior of your simple SmartContainer module will be undefined.

4. Add additional objects as desired to complete the module. A SmartB2BObject is shown:

![SmartB2BObject](image)

As you add such additional objects, Advisors might appear and offer to create SmartLinks for you. Examine each offer and accept those that seem appropriate.

5. Configure each object you employ in the module.

6. Open a **Section Editor**, if necessary, and add code to complete the module.

7. When you have completed the module, save your work using a distinctive filename. Note that simple SmartContainer filenames conventionally begin with `c`. You now have a module you can use in your application.

### Placing and configuring a SmartContainer module

The simple SmartContainer is an organizer object without a run-time representation. You can run it as an independent unit, or use it as a convenient wrapper for a module that you will make the child of some other smart organizer object.

### As an independent module

To run a simple SmartContainer as an independent object requires no special preparation. Build the module as described in the “Creating and populating a Simple SmartContainer” section on page 141, save it, and run it using the startup parameters appropriate to your circumstances.
As a child module

To set up a simple SmartContainer as a child module, use the SmartObject Properties dialog box.

To place and configure a simple SmartContainer module that you created:

1. Click the SmartContainer icon in AppBuilder’s Object Palette.

2. When the Choose SmartContainer dialog box appears, select a module from the Master File list and click OK. For example:

3. Move your cursor to an empty place in your workspace and click to release the object. You will see a representation similar to the following:

4. Right-click on the instance and choose Properties from the context menu. The SmartObject Property Sheet dialog box appears:
5. Change the **Object** identifier to one that more clearly reflects the role of this container in your application.

6. If you wish to use this instance as a placeholder, check the **Parameterize as Variable** box. For information about placeholders, see the “Creating a SmartObject placeholder” section on page 374 and *OpenEdge Development: ADM and SmartObjects*.

7. Save your work.

---

**Note:** The simple SmartContainer does not have a separate **Instance Properties** dialog box.
Creating paged layouts

Every smart organizer (SmartWindow, SmartFrame, or SmartDialog) allows you to partition sets of SmartObjects into logical pages. You can choose to represent these logical pages by separate windows, or by re-using (multiplexing) one or more areas of a single window. The number of different visual effects you can achieve by various combinations of arrangement and object choice is nearly unbounded.

In addition, AppBuilder offers a dedicated paging object: the SmartFolder. The SmartFolder implements the popular tabbed-file-folder metaphor, an industry-standard way to multiplex screen space and control the display of your logical pages.

By designing wisely with ADM paging, you can reduce the experience of visual and conceptual clutter, make better use of limited display space, and improve the usability of your applications.

Page identifiers

Each ADM page is identified by a unique, non-negative integer. Page 0 (zero) exists by default; you must create and assign numbers to all other pages that you need.

You need not assign page numbers sequentially, and it is fine to leave gaps. You can define up to 32767 pages for a given context—a much larger number than you would probably want to try to manage. To create a new page, you need merely make it the current design page (see the “Special pages” section on page 145).

A page remains in existence as long as it is the current design page, or has objects assigned to it. AppBuilder automatically destroys empty pages that are not current.

Special pages

The following page designations have special meaning within the paging system:

- Design page
- Page 0 (zero)
- Startup page

These page designations are discussed individually in the following subsections.

Design page

When you place SmartObjects into a design window workspace, you are placing them on the current design page, whatever that might be at the time. The current design page setting appears in the status bar of the AppBuilder main window, and is meaningful only for placing SmartObjects. The default design page is always page 0. An ADM page may have any unique, non-negative integer as its identifier.

AppBuilder places basic ABL and ActiveX objects on Page 0, regardless of the Design Page setting. Only SmartObjects may reside on pages other than Page 0. You may be able to work around this limitation by placing such non-Smart objects in a SmartFrame, and then placing the SmartFrame on the page of your choice.

As the name suggests, the Design Page setting is relevant only in design mode. It is not meaningful at run time, and is ignored.
To make a different page with the Design Page:

1. Open the dialog box using one of the following methods:
   - Double-click on the **Page Number** field in the AppBuilder main window.
   - Choose **Edit → Goto Page**.
   - Open the **Procedure Settings** dialog box (Tools → Procedure Settings), click **Pages**, and finally click **Design** in the **Pages** dialog box.

2. Enter the number of the new **Design Page**. If that page does not exist, AppBuilder creates it immediately.

---

**Note:** Remember that although you can change the Design Page, the change only affects SmartObjects. When you place other objects, including ActiveX objects, you are placing them on **Page 0** regardless of the Design Page setting.

---

To see the contents of all pages at once, change the Design Page value to a question mark (?). You can then align objects that reside on different pages so that page-changes appear neater and more orderly. All else being equal, users perceive neatness to indicate higher quality.

**Page 0 (zero)**

**Page 0** is the default page in every SmartContainer. If you create a SmartContainer and add objects to it without changing any of the paging settings, then all of the objects will be on **Page 0**.

**Page 0** objects are always displayed. If you have some objects assigned to **Page 0**, some assigned to **Page 1**, and some assigned to **Page 2**, the possibilities for display will be: **Page 0** objects only; **Page 0** objects + **Page 1** objects; **Page 0** objects + **Page 2** objects. Unless you write special code to handle the situation, you cannot exclude **Page 0** objects when displaying objects on other pages.

**Startup page**

You can choose to designate one page, in addition to **Page 0**, to be displayed when the SmartContainer starts up. This is called the **Startup Page**.

**Page 0** is the default **Startup Page**. Unless you explicitly specify a nonzero page number as the **Startup Page**, only the objects placed on **Page 0** will display when you run the SmartContainer.

For example, if you use a SmartFolder to organize the viewing and hiding of pages, you typically designate **Page 1** (which always corresponds to the leftmost folder tab) as the **Startup Page**. If you leave the **Startup** page set to **Page 0** when you use a SmartFolder, then the SmartObjects in the folder will not appear when the application starts up.

You set the **Startup Page** in the **Pages** dialog box, which you invoke from the **Procedure Settings** dialog box.
Why only SmartObjects?

The ADM defines the paging system in terms of a special set of SmartLinks. When you assign a SmartObject to some Page \( n \) in a Smart organizer object, AppBuilder automatically creates a SmartLink of type Page\( n \) between the organizer and the new SmartObject. Since only SmartObjects support and can use SmartLinks, no other type of object can participate in ADM paging.
Paging with SmartFolders

The ADM SmartFolder object offers a convenient, popular way to develop a paged interface design. The SmartFolder implements the tabbed-file-folder metaphor with which most people who work in an office are familiar. The images in Figure 22 show the SmartFolder in use, managing the display of two pages in a toy contact-management application.

![Figure 22: Paging using a SmartFolder](image)

While convenient to use and appropriate for many applications, SmartFolder may not be suitable for all cases. Although you can define up to 32 tabs, they will all be shown in a single line. This spares your users the disorientation of having tab rows re-order themselves, but might require that they use a horizontal scrollbar.

To manage paging in your application using SmartFolder:

1. Sketch out the purpose and organization of each tabbed page. Keep in mind these points:
   - There is no tab for Page 0. The leftmost tab always selects Page 1.
   - Non-Smart objects will always be visible by default, regardless of the tab selected. They always reside on Page 0, and objects on Page 0 are always visible unless you add special code to manage the situation.
• If your design requires that you place non-Smart objects within the perimeter of the SmartFolder, you might need to treat them in a special way.

For example, a rectangle cannot be placed directly on the surface of a SmartFolder—it sinks below the surface and cannot be seen. Nor can it be brought to the surface using Layout → Move-to-Top. To use a rectangle for visual organization, you must first place a borderless (thus invisible) frame object, with its Scroll Bars option turned off, on the SmartFolder. Then place the desired rectangle on the frame. The frame will keep the rectangle from sinking through the SmartFolder. (You should probably avoid placing non-Smart objects within the SmartFolder if you can.)

2. Be sure that your workspace is a SmartWindow, SmartDialog, or SmartFrame. No other organizer object will support ADM paging.

3. Set your Design Page to 0.

Caution: Since nested paging is not possible—ADM supports only a single set of pages for any single SmartContainer—the SmartFolder must always reside on Page 0. If you place the SmartFolder on, for example, Page 1, it will abruptly disappear from view the moment you select the tab for any other page.

4. Click the SmartFolder icon in the Object Palette.

5. Move your cursor over an empty spot on your workspace, and click again to place the new SmartFolder, as shown:

6. An Advisor dialog box will appear, offering to create a Page SmartLink between the Smart workspace and the new SmartFolder object. Examine the offer, and accept it if it seems appropriate.

The Page link allows the SmartFolder to tell the Smart organizer which page to display when the user selects a tab. For more detailed information about SmartLinks and their meanings, see OpenEdge Development: ADM and SmartObjects.

7. If necessary, click on the SmartFolder to reveal its handles (you can see them illustrated in Step 5). Use the handles to adjust the size and position of the SmartFolder appropriately.

8. Click Menu on the SmartFolder and choose Instance Properties. The SmartFolder Properties dialog box appears:
- Enter the labels for the tabs you will use. To move to a new field, click Insert. If you wish to insert a field before the current field, use the UP–ARROW key. To remove an entry, click Remove.

- If you wish to use a special font for the tab labels, click Font and select a font in the dialog box that opens in response (see the “Text style selector and editor” section on page 381 for more information.)

- By default, the width of the each tab agrees with the label; tabs are not of fixed size. If you prefer fixed-size tabs (shown in Figure 22), check the appropriate box and enter a size for the tab. You may need to experiment to achieve a pleasing effect.

When you have finished configuring the tabs and their labels, click OK to dismiss the dialog.

9. Set the Design Page to 1 (remember: the leftmost tab selects Page 1, not Page 0). Place and arrange the SmartObjects belonging to Page 1. To control how the objects layer on top of one another, use Layout→Move-to-Top and Layout→Move-to-Bottom. Check to be sure this is effective: not all objects respond to relayering requests.

Note: Remember that only SmartObjects can participate in ADM paging. If your layout includes non-Smart objects, they will remain visible regardless of the tab selected.

10. Repeat Step 9 for each succeeding page you defined, being sure to set the Design Page correctly each time before beginning to place objects. If you make a mistake, open the Pages dialog and move the misplaced objects to the correct page. See the “ADM pages manager” section on page 351 for more information.

11. Set your Startup Page to the appropriate nonzero number, generally 1. Save your work.
Paging without SmartFolders

Because paging is a property of the ADM itself rather than of SmartFolder objects, it is quite easy to develop an ADM-based paging scheme of your own, if you choose. Figure 23 and Figure 24 represent two possible designs for which AppBuilder supplies predefined controls.

Figure 23: Paging using button controls

Figure 24: Paging using radio-set controls

The two layouts illustrated here resemble a SmartFolder in appearance, but that was a deliberate design choice, not a requirement of the technology. You could create designs that look very different to these. You could use images rather than text on button controls. You could arrange the control buttons along the side or bottom rather than the top, color-code them, use very long strings as labels, and so forth. The possibilities are numerous.

The key to paging is the selectPage() procedure:

RUN selectPage (63).
Inserted as the trigger code for a button **CHOOSE** event, the example call would reveal all SmartObjects assigned to page **63** and hide all others. The value of the argument can be any non-negative **INTEGER**.

An alternative to the `selectPage()` call is the `viewPage()` call. Calling `viewPage(63)` would reveal all SmartObjects assigned to page **63**, but it will **not** hide any others. Anything in view before the call will still be in view after. This creates quite a different effect.

AppBuilder supplies a button that contains the following code for the **Choose** event:

```plaintext
DO:
    RUN viewPage(1).
END.
```

Right-click the button object icon in the **Palette** and choose the **View Page** item from the list. You can convert this button very easily by substituting a call to `selectPage()` for the existing call to `viewPage()`. Make this substitution using AppBuilder’s built-in **Section Editor**.

Buttons are not your only choice for paging controls. AppBuilder also supplies a set of radio buttons predefined with `selectPage()` calls. Right-click the radio-set object icon in the **Palette** and choose the **Page Select** item from the list.

**Note:** You should keep in mind that Progress Software Corporation supplies this radio set as a convenience, but does not necessarily endorse its use. Most experienced GUI users expect radio-sets to represent data, so using them as action controls might cause confusion and reduce your application’s usability.
Paging whole windows

You will find it easiest to construct an ADM-based paging system if you design with a single SmartWindow in mind as the paging context. The examples above follow such a single-window model.

If you are careful to design appropriately, you can construct a multi-window application that uses ADM paging to control window display and hiding. Figure 25 shows a sample application in which the larger window is opened or closed by the buttons in the smaller window.

Figure 25: Paging a whole window

To reproduce the example shown in Figure 25:

1. Create a new SmartWindow. This will be the Work window. Populate it with a SmartDataObject, SmartDataViewer, and the two SmartPanels (navigate and update). Save this assembly under a distinctive name.

2. Create a second new SmartWindow. This will be the control window. Populate it with two buttons, using the View Page versions of the buttons for convenience. Change their labels appropriately.

3. Select the button that will open the Work window. Open the Section Editor and replace the call to viewPage(1) in the trigger code with a call to selectPage(1). Close the Section Editor window.

4. Set the Design Page to 1. Select the SmartContainer object tool from the Palette. When the Selection dialog box opens, choose the file that represents the Work window you created and saved in Step 1.

5. Place this object in the control window.

A SmartWindow placed in this way will not display its run-time representation, but instead will present as a non-visible SmartObject. This is as it should be—the Work window is an independent SmartWindow and thus has no code that would allow it to open within the control window as a component object. Within the control window, the Work window is indeed a non-visible object.
6. Select the button that will close the **Work** window. Open the **Section Editor** and replace the call to `viewPage(1)` in the trigger code with a call to `selectPage(32768)`. Note that the number need not be 32768—simply choose some distinctive, non-negative integer that you are not using for an actual page number.

A call to `selectPage()` always turns off the old page before turning on the new one. However, since you have not defined a page 32768, there is no new page to turn on. So pressing this button will only have the effect of closing (turning off) the **Work** window.

7. Save the control window object. Run it, and choose the buttons to open and close the work window.
Data-Access Objects

Locating, reading, and writing database records is the one fundamental activity in any database application. This chapter describes the data-access objects AppBuilder supplies for your use, and discusses how to create, modify, and use them.

Topics discussed in this chapter include

- Introduction to data-access objects
- SmartDataObjects
- SmartBusinessObject
- SmartFilters
- Making changes to the data stream
- Creating a freestanding query object
- Defining and editing queries using Query Builder
- Selecting database fields for browsing
Introduction to data-access objects

Almost all database operations are performed against only a subset of the records in a database, and often against only a subset of the fields within those records. The reasons for this typically include security and privacy issues, the limits of human cognition and, in modern multi-terabyte databases, the computational and real-time costs of repeatedly traversing enormous numbers of irrelevant records.

Every OpenEdge application you build, regardless of what it does with the records afterwards, will start by connecting to at least one database and fetching records that meet certain criteria.

AppBuilder offers several powerful ADM SmartObject modular building blocks for data access:

- Static and dynamic DataView(s)
- Static and dynamic SmartDataObjects (SDOs)
- SmartBusinessObject (SBO)
- SmartFilter

These are in addition to the standard ABL objects including standalone queries and objects that combine data access with visualization and update capability.

The rest of this chapter discusses how to use these building blocks in your applications.
DataViews

A data view is a logical view of data. The structure of a data view does not reflect the structure of data in a particular data source. Rather, the data view’s structure represents a convenient arrangement of data for a particular task. A data view might include calculated data or even data from several different data sources.

The OpenEdge DataView is an ADM2 implementation of a data view. The DataView provides data binding between an ADM2 UI and a ProDataSet. The DataView is based on ProDataSets to take advantage of their efficiency. To make integrating DataViews into your applications easier, DataViews have the same object type as SDOs. This type enables existing visual objects to connect to DataViews exactly as they do to SDOs.

When you look at how a data object gets data from the data source to the UI, the process has these main parts:

- The interface between the data object and the UI
- The in-memory data storage
- The data access from the data source

In the SDO, these parts are encapsulated in a single object. When you work with DataViews, the process is spread between several objects. The DataView handles the data interface with the UI. The data interface transfers data between the UI and the in-memory data storage. One or more ProDataSets, managed by a DataContainer, handle the in-memory data storage. Finally, a Service Interface that you create serves as the gateway to the back-end process that handles data access with the ultimate data source.

This separation fits well with the OpenEdge Reference Architecture style of programming. The reference architecture also calls for a Service Interface between the back-end processes of the Business Services layer and the front-end processes of the Presentation and Integration layers. The DataView fits neatly into this prescription.

Note: For more information on programming with DataViews, see the development whitepapers on PSDN Web site:
http://www.psdn.com/library/index.jspa
SmartDataObjects

SmartDataObjects (SDOs) are modular data pumps that incorporates ADM Smart technology. They communicate in a loosely coupled way with other ADM SmartObjects using SmartLinks, and with objects on the Web using WebSpeed. They can also function in an Open4GL environment with non-ABL objects. SDOs are supplied for your use in both dynamic and static forms.

Static SmartDataObjects

Static SDOs act as custom data pumps, each producing and managing a specific data stream based on the terms of a specific query. You define a base version of that query within a master version of the object at design time.

Depending on your business needs, you can also define and add custom validation routines to the master object. These validation routines can operate at various levels of granularity, from a single field to a whole transaction. Once you have the master defined, you can then use instances made from it as often as you like.

When you compile such a static SDO, the Compiler creates two different versions of the executable r-code. One represents the complete object, usable in any context. The other is a stripped-down, client-only version. Figure 26 illustrates this process.

Figure 26: Compilation of an SDO

The stripped-down version (identified by _cl in the filename, for example: dTest_cl.w) will load whenever there is no local database connection. A _cl object expects to cooperate with the complete version of the same object loaded as part of an AppServer partition.

You can associate business rules or any other required logic with the object by writing the necessary code.
Dynamic SmartDataObjects

The dynamic version of the SDO is designed particularly for distributed use.

A static client-side SDO can only deal with one particular data stream—the specific data stream being supplied by its counterpart on the server. This is a limitation that can be significant where many such streams are involved, if the client-side objects are not stored locally. The OpenEdge WebClient is one such case—it is designed to be downloaded for use over a wide-area network such as the Internet. (See OpenEdge Deployment: WebClient Applications, for detailed information about downloading and using the new WebClient.)

The dynamic SDO solves a large part of this problem.

The dynamic object acts as a generic, general-purpose data pump. It is not limited to handling a specific data stream, as a static SDO is. The dynamic object automatically cooperates with any static, server-side SDO and can be attached to any client-side display object such as a SmartDataBrowser or SmartDataViewer.

These broad capabilities come at the cost of client-side customization.

Because it is designed to handle a data stream of any composition, you cannot enhance the dynamic SDO with custom routines. This is true even of custom validation procedures. You can add custom client-side validation routines to the static object, if you choose, but you should remain aware that all such custom routines will actually run in the static object on the AppServer, not on the client.

Since any SDO is only a data pump, you must connect its data stream to other modules for display or manipulation. Those other objects can take a number of forms, both OpenEdge and non-OpenEdge. You define and create them separately from the SDO.

Creating a SmartDataObject master

The individual static SDOs you employ as building blocks in your application are instances of one or more master objects. Using the AppBuilder’s SDO design wizard, you can create any number of masters that produce different data streams based on the queries you define in them.

Design considerations

Before you start the SmartDataObject Wizard, you should consider these questions:

- Will you need to define a temp-table first to reduce the amount of processing? Large quantities of data can affect performance. If your application must repeatedly traverse a very large database, you might get a significant performance increase by first subsetting to a temp-table, and then operating on that subset instead.

  Note that although the wizard will allow you to define such a temp-table, and will allow you to assign it as the SDO’s data source, you must write the code by hand that actually locks and copies records from the permanent table. This population step must take place before you give the SDO access to the temp-table at run time, if the rest of your application expects to find records in the table.

- What databases and tables do you want this SDO to use? This base query can be refined or sorted at run time.
Chapter 4: Data-Access Objects

- What fields do you want to expose to client objects, and what properties (such as read-only) do you want to set for each data element?

- What are your plans for validating data on the client side (the user interface side) and the SDO side? See the “Data validation limitation” section on page 169 for a discussion of an unusual and potentially important issue.

Creating the master

AppBuilder's **SmartDataObject Wizard** leads you though creating an SDO master.

**To create an SDO master:**

1. Click the **SmartDataObject** in the **Object Palette**. The Choose **SmartDataObject** dialog box appears.

2. Click **New**. The **SmartDataObject Wizard** appears:
3. Click **Next**. Page 2 appears:

![SmartDataObject Wizard - Page 2 of 5](image)

4. The SDO supports an external super procedure that allows you to encapsulate business logic called the data logic procedure. You can reuse this data logic procedure or specify a unique data logic procedure for each SDO. Activate the **Use SDO logic procedure** to indicate you want to use a data logic procedure. Specify the appropriate template in the **Use template** field and the procedure name in the **Logic procedure file name** field.

5. Click **Next** to move to Page 3:

![SmartDataObject Wizard - Page 3 of 5](image)

6. If this SDO will operate on one or more temp-tables, click **Define Temp-Tables** to open the Temp-Tables Maintenance Editor. Using the editor, define the temp-tables this SDO will use. See the “Temp-tables maintenance” section on page 378 for information about how to use the editor.

7. Click **Define Query** to start Query Builder. Define the base query this SDO will use. See the “Defining and editing queries using Query Builder” section on page 188 for information about how to use Query Builder.

---

**Note:** The option to create a free-form query is not available to you at this stage. If you need or want to create a free-form query, you must create a placeholder using Query Builder and then edit the query after the wizard completes. See the “Editing a SmartDataObject master” section on page 164 for further information.
When you finish with **Query Builder**, you will see displayed on **Page 3** the text of the query you just created.
8. Click **Next** to go to Page 4 of the wizard:

![SmartDataObject Wizard - Page 4 of 5](image)

9. Note that at this point, the list of fields is empty. Click **Add Fields** to start the Column Editor, and use the editor to select the fields that you want to make available through this SDO.

When you return from the Column Editor, the list will be populated with the fields you have chosen, as shown:

![SmartDataObject Wizard - Page 4 of 5](image)

For information about how to use the Column Editor, see the “Selecting database fields for browsing” section on page 168.

10. Click **Next** to advance to the next page. If you successfully defined a database query and the related SDO RowObject temp-table fields, the **Congratulatory** screen displays. (If not, press the **Back** button and make any necessary changes.)

11. Click **Finish** to dismiss the wizard and reveal the new SDO master:

![SmartDataObject - Untitled](image)

12. Choose **File** → **Save** and give the new master a descriptive filename. Note that, by convention, SDO filenames begin with “d”.

The new SDO master is now available for your use.
Note, too, that AppBuilder actually creates two different forms of the master. If you were to give it the name dExampleSDO and then check the file system, you would see the following:

- A standalone version, named dExampleSDO.w. This version is loaded whenever there is a local database connection. AppBuilder creates it with the DB-REQUIRED preprocessor value set to YES, since it should not load if there is no database connection.

- A client-side version, named dExampleSDO_cl.w. AppBuilder creates it with DB-REQUIRED set to NO. This version is loaded when there is no local database connection, on the presumption that the application is running in client/server mode and the database is resident on the server side. This version is compiled with all DB-REQUIRED internal procedures stripped out, which can create a problem. See the “Data validation limitation” section on page 169 for further information.

**Editing a SmartDataObject master**

Any modular system must have and enforce strict data-exchange requirements if it is to avoid possible data corruption. Although you can always update your SDO masters to reflect your changing needs, you must also update any other master objects that share data with them. Furthermore, you must sometimes update all the masters in a specific order if you are to avoid breaking the signatures on which data communication depends. For more information about making data-stream changes successfully, see the “Making changes to the data stream” section on page 186.

To edit an SDO master:

1. Choose File → Open and select the main source file (for example dExampleSDO.w, not the dExampleSDO_cl.w client-only file). The SDO appears:

![SmartDataObject - dCust2.png](image)

2. Double-click on the object. The SDO property sheet dialog box appears:

![Property Sheet - Query-Man.png](image)

3. Click Query to edit the existing query, if necessary. See the “Defining and editing queries using Query Builder” section on page 188 for information about how to use Query Builder.
4. Click on the Fields button to modify the original fields and their attributes. See the “Selecting database fields for browsing” section on page 168 for information about how to use the Column Editor.

5. Save your changes.

Creating a SmartDataObject instance

Once you have an SDO master designed that will supply the data you need, you can re-use it indefinitely. Because of the way AppBuilder checks for opportunities to create SmartLinks, you will probably find it good practice to select and place your SDO instance before you place the instances of the SmartObjects that will communicate with it.

To use an SDO in your application:

1. Open the Choose dialog box by clicking on the SmartDataObject tool icon in the Object Palette. When the dialog box opens, select the appropriate SDO master from the list:

   ![Choose SmartDataObject dialog box]

   If you have difficulty remembering which SDO master is which, choose Preview to open a dialog box that displays the fields listing for the selected master:

   ![Preview SmartObject dialog box]

2. Position the new instance (created automatically when you chose the master) anywhere you like in your smart organizer workspace, and click to release. The following is the design-time representation you will see:
3. AppBuilder will now automatically look for opportunities to create SmartLinks between it and other SmartObjects in the same organizer context. If it thinks it has found such an opportunity, an Advisor window opens. The example shown here presumes that you had previously placed a Navigation SmartPanel:

![Progress Advisor](image)

If the suggested link seems appropriate for the needs of your application, click OK. If you decide later to make changes, you can easily revise the linkage using the SmartLinks Editor. For more information the SmartLinks Editor, see the “SmartLinks editor” section on page 369.

4. Set the properties of this SDO instance. See the “Configuring a SmartDataObject instance” section on page 166 for further information.

5. Save your work.

### Configuring a SmartDataObject instance

Every SDO instance has a number of default properties you might wish to change. Two of the most important are:

- **Determinism** — By default, every instance represents a particular master object with a defined behavior. Sometimes, it might be more appropriate to treat the instance as a placeholder at design time, and conditionally load a particular SDO under program control at run time. The possible applications for this are numerous.

- **Statelessness** — By default, SDOs do not bind their AppServer session unless the AppServer Broker is configured to run statefully, with session-long connections. If the AppServer Broker is running in stateless (connectionless) mode, so will the SDO. Statelessness allows many more clients to share the available AppServer sessions. The cost is an increase—typically small—in the time it takes to re-establish connection for each request. To avoid this time penalty in selected cases, you can choose to force the SDO to bind its session and operate statefully.

**To configure the SDO instance:**

1. Right-click on the instance and choose Properties. The Property Sheet dialog box appears:
2. Change the **Object** identifier to one that more accurately reflects the role of this SDO in your application.

3. If you wish to use the object as a placeholder, see the “Creating a SmartObject placeholder” section on page 374.

4. Click **OK**.

5. Right-click on the instance, and choose **Instance Properties**. The following dialog box appears:

6. Set the properties and click **OK**. For more information on the properties, see the online help.
Selecting database fields for browsing

When you create an SDO master, you can access Column Editor with the Fields button on the SDO property sheet. Using the Column Editor, you can choose fields to be displayed by the browser object, impose an ordering, and define other characteristics, as shown:

Creating calculated fields

Very often, when creating applications, you will want to present a field to the user that is the result of some transformation applied to one or more other fields. Current value of inventory is one possible case, and invoice line-item total is another. The number of such potential uses is large.

The Column Editor allows you to create such calculated fields in a straightforward way.

To create a calculated field from the Column Editor’s dialog box:

1. Click the Calculated Fields button. The Calculated Field Editor dialog box appears:
2. Compose the expression whose result will appear in the field. You can compose by typing directly into the field, by double-clicking on tokens (Fields, Functions, Operators), or by some combination of these two methods. The expression can be of any complexity. Click OK when the expression is complete. The dialog box closes.

3. The newly defined field appears in the list of fields with the default identifier CALC, a default type of CHARACTER x(8), and no label. Change the identifier to one more meaningful in the context of your application. Add a label, if appropriate.

4. Change the data type and format, if necessary, to reflect the nature of the data. For example, if the expression yields a floating-point result, change the data type to DECIMAL and the format string to one that portrays DECIMAL values.

5. If appropriate, click Advanced and enter a Help string for this field.

6. Use the Move Up/Down buttons to put the new field into the correct relationship to the other fields that will display.

Note: Calculated fields are created in a not-updatable state. Although you can set them to be updatable, in general you should not: a calculated field is a scratch field, and is undefined in the context of the database. It can be easy to forget this. If you do choose to make a calculated field updatable, you must write the code yourself that will interpret any changes that a user makes.

Data validation limitation

You can choose to add data-validation procedures to your SDO. These optional procedures can operate at the column, row, or transaction level. If you do choose to create such routines, you must create them as internal procedures. Because the SDO calls these procedures automatically, you must follow the expected naming and error-handling conventions. See OpenEdge Development: ADM Reference for details.

SDOs have the DB-AWARE flag set. For DB-AWARE objects, AppBuilder sets the DB-REQUIRED flag in all new internal procedures, including validation procedures. Generally this is appropriate and useful. In one specific set of circumstances, however, it is not, and you will have to explicitly turn off the DB-REQUIRED flag. Those conditions are as follows:

- The application will run on an AppServer. Applications that do not run on an AppServer are not affected. Note that good practice suggests that you always design for the greatest flexibility of use.

- The client program does not require a local database connection through an SDO. Client programs that must have such a local connection in order to run are not affected. Note that good practice suggests that you always account for the case of no local connection.

- Your routines validate rows or columns (fieldnameValidate(), RowObjectValidate()). Routines that validate whole transactions (TransactionValidate()) are not affected.
The problem comes about because all DB-REQUIRED routines are removed from the client-only version of the SDO during compilation. This allows the program to load and run in the absence of a database connection. If your validation routines are marked DB-REQUIRED, then they, too, will be removed.

Normally, calling a non-existent routine would cause a run-time error. But calls to optional routines never complain if they fail, and validation routines are always optional. The net result is that, when the client-only object is loaded, database updates are carried out without client-side validation checks even though you wrote the routines to perform them. Neither the compiler nor the interpreter can detect this logical error.

**Solving the problem**

The following guidelines will help you avoid errors:

- Divide your validation tasks according to whether they require a database lookup operation. References to RowObject or other temp-tables do not count as lookup operations.

- Write your `fieldnameValidate()` and `RowObjectValidate()` procedures to include only the validation operations that do not require lookup. Do not include direct references to a database in these procedures, and turn off the DB-REQUIRED flag in them. AppBuilder offers a convenient option in the Section Editor for this purpose.

- Put any validation operations requiring lookup into one of the `TransactionValidate()` procedures. Keep the DB-REQUIRED flag turned on in these procedures.

By writing your `fieldnameValidate()` and `RowObjectValidate()` procedures such that you can legitimately turn off the DB-REQUIRED flag in them, you ensure that these routines will survive compilation and that all validation will occur as you intend.

**Forcing server-side validation**

It is generally more efficient to do row and column validation on the client side, as part of `SubmitRow()`. There are some cases where this is not possible—such as calling an SDO from a Java program where no client-side version of the object exists. You would then want to force all validation, including row/column validation, to take place on the server. You can do this with a single line of code.

This code also works in the case where there is a client. In that case, the client-side validation operations take place first on the client side, and then a second time on the server side. This introduces some inefficiency, but is not otherwise harmful.

To force all validation to take place on the server, regardless of whether it also takes place in the client:

1. Open your SDO master for editing. It will appear on your display, as shown:

   ![SmartDataObject](image)

2. Choose Window → Code Section Editor, and then select Procedures from the sections list.
3. Create a new procedure called `initializeObject()`—or edit the existing procedure by that name, if you already created it—and include the following line in the procedure:

```
DYNAMIC-FUNCTION( 'setServerSubmitValidate', yes ) .
```

4. Save your work.

All instances made from the SDO master you just changed will now perform all row/column validation on the client side—if there is a client—and on the server side too.

**Using the dynamic SmartDataObject**

In a situation involving an AppServer, part of the application runs on the client and part on the AppServer. Dividing the application in this way is done almost automatically—the only special thing you do is identify the AppServer partition at design time.

Changing your application to use the dynamic SDO is a one-step process: once your application is complete, move the `_cl` file (for example: `dSample_cl.w`) out of the `PROPATH` search space. If you are certain you will never want to use the static version on the client side, you can delete it. Otherwise, move it to a safe backup location.

That is all you need to do. If the `_cl` file cannot be found at run time, the dynamic object will be loaded and used instead.

**Caution:** The static SBO (see the “SmartBusinessObject” section on page 172 for information about that object) does not support the dynamic SDO. Generally speaking, you will get the best results if you create separate SDOs for standalone and SBO use. If you must use the same SDO in both an SBO and in a standalone context, **do not move or delete the `_cl` file.** If it cannot be found during initialization of the SBO, initialization will fail and the SBO will not run.
The SBO allows you to neatly package and fully synchronize—including the ability to update in a single, server-side transaction—up to twenty SDOs. Figure 27 illustrates the place of an SBO in a Web-enabled application.

Figure 27: SBO in a Web environment

Each static SDO produces and manages a single data stream. The nature and composition of that data stream is dependent on the query that you define within the object. Although you can cause a single SDO to produce a data stream of great complexity by the skillful use of JOINs, the result is often messy and difficult to use for business purposes.

One way to reduce complexity is to create a number of SDOs, each with a more simple query, and then synchronize them at the application level. For example, you might create five SDOs that respectively supply:

1. Customer records
2. Order records for a particular Customer
3. OrderLine records from a particular Order
4. Item records related to a particular OrderLine
5. Inventory records related to a particular OrderLine
Figure 28 illustrates these relationships.

![Data relationship among five tables](image)

Synchronizing their read operations is not difficult. You can use DATA SmartLinks for that purpose regardless of whether you use an SBO.

The difficult task is synchronizing updates. In general, there is no simple way to update multiple, standalone SDOs in a single transaction, if the objects run in a distributed environment. Such objects operate independently of one another on an AppServer.

The new SBO solves this problem by providing a single context for all the SDOs you embed in it. Because the code you write in the SBO can operate on all the RowObject temp-tables belonging to its subordinate SDOs, the SBO allows you to perform updates in a single server-side transaction. With the SBO, you can create and manage integrated data streams that are as complex and powerful as your customers’ business needs demand.

The SBO presents a single point of contact for external modules such as Smart data-display objects. Internally, it uses its CONTAINER links to connect those external objects with the SDOs it contains—communicating navigation instructions from a SmartPanel, for example, or sending data out to a SmartDataViewer for visualization. This all happens automatically; you need do nothing to make it work. The SDOs synchronize themselves using DATA links that you create.

**Creating and placing a SmartBusinessObject**

The SBO is a special-purpose organizer object and a member of the class SmartContainer. As is true of other organizer objects, the SBO is supplied as a nearly finished template. There is no wizard involved; you need only create a copy, populate it, and add SmartLinks.
**Caution:** The SBO only supports static SDOs. If it cannot find the client-side (_cl) files at run time, it will not be able to use the dynamic SDO and will report an error when it fails to start up successfully.

---

To create an SBO master:

1. Click the **SmartBusinessObject** in the **Object Palette**. The **Choose** dialog box appears.

2. Click **New**. AppBuilder creates the appropriate workspace, which looks like a frameless SmartWindow. Because an SBO has no frame element, you will see no layout grid even if you have grid visibility turned on:

![SmartBusinessObject](image)

3. Populate the object and configure it. See the “Populating and configuring a SmartBusinessObject” section on page 174 for more detailed information. Save the object using a distinctive filename. Note that SBO names conventionally begin with `sbo`.

4. Click the **SmartContainer** tool icon in the **Object Palette**. When the **Selection** dialog box opens, select the SBO master you just defined.

5. Move your mouse cursor over your application workspace and click to place the new object instance.

6. If you have already placed other SmartObjects such as a SmartDataBrowser, an **Advisor** might now appear and offer to create SmartLinks between those objects and the new SBO. Examine the offers and accept those that meet your needs.

7. If the **Advisor** does not offer to create all the links you desire, choose **Tools** → **Procedure Settings** and open the **SmartLinks Editor** to add links by hand. For information about the **SmartLinks Editor**, see the “SmartLinks editor” section on page 369.

8. Save your work.

---

**Populating and configuring a SmartBusinessObject**

You must complete the following major tasks when configuring your SBO master:

1. Determine what data this object will supply and decide how you will divide the total effort.

   In general, consider using one SDO per table. You can populate your SBO with a maximum of twenty SDOs.
2. Create and place the SDOs, add DATA links to represent the logical dependencies among them, and identify the foreign-field (relational) mappings.

For detailed information about creating and placing SDOs, see the “Synchronizing SmartDataObjects using DATA links” section on page 175.

3. Determine whether the users of your application are more likely to prefer efficiency or completeness when browsing the data stream and set the property CascadeOnBrowse accordingly. This is a somewhat subtle issue.

4. Determine your validation needs and create the appropriate routines to perform those tests.

The SBO makes it easier to perform comprehensive validation tests. Besides the tests local to each SDO, you can write validation routines that run in the SBO itself. The SBO can see the Update tables belonging to each of its contained SDOs and you can take advantage of that fact to create whole-stream validation.

Within the SDOs themselves, their update tables all have the same RowObjUpd identifier. Since they have separate namespaces internally, this is not a problem. But at the level of the SBO, each such update table needs a unique name. The ObjectName property serves that purpose.

So if your SBO contains two SDOs to which you have given the ObjectNames CustSDO and OrderSDO, you can write code referring to fields in their respective RowObjUpd tables as CustSDO.SomeFieldName and OrderSDO.SomeFieldName and everything will work as you intend.

For additional information about creating validation routines, see OpenEdge Development: ADM and SmartObjects.

Synchronizing SmartDataObjects using DATA links

To get the benefits the SBO can provide, you must identify the business hierarchy between the contained SDOs. You do this using SmartLinks of type DATA. The DATA-SOURCE is always the object that initiates a change and the DATA-TARGET is the object that must respond by staying in sync.

In the situation shown in Figure 28, you would create DATA links from the Customer object to the Order object, from Order to OrderLine, and from OrderLine to both Item and Inventory.

Figure 29 shows the hierarchy imposed by the DATA links.
Before deciding how to organize your DATA links, determine your business focus. If you are interested in both Customer and Order records, which are more central? Are you interested in orders only in connection with a particular customer? Or is your focus the order itself, with customer information being secondary? In the first case, you would create your DATA link from the Customer object to the Order object. In the second case, the link would go in the opposite direction. How you organize the dependencies is a function of your business goals.

**Note:** The SBO itself can be the target of a DATA link from some SDO outside itself. The effect when resynchronization takes place is exactly as though both objects were combined—the resynchronization process propagates through both objects.

---

**To create a synchronizing relationship between two SDOs within the SBO:**

1. Create and place the first (controlling) object.

2. Create the second (controlled) object, being sure to include at least one field shared with the first object. For example, the CustNum field is common to both the Customer table and the Order table. That field (the foreign field) relates those two tables. Note that the field need not have the same name in both tables, although it often does.

3. Place the second object. An Advisor dialog box appears and offers to create a DATA link from the first object. Accept the offer, as shown:

   ![Advisor dialog box](image1)

   **Note:** The SBO itself can be the target of a DATA link from some SDO outside itself. The effect when resynchronization takes place is exactly as though both objects were combined—the resynchronization process propagates through both objects.

4. Another Advisor dialog box appears asking you if you wish to identify the foreign-field (relational) mapping. Unless you have a reason to defer this operation, accept this offer as shown:

   ![Advisor dialog box](image2)
5. The **Multi-Field Mapping** dialog box appears showing the lists of available fields. Select the field common to both tables, for example **CustNum**, as shown:

![Multi-Field Mapping dialog box](image)

6. Click **Map**. Your selections disappear from the **Source** and **Target** lists and reappear as an associated pair in the **Mapped Fields** field, as shown:

![Multi-Field Mapping dialog box](image)

7. Create additional associations, if you so desire and there are suitable field pairs. When you have finished, click **OK** to close the dialog box. Synchronization between these two SDOs is now established.

8. Repeat from Step 2 for each additional SDO you place, creating a synchronizing **DATA** link only from the immediately preceding object.

   **Note:** The **Advisor** is not aware of your goal, so it will offer to create a link from any existing object. It is easy to become confused and select the wrong object. If you make such a mistake, use the **SmartLinks Editor** to correct it.

9. When you have linked all the SDOs appropriately, save your work.
If you were to create the relationships shown in Figure 29, they would appear in the SmartLinks Editor looking similar to the following:

![SmartLinks Editor](image)

**Configuring a SmartBusinessObject instance**

Configuration options are found on the **SmartBusinessObject** menu.

To configure the properties once you have populated and created the synchronizing relationships in your SBO:

1. Right-click on the instance and choose **Properties**. The **Property Sheet** dialog box appears:

   ![Property Sheet](image)

   2. Change the object identifier to more accurately reflect the role of this SBO in your application.

   3. If you wish to use the object as a placeholder, check the **Parameterize as Variable** box. See the “Creating a SmartObject placeholder” section on page 374 for further information about placeholders and resolving them at run time.
4. Click **OK** to close the dialog box. Right-click on the instance and choose **Properties**. The following dialog box appears:

5. Select the **Partition** this object will be assigned to when running on an AppServer.

If there are no partitions listed, you can define as many as you need. Close the dialog box and use the AppServer Service Parameter Maintenance Tool, available from the PRO*Tools toolbar. The **Partition** tags that you define in this way are immediately made available to AppBuilder and will appear in this list when you reopen this dialog box.

6. Use the **MoveUp/MoveDown** buttons to arrange the list of SDO names to agree with the synchronization hierarchy you have defined. The first object (**Customer**, in the example shown in Figure 29) must be at the top of the list. The order of objects at the same level (in Figure 29, Item and Inventory are at the same level) is not significant.

7. Click **OK** and save your work.
SmartFilters

The query you build into your SDO might return thousands—or even millions—of records. A return of such size can totally overwhelm users, causing them to fervently wish for a way to further subset the data stream. AppBuilder offers an ADM SmartObject to deal with that problem: the SmartFilter.

The SmartFilter provides a query-by-form (QBF) interface to the data stream supplied by your SDO. Using the SmartFilter, the user of your application can narrow the query as much as desired, possibly causing the query to return only a few records or even no records at all. Being able to focus the query more tightly can be very convenient for the user.

As seen by the user, the SmartFilter is rather simple. Each filterable field is represented by one or two editable fields representing a value and a comparison operator, as shown:

The user controls the object’s behavior using the following buttons:

- **Apply filter** — Activates the filter immediately, reducing the size of the data stream. To clear the effect of a filter, the user must click **Blank** and then **Apply**.

- **Blank** — Clears all editable fields and resets the operators (if visible) to their default states, ready for the next setup.

- **Reset** — Restores the most recent filter expressions. Does not clear the fields.

The SmartFilter is supplied as a pre-compiled master rather than as a template.

To include an instance of the SmartFilter in your application:

1. Click on **SmartFilter** in the Object Palette. There might be a short pause while AppBuilder creates the instance.

2. Position the cursor over the workspace and click to place the instance.
3. If you previously placed an SDO, AppBuilder now opens an Advisor window offering to create a Filter link to it. Unless you have reason not to do so, accept the offer:

4. Inspect the properties for this SmartFilter and change any that do not meet your needs. See the “Configuring SmartFilter properties” section on page 181 for information about how to do that.

5. When you have finished making changes, click OK to dismiss the properties dialog box.

6. Click the object to select it. Drag the handles to position and size the object to suit your layout. Your SmartFilter is now ready for use.

### Configuring SmartFilter properties

There are a number of changes you can make to the appearance and behavior of a SmartFilter instance through the Properties dialog box. This section discusses the options available to you.

To open the dialog box, right-click on the instance and choose Properties. The dialog box appears as shown:
Chapter 4: Data-Access Objects

Data

This area identifies the data source, and the fields to be filtered:

- For your convenience, if you place the SmartFilter object into your workspace after you place the SDO, AppBuilder automatically fills in the Target field for you. This is generally the best way to do it.

But if you place the SmartFilter instance first, you can still fully configure it. Click the Browse button and, when the Choose dialog box opens, select the appropriate SDO and click OK. The object filename immediately appears in the Target field, and a list of database fields supplied by that master populates the Fields field. Note that you are not in any way attaching that data source at this point; you have merely identified it so that you can configure your SmartFilter.

- By default, none of the fields supplied by the SDO are filterable.

Click Edit Field List and select the fields to make available for filtering. They will appear in the Fields list. If you change your mind about one of the fields, simply select it and click Remove. Removing the field from the filterable list has no effect on the data stream or the SmartObject assigned to display the data. To restore a field to the filterable list, click Edit Field List and add it back.

Note that performance might be unacceptably low if the number of records is large and you allow the user to filter on fields that are not indexed.

Style

You can define the amount of control the user has over the filter operation by setting the Style value. The Style you choose applies to all fields unless you modify the setting for a particular field. The possible values for Style are:

- Implicit — Choosing this option removes the relationship operator from the user’s control. The user still selects the value against which the filter tests, but cannot change the nature of the test (equality, inequality, etc.). You set the type of test at design time using the related combo box.

By default, the operation you choose in the combo box is ignored for character string fields. Character strings undergo a BEGINS test regardless of the setting in the combo box. If you want character strings to be tested using the operator you set in the combo box, uncheck the BEGINS box in the String Operator frame (below the Style radio buttons).

When Style is set to Implicit, you can set individual fields to be Ranges, instead. See the View as Range Fields option in the “Field Properties” section on page 185.

- Explicit — The default Style. Choosing this style allows the user to select the type of test on a per-field basis. The user selects the operator from a combo box (default) or by setting a radio button; see the “Operator View As” section on page 183.

Because BEGINS can be applied on a per-field basis for character fields (it appears in their list of operator choices), the global BEGINS option is disabled when Style is set to Explicit.
You can set individual fields to be ranges. See the View as Range Fields option in the “Field Properties” section on page 185.

- **Range** — Choosing this style causes the SmartFilter to display two fill-ins for each field, representing the upper and lower bounds of a range. The user types in the limiting values, which are considered **inclusive**. For example, entering c as the lower bound and e as the upper, for a CHARACTER field, will return all records where the value for that field is in the range c* through e, inclusive. Note that while e itself would be included, e* is not. Similarly, entering bounds of 10 and 100 for an INTEGER field would return all records where the value of that field is in the range 10 - 100, inclusive.

When Style is set to **Range**, you can set individual fields to be **Explicit**, instead. See the Explicit Operator option in the “Field Properties” section on page 185.

- **Inline** — Choosing this style requires that the user enter the comparison operator along with the value. For example, to test for INTEGER values over 10, the user must type in $> 10$.

  If the user enters a value without an operator, for example 10 rather than $>10$, the SmartFilter will presume the intended operator is **EQUALS**. The only exception is if the field is of type CHARACTER and the BEGINs check box is set. In that case the SmartFilter will perform the BEGINs test instead.

**String Operators**

When these check boxes are enabled, setting them overrides any conflicting setting in Style:

- **BEGINs** — When checked, the SmartFilter will perform a **BEGINs** test against CHARACTER fields

- **CONTAINS** — If the field being filtered is word-indexed, the SmartFilter will represent the field as an editor widget sized according to the Number of Lines in Editors setting in the Size & Position section.

**Operator View As**

By default, the SmartFilter lists the operators for Explicit fields in a combo box. You can force the options to be listed as radio buttons instead. To choose a representation, set the appropriate radio button.

**Size & Position**

**Size & Position** allows you to set the following visual characteristics of the SmartFilter instance:

- **Default Field Widths** — Set the displayed width of the editable portion of the filter fields. You can set the width separately for non-CHARACTER fields, and can override these settings on a per-field basis in the Field Properties section. The width you set here only affects the visible portion of the field, and it has no effect outside the SmartFilter itself.

- **Field Position** — You can control where the editable portion of the field starts. To minimize the amount of space the filter takes up in the X dimension, set this value
to the character count of the longest field label, plus two. For example, if your longest label is "Postal-Code:“, set the value to 14. If you use a smaller number, the field will hide the right end of one or more labels. If you use a larger number, both the fields and their labels will move to the right within the SmartFilter’s frame.
• **Number of Lines in Editors** — If the SmartFilter represents any field as an editor widget, this value is the number of lines that will be displayed. If you set this value to 1, the widget will display with the same height as a fill-in, and it will have no word-wrapping. If you set the value to 2 or more, the field will have word-wrapping and a vertical scroll bar.

**Field Properties**

Each filterable field has several default properties that you can change. Note that such changes have no effect on the database, the data stream, or how the data-display object treats the field. All changes are local to the SmartFilter.

To begin, select the field whose properties you wish to change:

• To change the label that identifies the field, uncheck the **Filter Target** box and type in the new text for the label. By default, the label is inherited from the field name in the schema.

• To change the field width, uncheck the **Use Default** box and type in the new value in character units. The default value is taken from the field definition in the schema.

• You can add text for a **Tooltip** identification by typing it in that field.

• If you plan to provide context-sensitive help, enter a unique **INTEGER** value for this field in the **Help ID** fill-in.

• The filter operators (equals, greater than, etc.) all refer to a single value. To select instead for values that fall within a certain range, check the box **View as Range Fields**. This option is available only when **Style** is **Implicit** or **Explicit**.

  When **View as Range Fields** is checked, a second editable field appears in place of the operators list.

• You can override the **Range** style on a per-field basis by setting the **Explicit Operator** box. The user will then see a single fill-in field instead of two, and be able to choose the comparison operator from a combo box.
Making changes to the data stream

The SDO provides data to the SmartDataBrowser and SmartDataViewer for display. In turn, the SmartDataViewer or SmartDataBrowser might provide data changes that must be written back to the database by the SDO. To preserve their ability to communicate with one another, you must make any changes to the data stream in an orderly way. Table 9 summarizes possible changes and the order in which you must make them.

Table 9: How to make changes to the data stream

<table>
<thead>
<tr>
<th>Your goal</th>
<th>How to reach it</th>
</tr>
</thead>
<tbody>
<tr>
<td>Get exactly the same fields, but from a different database.</td>
<td>Change the database name in the SDO.</td>
</tr>
<tr>
<td>Get exactly the same fields, but arranged in a different order than before.</td>
<td>Simply recompile.</td>
</tr>
<tr>
<td>Stop getting one of the fields.</td>
<td>If the field is being displayed, remove the field reference from the SmartDataBrowser and SmartDataViewer first, then remove it from the SDO. If it is not being displayed, simply recompile.</td>
</tr>
<tr>
<td>Start getting a new field.</td>
<td>Add the field reference to the SDO first. Then add it to the SmartDataBrowser and SmartDataViewer, if you want them to display it. If you do not want them to display it, simply recompile.</td>
</tr>
<tr>
<td>Make a field updatable.</td>
<td>Make the field updatable in the SDO first. Then make it updatable in the SmartDataBrowser and SmartDataViewer.</td>
</tr>
<tr>
<td>Make a field not updatable (read-only).</td>
<td>Make it read-only in the SmartDataBrowser and SmartDataViewer first. Then make it read-only in the SDO.</td>
</tr>
</tbody>
</table>
Creating a freestanding query object

Besides the queries embedded in and bound to other objects such as the SDO, you can create a query that exists by itself. Other objects can use such a freestanding query object by referring to its handle.

Such a query object, like the SDO, has no run-time representation. It is visible in the workspace only at design time.

To create a free-standing query object:

1. Click on Query in the Object Palette.

2. Place the object anywhere in the workspace—it is not visible at run time. In general, it is a good idea to place it in an unoccupied corner, if you can, in case you need to gain access to it later. At design time, the query object is represented by the following icon in your workspace:

3. When you click to place the new query object, the Query Builder dialog box appears. Use that dialog box to compose the terms of the query. See the “Defining and editing queries using Query Builder” section on page 188 for further information.
Defining and editing queries using Query Builder

A central step in developing any database application is creating the query or queries to be used for retrieving records from the database. AppBuilder offers a structured query editor for your use. You can invoke Query Builder in a number of ways:

- **Define a new SDO** — AppBuilder then starts the SmartDataObject Wizard, and the wizard calls Query Builder on your behalf. SmartObjects are the most powerful way to use queries.

- **Place a basic Data Browser (Browse) object in the workspace** — AppBuilder starts Query Builder. The browse object has all the internal logic necessary to use the query, though only in a self-contained way. You manually add any additional logic you require.

- **Place a Query object in the workspace** — AppBuilder then starts Query Builder. Such a query object is not connected to anything after you define it. You must manually add the code to make use of it.
Choose the Query button from the property sheet of a frame object — AppBuilder then starts Query Builder. As is true of the query object, you must manually write the code that makes use of this embedded query, after you have finished defining it.

**Note:** You can construct or modify queries by hand, using AppBuilder's Section Editor, but such queries cannot later be edited using Query Builder. If you wish to have all queries be maintainable in Query Builder, you would have to replace any such free-form queries with their Query Builder-generated logical equivalents.

Query Builder always starts in Table-selection mode.

**Table mode**

In this mode, the Query Builder allows you to specify the tables you want in the query. When you modify a query from the property sheet of a frame or browse, the Query Builder also initializes to this mode. Figure 30 shows how the Query Builder appears in Table mode.

---

**Figure 30:** Query Builder in Table mode
To select a database table, select the table name in the **Available Tables** list and click **Add**; you can also double-click on the name.

To remove a table from the **Selected Tables & Joins** list, select the table name and click **Remove**; you can also double-click on the name.

After you select the tables you want, the AppBuilder displays the query in the **Query** panel. For example, if you choose the **Customer**, **Order**, and **Order-Line** tables, the **Query** field appears, as shown in Figure 31.

![Figure 31: Sample query for OF-joinable tables](image)

As you select tables, the AppBuilder establishes the relationship among them and the other tables that you have selected. If two tables share a common key with the same name and data type, they are **OF** joinable. If they are not **OF** joinable, you must establish how they will be joined. For example, if you choose the **Customer** and **Local-Default** tables, the AppBuilder displays the query in the **Query** panel, as shown in Figure 32.

```
FOR EACH sports.Customer NO-LOCK,
    EACH sports.LocalDefault NO-LOCK WHERE TRUE: /* Customer join incomplete */
```

![Figure 32: Query sample with incomplete join criteria](image)

The comment indicates that you must complete the relationship of the **Local-Default** table to the **Customer** table. Complete the join criteria by choosing the **Join** button to enter **Join** mode.

If you select three or more tables and AppBuilder can establish the relationship among them, the AppBuilder still allows you to choose a table and change its join criteria. You do this by selecting the table in the **Selected Tables & Joins** list and choosing the **Switch Join Partners** button.
Join mode

When you activate the Join radio-set button in the Query Builder dialog box, you enter Join mode, and the Query Builder appears as in Figure 33.

Figure 33: Query Builder in Join mode

To enter this mode, you must already have selected at least two database tables. If you select more than two tables, you can use the down arrow button in the Join combo box to choose the combination of tables you want to join.

If two tables are of joinable, you can change their join criteria by activating the Customize Join toggle box to establish a WHERE clause between the two tables. Your comparison options are equal, not equal, less than, greater than, less than or equal, and greater than or equal. To use one of these options, double-click in a field from one of the tables, double-click on one of the comparison buttons, then click in another field from the other table.

As you establish comparisons between fields, the AppBuilder displays the ABL code in the Join Criteria panel. When you click OK, the AppBuilder displays the code in the Query Builder’s Query field (and in the widget’s property sheet, if the query is an embedded one). You can link the comparisons with AND or OR.

If you are familiar with ABL, you can edit the Join Criteria field by clicking in it and typing in the code directly.
Where mode

To specify search criteria for a table, activate the Where radio set button in the Query Builder dialog box. The Query Builder enters Where mode and appears as in Figure 34.

![Query Builder in Where mode](image)

Figure 34: Query Builder in Where mode

First, select a field from the list of fields. The AppBuilder displays the possible comparison operators for that field. These operators are sensitized based on the type of field.

For example, if you select the Cust-num field, the Contains button is not sensitized because Cust-num is not a word-indexed field. Also, Begins and Matches are not sensitized either, because Cust-num is an integer field.

After you select a field, choose one of the enabled comparison buttons. A dialog box appears that lets you supply a constant for comparison (you cannot specify variables). If you click either List or Range, the dialog boxes that appear allow you to specify whether the list or range is inclusive or exclusive. The AND and OR buttons extend the relationships between logical fields and also let you combine logical phrases with a complex expression.

The AppBuilder displays the ABL text of the clause in the Where Criteria editor. When you click OK, the AppBuilder displays the code in the Query Builder when it is in Table mode, and in the widget's property sheet if the query is an embedded one.

If you are familiar with ABL, you can type the search criteria directly into the Where Criteria panel.
Sort mode

To specify the sort order you want for your query, activate the Sort radio set button. The Query Builder enters Sort mode and appears as in Figure 35.

![Query Builder in Sort mode](image)

**Figure 35: Query Builder in Sort mode**

**Note:** If your query uses the `{&SORTBY-PHRASE}` preprocessor value to specify a sort order for the final result, the AppBuilder prevents you from entering this Sort mode by making the Sort button insensitive. You can set the query to use the `{&SORTBY-PHRASE}` from the Options mode of the Query Builder. For more information, see the “Options mode” section on page 194.

To specify the sort criteria, select fields from the Available Fields list. The Table combo box allows you to move between tables if you chose more than one table while in Table mode.

In the Sort Criteria editor, AppBuilder displays the fields you choose and the sort criteria you specify. When you click OK, the sort criteria is also displayed in Table mode. The Ascending and Descending radio buttons allow you to specify the display order of the sorted records.
Options mode

To specify query-tuning options and other query parameters, click **Options**. **Query Builder** enters the **Options** mode and appears as in **Figure 36**.

**Figure 36: Query Builder in Options mode**

**Editable find, join, and field list criteria**

To support the **QUERY FIELD-LIST** feature, **Query Builder** displays an editable browse with the following fields:

- **Table** — Specifies the tables in the query. This field is not editable.

- **Find** — Specifies the find criteria (**EACH**, **FIRST**, or **LAST**). This field is editable.

- **Join** — Specifies the type of join (**INNER** or **OUTER**). This field is editable.

- **Returned** — Specifies which fields are returned (included in the field list) when records are fetched to satisfy the query (**All Fields** or **Fields Used**). This field is editable.

To change the **Find** field, double-click in it until the desired value appears or type **E**, **F**, or **L**.

To change the **Join** field, double-click in it until the desired value appears or type **I** for **INNER** or **O** for **OUTER**.

The **Returned** field is a logical field that can be set in one of two modes: **All Fields** (the default) and **Fields Used**. When you select **All Fields**, the query fetches all fields of the table. When **Fields Used** is selected, the query returns only those fields in the **FIELDS-IN-QUERY** preprocessor list. For browses, this is controlled in the **Column Editor**; for frame queries, this is controlled by what fields you place in the frame.

To select **All Fields**, either double-click in the field until **All Fields** appears or type **A**. To select **Fields Used**, double-click in the field or type **F**.
Editable query tuning options

You specify query-tuning parameters by entering your choice of parameters in the Query Tuning Options panel. Depending on your choices, the AppBuilder inserts code into the OPEN-QUERY statement. For example:

<table>
<thead>
<tr>
<th>LOOKAHEAD</th>
</tr>
</thead>
<tbody>
<tr>
<td>NO-DEBUG</td>
</tr>
<tr>
<td>INDEX-HINT</td>
</tr>
</tbody>
</table>

Query-tuning parameters correspond to the QUERY-TUNING keyword. This keyword is available with the FIND, FOR EACH/LAST/FIRST, and OPEN-QUERY statements. For more information, see OpenEdge Development: ABL Reference.
Data-Display/Capture Objects

Presenting data to the user in a way appropriate for inspection or update is a major activity in a database application. Typically, the same objects that present data also capture new and changed data. The following sections describe the data-display/data-capture objects the AppBuilder supplies for your use:

- Introduction to data-display objects
- SmartDataBrowsers
- Dynamic SmartDataBrowser
- Static SmartDataBrowser
- SmartDataViewers
- SmartDataFields
- SmartSelects
- Basic data browsers
- Combo boxes
- Basic data viewers
- Multi-line editors
- Fill-ins (single-line editors)
- Radio button sets
Chapter 5: Data-Display/Capture Objects

- Selection lists
- Slider controls
- Spin controls (ActiveX)
- Toggle boxes (check boxes)
Introduction to data-display objects

Presenting data to the user is an important intermediate goal in nearly any database application. Presentation techniques range from the most generic row/column display to sophisticated, application-specific graphing and charting.

AppBuilder provides the following SmartObject building blocks:

- Dynamic and Static SmartDataBrowsers, for presenting data to your users in a simple, tabular row/column format
- SmartDataViewer, for presenting one record at a time, in a layout you determine
- SmartDataField, including the dedicated SmartSelect, for adding ADM capability down to the individual field level in the SmartDataViewer

Additionally, ABL provides a number of basic objects that display and capture data. These include:

- Data browser with built-in query, for representing data in tabular row/column format.
- Combo box, for presenting a list of choices
- Data viewer (DB-Fields) with built-in query, for representing data on a per-record basis
- Editor (multi-line editor), with most of the capabilities of a standard text editor
- Fill-in (single-line editor), for capturing a small amount of data
- Radio-button set, for representing an exclusive set of (usually non-string) choices
- Selection list, for presenting a list of choices
- Slider control, for representing a point within a subrange of INTEGERS or small INT64s
- Toggle box (check box), for representing a Boolean (LOGICAL) choice

This chapter discusses these building blocks and their role in your applications.
SmartDataBrowsers

SmartDataBrowsers (SDBs) are browse widgets enhanced with ADM smart technology. An SDB presents the results of a query in simple row/column tabular format. Each row displayed in an SDB always represents one record from the data stream (the record itself might be a dynamic composite created by a JOIN operation). Each column represents one of the fields in the records. The SDB can display any of the standard data types that can be represented by ASCII text.

An SDB displays and possibly updates data supplied by an SDO to which the SDB is connected by SmartLinks.

AppBuilder supplies two types of SDB for your use:

- **Dynamic** — You place an instance of the predefined dynamic SDB in your application. This object is able to connect to and interact with any SDO.

- **Static** — Using the wizard provided by AppBuilder, you define a static SDB master object to connect to and cooperate with a particular SDO. You later select and place an instance of the master object in your application.
Dynamic SmartDataBrowser

The dynamic SDB is capable of displaying and updating records supplied by any SDO. You make the connection and set up the conditions at design time.

Creating a dynamic SmartDataBrowser instance

Use the Object Palette to place a dynamic SDB.

To create, place, and configure a dynamic SmartDataBrowser:

1. First create and place an appropriate SDO to supply the data stream the Browser will display.

2. Right-click the SmartDataBrowser in the Object Palette and choose Dynamic SmartDataBrowser from the menu that opens.

3. Position your mouse cursor over the workspace and click to place the object. It appears as a Browse widget, initially with only a single column, as shown:

4. AppBuilder immediately opens an Advisor window if it finds opportunities to create SmartLinks to other objects. Examine the recommendations and accept all that seem appropriate.

5. Click on the Menu button and select Instance Properties from the menu. The following dialog box appears:
6. If you wish to display or allow updates to fewer fields than the SDO would permit, make those changes now. Click the appropriate button to open a selector dialog. See Table 10 for a description of how AppBuilder makes use of your choices.

<table>
<thead>
<tr>
<th>Your choice</th>
<th>AppBuilder response</th>
</tr>
</thead>
<tbody>
<tr>
<td>Make no changes.</td>
<td>Display all fields provided by the SDO (the value of the DataColumn property).</td>
</tr>
<tr>
<td></td>
<td>Allow updates on all fields enabled in the SDO (the value of the UpdatableColumns property).</td>
</tr>
<tr>
<td>Specify only the display list.</td>
<td>Display the fields you chose.</td>
</tr>
<tr>
<td></td>
<td>If there is a TableIO source, then allow updates on all fields that are enabled in the SDO, if they are also being displayed. If no TableIO source, then allow no updates at all.</td>
</tr>
<tr>
<td>Specify only the enabled list.</td>
<td>Display all fields provided by the SDO (the value of the DataColumn property).</td>
</tr>
<tr>
<td></td>
<td>Allow updates on the fields you chose.</td>
</tr>
<tr>
<td>Specify both the display list and</td>
<td>Display the fields you chose.</td>
</tr>
<tr>
<td>the enabled list.</td>
<td>Allow updates on the fields you chose.</td>
</tr>
</tbody>
</table>

7. If you wish to allow the user to search on one of the displayed fields, select it from the Search Field combo box.

8. Clear the Enable and View check boxes to initialize the object in a hidden, insensitive state.

9. Set the Down value to the number of rows you wish the browser to display. If you wish the object to determine its own best width, check the Calculate Width box and, if desired, enter a Max Width limiting value.

**Note:** The design-time representation does not account for the Down and Width choices you make, so you cannot predict the run-time appearance from it. You will need to experiment to determine how to get the run-time appearance you desire. A good first approximation for number of lines might be to show 1 or 2 more lines than your Down setting (1 to account for the column-labels line, and a second if there will be a horizontal scroll bar).
10. Unless the total number of records in the data stream is same or less than the **Rows To Batch** value, the user will not be able to use the scroll bar to reach the last record. The last record reachable by using the scroll bar is the last record in the buffer, not the last record in the data stream. This can be confusing to the user.

To solve this problem, check the **Scroll Remote Results List** box. You might also have to write some code. For more information see the “Scrolling to the last record in the data stream” section on page 212.

11. Check the **Use sort indicator** toggle if you want a graphical arrow to display in the column label to show the sort column and direction.

Unless you need to add special logic, the dynamic browser will typically be a lower-cost choice than a static browser.
Chapter 5: Data-Display/Capture Objects

Static SmartDataBrowser

The static SDB you use in your application is an instance of a master object that you create. Each master SDB is designed to cooperate with a particular SDO master, exchanging a well-defined set of data fields in a particular order.

Creating a SmartDataBrowser master

The first step in defining a new SDB master is always to identify the source of the data stream. Because of this dependency, you must first create your SDO, then create the SDB. See the “Creating a SmartDataObject master” section on page 159 for information about that process.

To create an SDB master:

1. Start the SmartDataBrowser Wizard by clicking on the SmartDataBrowser in the Object Palette.
2. Click New in the Choose dialog box. The SmartDataBrowser Wizard appears:

   ![SmartDataBrowser Wizard - Page 1 of 4](image)

   Welcome to the SmartDataBrowser Wizard. During the next few steps, the wizard will guide you through creating a SmartDataBrowser object. First you will choose a Database to supply data to the SmartDataBrowser, then you can specify the columns that will be displayed in the SmartDataBrowser. Please Next to proceed.

3. When you have finished reading the introductory text, click Next. The Page 2 dialog box appears:

   ![SmartDataBrowser Wizard - Page 2 of 4](image)

   Data definition source
   - Select SmartDataObject

   You need to specify the path to the SmartDataObject or include file that will provide data definitions for this SmartDataBrowser.

   ![Help on definitions source](image)

   [Help on definitions source]

   Cancel  Back  Next  Finish
4. Click **Browse** and select the appropriate SDO master. Alternately, you can create an SDB against a SmartBusinessObject (SBO) or a temp-table’s definition in an include file.
5. Click Next. The Page 3 dialog box appears:

6. Click Add Fields. The Multi-Field Selector dialog box appears:

7. The fields Available for display appear in the left-hand list. Select those you wish the SDB to display and click the Add button to move them to the Selected list in the right-hand window. If you make a mistake, click the Remove button.

When you have finished selecting fields, you can reorder them using the Move Up and Move Down buttons. When they are in the order you want them displayed, click OK. The Selector dialog box closes and the list of selected fields appears in the Fields to display section of the wizard, as shown:
8. Click **Next** to advance to the wizard’s final page. If you have successfully defined a data source and selected the fields to display, you will see “Congratulations!”. If you do not, click **Back** and make any necessary changes:

![Congratulations](Image)

9. Click **Finish** to dismiss the wizard and reveal the new SDB master, if it was not already visible.

10. Choose **File** → **Save** and give the new master a descriptive filename. Note that SDB filenames conventionally begin with b:

![SDB object](Image)

The new master object is now available for your use.

**Configuring SmartDataBrowser properties**

SDBs have properties associated both with their browse component and with their nature as a procedure-based object. You can make a number of changes to those settings, if the default values do not meet your needs.

To open the property sheet associated with the Browse component:

1. Choose **File** → **Open**, select the master you wish to configure, and click **OK**. The SDB object appears:
2. Click on the object to select it, if necessary, and choose **Tools → Property Sheet**. The **Property Sheet** dialog box appears:

![Property Sheet dialog box](image)

**Minimal configuration**

Although you can accept many of the default settings, you might wish to make two changes to individualize the object. Note that the following changes will apply to all created instances:

- Change the identifier to more closely reflect the object’s nature.
- Add a title string, if you plan to allow the Browse component to display a title bar.

**Query and fields**

Since the SDB uses the data stream from an SDO, you can change only the fields and their ordering. The **Query** button is disabled because the query belongs to the SDO, not the browse widget:

- Choosing the **Fields** button starts **Column Editor** and allows you to modify the columns this SDB will display. For information about how to use **Column Editor**, see the “Selecting database fields for browsing” section on page 168. Note, however, that the **Column Editor** for the SDB includes extra options to configure how columns display.

- By default, all columns can be scrolled horizontally, if there are too many columns to display at once. You can choose to lock the leftmost columns in place, so that scrolling does not affect them. Enter in the **Locked Columns** box the number of columns you want to freeze in place.

**Caution:** If you lock more columns than will fit in the browse’s viewable width, you effectively disable the horizontal scroll bar, because all scrolling will take place out of sight to the right.
• When displaying a vertical scroll bar, the system tries to size the scroll bar’s thumb slider to reflect the total number of lines in the data stream. The larger the number of lines, the smaller the thumb. However, that thumb size is based on the number of records being batched by the SDO, not on the total number in the stream. In general, the total number of records in the stream will be larger. When that is the case, the system cannot correctly size the thumb.

If you can predict, even approximately, the total number of records in the data stream, you can improve the accuracy of the scroll bar’s appearance. Enter your estimate in the Max Data Guess field.

• Type into the Tooltip field the identifying text that you want the system to display whenever the mouse cursor hovers over this SDB.

Geometry

You can set the exact origin and size of any SDB instance created from this master. Set the values, in character units, in the appropriate fields. You can choose whether the origin is measured at the upper-left corner (the default) or the upper-right corner.

If you prefer to use pixels rather than character units, click Advanced and set the values in that dialog box instead.

For more information on all the settings on the property sheet, see the online help.

Advanced properties

Click Advanced. The Advanced Properties dialog box appears:
You can make a number of changes to the SDB’s appearance and behavior by changing the default settings in this dialog box:

- **Help** — Text in this field displays in the status bar of the parent window when the SDB has the focus. If the parent window has no status area, this text will not display.
- **Private Data** — AppBuilder writes out the contents of this field as the value of the object's `PRIVATE-DATA` attribute. You can write code to read and operate on that value in any way that meets your needs.
- **Generated Code Layout Unit** — Controls whether AppBuilder describes the position and size of this SDB in character or pixel units when it generates source code.
- **Geometry - Pixels** — Expresses the origin and size of this widget in pixels. You can set a particular origin and size for the object here rather than interactively, if you wish. You can also choose to have the origin measured at the upper-right rather than the upper-left corner.
- **Column Movable** — Normally cleared. Setting this check box allows the user to reorder the columns by dragging.
- **Column Resizable** — Normally cleared. Setting this check box allows the user to resize the columns interactively. Resizing the column has no effect on the actual field widths.
- **Column Searching** — Normally cleared. Setting this box in read-only browsers allows the user to search in an individual field across all records. Updatable browsers allow such searching by default.

The search is started by clicking the desired column title and typing the letter for which to search. No prompt appears for the letter. The browser scrolls its window to bring into view and make current the next record, if any, in which the search field data begins with the typed-in letter.

- **Movable** — Normally cleared. Setting this check box and the **Selectable** check box allows the user to move the entire SDB object around within the bounds of the enclosing frame.
- **Resizable** — Normally cleared. Setting this check box and the **Selectable** check box allows the user to change the size of the SDB object, within the limits of the enclosing frame.
- **Row Resizable** — Normally cleared. Setting this check box allows the user to change the vertical size (height) of the rows by dragging a horizontal separator line.
- **Selectable** — Normally cleared. Setting this check box allows the user to select the SDB object.
Editing a SmartDataBrowser master

Any modular system must have and enforce strict data-exchange requirements if it is to avoid possible data corruption and loss. You can always update the field selections in your SDB to reflect your changing needs, though you might also need to make corresponding changes to the associated SDO (see Table 10).

To edit your SDB master:

1. Choose File → Open and select the source file (for example: bSampleSDB.w). The SDB object appears:

![SmartDataBrowser object](image)

2. Open its property sheet and make any necessary changes.

3. Save your changes and close the SDB master.

Creating and placing a SmartDataBrowser instance

Once you have an SDB master designed that will display the data you need, you can reuse it indefinitely in your applications.

To add an SDB to your organizer workspace:

1. Click on the SDB tool icon in the Object Palette. When the Choose dialog box opens, select the appropriate master and click OK.

2. Position the cursor over the workspace at the point where you want the upper-left corner of the widget to appear. Click, and the new SDB object appears.

3. AppBuilder immediately opens an Advisor window if it finds opportunities to create SmartLinks to other objects. Accept the Advisor’s recommendations, if they seem appropriate.

4. Drag the edges of the new SDB object to position and resize it.

5. Configure the object’s instance properties. See the next section.

6. Save your work.

Configuring a SmartDataBrowser instance

There are several properties you can configure in an SDB instance, if the default values do not meet your needs.
To configure the properties in an SDB instance when the values do not meet your needs:

1. Right-click on the instance and choose **Instance Properties**. The following dialog box appears:

   ![SmartDataBrowser Properties dialog box]

   - To disable the object at startup, clear the **Enable** box.
   - If multiple layouts are defined, choose one from the list.
   - To hide the object at startup, clear the **View** box.
   - To enable scrolling to the last record in the data stream, set the **Scroll Remote Results List** checkbox. You might also need to write some code. For details, see the “Scrolling to the last record in the data stream” section on page 212.
   - Click **OK** and save your work.

### Scrolling to the last record in the data stream

Conventionally, the size and position of the thumb slider within a scrollbar provides the user a hint about the overall size of the document being examined, and the position of the viewport within that document. The ratio of thumb size to scrollbar size indicates how much of the whole document is currently visible. The position of the thumb within the scrollbar’s length represents how far the visible portion is from the beginning and end of the document.

In the case of the SDB and its basic counterpart, the document being examined is actually a data stream. Typically, that data stream will contain many records. Many more records, in general, than are practical to buffer. But if there are more records than are buffered, the size and position of the thumb will reflect the buffer, not the whole data stream. Moving the thumb to the bottom of the scrollbar track brings into view the last record in the buffer, not the last record in the data stream.

This can be confusing to the user of your application.

**To fix the problem in your SDB:**

1. Click the SDB’s **Menu** button and select **Instance Properties**. The following dialog box appears:
2. Set the **Scroll Remote Results List** check box.

3. Save your work.

If you have a trigger defined for the **ROW-DISPLAY** event, you must modify it. Follow these steps:

1. Right-click the instance and choose **Edit Master** from the context menu. The master workspace appears (its appearance may be different):

2. Select the workspace if necessary and open a **Section Editor** window. Create a new procedure, for example `OldRowDisplayHandler`, and move the code from your **ROW-DISPLAY** handler into the new procedure.

3. Create a new function as an override for `rowDisplay`. Put in it a call to the procedure you just created, followed by a **RUN SUPER** statement. If you name your procedure `OldRowDisplayHandler`, your function body would look like the following:

   ```
   RUN OldRowDisplayHandler. /* run original local code */
   RUN SUPER. /* run the handler in the super procedure*/
   ```
4. Open your local **ROW-DISPLAY** trigger in the **Section Editor**. It should now have no code in it, because you moved that code to the new procedure you created.

5. Add the following line as the new body of your local trigger:

```
RUN rowDisplay. /* run local override of super-procedure handler*/
```

6. Save your work.

Now, when the user drags the thumb to the bottom of the scroll bar, bringing the last record in the buffer into view, the browser requests a new batch of records from the **Data-Source**. When the new batch is received, the browser repositions its thumb to account for the new total record count. Thus, the first time a new batch is requested, the thumb will in general reposition to the middle of the scrollbar because the former last record is now in the middle of the buffer. The second read will create a total of three batches, with the thumb positioned at the two-thirds point, and so forth.
SmartDataViewers

While the SDB is useful for rapidly scanning many records, it is less easy to focus on the fields of a single record. This is particularly true when there are a large number of fields involved. The SDB can only display data in tabular format; no more subtle arrangement is possible.

The SmartDataViewer displays fields from a single record at a time. By default, each field is represented by a fill-in widget, and the fields are stacked in a single left-aligned column. In contrast to the SDB, you can completely rearrange the fields of a SmartDataViewer master to suit your layout, and can even replace individual fill-ins with special-purpose SmartDataFields that you create.

The SmartDataViewer instances you use in your applications are each based on a master object that you design. SmartDataViewer masters are static objects; you design each one to display records supplied by a particular SDO. Once you design a SmartDataViewer master, you can reuse it repeatedly in your applications.

Creating a SmartDataViewer master

The first step in defining a new SmartDataViewer master is always to identify the source of the data stream. Because of this dependency, you must first create your SDO, then create the SmartDataViewer. See the “Creating a SmartDataObject master” section on page 159 for information about that process.

AppBuilder supplies a wizard to help with creating SmartDataViewer masters. The wizard has four pages, only two of which involve significant work:

1. Introduction.
2. Identifying the data source.
3. Selecting the fields to display from the data stream.
4. Congratulations.

To create a SmartDataViewer master:

1. Start the SmartDataViewer Wizard by clicking on the SmartDataViewer icon in the Object Palette.
2. When the Choose dialog box opens, click New.
3. The **SmartDataViewer Wizard** starts up and displays its first page. When you have finished reading the introductory text, click **Next**. The **Page 2** dialog box appears:

![Page 2 dialog box](image)

4. Click **Browse** and select the appropriate SDO master. Alternately, you can create an SDB against a SmartBusinessObject (SBO) or a temp-table’s definition in an include file.

5. Click **Next**. The **Page 3** dialog box appears:

![Page 3 dialog box](image)

6. Click **Add Fields**. The **Multi-Field Selector** dialog box appears.

7. The fields available for display appear in the left-hand list. Select those you wish the SmartDataViewer to display and click the **Add** button to move them to the **Selected** list in the right-hand window. If you make a mistake, click the **Remove** button.
When you have finished selecting fields, you can reorder them using the **Move Up** and **Move Down** buttons. When they are in the order you want them displayed, click **OK**. The **Selector** dialog box closes and the list of selected fields appears in the **Available Fields** section of the wizard, as shown:

8. Click **Next** to advance to the wizard's final page. If you have successfully defined a data source and selected the fields to display, you will see “Congratulations!”. If you do not see that page, click **Back** and make necessary changes.

9. Click **Finish** to dismiss the wizard and reveal the new **SmartDataViewer** master, if it was not already visible. For example:

10. Fields in a SmartDataViewer are read-only unless you connect them to the appropriate **TableIO** source, such as an **Update** SmartPanel. If you do connect them to **Update** controls, then all fields become updatable unless you explicitly make them read-only.

To make any of the individual fields read-only, double-click on it to open its property sheet. When the **Property Sheet** dialog box opens, set the **Read-only** check box and click **OK**.

Note the difference in how fields display at run time, depending on their state.
In the first case, there is no **Update** SmartPanel, and so all fields are read-only. The fill-ins display their content without displaying themselves—the fields are not outlined or modelled in any way; they are invisible. All text looks static. This is the same effect you will get if you set the fields to be not-updatable in the SDO:

In the second case, there is an **Update** SmartPanel, and so all fields are updatable if they are updatable in the SDO. The fill-ins display their content in the ordinary way, as shown:

In the third case, there is an **Update** SmartPanel, but the **Name** field has its **Read-only** property set. Here, the **Name** field is clearly in a different state to the others, and the experienced user will recognize that it is not editable. However, this style of presentation only applies where the field is updatable in the SDO, but set read-only in the fill-in. If it is not updatable in the SDO, it appears as in the first example:

11. Choose **File** → **Save** and give the new master a descriptive filename. Note that SmartDataViewer filenames conventionally begin with `v`. The new master object is now available for your use.

If you plan to replace one or more of the simple fields with SmartDataFields, do it now. See the “Placing and configuring a SmartDataField instance” section on page 225 for information about that process.

**Note:** Although SmartDataViewers can be members of the class SmartContainer, they are not organizer objects, so placing SmartObjects in them other than SmartDataFields is not supported. The only exception is that, if you replace one or more of the fields with SmartSelect objects, you can also include an equal number of SDOs to feed them.
Adding and removing SmartDataViewer fields

If you modify the data stream being supplied to a SmartDataViewer master, you might have to add and/or remove fields.

Removing SmartDataViewer fields

Removing fields is very easy: just select and delete them. AppBuilder handles the situation gracefully, without leaving residue behind.

Adding SmartDataViewer fields

Adding additional fields for display is also easy, once you know how.

To add additional fields for display:

1. Choose File→Open and open the master object. Drag the edges of its workspace, if necessary, to add space for the new fields.

2. Click on DB-Fields in the Objects Palette.

3. Click on an empty spot in the master object’s workspace, not the main workspace. The Multi-Field Selector dialog box appears:

4. Move the desired fields from the Available Fields list to the Selected Fields list. Click OK.

5. Position, size, and configure the newly added fields in the master workspace. Save your work.

Configuring SmartDataViewer properties

SmartDataViewers have properties associated both with their fill-in components and with their nature as a procedure-based object. You can make a number of changes to those settings, if the default values do not meet your needs.
To open the property sheet associated with a fill-in component:

1. Choose **File** → **Open**, select the master you wish to configure, and click **OK**. The SmartDataViewer master object appears in its own workspace:

![SmartDataViewer master object](image1)

2. Click on the fill-in to select it, and choose **Tools** → **Property Sheet**. The **Property Sheet** dialog box appears:

![Property Sheet dialog box](image2)

### Minimal configuration

Although you can accept many of the default settings, you might wish to make three changes:

- Add a Tooltip string. Under MS-Windows, Tooltips display whenever the user allows the mouse cursor to hover for a few seconds over an object for which a Tooltip is defined.
- Add a unique integer as the identifier for context-sensitive help, if you plan to provide such help as part of your application.
- Set the **Read-Only** check box (in the **Other Settings** area) to prevent the user from modifying the data in the field.

### Rearranging the layout

The way a viewer’s fields are laid out is also a property that can be changed, though only at the level of the master. All instances created from a given master share the same physical layout. To have different layouts for different applications, you must either create extra copies of the master and lay out each one differently—effectively
creating separate masters—or use the alternate-layouts feature. See Appendix B, “Multiple Layouts” for information about that feature.

**To create a custom layout:**

1. Open the master object by choosing **File → Open**. The object opens in a design window workspace:

   ![SmartDataViewer layout image](image)

2. Save the master under the name you will use for the new arrangement. Do this before you actually make any changes, so that you will not risk getting confused later and overwriting the original arrangement.

3. Resize the workspace appropriately, drag the individual fill-ins into the new arrangement, and save again:

   ![Modified SmartDataViewer layout image](image)

   Note that you should make the workspace no larger than needed, since the amount of space taken up by an instance is always the same as the master’s workspace.

**Other property changes**

By default, AppBuilder predefines certain properties of each fill-in that is used by a SmartDataViewer, and makes some of the properties read-only:

- Object identifier
- Label
- Allowed field format and size
- Help string

AppBuilder creates and assigns a unique identifier, and sets the other properties to conform to the field definition from the data stream. You cannot assign a different identifier or change the basic data type, but you can make changes to the label, field specifications, or help string.
To make changes to the label, field specifications, or help string:

1. Click the **Database Field** button, and when the dialog box opens, clear the check boxes for the properties you wish to set by hand. Click **OK** to dismiss the dialog box. If you clear all three, the properties dialog box appears as shown:

![Property Sheet - Name](image)

2. You can now enter new values for the label and the format specification. If you wish to pick the format specifier from a list, click **Format**. The **Format** dialog box appears:

![Format](image)

You can more directly change other properties:

- **No-Label** — Normally cleared. Setting this check box turns off display of any label. Setting this check box does not clear the actual label text; the label string remains visible in the property sheet. The only other effect of setting or clearing this box is to alter the values in the Geometry section so that the fill-in stays at the same XY location within the enclosing frame.

- **Geometry** — Reflects the XY origin and size, in character units, of the fill-in. By default, the fill-in is colon-aligned. You can change that to left- or right-alignment, though the only noticeable effect that will have is to change the X origin value.

- **Auto-Resize** — Normally cleared. Setting this box causes the object to automatically change its displayed size to agree with the current type size.
- **Auto-Return** — Normally cleared. Setting this box causes focus to move to the next object in the traversal list once this fill-in has accepted as many characters as it can.

- **Blank** — Normally cleared. Setting this box prevents the fill-in from echoing input back to the display. Useful for password fields and similar applications.

- **Deblank** — Normally cleared. Setting this box causes the fill-in to automatically discard any leading blanks from input.

- **Disable-Auto-Zap** — Normally cleared. Setting this box prevents the fill-in from automatically clearing its input field whenever it gets the focus.

- **Display** — Normally set. Clearing this box prevents the SmartDataViewer from automatically populating this fill-in during initialization.

- **Drop-Target** — Normally cleared. Setting this box causes this object to experience an event whenever the user drags another object onto this one. You must write the appropriate event-handling code.

- **Enable** — Normally set. Clearing this box makes the fill-in decline input focus when offered.

- **Hidden** — Normally cleared. Setting this box prevents the fill-in from responding to implicit requests to display itself. It will only honor explicit requests.

- **Native** — Normally cleared. Setting this box causes the fill-in to vary its behavior according to the underlying platform (MS-Windows, for example) rather than behaving in the same way regardless of platform.

- **No-Tab-Stop** — Normally cleared. Setting this box removes this fill-in from the enclosing frame’s traversal list. Normally, pressing the key causes focus to move to the next object in the list. When this box is set, the fill-in can neither lose nor gain focus when the user presses the **TAB** key. If the widget has the focus, it will ignore the key, and if it does not, focus will cycle through the other members of the traversal list while ignoring this widget.

  **Caution:** Making this fill-in **Movable** or **Resizable** (Advanced Properties) prevents this fill-in from gaining input focus using the mouse. So if you also set this property, you effectively prevent the widget from ever gaining input focus.

- **No-Undo** — Cleared. Cannot be set. The ABL Virtual Machine (AVM) will always journal changes to the data in this fill-in.

- **Read-Only** — Normally cleared. Setting this box prevents the user from changing the content of the fill-in.

- **Remove from Layout** — Cleared. Cannot be set unless defining an alternate layout.

- **Shared** — Cleared. Cannot be set. This fill-in will always be local to the SmartDataViewer within which it is defined.
Chapter 5: Data-Display/Capture Objects

- **View-as-Text** — Normally cleared. Setting this box causes this fill-in to display the contents of its field as though it were static text: read-only, and without any border or 3D effect.

**Advanced properties**

A fill-in has only the minimum advanced properties, but you can change those that do not meet your needs.

- **Initial value** — You cannot set this for a fill-in that is part of a SmartDataViewer.

- **Help** — Unless this fill-in inherits the help string defined in the data dictionary, the text you enter here will display in the parent window’s status bar whenever this fill-in has input focus. No text will display if the window has no status bar.

- **Private data** — AppBuilder assigns the contents of this field as the value of the **PRIVATE-DATA** property. You can write code to manipulate this data in any way you desire.

- **Layout units** — You can choose character or pixels. This setting affects source code generation only.

- **Custom lists** — You can add this fill-in to any or all of the six lists (macros) maintained by the enclosing frame.

- **Geometry** — Shows the same information as in the base property sheet, but in pixel units.

- **Manual highlight** — Normally cleared. Setting this box allows you to write code to define a custom highlight effect. Your custom effect will be applied whenever this fill-in has input focus.

- **Movable** — Normally cleared. Setting this box makes it impossible for the user to give this fill-in input focus by clicking with the mouse. Instead, the user can use the mouse to drag the fill-in field—but not the label, which remains where it was—to a different position within the bounds of the enclosing frame.

- **Resizable** — Normally cleared. Setting this box makes it impossible for the user to give this fill-in input focus by clicking with the mouse. Instead, if the **Selectable** box is also set, clicking with the mouse causes handles to appear so that the user can resize the object.

- **Selectable** — Normally cleared. Setting this box allows the user to select this object.

---

**Caution:** If you make this fill-in Movable or Resizable, and you also set the **No Tab Stop** option in the base property sheet, you effectively prevent this object from ever gaining input focus.
A simple fill-in is not necessarily the best representation for all data fields. Sometimes it would be very convenient to bring the power of ADM Smart technology down to the level of the individual data field in a SmartDataViewer. AppBuilder offers the SmartDataField object as a way for you to do that.

The SmartDataField instances you use in your applications are each based on a master object that you design for a particular purpose. Once you design a SmartDataField master, you can reuse it repeatedly whenever you need a SmartDataViewer field with that particular capability.

AppBuilder supports SmartDataFields only as replacement for simple SmartDataViewer fields, not for standalone placement. You can extend their applicability, if you wish, by writing the necessary supporting code.

For information about creating SmartDataField masters, see OpenEdge Development: ADM and SmartObjects.

Placing and configuring a SmartDataField instance

Each field in a SmartDataViewer represents a certain data type—an INTEGER, for example, or a DATE. The SmartDataField object you use as a replacement for such a field must represent the same type.

To use a SmartDataField in a SmartDataViewer:

1. Choose File→Open and select the SmartDataViewer master you intend to modify. Click OK. The master opens in a workspace window, as shown:

2. Click on the SmartDataField in the Object Palette.

3. When the Choose dialog box appears, select the appropriate master and click OK.

4. Position your mouse cursor over the field you are replacing, and click to make the replacement. The SmartDataField representation appears in place of the original fill-in:
5. Add a static text label, if appropriate. A SmartDataField does not inherit the label of the field it replaces.

6. AppBuilder supplies stubs for the enableField() and disableField() procedures. Open the Section Editor and add additional code to make those procedures work for the particular SmartDataField you added.
SmartSelects

The SmartSelect is a predefined SmartDataField object that represents a self-populating set of choices. You would typically use a SmartSelect to choose a new value for a field from among a relatively small group of possibilities drawn from a related table.

The SmartSelect object is data-driven. Most widgets used in an application have their values embedded as data within the program itself, so that changing the values in any way typically requires recompilation. Since the SmartSelect obtains its values from the database being modified, instead, recompilation is rarely required.

Some examples of the kind of situation for which a SmartSelect would be appropriate:

- Assigning a different sales rep to an account. Typically a company has a small number of sales reps, each of whom calls on many accounts.

- Changing a customer’s credit limit, if the possible choices are few. For example: discredited; credit hold; credit not requested; $10,000; $50,000; $100,000; unlimited.

- Changing some demographic value in a personnel record. For example: single, partnered, married, separated, divorced, widowed, deceased, dependent.

- Setting the circulation status of a book in a library-management system. For example: on-order, reference, reserved, available, checked-out, bindery, lost.

- Picking a customer number for use in order-entry. Since customer numbers are important to the seller rather than the customer, customers rarely remember them.

You can configure each SmartSelect instance to represent its set of values using your choice of four different widgets: combo box (the default), radio set, selection list, or a browse that opens in its own popup window. Of those four, only the browse is capable of handling a large or unpredictable number of values. You might find it helpful to experiment before deciding on a representation.

Placing a SmartSelect instance

Start with the File → Open menu option.

To use a SmartSelect as a field in a SmartDataViewer:

1. Choose File → Open and select the SmartDataViewer master you intend to modify. Click OK. The master opens in a workspace window, as illustrated here:

2. Create, if necessary, and place the SDO that will supply values to the SmartSelect.
3. Click on the SmartDataField in the Object Palette.

4. Choose SmartSelect from the menu that opens.

5. Position your mouse cursor over the field you are replacing, and click to make the replacement. The SmartSelect representation appears in place of the original fill-in:

   ![Image of SmartDataField replacement]

6. An Advisor should now appear and offer to add the Data link from the SDO to the SmartSelect. Agree to the offer.

7. If no Advisor appears, open the SmartLink Editor and add it yourself.

8. Right-click the instance and choose Instance Properties from the menu. Configure the instance. See the “Configuring a SmartSelect instance” section on page 229 for information.

**Configuring a SmartSelect instance**

The SmartSelect has a relatively complex Instance Properties dialog box, as shown:

![SmartSelect Instance Properties dialog box]

**Data source**

This section identifies the SDO that will feed the SmartSelect object. You cannot enter the filename of the SDO directly; AppBuilder fills in this field as part of creating the SmartLinks, once you place the SDO in the viewer workspace.
You can subset the data that the SmartSelect displays. Type a subsetting expression into the Filter field—for example:

```
CreditLimit > 10000
```

The SmartSelect will then display only the subset of items that conform to that restriction.

Data

This section describes the field being replaced, and the identifying characteristics of its replacement:

- **External field** — Identifies the field in the SmartDataViewer that you are replacing. This identification is read-only, supplied for your information only.

- **Key field** — If the replacement data stream has more than one field, use this combo box to select the field that will appear in place of the original. Be certain to select the correct one.

  For example, the State table in the sample database has three fields: State, StateName, and Region. If you use a SmartSelect fed from the State table to update the Customer.State field, the only correct choice for the key field would be State.State, since that is the related field. If you choose StateName or Region instead, confusion is almost certain to result, later.

- **Displayed field** — If the replacement data stream has more than one field, use this combo box to select the field that the user will see. To continue the State example, you might prefer to display the more recognizable StateName field. That would be a more user-friendly choice than displaying the cryptic two-character post-office abbreviation from the State field itself, even though it is that two-letter code that you will store.

- **Event on change** — You can declare a name for the event to be experienced when the value of this field changes. This allows you to write an appropriate event-handling procedure. The name you define is local to the object. See OpenEdge Development: ADM and SmartObjects and the for further information.

- **Edit browser columns** — Active only when the field is to be represented as a Browse widget. Choosing this button opens the standard field-selection dialog box so that you can select the fields to be displayed.

Properties

This section presents three important behavioral properties:

- **Enable** — Normally set. Clearing this box prevents the SmartSelect from enabling itself even when the other fields of the SmartDataViewer enable themselves.

- **Display** — Normally set. Clearing this box prevents the SmartSelect from displaying data even when the other fields of the SmartDataViewer display data.

- **Sort** — Normally set. Clearing this box causes the items to appear in unsorted order. Normally the visible fields appear sorted on the displayed field.
Optional

This check box is normally cleared. Setting this box means that the associated field need not have a value.

You can specify the text that represents that nonvalue; the default is <none>. Note that this text does not necessarily appear at the top of your list of choices. If you wish it to appear as the first item in the list, you must either explicitly make it the first item in the source (for unsorted lists) or begin with some character, such as the angle bracket (<), that the sort operation will move to the top of the list.

Visualization

This section allows you to specify how the SmartSelect list will represent itself at run time. The choices are:

- **Browser** — The browser representation is the best choice for handling lists that are known to be very large or are of unknown size. This representation initially appears in a closed state, under an iconic button next to the current value of the field:

  ![Massachusetts](image)

  Clicking the button opens the list of items as a browse in a separate window. Click on the **Edit Browser Columns** button to choose what fields to display. Set the number of lines to display by entering an integer in the **Inner Lines** field.

- **Combo box** — Default. This representation is configured as a drop-down list by default. For a description of the three types of representation, see the “Combo boxes” section on page 241.

  Set the number of lines to make visible in the list by entering an integer in the **Inner Lines** field.

- **Selection list** — Selection lists generally take up more space than combo boxes because you must specify their size at design time. Note that setting the **Inner Lines field** property has no effect on the visible size of the widget. You must resize it manually by dragging the handles.

- **Radio set** — Best suited to very small, fixed-size data sets that can be represented as short labels. You can specify a vertical (default) or horizontal orientation.

Displayed field attributes

Specify the characteristics of the field you display as a prompt to the user:

- **Label** — Specify the label, if any, to display with the SmartSelect. The SmartSelect object does not inherit the label of the SmartDataViewer field it replaces. You can set the **Data Source** check box to use the schema name of the field, or type in a label of your choice.

- **Browse title** — Active only when browse is the representation type. You can set the title string that the browse widget will display.
• **Datatype** — Read-only. Displays the underlying data type of the displayed field from the schema definition.

• **Format** — Displays the field descriptor from the schema definition. Clear the **Data Source** check box if you have reason to modify this descriptor.

• **Tooltip** — Enter the string the SmartSelect will display as the MS-Windows Tooltip.

• **Help ID** — If you will offer context-sensitive help for this object, enter a unique integer identifier here.

**Geometry**

Displays the origin and size of the SmartSelect representation in character units. You can set these values here, or in pixel units in the **Advanced Properties** dialog box.

**Example: assigning a new sales rep**

This example illustrates how to use a SmartSelect instance to update the SalesRep field in a Customer record. The tables it uses are found in the sports2000 database.

To use a SmartSelect instance to update the SalesRep field in a Customer record (agree to all Advisor suggestions for links):

1. Create a SmartWindow as the application workspace. Save it.

2. Create the SDO master that will pump the Customer records. Choose the Customer table. Use only the Name, Address, City, and SalesRep fields from the Customer table. Save the master. For example:

   ![SmartDataObject - dCustomerSDO.w](image)

3. Place into the application workspace an instance of the Customer SDO you just created:

   ![SmartWindow title - Undefined1](image)

4. Create the SDO master that will feed the SmartSelect field. Choose the Salesrep table. Use only the SalesRep field from that table. Save the master:
5. Create the SmartDataViewer master that will display the Customer records. Include all four of the fields. Save the master, but leave its workspace open:

![SmartDataViewer](image1)

6. Place an instance of the Salesrep SDO into the master SmartDataViewer workspace:

![SmartDataViewer-Salesrep](image2)

7. Replace the SalesRep field in the SmartDataViewer with a SmartSelect instance. Resize the instance for cosmetic reasons:

![SmartDataViewer-SmartSelect](image3)

8. Save the changes in the SmartDataViewer. Place an instance of the SmartDataViewer into application workspace:

![SmartDataViewer-Application](image4)

9. Place Navigation and Update SmartPanels into the application workspace:

![SmartPanels](image5)
10. Run the workspace. You should be able to assign a new sales rep to any account by choosing from the combo box, as shown:
Basic data browsers

In addition to the SDB, AppBuilder supplies the basic ABL data browser (Browse widget), with its built-in query feature. Like the SDB, a basic data browser presents the results of a query in simple row/column tabular format. Each row displayed in a Browse always represents one record from the data stream. Each column represents one of the fields in the records. The browse object can display any of the standard data types that can be represented by ASCII text.

Unlike an SDB, the basic browse object manages its own data stream, communicating with the data source on its own behalf rather than tapping into the data stream supplied by a modular data pump such as the SDO.

Although you can freely place a basic browse object in a smart workspace, for example a SmartWindow, doing so will not enable it to take advantage of SmartLinks or participate in ADM paging.

Creating a basic data browser instance

Unlike an SDB, a basic browse object has no master, and obtains its data stream directly using its built-in query feature. Although there is no master to define, you must define that query.

To create and place a basic Data Browser:

1. Click on the basic Browse tool icon in the Object Palette. Click on a bare spot in your workspace to place it.

2. Query Builder immediately opens. Define the query. See the “Defining and editing queries using Query Builder” section on page 188 for more information. This version of the Query Builder includes a Fields button to allow you to choose specific fields from the table.

   **Note:** While you can elect to jump out of Query Builder and create a free-form query, you cannot later use Query Builder to maintain it. Confirming that you wish to create a free-form query locks out Query Builder immediately; you cannot change your mind. Your only recourse will be to delete the Browse object altogether and create a new one.

3. When you have defined the query terms and chosen the fields the browse will display, click OK to dismiss Query Builder. Your browse widget displays the fields you have chosen.

4. Select the browse, if necessary, and drag the handles to resize and position it to meet your needs. Note that the browse does not display a horizontal scroll bar as long as it has enough space to display at least a fragment of the rightmost field. Check to be sure it displays the whole field.
Configuring a basic data browser instance

You can make a number of changes to the appearance and behavior of your basic Browse object, if the default settings in the property sheet do not meet your needs.

Click on the object to select it, if necessary, and choose Tools → Property Sheet. The Property Sheet dialog box appears:

![Property Sheet Dialog Box](image)

**Minimal configuration**

Although you can accept many of the default settings, you might want to make two changes to individualize this object:

- Change the identifier to more closely reflect this data browser’s role in your application.
- Add a title string, if you plan to allow the browse to display a title bar.

**Query and fields**

If the Query and Fields buttons are visible, it means you can edit those elements using Query Builder and Column Editor rather than the Section Editor. If the buttons are not visible, you must use the Section Editor, and the balance of this section does not apply to this browse.
Since the query is local to this browse, rather than in a separate module, you can make changes both to the terms of the query and to the fields the browse will display.

- Choosing the Query button will start **Query Builder** and allow you to modify the terms of the query. See the “Defining and editing queries using Query Builder” section on page 188 for more information.

- Choosing the Fields button will start **Column Editor** and allow you to modify the columns this SDB will display. For information about how to use Column Editor, see the “Selecting database fields for browsing” section on page 168.

- By default, all columns can be scrolled horizontally, if there are too many columns to display at once. You can choose to lock the leftmost columns in place, so that scrolling does not affect them. Enter in the Locked Columns box the number of columns you want to freeze in place.

  **Caution:** If you lock more columns than will fit in the browse’s window, you effectively disable the horizontal scroll bar.

- When displaying a vertical scroll bar, the system tries to size the scroll bar’s thumb slider to reflect the total number of lines in the data stream. Ideally, the size of the thumb varies inversely with the number of lines (records). In general, the number of records being returned by a query will be larger than the number of lines that can be buffered and, when that is the case, the system cannot begin to correctly size the thumb. If you have a good idea about the total number of records in this data stream, you can improve the accuracy of the scroll bar’s appearance. Enter your estimate in the Max Data Guess field.

- Type into the Tooltip field the identifying text that you want the system to display whenever the mouse cursor hovers over this browse.

**Geometry**

You can set the exact XY origin (relative to the containing frame) and size of this browse instance. Set the values, in character units, in the appropriate fields. You can choose whether the origin is measured at the upper-left corner (the default) or the upper-right corner.

If you would prefer to use pixels rather than character units, click Advanced and set the values using that dialog box instead.

For more information on all the settings on the property sheet, see the online help.
Advanced properties

Click Advanced. The Advanced Properties dialog box appears:

You can make a number of changes to the browse’s appearance and behavior by changing the default settings in this dialog box, as follows:

- **Help** — The text in this field is displayed in the status bar of the parent window when the Browse has the focus. If the parent window has no status area, this text never displays.

- **Private Data** — AppBuilder writes the contents of this field out as the value of the PRIVATE-DATA attribute. You can write code to use this data in any way that meets your needs.

- **Generated Code Layout Unit** — Controls whether AppBuilder describes the position and size of this Browse in character or pixel units, when it generates source code.

- **Geometry - Pixels** — Expresses the origin and size of this widget in pixels. You can set a particular origin and size for the object here rather than interactively, if you wish. You can also choose to have the origin be measured at the upper-right rather than the upper-left corner.

- **Column Movable** — Normally cleared. Setting this check box allows the user to reorder the columns by dragging. Such reordering is cosmetic and has no effect on the actual record.

- **ColumnResizable** — Normally cleared. Setting this check box allows the user to resize the columns interactively. Resizing the column has no effect on the actual field widths.

- **ColumnSearching** — Normally cleared. Setting this check box allows the user to search on a selected column (field).
- **Movable** — Normally cleared. Setting this check box, together with the **Selectable** box, allows the user to move the entire browse object around within the bounds of the enclosing frame.

- **Resizable** — Normally cleared. Setting this check box, together with the **Selectable** box, allows the user to change the size of the browse object, within the limits of the enclosing frame.

- **Row Resizable** — Normally cleared. Setting this check box allows the user to change the vertical size (height) of the rows by dragging a horizontal separator line.

- **Selectable** — Normally cleared. Setting this check box allows the use to select the browse object.
Combo boxes

The combo box object combines a fill-in with a selection list. You might use it in cases where:

- The user will have to choose a single item from a list.
- A radio-button set is not an appropriate representation.

A combo box will generally be a better representation than a radio set when the set of choices is large, varies in size, or involves long strings. A drop-down list or combo box will generally be a better choice than a simple list or combo box when space is at a premium, as is often the case. Drop-down lists/combo boxes also visually emphasize the current choice more than radio sets or simple lists/combo boxes do.

AppBuilder offers two different combo box objects for your use:

- The basic ABL combo box
- An ActiveX (OCX) combo box

Creating a basic combo box instance

You can find the combo box on the Object Palette.

To create and place a basic combo box instance:

1. Click the Combo Box in the Object Palette.
   
   Be sure to select the one shown here. The other Combo Box icon (not shown) represents the OCX version.

2. Move the mouse cursor over a bare spot in your workspace and click to place the new combo box.

3. Configure and size it.
Configuring a basic combo box instance

To configure your combo box object, begin by selecting the object and choosing Tools → Property Sheet. The Property Sheet dialog box appears:

Minimal configuration

Although you can accept the default values for many object properties, you should at least make the following changes:

- Change the object identifier and Label to better represent the role of this combo box in your application.
- Type in the items that will populate the list, one item per line. You might need to change the data type first. See the Define As and Format entries in the “Size and style configuration” section on page 242.
- If appropriate, click Advanced and, when the Advanced Properties dialog box opens, enter the Initial Value.

Size and style configuration

- No-Label — Normally cleared. Setting this check box turns off display of any label. Setting this check box does not clear the actual label text; the label string remains visible in the property sheet. The only other effect of setting or clearing this box is to alter the values in the Geometry section so that the combo box stays at the same XY location within the enclosing frame.
- Inner Lines — Type in the number of lines to be displayed by the selection-list component when it is open. The default value is 5 lines.
**Combo boxes**

- **Define As** — Choose the data type from the list. The default type is **character**, but you can choose **date**, **decimal**, **integer**, **int64**, or **logical** instead. AppBuilder will seed the list with a single item of that type.

- **Format** — Enter the formatting string for the data type you have chosen. If you would prefer to pick the format string from a list rather than enter it by hand, click **Format**.

- **Tooltip** — This combo box displays any text you enter here whenever the user allows the mouse cursor to hover over it.

- **Help ID** — If you plan to provide context-sensitive help in your application for this object, type in a unique integer as its identifier.

**Simple / Drop-Down / Drop-Down-List:**

- **Simple** — In this style, you must explicitly make the selection list component visible at design time, if it is to be visible at all. By default, AppBuilder generates the widget with only the fill-in visible. Drag the bottom handle to reveal as many lines of list as you like. In this style, the fill-in element is editable.

- **Drop-Down** — In this style, the user can open and pick from the list, or type a value into the fill-in component. You can write code to permanently add the typed-in value to the entries in the list, if you wish, or discard the entry after use.

- **Drop-Down-List** — (Default) In this style, the fill-in component is read-only—the user cannot type into it. The user can only open and pick from the list. The choice then appears in the fill-in component. Note that in other major widget taxonomies, a drop-down list is a type of selection list, not a type of combo box. Note, too, that this style is not the default for the ActiveX combo box.

- **Color, type style, popup, string attributes, data field** — Click the appropriate button to set these properties. For further information, see Appendix A, “Frequently Used Dialogs.”

- **Geometry** — Although it is often more convenient to set the XY origin and size of a widget visually in the workspace, you can set those values explicitly here, if you prefer. You can also choose a particular alignment, though the only effect this has is to change the X origin in the source code.

- **Auto-Completion** — Normally cleared. Setting this box causes the combo box to attempt to complete the entry the user is typing. This option is only meaningful where the fill-in portion of the combo box is editable.

- **Display** — Normally set. Clearing this box prevents this combo box from automatically populating its fill-in during initialization.

- **Drop-Target** — Normally cleared. Setting this box causes this combo box to experience an event whenever the user drags another object onto it. You must write the appropriate event-handling code.
• **Enable** — Normally set. Clearing this box makes the fill-in part unresponsive to input.

• **Hidden** — Normally cleared. Setting this box prevents the combo box from responding to implicit requests to display itself. It will only honor explicit requests.
• **No-Tab-Stop** — Normally cleared. Setting this box removes this combo box from the enclosing frame’s traversal list. Normally, pressing the key causes focus to move from one object to the next in the list. When this box is set, the object can neither lose nor gain focus when the user presses the **TAB** key. If the widget has the focus, it will ignore the key, and if it does not, focus will cycle through the other members of the traversal list while ignoring this widget.

**Caution:** Making this combo box **Movable** or **Resizable** (**Advanced Properties**) prevents this object from gaining input focus using the mouse. So if you also set **No Tab Stop**, you effectively prevent the widget from ever gaining input focus.

• **No-Undo** — Cleared. Cannot be set. The AVM will always journal changes to the data in this combo box.

• **Remove from Layout** — Cleared. Cannot be set unless defining an alternate layout.

• **Shared** — Cleared. Setting this box causes the combo box to be reachable outside the defining procedure.

• **Sort** — Normally cleared. Setting this box causes the combo box to always display the items in its drop-down list in sorted order, regardless of their real order.

• **Unique-Match** — Normally cleared. (This option is not available unless you set **Auto-Completion**.) Setting this box causes the combo box to wait for a unique substring before completing the entry.

**Advanced properties**

Click **Advanced**. The **Advanced Properties** dialog box appears:
You can change any of the following values that do not meet your needs:

- **Initial Value** — You can enter a value here that will appear in the fill-in component of the combo box on startup.

- **Help** — The text you enter here will display in the status area of the enclosing window, whenever this object has input focus. If you choose to let this combo box inherit the help string defined in the Data Dictionary’s schema, you will not be able to enter text here, even if there is no help string in the schema. If the combo box is assigned to a dialog box rather than a window, or if the window has no status area, this text will not display.

- **Private Data** — AppBuilder writes this data out as the value of the PRIVATE-DATA attribute. You can write code to make use of this data in any way that meets your needs.

- **Generated Code Layout Unit** — You can elect to have AppBuilder define this object in character (the default) or pixel units, in the source code it generates.

- **Custom Lists** — The custom lists are macros belonging to the enclosing frame. They allow you to treat many objects alike without having to refer to them individually. You can include this object in any or all of the lists.

- **Geometry** — You can set the XY origin and closed size of this combo box in pixel units. This section is identical to the corresponding section in the base property sheet apart from the type of units you use.

- **Manual-Highlight** — Normally cleared. Setting this box allows you to write code to define a custom highlight effect. Your custom effect will be applied whenever this combo box has input focus.

- **Movable** — Normally cleared. Setting this box makes it impossible for the user to give this combo box input focus by clicking with the mouse. Instead, the user can use the mouse to drag the combo box body—but not the label, which stays where it was—to a different position within the bounds of the enclosing frame.

- **Resizable** — Normally cleared. Setting this box makes it impossible for the user to give this combo box input focus by clicking with the mouse. Instead, if the Selectable box is also set, clicking with the mouse causes handles to appear so that the user can resize the object.

- **Selectable** — Normally cleared. Setting this box allows the user to select this combo box.

---

**Caution:** If you make this combo box Movable or Resizable, and you also set the No Tab Stop option in the base Property Sheet, you effectively prevent this object from ever gaining input focus.
Operating a basic combo box

The basic combo box widget consists of a joined fill-in and selection list. You can manipulate the contents of the list under program control.

Clearing the list buffer

The list of items is stored as a string, pointed at by the LIST-ITEMS attribute. You can clear the list by assigning the empty string. For example:

```
comboExample:LIST-ITEMS = "".
```

Setting LIST-ITEMS to the empty string clears the buffer immediately.

**Caution:** The combo box widget is created with a single item in its list. You should always clear that item as part of your initialization process.

You can also use a loop to delete the line items one by one. For example:

```
DO WHILE comboExample:DELETE (1); /* empty statement */ END.
```

In the example code, the DELETE method is called in a WHILE loop to repeatedly delete line item 1. When the buffer is empty of lines, DELETE will return FALSE and the WHILE loop will terminate.

Adding a line item

Using the INSERT() method, you can add a line item at any offset in the list, regardless of the Sort option.

The ADD-FIRST() and ADD-LAST() methods have a different result depending on whether the Sort option is set. If the option is not set, new items will be added to the top or bottom of the list, depending on which method you call. If the Sort option is set, new items will be inserted in sorted order regardless of which method you call.

The INSERT(), ADD-FIRST() and ADD-LAST() methods all return TRUE if they succeed, and FALSE if they cannot perform the insertion:

- The following adds a simple item as the new fifth line:

  ```
  comboExample:INSERT ( "Toy Item", 5 ).
  ```

- The following finds the first exact match of "Target Item" and inserts "Toy Item" as a new line above it:

  ```
  comboExample:INSERT ( "Toy Item", "Target Item" ).
  ```
Chapter 5: Data-Display/Capture Objects

- The following adds a simple item as the new first line:

  ```
  comboExample:ADD-FIRST ( "Toy Item" );
  ```

- The following adds a simple item as the new last line:

  ```
  comboExample:ADD-LAST ( "Toy Item" );
  ```

If you are using simple line items—not item/value pairs—you can add more than one in a single call by combining them into a comma-separated list: "Item 1, Item 2, . . . , Item n".

- The following adds three simple items as the new 5th, 6th, and 7th lines:

  ```
  comboExample:INSERT ( "Line 5 text, Line 6 text, Line 7 text", 5 );
  ```

If you are adding item/value pairs, you can only add one line per call.

- The following adds three item/value pairs as the new 5th, 6th, and 7th lines, with values 25, 48, and 16:

  ```
  comboExample:INSERT ( "Line 5", 25, 5 ).
  comboExample:INSERT ( "Line 6", 48, 6 ).
  comboExample:INSERT ( "Line 7", 16, 7 ).
  ```

Multiple item/value pairs cannot be added using a single call. The following code looks reasonable but would not compile successfully:

  ```
  comboExample:ADD-FIRST ( "Line 5", 25, 5 ,
  "Line 6", 48, 6 ,
  "Line 7", 16, 7 );
  ```

**Adding a user-supplied line item**

Although a combo box appears to be a combined fill-in and list, you cannot capture user input as new items. The fill-in’s function is only to provide a way to select a list item other than by scrolling to find it.
To allow the user to add items to the list, use a separate fill-in to capture the text for the new item or item/value pair and call the appropriate insertion method to add it, as shown in the following:

```
FINewItem pbAppend cbList

IF FINewItem:SCREEN-VALUE <> "" THEN DO:
  /* ignore event if field empty */
  ASSIGN FINewItem.
  /* set the value of the Fill-in */
  CBList:ADD-LAST( FINewItem ).
  /* append the new value to list */
  FINewItem:SCREEN-VALUE = "".
  /* clear Fill-in’s image... */
  FINewItem = "".
  /* ...and its value */
END.
```

Deleting a line from the list

Deleting a line requires only that you know the line number. The following code will delete line 5 if it exists:

```
COMBOExample:DELETE { 5 }.
```

Finding a line or item in the list

- You can determine the line offset of some item using the \texttt{LOOKUP()} method, as shown:

```
lineoffset = COMBOExample:LOOKUP( "Line Item of Interest" ).
```

Note that \texttt{LOOKUP()}:

- Always finds the first instance of the string, if there are duplicates.
- Returns 0 (zero) if the string is not found.

- You can determine the string value of some item using the \texttt{ENTRY()} method, as shown:

```
strItemValue = COMBOExample:ENTRY ( 5 ).
```
Note that ENTRY() will complain and return the undefined value (?) if you pass an argument that does not index an item in the list.
Creating an ActiveX combo box instance

The ActiveX version of the combo box is also available on the Object Palette.

To create and place an ActiveX combo box instance:

1. Click the CSCombo Box in the Object Palette.
   
   Be sure to select the one shown here. The other combo box icon (not shown) represents the version defined in ABL.

2. Move the mouse cursor over a bare spot in your workspace and click to place the new combo box.

3. Configure and size it.

Configuring an ActiveX combo box instance

ActiveX (OCX) objects are functionally similar to native ABL objects, but written to the Component Object Model (COM) standard defined by Microsoft. To adapt them for use in the OpenEdge environment, AppBuilder automatically supplies a two-layer interface object, the control frame. Control frames translate between the COM world and the AVM world.

When you select an ActiveX (OCX) object and choose Tools → Property Sheet, the dialog box that opens in response displays the few properties belonging to the ABL layer of the control frame. See the “ActiveX control frame properties” section on page 349 for further information.

To open the properties dialog box for the combo box itself, double-click on the object. The special ActiveX-style properties dialog box appears:

References in your code to the native ActiveX properties of the combo box instance must take the indirect form

Com-Handle:ActiveX-Identifier:Property-Identifier.
Chapter 5: Data-Display/Capture Objects

Minimal configuration

While you can accept many of the default settings, you will need to make the following changes:

- Replace the default object identifier for the control frame with one that more clearly represents the role of this combo box instance in your application. You can do this directly in the main AppBuilder window, when the instance is selected. You need not change the identifier of the actual ActiveX object itself, though you can if you wish.

- Populate the list of choices that the combo box will use.

To populate the list of choices:

1. Click in the [Custom] property data field to expose the ellipsis (…) button, then click the ellipsis button to open the Custom Properties dialog box:

2. Choose the Contents tab to expose that field:

Type in this combo box’s list of items, one item per line. When finished, click OK to close the dialog box.
Additional property configuration

Choose from three different styles:

- **0 Dropdown Combo** — Default. The user can open and pick from the list, or type a value into the fill-in component. Note that this style is not the default style for the ABL combo box.

- **1 Simple Combo** — In this style, you must explicitly make the selection list component visible at design time, if it is to be visible at all. By default, AppBuilder generates the widget with only the fill-in visible. Drag the bottom handle to reveal as much of the list element as you like. In this style, the fill-in element is editable.

- **2 Dropdown List** — In this style, the fill-in component is read-only—the user cannot type into it. The user can only open and pick from the list. The choice then appears in the fill-in component. Note that, in other taxonomies, a drop-down list is a type of selection list, not a type of combo box configuration.

Code configuration

When you run a workspace for the first time after placing your first ActiveX (OCX) object in it, AppBuilder creates the `control_load` procedure. You can inspect that procedure in the **Section Editor**, but not edit it.

In that procedure, AppBuilder creates the variable of type `COM-HANDLE` that you will use when you write event handlers. The identifier of the variable is the same as the identifier you assign to the control frame's **Object** field, with `ch` prepended. Thus, if you assign the identifier `Example` to the control frame, the `COM-HANDLE` identifier will be `chExample`.

The combo box stores its current string value in the `Value` property. To determine the index value of that string (the topmost list item is index 0), pass the `Value` property to the `FindStringExact()` method.

Presuming you use the object identifier `Example` for the OCX control frame, this toy code will detect the user's selection, and print out the string and index values:

```plaintext
/* Add to the Definitions section */
DEFINE VARIABLE sSelection AS CHARACTER NO-UNDO.
DEFINE VARIABLE iSelection AS INTEGER NO-UNDO.

/* Add as the Trigger for event OCX.Click */
ASSIGN
  sSelection = chExample:CSComboBox:Value
  iSelection = chExample:CSComboBox:FindStringExact( sSelection, -1 ).

MESSAGE 'Selection is ' sSelection 'at index' iSelection .
```

For further information about events, methods, and properties for the three OCX objects that AppBuilder supplies in the **Object Palette**, see the online help.
Basic data viewers

The basic data viewer object, or DB-Fields as it is also called, corresponds in purpose to the SmartDataViewer object. While browsers present fields from many records at once, in a row/column tabular format, the viewer objects display fields from a single record using fill-in widgets, one fill-in per field. The viewer object can display any of the standard data types that can be represented by ASCII text.

Unlike a SmartDataViewer, the basic viewer object manages its own data stream, communicating with the data source on its own behalf rather than tapping into the data stream supplied by a modular data pump such as the SDO.

Although you can freely place a basic data viewer object in a smart workspace, for example, a SmartWindow, doing so will not enable it to take advantage of SmartLinks or participate in ADM paging.

Creating a basic data viewer instance

Unlike a SmartDataViewer, a basic data viewer (DB-Fields) object is not based on a master, but you must define the query it will use.

To create and place a basic data viewer object:

1. Click DB-Fields in the Object Palette.

2. Click on a bare spot in your workspace to begin the placement process. The Table Selector dialog appears:
3. Select a table or tables from which to select fields, then click **OK**. The **Multi-Field Selector** dialog box appears:

4. Select the database fields to add to your workspace, then click **OK**. The fields appear in your workspace.

**Configuring a basic viewer instance**

Besides rearrangement, you can make a number of other changes to the appearance and behavior of your basic viewer object, if the default settings do not meet your needs. You make such changes via the property sheets of the individual fill-ins.

See the “Configuring a fill-in instance” section on page 258 for more information.
Multi-line editors

The Editor widget provides the ability to capture large amounts of text in a way familiar to and convenient for the user. You might use an editor object to capture, for example, free-form comments of undetermined length.

Although they are basic ABL objects rather than SmartObjects, you can add a considerable amount of additional capability to them through calls to ABL methods for searching and other functions.

Creating an editor instance

Because the Editor widget is a basic ABL object, creating one is very simple.

To create an Editor widget:

1. Click Editor in the Object Palette.
2. Move the mouse cursor over a bare spot in your workspace and click to place the new Editor object.
3. Configure and size it.

Configuring an editor instance

You can change some basic characteristics of the editor widget’s appearance and behavior through its property sheet, if the default settings do not meet your needs. Note, however, that the more sophisticated behaviors, such as searching, cannot be enabled in the property sheet.

To configure your editor object, begin by selecting the object and choosing Tools → Property Sheet. The Property Sheet dialog box appears:
Minimal configuration

Although you might choose to accept the other default settings, you should make at least the first of these two changes:

- Change the default identifier to one that more closely reflects the role of this object in your application.

- Turn off the **Horizontal** scroll bar and turn on **Word Wrap**. The default style produces a single long line of input unless the user explicitly uses the **RETURN** key. This might not be the most appropriate style for the needs of your application.

Edit-buffer size

The default size of an editor widget's buffer is 20KB under Windows. You can reduce memory requirements by forcing a smaller buffer size. Enter the desired value in the **Maximum Characters** field.

Help

Add one or both of these help elements:

- Add a **Tooltip** string, if appropriate. The editor will display that string whenever the user allows the mouse cursor to hover over the widget.

- If you will provide context-sensitive help for this object, add a unique integer **Help ID**.

Geometry

AppBuilder allows you to adjust the position and size of your widgets interactively, by dragging their handles. The changes you make in this way are reflected in the **Geometry** values. You can also change these values explicitly, here.

AppBuilder normally generates source code that identifies the upper-left corner of the object as its origin. You can choose to have the upper-right corner identified as the origin instead. This alignment setting does not change the actual position of the object in any way.

For more information on all the settings on the property sheet, see the online help.

Advanced properties

The editor widget has only the standard advanced properties, but you can change those that do not meet your needs. See the “Advanced properties” section on page 355 for more information.
Fill-ins (single-line editors)

The fill-in widget provides the ability to capture and/or display a small amount of text, typically a single token or short string. Fill-ins do not allow embedded line breaks. You can choose to have text captured by a fill-in undergo automatic type conversion and validation.

Creating a fill-in instance

Because the fill-in widget is a basic ABL object, creating one is very simple.

To create a fill-in widget:

1. Click Fill-in in the Object Palette.
2. Move the mouse cursor over a bare spot in your workspace and click to place the new object.
3. Configure and size it.

Configuring a fill-in instance

You can change some basic characteristics of the fill-in widget’s appearance and behavior through its property sheet, if the default settings do not meet your needs.

To configure your fill-in object, begin by selecting it and choosing Tools→Property Sheet. The Property Sheet dialog box appears:
Minimal configuration

Although you can accept many of the default settings, you should at least make the following three changes:

- Change the AppBuilder-generated object identifier to one that more accurately reflects the role of this fill-in in your application.
- Change the generic label to one that will be meaningful to the users of your application. Or, if appropriate, set the No Label check box to hide the label. Setting this check box does not clear the actual label text; the label string remains visible in the property sheet. The only other effect of setting or clearing this box is to alter the values in the Geometry section so that the fill-in stays at the same XY location within the enclosing frame.
- Click the Advanced button and set the initial value, if any, that the fill-in is to display. By default, the initial value is empty/undefined.

Internal data format

You can use a fill-in to capture any data type whose value can be entered from the keyboard and represented on the display as ordinary text. The fill-in will do a limited amount of syntax-checking for you if you appropriately set the values for Define As and Format.

- Define as — Choose the data type from the list. The default type is CHARACTER, but you can choose DATE, DATETIME, DATETIME-TZ, DECIMAL, INTEGER, INT64, or LOGICAL instead.
- Format — Enter the formatting string for the data type you have chosen. If you would prefer to pick the format string from a list rather than enter it by hand, click Format to open a dialog box specific to the type you have chosen. Shown here is the dialog box that displays for type CHARACTER:

![Character Format Dialog](image)

Help

You can supply helpful information to your users in several ways. Here are two of the most common:

- Add a Tooltip string. Under Windows, Tooltips display whenever the user allows the mouse cursor to hover for a few seconds over an object for which a Tooltip is defined.
- Add a unique integer as the identifier for context-sensitive help, if you plan to provide such help as part of your application.
Geometry

Reflects the XY origin and size, in character units, of the fill-in. By default, the fill-in is colon-aligned. You can change that to left- or right-alignment, though the only noticeable effect that will have is to change the X origin value.

For more information on all the settings on the property sheet, see the online help.

Advanced properties

A fill-in widget has only the standard advanced properties, but you can change those that do not meet your needs. See the “Advanced properties” section on page 355 for more information.
Radio button sets

The radio-set widget provides a way to force a single choice from a small set of possibilities. Unlike a logical set that you might construct using toggle boxes, a radio-button set must always have exactly one member—no more, no fewer—selected. Thus, you cannot use radio button sets when you wish to allow no selection or multiple selection.

The radio set widget will represent a value of any standard type, including CHARACTER. Typically, though, you would use a radio button set for values that are basically nontext-numeric, symbolic-in nature.

By default, AppBuilder supplies a set of three buttons, arranged vertically. Using the property sheet, you can easily change the orientation to horizontal, and increase or decrease the number of members in the set.

Creating a radio-set instance

Because the radio-set widget is a basic ABL object, creating one is very simple.

To create a radio-set widget:

1. Click Radio Set in the Object Palette.

2. Move the mouse cursor over a bare spot in your workspace and click to place the new object:

3. Configure and size it. Note that you can change the spacing between the buttons by dragging the group handles.
Configuring a radio-set instance

To configure your radio-set object, begin by selecting it and choosing **Tools → Property Sheet**. The **Property Sheet** dialog box appears:

![Property Sheet - RADIO-SET-1](image)

**Minimal configuration**

Although you can accept many default settings, you should at least make the following changes:

- **Object** — Change the default identifier to one that more clearly reflects the role of this radio set in your application.

- **Define As** — By default, the radio-set widget represents a variable of type `INTEGER`. You can choose a different data type, if more appropriate. Open the drop-down list and make your choice. Note that the button definitions in the list above this drop-down change to agree with your choice here.

- **Buttons** — Each button is defined by a pair of values:
  - **Label string**, delimited by double quotes
  - **Item value**, consistent with the data type

  Use a comma as separator between the label string and the item value, and between the item value for one button and the label string for the next button.

  Changing the number of buttons is very simple. To make a set with fewer buttons, delete the unwanted value pairs. To make a larger set, add value pairs.

- **Initial value** — By default, the initial value is undefined. That might not be at all obvious because of the way a radio-button set displays itself. It is good programming practice to always explicitly initialize variables, but initialization is particularly important in such cases as this.
To set the initial value, click the **Advanced button. When the Advanced Properties dialog box appears, type an appropriate value into the Initial Value field.

**Help**

You can add one or two types of help here:

- **Tooltip** — The radio button set will display this string whenever the user allows the mouse cursor to hover over the object’s frame.

- **Help ID** — If you plan to provide context-sensitive help, type in a unique integer identifier.

**Geometry**

Reflects the XY origin and size, in character units, of the widget’s bounding box. By default, the object’s origin is considered to be the upper-left corner. You can elect to have AppBuilder consider the origin to be the upper-right corner instead, though this will not change the object’s position in any way.

For more information on all the settings on the property sheet, see the online help.

**Advanced properties**

A radio-set widget has only the standard advanced properties, but you can change those that do not meet your needs. See the “Advanced properties” section on page 355 for more information.
Selection lists

The *selection-list* widget allows you to present users with a list of values represented by text strings. Selection lists serve a similar function to radio button sets and combo boxes: grouping and presenting a set of potential choices. Unlike those objects, Selection lists permit multiple selection. Selection lists (or combo boxes) are more appropriate than radio-button sets when the number of items in the set cannot be determined in advance, or where long text strings are involved.

As with radio button sets, you can assign arbitrary values to the line items in the list.

Creating a selection list instance

Because the selection list widget is a basic ABL object, creating one is very simple.

To create the selection list widget:

1. Click **Selection List** in the **Object Palette**.
2. Move the mouse cursor over a bare spot in your workspace and click to place the new object.
3. Configure and size it.

Configuring a selection list instance

To configure your selection list object, begin by selecting it and choosing **Tools** → **Property Sheet**. The **Property Sheet** dialog box appears:
Minimal configuration

Although you can accept many default settings, you should at least make the following changes:

- **Object** — Change the object identifier to one that more clearly relates to the role of this List object in your application.

- **List-Items versus List-Item-Pairs** — Choose whether the selection list object should interpret the content you enter in the field below as independent, listable strings only, or string + value pairs. If you elect Items, the value of the variable will be the selected string(s) themselves. If you elect Pairs, the value will be the value portion of the selected item(s).

- **Content** — Type in the selectable items to be displayed by the object. They can be either strings (Items) or comma-separated string + value pairs (Item Pairs). Type in only one item or item pair per line. If you are using Item Pairs, remember to separate the string from the value by a comma.

Help

You can provide your users additional help through these settings:

- **Tooltip** — The selection list displays this string whenever the user allows the mouse cursor to hover over the object’s frame.

- **Help ID** — If you plan to provide context-sensitive help, type in a unique integer identifier.

Geometry

Reflects the XY origin and size, in character units, of the selection list’s bounding box. By default, the object’s origin is considered to be the upper-left corner. You can elect to have AppBuilder consider the origin to be the upper-right corner instead, though this will not change the object’s position in any way.

For more information on all the settings on the property sheet, see the online help.

Advanced properties

A selection list widget has only the standard advanced properties, but you can change those that do not meet your needs. See the “Advanced properties” section on page 355 for more information.
Slider controls

The Slider-Control widget is a virtual knob-and-track device with integrated numeric readout. Moving the knob along the track sets the associated value to a proportional value within the range you have defined on the track. Conversely, setting the value of the associated variable moves the knob to the corresponding position along the track, offering the user a degree of analog, at-a-glance information that the number displayed by the readout does not.

**Note:** You can assign a slider to visualize an INTEGER or INT64 field or variable. However, the slider cannot display values less than -32,768 and greater than 32,767.

Creating a slider-control instance

Because the slider-control widget is a basic ABL object, creating one is quite simple.

To create the slider-control widget:

1. Click Slider-Control in the Object Palette.

2. Move the mouse cursor over a bare spot in your workspace and click to place the new object:

3. Configure it, and adjust its size and position appropriately.
Configuring a slider control instance

You can change some basic characteristics of the slider control widget’s appearance and behavior through its property sheet, if the default settings do not meet your needs.

To configure your slider control object, begin by selecting it and choosing **Tools** → **Property Sheet**. The **Property Sheet** dialog box appears:

![Property Sheet dialog box](image)

**Minimal configuration**

Although you can accept many default settings, there are some you should change:

- **Object** — Change the object identifier to one that more closely matches the role of this slider control in your application.

- **Min Value/Max Value** — By default, the slider control represents the subrange 0–100. Unless this already meets your needs, define the subrange you want. The Slider can display any signed integer value from \(-32768\) to \(32767\).

- **Initial value** — By default, the slider control is initialized to 0, or to the lowest value in the subrange if 0 is outside the subrange. To initialize to some other value, click the **Advanced** button and, when that dialog box opens, type in the initial value you desire.

- **Tic Marks** — By default, the scale (virtual slot) is unmarked. You can choose to add tic marks to either or both sides. If you do, you can also choose the value interval (default is 10, for a 0–100 scale).

**Help**

You can provide additional help to your users with these settings:

- **Tooltip** — The slider control displays this string whenever the user allows the mouse cursor to hover over the object’s frame.

- **Help ID** — If you plan to provide context-sensitive help, type in a unique integer identifier.
Geometry

Reflects the XY origin and size, in character units, of the slider control’s bounding box. By default, the object’s origin is considered to be the upper-left corner. You can elect to have AppBuilder consider the origin to be the upper-right corner instead, though this will not change the object’s actual position in any way.

For more information on all the settings on the property sheet, see the online help.

Advanced properties

A slider control widget has only the standard advanced properties, but you can change those that do not meet your needs. See the “Advanced properties” section on page 355 for more information.
Spin controls (ActiveX)

The **Spin-Control** widget consists of two buttons marked with arrowheads, optionally attached to a readout field that displays an **INTEGER** value. You can think of the buttons as being a form of scroll bar, without the actual bar or thumb. Pressing one of the buttons causes the value in the readout fields to change by some amount you set (default 1) within the subrange **–10000** to **10000**. Unlike a scroll bar or a slider control, a spin control offers no analog, at-a-glance information. You might use a spin control in cases where you wish to allow the user to set some value that changes in integer steps other than 1.

Creating a spin control instance

To create a spin control:

1. Click **CSSpin** in the **Object Palette**.
2. Move the mouse cursor over a bare spot in your workspace and click to place the new object. It will almost certainly be too large, so resize it temporarily:

![Spin Control Example](image)

3. Configure it, and make final adjustments to its size and position.

Configuring a spin-control instance

The spin control has a number of properties you can change if the default settings do not meet your needs. Double-click the instance to open its **Property Editor** sheet:
Minimal configuration

Although you can accept many default settings, you should at least make the following changes:

- Replace the default identifier (shown in AppBuilder’s main window) with one that more clearly identifies the role of this object in your application. This identifier belongs to the control frame interface. For more information about control frame objects, see the “ActiveX control frame properties” section on page 349. **Max and Min**—normally 10000 and –10000 should have their properties set to the upper and lower INTEGER bounds of the range you want the spin control to use. You cannot set a value smaller than –10000 or larger than 10000. Note that if you set Min to be larger than Max, the meaning of the buttons will reverse, which may confuse the user.

- **Increment** — Normally 1. Set this property to be the size of the INTEGER change to be made per button press. This is an unsigned (absolute) value.

Optional configuration

You may wish to make changes to some or all of the following settings, or to others not discussed here:

- **Value** — Normally 0. Set this property to initialize the object; read it to detect user changes.

- **Spin Rate** — Normally 10. This property represents the number of increments per second when the user holds down one of the buttons. Thus, if the increment value is 100, and you set the Spin Rate to 12, you can expect the value to change by 1200 over a second’s time, when a button is held down.

- **GetArrows** — Normally TRUE. Setting this property to FALSE prevents the object from responding to keyboard arrow-key presses. Normally, pressing one of the arrow keys has the same effect as pressing one of the spin control buttons.

- **ValueDisplay** — Normally AutoSized. Setting this property to None prevents the object from displaying the integrated readout. Turning off the readout in this way is useful if you wish to bind the buttons to some other object for display.

- **Style** — Normally 3D Vertical. There are four possible settings, combining Normal versus 3D, and Horizontal versus Vertical. Setting this property to Normal flattens out the 3D effect, and setting it to Horizontal changes the orientation of the buttons such that they point left and right rather than up and down.

  Combining Horizontal orientation with reversed Min and Max meanings may be appropriate in some international contexts.

- **Alignment** — Normally Right Justify. Applies to how the integrated readout displays the object’s INTEGER value. Possible settings are Left Justify, Center, and Right Justify.
Toggle boxes (check boxes)

The toggle box always represents two-valued, either/or information. You can visually group together many toggle boxes in a logical relationship that you define, but, unlike radio buttons, toggle boxes have no interdependence and are unaware of one another’s settings. Setting one box has no effect on any other unless you write the code to create and manage that effect.

Radio-sets are best for representing a group of mutually exclusive states; toggle box sets are best for representing a group of independent states.

Creating a toggle box instance

Because toggle boxes are ABL objects, creating one is quite simple.

To create a toggle box instance:

1. Click Toggle Box in the Object Palette.

2. Move the mouse cursor over a bare spot in your workspace and click to place the new object:

3. Configure it, and adjust its size and position appropriately.

Configuring a toggle box instance

You can change some basic characteristics of the Toggle-Box widget’s appearance and behavior through its property sheet, if the default settings do not meet your needs.

To configure your toggle box object, begin by selecting it and choosing Tools → Property Sheet. The Property Sheet dialog box appears:
Minimal configuration

Although you can accept other default settings, you should at least make the following changes:

- **Object** — Change the object identifier to one that better reflects the role of this toggle box in your application.

- **Label** — Change the label to a string that will help the user of your application understand what the toggle box selects.

  Note that it will be better for your users if you do not create cross-connections in their heads: the cleared state should always represent the *not/off/false/negative* condition, not the default condition. Initialize the box to whatever the default condition is, whether set or cleared.

- **Initial Value** — By default, the toggle box initializes itself to the cleared state. To change that, click the **Advanced** button, and when the **Advanced Properties** dialog box opens, type yes into the **Initial Value** field.

Help

You can offer additional help to your users through these settings:

- **Tooltip** — The check box displays this string whenever the user allows the mouse cursor to hover over the object’s frame.

- **Help ID** — If you plan to provide context-sensitive help, type in a unique integer identifier.

Geometry

Reflects the XY origin and size, in character units, of the object’s bounding box. By default, the object’s origin is considered to be the upper-left corner. You can elect to have AppBuilder consider the origin to be the upper-right corner instead, though this will not change the object’s position in any way.

For more information on all the settings on the property sheet, see the online help.

Advanced properties

A toggle box widget has only the standard advanced properties, but you can change those that do not meet your needs. See the “Advanced properties” section on page 355 for more information.
Data-Communication Objects

The world is increasingly a wired one, where the limitations imposed by physical distance are being overcome in part by high-speed, global communication. As more companies partner with customers on the other side of the globe, effective data communication becomes vital to staying in business.

This chapter describes the data-transformation and communication objects AppBuilder supplies for your use:

- SmartB2BObjects
- SmartSender and SmartReceiver objects
- SmartRouters
- SmartProducers and SmartConsumers
- The message-handling relationship: internal details
The SmartB2BObject helps you make your applications capable of business-to-business communication. It handles transformation between the internal data representation and the emerging standard for inter-business communication, the eXtended Markup Language (XML). Figure 37 illustrates how the SmartB2BObject fits into an application that can communicate with another business over the Internet.

XML is related to HTML, the HyperText Markup Language of the Web. Both XML and HTML are descendents of SGML, the Standard Generalized Markup Language used in high-end publication editors.

A detailed description of XML is well beyond the scope of this document, but you can find specifications and descriptions in a number of sites on the Web. The standards body for XML, as for HTML, is the WorldWide Web Consortium (W3C), an international organization. The W3C is hosted in the Americas by the Massachusetts Institute of Technology in Cambridge, Massachusetts, USA, in Europe by the Institut National de Recherche en Informatique et en Automatique (INRIA) at several locations in France, and in Asia by Keio University at their Shonan Fujisawa Campus in Japan.
The W3C sponsors several ongoing engineering committees, including the XML Schema Working Group. The consortium’s Web site has information about these working groups, including instructions for joining them if you want to help with their work. The Web site also has primary instructional materials, standards documents, pointers to tools such as schema validators, and links to other sites. Their URL is http://www.w3.org.

**XML schema and mapping files**

Although two business partners might use an identical set of logical documents, their documents generally have different physical formats and map to databases that are organized differently. Rarely will two businesses use the identical format for their purchase orders, for example, or have identically-named tables and fields. This creates a problem for automatic handling. Although human beings are extremely good at recognizing when two different physical formats are logically equivalent, computers are not. For this reason, some way is needed to transform a logical document from the sender’s local format into the receiver’s local format. The most general solution to this problem is to create a shareable intermediate representation. XML, emerging as an international standard, is well-suited to that role.

XML schema are defined using a notation called “XML Data, subset reduced.” A number of organizations have arisen that act as repositories for shareable schema and there are already schema defined for many common documents. You can discover some of them through the WWW Consortium Web site and others by using a Web search engine.

An XML schema for some logical unit of communication (a purchase order, an invoice, a catalog, etc.) is defined in advance and shared with business partners who will receive that kind of document. XML schema serve the same purpose as database schema—they define how raw data should be interpreted. They deal with form rather than content.

After a schema for a document has been agreed upon, each business creates an additional XML file that describes how to map between that common, shared schema and their own local data format. Typically, different mapping files will be used for inbound and outbound documents, even within a single site.

Once those mapping files have been created and debugged, communication becomes a relatively straightforward operation.

**Caution:** At present, there is no automatic safeguard against schema version skew. It is possible for a particular schema to be changed without notice, with an updated map file being created only at one end of the communication channel. In that case, miscommunication will certainly occur, possibly in ways that are important but hard to detect. Although you cannot eliminate this problem, you can reduce it by maintaining and checking for version information in any schema you create.
Figure 38 illustrates how the schema, the map file, and the data interact in inter-business messaging.

On the originating side (the left side in Figure 38), the value for the Surname (family name) field in the Empl table is Smith. The XML schema specifies a Surname field of type string. The map file relates the XML Surname node to the Empl.Surname field.

The SmartB2BObject would use that mapping to extract the value Smith from the data and insert it into the message. When the message is received (the right side in the figure), the SmartB2BObject there parses the message, encounters Surname, and checks its own map file, where it sees that Surname maps to the Client.FamName field. It then passes the value Smith to the SmartDataObject handling that table.

Note that neither the table nor the field need have the same name on both sides. That is the purpose of XML mapping: to make such differences irrelevant.
Figure 38 illustrated the simplest mapping: an XML field to a database field. Figure 39 illustrates a more complex possibility: deriving a value for the message by filtering local data.

Figure 39: Mapping an XML node to a function

In this example, the node definition in the XML schema is the same as in Figure 38: Surname, defined as type string. Here, though, there is no surname field in the Empl table. The whole name is stored as a single string. The mapping in this case is to a dedicated function FamilyName() that reads the Name field and returns the surname substring.

Where does that dedicated function come from? You create it.

You can create mappable procedures and functions within the SmartB2BObject itself, or in the SmartBusinessObject or SmartDataObject that cooperates with the SmartB2BObject. In general, good programming practice suggests that you put special procedures and functions inside the object to which they are most closely related. In the illustrated case (Figure 39), that would be the SmartDataObject, since a FamilyName() function would be the logical equivalent of a calculated field.

Mapping options

Mapping is like translating between spoken languages. It can be simple or difficult depending on the complexity of the original document and your skill at preserving the underlying meaning.

**Caution:** No type-checking is performed during the mapping process. You must ensure that the values you produce by mapping or conversion are appropriate and correct.

You have a number of mapping options to aid you in your document conversion. You can choose to map a schema node to:

- A column being managed by a data-access object.
• A function you created in the SmartB2BObject itself.
• A procedure you created within the data-access object.

• A function you created within the data-access object.

• A whole data-access object.

These options are discussed more fully in the following sections.

**Mapping to a column**

This is the simplest and probably the most common mapping. You can use it whenever a column in the data stream corresponds directly to a schema element.

Calculated fields/columns can complicate matters. On the outbound side, mapping a calculated column is identical to mapping an ordinary column. However, since calculated fields have no physical existence in a database, you would have to write special code to make sense of an inbound mapping. Usually, calculated fields are read-only; writing them in a meaningful way requires that you handle the result as a special case, decomposing and folding it back into the original fields in some way that fits your business context.

**Mapping to a function in the SmartB2BObject**

If you need to transform or convert a column value in some general way before sending/storing it, you can create a function to do that inside the SmartB2BObject itself. For example, you might create a function to convert dates to some special format, or present an integer value in some unusual base. The Mapping Tool will display any such functions as options when you elect to map to a column.

These conversion functions always have a single parameter:

• For inbound documents, the value of the message element is passed as the parameter and the return value of the function is stored into the data field.

• For outbound documents, the situation is exactly opposite: the data field is passed as the parameter and the return value of the function is used as the message element.

**Mapping to a procedure in the data-access object**

When you map an XML node to a procedure, you are actually mapping to the procedure’s parameter. The parameter must be an **INPUT** parameter for inbound documents and an **OUTPUT** parameter for outbound documents. It must also be the only parameter. You must handle all ABL data operations inside the body of the procedure.

**Mapping to a function in the data-access object**

When you map to a function, the exact mapping depends on the direction:

• For inbound documents, you are mapping the schema node to an **INPUT** parameter. You must handle all assignments to the data field within the body of the function; the return value will be discarded.

• For outbound documents, you are mapping the return value of the function to the schema node. These functions can have no parameters. Handle all data reads within the body of the function.
Mapping to a whole data-access object.

Mapping a whole object to a schema node has a different meaning depending on whether you are creating an inbound or an outbound map. On the outbound side, the meaning is an implied one: iteration.

Consider the subtree example shown:

```
Customer
  custnum
  name
  state
  street
  town
  zip
```

The fields custnum, name, state, and so forth have obvious mappings to fields in the Customer table. To map those fields to these nodes, you must identify as a resource the SmartDataObject that supplies records from the Customer table.

If the schema allows multiple instances of the Customer element to be generated, and you map the object itself to the Customer node here, then the SmartB2BObject treats that as a request to fetch all Customer records as part of building the message body. It will loop through all Customer records, extracting values for each of the mapped fields (custnum, name, and so forth) and creating XML for them.

The net result of that loop will be multiple Customer record elements, explicitly laid out in the message body. It might look something like the following, if the only fields mapped were custnum and name:

```
<Customer>
  <custnum> 1 </custnum>
  <name> Smith </name>
</Customer>
<Customer>
  <custnum> 2 </custnum>
  <name> Garcia </name>
</Customer>
<Customer>
  <custnum> 3 </custnum>
  <name> Hardingfele </name>
</Customer>
```

Which means that, on the inbound side, no loop is required—simply going through the message in a linear way will traverse all included elements.

On the inbound side, the result of processing the incoming XML is typically operations on a database. When you elect to map a data object to an element, you must identify what sort of operation is desired or acceptable:

- **Update (may exist)** — Any particular record need not exist. If it does exist, it will be updated and if it does not exist, it will be created.

- **Update (must exist)** — The record must exist and will be updated as part of the message-consuming process. If the record does not exist, the data handler will report an error.
• **Create only** — The record must not already exist; it is created as part of the message-consuming process. If the record already exists, the data handler will report an error.

• **Delete** — The record must exist; it is deleted as part of the message-consuming process. If the record does not exist, the data handler will report an error.

• **Find** — This operation is used for positioning the current-record pointer in the database.

**Note:** It is also possible to identify the operation within a node of the message itself. Exactly how this is to be done is not well-defined and may vary across document schema. If you face this situation, you must write code to handle it as a special case.

To continue the example: if on the inbound side you map the Customer object to the Customer element with a type of Create, then every time the receiving SmartB2BObject sees the `<Customer>` token in the received message, it will build a Create request using field data from `<custnum>`, `<name>`, and so forth. When it reaches the `</Customer>` token, it will forward the request to the local SmartDataObject that manages that table.

Note that, in this example, Customer cannot be the root node of the schema tree if you intend to generate multiple records; XML only allows one root node. If Customer were the root node, only data from the current record would be transformed into XML.

However, if Customer is not the root node of the schema tree, then all Customer records will be processed. If you want only a subset of all records to be used, you must take steps to ensure that only those records appear in the data stream. Consider using a SmartFilter for that purpose (see the “SmartFilters” section on page 180 for details).

**Caution:** If you map an object to some field/column that does not necessarily have unique values across all records, Find, Delete, and Update operations will act on the first acceptable record found. That might not be what you intend or desire.

**XML schema Mapping Tool**

Every time the SmartB2BObject converts some document to or from XML, it must read the logical associations from a map file. You or the user of your application must create each such map file specifically for a particular document schema and direction (inbound or outbound). This can be a non-trivial programming task. Progress Software provides an editor—the XML Mapping Tool—to make that task easier.
Figure 40 shows the Mapping Tool’s window.

The Mapping Tool window is divided into two spaces—a tree view on the left and a tab control with four tabs on the right.

The tree view displays the current state of the map file. Each line represents a mappable element of the document. As you make mapping choices, the tree view changes to reflect them. When every node displays a mapping, your map file is complete.

The four tabs on the right contain the editing interface:

- The Map tab is where you will do most of the mapping work.
- The Schema tab provides read-only information about the current schema file.
- The Source tab offers a read-only view of the raw schema source.
- The Object tab allows you to identify the local SmartObjects to use when mapping nodes.
Starting the XML Mapping Tool

You can start the XML Mapping Tool in either of two ways:

- Click the tool icon at the end of the PRO*Tools toolbar:

![Mapping Tool icon]

When the Mapping Tool window opens, choose File → Open and select one of the three types of files the mapping editor understands. Those files are:

- **Outbound map file** — Identified by the filename extension .xmp (XML Map for Producers). This file is used to transform outgoing data from the local internal representation into XML format for transmission.

- **Inbound map file** — Identified by the filename extension .xmc (XML Map for Consumers). This file is used to transform incoming data from the XML representation into the local internal format for processing and storage.

- **XML schema file** — Identified by the filename extension .xsd (XML Schema Document). This file represents the generic, standard, nonproprietary document. It is used by all parties as the basis for creating their inbound and outbound map files. You cannot edit a schema file using the XML Mapping Tool.

- Choose File → Open in AppBuilder and select a map or schema file. AppBuilder will automatically call the Mapping Tool on your behalf.

**Note:** The XML Mapping Tool only supports schema files that conform to the W3C specification. It does not attempt to handle other formats such as Microsoft’s or BizTalk’s. Nor does it handle the older Document Type Description (DTD) files.

Creating an XML map file

Use the Mapping Tool to create a map file.

**To create a map file:**

1. Start the Mapping Tool and select the SmartObjects that will handle this class of document.

2. Work through the fields—nodes— of the document in an orderly way, mapping each one to the corresponding object, database field, or transforming routine.

Selecting SmartObjects for mapping

The SmartB2BObject always transforms data on behalf of some other object. You must identify at least one such object—typically a SmartDataObject or SmartBusinessObject—before you can begin mapping nodes.
To map SmartObjectsWriter:

1. Choose the Object tab. The view changes, as shown:

2. Click Add. Select an object that can serve as a DATA-SOURCE or DATA-TARGET, depending on the type of map file you are creating. Its ObjectName property will appear in the fill-in and its filename will appear in the list box.

Note: You can edit any ObjectName here, but no two listed objects can have the same ObjectName. If you change an ObjectName, the new name must be locally unique (in other words, unique within the list you are creating here).

3. Repeat Step 2 until you have identified all the objects you will use.

Note: If you intend to use conversion functions that reside in the SmartB2BObject, you must add that object to this list as well.

If you make a mistake when adding an object, select it in the list and click Remove. Note that you can remove an object from the list at any time. Even if you have already mapped nodes to the object, the mappings will go away cleanly if you remove the object name from the list.

4. Select the mode of this map file: inbound (consumer) or outbound (producer).

5. Click Browse and identify the SmartContainer that holds the SmartB2BObject that will use this map file. You can omit this step if this is the only document type your application will produce/consume.

6. Choose File → Save to save your work.

You are now ready to begin the mapping process itself.
Mapping schema nodes

As the SmartB2BObject parses some logical document, it consults the map file you created for that document type. That map file must contain a mapping association for every element of the document. As the SmartB2BObject identifies an element in the document, it creates a transformation based on the association you supplied.

To create an association:

1. Select a node in the tree view. Click the Map tab, if necessary:

2. Pull down the Object list and select the object that will supply the association for this node:
3. Select the appropriate radio button to refine the association. You can choose to map the node to:

- The whole object, if you intend to loop through multiple records (outbound side) or to CREATE, FIND, or DELETE the node, or UPDATE it or its children (inbound)
- Some particular field supplied by the object, if the node does not have children
- Some procedure or function, if the node does not have children

See the “Mapping options” section on page 277 for more information.

4. The display changes to reflect your choice, as shown:

![Image of XML Schema Mapping]

Complete the association by selecting the exact mapping (see the “Mapping options” section on page 277 for more information):

- If mapping the whole node in an inbound document, select the action to be performed (Update-may exist, Update-must exist, Create only, Delete, Find):
• If mapping to or from a column that you will filter through a SmartB2BObject function, select the column identifier before you select the function identifier:

• If mapping to a procedure, or to a function not in the SmartB2BObject, select it from the list that appears after you choose the radio button.

Creating a master SmartB2BObject

The SmartB2BObject is supplied for your use in two forms: a template for creating custom master objects and a precompiled master from which you can create generic instances. Unlike other template-based SmartObjects, creating a custom master SmartB2BObject does not involve a wizard.

To create a new master object:

1. Click SmartB2BObject in the Object Palette.

2. When the Choose dialog box appears, click New.
3. The new SmartB2BObject master appears immediately. Select it, open the Section Editor, and add all the code needed to complete this custom master.

4. Choose File → Save and give the new master a descriptive filename. Note that SmartB2BObject filenames conventionally begin with sbb.

The new master object is now available for your use.

Creating and placing a SmartB2BObject instance

Creating a SmartB2BObject instance is much like creating an instance of any other SmartObject.

To add a SmartB2BObject instance to your organizer workspace:

1. Click the SmartB2BObject tool icon in the Object Palette. When the Choose dialog box opens, select the appropriate master and click OK.

   Note: To select the dynamic object, right-click the tool icon instead. The dynamic object is listed last in the menu that appears.

2. The SmartB2BObject has no run-time representation, so you can position it anywhere in the workspace. For your future convenience, consider selecting a spot that will otherwise remain empty. When you have selected a spot, click to release. The design-time representation appears:

3. AppBuilder opens an Advisor window if it finds opportunities to create SmartLinks to other objects. Accept the Advisor’s recommendations, if they seem appropriate.

4. Configure the instance. Save your work.

Configuring a SmartB2BObject instance

If you have already created the map file, configuring a SmartB2BObject instance is straightforward. To begin the configuration process, right-click the instance and choose Properties from the context menu. The Property Sheet dialog box appears:
To configure an instance

1. Change the object identifier to more clearly reveal the role of this object in your application.

2. If you wish to use this object as a placeholder, set the Parameterize as Variable check box. For information about using instances as placeholders, see the “Creating a SmartObject placeholder” section on page 374.

3. Click OK and save your work.

You are now ready to configure the instance properties. The SmartB2BObject’s instance properties vary depending on whether the object will process incoming or outgoing documents. In either case, begin by clicking the menu button and choosing Instance Properties from the menu that opens.

Outgoing instance properties

If you have already linked this object to a SmartProducer, the dialog box should open with the Producer tab selected, as shown:

To configure outgoing properties:

1. At a minimum, configure the following fields to use XML:
Chapter 6: Data-Communication Objects

- **XML Mapping File** — Type in the path to the file that this object will use when transforming documents.

- **Destination** — The logical identifier of the outbound document's destination. At present this must be a queue or topic served by the Progress SonicMQ system.

If you prefer to use a DTD (Document Type Definition) file, set the **Use DTD** toggle. This will enable the **Public ID** and **System ID** fields for you to specify:

- **Public Id (DTD)** — (Optional) Enter the global public identifier of the DTD document.

- **System Id (DTD)** — (Mandatory) Enter the path to the actual DTD file. Click the Browse button if you wish to search for the file.

2. Examine the following fields and change those that do not meet your needs:

- **Reply Required** — Defaults to cleared. Setting this check box will notify recipients that you wish a reply sent to you whenever they receive a document of this type. You must add code to handle these replies.

- **Reply Selector** — If you wish to filter incoming replies according to values in reply-header fields or properties, enter the expression here. The SmartProducer object will perform the test on incoming replies and discard from the inbound **Queue/Topic** any messages that fail the test. Example: `company_name = "Smith" AND priority > 4`. A reply from the Smith company with priority of 4 or less would be discarded without notice. The syntax is a subset of the syntax defined in SQL-92.

3. If this SmartB2BObject will create different documents from the same data stream, or send to different real-world or JMS destinations, click **Multiple Producers**. Additional fields come into view, as shown:
4. For each document type/destination pair, fill in the fields identified in Step 1 and Step 2.

5. To specify where to find the name reference at run time, set the **Document Name Data** check box. Three additional fields activate themselves. Change their values as appropriate:
   - **Data Object** — Select the SmartDataObject or other data-handling object that handles the data for the new document type.
   - **Column, Function** — Defaults to Column. Selecting Function means that the **Document/Direction Name** value is returned by a function in the data object rather than by one of its columns.
   - **Column/Function** — The label on this fill-in reflects the current radio-button selection. Select the column or function in the data object that will return the **Document/Direction Name**.

6. Click **Save** to add the new document information to the list in the browser widget.

   **Note:** If you decide not to add this entry, click **Cancel** instead of **Save**. If you decide you made a mistake in saving an entry, click **Delete**.

7. To add an additional entry, click **Add** and repeat Step 4 through Step 6.

8. When you have added all the document types/destinations you desire, save your work.

**Incoming instance properties**

If you have already linked this object to a SmartConsumer, the dialog box should open with the **Consumer** tab selected. If not, select it now:
To configure this object for consuming:

1. Identify the mapping file.
2. Save your work.
SmartSender and SmartReceiver objects

The SmartB2BObject is designed to transform the representation of data between the internal ABL format and industry-standard XML. But what if you need no such transformation? What if you only want to send, for example, some unstructured block of ordinary text?

You can use the SmartSender (or, on the inbound side, the SmartReceiver) in place of the SmartB2BObject if you do not need the SmartB2BObject’s special capabilities. The capabilities of the SmartSender and SmartReceiver are whatever you choose to make them. Figure 41 illustrates where the objects fit in with other SmartObjects.

Figure 41: The SmartSender and SmartReceiver in B2B communication

The SmartSender and SmartReceiver objects are supplied for your use as templates with stubbed handler routines. After writing ABL procedures to complete the handler stubs, you can connect these objects to the Smart message-interface objects in exactly the same way you would connect a SmartB2BObject. The SmartSender will then perform any transformation you have included in the handler routines, package the content, and call the SmartProducer to send it off.

Similarly, the SmartReceiver will accept an inbound message from the SmartConsumer, perform the handling process you define, and pass the result on to some other SmartObject for storage or further handling.
Because you provide the handling logic, you can make these objects as simple or complex in their behavior as you desire.

You could handle plain, unformatted text by making your handler routines mere pass-throughs, their only function being to copy the unaltered text into or out of the message body. Or, you could implement special encryption/decryption procedures, graphics reformatting, or even your own special-purpose XML logic. You can implement any handling you like.

What you do with a SmartSender/SmartReceiver is entirely up to you.

**Creating and completing a SmartSender master**

Use the **Object Palette** to place a SmartSender object.

To create a new SmartSender master:

1. Click the **SmartSender** tool icon on the **Object Palette**:

2. When the **Choose** dialog box appears, click **New**. After a moment, a new SmartSender object appears:

3. Open the **Section Editor** and add handler code to complete the **sendHandler** and **receiveReplyHandler** procedures. Use calls from the ABL-JMS API.

   The **sendHander** procedure deals with your outbound messages. Use it to set properties and create message bodies. See the “Example of sendHandler code” section on page 314.

   The **receiveReplyHandler** procedure deals with incoming replies. Use it to extract properties and evaluate message bodies. See the “Example of sendReplyHandler override code” section on page 314.

4. Save the completed master using a descriptive filename. Note that SmartSender filenames conventionally begin with **sms**.

Creating a SmartReceiver master involves comparable steps, though the names of the handler routines are **receiveHandler** and **sendReplyHandler**, respectively. See the “Example of receiveHandler code” section on page 317 and the “Example of sendReplyHandler code” section on page 319.
Placing and configuring a SmartSender instance

Once you have created a master object, placing an instance is a straightforward process.

To place an instance:

1. Click the **SmartSender** tool icon on the **Object Palette**:

2. When the **Choose** dialog box opens, select the master object and click **OK**. Move your mouse cursor over your workspace and click to release the object.

3. Save your work.

You are now ready to configure the instance.

To configure the instance:

1. Right-click the instance and choose **Properties** from the context menu. When the standard **SmartObject Property Sheet** opens, change the **Object identifier** (the instance handle) to more clearly reflect the role of this object in your application.

2. If you wish to use this instance as a placeholder, set the **Parameterize as Variable** check box. For information about placeholders, see the “Creating a SmartObject placeholder” section on page 374 and *OpenEdge Development: ADM and SmartObjects*.

3. Click **OK** to close the **Property Sheet**. Right-click the instance and choose **Instance Properties** from the context menu. The **SmartSender Instance Properties** dialog box appears:
4. Set the **Destination** property to the identifier or the SonicMQ Topic (Publish-and-Subscribe) or **Queue** (Point-to-Point) to which your message is to be sent.

You can choose to set two other properties, if you wish:

- **Reply Required** — Defaults to cleared. Setting this check box notifies the recipient that you wish a reply to your message. Your `receiveReplyHandler` routine must deal with any such reply.

- **Reply Selector** — If you wish to filter incoming replies according to values in reply-header fields or properties, enter the expression here. The SmartConsumer object will perform the test on incoming replies and discard from the inbound queue/topic any messages that fail the test. Example: `company_name = "ABC" AND priority >= 4`. Any reply received from company ABC with a priority of 3 or less will be discarded without notice. The syntax is a subset of the syntax defined in SQL-92.

5. Click **OK** to close the dialog box. Save your work.

Placing and configuring a SmartReceiver instance involves comparable steps. The major difference is that the SmartReceiver has no **Instance Properties** dialog box.
The SmartRouter object is designed to distribute incoming documents to the appropriate SmartB2BObject for transformation. It is only required in applications that can handle more than one document type. Figure 42 illustrates where the SmartRouter fits into the document-handling process.

Figure 42: SmartRouter distributing incoming documents
Handling multiple document types

You can create a complete message-handling system using very few SmartObjects, if your needs are uncomplicated. Figure 43 gives a schematic view of such a system.

![Figure 43: Basic message-handling blocks](image)

The business object would typically be a SmartDataObject or SmartBusinessObject. The SmartB2BObjects could also be a SmartSender/SmartReceiver pair. Regardless, the basic layout is very straightforward when all inbound or outbound messages are handled alike.

In some business situations, however, you might have to handle several different incoming logical-document types—in Figure 44, purchase order, sales enquiry, and customer support form—all packaged identically as XML messages. Since at present each document type is handled by a dedicated SmartB2BObject instance, you would need a way to route them appropriately.

The SmartRouter object provides exactly that service.
**Figure 44** illustrates how the SmartRouter relates to the SmartConsumer and SmartB2B objects.

When a new message comes in, the SmartRouter determines which SmartB2BObject should do the transformation and starts that container, if necessary. It then identifies the SmartB2BObject to the SmartConsumer and hands off the message file to the SmartB2BObject. After that, it has nothing more to do with that message. The SmartConsumer and SmartB2BObject communicate directly from that point onward, as they do when a SmartRouter is not involved.

**Callable document-handlers**

The major difference between using and not using a SmartRouter is in the packaging. As **Figure 44** illustrates, the SmartB2BObject/SmartDataObject pairs that handle a particular document type are packaged separately. Similarly, a SmartRouter and SmartConsumer can be packaged together, if desired.

The package used in each case is the simple SmartContainer.

The simple SmartContainer is a specialized organizer object. It has no run-time representation. You would typically use it only when creating packages such as those illustrated in **Figure 44**. Being able to package components without a user interface is particularly useful when your message-consuming process is to run in batch mode, without human intervention.
Creating a document-handling package

Creating a unit to handle inbound documents is a straightforward process.

To create a unit to handle inbound documents:

1. Create a SmartB2BObject—the SmartRouter cannot communicate with a SmartReceiver—to transform the object. See the “SmartB2BObjects” section on page 274 for details. Save the object.

2. Create a data handler—a SmartDataObject or SmartBusinessObject—to process the transformed document. See OpenEdge Development: ADM Reference for information about the SmartDataObject, or the “SmartBusinessObject” section on page 172 for details about that object. Save the object.

3. Choose File→New and select the simple SmartContainer. A workspace of that type appears:

4. Place and configure the transformer and data handler objects that you created. No advisor will appear to offer to create SmartLinks between these objects: they do not communicate using the SmartLink mechanism.

5. Save your work. Repeat this process until you have created a handler for each incoming document type.

Creating a document-routing package

If your customer’s business practices allow, you can create a system that processes incoming documents in batch mode, without human intervention.

To do this, you would create separate containers to perform the document routing and the document handling. At run time, you start the routing package in batch mode and allow it to call the document-handling packages as documents arrive for processing. For information about creating document-handling packages, see the “Creating a document-handling package” section on page 300.

This example assumes that you will use the invisible simple SmartContainer as the organizer. If you require a user interface, use the SmartWindow instead.

To create a document-routing package:

1. Choose File→New and select the simple SmartContainer. A workspace of that type appears:
2. Place a SmartConsumer object and configure it to monitor the appropriate inbound queue or topic. See the “Creating and placing a SmartConsumer instance” section on page 307 and the “Configuring a SmartConsumer instance” section on page 308 for details.

3. Click the SmartRouter tool icon:

4. Place the instance in the workspace. An Advisor will appear and offer to create a SmartLink of type ROUTER from the SmartConsumer. Accept the offer.

5. Right-click the instance and choose Instance Properties from the context menu. The SmartRouter Properties dialog box appears:

6. Click the Add button. This makes the External Reference field editable. Enter the URL of the schema file for some document type this router link must recognize. Note that the filename of the schema must be the same locally as it appears in the URL, though the paths to them will probably be very different.

7. Click the corresponding Internal Reference field to activate it. Enter the PROPATH-relative path to the corresponding map file. Thus, if the full path is d:\abc\def\mapfile.xmc and PROPATH contains d:\abc, you should enter def\mapfile.xmc here.

8. If you are satisfied with this entry, click the Save button to write the entry out to disk. Otherwise, click Reset to clear the fields, or Cancel to clear the fields and leave edit mode.
9. Repeat Step 6 through Step 8 until you have created entries for each document type this Router instance must recognize. Click OK to close this dialog box. Now, when run, this Router will be able to recognize and appropriately distribute those document types.

10. Save the package using a distinctive filename. Note that filenames for simple SmartContainers conventionally begin with c.
SmartProducers and SmartConsumers

Progress Software provides you with two message-handling objects—the SmartProducer and SmartConsumer. The SmartProducer sends messages and the SmartConsumer receives them. With them, your ADM-compliant application can use the reliable Progress SonicMQ message service for communication within and between businesses. Figure 45 illustrates the place of the SmartProducer and SmartConsumer objects in the message-handling process.

Figure 45: The Smart Message-interface objects

SonicMQ is Progress Software Corporation’s implementation of the industry-standard Java Message Service (JMS). The SmartProducer and SmartConsumer communicate with the SonicMQ broker through the ABL-JMS API.
Creating and placing a SmartProducer instance

The SmartProducer is supplied as a precompiled master. Creating and placing an instance is a straightforward process.

To create and place an instance in the SmartProducer:

1. Click SmartProducer in the Object Palette.

2. Position the mouse cursor over an empty spot in your workspace and click to place the object. If you have one or more SmartB2BObjects or SmartSenders in place, AppBuilder opens an Advisor dialog box and offers to create \texttt{OUTMESSAGE} SmartLinks. Examine the offers and accept those that are appropriate.

3. Right-click the instance and choose Properties from the context menu. The Property Sheet dialog box appears:

4. Change the Object identifier (instance handle) to one that more accurately describes the role of this SmartProducer in your application.

5. Configure the instance. Save your work.
Configuring a SmartProducer instance

There are only a limited number of instance properties you need to configure.

To configure instance properties in the SmartProducer:

1. Begin by clicking the instance’s menu button and choosing Instance Properties. The SmartProducer Properties dialog box appears:

2. Change the default values that do not meet your needs:

   - **Domain** — Defaults to Publish-and-Subscribe. Setting this value to Point-to-Point creates a single copy of the message. Although a number of entities might have access to the message, the first entity to read it removes it from the queue. With the Publish-and-Subscribe mechanism, a single copy of the message can be read by all subscribing entities. This allows implementation of a form of multicasting.

      You cannot modify the Domain value at run time.

   - **JMS Partition** — Select a JMS Partition from the dropdown list. If there are no JMS Partitions listed, you can define as many as you like using the Service Parameter Maintenance Tool, available on the PRO*Tools toolbar. For information about how to use that tool, see the online help.

   - **JMS User** — Set this field to identify the user of the JMS Broker connection.

   - **JMS Password** — Set this field to be the password that corresponds to the JMS user identifier.

   - **JMS Client ID** — Set this field to a value unique to this client. This field is used to resolve ambiguities in cases where multiple clients might be using the same subscription and user names.

      **Note:** If you do not know the User, Password, and Client ID values at design time, you can check the Prompt-for-JMS-Login box and the values will be collected at run time.

   - **Ping Interval** — Defaults to 0 (pinging off). Setting this field to some integer value (representing seconds) causes the connection to the SonicMQ broker
to be tested at that rate for the duration of the JMS session. It is good practice not to ping frequently, since pinging decreases overall system performance.

- **Prompt for JMS Login** — Defaults to cleared. Setting this check box causes the messaging object to prompt the user for login.

- **Priority** — Defaults to 4. The value is read whenever a new message is sent. It establishes the priority for that message in the range 0 (lowest) to 9 (highest). You can modify the value at run time under program control.

- **Time to Live** — Defaults to 0 (no expiration). This field is evaluated for every new message. It establishes the length of time in milliseconds that the message can remain unread before being discarded as stale. You can modify the value at run time under program control.

- **Persistency** — Defaults to **PERSISTENT** (message retained in the broker’s database). Other values supported are:
  - **NON_PERSISTENT** (message not retained)
  - **NON_PERSISTENT_ASYNC**
  - **UNKNOWN**

- **Message Type** — Defaults to **TextMessage**. Other types supported are:
  - **BytesMessage** — A stream of raw (uninterpreted) bytes. This is the default type when connecting to a SmartB2BObject; most other types require extra code.
  - **HeaderMessage** — Known simply as type Message within the SonicMQ system. Use for shutdown messages.
  - **XMLMessage** — A string representing an XML tree that can be parsed as a document. **Do not use this type** when connected to a SmartB2BObject.
  - **MapMessage** — A set of name/value pairs, where names are of type string and values are Java primitives. You can read the entries in sequence or randomly by reference to the name.
  - **StreamMessage** — A stream of Java primitives, read sequentially.
Creating and placing a SmartConsumer instance

The SmartConsumer is supplied as a precompiled master. Creating and placing an instance is a straightforward process.

To create and place an instance with the SmartConsumer:

1. Click **SmartConsumer** in the **Object Palette**.

2. Position your mouse cursor over an empty spot in your workspace and click to place the object. If you have a SmartRouter in place, AppBuilder opens an **Advisor** dialog box and offers to create a **ROUTER** SmartLink. If, instead, you have a SmartB2BObject or SmartReceiver in place, the **Advisor** will offer to create an **INMESSAGE** link. In either case, accept the offer unless it seems inappropriate.

3. Right-click the instance and choose **Properties** from the context menu. The **Property Sheet** dialog box appears:

4. Change the instance handle to one that more accurately describes the role of this SmartConsumer in your application.

5. Configure the instance. Save your work.
Configuring a SmartConsumer instance

There are only a limited number of instance properties you need configure.

To configure the limited number of instance properties with SmartConsumer:

1. Begin by clicking the instance’s menu button and choosing Instance Properties. The SmartConsumer’s instance properties dialog box appears:

2. Change the following default values that do not meet your needs:

   - **Domain** — Defaults to Publish and Subscribe. Setting this value to Point-to-Point creates a single copy of the message. Although a number of entities might have access to the message, the first one that reads the message deletes it from the pipeline. With the Publish-and-Subscribe mechanism, all subscribing entities can read the message. This allows implementation of a form of multicasting.

   The Domain value is not modifiable at run time.

   - **JMS Partition** — Select a Partition from those listed. If there are no JMS Partitions listed, you can define as many as you like using the Service Parameter Maintenance Tool available on the PRO*Tools toolbar. For information about how to use that tool, see the online help.

   - **Ping Interval** — Defaults to 0 (pinging off). Setting this field to some integer value in seconds causes the connection to the SonicMQ broker to be tested at that rate for the duration of the JMS session. It is good practice not to ping frequently, since pinging decreases system performance.
SmartProducers and SmartConsumers

- **Log File** — Defaults to empty. Set this field to the pathname of the error-log file that will be used when running in batch mode.

- **Shutdown** — Defaults to empty. Set this field to the identifier for the Topic (Publish-and-Subscribe) or Queue (Point-to-Point) to be used for shutting down this SmartConsumer instance when running in batch mode. Sending any message to this destination causes this SmartConsumer object to begin the shutdown process.

- **JMS User** — Set this field to identify the user of the JMS Broker connection.

- **JMS Password** — Set this field to be the password that corresponds to the JMS User identifier.

- **JMS Client ID** — Set this field to a value unique to this client. This field is used to resolve ambiguities in cases where multiple clients might be using the same subscription and user names.

---

**Note:** You can supply the User, Password, and Client ID values at design time if you know them. Otherwise, check the Prompt-for-JMS-Login box and the object will prompt the user for them at run time.

- **Prompt for JMS Login** — Defaults to cleared. Setting this check box causes the object to prompt the user for login.

- **Destination** — Set this field to create/update an identifier for the destination Topic/Queue.

- **Message Selector** — If you wish to filter incoming messages according to values in header fields or properties, enter the expression here. The SmartConsumer object will perform the test on incoming messages and discard from the inbound queue/topic any messages that fail the test. **Example:** `company_name = "ABC" AND priority < 4`. Any message received from company ABC with a priority of 3 or less will be discarded without notice. The syntax is a subset of the syntax defined in SQL-92.

- **Durable Subscription** — Defaults to cleared. Enabled only when Domain is Publish-and-Subscribe. Set this check box to preserve the current subscription across JMS sessions.

- **Subscription Name** — Enabled only for Durable Subscriptions. Set this field to create/update a subscription name.

- **Unsubscribe on Session Close** — Defaults to cleared. Enabled only for Durable Subscriptions. Setting this check box causes the selected subscription to be cancelled when the JMS session ends.
Batch mode: starting and stopping a SmartConsumer

Three properties are generally required before running SmartConsumer object in batch mode, if SonicMQ security checking is turned on. They are JMSUser, JMSPassword, and ClientID. Strictly speaking, ClientID is not required except when needed to distinguish between sessions using the same user identifier and password.

At present, you can set those properties in the instance properties dialog box or from the command line using the `-param` startup parameter, as shown:

```
prowin32 -b -p containerfilename -param "jmsuser,jmspassword,clientId" .
```

In the example shown, `containerfilename` would be the filename of a simple SmartContainer that contains a SmartConsumer object and a SmartRouter object. The values you pass in the parameter string override any values set at design time using the Instance Properties dialog box.

Stopping a SmartConsumer

The most orderly way to shut down a SmartConsumer object running in batch mode is to send a message to the designated shutdown topic or queue. You identify that topic or queue at design time in the Shutdown property.

The shutdown message needs no body; its receipt by the shutdown Queue or Topic is sufficient.

When the SmartConsumer detects reception of a message in that Queue/Topic, it sends a shutdown message to its container object. Shutting down the container object shuts down all objects in the container (including the SmartConsumer itself) as well as any containers that were started by the SmartRouter to which the SmartConsumer is connected.

To set up and test a shutdown mechanism:

1. Create a simple SmartContainer.
2. Create and place a SmartProducer in the SmartContainer. Set Message Type to HeaderMessage and configure other properties appropriately.
3. Create and place a SmartSender in the SmartContainer. If an Advisor offers to create an OUTMESSAGE link to the SmartProducer, accept the offer; otherwise, create the link using the SmartLinks editor. Set the Destination property to be the shutdown destination for the consumer, for example “Shutdown”. Any message this SmartProducer sends will then be a shutdown message.
4. Open a **Section Editor** window and create a local override procedure called `initializeObject`. Insert the following `RUN` statement as the procedure body:

```
RUN sendMessage IN THIS-PROCEDURE.
```

5. Save your work using a distinctive filename, for example `stopconsumer`. To test this shutdown mechanism, enter this statement on the command line:

```
prowin32 -b -p stopconsumer.w
```
The message-handling relationship: internal details

The process for handling a message is very much the same regardless of whether the message is coming in or going out.

Outbound message and reply-handling process

Sending a message requires cooperation between the SmartProducer and an object serving as the OUTMESSAGE-SOURCE (OMS). Generally you would use either a SmartB2BOBJECT or a SmartSender as OMS. Figure 46 illustrates the process.

![Diagram of outbound message-handling process]

**Figure 46: Outbound message-handling process**

The following steps describe the process shown in Figure 46.

1. When a message is to be sent, the OMS calls sendMessage in the SmartProducer.

2. The sendMessage() routine in the SmartProducer creates an empty message. It then calls sendHandler() in the OMS, passing the handle of the message it created.

3. The sendHandler() routine in the OMS sets the message header properties, adds a body to the message, and returns.

4. The sendMessage() routine in the SmartProducer now has a complete message to send and calls the relevant routines in the ABL-JMS API to start the message on its way.

5. When a reply comes in, replyHandler() in the SmartProducer calls replyHandler() in the OMS, passing it the handle of the reply.
6. The `replyHandler()` routine in the OMS gets the ID of the original message and the reply properties and body. It performs any desired processing on that information and returns.

**Inbound message-handling and reply process**

Receiving a message requires cooperation between the SmartConsumer and an object serving as the INMESSAGE-TARGET (IMT). Generally you would use either a SmartB2BObject or a SmartReceiver as IMT. Figure 47 illustrates this process.

<table>
<thead>
<tr>
<th>SmartConsumer</th>
<th>InMessage target</th>
</tr>
</thead>
<tbody>
<tr>
<td>messageHandler ()</td>
<td>receiveHandler ()</td>
</tr>
<tr>
<td>RUN receiveHandler (hMsg)</td>
<td>Get properties, body</td>
</tr>
<tr>
<td>If reply required then</td>
<td>Process message</td>
</tr>
<tr>
<td>Create empty reply</td>
<td>Return</td>
</tr>
<tr>
<td>RUN sendReplyHandler (hReply)</td>
<td>sendReplyHandler ()</td>
</tr>
<tr>
<td>Send reply message</td>
<td>Set properties, body</td>
</tr>
<tr>
<td></td>
<td>Return</td>
</tr>
</tbody>
</table>

**Figure 47: Inbound message-handling process**

If you use a SmartRouter to distribute incoming messages, the SmartRouter acts as an IMT proxy, accepting calls from the SmartConsumer and passing them on transparently to the real IMT. The brief description below ignores the role of the SmartRouter:

1. When a message is received, the `messageHandler()` routine in the SmartConsumer calls the `receiveHandler()` routine in the IMT, passing the handle of the received message.

2. The `receiveHandler()` routine in the IMT extracts header properties and the message body, performs any desired processing, and returns.

3. If the message requires a reply, the `messageHandler()` routine in the SmartConsumer creates an empty reply message and calls `sendReplyHandler()` in the IMT, passing the handle of the reply it created.

4. The `sendReplyHandler()` routine in the IMT sets the header properties, adds a body, and returns.

5. The `messageHandler()` routine in the SmartConsumer now has a complete reply message to send and calls the relevant routines in the ABL-JMS API to start it on its way.
Example of sendHandler code

The following code might be used to create a large text message in a SmartSender:

```verbatim
/* Declare a handle for the message */
DEFINE INPUT PARAMETER hMessage AS HANDLE NO-UNDO.

/* Set the message properties */
DYNAMIC-FUNCTION('setBooleanProperty':U IN hMessage,
    INPUT 'backordered':U, INPUT TRUE).
DYNAMIC-FUNCTION('setDoubleProperty':U IN hMessage,
    INPUT 'minorderamount':U, INPUT 1500.00).

/* Append text blocks from tables to create message body */
FOR EACH table:
    DYNAMIC-FUNCTION('appendText':U IN hMessage, table.datafield).
END.
```

Example of sendHandler override code

The following code might be used in a sendHandler() override in a SmartB2BObject:

```verbatim
DEFINE INPUT PARAMETER hMessage AS HANDLE NO-UNDO.

/* Set custom message properties (example only) */
DYNAMIC-FUNCTION('setProperty':U IN hMessage,
    INPUT 'city':U, INPUT cCity).

/* Run the SmartB2BObject's version of sendHandler to assign the body of the message. */
RUN SUPER.
```

Example of receiveReplyHandler code

Any object that acts as an OUTMESSAGE-SOURCE to a SmartProducer must include a receiveReplyHandler() procedure. That procedure handles replies from message recipients. It might perform some or all of these functions:

- Identify the original message.
- Extract any important properties from the reply.
- Identify the reply type and obtain the reply body in an appropriate format.
Example 1 shows code that performs those functions for some OUTMESSAGE-SOURCE object other than a SmartB2BObject, for example a SmartSender.

Example 1: receiveReplyHandler code

```plaintext
DEFINE INPUT PARAMETER hReply AS HANDLE NO-UNDO.
/* Declare storage for obtaining the properties */
DEFINE VARIABLE cCharProp AS CHARACTER NO-UNDO.
DEFINE VARIABLE cOriginalMsgID AS CHARACTER NO-UNDO.
DEFINE VARIABLE cProperty AS CHARACTER NO-UNDO.
DEFINE VARIABLE cPropertyNames AS CHARACTER NO-UNDO.
DEFINE VARIABLE cPropType AS CHARACTER NO-UNDO.
DEFINE VARIABLE cReplyType AS CHARACTER NO-UNDO.
DEFINE VARIABLE fDecProp AS DECIMAL NO-UNDO.
DEFINE VARIABLE iIntProp AS INTEGER NO-UNDO.
DEFINE VARIABLE iThisProp AS INTEGER NO-UNDO.
DEFINE VARIABLE lLogicProp AS LOGICAL NO-UNDO.
DEFINE VARIABLE mReplyBody AS MEMPTR NO-UNDO.

/* Identify the original message using the reply handle, get property names */
cOriginalMsgID = DYNAMIC-FUNCTION('getJMSCorrelationID':U IN hReply).
cPropertyNames = DYNAMIC-FUNCTION('getPropertyNames':U IN hReply).

/* Loop through all properties, extracting their values according to type */
DO iThisProp = 1 TO NUM-ENTRIES(cPropertyNames):
  ASSIGN
    cProperty = ENTRY(iThisProp, cPropertyNames)
    cPropType = DYNAMIC-FUNCTION('getPropertyType':U IN hReply, 
      INPUT cProperty).
  CASE cPropType:
    WHEN 'String':U THEN DO:
      cCharProp = DYNAMIC-FUNCTION('getCharProperty':U IN hReply, 
        INPUT cProperty).
      /* Insert code here to process this character property */
    END.
    WHEN 'Boolean':U THEN DO:
      lLogicProp = DYNAMIC-FUNCTION('getLogicalProperty':U IN hReply, 
        INPUT cProperty).
      /* Insert code here to process this logical property */
    END.
```
WHEN 'Byte':U OR WHEN 'Short' OR WHEN 'Int' THEN DO:
iIntProp = DYNAMIC-FUNCTION('getIntProperty':U IN hReply,
INPUT cProperty).
/* Insert code here to process this integer property */
END.
WHEN 'Long':U OR WHEN 'Float' OR WHEN 'Double' THEN DO:
fDecProp = DYNAMIC-FUNCTION('getDecProperty':U IN hReply,
INPUT cProperty).
/* Insert code here to process this decimal property */
END.
END CASE. /* cPropType */
END. /* DO iThisProp */
/* Identify the reply type */
cReplyType = DYNAMIC-FUNCTION('getMessageType':U IN hReply).
/* Extract the reply body in the appropriate format. */
CASE cReplyType:
WHEN 'BytesMessage':U THEN
mReplyBody = DYNAMIC-FUNCTION('getMemptr':U IN hReply).
WHEN 'TextMessage':U OR WHEN 'XMLMessage':U THEN DO:
DO WHILE (DYNAMIC-FUNCTION('endOfStream':U IN hReply) = FALSE:
cReplyBody = DYNAMIC-FUNCTION('getTextSegment':U IN hReply).
END. /* DO WHILE */
END. /* WHEN textmessage */
END CASE. /* cReplyType */
Example of receiveHandler code

Example 2 shows code that might be used in an INMESSAGE-TARGET object other than a SmartB2BObject, for example a SmartReceiver. Note the similarities to the receiveReplyHandler code:

Example 2: receiveHandler code

```plaintext
DEFINE INPUT PARAMETER hMessage AS HANDLE NO-UNDO.
/* Declare storage */
DEFINE VARIABLE cCharProp AS CHARACTER NO-UNDO.
DEFINE VARIABLE cMessageID AS CHARACTER NO-UNDO.
DEFINE VARIABLE cMessageType AS CHARACTER NO-UNDO.
DEFINE VARIABLE cProperty AS CHARACTER NO-UNDO.
DEFINE VARIABLE cPropertyNames AS CHARACTER NO-UNDO.
DEFINE VARIABLE cPropType AS CHARACTER NO-UNDO.
DEFINE VARIABLE fDecProp AS DECIMAL NO-UNDO.
DEFINE VARIABLE iIntProp AS INTEGER NO-UNDO.
DEFINE VARIABLE iThisProp AS INTEGER NO-UNDO.
DEFINE VARIABLE lLogicProp AS LOGICAL NO-UNDO.
DEFINE VARIABLE mMessageBody AS MEMPTR NO-UNDO.

/* Loop through all properties, identifying types and extracting values appropriately. */
cPropertyNames = DYNAMIC-FUNCTION('getPropertyNames':U IN hMessage).

DO iThisProp = 1 TO NUM-ENTRIES(cPropertyNames):
   ASSIGN
      cProperty = ENTRY(iThisProp, cPropertyNames)
      cPropType = DYNAMIC-FUNCTION('getPropertyType':U IN hMessage,
                                   INPUT cProperty).
   CASE cPropType:
      WHEN 'String':U THEN DO:
         cCharProp = DYNAMIC-FUNCTION('getCharProperty':U IN hMessage,
                                       INPUT cProperty).
         /* Insert code for processing a string property */
         END.
      WHEN 'Boolean':U THEN DO:
         lLogicProp = DYNAMIC-FUNCTION('getLogicalProperty':U IN hMessage,
                                        INPUT cProperty).
         /* Insert code for processing a logical property */
         END.
      WHEN 'Byte':U OR WHEN 'Short':U OR WHEN 'Int':U THEN DO:
         iIntProp = DYNAMIC-FUNCTION('getIntProperty':U IN hMessage,
                                      INPUT cProperty).
         /* Insert code for processing an integer property */
         END.
   END.
```

(1 of 2)
Example of receiveHandler override code

The following code might be used in a receiveHandler override in a SmartB2BObject:

```
DEFINE INPUT PARAMETER hMessage AS HANDLE NO-UNDO.
/* Declare storage */
DEFINE VARIABLE lBackOrdered AS LOGICAL NO-UNDO.
/* Get a specific property value */
lBackOrdered = DYNAMIC-FUNCTION('getCharProperty':U IN hMessage).
RUN SUPER.
```
Example of sendReplyHandler code

The following code might be used in the sendReplyHandler procedure of some INMESSAGE-TARGET object other than a SmartB2BObject, for example a SmartReceiver:

```plaintext
DEFINE INPUT PARAMETER hReplyMessage AS HANDLE NO-UNDO.
/* Set message properties */
DYNAMIC-FUNCTION('setBooleanProperty':U IN hMessage,
   INPUT 'backordered':U, INPUT TRUE).
DYNAMIC-FUNCTION('setDoubleProperty':U IN hMessage,
   INPUT 'minorderamount':U, INPUT 1500.00).
/* Assign the message body */
RUN setMemptr IN hReplyMessage
   (INPUT mMessage, INPUT 1, INPUT 200).
```

Example of sendReplyHandler override code

The following code might be used in a SmartB2BObject’s sendReplyHandler override:

```plaintext
DEFINE INPUT PARAMETER hReplyMessage AS HANDLE NO-UNDO.
/* Set custom message properties */
DYNAMIC-FUNCTION('setStringProperty':U IN hMessage,
   INPUT 'city':U, INPUT cCity).
/* Run the SmartB2BObject’s version of sendReplyHandler to assign the body of the message. */
RUN SUPER.
```
Control Objects

Menus, toolbars, buttons, and similar objects serve as the controls and control panels of an application. They allow the user to navigate through databases, shift between functional layouts, set values for fields, and choose when and whether to make changes to database records.

This chapter covers the following:

- Introduction to control objects
- SmartToolbars
- SmartPanels
- Basic buttons
Introduction to control objects

Nearly every nontrivial application offers many ways to control its behavior and, perhaps, appearance. Because of the way human memory works, grouping these controls according to their function is a standard way to improve their ease of use. You will probably have experienced this principle yourself.

Menu bars, typically with pull-down menus attached, were originally the only means provided for gaining access to an application’s functions. Toolbars were developed as a type of supplemental menu bar for frequently used features. They gradually became standard after graphics editors and similar applications popularized the button as an action and tool interface.

As part of the ADM toolset, AppBuilder offers several control clusters that embody Smart technology and are able to control other SmartObjects:

- SmartToolbar
- SmartPanels for:
  - Navigation
  - Saves and updates
  - Commits

AppBuilder also offers the basic ABL button. You can use it to build your own control groups, if you choose.
SmartToolbars

The SmartToolbar object optionally combines a standard menu bar with a full-width toolbar, and provides access to database navigation and record-management functions. You can use a SmartToolbar in place of the standard menu bar in a SmartWindow, if you wish. The SmartToolbar offers the same functions that the larger, separate Navigation and Update SmartPanel button arrays provide between them.

The SmartToolbar has some limitations:

- You can only use the full SmartToolbar in a SmartWindow or SmartFrame. If you place one in a SmartDialog, only the toolbar component will activate, since a dialog cannot have a menu bar even as part of a SmartObject.
- You can use only one SmartToolbar per organizer instance. If you need additional controls, you must create and group them by hand.
- The width of a SmartToolbar does not automatically change to agree with changes in the organizer object. You must change the width under program control, or manually.
- If you use the menu component, you cannot use the standard menu editor to populate it. You must write code to add any additional menu items that you desire.

Placing a SmartToolbar

AppBuilder supplies a single version of the SmartToolbar. If you do not need to add additional functions, using it in your application is very straightforward.

To use the SmartToolbar:

1. Click SmartToolbar in the Object Palette.
2. Move the mouse cursor over a bare spot in your workspace and click to place the object. A menu bar and its corresponding toolbar have a well-defined position in a window, so you need not be careful where you place it—it establishes itself in the right place automatically, in some cases even moving other objects out of the way.
3. Configure it, and adjust its size appropriately.
Figure 48, Figure 49, and Figure 50 show the SmartToolbar in different states with both components and all supplied functions enabled. The Filter button appears insensitive because there was nothing connected to it at the time these images were taken.

Figure 48: SmartToolbar fully enabled

Figure 49: SmartToolbar in record-changed state

Figure 50: SmartToolbar in transaction-pending state

Configuring a SmartToolbar instance

A default SmartToolbar has a few properties you can change without writing code. To open the Properties dialog box, select Instance Properties from the menu-button menu. The SmartToolbar Properties dialog box appears:
Table 11 describes the use of each group of property settings.

**Table 11: SmartToolbar properties**

<table>
<thead>
<tr>
<th>Section</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Deactivation of link to hidden targets.</td>
<td>This is used for performance tuning when you have a tab folder whose pages are not all linked to the toolbar. Select the <strong>Immediately on hide of target</strong> option when you have a mix of linked and unlinked tabs in a tab folder.</td>
</tr>
<tr>
<td>Use toolbar.</td>
<td>Controls if and how the toolbar portion of the toolbar visualizes.</td>
</tr>
<tr>
<td>Use menu.</td>
<td>Controls if and how the menu portion of the toolbar visualizes.</td>
</tr>
<tr>
<td>Categories.</td>
<td>Controls which bands of actions are active on the toolbar.</td>
</tr>
<tr>
<td>Actions.</td>
<td>Controls which individual actions in a given category are available.</td>
</tr>
</tbody>
</table>

Table 12 describes the settings in the Categories section of the property sheet.

**Table 12: SmartToolbar Categories options**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Navigation</td>
<td>When checked, the navigation actions are available.</td>
</tr>
<tr>
<td>Tableio</td>
<td>When checked, table I/O actions appropriate to the selected options are available.</td>
</tr>
<tr>
<td>Save/Update</td>
<td>If the <em>TableIOMode</em> is “Save”, you can modify any updateable field. The “Update” mode defines that a modal update mode is used. The fields are disabled until you click <strong>Update</strong> and becomes disabled again immediately on save or cancel.</td>
</tr>
<tr>
<td>Undo changes</td>
<td>When checked (default), the <em>UndoChanges</em> action controls what can be undone and the order that it happens. When unchecked, the older <em>Reset</em> action controls this. This option is available for backwards compatibility.</td>
</tr>
<tr>
<td>Undo add and copy mode</td>
<td>When checked, the functions of the <em>Cancel</em> button are incorporated into the <em>Undo</em> button. This option is only available when <em>Undo changes</em> is checked and the <em>TableIOMode</em> is “Save”.</td>
</tr>
<tr>
<td>Transaction</td>
<td>When checked, the <em>Undo</em> and <em>Commit</em> actions are available.</td>
</tr>
<tr>
<td>Function</td>
<td>When checked, the <em>Filter</em> action is available.</td>
</tr>
</tbody>
</table>
Creating a new SmartToolbar

AppBuilder supplies a single, precompiled SmartToolbar that can replace all the SmartPanels that AppBuilder also supplies. If you choose to use the Toolbar in your application, you can elect to enable more or fewer of those virtual SmartPanels.

If you want to make other changes to the SmartToolbar, you must write code. See OpenEdge Development: ADM Reference for further information.

Adding a filter-control window

Displaying a SmartFilter object necessarily takes up a certain amount of space on the display. Since display space is typically in short supply, you might prefer to allow the user to control whether the filter is visible. One way to do this is to put the filter in a separate, callable SmartWindow. ADM makes this choice easier to implement by supplying a dedicated filter button as part of the SmartToolbar object.

To create a sample application that uses a Filter window:

1. Create a new SmartWindow instance to be the main window of this toy application. Populate it with a SmartDataObject, SmartDataViewer, and SmartToolbar. Allow the Advisor to create SmartLinks for you. Adjust sizes and positions as necessary. Your result should look similar to the following:
2. Right-click the SmartToolbar instance and choose **Instance Properties** from the context menu. When the dialog box appears, set the **Filter** check box:

![SmartToolbar Properties dialog box]

3. Click **OK** to dismiss the dialog box.

4. Create a SmartWindow to be your **Filter** window. Populate it with a SmartFilter.

5. Right-click the filter instance and choose **Instance Properties** from the context menu. The **SmartFilter Properties** dialog box appears:

![SmartFilter Properties dialog box]

6. Identify the data source and the filterable fields. For the purposes of this example, accept the default style and **view-as** settings. Click **OK**.
7. Right-click the instance and choose **SmartLinks** from the context menu. Add a **Filter** link from the filter object (represented by the handle identifier) to the window object (represented by **THIS-PROCEDURE**):

8. Close the **SmartLinks** editor. Resize the **Filter** window as necessary. Save it using a distinctive name.

9. Click on the SmartContainer tool in the **Object Palette**. When the **Choose** dialog box opens, select the **Filter** window that you just saved, and click **OK**. Place the object on any blank spot in your main window. Allow the **Advisor** to create the links it suggests. Your result should now look similar to the following:

10. Right-click the SmartContainer instance and choose **Instance Properties** from the context menu. When the dialog box opens, clear the **View** check box. This will prevent the **Filter** window from automatically displaying at startup. Click **OK** to dismiss the dialog box.

11. Run your sample application. When it starts up, click the **Filter** button to open the **Filter** window. Verify that you can filter the data stream:

The **Filter** button only opens the **Filter** window. To close the **Filter** window, you must click the **Close** button (the **X**) at the right end of its title bar.
A SmartPanel is a task-oriented array of buttons that incorporates ADM Smart technology. As is true of all SmartObjects, SmartPanels are modular and communicate with other SmartObjects through SmartLinks. SmartPanel instances are immediately available as precompiled objects from the Object Palette. They are loosely coupled to the SmartObjects they control and, because they are not directly involved in the operation of a data stream, are not based on a master object.

Table 13 describes the predefined SmartPanels for your use.

<table>
<thead>
<tr>
<th>Style</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Navigation (with Icon Labels)</td>
<td>A four-button array with iconic labels that follow the arrowhead convention made familiar by tape recorders and VCRs. The four buttons select, respectively:</td>
</tr>
<tr>
<td></td>
<td>* The first record in a data stream</td>
</tr>
<tr>
<td></td>
<td>* The record immediately preceding the current record, if possible</td>
</tr>
<tr>
<td></td>
<td>* The record immediately following the current record, if possible</td>
</tr>
<tr>
<td></td>
<td>* The final record in the data stream</td>
</tr>
<tr>
<td>Navigation (with Text Labels)</td>
<td>The same four-button array, but with text (First, Prev, Next, Last) rather than icon labels.</td>
</tr>
<tr>
<td>Update (Standard)</td>
<td>A six-button array with text labels. The six buttons are Save/Update, Reset, Add, Copy, Delete, and Cancel. You must use this SmartPanel, or the equivalent buttons in a SmartToolbar, to enable changes to the database when using a SmartDataViewer for data display. You do not need it to make simple updates when using a SmartDataBrowser; a SmartDataBrowser that allows update will automatically perform the update when the user leaves the changed row. Use an Update SmartPanel with a SmartDataBrowser if you want the user to be able to add and delete records, or make more sophisticated updates.</td>
</tr>
</tbody>
</table>
A SmartDataBrowser provides its own navigational interface with the scroll bar. Adding a navigation array creates the possibility of confusion: since the SmartPanel is not able to communicate with the scroll bar, they can get out-of-sync. If you choose to add a SmartPanel for navigation, consider turning off the scroll bar in the property sheet for the browse widget.

Creating and configuring a SmartPanel instance

After you determine which SmartPanel will meet your needs, creating a SmartPanel is quite easy.

To create a SmartPanel:

1. Right-click SmartPanel in the Object Palette.
2. Select the SmartPanel you want from the context menu:
   
<table>
<thead>
<tr>
<th>Style</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Commit</td>
<td>A two-button array used for transaction processing. The two buttons are Commit and Undo. A transaction is any group of operations that must be completed or discarded as an atomic unit. Failing to treat a transactional group atomically generally results in logical rather than physical data corruption. For example, after a credit purchase, successfully updating the inventory and shipping queue without also updating the customer’s balance will cause an inventory leak. In this example, an update must be performed on all of the tables or on none of them, if the system is to remain in good order.</td>
</tr>
</tbody>
</table>

   
   Table 13: SmartPanels options

   Note: A SmartDataBrowser provides its own navigational interface with the scroll bar. Adding a navigation array creates the possibility of confusion: since the SmartPanel is not able to communicate with the scroll bar, they can get out-of-sync. If you choose to add a SmartPanel for navigation, consider turning off the scroll bar in the property sheet for the browse widget.
4. Right-click the instance and choose Properties from the context menu. The Property Sheet dialog box appears. The sheet for the iconic Navigation panel is shown here:

5. Change the object identifier to one that more accurately describes the role of this SmartPanel in your application.

6. The properties for appearance and behavior vary from panel to panel. Click the Edit button to inspect them (you can also reach them directly by choosing Instance Properties from the menu-button menu). Change those that do not meet your needs.

Navigation SmartPanel properties

A Navigation SmartPanel has three properties. You can change those that do not meet your needs:

- **Show Border** — Normally set. Clearing this check box turns off the border (implemented as a rectangle) around the buttons.

- **Edge Pixels** — Normally 2. You can set the value to as much or as little as you like, with differing visual effects. Note that the number of pixels between the edge of the button and the inner edge of the rectangle does not change—the rectangle’s border grows inward toward the buttons rather than outward, in other words.

- **Internationalization** — (Applies only to the iconic Navigation panel.) To conform your software to cultural conventions, you can choose which button—leftmost or rightmost—will set the pointer to the first record in a data stream. You can often determine the convention for a particular culture by looking at the direction in which the local language is written and read.
Save/Update SmartPanel properties

A Save/Update SmartPanel has only two properties. Change either or both, as desired:

• **TableIO type** — Normally **Save**. Setting this option to **Update** requires the user to first click **Update** before the fields will make themselves editable.

  **Save** causes the fields to be editable by default. In either case, once the user has edited a field, choosing the **Update** button (now labelled **Save**) writes the changes back to the database immediately. If you also have a transaction (**Commit/ Undo**) panel installed, your application will journal the changes so that it can undo them again, if the user elects not to eventually commit.

• **Behavior of Add button** — Normally prompts for one new record. Setting to **Add Multiple** causes your application to prompt for an arbitrary number of new records without requiring the user to click **Add** again.

Transaction SmartPanel properties

There are no programmer-modifiable instance properties for the **Commit** (Transaction) SmartPanel, apart from the object identifier.
Basic buttons

In a GUI, a button is equivalent in power and generality to a menu item. Indeed, you can construe a button as being a self-contained, single-item menu. Since buttons are normally always visible, they offer more immediacy and convenience than menu items at the cost of taking up more space. Because they do take up more space, you will probably want to use them sparingly.

Because of how they are used in everyday life, buttons in a GUI are associated with invocations, actions, and major state changes, not with minor state changes such as setting a single value. Using them in a way that runs counter to this expectation can make your applications harder and less satisfying for people to use.

AppBuilder supplies a default, undefined button object as well as a number of buttons preconfigured for common applications:

- **View page** — Applies only to ADM paging (see the “Simple SmartContainers” section on page 141). Causes objects associated with a certain page number to appear. You supply the number as an argument to the call in the trigger code. Already-visible objects assigned to other ADM pages do not disappear.

- **OK, Cancel** — Accepts/discards changes and closes the parent dialog box or window.

- **Done** — Calls the application’s shutdown routine.

- **Help** — Calls the help system.

- **First, Prev, Next, Last** — Moves the current-record cursor to the record indicated by the button.

- **Custom Size/Color** — (Default) Creates a generic button with no action defined on it. You must add the action code yourself in the CHOOSE trigger.

Creating a button instance

Because they are such simple objects, you can create and configure buttons very easily.

>>> To create and configure a button in your application:

1. Right-click the **Button** in the Object Palette. Choose the appropriate type of button from the context menu:
2. Move your mouse cursor over a bare spot in your workspace window and click to place the new button.

3. Configure, position, and size it appropriately.

Configuring a button instance

To configure a button, you must:

- Customize the appearance to present appropriate cues to the user.
- Write trigger code to respond to the CHOOSE event.

To begin customizing the button’s appearance, select it and choose Tools→Property Sheet. The Property Sheet dialog box appears:

Minimum configuration

While you can accept many default settings, at a minimum you should do the following:

- Change the object identifier to one that more closely represents the role of this button in your application.
- Set the identifying label to a string or icon that will be meaningful to the user. See the “Setting a button label” section on page 335 for instructions.
- Resize the button to fit it to its surroundings in a way that minimizes the space it takes up. For the best visual effect, you should make all related buttons the same size, and align them carefully. If one of them is more significant than the others, you can indicate that greater significance by making that button unmistakably larger in one dimension, as in these examples:
For more information on all the settings on the property sheet, see the online help.

**Advanced properties**

The button object has only the standard advanced properties. See the “Advanced properties” section on page 355 for further information.

**Setting a button label**

You can choose to label your buttons with text or an iconic image, but you cannot use both on the same object.

To use a text label, simply type the new string into the Label field. You can even do this without opening the property sheet, if you wish. For your convenience, AppBuilder displays below the toolbar in its main window both the identifier and the label of a button object whenever it is selected.

**To use an icon (and override any text label):**

1. Double-click on the square button marked Up. The Choose Image dialog box appears:

![Choose Image Dialog Box]

2. If the image file you wish to use is listed, select it and click OK. If the Preview check box is on, the image you select will display in the open area to the right of the listing.

   If you are looking for a particular type of file (.ico, .bmp, etc.) you can choose to filter for only those files by selecting the appropriate item from the File Type drop-down list.

3. If the image file is not listed, you can click Browse to look for them. If you will often search certain other directories for image files, you can add the other directories to the drop-down list in the Directories combo box. Click Edit Path to add a directory, or to modify the order in which they are listed.
This chapter covers the following other objects that you might use in your ABL applications:

- Simple (undefined) SmartObjects
- ActiveX (OCX) objects
- Static images
- Static text
- Timer objects (ActiveX)
Simple (undefined) SmartObjects

AppBuilder supplies a number of ADM SmartObjects for your use. As a developer, however, you will probably encounter situations where the current set of SmartObjects falls short. To solve a particular problem, you will need some SmartObject that does not exist. How will you find a solution? You have two choices:

• Solve the immediate problem by using ABL objects to fill in the gap, linking them into the larger web of SmartObjects in your application. This is a point solution, but it is a somewhat lower-cost one.

• Define and create your own SmartObject. The extra generality required might cost more in design time, but you would then be in a position to reuse the object indefinitely and gain the same advantages in development and maintenance costs that you get from other SmartObjects.

AppBuilder supplies the unfinished Simple SmartObject to make development simpler and quicker. You create one by choosing it from the list under File → New.

For detailed instructions about ADM and creating new SmartObjects, see OpenEdge Development: ADM and SmartObjects.
ActiveX (OCX) objects

ActiveX (OCX) controls are objects that are conceptually similar to ABL widgets and ADM SmartObjects, but written to Microsoft’s Component Object Model (COM) standard. ActiveX objects supply encapsulated functionality of various kinds, and are available from a number of third-party vendors. The COM standard is the current successor to the older VBX standard.

Note: AppBuilder supplies only three ActiveX objects that you can use freely in your applications. In general, using an ActiveX object requires a separate licence from the supplier of the object.

AppBuilder allows you to select and position ActiveX objects in your GUI workspace in the same way you select and position native ABL and SmartObjects. To make this work, AppBuilder supplies a two-layer interface between the ActiveX object itself and the AVM. The two layers are a control frame widget and a Control-Frame COM object. They translate between the Microsoft and AVM standards.

Although the control frame interface is too general a mechanism to make the differences between ActiveX objects and ABL fully transparent to you, this section provides a general overview of how to create and configure instances.

For a full technical discussion of ActiveX objects in OpenEdge applications, see OpenEdge Development: Programming Interfaces manual.

Creating an ActiveX object instance

Although an ActiveX object is very different, internally, to an ABL object or SmartObject, the basic process of selecting and placing an OCX object is similar to the process for a native ABL object.

To select and place an OCX object:

1. Click OCX in the Objects Palette.

2. The dialog box that appears lists all ActiveX controls found within your development system, as shown:

AppBuilder does not know whether the controls it finds are licensed. Before using an OCX object, verify you have a license.
3. Select the object you wish to use, and click **OK**. Move your mouse cursor over a bare spot in your workspace and click to place the instance.

4. Configure and size the object.

**Generic ActiveX event handlers**

You might sometimes find that you have several ActiveX objects, perhaps of different kinds, that can all register the same kind of event. If it would meet your needs, you can write a single event handler that will respond to that event regardless of which object instance experiences it. If you do write such a generic handler, it need not apply to all objects. You can override it by writing handlers that you bind to specific instances. You can have only one generic handler for a particular event type, but you can have as many instance-specific handlers as you like.

Inside the event handler, use the generic identifier **COM-SELF** to refer to the object instance that experienced the event. For example, to refer to the experiencing instance’s `Value` property in a generic handler, you would use the expression `COM-SELF:Value`. Note that you do not need to use the usual `chInstanceHandle:OCXName:Value` format.

**To create a generic event handler:**

1. Choose **Window** → **Code Section Editor** to open that window. Set the **Section** to **Procedures**, not **Triggers**, and click **New**.

2. Type in `ANYWHERE.Eventname` as the name of the procedure (where `Eventname` is the actual name of the event, as for example `Tick`, `Click`, `Choose`, etc.).

3. Insert the code for handling the event.

4. If you want to bind a special handler to a particular instance, overriding the generic handler, set **Section** to **Triggers**, and click **New**. Select the same event and define the special handler for it.

5. If you want to remove a special handler, making the generic handler the new event-service routine, bring the special handler up in the edit window and choose **Edit** → **Delete Trigger**.

**ActiveX (OCX) properties data**

AppBuilder saves in a single file the properties data for all OCX objects that are local to a particular external procedure. (The file is not human readable.) By default, AppBuilder saves that file in the same directory where it saves the source files for the procedure, and using the same basic name with the extension `.wrx`. You can choose to use a different directory and/or filename.

**To use a different directory and/or filename:**

1. Choose **Tools** → **Procedure Settings**.

2. From the **OCX Binary** drop-down list, select **Other**.
3. Type in the new filename, including the path if you want AppBuilder to store the file in some place other than in the default working directory.

Static images

Static image objects have no behavioral repertoire of their own, though you can use them as labels on buttons and in similar contexts. Consider cultural differences when choosing images, especially when choosing images to use as icons and labels. What is perfectly clear to one person might be mystifying to another, or even offensive. Be especially wary of using visual puns: they almost never translate well.

To create and configure a Static image element:

1. Click Image in the Objects Palette.

2. Move your mouse cursor to a bare spot in your workspace, and click to place the new Image object. Initially, the Image is undefined and looks like a smudged square, as shown:

3. Select the object and choose Tools→Property Sheet. The Property Sheet dialog box appears:

Minimal configuration

At a minimum, you should do the following things:

- Change the object identifier to one that more clearly conveys the purpose of this image in your application.

- Identify the actual image file.
To identify the image file:

1. Click on the smudge image. The Choose Image dialog box appears:

![Choose Image dialog box]

2. Select the image type desired. AppBuilder supports many different image formats.

3. If the image you want to use is not listed, click Browse to move to the correct directory. Select the filename. You will see a preview of the image, if you have the Preview box checked.

   Note that Preview shows as much of the image as possible, at the size it will appear when the application runs; AppBuilder does not rescale images here. If the image is the wrong size for your purposes, you must use some tool such as a graphics editor to rescale it before use, or must write code to rescale it under program control.

4. When you have the correct image file identified, click OK to return to the property sheet. Some portion of the image—not necessarily the whole thing—appears in place of the smudge, as a token that you have successfully identified the image. The fully qualified filename of the image also appears, for your convenience:

![Property Sheet - IMAGE-1]

5. Set any other properties you consider appropriate, and click OK to dismiss the property sheet.

**Help**

You can include a Tooltip string, if you wish. Under MS-Windows, the image object will display the Tooltip string whenever the user allows the mouse cursor to hover over the image.
Geometry

If you prefer to set the origin and size of the image explicitly rather than interactively, do so here.

For more information on all the settings on the property sheet, see the online help.

Advanced properties

The static image object has the normal minimum Advanced Properties. See the “Advanced properties” section on page 355 for more information.
Static text

Static text can play an important role in your application by calling attention to important objects, and by contributing to an overall corporate image, where appropriate.

To create and configure a static text element:

1. Click **Text** in the **Objects Palette**.

2. Move your mouse cursor to a bare spot in your workspace, and click to place the new text object.

3. Select the object and choose **Tools** → **Property Sheet**. The **Property Sheet** dialog box appears:

4. Type in the text string the object will display.

5. Choose a special typestyle and colors, if appropriate. See the “Choosing colors” section on page 357 and the “Choosing a type style” section on page 381 for more information.

6. Add translation information, if necessary. See the “String attributes” section on page 375 for more information.

7. Click **OK** to dismiss the property sheet. Select the object and drag its handles to position and size it appropriately.
Timer objects (ActiveX)

The majority of GUI-based applications follow an asynchronous, event-driven model similar to that for real-time or process-control applications. The majority of their time is spent waiting for input, in this case from the user rather than some hardware device.

But there are a number of cases for which it can be convenient to perform some activity at a regular interval, regardless of what the user might be doing. Providing a real-time clock display is perhaps the simplest case. Checking or reporting on the state of some lengthy process is another.

AppBuilder supplies a simple OCX Timer object for your use. The timer is interrupt-driven from the system clock, and generates a single event (Tick) at some regular interval you determine. You configure the Interval property to be a multiple of 1/1000 of a second, and write an event handler to react to the Tick event. The timer will continue to generate this event with metronomic regularity until you reset or disable it.

**Caution:** It takes a certain amount of time to react to any event. If you set up a situation where you must respond to every Tick event, but you configure them to occur more frequently than you can handle them, your application might behave in a way that is both strange and hard to debug.

To create and configure a Timer instance:

1. Click PSTimer in the Objects Palette.
2. Move your cursor to some bare spot in your workspace and click to place the object. The Timer object has a design-time representation, but is invisible at run time.
3. Change the Object identifier, shown in AppBuilder’s main window, to one that more clearly identifies the role of this timer in your application.
4. Choose Window → OCX Property Editor to open the timer’s own property sheet.
5. Set the Interval property to the desired integer frequency, representing thousandths of a second. For example, to get a Tick event every second, set Interval to 1000. For 1/10th of a second, set Interval to 100, and for a tick every 5 seconds, set Interval to 5000. Close the window.
6. Open the Section Editor. Set the Section to Triggers, if necessary, and click New to create a new event handler. Select ocx.Tick as the event, and click OK. AppBuilder will create a stub event handler.
7. Insert the code to perform the task for which you set the timer.
This is a toy handler for the Tick event:

```cobol
/*
**  In the definitions section:
*/
DEFINE VARIABLE bTickTock AS LOGICAL INITIAL FALSE.

/*
**  In the OCX.Tick event handler:
*/
bTickTock = NOT( bTickTock ). /* flip the value */
IF bTickTock THEN /* decide whether to tick or tock */
  MESSAGE "Tick".
ELSE
  MESSAGE "Tock".
```

When run, this toy event handler will alternately, and endlessly, write “Tick” or “Tock” to the message area of the window, presuming you have configured your window object to have a message area. The endless, synchronous looping action comes not from any loop code in the handler, but rather from the fact that the Timer itself is bound to the endlessly-operating system clock.
Frequently Used Dialogs

You will repeatedly encounter a number of dialog boxes as you use AppBuilder. While the context might change in which you find them, they themselves generally have a somewhat fixed format. This appendix describes the following dialog boxes and serves as a reference for their use:

- ActiveX control frame properties
- ADM pages manager
- Advanced procedure settings
- Advanced properties
- Colors selector and editor
- Custom lists naming
- Database field selector
- Method library includes list
- Procedure settings
- Properties window
- SmartLinks editor
- SmartInfo
- SmartObject properties
Appendix A: Frequently Used Dialogs

- String attributes
- Temp-tables maintenance
- Text style selector and editor
ActiveX control frame properties

When you select an ActiveX (OCX) object and choose **Tools → Property Sheet**, the dialog box that opens does not display the properties for the ActiveX object itself. It displays the properties for the invisible control frame object that serves to adapt the ActiveX object to the OpenEdge environment, as shown:

Since control frames are adapters, they have relatively few properties, and not all of those have a perceptible effect. You can set those that exist, if you choose:

- **Object** — You should change this identifier to better reflect the role of the ActiveX object in your application.
- **Help ID** — If you plan to provide context-sensitive help for this object, enter a unique integer here as the identifier.
- **Geometry** — If you prefer not to position and size the object interactively, you can set those values explicitly here instead. This dialog box uses character units; choose the **Advanced** button to set the same values using pixel units.
- **Hidden** — Normally cleared. Setting this box prevents the ActiveX object from responding to implicit requests to display itself.
- **No-Tab-Stop** — Normally cleared. Setting this box prevents the object from participating in the enclosing frame's traversal group. Unless an object is part of a traversal group, it can neither gain nor lose the input focus as the result of the user pressing the **TAB** key.
- **Remove from Layout** — Cleared. Cannot be set except when defining an alternate layout.
- **Sensitive** — Normally set. Clearing this box causes the object to decline the input focus when offered.
Appendix A: Frequently Used Dialogs

Advanced properties

Click on the **Advanced** button to open the **Advanced Properties** dialog box for this control frame:

The control frame does not have the properties **Manual Highlight**, **Movable**, **Resizable**, or **Selectable**. Nor does it offer you the ability to set alignment.
ADM pages manager

The button shown here is available in the **Procedure Settings** dialog box for objects that are members of the class SmartContainer:

ADM paging allows you to multiplex your display space in useful ways. But once you have a complex, paged design in place, managing all the SmartObjects can be quite a difficult task. AppBuilder provides the **Pages** dialog box to help with that.

Using the **Pages** dialog box, you can:

- Review the list of SmartObjects assigned to a page.
- Set the **Design** and **Startup** pages.
- Move SmartObjects from one page to another.
- Delete SmartObjects from a page.
- Delete whole pages.
- Exchange the SmartObject contents of any two pages.

**Note:** The Pages dialog box only provides help with SmartObjects. Other objects, whether basic ABL or ActiveX (OCX), are not shown by this dialog box.

To open the Pages dialog box, choose **Tools → Procedure Settings**, or the **Procedure Settings** button on the toolbar, then click **Pages**. Figure 51 shows the dialog box.

![Figure 51: Pages dialog box](image-url)
**Reviewing the list of SmartObjects assigned to a page**

To see the list of SmartObjects assigned to any page, click on the page number in the page in at the left side, or click **Page** and enter the desired page number in the small dialog box that appears in response.

**Note:** Choosing to set the page number through the **Page** button and dialog box only determines which page’s contents are displayed in the right-hand list. It does **not** set the design page as it would do in other circumstances.

**Setting the design or startup page**

The paging system identifies two special pages:

- **Design Page** — Whenever you place a SmartObject, it always goes onto the current design page.

- **Startup Page** — Whenever you run an application that uses ADM paging, the startup page is always the initial page displayed.

See the “Special pages” section on page 145 for a more complete discussion of the relationship between these pages and the default page 0 (zero).

To alter where you place future SmartObjects, or which SmartObjects appear at startup, click **Design...** or **Start...** as appropriate, and enter the desired number in the dialog box that appears. Note that the dialog boxes are identical apart from the text in their title bars. Be sure you are setting the appropriate value.

**Moving a SmartObject between two pages**

To move a SmartObject from one page to another, highlight the object in the listing for its current page, click **Move to Page...**, enter the destination page number in the **Move to Page** dialog box, and click **OK**. Note that you cannot move the object by cutting and pasting the list entry.

**Exchanging the contents of two pages**

To completely exchange the contents of two pages, one of which might be empty, in a single operation, highlight them both (shift-click to highlight the second) and then click **Swap Pages**. If one of the pages is empty, the swap operation will be equivalent to a move-all operation.

**Deleting a SmartObject from a page**

To delete a SmartObject from a page, highlight the object in the listing and click **Delete SmartObject**.

**Deleting a page and all its SmartObjects**

To delete a page and all SmartObjects on it, select the page number in the left-hand list, then click **Delete**. A question box prompts you for confirmation. On completion, the page number will no longer appear in the list. You can easily recreate the page by assigning some SmartObject to it.
Advanced procedure settings

AppBuilder uses the same Advanced Procedure Settings dialog box for all procedure level objects. Some of the fields might not apply to a particular object type, either because the qualities are predefined and fixed, or because they are entirely irrelevant.

You invoke this dialog box by choosing the Advanced button in the Procedure Settings dialog box.

**Note:** If you close the Advanced Procedure Settings dialog box by clicking OK, you will always be shown a message box reminding you to include all needed method libraries. This is true even if you have only inspected the settings. If you have made no changes you want to save, you can avoid this message by clicking Cancel instead of OK.

Figure 52 shows the dialog box with the options that are enabled for SmartDialog objects.

![Advanced Procedure Settings dialog box](image)

**Figure 52:** Advanced Procedure Settings dialog box

The options are as follows:

- **Procedure Type** — AppBuilder sets this by default to match the object type. In other words, when you open this dialog box for a SmartWindow, you will see SmartWindow listed here. If you wish, you can select a procedure type different to the object type, for example a SmartDataBrowser procedure for a SmartWindow type. For more information, see OpenEdge Development: ADM and SmartObjects.

- **Supported SmartLinks** — Lists the SmartLink types an object knows how to handle as originator, recipient, or both. As shown in Figure 52, a SmartDialog can handle either end of a Data or Update link, and knows how to be on the receiving end of a Page link.

You can add additional link types to this list, if you are prepared to write the code to support them. For further information, see OpenEdge Development: ADM and SmartObjects.
• **File Type** — Determines the filename suffix when the file is saved. For SmartObject sources, this is always .w.

• **Template** — Normally cleared. Checking this box causes certain information in the file to be automatically stripped out before saving, making the file more generic. If left unchecked, the file is saved as a master file rather than a template.

• **Add Fields to** — Determines where database fields will be added: to the Frame Query, the procedure's external table, if any, or to neither. Generally you should not alter the default setting, which is Frame Query.

• **Run Option: Persistent Only** — Normally set. When set, any attempt to run the object nonpersistently fails with an error message. This is true of all SmartObjects except the SmartDialog.

• **Allow Drawing of** — Determines what sort of objects can be made children of this object. If you clear, for example, the Basic Objects box, AppBuilder will refuse to allow you to place basic ABL objects onto this workspace. You will be able to choose an ABL object tool from the Objects Palette, but not release such objects onto the workspace.
Advanced properties

All basic ABL objects have an Advanced Properties dialog box under the Advanced button in their property sheet. Most advanced properties are the same for all widgets. The Advanced Properties dialog box for a button is shown:

![Advanced Properties dialog box for a button](image)

Change any of the default settings that do not meet your needs. For example:

- **Help** — The text you enter here appears in the status area of the enclosing window whenever this object has focus. If you enter no special text, a default string appears instead. If the enclosing window has no status area, no text appears.

- **Private Data** — AppBuilder writes out the contents of this area as the value for the PRIVATE-DATA attribute. You can write code to use this data in any way that meets your needs.

- **Generated Code Layout Unit** — Choose whether AppBuilder uses character (the default) or pixel units when it generates the source statements to create and manage this object.

- **Custom Lists** — Custom lists are a way to refer to many objects with a single identifier. The six lists shown always belong to the nearest supporting frame, not to this object. You can add this object to any or all of the lists, as you choose. If you move this object so that it is supported by a different frame, you will have to create new associations if you want them.

- **Geometry - Pixels** — If you prefer to set the XY origin and size using explicit pixel units, you can do that here. You can also choose whether to align to the left or right, but this has no effect other than to change the number used for the X origin.

- **Manual-Highlight** — Normally cleared. Setting this box allows you to write code to define a custom highlight effect. Your custom effect is applied whenever this object has input focus.
Appendix A: Frequently Used Dialogs

- **Movable** — Normally cleared. Setting this box makes it impossible for the user to give this object input focus by clicking with the mouse. Instead, the user can use the mouse to drag the object body to a different position within the bounds of the enclosing frame. Note that if the object has a separate label, as in the case of a fill-in, the label does not move. The result is that the object and its label can be visually separated from one another.

- **Resizable** — Normally cleared. Setting this box makes it impossible for the user to give this object input focus by clicking with the mouse. Instead, if the selectable box is also set, clicking with the mouse causes handles to appear so that the user can resize the object.

- **Sync With Master** — If this is an alternate layout, choosing this button resets the characteristics of this object in this layout to agree with its characteristics in the main layout. For example, if the width were 12 characters in the alternate layout but 14 in the main layout, choosing Sync would cause the object to be 14 characters wide in both layouts.
Colors selector and editor

Almost every object with a visible run-time representation has a foreground and background color that you can set. Whether your settings will override any system defaults is platform-dependent. For example, you can set the title color for a frame object, but such settings have no effect under Windows.

It is good usability practice to be sparing with color. Too much color, or too many colors, can create a recreational or even childlike impression on the user. This might not be the most desirable outcome, if your application is one for office use. But you need not avoid color changes altogether. Used carefully, special color changes can help focus the user's attention in appropriate ways. This improves the usability of your product and, often, its marketability. Careful use of color can also be a defining element in a corporate identity program, allowing you to create semicustom software packages with little extra effort.

ABL widgets that display data use the foreground and background colors for that purpose. They display their data in the foreground color against the background color. In the case of data browser widgets, you can also choose a color for the internal lines separating rows and columns.

ABL widgets such as the rectangle use the foreground color for their border, and the background color for the fill, if filled.

Choosing colors

Select colors with the Color Selector dialog box.

To set foreground and background data colors for an object:

1. Select the object and choose Tools → Color, or open the property sheet and click Colors (the crayons). The Choose Color dialog box opens:

Sixteen colors remains the baseline standard under Windows, and those colors occupy slots 0 through 15 in the OpenEdge color table. The boxes labeled with the Unknown value (?) represent the default colors for the object. The default
colors are those assigned by the object's parent, but are most often the colors shown in the example: black (slot 0) foreground and light gray (slot 8) background.

2. Click on a new color for the desired context. If you wish to use a color not in the default set, see the “Defining new colors” section on page 358.

3. If the object whose colors you are changing must be readable (text, instrumentation, graphs, etc.), verify that you have chosen a good combination by examining the text in the Sample rectangle.

Text is always less readable on a monitor than on paper, so it is good practice to change your design choices rather than compromise readability. While good contrast is the most important factor over which you have some control, other factors also come into play, including font size and style. There are also other factors in play over which you as the programmer have no control—the characteristics of the eventual user's monitor being the most important. For this reason, you should choose the most highly readable combinations whenever possible.

**Defining new colors**

The default Windows color table has only 16 slots (4 bits/pixel). AppBuilder's color table has a total of 256 slots, numbered 0 through 255. Only slots 0 through 15 have colors defined on them by default, and those colors match the default Windows set, as shown in Table 14.

<table>
<thead>
<tr>
<th>Slot</th>
<th>ABL color name</th>
<th>Red-Green-Blue (RGB) values</th>
<th>Decimal</th>
<th>Hex</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Black</td>
<td>0 0 0</td>
<td>0 0 0</td>
<td>0 0 0</td>
</tr>
<tr>
<td>1</td>
<td>Dark Blue</td>
<td>0 0 128</td>
<td>0 0 80</td>
<td>80</td>
</tr>
<tr>
<td>2</td>
<td>Dark Green</td>
<td>0 128 0</td>
<td>0 80 0</td>
<td>80</td>
</tr>
<tr>
<td>3</td>
<td>Blue Green</td>
<td>0 128 128</td>
<td>0 80 80</td>
<td>80</td>
</tr>
<tr>
<td>4</td>
<td>Red</td>
<td>128 0 0</td>
<td>80 0 0</td>
<td>80</td>
</tr>
<tr>
<td>5</td>
<td>Purple</td>
<td>128 0 128</td>
<td>80 0 80</td>
<td>80</td>
</tr>
<tr>
<td>6</td>
<td>Olive</td>
<td>128 128 0</td>
<td>80 80 0</td>
<td>80</td>
</tr>
<tr>
<td>7</td>
<td>Gray</td>
<td>128 128 128</td>
<td>80 80 80</td>
<td>80</td>
</tr>
<tr>
<td>8</td>
<td>Light Gray</td>
<td>192 192 192</td>
<td>C0 C0 C0</td>
<td>80</td>
</tr>
<tr>
<td>9</td>
<td>Blue</td>
<td>0 0 255</td>
<td>00 00 FF</td>
<td>80</td>
</tr>
<tr>
<td>10</td>
<td>Green</td>
<td>0 255 0</td>
<td>00 FF 00</td>
<td>80</td>
</tr>
<tr>
<td>11</td>
<td>Turquoise</td>
<td>0 255 255</td>
<td>00 FF FF</td>
<td>80</td>
</tr>
</tbody>
</table>
You can increase the colors available to your application—for example, to create a special corporate color scheme—by defining colors on slots 16 through 255 (16 through 127 for character mode), although not all objects can accept colors from slots above 15. You can also change the colors defined for slots 0 through 15 (for example, substituting a green for a red), though for compatibility reasons this is discouraged.

Note that changes made to the color table are permanent the moment they are made. Clicking **Cancel** does not discard the changes. To restore earlier colors, you must recreate them.

### To add a new color to the table:

1. Click the arrowhead button to bring the next set of 16 color slots into view. They are all defined as black, initially.

2. Double-click the first undefined slot (slot 16, unless you have already defined additional colors for this application, or for another application during this OpenEdge session). It does not matter whether you click the foreground or the background slot—they are really the same slot, and when you define a color, it appears in both places. The standard Windows color-editor dialog box opens, as shown:

<table>
<thead>
<tr>
<th>Slot</th>
<th>ABL color name</th>
<th>Red-Green-Blue (RGB) values</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Decimal</td>
</tr>
<tr>
<td>12</td>
<td>Red</td>
<td>255</td>
</tr>
<tr>
<td>13</td>
<td>Pink</td>
<td>255</td>
</tr>
<tr>
<td>14</td>
<td>Yellow</td>
<td>255</td>
</tr>
<tr>
<td>15</td>
<td>White</td>
<td>255</td>
</tr>
</tbody>
</table>
Appendix A: Frequently Used Dialogs

3. If none of the existing colors meets your needs, you can modify any or all of the 16 colors in the **Custom colors** bank. These are not the same 16 colors that appear in the default slots. Click on the color you wish to modify.

The color in that cell will immediately appear in the large color/solid swatch, its HSL and RGB values (HSL and RGB are just different color-notation schemes) appears in the readouts, and the cursors showing where the color is in the color space will reposition themselves appropriately, as shown:

4. To create the new color, you can:

   - Move the cursors to new positions in the rainbow color space. The larger space represents the qualities of Hue (red, green, etc.) and saturation/intensity (bright, rich color versus muted, grayish color). The long, narrow space to the right represents luminance or value (in paint or printer’s ink, the amount of white or black (but not both) in the color; on a monitor, the amount of energy exciting the phosphor).

   - Set the HSL or RGB values explicitly. This is a particularly useful method if you are trying to work to a known standard, or reproduce colors for which you know those values.

5. When the color is correct, click **Add to Custom Colors** to preserve it, as shown:

6. If you wish to define additional custom colors, select another **Custom Color** cell and repeat **Step 4** and **Step 5**. When you are finished, select a color cell and click
OK. The color editor dialog box closes, and the selected color is assigned to the color table.
Custom lists naming

The button shown is available in the Procedure Settings dialog box:

Custom lists would be called macros in some other languages, such as C. They provide a convenient way to refer to many objects with a single identifier. Each instance of a procedure or procedure-based object, such as a SmartWindow, has its own set of six custom lists. When the preprocessor encounters a reference to a custom list in source code, it replaces that reference with all the identifiers associated with that particular list.

The dialog box shown in Figure 53 allows you to give more meaningful names to the lists that belong to a particular procedure. For example, if you create an area within a SmartWindow that has widgets dealing with order entry, and you assign them to the first list, you might give that first list the name OrderEntry or Order_Entry (embedded spaces are not allowed in the names you give) so as to more easily keep track of what you are doing.

![Custom Lists dialog box](image)

**Figure 53:** Custom lists naming dialog box

To change the name of a list, merely type in the new name.

Your change will be reflected in the list of lists in the Procedure Settings dialog box, and in the properties dialog boxes for all the basic widgets subordinate to the procedure. To continue the earlier example, if you place a button widget in the SmartWindow, and open its Advanced Properties dialog box, you will now see Order_Entry as the name of the first Custom List.
Database field selector

The button shown is available in the Property Sheet dialog box, where relevant:

The Database Field Selector dialog box allows you to associate a database field with a data-capturing widget such as a fill-in, toggle box, etc. By choosing appropriate widgets for such associations and adding the necessary additional supporting code, you can create layouts that are more subtly informative and helpful than those where you only use, for example, a data browser with its tabular display.

To associate a database field with a data-capturing widget:

1. Select the widget and choose Tools → Property Sheet. When the dialog box opens, click Database Field. The Field Selector dialog box appears:

![Field Selector](image)

2. Select, as appropriate, a database, a table, and a field to be associated with the widget. Click OK to dismiss the dialog box. The Data Field Defaults dialog box immediately appears in its place:

![Data Field Defaults](image)
3. Choose the control type:

- **Database Field** — Default. Causes the widget to be associated with the database field you chose in Step 2.

- **Local Variable** — Causes the widget to be associated with a local variable.

- **Like chosen_table.field** — The chosen table.field shown is the one you selected in Step 2. Choosing the option causes the widget to inherit any triggers defined for the database field. If there are no triggers to inherit, you can define those you need. But if the object inherits even one trigger, you cannot define additional ones.

4. If you choose **Database Field** or **Like Customer.Name**, you can also choose whether to inherit some display characteristics from the data source:

- **Label** — Creates a label for the widget based on the field name.

- **Format String** — Ensures that the format of the widget is the same as that of the field.

- **Help String** — Uses the help string associated with the database field.

5. Click **OK** to dismiss the dialog box. Your widget is now associated with the storage unit (database field or local variable) you chose.
Method library includes list

The button shown is available in the Procedure Settings dialog box:

The Method Libraries dialog box lists all the header files relevant to the current external procedure. If you modify the behavior of a SmartObject, you must add references to any additional header files required by your changes.

To change the list of include files:

1. Choose Tools → Procedure Settings. When that dialog box opens, click the Method Libraries button (bookcase icon) in the upper-right corner. The Method Libraries dialog box appears:

2. Click Add. An editing dialog box like the following appears:

3. Enter the filename to be added to the list, or click Files to browse for the file. Note that the curly bracket delimiters are supplied automatically when you add a reference. You might need to use the Move Up/Move Down buttons to adjust the order in which files are included.

To modify an entry, select it and click Modify. A nearly identical editing dialog box opens, with the entry ready for editing. To delete an entry, select it and click Delete.
Appendix A: Frequently Used Dialogs

Procedure settings

Broadly speaking, procedure settings deal with the nonvisual aspects of objects that are based on external procedures. In the case of a SmartWindow, for example, they are aggregated into seven groups, each represented by a dialog box discussed in this appendix:

- Main (this section)
- Advanced procedure settings
- Method libraries
- Custom lists
- Temp-tables
- SmartLinks
- Pages

Other procedure based objects, including other SmartObjects, will have a different number of groups, depending on their nature. For example, a SmartDataObject will not have a Pages button because it is not a SmartContainer and thus does not support a paging context of its own.

To open the main Procedure Settings dialog box for a procedure-based object, you must first open the master object itself, if there is one. Choose File → Open and select the object or, if the object is a SmartObject instance, click the menu button and choose Edit Master.

When the master object is open and selected, choose Tools → Procedure Settings, or the Procedure Settings button from the toolbar. A dialog box similar to that in Figure 54 opens.

![Procedure Settings dialog box](image)

Figure 54: SmartWindow main procedure settings dialog box
The main Procedure Settings dialog box is used for all procedure level objects. Some of the fields will therefore not apply to a particular object type, either because the qualities are predefined and fixed, or because they are entirely irrelevant. The settings shown here are those for a SmartWindow:

- **Type** — Reflects the type of subprogram being used for this object. Although you can reset this value in the Advanced dialog box, see OpenEdge Development: ADM and SmartObjects for more information.

- **File Name** — Reflects the name of the .w file on disk. This is undefined until you save the object. You can change this value at any time with the usual Windows tools—the Explorer file system interface, for example.

- **Description** — A general-purpose, multi-line field for comments about this object.

- **OCX Binary** — If you include any ActiveX objects in your SmartContainer’s population, their properties are saved in a file, by default the .w file itself. If you prefer, you can specify a different file here.

- **Compile in** — By default, the .r object file that results from compilation will be stored in the same directory as the .w source. If you prefer, you can specify a different directory here.

- **Run Persistent from AppBuilder** — Determines whether the object procedure will preserve their data and interface contexts when the RUN statement that invoked them completes execution. Persistent contexts remain allocated until explicitly released, or until the end of the OpenEdge session.

  In general, you should check this box for all SmartObjects other than SmartDialog.

- **Compile on Save** — Determines whether AppBuilder produces an object file when it saves the current source file, rather than recompiling whenever an instance is needed at run time. Checking this box is generally better, but because AppBuilder automatically compiles whenever changes are made, the advantages are not clear-cut.

- **AppServer Aware** — Determines whether AppBuilder includes the header files required for connecting to an AppServer service, making requests of the service, and later disconnects from the service. In an ADM-compliant application, AppServer awareness is a property of the SmartDataObject, and generally not needed by other objects.
Appendix A: Frequently Used Dialogs

Properties window

To open this dialog box, choose **Window → Properties Window**. It displays certain properties for the currently selected object. The displayed properties are different for different object types. If more than one object is currently selected, it displays only those property types they have in common (generally no more than their dimensions.) **Figure 55** shows the **Properties Window** for a control frame, such as that automatically supplied by AppBuilder when you place an OCX object.

![Properties Window](image)

**Figure 55:** Properties Window

To use this dialog box to make changes to one or more selected objects:

1. Select the object or objects.

2. Choose **Window → Properties Window**. The dialog box appears.

3. Select the line item you wish to change. If necessary, first click the + sign in the leftmost column to expand and see the values for a category.

4. The current value appears in the fill-in. Depending on the data type, the fill-in might change to a combo box, or display a button at the right side with the “...” convention that indicates a dialog box will open. Enter the new value for the field accordingly.

5. Click on the check-mark button to accept the change you made, or on the x-out button to discard it.

6. When finished, click on the **Dismiss** button at the right side of the title bar to dismiss the dialog box.
SmartLinks editor

The button shown is available in the **Procedure Settings** dialog box:

SmartLinks are the well-defined ADM communication pathways between SmartObjects. Although AppBuilder provides **Advisor** dialog boxes to semiautomatically create links between SmartObjects when you add them to a SmartContainer, there will be times when you will find it desirable or necessary to edit links by hand.

The **SmartLinks** editor shown in Figure 56 helps you with this task.

![SmartLinks editor dialog box](image)

**Figure 56:** SmartLinks editor dialog box

You can open this editor in either of the following ways:

- Click on the menu button of a SmartObject and choose the **SmartLinks** menu item.

- Choose **Tools** → **Procedure Settings** and then click **SmartLinks** (the chain-links icon).

Regardless of where you start when you open the editor dialog box, **it always displays links from the standpoint of the current SmartContainer**. Any references to **THIS-PROCEDURE** are always references to that current SmartContainer, not to any other SmartObject that might be selected. For example:
The **SmartLinks** dialog box provides extensive filtering capabilities. By default, the editor displays all current links. If the list is confusingly large, you can subset it by filtering on a particular source, link type, or destination, or any combination. You can also choose to sort the list by source, link type, or destination.

To add a new SmartLink:

1. Click **Add**. The **Add a SmartLink** dialog box appears:

2. All SmartObjects local to the current SmartContainer, including the SmartContainer itself (**THIS-PROCEDURE**), are listed as possible sources and targets. Select one of them to be the source of the new SmartLink.

   If you are not sure what types of SmartLink are supported by the selected object, click **Info on Source**. The SmartInfo dialog box opens. See the “SmartInfo” section on page 372 for more information.

3. Selecting the source of the new SmartLink displays in the **LinkType** field the SmartLink types for which the selected object can act as source. Choose the type of SmartLink to add.

   If you click **New**, a dialog box opens and requires you to type in the identifier for the new type of SmartLink. You must be prepared to write code to manage such application-specific link types yourself. See *OpenEdge Development: ADM and SmartObjects* for information about creating and managing new types of SmartLinks.
4. Choose the target for the new link.

If the target you choose cannot deal with links of the type you selected, an Advisor appears asking that you confirm your choice or elect not to create the link, as shown:

5. Repeat Step 2, Step 3, and Step 4 until you have added all the necessary links. Click OK to dismiss the Add dialog. Your new links appear in the SmartLinks list.

You can modify an existing link by selecting it and choosing the Modify button. The process is otherwise the same. When you dismiss the Modify dialog box, the link you selected will reflect the changes you made.

To delete a SmartLink, select it and click Remove.
AppBuilder provides information about a number of SmartObject properties in the two SmartInfo dialog boxes. You can open the main SmartInfo dialog box in either of these ways:

- Select the SmartObject, choose Tools→Property Sheet, and then click the SmartInfo button (the i icon).
- Click the menu button for the SmartObject, and choose the SmartInfo menu item.

The main SmartInfo dialog box appears:

This dialog box provides the filename of the object’s master, its class (in the example, SmartDataObject), and a list of supported link types, including directionality.

A number of other properties for the selected SmartObject can be inspected by choosing the Properties button. This read-only dialog box appears to present the properties, as shown:
SmartObject properties

A SmartObject has few editable properties of its own, although the basic objects that make up its run-time representation, if any, have all the properties associated with their kind. There is no Advanced Properties dialog box for a SmartObject as such, though there is for any widget the object uses for its run-time representation.

You can open the Property Sheet for a SmartObject other than a SmartWindow, SmartDialog, or SmartFrame by any of these methods:

- Clicking its menu button and selecting the Properties menu item
- Right-clicking on the object and selecting the Properties menu item
- Selecting the object and choosing Tools → Property Sheet

The Property Sheet dialog box appears:

This Property Sheet dialog box combines information about both the master object and the particular selected instance. The fields are:

- **Object** — The instance handle identifier. You should change this to more clearly reflect the role of the object in your application.

- **Type** — This read-only field identifies the class to which this object belongs.

- **Master File** — The master file that this instance uses. Choosing the File button opens a dialog box that allows you to associate a different master with this instance. Be cautious about using this ability.

- **Instance Properties** — The nature of the properties in this list varies with the object class. See the relevant chapter of this manual for a description of the instance properties pertaining to a particular SmartObject class. Click Edit to change the editable properties.

- **Parameterize as Variable** — This toggle is normally cleared. Setting this box causes AppBuilder to treat this object as a placeholder for its class rather than as an instance of a specific master object.
By default, every instance of a SmartObject represents a particular master object with a defined set of behaviors. For example, a given SmartDataBrowser instance is constrained to display a certain set of fields, generally from a particular database, and only those fields. Under some circumstances, you might find it advantageous to be able to treat a SmartObject instance as a design-time placeholder, instead. That would allow you to defer the choice of master until run time, when you could choose, load, and run a situation-specific instance under program control. See the “Creating a SmartObject placeholder” section on page 374 for information about how to do this.

Creating a SmartObject placeholder

You can add an object to hold the place of an object you plan to develop later.

To use an instance of a SmartObject as a design-time placeholder:

1. Place a SmartObject instance.

2. Open the object's Property Sheet. Set the Parameterize as Variable check box. A fill-in field opens to the right, as shown:

   ![Parameterize as Variable](image)

   Type in the identifier for the variable you will use to control which master gets loaded at run time.

3. Select the SmartContainer that supports the new placeholder. Open the Section editor to the Definitions area, and define the variable. Add additional code in the appropriate section to resolve the reference.
String attributes

The button shown is available in the Property Sheet for widgets for which it is relevant:

This dialog box takes different forms, depending on the object. For example, Figure 57 shows the String Attributes dialog box for a static text object, and Figure 58 shows the same dialog box for a combo box object.

The string attributes you include here govern display and translation characteristics for the strings. Note that you also set attributes for the associated help and tooltip strings here.

As long as they do not contradict one another, you can include several attributes. The available attributes are:

- **L R C T** — Orientation: Left, Right, Centered, or Trimmed. Use only 1 of these. The default varies with the role of the string.

- **U** — Untranslatable. Add this marker to prevent the OpenEdge translation utility from processing the string. By default, the utility processes all strings.

- **9999** — The INTEGER size of the space to be allocated in the literals table for this string. The default size is the length of the string itself, and the maximum size is 5120 characters. If the string is to be translated, and you believe the translation will produce a longer string, you should allow for that increased space here.

To specify one or more values, simply type them into the appropriate field.
Traversal-path editor

The button shown is available in the Property Sheet dialog box for frame and dialog box objects:

Under Windows, repeatedly pressing the TAB key causes the input focus to shift from one widget to another within a frame. The default order in which the widgets are visited is left-to-right, top-to-bottom. You can change this default order using the Tab Editor. The Tab Editor is available through the property sheet for any frame or dialog widget, including the widgets managed by SmartFrames and SmartDialogs.

Click Tab Editor to open the Tab Editor dialog box, shown in Figure 59.

![Tab Editor dialog box]

Figure 59: Tab Editor dialog box

The three areas of interest are:

- The combo box that displays the current Tabbing Options.
- The list of widgets that will be traversed.
- The buttons that control how the items in the list are ordered.

Initially, the Tabbing Options is set to Default. In addition to the Default ordering, there are four predefined orderings, plus Custom. One of the predefined orderings will be the same as the Default order. In English-speaking countries among others, this is the Left-to-Right By Rows order.

To impose one of the predefined traversal orderings, select it from the list of options. The order of the widgets in the objects list changes accordingly.

To define a special traversal order:

1. Select Custom as the Tabbing Option. This enables the four Move buttons.

2. Use the Move buttons to reorder the widgets in the objects list. The items will be visited in the order in which they appear in this list.
3. Click OK.
Temp-tables maintenance

The button shown is available in the Procedure Settings dialog box:

The editor is also called automatically when you choose to define a temp-table in a SmartDataObject.

Temp-tables are temporary (scratch) tables. You might choose to create and use a temp-table to avoid the overhead of manipulating a large original table. By selecting out only those records that are of interest, and creating from that subset a temp-table, you can make subsequent processing faster or more convenient by some large factor.

Temp-tables have these characteristics:

- **Single-user** — Unlike regular database tables, you cannot make the same temp-table available to more than one user. They are session-bound.

- **Temporary** — Temp-tables never outlast the session in which they are created, and might have a much shorter lifespan than that. You can choose to make the table:
  - **Local** — (Default). Creates a new local table. A local table is available only to the defining procedure, and is destroyed when that procedure terminates.
  - **Shared** — Specifies that the table is not to be created, but is being shared by the calling procedure that did create it, within the current session.
  - **New Shared** — Creates a new table and allows it to be shared by called procedures in the same session, if they declare the table Shared.
  - **New Global Shared** — Creates a new table and allows it to be shared by all other procedures in the session that also declare the table New Global Shared. Note that although all procedures must use the New syntax, the table is allocated only once.

Temp-tables can be declared NO-UNDO, which improves performance by eliminating the overhead of journaling. In AppBuilder, temp-tables are created NO-UNDO by default.

Temporary table storage can be allocated in memory or on disk. There are some differences in the characteristics of a table depending on where it resides. See OpenEdge Getting Started: ABL Essentials for a discussion of these differences.

To allocate a temp-table:

1. Choose Tools → Procedure Settings. When that dialog box opens, click the Temp-Tables button (the drum icon). The Temp-Table Maintenance dialog box appears:
2. Click **Add** to create a temp-table. The **Table Selector** dialog box appears, showing the currently connected databases:
3. Choose a database, if necessary, and the table you wish to copy from. Click OK. The Selector dialog box closes and your selection appears in the Temp-Table Maintenance dialog box, as shown:

![Temp-Table Maintenance dialog box](image)

Note that AppBuilder always defines the temp-table as being LIKE the reference table.

4. Modify the default properties, if they do not suit your purposes, and click OK. The default properties are:

- Allocation on disk (temp-table) rather than memory (buffer).
- **Local** scope rather than **Shared** or **Global Shared**.
- NO-UNDO.
- Name same as reference-table name. You might wish to change this to more clearly identify the reason you are using a temporary copy of the table.
- No additional fields. You can define additional fields, but they are not equivalent in all ways to the actual fields in the database records. You cannot refer to additional fields in a query, for example.

Note that this editor does not create code to populate the table. You must do that by hand, if the object in your application expects to find records in the table.
Text style selector and editor

The button shown here is available in the property sheet of most widgets:

This button also appears in the Column Editor dialog box for data browser widgets, where you can set the font for column labels separately.

AppBuilder provides a fonts table similar in principle to its color table. Rather than specify each change of type style-font, weight and slant, point size, and attributes such as underlining on the fly, you define them in advance, with each definition occupying a slot in the fonts table. You then apply all characteristics at once by specifying a slot number.

As with the use of color, be sparing with font changes. Although at one time it was very common to use many sizes and styles of type in a single composition, today too many font changes can create an unfavorable impression on the user. Used carefully, special changes in the type can help focus the user's attention in a good way. Because of readability issues, fonts need to be selected with even more care than colors if they are to give the desired result.

Many companies use one or more particular fonts as part of their corporate identity program. If you are able to use those fonts too, without compromising readability, you might be able to gain a competitive advantage when marketing your software to such a company.

Type style selections apply to all text displayed in connection with a given widget. For example, you cannot choose one style for the column labels on a Browse widget and another style for the data it displays. Whatever style you select will be applied to both.

Choosing a type style

You can assign type styles on a per-widget basis. Each widget that displays text, whether as labels, data, or both, can have its own type style. Both labels and data will be displayed in the selected style; you cannot select one style for the labels and another for the data in AppBuilder. You can write code to do that if it is important to your design.

Generally speaking, you should choose the same style for most if not all of the widgets in your application. Make each extra type style count.

To assign a type style to a widget:

1. Open the property sheet for the widget. If the widget is being displayed and managed by a SmartObject, you must click the object's menu button and choose Edit Master to get access to that widget.

2. When the Property Sheet dialog box appears, click the type style button (the AAa icon). The Choose Font dialog box appears:
3. If necessary, click on the arrowhead buttons until the font sample you want to use is in view. Click it, and the thick outline appears, indicating selection.

4. Click OK to dismiss the Choose dialog box. Click OK to dismiss the property sheet. You should see your choice of type style reflected in the widget.

### Defining a type style

Use the Choose Font dialog to define a type style.

#### To define a new type style or edit an existing one:

1. Open the property sheet for a widget. Click on the Type style button (the AAh icon). The Choose Font dialog box appears:

2. Unless you also want to change the font being used for the current widget, make a note of which slot is current so that you can restore it before you exit this font-editing session.

3. Slots 0 through 7 have predefined styles that are not editable. You can assign styles to slots 8 through 255. Click the right arrowhead button until slot 8 appears.
4. Double-click slot 8. The **Font** dialog box appears:

![Font Dialog Box](image)

5. Choose a face, a weight and slant, a point size, and attributes (underline, etc.). Unless you are creating an application for a market that requires a special encoding (Greek, Cyrillic, etc.), be sure the **Script** setting is **Western**.

---

**Caution:** Remember that the fonts being presented to you by this dialog box are those you have installed on your development system. The fonts you choose here will not necessarily be available to the users of your application unless you provide them as part of your software distribution package. Unless you are prepared to do that, you should choose only those fonts that you know are supplied with the operating system.

---

6. Click **OK** to dismiss the **Font** dialog box. Your choices are reflected in the sample text in the slot. In this example, it shows the result of choosing 10 point Arial Bold with underlining:

![Choose Font Dialog Box](image)

7. Unless you want your definition discarded at the end of the current AppBuilder session, click **Save Font Settings** to make your definition permanent.

8. Click on the slot you noted in Step 2. If you want to change the type style for the current widget, click on that slot instead.

9. Click on **OK** to dismiss the **Choose Font** dialog box. Click on **OK** to dismiss the **Property Sheet** dialog box.
Multiple Layouts

This appendix describes how to use multiple layouts to build your applications. In addition, it explains how to use AppBuilder to run and test applications for a character-based user interface.

This appendix discusses the following topics:

- Why use multiple layouts?
- What is a layout?
- Two types of layouts
- Creating alternate layouts
- Selecting a predefined alternate layout
- Modifying layouts with layout inheritance
- How multiple layouts work: a look at the code
- Alternate layout limitations
- Switching between layouts at run time
- Simulating character applications
- Running character applications
- Multiple layouts for SmartObjects
Why use multiple layouts?

The following list identifies just a few of many different usages you might consider to employ multiple layouts:

- If you plan to run an application in different run-time environments such as Windows and a character-based terminal, you might want to adjust the application’s interface for each environment. If you are using SmartObjects, you might want to build a single master file for a SmartDataViewer or SmartContainer that provides a choice of visualizations. One solution is either to maintain a separate version of the application for each environment or to create a separate SmartObject instance for each visualization. This approach requires that you maintain and deploy multiple sets of source code.

- Another solution is to use the AppBuilder’s capability to support multiple layouts in a single procedure file. The advantage of this approach is that you maintain and deploy one set of source files for an application. When you run a procedure file that contains multiple layouts, the procedure file adjusts its interface to suit the current run-time environment. You can also switch between layouts at run time.

- Multiple layouts can help you internationalize an application. For example, you might have an application that helps you to distribute products globally. Since different countries have different address formats and information requirements, your application can employ multiple layouts to effectively address this addressing issue.

For more information on multiple layouts and international considerations, see OpenEdge Development: Internationalizing Applications.
What is a layout?

A layout can be thought of as a collection of objects and associated property settings. These property settings determine how the objects appear when you run the application. Each layout has a name and an associated run-time expression. Run-time expressions evaluate to TRUE or FALSE, and determine which layout is presented during a specific session. Typically the same set of run-time expressions will appear for all procedure files in an application. For SmartObjects, layouts are typically associated with values of the ObjectLayout instance property.

When you run a procedure file, it evaluates the run-time expressions (if any) for the available layouts and, if a layout’s expression evaluates to TRUE, uses that layout. For a SmartObject, this run-time expression determines the setting of the DefaultLayout property. If the SmartObject has no ObjectLayout property setting, it uses the DefaultLayout property setting to determine the layout. When the procedure file determines that it will use a particular layout, the procedure file executes for that layout a CASE statement that contains all of the property settings assigned for the layout.

The AppBuilder generates a CASE statement that contains an entry for each layout in the procedure file. The CASE statement is contained within the internal procedure named {&LAYOUT-VARIABLE} variables. This procedure name resolves to the name of the procedure file’s window, with “-Layouts” appended. For example, if the window name is WINDOW-1, the name of this procedure is WINDOW-1-Layouts. For more information about how layouts are implemented within a procedure file, see the “How multiple layouts work: a look at the code” section on page 398.

At design time, a layout is visually manifested in the design window. When you switch between layouts in the design window, the AppBuilder alters the appearance of the design window to match the characteristics of the new layout.
Two types of layouts

A procedure file can contain two types of layouts:

- **Master layout** — The main layout of the application. A procedure file has one master layout.

- **Alternate layout** — An additional layout for a specific run-time environment. A procedure file can have multiple alternate layouts.

The following sections describe the characteristics of these types of layouts.

### Master layout

The master layout is what the AppBuilder regards as the main layout of the procedure file. When you first create a procedure file, you see the master layout in the design window. If you do not create any alternate layouts, you see the master layout when you run the procedure file. You also see the master layout if the run-time expressions for all of the alternate layouts evaluate to `FALSE`.

It is helpful to think of the master layout as the compile-time layout, or the layout as it appears to the ABL Virtual Machine (AVM). Unlike other layouts, the master layout does not necessarily require additional property assignments. Alternate layouts, in contrast, are implemented solely through the use of run-time property assignments.

The master layout consists of the following elements:

- All of the static widget definitions generated by the AppBuilder in the procedure file.

- All of the property assignments, if any, in the Runtime Attributes and AppBuilder Settings code section.

- The procedure file’s window (a dynamic widget) and any ActiveX control frames.

- A `CASE` statement entry for "Master Layout".

The master layout never has a run-time expression associated with it.

If desirable, you can run the "Master Layout" entry or any other `CASE` statement entry from within the procedure file. This allows you to alternate programmatically between layouts at run time. For more information, see the “Switching between layouts at run time” section on page 403.

### Alternate layout

An alternate layout is a layout that you create for a specific run-time instance. For each alternate layout that you create, you supply a name, an optional run-time expression, and the emulation style (graphical or character). At run time, the procedure file tests any run-time expression, and if the expression evaluates to `TRUE`, the procedure file uses that layout, executing the appropriate `CASE` statement entry. If the procedure file is a SmartObject that has an `ObjectLayout` property setting, the SmartObject uses the specified layout, executing the appropriate `CASE` statement entry. The procedure file thus determines the layout before enabling or displaying any widgets. For more
Two types of layouts

information about creating an alternate layout, see the “Creating alternate layouts” section on page 391.

Standard layouts

Standard layouts are alternate layouts with predefined run-time expressions. The AppBuilder predefines these expressions for three primary OpenEdge run-time environments: character, MS-Windows, and MS-WIN95.

Table 15 lists the standard layouts.

Table 15: Standard layouts and run-time expressions

<table>
<thead>
<tr>
<th>Layout name</th>
<th>Run-time expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>Standard Character</td>
<td>SESSION:DISPLAY-TYPE = 'TTY':U</td>
</tr>
<tr>
<td>Standard MS-Windows</td>
<td>SESSION:WINDOW-SYSTEM = 'Windows':U</td>
</tr>
<tr>
<td>Standard Windows 95</td>
<td>SESSION:WINDOW-SYSTEM = 'MS-WIN95':U</td>
</tr>
</tbody>
</table>

If you decide to use a standard layout, you cannot change the layout’s name or run-time expression.

Layouts at design time

When you create or select an alternate layout, the AppBuilder changes the design window to assume the alternate layout’s characteristics. The AppBuilder also reflects the characteristics of the layout in the property sheets of its widgets. Once widgets are in an alternate layout, you can then manipulate them within the layout or change their properties. Within an alternate layout, you can modify some but not all of the widgets’ properties. For more information, see the “Alternate layout limitations” section on page 402.

The changes you make in an alternate layout visually affect that layout only, but there are some exceptions. For more information, see the “Modifying layouts with layout inheritance” section on page 394. For example, suppose you start with the master layout shown in Figure 60.

Figure 60: Master layout
Now, suppose that you choose the **Standard Character** layout option in the **Alternate Layout** dialog box. The AppBuilder now changes the design window to look like the one in Figure 61.

![Character alternate layout](image)

**Figure 61:**  **Character alternate layout**

Notice that image disappears and the buttons appear as text. Also, the grid changes to reflect the number of lines in a character terminal. For more information, see the “Simulating character applications” section on page 404.

All property sheets for the widgets in this layout reflect the characteristics of the new layout. In this example, the property sheet of the window reflects a change in size: character windows are not resizable and have a default size of 80 x 21 character units. Also, since the image does not appear in this layout, you cannot access its property sheet from within the layout. However, you can use the **List Objects** dialog box to access the image’s property sheet. For more information about the **List Objects** dialog box, see the “Tool bar” section on page 64.

In general, when you initially create an alternate layout, the AppBuilder tries to keep all objects and properties unchanged from the prior layout.

**Alternate layout scope**

When you create a layout, it is available for all procedure files that you edit in the AppBuilder session. You do not have to define the layout individually for every procedure file that uses it.

The AppBuilder maintains a cumulative list of nonstandard layouts for each AppBuilder session. This list expands as you edit procedure files with previously defined layouts. Restarting the AppBuilder resets the list to include only the standard layouts and those alternate layouts used by the procedure files that you open.
Creating alternate layouts

The **Layout** menu contains the alternate layout options.

To create an alternate layout:

1. Choose **Layout → Alternate Layout** from the AppBuilder main menu. The **Alternate Layout** dialog box appears:

2. Click **New**. The **New Layout Name** dialog box appears:

3. Type the name of the layout, then click **OK**. The AppBuilder returns to the **Alternate Layout** dialog box.

4. Activate the GUI-based radio button to create a graphical look for the design window. Activate the Character-based radio button to simulate a character design window.

5. Type the run-time expression to test in the Expression panel, then click **OK**.

Any valid ABL expression that resolves to a LOGICAL value is acceptable. However, if you use a character string within the expression, place the string in single quotes (') not double quotes (" "). If you need to use embedded quotation marks, “escape” the quotation marks with the tilde (~) character. This convention helps the AppBuilder to generate code that avoids compiler ambiguities.

When you enter an expression, you can optionally enter a comment that describes the alternate layout. The AppBuilder places this comment in the Runtime Properties and AppBuilder Settings section of the procedure file, where other developers can see it. Enter the comment by typing it in the Comment fill-in field in the Custom Layout dialog box.
Appendix B: Multiple Layouts

You have finished creating the alternate layout. The AppBuilder redisplay your design window, with the name of the alternate layout in the title bar.

**Note:** The Alternate Layout dialog box allows you to add, delete, or modify only one alternate layout at a time.
Selecting a predefined alternate layout

The **Alternate Layouts** dialog box lets you select predefined layouts.

To select a layout that has already been defined:

1. Choose **Layouts** → **Alternate Layout** from the AppBuilder main menu. The **Alternate Layout** dialog box appears.
2. Select the standard alternate layout that you want from the **Layout** combo box.
3. Click **OK**.

If you select a standard layout, you cannot change its expression or name. However, you can modify the expression and name of a nonstandard alternate layout.
Modifying layouts with layout inheritance

In general, if you make a change to the master layout, such as adding a button, the AppBuilder automatically adds the same button to all of the other layouts in the application. Similarly, if you change the size (or other property) of a widget in the master layout, that change is also reflected in the other layouts in the application. This process of automatically passing on the master layout’s characteristics to alternate layouts is called layout inheritance.

Within each alternate layout, you can explicitly override inheritance on a property-by-property basis for each widget. You can do this by manipulating the widgets or by changing their properties. For example, if you change the color of a button in an alternate layout, it disinherits that property from the master. No matter how you change the color of the button in the master, the alternate layout is unaffected, and vice versa.

**Note:** Not all properties can be disinherited. Some properties can only have one value for all layouts. Such properties are insensitive in the widget’s property sheet and cannot be changed.

You can also override layout inheritance on a widget-by-widget basis by inserting a widget into an alternate layout or by removing a widget from the alternate layout.

You can re-establish layout inheritance for a widget on a property-by-property basis. To do this, access the widget’s advanced property sheet and choose the Sync with Master button. For more information, see the “Re-establishing layout inheritance” section on page 396.

**Layout inheritance behavior at run time**

At run time, inheritance always occurs from the master layout to all other layouts in the procedure file. However, inheritance is conditional in that a character layout does not inherit all of the widgets or properties in a graphical layout, and inheritance can be explicitly overridden.

**Character layout inheritance**

If the character-mode AVM does not support a particular widget, a character layout cannot inherit the widget even if it appears in the master layout. Similarly, if the character-mode AVM does not support a particular property for a widget, the character layout cannot inherit the property. For example, the height of fill-ins, combo boxes, toggle boxes, buttons, and text widgets is always 1 in a character interface.

When you create a character alternate layout, the AppBuilder changes the appearance of the design window and the widgets within the design window to fit within the limitations of a character environment. Thus, buttons can only be one line high, and the character window has a default width of 80 character units and a height of 21 character units. For more information, see the “Simulating character applications” section on page 404.

**Overriding layout inheritance**

If you change a property of a widget in an alternate layout, that layout no longer inherits the property from the master layout unless you explicitly re-establish layout inheritance.
Also, if you insert a widget into an alternate layout, or delete a widget from an alternate layout, you disinherit the widget from the master layout.
There are two special cases:

- If you change either coordinate of a widget’s position, the other coordinate is disinherited as well. You must synchronize both coordinates with the master layout to re-establish layout inheritance.

- If you change either dimension of a widget, the other dimension is disinherited as well. You must synchronize both dimensions to re-establish layout inheritance.

**Layout inheritance behavior at design time**

When you create a new layout at design time, it inherits the characteristics of the current layout, even if the current layout is not the master layout. The new layout also disinherits each property that the current layout disinherits from the master. However, at run time, layout inheritance occurs between the new alternate layout and the master layout.

**Re-establishing layout inheritance**

The *Sync with Master* function lets you reapply inheritance.

To re-establish layout inheritance:

1. While in an alternate layout, open the advanced property sheet for the widget whose layout inheritance is to be re-established, then click *Sync With Master*. The *Sync With Master* dialog box appears:

   ![](image)

   This dialog box displays, for the current widget, all of the property discrepancies between the master and alternate layout. You can re-establish layout inheritance in two ways:

   - Have the master adopt the properties of the alternate layout. This changes the widget’s definition in the master layout.

   - Have the alternate layout adopt the properties of the master layout. This changes the properties of the alternate layout to match those of the master layout.

2. Select the property to synchronize.
3. Click the button that indicates how to synchronize the property:

- If you click **Alternate Reverts to Master Value**, a greater than symbol (>) appears to the right of the **Master Layout Column**. This indicates that the alternate layout adopts the property setting from the master layout.

- If you click **Master Updates to Alternate Value**, a less than symbol (<) appears to the right of the **Master Layout Column**. This indicates that the master layout adopts the property setting from the alternate layout.

- To remove any synchronization choice, click the center button between **Alternate Reverts to Master Value** and **Master Updates to Alternate Value**.

If neither symbol appears, the properties will not be synchronized.

An alternate technique to indicate property synchronization is to repeatedly double-click on the property in the selection list. As you double-click on the property, the AppBuilder rotates among the greater than (>) symbol, the less than (<) symbol, and no symbol.

4. When you finish specifying how to synchronize the properties, click **OK**.

The AppBuilder synchronizes the properties according to the button you choose. The AppBuilder also re-establishes inheritance for the property, with two exceptions:

- If you change either coordinate of a widget's position, the other coordinate is disinherit as well. You must synchronize both coordinates with the master layout to re-establish layout inheritance.

- If you change either dimension of a widget, the other dimension is disinherit as well. You must synchronize both dimensions with the master layout to re-establish layout inheritance.
How multiple layouts work: a look at the code

Within a procedure file, the AppBuilder supports an alternate layout with the following code:

- Run-time Properties and AppBuilder Settings code section.
- Layout cases (**&LAYOUT-VARIABLE**) variables) internal procedure.
- Enable_Ui internal procedure.

Run-time properties and AppBuilder settings

For each alternate layout, the AppBuilder places an IF statement in the Run-time Properties and AppBuilder Settings code section. This IF statement checks to see whether the layout's run-time expression evaluates to TRUE. If so, this statement runs the layout case's internal procedure, passing to it the name of the layout as an input parameter.

For example, the multi-layout run-time adjustments code appears as follows:

```c
/* _MULTI-LAYOUT-RUN-TIME-ADJUSTMENTS */

/* LAYOUT-NAME: "Standard Character"
 LAYOUT-TYPE: CHARACTER
 EXPRESSION: SESSION:DISPLAY-TYPE = 'TTY':U
 COMMENT: This layout is the standard layout specification for a customized Character based terminal. It is usually selected to modify a window that has a GUI based master layout. */

IF SESSION:DISPLAY-TYPE = 'TTY':U THEN
  RUN C-Win-layouts (INPUT 'Standard Character':U) NO-ERROR.

/* LAYOUT-NAME: "Standard MS Windows"
 LAYOUT-TYPE: GUI
 EXPRESSION: SESSION:WINDOW-SYSTEM = 'Windows':U
 COMMENT: This layout is the standard layout specification for a customized MS Windows window. It is usually selected to modify a window that needs to have a standard "MS Windows" look. */

ELSE IF SESSION:WINDOW-SYSTEM = 'Windows':U THEN
  RUN C-Win-layouts (INPUT 'Standard MS Windows':U) NO-ERROR.

/* LAYOUT-NAME: "Standard Windows 95"
 LAYOUT-TYPE: GUI
 EXPRESSION: SESSION:WINDOW-SYSTEM = 'MS-WIN95':U
 COMMENT: This layout is the standard layout specification for a customized Windows 95 window. It is usually selected to modify a window that needs to have a standard "Windows 95" look. */

ELSE IF SESSION:WINDOW-SYSTEM = 'MS-WIN95':U THEN
  RUN C-Win-layouts (INPUT 'Standard Windows 95':U) NO-ERROR.

/* END-OF-LAYOUT-DEFINITIONS */

IF SESSION:DISPLAY-TYPE = 'GUI':U AND VALID-HANDLE(C-Win) THEN
  C-Win:HIDDEN = no.
```
If the expression $\text{SESSION:WINDOW-SYSTEM} = \text{'Windows':U}$ evaluates to TRUE, this IF statement passes the input parameter ‘Standard MS Windows’ to the layout cases internal procedure. For SmartObjects, the DefaultLayout property is set. This is used to run the appropriate layout case later, when the SmartObject is initialized.

Thus, for SmartObjects, the multi-layout run-time adjustments code appears as follows:

```plaintext
/* _MULTI-LAYOUT-RUN-TIME-ADJUSTMENTS */
/* LAYOUT-NAME: "Standard Character"
 LAYOUT-TYPE: CHARACTER
 EXPRESS:  \text{SESSION:DISPLAY-TYPE} = \text{'TTY':U}
 COMMENT: This layout is the standard layout specification for a customized Character based terminal. It is usually selected to modify a window that has a GUI based master layout.
 */
IF \text{SESSION:DISPLAY-TYPE} = \text{'TTY':U} THEN
 DYNAMIC-FUNCTION('setDefaultLayout':U, 'Standard Character':U) NO-ERROR.

/* LAYOUT-NAME: "Standard MS Windows"
 LAYOUT-TYPE: GUI
 EXPRESS: \text{SESSION:WINDOW-SYSTEM} = \text{'Windows':U}
 COMMENT: This layout is the standard layout specification for a customized MS Windows window. It is usually selected to modify a window that needs to have a standard "MS Windows" look.
 */
ELSE IF \text{SESSION:WINDOW-SYSTEM} = \text{'Windows':U} THEN
 DYNAMIC-FUNCTION('setDefaultLayout':U, 'Standard MS Windows':U) NO-ERROR.

/* LAYOUT-NAME: "Standard Windows 95"
 LAYOUT-TYPE: GUI
 EXPRESS: \text{SESSION:WINDOW-SYSTEM} = \text{'MS-WIN95':U}
 COMMENT: This layout is the standard layout specification for a customized Windows 95 window. It is usually selected to modify a window that needs to have a standard "Windows 95" look.
 */
ELSE IF \text{SESSION:WINDOW-SYSTEM} = \text{'MS-WIN95':U} THEN
 DYNAMIC-FUNCTION('setDefaultLayout':U, 'Standard Windows 95':U) NO-ERROR.

```
Layout cases internal procedure

This internal procedure contains a `CASE` statement that has an entry for each layout in the procedure file. The `CASE` statement entry contains the run-time assignments for the layout. The Preprocessor reference `{&LAYOUT-VARIABLE}` resolves to the name of the window in the procedure file prefixed to -layout. Following is a sample layout case’s internal procedure. Note that the variable name `{&LAYOUT-VARIABLE}` is usually the same as `{&WINDOW-NAME}-layout`. The layout cases internal procedure is named `{&LAYOUT-VARIABLE}` variables, which in this sample resolves to `C-Win-layouts`:

Example 3: Layout cases internal procedure

```plaintext
PROCEDURE C-Win-layouts:
    DEFINE INPUT PARAMETER layout AS CHARACTER NO-UNDO.
    DEFINE VARIABLE lbl-hndl AS HANDLE NO-UNDO.
    DEFINE VARIABLE widg-pos AS DECIMAL NO-UNDO.
    /* Copy the name of the active layout into a variable accessible to the rest
       of this file. */
    C-Win-layout = layout.
    CASE layout:
        WHEN "Master Layout": U THEN DO:
            ASSIGN
                &IF '{&WINDOW-SYSTEM}' NE 'TTY': U &THEN
                C-Win:HIDDEN = yes &ENDIF
                C-Win:HEIGHT = 16.
            ASSIGN
                Btn_Done:HIDDEN IN FRAME DEFAULT-FRAME = yes
                Btn_Done:HEIGHT IN FRAME DEFAULT-FRAME = 1.14
                Btn_Done:ROW IN FRAME DEFAULT-FRAME = 3.62
            ASSIGN
                Btn_Help:HIDDEN IN FRAME DEFAULT-FRAME = yes
                Btn_Help:HEIGHT IN FRAME DEFAULT-FRAME = 1.14
                Btn_Help:ROW IN FRAME DEFAULT-FRAME = 3.38
        END. /* Master Layout Layout Case */
        WHEN "Standard Character": U THEN DO:
            ASSIGN
                Btn_Done:HIDDEN IN FRAME DEFAULT-FRAME = yes
                Btn_Done:HEIGHT IN FRAME DEFAULT-FRAME = 1
                Btn_Done:ROW IN FRAME DEFAULT-FRAME = 4
            ASSIGN
                Btn_Help:HIDDEN IN FRAME DEFAULT-FRAME = yes
                Btn_Help:HEIGHT IN FRAME DEFAULT-FRAME = 1
                Btn_Help:ROW IN FRAME DEFAULT-FRAME = 3 NO-ERROR.
        END. /* Standard Character Layout Case */
    END CASE.
END PROCEDURE. /* C-Win-layouts */
```
This sample contains **CASE** statement entries for two layouts, the master layout and the standard character layout. The **Btn_Help** button appears in the master layout but not in the standard character layout. The master layout also sets size properties to decimal character units because a graphical environment supports fractions of a character. However, in a character environment, they are set to integer character units.

**Enable_UI internal procedure**

The **Enable_UI** internal procedure controls whether widgets are enabled for specific layouts. This procedure is used only for non-SmartObject procedure files. It uses the **WHEN** option of the **ENABLE** statement to determine whether a widget in a SmartObject is enabled.

The following is a sample **Enable_UI** procedure:

```plaintext
PROCEDURE enable_UI :
/*------------------------------------------------------------------------
Purpose:     ENABLE the User Interface
Parameters:  <none>
Notes:       Here we display/view/enable the widgets in the user-interface. In addition, OPEN all queries associated with each FRAME and BROWSE. These statements here are based on the 'Other Settings' section of the widget Property Sheets.
------------------------------------------------------------------------*/

{&OPEN-QUERY-DEFAULT-FRAME}
GET FIRST DEFAULT-FRAME.
IF AVAILABLE Customer THEN
   DISPLAY Customer.Cust-Num Customer.Name
   WITH FRAME DEFAULT-FRAME IN WINDOW C-Win.
   ENABLE IMAGE-1 Btn_First Btn_Next Btn_Prev Btn_Last BROWSE-1
   Btn_Photo WHEN NOT (SESSION:DISPLAY-TYPE = 'TTY':U )
   WITH FRAME DEFAULT-FRAME IN WINDOW C-Win.
{&OPEN-BROWSERS-IN-QUERY-DEFAULT-FRAME}
VIEW C-Win.
END PROCEDURE.
```

In this example, the **Btn_Photo** is enabled only if the standard character layout is not used at run time.
Appendix B: Multiple Layouts

Alternate layout limitations

Alternate layouts are somewhat less flexible than the master layout. This section describes the limitations of alternate layouts.

Modifiable properties

Within an alternate layout, you can change some, but not all of the properties that you can change in the master layout. Table 16 lists the properties that you can change.

Table 16: Modifiable properties in alternate layouts

<table>
<thead>
<tr>
<th>BGColor</th>
<th>Graphic-Edge</th>
<th>Title-FGColor</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column</td>
<td>Height</td>
<td>Virtual-Height</td>
</tr>
<tr>
<td>Edge-Pixels</td>
<td>Row</td>
<td>Virtual-Width</td>
</tr>
<tr>
<td>FgColor</td>
<td>Separators</td>
<td>Visible</td>
</tr>
<tr>
<td>Filled</td>
<td>Three-D</td>
<td>Width</td>
</tr>
<tr>
<td>Font</td>
<td>Title-BGColor</td>
<td></td>
</tr>
</tbody>
</table>

Note: To exclude a widget from a particular alternate layout, set the Remove from Layout toggle box in the widget’s property sheet.

Text widgets in alternate layouts

You can insert text widgets only in the master layout. If the master layout contains a text widget, you cannot cut or change the properties of the widget in an alternate layout. However, you can simulate a text object in different layouts by using a fill-in object with no label and activating the View-As-Text toggle box in the fill-in’s property sheet. The content of the field will appear to be a static text object.

Combo boxes in alternate layouts

In an alternate layout, you can only modify the height of a simple combo box. You cannot modify the height of a drop-down or drop-down list.

SIZE-TO-FIT setting

The Size-To-Fit setting works only for the initial call to the master layout. In fact, when you change layouts, the width/height of the frame that you see is the design size, not the initial Size-To-Fit size; that is, there is a margin on the right and bottom, even if you choose to set the layout to the master layout.
Switching between layouts at run time

The multiple layout functionality that the AppBuilder provides is meant primarily to establish a layout once: when you run a procedure file. However, you can also switch among layouts at run time, if you write the necessary code to manage it.

Note: For SmartObjects, all of the code for switching among layouts at run time is managed by the ADM `setInstanceProperties()` function and `applyLayout()` procedure. For more information, see the “Applying SmartObject layouts at run time” section on page 413.

One way to switch among layouts is to have a trigger execute the `CASE` statement entries for the different layouts.

To have a trigger execute the `CASE` statement entries for the different layouts:

1. Execute the "Master Layout" `CASE` entry in the layout cases internal procedure with the following statement where the `{&LAYOUT-VARIABLE}` preprocessor name is set:

   ```plaintext
   RUN {&LAYOUT-VARIABLE}s (INPUT "Master Layout").
   ```

   This statement changes all of the run-time properties to match those of the master layout. This step is necessary because all of the other layouts change their settings relative to the master layout. Thus, before you can switch to a new layout, you should switch back to the master layout.

2. Execute the `CASE` entry for the layout you want. The following statement sets all of the layout’s properties that you specify:

   ```plaintext
   RUN {&LAYOUT-VARIABLE}s (INPUT "My Layout").
   ```

3. If necessary, write code that correctly enables the widgets in the new layout.

   If widgets are enabled differently from one layout to another, you cannot execute the `Enable_UI` procedure to do your enabling. The `Enable_UI` procedure enables widgets based on `WHEN` phrases built using the layouts’ associated run-time expressions. The explicit purpose of these run-time expressions is to identify a unique run-time environment. Since you want to switch layouts only within the same run-time environment, you must write your own code to handle the enabling.
Simulating character applications

To help you develop applications for character interfaces, the AppBuilder simulates character environments in its design windows. Within a character simulator window, the widgets appear as they would in a character environment, to the extent possible. For example, buttons appear as they do in character environments, but some other widgets, such as radio sets, have a graphical appearance. To see exactly how the widgets appear at run time, you must run the application in the character environment.

Note: You can run character applications directly from the AppBuilder. For instructions, see the “Running character applications” section on page 405.

There are some operations that you can perform on widgets in a graphical window that you cannot perform on widgets in the character simulator window. Make sure to consider the following when designing a character interface:

- You can size buttons horizontally but not vertically. The height of a button in a character layout is one character.
- A browser must be at least six characters high.
- A (horizontal) radio set must be at least three characters high.

When you create a new design window or dialog box, the New dialog box appears. Select TTY Window or TTY Dialog to put the master layout in character mode. In general, if you plan to have both character and graphical layouts, make the master layout graphical.
Running character applications

Use the AppBuilder’s **Character Run Window** to run character applications.

To run character-mode procedures and view them in actual character-mode format:

1. Start the broker process for all necessary application databases. For example:

   ```
   PROSERVE sports
   ```

2. Start the OpenEdge session and connect to the application database in multi-user mode.

3. When you are ready to run your character procedure, choose **Layout → Alternate Layout** from the AppBuilder main window.

4. On the **Alternate Layout** box, select **Standard Character** from the **Layout** combo box.

5. Choose **Compile → Run** from the main window.

   AppBuilder disables itself and opens the AppBuilder **Character Run Window**, which starts a AVM character client session. The Character client first connects to all the databases to which the AppBuilder is connected, then runs your character application.

6. To return to design mode in AppBuilder, exit the layout in the manner you designed for that layout; for example, by pressing the **ESC** key in the **Character Run Window**.

   The AppBuilder **Character Run Window** clears the running layout and displays a status message of “Procedure complete. Waiting for next run.” The AppBuilder enables itself so that you can make further changes to the character layout. Note that the character client session is still running and remains connected to the application databases, so that you can run the procedure again to test your changes.

7. To close the **Character Run Window**, choose **Compile → Close Character Run Window** in the AppBuilder Main window.

   The character client session exits and the **Character Run Window** closes.

---

**Note:** If the **Character Run Window** does not close, you might have to delete the file that the AppBuilder uses to communicate with the **Character Run Window**. This file has the form `pnnnnnm.tty` and is located in the OpenEdge temporary file directory (by default, your current directory). When you delete this file, the character session ends and the **Character Run Window** closes.
Character client connection issues

If the application databases with which you are testing a character layout require connection parameters in addition to the database names, specify the database names and additional connection parameters in the default OpenEdge startup.pf file.
If you want to specify different connection parameters for the AppBuilder client and the Character Run client, create a parameter file for the character client, then set the AVM WinChar PROSTARTUP registry setting to the new parameter file. For example, if the AppBuilder client session has different code page settings than the character client, you can specify appropriate code page startup parameters in the character parameter file.

If you connect to additional databases during the AppBuilder session, you must specify only the database name and multi-user mode. The Character Run Window client will not recognize any additional connection options you specify, and running the character layout might fail to connect to the database.

Double-byte characters

The Character Run window does not support the display of double-byte characters. For more information about double-byte characters, see OpenEdge Development: Internationalizing Applications.
Multiple layouts for SmartObjects

Multiple layouts for SmartObjects are designed to provide alternate visualizations of a SmartObject, as might be required by use in different SmartContainers or by other functional criteria of the application, such as access privileges. Thus, the setup and initialization of a SmartObject layout is not primarily a function of the run-time environment, but of the SmartContainer logic that instantiates the SmartObject.

For SmartObjects, multiple layouts are supported by these ADM properties:

- **LayoutOptions** — Contains a comma-separated list of the layouts that you set up for a SmartObject in the AppBuilder at design time.

- **LayoutVariable** — Contains the layout that you choose (other than the default) for an instance of the SmartObject when you add it to a SmartContainer. (If you choose the default, the SmartObject uses the value of the DefaultLayout property.) This is also the variable that you set to change a SmartObject’s layout at run time.

- **DefaultLayout** — Contains the layout that the SmartObject uses if you do not set an **ObjectLayout** property value for an instance of the SmartObject. DefaultLayout is set based on the run-time settings established in the Alternate Layout dialog box. If DefaultLayout has no value, the SmartObject uses the master layout.

- **ObjectLayout** — Contains the layout that the SmartObject uses.

Unlike the run-time expressions used for basic procedure files, the setting of these properties does not immediately affect a SmartObject’s layout. Rather, the action of these properties depends on initialization of the SmartObject by its SmartContainer. At run time, the initializeObject() event procedure runs the layout cases internal procedure {&LAYOUT-VARIABLE} variables by running applyLayout. The applyLayout() event procedure uses the value of the ObjectLayout or DefaultLayout property to determine initial visualization for the SmartObject. At any point after initialization, you can choose a different layout for the SmartObject by setting and applying a different value to the ObjectLayout property (from LayoutOptions).
Creating SmartObject alternate layouts

You can create an alternate layout for a SmartObject or SmartContainer much like you do for a basic procedure file (see the “Creating alternate layouts” section on page 391). However, you should not enter a run-time expression to determine the active layout. Figure 62 shows the Alternate Layout dialog box that appears for a SmartObject.

![Figure 62: Alternate Layout dialog box for SmartObjects](image)

This example shows the setting for an alternate Layout, Address Information, created for the SmartObject. Note the Don't use Run-time Expression option. This appears only for SmartObjects and is turned on by default. To activate a run-time expression for this layout, turn off the option. The default setting when you turn it off is FALSE.

Modifying SmartObject layouts

You can modify and synchronize SmartObject layouts in the design window similar to basic procedure file layouts. (For more information, see the “Modifying layouts with layout inheritance” section on page 394.) However, SmartObject instances in a SmartContainer layout have additional features.

To illustrate working with SmartObject layouts, the rest of this section references a SmartDialog that contains a SmartDataViewer that has three layouts: a master and two alternates. The master layout, shown in Figure 63, contains many of the fields of the sports database Customer table, some of which overlay each other.

![Figure 63: SmartDataViewer master layout](image)
Each of the alternate layouts, shown in Figure 64 and Figure 65, displays or hides different sets of the fields in the master layout.

![Figure 64: SmartDataViewer Address alternate layout](image1)

![Figure 65: SmartDataViewer Balance alternate layout](image2)

In general, SmartObjects instances inherit the active layout of the parent SmartContainer in the AppBuilder. While the SmartContainer is in an alternate layout, you cannot set the `ObjectLayout` (or any other instance property) of the SmartObjects that it contains. To set the active layout of a SmartObject instance, the parent SmartContainer must be in the master layout. Also, once set, the layout for a SmartObject instance overrides any subsequent layout setting inherited from the parent SmartContainer. If you want the SmartContainer to change the layout of its SmartObjects dynamically, you can create an override `createObjects()` event procedure that sets the `ObjectLayout` properties of the SmartObjects after they are created.

**Setting layout options for SmartObject instances**

Several SmartObjects provided with OpenEdge include instance properties dialog boxes that allow you to set run-time options for a SmartObject instance. For more information, see the “SmartObject properties” section on page 373. You can set instance properties only for a SmartObject displayed in the master layout of the parent SmartContainer, in the example, a SmartDialog.
You can access the **Properties** dialog box for an instance in two ways. One is to click on the instance menu button to display the pop-up menu shown in Figure 66.

![Figure 66: SmartDataViewer menu button’s pop-up menu](image)

**Figure 66:** SmartDataViewer menu button’s pop-up menu

This allows you to go directly to the Instance **Properties** dialog box by clicking on Instance **Properties**. Alternatively, you can click on **Properties** (or double-click on the instance itself) to open the instance property sheet, then click on the **Edit** button to open the Instance **Properties** dialog box.

For the same SmartObject instance with the parent SmartContainer displayed in an alternate layout, the menu button’s pop-up menu changes to prevent you from modifying any instance properties, as shown in Figure 67.

![Figure 67: Menu button’s pop-up menu in alternate layout](image)

**Figure 67:** Menu button’s pop-up menu in alternate layout

In this case, the Instance **Properties** option is insensitive and the **Delete Instance** option is replaced with the **Remove from Layout** option. Both **Remove from Layout** and **Delete Instance** hide the SmartObject from view. However, **Remove from Layout** only hides the SmartObject, while **Delete Instance** actually deletes it from the SmartContainer. **Remove from Layout** is used for alternate layouts rather than **Delete Instance** because the SmartObject instance is still available from the master layout of the SmartContainer.
Also, the instance property sheet changes in a SmartContainer alternate layout, as shown in Figure 68.

![Property Sheet - b.wayout - Layout: Address Information](image)

**Figure 68:** Instance property sheet in alternate layout

This is the property sheet for the SmartDataViewer instance in an alternate layout. Note that the Edit button is insensitive, preventing editing of the instance properties. The **Remove from Layout** option, the **Layout** inherited from the SmartContainer, and the **Sync with Master** button are also added to the property sheet. The **Parameterize as Variable** option, normally available in the master layout, is also insensitive.

This example illustrates how you might have an alternate layout standard for the windows and dialog boxes of an entire application, while maintaining the ability to apply instance-specific layouts (**Layout** = **Balance Information**) for SmartObjects contained within these windows and dialog boxes. Thus, you might have two or more application visualizations in which the SmartObject instances retain the same functional layouts.

Two supported SmartObjects, SmartDataViewers and SmartDataBrowsers, support **ObjectLayout** as an instance property. You can set this property in the **Instance Properties** dialog box using the **Layout** combo box, as shown in Figure 69.

![Visual SmartObject Properties](image)

**Figure 69:** SmartDataViewer properties with layout options

**Note:** If the SmartObject has no alternate layouts, the **Layout** combo box is insensitive.
You get this particular **Instance Properties** dialog box for the SmartDataViewer instance shown in Figure 66, displayed in the SmartContainer master layout.

In general, the **Layout** combo box lists the `LayoutOptions` property values available for the SmartObject instance. These are the alternate layout names that you define for the SmartObject when you create or edit the SmartObject in the AppBuilder using the **Alternate Layout** dialog box (Figure 62). If the SmartObject has a visualization for an alternate layout (such as **Balance Information**), you can make it visible for the instance by selecting the **Layout** value. Once you select and confirm the layout (by clicking on **OK**), the visualization for the selected layout appears in the SmartContainer design window for that SmartObject instance (Figure 67). Note the difference in the SmartDataViewer instance layout between Figure 66 and Figure 67.

Regardless of which layout you set for the SmartContainer, the SmartObject instance always displays the selected layout, as indicated by the `ObjectLayout` instance property setting shown in Figure 68. This is true at run time as well as at design time, unless you explicitly create a run-time override of the instance layout. For more information on run-time layout overrides, see the “Applying SmartObject layouts at run time” section on page 413.

If you leave the instance layout setting as [default], the instance in the design window has no layout property setting and displays the SmartObject master layout or the current layout of the SmartContainer, if different. This setting also allows you to specify the initial layout for the instance by the run-time setting of the `DefaultLayout` property.

**Applying SmartObject layouts at run time**

You can reliably affect the layout of a SmartObject at run time in two ways:

- Set the SmartObject `ObjectLayout` property before SmartObject initialization and display, usually in a local version of the `createObjects()` event procedure.

- Set the SmartObject `ObjectLayout` property and apply it any time after SmartObject initialization.

Thus, you can set the initial SmartObject layout and change it as often as you like at run time.
Setting the initial layout

You can dynamically set the initial layout for your SmartObjects by creating a local createObjects() event procedure in the SmartContainer that parents the SmartObjects, as shown:

```pascal
/* Purpose: Super Override
Parameters: </doc>
Notes:

DEFINE VARIABLE v-link-hals AS CHARACTER NO-NULL.
DEFINE VARIABLE l AS INTEGER.
DEFINE VARIABLE h-mno AS HANDLE.

"" Code that executes PRIOR to standard behavior
""
RUN SUPER.

"" Code that executes AFTER standard behavior
""
/* Set handles for SmartObjects in this container */
RUN linkHandle = ADT.adb-broker-hdl
  < INPUT THIS-PROCEDURE,
    INPUT CONTAINER-TARGET : U,
    OUTPUT v-link-hals > .

/* Set initial SmartObject layouts */
DO l = 1 TO NUM-ENTRIES | v-link-hals ]
  h-mno = WIDGET-HANDLE | ENTRY ( t, v-link-hals | ]
  RUN set-attribute-list IN h-mno
    < INPUT Layout = '0 + p-layout > .
END]
END PROCEDURE.
```

The code after the RUN SUPER statement is what you might add to the local createObjects() procedure. This code finds all of the SmartObjects in the SmartContainer (SmartObjects that have Container-Target links to this container). Next, it returns each link handle (the procedure handle for each SmartObject) and sets the ObjectLayout property for the associated SmartObject.

**Note:** Setting a property for a SmartObject that does not recognize the specified property has no effect. In this case, only SmartDataViewers and SmartDataBrowsers respond to the setting of ObjectLayout.

The p-layout identifier in this example represents a character-string input parameter to the SmartContainer that holds the initial layout value. This assumes that the SmartContainer is called from some other procedure, perhaps with the actual p-layout value determined at run time.

Note that the initial setting of ObjectLayout occurs after the ADM createObjects() procedure executes. Thus, the SmartContainer changes all the SmartObject instance settings of ObjectLayout after the SmartContainer creates its SmartObjects but before it initializes them (using initializeObject()).
Changing layouts

You can change the layout of a SmartObject with multiple layouts at any time after initialization. For example, you might do this in a user interface trigger that explicitly changes the layout when the user clicks on a button, or in response to an expression value that determines what layout a particular user is permitted to see (for example, a security key). You might have a series of expressions in a `CASE` statement that sets a varying layout according to a variety of criteria.

In all of these cases you execute the following code, where `so-handle` is your SmartObject procedure handle and `chosen-layout` is the name that you have assigned to the alternate layout to be applied:

```plaintext
DYNAMIC-FUNCTION('setObjectLayout':U IN so-handle, chosen-layout).
RUN applyLayout IN so-handle.
```

Thus, for the Balance button shown in Figure 67, you can create a trigger like the following:

```plaintext
ON CHOOSE OF bBalance IN FRAME D-Dialog DO: /* Balance */
  DYNAMIC-FUNCTION('setObjectLayout':U IN h_v_cust,
                   "Balance Information":U).
  RUN applyLayout IN h_v_cust.
END.
```

Executing this code immediately redisplay the layout for the SmartObject specified by the `h_v_cust` handle. This code can execute anywhere inside or outside of the SmartObject as long as it occurs after SmartObject initialization and while the SmartObject is still instantiated.
Customizing AppBuilder

This appendix documents two techniques for customizing AppBuilder. It discusses the following topics:

- Creating custom object files
- Creating extended features (XFTRs)
- AppBuilder’s API
- Example using AppBuilder’s API

Note that you can also use ADE hooks to change the behavior of AppBuilder; however, this appendix does not discuss this technique. For information, see OpenEdge Development: Basic Development Tools (character only; information for Windows is in online help).

Note: Customizing AppBuilder, especially using XFTR features, is an advanced feature. You do not need to understand the material in this appendix to use AppBuilder effectively.
Custom object files and extended features

Two techniques for customizing AppBuilder are:

- **Creating custom object (.cst) files.**

  Custom object files determine which objects are available in AppBuilder. They determine the options on both the **New** dialog box (accessed by choosing **File** → **New** from AppBuilder’s main menu) and the **Object Palette**.

- **Creating Extended Features (XFTR).**

  An **Extended Feature**, or **XFTR**, is a custom code block that you write and place in a procedure file. At critical moments in the processing of the procedure file, AppBuilder passes control to the XFTR, which can then run its own ABL procedures. These procedures can interact with AppBuilder, calling the AppBuilder application program interface (API). You use XFTRs to perform a variety of customized processing, such as creating and deleting objects, modifying code sections, and creating custom preprocessor variables. Wizards and cue cards are examples of customized processing implemented with XFTRs.

The following sections describe these techniques.
Creating custom object files

A custom object file is a text file (normally with a .cst extension) that tells AppBuilder to work with your own custom widgets and SmartObjects. You can use a custom object file to control the appearance and behavior of the Object Palette and some aspects of the New dialog box.

Although you can create a custom object file from scratch, it is much simpler to copy and modify an existing custom object file. OpenEdge supplies default custom object files that you can copy and modify according to your application needs.

OpenEdge supplies different default custom object files depending on your AppBuilder licensing option. Table 17 identifies all the custom files in the current release and the object definitions they contain. The files you have depend on your AppBuilder license.

Table 17: Custom object files and their contents

<table>
<thead>
<tr>
<th>Filename</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>progress.cst</td>
<td>Basic Objects, SmartPanel, SmartFolder, SmartContainer, SmartWindow, SmartDialog, SmartFrame, Method Library, Structured Include, Structured Procedure</td>
</tr>
<tr>
<td>shared.cst</td>
<td>SmartDataObject</td>
</tr>
<tr>
<td>smart.cst</td>
<td>SmartDataBrowser and SmartDataViewer</td>
</tr>
<tr>
<td>activex.cst</td>
<td>CSSpin, CSComboBox, PSTimer</td>
</tr>
<tr>
<td>web.cst</td>
<td>CGI Wrapper, Frameset, HTML Mapping, Structured Include, Main, Structured Procedure, Report Template, Table, and Method Library</td>
</tr>
<tr>
<td>smartv8.cst</td>
<td>Version 8 SmartObject definitions</td>
</tr>
</tbody>
</table>

Note: The ActiveX control definitions that were in the Progress Version 8 cst file are now contained in the activex.cst file.

General coding rules

Here are some general comments on coding custom object files:

- You can put comments (/* ... */ ) anywhere in a custom object file.

- Custom object files must end with a blank line, otherwise you lose the last line of code.
Entry types

You can add four types of entries to a custom objects file:

- A button to the Object Palette
- A SmartObject to an Object Palette button pop-up menu
- A template to the New dialog box
- A custom widget to an Object Palette button pop-up menu

The following sections describe these entries.

Adding a button to the Object Palette

Use this type of entry to define your own object type and place it on the Object Palette:

Syntax

```plaintext
#object-type &Default
UP-IMAGE-FILE bitmap-file [X,Y]
DOWN-IMAGE-FILE bitmap-file [X,Y]
LABEL label-name

{   USE master-file-name
    NEW template-file-name
        [ DIRECTORY-LIST list FILTER filter TITLE title ]
    DIRECTORY-LIST list FILTER filter TITLE title
}

[ DB-CONNECT ]
```

#object-type &Default

Specifies the type of object to add to the Object Palette.

UP-IMAGE-FILE bitmap-file [X,Y]

Specifies the name of the bitmap file for object-type when deselected. To fit properly on the Object Palette, the image must be 28 by 28 pixels, including all shadows and highlights.

DOWN-IMAGE-FILE bitmap-file [X,Y]

Specifies the name of the bitmap file for object-type when selected. To fit properly on the Object Palette, the image must be 28 by 28 pixels, including all shadows and highlights.

LABEL label-name

Specifies the text for the label for object-type. This label appears on the Object Palette and in the Object Palette menu.
USE master-file-name

Specifies the name of the SmartObject master file to instantiate when
smartobject-type is selected from the Object Palette. If you specify USE, a
Choose Object dialog box does not appear.

NEW template-file-name

Specifies the template file that AppBuilder opens when the user performs a New
operation from Object Palette. You cannot use this option with the USE option.

DIRECTORY-LIST list

Specifies the directories that appear in the Choose dialog box for object-type.

FILTER filter

Specifies a comma-separated list of file search masks that appear in the Choose
dialog box for the current directory.

TITLE title

Specifies the title for the Choose dialog box for object-type.

DB-CONNECT

Specifies whether AppBuilder prompts you to connect a database (if one is not
connected) when you select the object-type. This is useful for data-aware
objects such as SmartDataViewers, SmartDataObjects, and SmartDataBrowsers.

The sample entry in Figure 70 adds a SmartObject type, specifically a
SmartDataBrowser.

Figure 70: Sample entry for SmartObject type

Note: You can also use the adecomm/_chosobj.w procedure in the src/adecomm.pl
procedure library to modify the Choose Object dialog box. For more
information, see OpenEdge Development: Basic Development Tools
(character only; information for Windows is in online help).
Adding a SmartObject to a palette button pop-up menu

Use this type of entry to add an object to the Object Palette’s pop-up menu for an object type. The new object you define also appears in the Object Palette’s submenu for the object type. This type of entry also allows you to select an object without first using the Choose dialog box. Before you create this type of entry, make sure that you have created the object type (see the “Adding a button to the Object Palette” section on page 420). For example:

Syntax

```plaintext
*smartobject-type    name
{  USE master-file
     | DIRECTORY-LIST list FILTER filter TITLE title
}
```

*smartobject-type

Specifies the name of an existing object type.

name

Specifies the name of the object as it appears on the Object Palette’s menus.

USE master-file

Specifies the name of the SmartObject master file to instantiate when name is selected from the Object Palette.

DIRECTORY-LIST list

Specifies the directories that appear in the Choose dialog box for smartobject-type.

FILTER filter

Specifies a comma-separated list of file search masks that appears in the Choose dialog box for the current directory.

TITLE title

Specifies the title for the Choose dialog box for smartobject-type.

The sample entries in Figure 71 add SmartObject masters from src/template/smart.cst.

Add four SmartPanel masters

```
*SmartPanel    NavigationPanel(&Icons)
USE            adm2/pnavico.w
*SmartPanel    UpdatePanel(&Standard)
USE            adm2/pnavlbl.w
*SmartPanel    NavigationPanel(&Labels)
USE            adm2/pudsav.w
*SmartPanel    CommitPanel
USE            adm2/pcommit.w
```

Figure 71: Sample entries for adding a SmartObject master
**Adding a new template**

The following type of entry allows you to define your own template, whose name appears in the **New** dialog box:

**Syntax**

```
{ 
  *NEW-CONTAINER 
  | *NEW-SMARTOBJECT TYPE name 
  | *NEW-PROCEDURE 
}
template-name
NEW-TEMPLATE template-file
```

*NEW-CONTAINER

Specifies that the template appears in the **New** dialog box when the **Containers** toggle box is selected. A container is either a window, a dialog box, or a SmartContainer.

*NEW-SMARTOBJECT

Specifies that the template appears in the **New** dialog box when the **SmartObjects** toggle box is selected.

**TYPE name**

Specifies the type of SmartObject. AppBuilder uses this value to determine whether to connect a database when the particular type of SmartObject is created.

*NEW-PROCEDURE

Specifies that the template appears in the **New** dialog box when the **Procedures** toggle box is selected. A procedure can be either a structured procedure file, a structured include file, or a method library.

**template-name**

Specifies the name of the template as it appears in the **New** dialog box.

**NEW-TEMPLATE template-file**

Specifies the pathname of the template file that AppBuilder opens when you select the template from the **New** dialog box.
The sample entries in Figure 72 define New templates.

![Sample entries for new templates](image)

**Adding a widget to a palette button pop-up menu**

You create and define custom widgets in a custom object file. The following is the syntax for adding custom widgets:

**Syntax**

```plaintext
*widget-type name
[ DESCRIPTION [ description-text-string ] ]
{ [ attribute value ] ...
  [ INHERIT name-of-entry ] ...
  [ trigger-block ] ...
} ...
RUN file-name
```

*widget-type

Specifies the type of custom widget to create. It must be one of the following:

- BROWSE
- BUTTON
- COMBO-BOX
- EDITOR
- FILL-IN
- FRAME
- IMAGE
- RADIO-SET
- RECTANGLE
- SELECTION-LIST
- TEXT
- TOGGLE-BOX

name

Specifies the display name of the custom widget as it appears on the Palette submenu (or pop-up menu on the Palette). After you choose a widget, AppBuilder displays `display-name`, followed by `widget-type`, in the status bar of AppBuilder main window.

DESCRIPTION [ description-text-string ]

Specifies the description of the widget. The description helps another developer to read and understand the intent of each custom widget.

attribute

Specifies an attribute to set for the widget. You can specify any attribute that you can also set from the widget’s property sheet. See Table 18, later in this appendix,
for a list of the attributes that you can specify and the widgets to which they can apply.

value

Specifies the value for attribute (based on the data type of the attribute).

INHERIT name-of-entry

Specifies the display name of another widget in the custom widgets file. The current widget inherits all of the attribute settings specified for the other widget. If attribute settings conflict, the latter setting applies.

trigger-block

Specifies a trigger for the custom widget, as shown:

**Syntax**

```
TRIGGER event
   DO [ trigger-code ] END.
END TRIGGER
```

In this syntax, event specifies an event to pair with the custom widget and trigger-code specifies the code statements to execute for the widget/event pair.

RUN file-name

Specifies a procedure to run immediately before the object is created. The procedure file can take two parameters:

- INPUT p_id AS INTEGER NO-UNDO - The context ID of the object being created.
- OUTPUT p_sct AS CHAR NO-UNDO - A list of new custom object entries to process.

You can have multiple RUN statements for a single custom object file; they are run sequentially. Do not end a RUN statement line with a trailing period (.).

Table 18 describes the attributes you can set in the custom objects file and the widgets to which they apply.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Data type</th>
<th>Allowed widgets</th>
</tr>
</thead>
<tbody>
<tr>
<td>AUTO-COMPLETION</td>
<td>Logical</td>
<td>COMBO BOX</td>
</tr>
<tr>
<td>AUTO-END-KEY</td>
<td>Logical</td>
<td>BUTTON</td>
</tr>
<tr>
<td>AUTO-GO</td>
<td>Logical</td>
<td>BUTTON</td>
</tr>
<tr>
<td>AUTO-INDENT</td>
<td>Logical</td>
<td>BUTTON, EDITOR, FILL-IN, SELECTION-LIST, TOGGLE-BOX</td>
</tr>
</tbody>
</table>
Table 18: Settable attributes for custom widgets

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Data type</th>
<th>Allowed widgets</th>
</tr>
</thead>
<tbody>
<tr>
<td>AUTO-RESIZE</td>
<td>Logical</td>
<td>BUTTON, EDITOR, FILL-IN, SELECTION-LIST, SLIDER, TOGGLE-BOX</td>
</tr>
<tr>
<td>AUTO-RETURN</td>
<td>Logical</td>
<td>FILL-IN</td>
</tr>
<tr>
<td>BGCOLOR</td>
<td>Integer</td>
<td>BROWSER, BUTTON, COMBO-BOX, EDITOR, FILL-IN, FRAME, IMAGE, RADIO-SET, RECTANGLE, SELECTION-LIST, SLIDER, TEXT, TOGGLE-BOX</td>
</tr>
<tr>
<td>BLANK</td>
<td>Logical</td>
<td>COMBO-BOX, FILL-IN</td>
</tr>
<tr>
<td>BOX-SELECTABLE</td>
<td>Logical</td>
<td>FRAME</td>
</tr>
<tr>
<td>CANCEL-BUTTON</td>
<td>Logical</td>
<td>BUTTON</td>
</tr>
<tr>
<td>COLUMN-SCROLLING</td>
<td>Logical</td>
<td>BROWSER</td>
</tr>
<tr>
<td>DATA-TYPE</td>
<td>Character</td>
<td>COMBO-BOX, FILL-IN, RADIO-SET</td>
</tr>
<tr>
<td>DEBLANK</td>
<td>Logical</td>
<td>COMBO-BOX, FILL-IN</td>
</tr>
<tr>
<td>DEFAULT-BUTTON</td>
<td>Logical</td>
<td>BUTTON</td>
</tr>
<tr>
<td>DEFAULT-STYLE</td>
<td>Logical</td>
<td>BUTTON</td>
</tr>
<tr>
<td>DISPLAY</td>
<td>Logical</td>
<td>COMBO-BOX, EDITOR, FILL-IN, RADIO-SET, SELECTION-LIST, SLIDER, TOGGLE-BOX</td>
</tr>
<tr>
<td>DOWN</td>
<td>Logical</td>
<td>FRAME</td>
</tr>
<tr>
<td>DRAG-ENABLED</td>
<td>Logical</td>
<td>SELECTION-LIST</td>
</tr>
<tr>
<td>EDGE-PIXELS</td>
<td>Integer</td>
<td>RECTANGLE</td>
</tr>
<tr>
<td>ENABLE</td>
<td>Logical</td>
<td>BUTTON, FILL-IN, IMAGE, RADIO-SET, SELECTION-LIST, SLIDER, TOGGLE-BOX</td>
</tr>
<tr>
<td>EXPAND</td>
<td>Logical</td>
<td>RADIO-SET</td>
</tr>
<tr>
<td>FGCOLOR</td>
<td>Integer</td>
<td>BROWSER, BUTTON, COMBO-BOX, EDITOR, FILL-IN, FRAME, IMAGE, RADIO-SET, RECTANGLE, SELECTION-LIST, SLIDER, TEXT, TOGGLE-BOX</td>
</tr>
<tr>
<td>FILLED</td>
<td>Logical</td>
<td>RECTANGLE</td>
</tr>
<tr>
<td>FONT</td>
<td>Integer</td>
<td>BROWSER, BUTTON, COMBO-BOX, EDITOR, FILL-IN, FRAME, RADIO-SET, SELECTION-LIST, SLIDER, TEXT, TOGGLE-BOX</td>
</tr>
<tr>
<td>FORMAT</td>
<td>Character</td>
<td>COMBO-BOX, FILL-IN</td>
</tr>
<tr>
<td>GRAPHIC-EDGE</td>
<td>Logical</td>
<td>RECTANGLE</td>
</tr>
<tr>
<td>Attribute</td>
<td>Data type</td>
<td>Allowed widgets</td>
</tr>
<tr>
<td>---------------------</td>
<td>-----------</td>
<td>---------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>HEIGHT</td>
<td>Integer</td>
<td>BROWSER, BUTTON, COMBO-BOX, EDITOR, FILL-IN, FRAME, IMAGE, RADIO-SET, RECTANGLE, SELECTION-LIST, SLIDER, TEXT, TOGGLE-BOX</td>
</tr>
<tr>
<td>HEIGHT-PIXELS</td>
<td>Integer</td>
<td>BROWSER, BUTTON, COMBO-BOX, EDITOR, FILL-IN, FRAME, IMAGE, RADIO-SET, RECTANGLE, SELECTION-LIST, SLIDER, TEXT, TOGGLE-BOX</td>
</tr>
<tr>
<td>HELP</td>
<td>Character</td>
<td>BUTTON, COMBO-BOX, EDITOR, FILL-IN, RADIO-SET, SELECTION-LIST, SLIDER, TOGGLE-BOX</td>
</tr>
<tr>
<td>HIDDEN</td>
<td>Logical</td>
<td>BROWSER, BUTTON, COMBO-BOX, EDITOR, FILL-IN, FRAME, IMAGE, RADIO-SET, RECTANGLE, SELECTION-LIST, SLIDER, TEXT, TOGGLE-BOX</td>
</tr>
<tr>
<td>HORIZONTAL</td>
<td>Logical</td>
<td>RADIO-SET, SLIDER</td>
</tr>
<tr>
<td>IMAGE-DOWN</td>
<td>Character</td>
<td>BUTTON</td>
</tr>
<tr>
<td>IMAGE-FILE</td>
<td>Character</td>
<td>BUTTON, IMAGE</td>
</tr>
<tr>
<td>IMAGE-INSENSITIVE</td>
<td>Character</td>
<td>BUTTON</td>
</tr>
<tr>
<td>INITIAL-VALUE</td>
<td>Character</td>
<td>COMBO-BOX, EDITOR, FILL-IN, RADIO-SET, SELECTION-LIST, SLIDER, TOGGLE-BOX</td>
</tr>
<tr>
<td>INNER-LINES</td>
<td>Integer</td>
<td>COMBO-BOX</td>
</tr>
<tr>
<td>KEEP-TAB-ORDER</td>
<td>Logical</td>
<td>FRAME</td>
</tr>
<tr>
<td>LABEL</td>
<td>Character</td>
<td>BROWSER, BUTTON, COMBO-BOX, FILL-IN, FRAME, TOGGLE-BOX</td>
</tr>
<tr>
<td>LARGE</td>
<td>Logical</td>
<td>EDITOR</td>
</tr>
<tr>
<td>LAYOUT-UNIT</td>
<td>Character or P</td>
<td>BROWSER, BUTTON, COMBO-BOX, EDITOR, FILL-IN, FRAME, IMAGE, RADIO-SET, RECTANGLE, SELECTION-LIST, SLIDER, TEXT, TOGGLE-BOX</td>
</tr>
<tr>
<td>LIST-ITEMS</td>
<td>Character</td>
<td>COMBO-BOX, RADIO-SET, SELECTION-LIST</td>
</tr>
<tr>
<td>LOCK-COLUMNS</td>
<td>Integer</td>
<td>BROWSER</td>
</tr>
<tr>
<td>MANUAL-HIGHLIGHT</td>
<td>Logical</td>
<td>BUTTON, COMBO-BOX, EDITOR, FILL-IN, FRAME, IMAGE, RADIO-SET, RECTANGLE, SELECTION-LIST, SLIDER, TEXT, TOGGLE-BOX</td>
</tr>
<tr>
<td>MAX CHARS</td>
<td>Integer</td>
<td>EDITOR</td>
</tr>
<tr>
<td>MAX-DATA-GUESS</td>
<td>Integer</td>
<td>BROWSER</td>
</tr>
<tr>
<td>Attribute</td>
<td>Data type</td>
<td>Allowed widgets</td>
</tr>
<tr>
<td>----------------------</td>
<td>-----------</td>
<td>---------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>MAX-VALUE</td>
<td>Integer</td>
<td>SLIDER</td>
</tr>
<tr>
<td>MIN-VALUE</td>
<td>Integer</td>
<td>SLIDER</td>
</tr>
<tr>
<td>MOVABLE</td>
<td>Logical</td>
<td>BUTTON, COMBO-BOX, EDITOR, FILL-IN, FRAME, IMAGE, RADIO-SET, RECTANGLE, SELECTION-LIST, SLIDER, TEXT, TOGGLE-BOX</td>
</tr>
<tr>
<td>MULTIPLE</td>
<td>Logical</td>
<td>BROWSER, SELECTION-LIST</td>
</tr>
<tr>
<td>NAME</td>
<td>Character</td>
<td>BROWSER, BUTTON, COMBO-BOX, EDITOR, FILL-IN, FRAME, IMAGE, RADIO-SET, RECTANGLE, SELECTION-LIST, SLIDER, TEXT, TOGGLE-BOX</td>
</tr>
<tr>
<td>NATIVE</td>
<td>Logical</td>
<td>FILL-IN</td>
</tr>
<tr>
<td>NO-BOX</td>
<td>Logical</td>
<td>BROWSER, FRAME</td>
</tr>
<tr>
<td>NO-HIDE</td>
<td>Logical</td>
<td>FRAME</td>
</tr>
<tr>
<td>NO-LABEL</td>
<td>Logical</td>
<td>COMBO-BOX, FILL-IN</td>
</tr>
<tr>
<td>NO-LABELS</td>
<td>Logical</td>
<td>BROWSER, FRAME</td>
</tr>
<tr>
<td>NO-UNDERLINE</td>
<td>Logical</td>
<td>FRAME</td>
</tr>
<tr>
<td>NO-UNDO</td>
<td>Logical</td>
<td>COMBO-BOX, EDITOR, FILL-IN, RADIO-SET, SELECTION-LIST, SLIDER, TOGGLE-BOX</td>
</tr>
<tr>
<td>NO-VALIDATE</td>
<td>Logical</td>
<td>FRAME</td>
</tr>
<tr>
<td>OPEN-QUERY</td>
<td>Logical</td>
<td>BROWSER, FRAME</td>
</tr>
<tr>
<td>OVERLAY</td>
<td>Logical</td>
<td>FRAME</td>
</tr>
<tr>
<td>PAGE-BOTTOM</td>
<td>Logical</td>
<td>FRAME</td>
</tr>
<tr>
<td>PAGE-TOP</td>
<td>Logical</td>
<td>FRAME</td>
</tr>
<tr>
<td>PRIVATE-DATA</td>
<td>Character</td>
<td>BROWSER, BUTTON, COMBO-BOX, EDITOR, FILL-IN, FRAME, IMAGE, RADIO-SET, RECTANGLE, SELECTION-LIST, SLIDER, TEXT, TOGGLE-BOX</td>
</tr>
<tr>
<td>RADIO-BUTTONS¹</td>
<td>Character</td>
<td>RADIO-SET</td>
</tr>
<tr>
<td>READ-ONLY</td>
<td>Logical</td>
<td>EDITOR</td>
</tr>
<tr>
<td>RESIZABLE</td>
<td>Logical</td>
<td>BUTTON, COMBO-BOX, EDITOR, FILL-IN, FRAME, IMAGE, RADIO-SET, RECTANGLE, SELECTION-LIST, SLIDER, TEXT, TOGGLE-BOX</td>
</tr>
<tr>
<td>RETAIN</td>
<td>Integer</td>
<td>FRAME</td>
</tr>
<tr>
<td>RETURN-INSERTED</td>
<td>Logical</td>
<td>EDITOR</td>
</tr>
</tbody>
</table>
### Table 18: Settable attributes for custom widgets

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Data type</th>
<th>Allowed widgets</th>
</tr>
</thead>
<tbody>
<tr>
<td>SCROLLABLE</td>
<td>Logical</td>
<td>FRAME</td>
</tr>
<tr>
<td>SCROLLBAR-HORIZONTAL</td>
<td>Logical</td>
<td>EDITOR, SELECTION-LIST</td>
</tr>
<tr>
<td>SCROLLBAR-VERTICAL</td>
<td>Logical</td>
<td>EDITOR, SELECTION-LIST</td>
</tr>
<tr>
<td>SELECTABLE</td>
<td>Logical</td>
<td>BUTTON, COMBO-BOX, EDITOR, FILL-IN, IMAGE, RADIO-SET, RECTANGLE, SELECTION-LIST, SLIDER, TOGGLE-BOX</td>
</tr>
<tr>
<td>SENSITIVE</td>
<td>Logical</td>
<td>FRAME</td>
</tr>
<tr>
<td>SEPARATORS</td>
<td>Logical</td>
<td>BROWSER</td>
</tr>
<tr>
<td>SHARED</td>
<td>Logical</td>
<td>BROWSER, COMBO-BOX, EDITOR, FILL-IN, FRAME, RADIO-SET, SELECTION-LIST, SLIDER, TOGGLE-BOX</td>
</tr>
<tr>
<td>SIDE-LABELS</td>
<td>Logical</td>
<td>FRAME</td>
</tr>
<tr>
<td>SORT</td>
<td>Logical</td>
<td>COMBO-BOX, SELECTION-LIST</td>
</tr>
<tr>
<td>TITLE</td>
<td>Logical</td>
<td>BROWSER, FRAME</td>
</tr>
<tr>
<td>TITLE-BAR</td>
<td>Logical</td>
<td>BROWSER, FRAME</td>
</tr>
<tr>
<td>TITLE-BGCOLOR</td>
<td>Integer</td>
<td>FRAME</td>
</tr>
<tr>
<td>TITLE-FGCOLOR</td>
<td>Integer</td>
<td>FRAME</td>
</tr>
<tr>
<td>TOP-ONLY</td>
<td>Logical</td>
<td>FRAME</td>
</tr>
<tr>
<td>UNIQUE-MATCH</td>
<td>Logical</td>
<td>COMBO BOX</td>
</tr>
<tr>
<td>VIEW</td>
<td>Logical</td>
<td>BROWSER, BUTTON, COMBO-BOX, EDITOR, FILL-IN, FRAME, IMAGE, RADIO-SET, RECTANGLE, SELECTION-LIST, SLIDER, TEXT, TOGGLE-BOX</td>
</tr>
<tr>
<td>VIEW-AS-TEXT</td>
<td>Logical</td>
<td>FILL-IN</td>
</tr>
<tr>
<td>VIRTUAL-HEIGHT</td>
<td>Integer</td>
<td>FRAME</td>
</tr>
<tr>
<td>VIRTUAL-HEIGHT-PIXELS</td>
<td>Integer</td>
<td>FRAME</td>
</tr>
<tr>
<td>VIRTUAL-WIDTH</td>
<td>Integer</td>
<td>FRAME</td>
</tr>
<tr>
<td>VIRTUAL-WIDTH-PIXELS</td>
<td>Integer</td>
<td>FRAME</td>
</tr>
<tr>
<td>WIDTH</td>
<td>Integer</td>
<td>BROWSER, BUTTON, COMBO-BOX, EDITOR, FILL-IN, FRAME, IMAGE, RADIO-SET, RECTANGLE, SELECTION-LIST, SLIDER, TEXT, TOGGLE-BOX</td>
</tr>
</tbody>
</table>
### Table 18: Settable attributes for custom widgets

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Data type</th>
<th>Allowed widgets</th>
</tr>
</thead>
<tbody>
<tr>
<td>WIDTH-PIXELS</td>
<td>Integer</td>
<td>BROWSER, BUTTON, COMBO-BOX, EDITOR, FILL-IN, FRAME, IMAGE, RADIO-SET, RECTANGLE, SELECTION-LIST, SLIDER, TEXT, TOGGLE-BOX</td>
</tr>
<tr>
<td>WORD-WRAP</td>
<td>Logical</td>
<td>EDITOR</td>
</tr>
</tbody>
</table>

1. The RADIO-BUTTONS attribute represents the labels and values for the individual buttons in a set, arranged in a comma-separated list. The following example identifies this format: label, value, label, value, label, value, and so forth. One label/value pair is defined for each button identified in a set.
Creating custom object files

Sample widget entry

The following sample entry is in the `src/template/progress.cst` file:

```cst
*BUTTON Ne&xt
DESCRIPTION Simple Navigation Button
INHERIT C&ustom Size/Color
LABEL &Next
NAME Btn_Next
TRIGGER CHOOSE
DO:
  &IF "(&PROCEDURE-TYPE)" EQ "SmartPanel" &THEN
  &IF "(&ADM-VERSION)" EQ "ADM1.1" &THEN
    RUN notify IN THIS-PROCEDURE ("get-next") NO-ERROR.
  &ELSE
    PUBLISH *fetchNext*:U.
  &ENDIF
  &ELSEIF "(&TABLES-IN-QUERY-(&FRAME-NAME))" NE "" &THEN
    /*
    ** This is a simple NEXT RECORD navigation button, useful for building
    ** test screens quickly. NOTE: if there are no tables in the query,
    ** then this code will not compile so use the preprocessor to skip it.
    */
    GET NEXT (&FRAME-NAME).
    IF NOT AVAILABLE {&FIRST-TABLE-IN-QUERY-(&FRAME-NAME)}
      THEN GET LAST (&FRAME-NAME).
    IF AVAILABLE {&FIRST-TABLE-IN-QUERY-(&FRAME-NAME)} THEN DO:
      DISPLAY {&FIELDS-IN-QUERY-(&FRAME-NAME)} WITH FRAME {&FRAME-NAME}.
      {&OPEN-BROWSERS-IN-QUERY-(&FRAME-NAME)}
    END.
  &ENDIF
END TRIGGER
```

If you analyze this sample entry one section at a time, you can see how to write your own custom widget entry. In this example:

- The first line specifies the widget type `BUTTON` and the display name for the widget:

  ```cst
  *BUTTON Ne&xt
  ```

  AppBuilder displays this name in the appropriate `Object Palette` menus. The ampersand (`&`) specifies that the “x” is the mnemonic on the `Object Palette` menu.

- The second line describes the button’s functionality:

  ```cst
  DESCRIPTION Simple Navigation Button
  ```

  AppBuilder does nothing with this description. The description is meant as a summary for someone reading the custom object file.
• The third line names another custom widget (Custom Size/Color) in the progress.cst file by using the widget’s display name:

```
INHERIT Custom Size/Color
```

The current widget (Next) inherits all of the attribute settings for the Custom Size/Color button. Where you place the INHERIT keyword affects how attributes are set. Later definitions override earlier definitions.

• The fourth line specifies the label of the button:

```
LABEL &Next
```

The ampersand (&) specifies that “N” is the mnemonic for the button.

• The fifth line specifies the widget name that AppBuilder uses internally to refer to the button:

```
NAME Btn_Next
```
Creating extended features (XFTRs)

An **XFTR** is a code block that you write to customize the behavior of AppBuilder. There are two uses for **XFTRs**:

- Adding custom run-time code
- Adding text blocks that will direct your own routines to interact with the user

An **XFTR** can be self-modifying; that is, change itself based on user action. **Figure 73** shows a sample **XFTR**.

```
&ANALYZE-SUSPEND _UIB-CODE-BLOCK _XFTR "SmartDataBrowserWizard" bTableWin _INLINE
/* Actions: adm2/support/_wizard.w ? ? adm2/support/_wizdel.p */
/* SmartDataBrowser Wizard
Welcome to the SmartDataBrowser Wizard! During the next few steps, the wizard will lead you through creating a SmartDataBrowser object. First you will choose a DataSource to supply data to the SmartDataBrowser, then you can specify the columns that will be displayed in the SmartDataBrowser. Press Next to proceed.
adm2/support/_wizntro.w,adm2/support/_wizds.w,adm2/support/_wizdfld.w,adm2/support/_wizend.w
*/
/* _UIB-CODE-BLOCK-END */
&ANALYZE-RESUME
```

**Figure 73:** **XFTR** in browser.w template

This code does not, by itself, perform any customized processing. However, it points to other ABL procedures (**adm2/support/_wizard.w** and **adm2/support/_wizdel.p**) that do perform customized processing. AppBuilder calls these procedures when significant AppBuilder events occur; for example, when a design window is realized or code is generated. Consequently, these procedures are called **XFTR** event handlers. An **XFTR** can reference up to five such procedures for AppBuilder events (see **Table 19**).

As this example illustrates, an **XFTR** has five sections:

- An opening **&ANALYZE-SUSPEND** directive (required)
- A comment that maps event types to event handlers (required)
- A comment that contains code passed to the event handlers (optional)
- A comment that closes the code block (required)
- A closing **&ANALYZE-RESUME** directive (required)

The sections that follow explain how to set up these sections.
The &ANALYZE-SUSPEND directive for XFTRs

An XFTR code block begins with an &ANALYZE-SUSPEND directive. This directive is required. This is its syntax for XFTR:

**Syntax**

```
&ANALYZE-SUSPEND UIB-CODE-BLOCK XFTR name object INLINE
```

The `name` value is a quoted string that specifies the name of the XFTR. The `object` value is an unquoted string with no embedded spaces that specifies a window name; if the procedure file has no window, specify this value as "Procedure".

The event-mapping comment

This comment maps various AppBuilder events to XFTR event handlers. It is parsed by AppBuilder and must be the first comment after the &ANALYZE-SUSPEND directive. **Figure 74** provides an example, and illustrates the components of this comment type.

![Figure 74: Event handler components](image)

Components 0 and 7 are standard comment delimiters. Component 1, which must end in a colon, is simply a title for the comment. Components 2 through 6 are space-delimited procedure names for the XFTR event handlers; each maps to a particular AppBuilder event, as follows:

- Position 2 maps to the **Realize** event.
- Position 3 maps to the **Edit** event.
- Position 4 maps to the **Destroy** event.
- Position 5 maps to the **Read** event.
- Position 6 maps to the **Write** event.

For example, in Figure 74, if an AppBuilder **Realize** event occurs, AppBuilder calls the `adm2/support/_wizard.w` event. Note that a question mark indicates that no event handler is specified for the corresponding event.
Table 19 summarizes AppBuilder events that you can map to XFTR event handlers.

<table>
<thead>
<tr>
<th>AppBuilder event</th>
<th>Description</th>
<th>User actions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Realize</td>
<td>Occurs when a design window is realized.</td>
<td>Opening a procedure file, creating a new procedure file, changing layouts, or changing size of a window</td>
</tr>
<tr>
<td>Edit</td>
<td>Occurs when AppBuilder presents an XFTR code block for editing.</td>
<td>Selecting an XFTR code section from the Section Editor’s List Sections dialog box</td>
</tr>
<tr>
<td>Destroy</td>
<td>Occurs when a procedure file is closed, or when AppBuilder closes a design window.</td>
<td>Closing a design window</td>
</tr>
<tr>
<td>Read</td>
<td>Occurs when AppBuilder has finished opening a procedure file.</td>
<td>Opening a procedure file</td>
</tr>
<tr>
<td>Write</td>
<td>Occurs when AppBuilder generates code and saves it to a procedure file. It specifically, occurs when the XFTR is encountered at code generation.</td>
<td>Saving or running a design window</td>
</tr>
</tbody>
</table>

The compilable code comment

This second comment, which is optional, has no specific format. The code section enclosed between the comment delimiters must be a block of AVM-compilable code (which can include comments). AppBuilder passes the contents of this code section to the XFTR event handlers that you reference in the first comment; the code executes when the procedure file is run.

The ending comment

The third comment simply specifies the end of the code block. Include it exactly as shown:

```/* _UIB-CODE-BLOCK-END */```

The &ANALYZE-RESUME directive for XFTRs

An XFTR code block ends with an &ANALYZE-RESUME directive. Include it exactly as shown:
How AppBuilder runs XFTR event handlers

When a AppBuilder event occurs for a specific procedure file and the procedure file contains an XFTR code block with an XFTR event handler specified in the corresponding position, AppBuilder runs the XFTR event handler and passes it two parameters:

- The context ID (integer) of the XFTR code block (INPUT parameter). A context ID is a unique integer ID for the code block. It can be used by other procedures in AppBuilder’s API.
- The contents (CHARACTER) of the optional code section (the section in between the first and last comments) in the XFTR code block (INPUT-OUTPUT parameter).

Make sure that your XFTR event handler can accept these parameters.
AppBuilder’s API

Once AppBuilder runs an XFTR event handler, the event handler can access AppBuilder’s API. This allows the XFTR event handlers to interact with AppBuilder to provide customized processing that is coordinated with AppBuilder’s standard processing.

Context IDs

AppBuilder’s API allows XFTR event handlers to gather information about all of the widgets, procedure files, SmartObject instances, and user-editable code sections in AppBuilder. Each of these different objects is stored in a separate record in AppBuilder’s internal temporary tables. The context ID provides a unique reference for each type of object.

Although AppBuilder’s API allows you to reference some objects by name or by handle, you should use the context ID to reference objects. Context IDs have the following advantages:

- They are guaranteed to be unique for each AppBuilder session
- They generally provide faster access to the available objects

Naming convention

All of the parameter names used in AppBuilder’s API begin with the letter p (for parameter), which is followed by a second letter that specifies the data type, as indicated in Table 20.

<table>
<thead>
<tr>
<th>Character</th>
<th>Data type</th>
</tr>
</thead>
<tbody>
<tr>
<td>c</td>
<td>Character</td>
</tr>
<tr>
<td>d</td>
<td>Decimal</td>
</tr>
<tr>
<td>h</td>
<td>Handle</td>
</tr>
<tr>
<td>i</td>
<td>Integer</td>
</tr>
<tr>
<td>l</td>
<td>Logical</td>
</tr>
</tbody>
</table>

AppBuilder’s API summary

Table 21 summarizes the various procedures that comprise AppBuilder’s API. These procedures are stored in the adeuib.pl procedure library. Each of these procedures is described in detail later in this appendix.
Add/remove SmartLinks (adeuib/_ablink.p)

Use the adeuib/_ablink.p procedure to add/remove a SmartLink joining two SmartObjects, as shown:

Calling sequence

```
RUN adeuib/_ablink.p.p
  ( INPUT pc_operation,
    INPUT pi_sourcecontext,
    INPUT pc_linkname,
    INPUT pi_targetcontext ).
```

Input parameters

The adeuib/_accsect.p procedure takes the following input parameters:

**pc_operation**

A quoted character string that specifies the operation to be performed. For example:

- **"ADD"** — Adds the link identified by the `pc_linkname` parameter
- **"REMOVE"** — Removes the link identified by the `pc_linkname` parameter

**pc_sourcecontext**

The context ID for the object at the originating (source) end of the link.
If the operation is “REMOVE”, you can use the question mark (?) character to refer to THIS-PROCEDURE.
If the operation is “**REMOVE**” and the target context argument represents a single destination object, you can use:

- The context ID for a single source object
- A comma-separated list of context IDs, representing multiple source objects
- The star (⋆) character, representing all source objects

**pc_linkname**

A quoted character string identifying the type of link to be added (**ADD**) or removed (**REMOVE**). For example “**FILTER**”.

**pc_targetcontext**

The context ID for the object at the destination (target) end of the link.

If the operation is “**REMOVE**”, use the question mark (?) to refer to **THIS-PROCEDURE**.

If the operation is “**REMOVE**” and the source context argument is a single object, use:

- The context ID for a single destination object
- A comma-separated list of context IDs, representing multiple destination objects
- The star (⋆) character, representing all destination objects

**Note:** Either the source context or the target context must represent a single object. You cannot have multiple objects at both the source and target ends. If the operation is “**ADD**”, both source and target must be single objects.

**Example**

The following code purges all **Navigation** links originating at the caller:

```c
/* Get own context ID. Example presumes handle of current procedure previously stored in phSelf. */
RUN adeuib/_uibinfo.p
   { INPUT ?,
     INPUT "HANDLE " + STRING( phSelf ),
     INPUT "CONTEXT":U,
     OUTPUT cContextID ).

/* Remove all Navigation links */
RUN adeuib/_ablink.p
   { INPUT "REMOVE":U,
     INPUT cContextID,
     INPUT "NAVIGATION":U,
     INPUT "***":U ) .
```
**Access section (adeuib/_accsect.p)**

Use the `adeuib/_accsect.p` procedure to read and write code sections in AppBuilder. For example:

### Calling sequence

```plaintext
RUN adeuib/_accsect.p
  ( INPUT        pc_mode,  
    INPUT        pi_context, 
    INPUT        pc_section, 
    INPUT-OUTPUT pi_srecid, 
    INPUT-OUTPUT pc_code ) .
```

### Input parameters

The `adeuib/_accsect.p` procedure takes the following input parameters:

- **`pc_mode`**

  A quoted character string that specifies the mode of operation. Valid values are:

  - **“GET”** — Reads the contents of the section or returns the Unknown value (?)
  - **“SET”** — Writes the contents of the section
  - **“DELETE”** — Deletes the current section

  You cannot actually delete either the **MAIN-CODE-BLOCK** or the **DEFINITIONS** sections (see `pc_section` below). The **DELETE** value empties the section but does not also remove the stub.

- **`pi_context`**

  The context ID of the object to access. If it is the Unknown value (?), AppBuilder assumes the current window or procedure.

- **`pc_section`**

  The name of the code section to access. Valid values are:

  - **DEFINITIONS**
  - **MAIN-CODE-BLOCK**
  - **TRIGGER:event-name**
    (For example, **TRIGGER:CHOOSE**)
  - **PROCEDURE:name:handler**
    (For example, **PROCEDURE:mytest:maintain.p**. See the “Examples” section below for a description of how you can use this.)
  - **FUNCTION:name**
  - **XFTR:xftr-name**

  When you have a **TRIGGER**, then `pi_context` refers to a widget. In all other cases, `pi_context` points to the procedure.
If `pi_srecid` is the Unknown value (?), then `pi_context` and `pc_section` are used to identify an existing section. If `pi_srecid` is known, then `pc_section` is ignored.

**Input-output parameters**

The `adeuib/_accsect.p` procedure uses the following **INPUT-OUTPUT** parameters:

`pi_srecid`

The context ID of the current section. If its value is other than the Unknown value (?), `pc_section` is ignored.

`pc_code`

The contents of the trigger or other code section.

**Return values**

This procedure returns:

"Error"

Indicates that `pi_context` is not specified and there is no current procedure or window.

**Examples**

The following code resets the **MAIN-CODE-BLOCK** to an include file:

```c
/* Get the current value */
pi_srecid = ?.
RUN adeuib/_accsect.p (*GET*, ?, "MAIN-CODE-BLOCK",
    INPUT-OUTPUT srecid,
    INPUT-OUTPUT code).
IF RETURN-VALUE NE "Error" THEN DO:
    IF code NE "{include.i}" THEN DO:
        code = "{include.i}".
        RUN adeuib/_accsect.p (*SET*, ?, ?,
            INPUT-OUTPUT srecid,
            INPUT-OUTPUT code).
    END.
END.
```
The following example creates a AppBuilder-maintained procedure: a procedure that the Code Section Editor displays as a READ-ONLY procedure. The following code fragment calls adeuib/_accsect.p:

```app
DEFINE VARIABLE code AS CHARACTER NO-UNDO.
DEFINE VARIABLE section_id as INTEGER NO-UNDO INITIAL ?.
RUN adeuib/_accsect.p (INPUT 'SET':U,
   INPUT ?,
   INPUT 'PROCEDURE:mytest:maintain.p',
   INPUT-OUTPUT section_id,
   INPUT-OUTPUT code).
```

In this example:

- The first INPUT parameter, "SET":U, specifies SET mode; SET mode tells adeuib/_accsect.p to write or create a code section.
- The second INPUT parameter, ?, specifies the context ID of the object to access. By default, adeuib/_accsect.p interprets the Unknown value (?) to be the context ID of the current window or procedure.
- The third INPUT parameter, "PROCEDURE:mytest:maintain.p", specifies the following:
  - The type of section to create is an internal procedure
  - The name of the internal procedure is mytest
  - The procedure maintain.p handles generating the code for the internal procedure
- The first INPUT-OUTPUT parameter specifies the context ID of the section; this value must be the Unknown value (?) or pc_section is ignored.
- The final INPUT-OUTPUT is a character string that holds the contents of the section.
This `maintain.p` procedure generates the code for the `mytest` internal procedure. For example:

```plaintext
/*----------------------------------------------------------------------
File: maintain.p
Description:
  Sample procedure showing how a developer procedure can maintain an
  AppBuilder Code Section.
Input Parameters:
  p_id  - (INTEGER) context ID of the current procedure
Output Parameters:
  p_Code - (CHAR) code to return. (Including "END PROCEDURE." ).
------------------------------------------------------------------------*/
DEFINE INPUT  PARAMETER p_id AS INTEGER    NO-UNDO.
DEFINE OUTPUT PARAMETER p_code AS CHARACTER  NO-UNDO.
DEFINE VARIABLE ch AS CHARACTER NO-UNDO.
/* Line for comments. */
&SCOPED-DEFINE COMMENT-LINE
/* Standard End-of-line character */
&SCOPED-DEFINE EOL CHR(10)
/* Get some info about the current procedure. */
RUN adeuib/_uibinfo.p (p_id, ?, "FILE-NAME", OUTPUT ch).
p_code =
  /*{&COMMENT-LINE}*/ + {&EOL} +
  " Purpose:     Sample code for file " + ch + {&EOL} +
  " Parameters: <none>" + {&EOL} +
  "(COMMENT-LINE)"*/ + {&EOL} + {&EOL} +
  " MESSAGE 'Hello World!':U." + {&EOL} + {&EOL} +
  "END PROCEDURE.".

/*-----------------------------------------------------------------------
Purpose:     Sample code for file C:\WORK\V-CUST.W
Parameters:  <none>
------------------------------------------------------------------------*/
MESSAGE 'Hello World!':U.
END PROCEDURE.
```

The `maintain.p` procedure generates a `mytest` procedure that the Code Section Editor displays as read only. The contents of the generated `mytest` procedure are:

```plaintext
Purpose: Sample code for file C:\WORK\V-CUST.W
Parameters: <none>
MESSAGE 'Hello World!':U.
END PROCEDURE.
```
AppBuilder-maintained procedures provide an alternative to traditional XFTR use. They basically fill the role of an XFTR with only a single WRITE handler. The advantages of AppBuilder-maintained procedures overusing XFTR are:

- You can add and delete them programmatically using adeuib/_accsect.p.
- They are visible to you, the developer, so that you can see the code being generated.

The disadvantages are:

- They can be deleted by the user from the Code Section Editor menu (Edit/Delete Procedure).
- They cannot store data in comments used to rebuild the code section. That is, the contents of the AppBuilder-maintained procedure must be derived totally from external sources or calls to adeuib/_uibinfo.p. For example, an XFTR handler can read a section and have it affect what it generates; however, an AppBuilder-maintained procedure can only write code.

**AppBuilder database table names (adeuib/_dbtbnam.p)**

Use the adeuib/_dbtbnam.p procedure to have AppBuilder correctly generate table names based on setting the Qualify Database Fields with Database Names user preference. For example:

**Calling sequence**

```
RUN adeuib/_dbtbnam.p ( INPUT p_id, INPUT p_name_in, OUTPUT p_name_out ).
```

**Input parameters**

The adeuib/_dbtbnam.p procedure uses the following input parameters:

- `pi_context`
  - The context ID of the current procedure (to obtain this ID, use adeuib/_uibinfo.p).

- `pc_name_in`
  - A table name. This name might or might not be qualified with a database name.
**Output parameter**

The adeuib/_dbtbnam.p procedure uses the following output parameter:

`pc_name_out`

A table name that meets the settings of the Qualify Database Fields with Database Names user preference.

**Example**

```plaintext
DEFINE VARIABLE ch AS CHARACTER NO-UNDO.
DEFINE VARIABLE db-tbl AS CHARACTER NO-UNDO.
DEFINE VARIABLE proc-id AS INTEGER NO-UNDO.

/* Get the context of the current procedure. */
RUN adeuib/_uibinfo.p (INPUT ?, INPUT ?, INPUT "PROCEDURE":U, OUTPUT ch).
proc-id = INTEGER(ch).

/* The user may have wanted to suppress the db name in AppBuilder. Ask AppBuilder to set up the database/table name. */
MESSAGE db-tbl.
```

**AppBuilder information (adeuib/_uibinfo.p)**

Use the adeuib/_uibinfo.p procedure to obtain information about the widgets and SmartObject instances in a design window. For example:

**Calling sequence**

```plaintext
RUN adeuib/_uibinfo.p
   ( INPUT  pi_context,
     INPUT  pc_name,
     INPUT  pc_request,
     OUTPUT pc_info ).
```

**Input parameters**

The adeuib/_uibinfo.p procedure takes the following input parameters:

`pi_context`

The context ID of the widget, SmartObject instance, code section, or procedure to access. If the Unknown value (?), AppBuilder assumes the current procedure. The value of `pi_context` can be the context ID for any of the following:

- An object. For example, you can obtain the context of a button, Btn_OK, with the following code:

  ```plaintext
  RUN adeuib/_uibinfo.p (?,"Btn_OK","CONTEXT", OUTPUT c_info).
  ```

- A procedure. For example, you can obtain the context for the current procedure with the following code:
• A SmartObject instance. For example, you can obtain the context of a SmartObject instance with the following code:

```
RUN adeuib/_uibinfo.p (?, ?, "PROCEDURE", OUTPUT c_info).
```

• A code section. For example, you can obtain the context ID and contents of the MAIN-CODE-BLOCK section with the following code:

```
RUN adeuib/_uibinfo.p (?, "HANDLE " + STRING(THIS-PROCEDURE)).
```

pc_name

A quoted character string that specifies the name of an object. This string has the following syntax:

**Syntax**

```
{ object
  [ IN FRAME frame-name ]
  [ IN WINDOW window-name ]
  | object
  [ IN FRAME frame-name ]
  [ IN PROCEDURE file-name ]
  | HANDLE handle
}
```

In this syntax:

• **object** is the name of the widget or SmartObject instance.

• **frame-name** is the name of its parent frame.

• **window-name** is the name of its parent window.

• **file-name** is the name of the parent procedure file.

• **handle** is either the handle of a widget or the procedure handle for a SmartObject instance.

If you omit the **FRAME** or **WINDOW** option, the current window and current frame are assumed. If an object is unique in a window, you can refer to it as object **IN WINDOW window-name**.

To refer to a window or frame, preface the object with the type. For example, to find **myFrame** in **myWin**.
To find window myWin:

WINDOW myWin

To find a procedure with the name p.w:

PROCEDURE p.w

The following special cases also apply:

- ? — Gets the current object (shown in the AppBuilder’s main window)
- FRAME ? — Gets the current frame
- WINDOW ? — Gets the current window
- PROCEDURE ? — Gets the current procedure
  
  If you use the HANDLE handle to reference an object, the handle can be either a HANDLE of the object or PROCEDURE-HANDLE for a SmartObject (converted to a STRING).

- PALETTE object — Object is the name directly following # in the cst file

pc_request

A quoted character string that specifies what to request. Valid requests are:

- “NAME” — Returns the name of the object.
- “ATTRIBUTES” — Returns a string with all of the attributes read from the cst file.
- “PROCEDURE” — Returns the STRING(pi_context) for the current procedure.
- “FILE-NAME” — Returns the name of the parent procedure file as last saved by AppBuilder; if not saved, returns “?”. 
- “TEMPLATE” — Returns YES or NO depending on whether the current object is a template.
- “TYPE” — Returns the type of object.
- “HANDLE” — Returns either the handle of the object or the adm-object-handle of a SmartObject.
- “PROCEDURE-HANDLE” — Returns the procedure handle of a SmartObject.
- “CONTEXT” — Returns the context ID of the widget or SmartObject instance.
• “CONTAINS contains-phrase” — Returns all objects contained in the current context (of a type or with key toggle boxes set). By default, returns the context ID of the items that match the filter, but you can ask for the list of names. The asterisk (*) returns all objects.

The syntax for contains-phrase is as follows:

Syntax

```
{ * | object-list }
[ { DISPLAY | ENABLE | MANUAL-HIGHLIGHT | MOVABLE
  | RESIZABLE | SELECTABLE | SHARED | VISIBLE
  | LIST-1 | LIST-2 | LIST-3 | LIST-4 | LIST-5 | LIST-6
  } { TRUE/YES | FALSE/NO }
] [ RETURN { CONTEXT | NAME } ]
```

In this syntax, object-list is a comma-separated list (with no spaces) of object types.

• “FRAMES” — Returns all frames (in a window). This is shorthand for CONTAINS FRAME RETURN NAME.

• “FIELDS” — Returns dbfields in frame or dbfields in browse.

• “EXTERNAL-TABLES” — Returns the list of external tables for a procedure.

• “TABLES” — The tables used by the query of a FRAME, BROWSE, or QUERY object.

• “4GL-QUERY” — The ABL query for the query of a FRAME, BROWSE, or QUERY object.

• “WBX-FILE-NAME” — The name of the .wrx in which to save run-time attributes for the OCXs in a procedure.

• “COMPILE-INTO-DIR” — The directory where the procedure file is compiled.

• “&FRAME-NAME [RETURN NAME]” — The context ID or name of the FRAME-NAME, or ?.

• “&QUERY-NAME [RETURN NAME]” — The context ID or name of QUERY-NAME, or ?.

• “&BROWSE-NAME [RETURN NAME]” — The context ID or name of BROWSE-NAME, or ?.

Other options

The following returns a comma-separated list of procedure names:

```
* | object-list
```
RUN adeuib/_uibinfo.p

(INPUT ?, /* P_context (INTEGER) */
  INPUT "SESSION", /* p_name (CHARACTER) */
  INPUT "PROCEDURES RETURN NAME", /* P_request (CHARACTER) */
  OUTPUT name-list). /* p_info (CHARACTER) */
The following returns the same list but uses context IDs instead of names:

```plaintext
RUN adeuib/_uibinfo.p
(INPUT ?, /* P_context (INTEGER) */
 INPUT 'SESSION', /* p_name (CHARACTER) */
 INPUT 'PROCEDURES RETURN CONTEXT', /* P_request (CHARACTER) */
 OUTPUT name-list). /* p_info (CHARACTER) */
```

**SECTIONS** function

You can ask a procedure for the list of internal procedures and functions defined in AppBuilder. The list can return the names or context IDs of the procedure and function sections, which you can use in `adeuib/_accsect.p` to get, modify, or delete the contents of code blocks. For example:

**Syntax**

```plaintext
SECTIONS PROCEDURE [ ,FUNCTION ]
[ RETURN { CONTEXT | NAME } ]
```

If you do not specify either RETURN CONTEXT or RETURN NAME, it returns the list in context ID order.

To obtain a list of all internal procedures in a file by name, use the following:

```plaintext
SECTIONS PROCEDURE RETURN NAME
```

To obtain all of the procedures and functions defined in a file, use the following:

```plaintext
SECTIONS PROCEDURE,FUNCTION
```

This returns the list in context ID order.

**HTML-FILE-NAME**

Returns the HTML filename associated with an HTML mapping object procedure.

**BROKERURL**

Returns the broker URL set in Web preferences, as shown:

```plaintext
```

**REMOTE**

Returns TRUE if the Remote File Management button in AppBuilder is set to ‘Remote’, otherwise returns FALSE, as shown:

```plaintext
```
WEBBROWSER
Returns the Web browser set in Web preferences.

DATAOBJECT
Returns the SmartDataObject associated with the procedure, as shown:

```
RUN adeuib/_uibinfo.p (INTEGER(hProc),"","DataObject":U, OUTPUT SDOName).
```

DATAOBJECT-INCLUDE
Returns the name of the include file associated with the SmartDataObject of the procedure, as shown:

```
RUN adeuib/_uibinfo.p (INTEGER(hProc),"","DataObject-Include":U, OUTPUT SDOiName).
```

PALETTE-ITEM
For a given custom definition in a .cst file, returns the settings for ATTRIBUTES, LABEL, TEMPLATE, and FILES, as shown:

**Syntax**

```
PALETTE-ITEM cst-obj-name
    [ ATTRIBUTES | LABEL | TEMPLATE | FILES ]
```

```
RUN adeuib/_uibinfo.p ( INPUT ?, INPUT "PALETTE-ITEM SmartDataObject":U, INPUT "ATTRIBUTES":U, OUTPUT Attributes).
```

**Output parameter**

The adeuib/_uibinfo.p procedure uses the following output parameter:

```
pc_info
```

Output value, cast as a character string.
AppBuilder create (adeuib/_uib_crt.p)

Use the adeuib/_uib_crt.p procedure to create objects in AppBuilder. You can create under program control the objects found in the custom object files. The TYPES, ARGUMENTS, and CUSTOM TYPES are the same as those defined in the custom object files. This acts just as if you choose a button from the Object Palette and insert it into a window or frame. For example:

Calling sequence

```plaintext
RUN adeuib/_uib_crt.p
   ( INPUT pi_parent ,
     INPUT pc_type ,
     INPUT pc_custom ,
     INPUT pd_Row ,
     INPUT pd_Column ,
     INPUT pd_height ,
     INPUT pd_width ,
     OUTPUT pi_context ).
```

Input parameters

The adeuib/_uib_crt.p procedure takes the following input parameters:

pi_parent

The context ID of the parent of the object to create. If this is the Unknown value (?), the parent is assumed to be the current frame. If there is no current frame, then the current window is assumed.

pc_type

The type of object to create (for example, "BUTTON" or "SmartObject").

pc_custom

The name of the custom object type (for example, "OK Button"). If this is the Unknown value (?), the "&Default" object is created. For example:

```
"case:value"
```

Special cases of pc_custom

The following are some special cases of the pc_custom parameter:

"Custom:name"

The name of the custom object defined in custom files. This draws a Next button, as shown:

```
Custom:&Next
```
"SmartObject:object-file"

The name of a SmartObject to load. For example:

\begin{verbatim}
SmartObject: C:/Progra-l/OpenEdge/gui/object/p-nav.w
\end{verbatim}

"SPECIAL:attributes-values"

This is similar to creating a new custom object file entry temporarily. The attributes and values are parsed the same way as entries in the custom object file. Blank lines are ignored. You must separate lines with a carriage return (that is, \texttt{CHR(10)}). For example:

\begin{verbatim}
*SPECIAL: " +
"BGCOLOR 7 " + CHR(10) +
"FONT    2 " + CHR(10) +
"NAME    test".
\end{verbatim}

\texttt{pd\_ROW}

The \texttt{ROW} to create the object.

\texttt{pd\_COLUMN}

The \texttt{COLUMN} to create the object.

\texttt{pd\_HEIGHT}

The \texttt{HEIGHT} of the object in characters; if the Unknown value (?), the default height is used.

\texttt{pd\_WIDTH}

The \texttt{WIDTH} of the object in characters; if the Unknown value (?), the default width is used.

\textbf{Output parameter}

The \texttt{adeuib/_uib_crt.p} procedure uses the following output parameter:

\texttt{pi\_context}

The context ID of the object created. If the creation fails, this is the Unknown value (?). You can use this value as the object context ID for the companion programs, which are \texttt{adeuib/_accsect.p}, \texttt{adeuib/_uibinfo.p}, and \texttt{adeuib/_uib_del.p}.

\textbf{Return values}

The \texttt{adeuib/_uib_crt.p} procedure returns:

"Error"

If \texttt{pi\_context} does not point to a valid object.
AppBuilder delete (adeuib/_uib_del.p)

Use the adeuib/_uib_del.p procedure to delete objects in AppBuilder, as shown:

**Calling sequence**

```plaintext
RUN adeuib/_uib_del.p ( INPUT pi_context ).
```

**Input parameter**

The adeuib/_uib_del.p procedure takes the following input parameter:

* pi_context

  The context ID of the object to delete. There is no default value for this; you must pass a valid context ID. This value is the same value returned by adeuib/_uibinfo.p.

**Return values**

This procedure returns:

* **"Error"**
  
  Indicates that *pi_context* does not point to a valid object.

* **"Fail"**
  
  Indicates that the object was not deleted.

AppBuilder dialog (adeuib/_uib_dlg.p)

Use the adeuib/_uib_dlg.p procedure to invoke a subset of AppBuilder’s dialog boxes, as shown:

**Calling sequence**

```plaintext
RUN adeuib/_uib_dlg.p
  ( INPUT pi_context, INPUT pc_dname, INPUT-OUTPUT pc_args ).
```

**Input parameters**

The adeuib/_uib_dlg.p procedure takes the following input parameters:

* **pi_context**

  The context ID of the object to which the dialog box will apply.

* **pc_dname**

  A quoted character string that specifies the name of the AppBuilder dialog box to call. Valid values are:

  * **"QUERY BUILDER"** — The context ID must be for a query, frame, or browse
  * **"COLUMN EDITOR"** — The context ID must be for a browse
Appendix C: Customizing AppBuilder

- “EXTERNAL-TABLES” — The context ID must be for a procedure

Input/output parameters

The adeuib/_uib_dlg.p procedure uses the following input/output parameters:

```
pc_args
```

A character string to send to the dialog box. For the Column Editor or the External Tables dialog box, you can send a table-list, which is a comma-separated list of tables. For the Query Builder, you can specify a mode, which is a comma-separated list having the following syntax:

Syntax

```
{ ? | NORMAL | QUERY-ONLY | CHECK-FIELDS }
[ NO-FREEFORM-QUERY ]
```

The values are as follows:

- ? — The default. Changes the Query Builder to NORMAL mode. For queries, this means that the Fields button is disabled; for browsers, it means that all fields that are Query Builder options are enabled.
- “NORMAL” — Changes the Query Builder to NORMAL mode. For queries, this means that the Fields button is disabled; for browsers, it means that all fields that are Query Builder options are enabled.
- “QUERY-ONLY” — Specifies that the Query Builder be in QUERY-ONLY mode. This means that the fields button is disabled.
- “CHECK-FIELDS” — Specifies that the Query Builder be in CHECK-FIELDS mode. This means that if you try to leave the Query Builder and have not selected any fields, you are prompted to select fields.
- “NO-FREEFORM-QUERY” — Specifies that the Freeform Query button must be disabled.

Window save (adeuib/_winsave.p)

Use the adeuib/_winsave.p procedure to set an internal flag that indicates whether the window has been modified since it was last saved or opened. AppBuilder checks this flag whenever it closes a window:

- If the flag is TRUE, the window has recently been saved (or just opened).
- If the flag is FALSE, the window needs to be saved.
Whenever you modify something in the design window that will be reflected in its saved procedure file, call `adeuib/_winsave.p` to set the flag to `FALSE`:

**Calling sequence**

```
RUN adeuib/_winsave.p ( INPUT ph_handle, INPUT pl_saved ).
```

**Input parameters**

The `adeuib/_winsave.p` procedure takes the following input parameters:

- `ph_handle`
  
  The widget-handle of the design window to mark as saved.

- `pl_saved`
  
  A logical value that indicates that the window has been saved or opened since it was last modified.

**Example**

```
RUN adeuib/_winsave.p (h_deswin, FALSE).
```

**Reserved names (adeuib/_namespc.p)**

Use the `adeuib/_namespc.p` procedure to register the names of variables or procedures that AppBuilder users cannot use. For example, if you write an `XFTR` that creates a procedure, you do not want an AppBuilder user to create an internal procedure with the same name. Similarly, if the `XFTR` defines variables, you want to restrict AppBuilder users from using those variable. For example:

**Calling sequence**

```
RUN adeuib/_namespc.p ( INPUT pi_context, INPUT pc_mode, INPUT pc_list ).
```
Input parameters

The adeuib/_namespc.p procedure takes the following input parameters:

**pi_context**

The context of the procedure object to access. If this is the Unknown value (?), then get the current procedure. If a procedure object cannot be found, returns ERROR.

**pc_mode**

The action to perform. Valid actions are as follows:

Syntax

```
{ RESERVE | UNRESERVE }
[ { VARIABLE | PROCEDURE }
[ NAME | NAMES ]
]
```

**pc_list**

A comma-separated list of names to add or remove.

If you try to reserve a name that is already in use, warnings are generated; however, the reservation is made, so that if you delete the widget that uses the name, you cannot use it again. You can unreserve any name, even one that it not reserved, but no warning is generated.
Example using AppBuilder’s API

The following example shows how to call AppBuilder’s API procedures:

```plaintext
/* This example shows how to replace the string "v-credit" to "v-debit" in a trigger code block of a radio-set named rs-disc. */

DEFINE VARIABLE char-hndl    AS CHARACTER NO-UNDO.
DEFINE VARIABLE my-widget    AS CHARACTER NO-UNDO.
DEFINE VARIABLE trig-code    AS CHARACTER NO-UNDO.
DEFINE VARIABLE trig-context AS INTEGER NO-UNDO.

/* Get the context-id of the radio-set called rs-discounts */
RUN adeuib/_uibinfo.p
  (INPUT ?,                        /* We don’t have the context id but the radio-set is in the current design window */
   INPUT "rs-disc",            /* The name of the radio-set */
   INPUT "CONTEXT",            /* Please return the context id */
   OUTPUT my-widget).        /* This is the context-id we need */

/* Fetch the trigger code to be modified */
trig-context = ?.              /* This is IMPORTANT, otherwise _accsect.p will attempt to use this trig-context instead of my-widget and TRIGGER:VALUE-CHANGED */
RUN adeuib/_accsect.p
  (INPUT "GET",                /* We want to read the code */
   INPUT INTEGER(my-widget),   /* The context id from above */
   INPUT "TRIGGER:VALUE-CHANGED", /* The trigger we want */
   INPUT-OUTPUT trig-context,  /* The trigger context so we can reference this block directly in the future. IMPORTANT: This must be ? initially or _accsect will attempt to use it instead of parameter 2 */
   INPUT-OUTPUT trig-code).   /* The code block */

/* Replace the string */
trig-code = REPLACE(trig-code, "v-credit", "v-debit").

/* Store the trigger */
RUN adeuib/_accsect.p
  (INPUT "SET",                /* Write the code back */
   INPUT ?,                    /* We have code context, use it */
   INPUT ?,                    /* We have code context, use it */
   INPUT-OUTPUT trig-context,  /* We are using it directly */
   INPUT-OUTPUT trig-code).   /* We are writing this back */

/* Mark the window as having been modified since last save */
/* First get the handle of the design window */
RUN adeuib/_uibinfo.p
  (INPUT ?,                        /* We don’t know the context id */
   INPUT "WINDOW ?",            /* We want the handle of the design window */
   INPUT "HANDLE",             /* We want the HANDLE */
   OUTPUT char-hndl).          /* Returns a string of the handle */

/* Now indicate that the window needs to be saved again */
RUN adeuib/_winsave.p (HANDLE(char-hndl), FALSE).      
```

OpenEdge Development: AppBuilder
Index

A

Actions
assign Widget IDs 59
check source-code syntax 59
choose colors for current object 62
close character-mode test window 60
configure alternate layouts 62
connect to database 62
copy selected object 58
create new ADM class 61
create new object file 57
cut selected object 58
delete an object instance 58
disconnect database 62
delete an object instance 58
disconnect database 62
delete an object instance 58
disconnect database 62
edit file-level properties 61
deploy file-level properties 61
edit traversal list 59
edit widget properties 61
export an object 59
hide tool buttons 66
hide/show Objects Palette 63
insert whole file 59
modify temp-tables 61
modify database connections 62
open ActiveX property sheet 63
open error-message window 64
open existing object file 57
open online help window 64
open Section Editor window 63
paste object 58
place object in workspace 69
place several objects of same type 70
print object source 58
review recent Cue Cards 64
review recent messages 64
run current workspace 59
save all open files 58
save object source file 57
save object source under another name 57
set Design Page 59
set preferences 62
start non-AppBuilder editor 61
stop or undo object placement 70
toggle layout-grid stickiness 62
toggle layout-grid visibility 62
undo latest operation 58
view/modify common properties 63

ActiveX (OCX) object 339
adaptable interface 339
creating and placing 339
event handlers
generic 340
in master layout 388
properties stored in file 340
tool 68
using in application requires licence 339

ActiveX (OCX) Timer 345

ActiveX object
property references in code 251
activex.cst 419

ADM 30
architecture components 30
current version 30
paging 145

ADM Pages manager 351
deleting a whole page 352
deleting an object from a page 352
exchanging contents of pages 352
Advanced Procedure Settings 353
Advanced Procedure settings
child objects, specifying allowed 354
Alternate layout
definition 388
Alternate layouts. See Layouts
API
add/remove SmartLinks 438
AppBuilder
API 437 to 459
add/remove SmartLinks 438
custom object files 419
customizing 49, 70, 87, 91, 418
default function type 88
double-click 88
introduction to 418
layout grid 89
objects in object files 419
designing for character environments 404
event handling 434
exiting 54
main window 55
programming interface 437
setting personal preferences 87
starting 54
testing character-mode designs 405
version number 64
WebSpeed, for 54
working with 45, 48
AppBuilder main window
buttons 64
current object fields 55
menu bar 57
status bar 56
tool bar 64
AppBuilder-maintained procedures 445
Application
design considerations
single vs multi-window 46
Application Development Model. See
ADM
AppServer
enabling support for 367
Attributes, object. See Properties
B
B2B messaging
creating consumer instances 307
message types 306
SmartConsumers 303
SmartProducers 303
SonicMQ domains 308
Batch mode
containers for 141
operating in 310
SmartConsumers 310
Broker URL 451
Buttons
AppBuilder main window 64
C
Calculated fields
creating 168
Caution
guard against version skew 275
mapping to non-unique values 281
must use static data object 171
no type-checking in maps 277
objects incompatible 174
visible objects in non-visible container 142
Cautions
data validation 169
input focus
preventing object from gaining 223, 246
race condition 345
too many events to handle 345
Changing the data stream 186
Character applications in AppBuilder 404, 405
Character client 406
Character mode
designing for 47
Character-mode layouts
double byte characters 407
limitations on inheritance in 394
running 405
simulating 404
Check Box 271
See also Toggle Box
Checking syntax 59
Child objects in workspaces
specifying which are allowed 354
Code
testing 113
Code base
single, for different environments 386
Code sections
navigating 99
reading and writing 441 to 445
Runtime attributes and AppBuilder settings 398
Colors
choosing 357
defining new 358
how they are applied 357
table of pre-defined 358
Combo Box 241
ActiveX (OCX)
configuring 251
creating and placing 251
tool 68
basic ABL
configuring 242
creating and placing 241
initial value of 246
tool 67
Drop-down style, defined 243, 253
Simple style, defined 243, 253
Common properties
displaying in a dialog 368
Compiling and running 59
Configuring
SmartB2BOBJECT instances 288
SmartBusinessObjects 174, 178
SmartConsumer instances 308
SmartProducer instances 305
Context IDs 437
Control-frame properties 349
Copying text
Section Editor 100
Creating
document-handling packages 300
document-routing packages 300
master SmartB2BOBJECTs 287
Simple SmartContainers 141
SmartB2BOBJECT instances 288
SmartBusinessObjects 173
SmartConsumer instances 307
SmartProducer instances 304
SmartSender instances 294
XML map file 283
Current object fields
AppBuilder main window 55
Custom Lists
assigning meaningful names 362
Custom object files 70, 419 to 459
Custom objects
settable properties 425 to 431
Customizing AppBuilder 418 to 459
Cutting text
Section Editor 100
D
Data access
client-only object versions
filenames end in ‘_cl’ 158
client-only version 158
efficiency versus completeness 175
foreign-field mapping 177
generic/general-purpose 159
partitions 178, 179
reducing complexity 172
relational mapping 177
single-transaction updates 172
synchronizing 173
Data Browser
basic ABL 236
configuring 237
creating and placing 236
editing query and fields 237
tool 67
Smart 200
configuring 201, 207
creating and placing 201, 211
creating master 204
estreaming data stream in master 211
tool 68
Data fields
differences in appearance 217
Data Fields. See Data Viewer
Data pump
Smart
example of use 49
tool 68
DATA SmartLinks 175
Index

Data stream
- allowing user to filter 180
- changing 211
- changing contents of 186
- preserving integrity of 43
- selecting fields for browsing 168

Data transfer
- SmartProducers/SmartConsumers 303

Data transformation
- SmartB2BOBJECTS 274
- SmartSENDERS/SmartReceivers 293

Data validation
- limitation with SmartDataObject 169

Data Viewer
- basic ABL 254
  - configuring 255
  - creating and placing 254
  - tool 66
- Smart 215
  - adding/removing fields 219
  - appearance of fields 217
  - configuring 219
  - creating master 215
  - example of use 48, 151
- tool 68

Database
- add, modify, remove connections 62
- connections for character-mode clients 406
- field names in Section Editor 104
- selecting fields for browsing 168

Database tables
- working copies 378

DataView
- tool 68

Default Page 146
- at startup 146

Deleting
- whole procedure, trigger, etc. 103

Design Page
- limitations 145

Design windows 97

Development mode switch. See Remote development button

Dialog Box
- basic ABL
  - configuring 135
  - creating new 57
- Smart
  - configuring 128
- creating new 57
  - file-level properties, configuring 130

Dialogs, frequently-used
- ActiveX (OCX) control frame properties 349
- ADM Pages manager 351
- advanced file-level properties 353
- Advanced Procedure Settings 353
  - base procedure type 353
  - method-libraries reminder, avoiding 353
  - supported SmartLinks 353
- Color Selector and editor 357
- database field selector 363
- method library include-files list 365
- naming custom lists 362
- Procedure Settings 366
- Properties Window 368
- SmartInfo 372
- SmartLinks editor 369
- String Attributes 375
- Temp-tables Maintenance 378
- Text-style selector and editor 381
- Traversal-path editor 376

Documents
- XML mapping 275

Drop-down List
- as style of Combo Box 243, 253
- defined 243

Dynamic SmartDataObjects 158 to 171

E

Edit
- menus 124

Editing
- ActiveX object properties 63
- importance of using Section Editor 98
- object properties 110
- open editor window 63

Editor object
- multi-line
  - buffer size 257
  - configuring 256
  - creating and placing 256
  - tool 67
- single-line
  - configuring 258
  - creating and placing 258
  - tool 67

Editor object, single-line 258

Ending AppBuilder session 54

Environment
character
designing for 47

Event handlers
for XFTRs 434 to 436

Event names
in Section Editor 105

Examining procedure files 112

Example of use
data pump
Smart 49
Data Viewer
Smart 48, 151
PushButton 49, 151, 153
Smart 48
Radio Set 151
Rectangle 49, 151
SmartContainer tool 153
SmartDataField 232
SmartDataObject 49
SmartDataViewer 48, 151, 232
SmartFilter 326
SmartFolder 148
SmartLinks 49, 50
SmartPanel 48, 148, 151
SmartSelect 232
SmartWindow 48, 148
Static Text 49

Extended features 433
reserving names 457

F

Field lists
specifying 194

Fields
creating calculated 168
selecting for browsing 168

Field-selector dialog 363

File-level properties 366

Filename conventions
SmartB2BObjects 288
SmartBusinessObjects 174
SmartContainers 302
SmartSenders 294

Filenames
Section Editor 109

Files
custom object, contents of 419
custom object, listed 419
database tables

working copies 378

Fill-in 258
configuring 258
creating and placing 258
tool 67

Filtering incoming messages 290, 296

Frame
basic ABL
configuring 136
tool 67
creating 136
Smart
configuring 131
creating new 57

Functions
listing 451

H

Help 64
review recent Cue Cards 64
review recent messages 64
see AppBuilder version 64
see system resources 64
with message numbers 64

HTML Mapping Object 451

I

Image object 341
See also Static Image

include files
for temp-table definitions 71

Include-files
list of 365

Inheritance of layouts
preventing 394

INMESSAGE SmartLinks 307

Instances
getting information 445 to 452

Inter-business communication 303

Internal procedures
listing 451

Internationalization
no-translation attribute 375
specifying extra space in literals table 375
**J**

Java-based messaging 303

JMS Partitions 308

Joins
  queries 191

**L**

Layout
  align objects automatically 62, 63
  alternate
    creating 391
    definition 388
  configure alternate 62
  definition 387
  master
    definition 388
    elements of 388
    multiplexing 145
    paging 145
  selecting pre-defined alternate 393
  standard 389
  toggle grid stickiness 62
  toggle grid visibility 62

Layouts
  alternate 402
    Combo Boxes in 402
    modifiable properties in 402
    Static Text objects in 402
  design time view 389
  how they work internally 398
  inheritance from master 394 to 397
    limitations 394
    preventing 394
    restoring 394, 396
  limitations in alternate 402
  master
    re-establishing inheritance from 396
  propagation of master changes 394 to 397
  run-time customization 403

SmartObject
  applying at run time 413
  changing at run time 415
  creating 409
  initial run time 414
  instance options 410
  modifying 409
  SmartObjectLayouts 408
  switching at run time 403

Limitations
  data validation 169
  double-byte characters 407
  ObjectNames in resource list 284
  of data-stream integration 172

  of static SmartDataObjects 159
  SmartFolder 148
  SmartRouters/SmartReceivers 300
  SmartToolbar 323
  XML mapping support 283

Line object
  using Rectangle to simulate 137

List button
  AppBuilder main window 65

Lock status
  for inserting objects 66

Look-and-feel
  3D 122
  automatic resizing 222
  border thickness 138, 139
  column width 210
  display as static text 224
  iconic label 335
  keep existing layering of children 123
  max button in title bar 123
  message area 123
  min button in title bar 123
  minimal title bar 124
  number of lines 242
  re-arranging fields 220
  remove from layout 223, 245, 349
  reset to master layout properties 394
  re-using part of the window 145
  scroll bars 123
  show filled 139
  show label 222, 231, 242
  sorted data 230
  special highlighting 133, 140, 224, 246, 355
  state determines appearance 217
  status area 124
  sync with master layout 127
  text label 335
  title bar 122, 133
  type of widget used 231, 243, 253
  undefined value 231
  visible border 132, 133

**M**

Macros 362

Master layout
  See also Layouts
  definition 388
  elements of 388

Menu
  creating 124
  popup, creating 124

Menu bar
  AppBuilder main window 57
creating 124
Message destination identifiers 290
Message system login 309, 310
Message types 306
Message-handling
  algorithms 312
  code samples 312
  inbound process 313
  internal details 312
  outbound process 312
Multi-line Editor 256
Multiple document types 298
Multiple document types/destinations 290
Multiple layouts
  See also Layouts
coding 398
  internals 398
  reason for using 386

N
New object 57

O
Object
  ActiveX (OCX)
    creating and placing 339
    introduction to 339
  ActiveX (OCX) timer 345
Check Box 271
choose colors 62
Combo Box 241
  Combo Box (ActiveX)
    configuring 251
    creating 251
  Combo Box (basic ABL)
    configuring 242
    creating 241
Data Browser (basic ABL) 236
  configuring 237
  creating and placing 236
Data Browser (Smart) 200
  configuring 201, 207
  creating and placing 201, 211
  creating master 204
  editing data stream in master 211
Data Fields 254
Data Viewer (basic ABL) 254
  configuring 255
  creating and placing 254
Data Viewer (Smart) 215
  adding/removing fields 219
  configuring 219
  creating master 215
  data-capture
    introduction to 199
  data-display
    introduction to 199
DataView 157
deleting instance 70
Dialog Box (Smart)
  configuring 128
    file-level properties 130
Drop-down List 241
    editing file-level properties 61
    editing properties 110
Editor (multi-line) 256
  configuring 256
  creating and placing 256
Fill-in 258
  configuring 258
  creating and placing 258
Frame (basic ABL)
  configuring 136
  creating and placing 136
Frame (Smart)
  configuring 131
names in Section Editor 108
open ABL Property Sheet 61
PushButton 333
  configuring 334
  creating and placing 333
Smart array 329
Query 187
  creating 187
Radio Set 261
  configuring 262
  creating and placing 261
  initial value 262
Rectangle
  configuring 137
  creating and placing 137
  repeating a placement 70
Selection List 264
  configuring 264
  creating and placing 264
single-line Editor 258
Slider Control 266
  boundary values 267
  configuring 267
  creating and placing 266
  initial value 267
  tic marks 267
Smart, data-driven list 228
SmartDataBrowser 200
  configuring 201, 207
  creating and placing 211
  creating master 204
  dynamic 201
  editing master 211
  static 204
SmartDataField 225
  placing and configuring 225
SmartDataObject 158
  configuring 166
  creating master 159
SmartDataViewer 215
  adding/removing fields 219
  configuring 219
  creating master 215
SmartDialog
  configuring 128
  creating instance 118
SmartFilter 180
SmartFrame
  configuring 131
  creating instance 118
SmartObject template 338
SmartPanel
  configuring 330
  creating and placing 330
SmartSelect 228
  configuring 229
  creating and placing 228
SmartToolbar 323
  configuring 324
  creating and placing 323
  creating new master 326
SmartWindow
  configuring 120
  creating instance 118
  opening property sheet for 120
  special-purpose, where to find 69
Spin Control (ActiveX) 269
  configuring 269
  creating and placing 269
Static Text 344
Toggle Box 271
  configuring 271
  creating and placing 271
Window (Smart)
  configuring 120
workspace 97

Object behavior
  accept dropped objects 123, 223, 243
  allow automatic re-sizing 222
  allow undefined value 231
  allow user to change column width 210, 239
  allow user to edit data 223
  allow user to move 133, 140, 210, 224, 240, 246, 356
  allow user to re-order columns 210, 239
  allow user to re-size 123, 133, 140, 210, 224, 240, 246, 356
  allow user to search on columns 210, 239
  allow user to select 133, 140, 210, 224, 240, 246
  appear at specific location 123
  automatically clear field for input 223
  automatically sort data 230, 245
  automatically validate input 129
  change object scope 223, 245
  create scrollbars when needed 123
  data type 243, 259, 262, 265
  decline input focus 123, 139, 223, 230, 244, 349
  disallow min/max resizing 124
  discard leading spaces 223
  display as (widget type) 231
  display context-sensitive help 349
  display data type from schema 232
  display field descriptor from schema 232
  display MESSAGE output 123
  display minimized in/above taskbar 123
  display special help string 210, 239, 246
  display status messages 124
  display tooltip 232, 243, 257, 259, 263, 265, 267, 272, 342
  emulate platform-native object 223
  format display 243, 259
  initialize in hidden state 123, 139, 223, 244, 349
  journal changes 223, 245
  maintain child-object layering 123
  minimize to icon 123
  move to next field when full 223
  page between different layouts 145
  page length 132
  participate in traversal list 223, 245, 349
  predict user input 243, 245
  prevent input echo 223
  resize to full screen 123
  stay in front of other objects 127
  use help strings and validation from dictionary 129

Objects
  action control
    listed 32, 34, 36
  ActiveX (OCX)
    listed 37
    adding template to New-object dialog 423
    adding to a tool menu 422
  basic ABL
    listed 32
    control
      introduction to 322
      creating and placing 69
  data-access
    listed 35
  data-display and -capture
    listed 32, 35, 37
  defined 40
  Dialog Boxes
    basic ABL 135
    Smart 128
for controlling actions 322
Frames
  basic ABL 136
  Smart 131
organizer
  creating procedure-based instance 118
  introduction to 116
  listed 32, 34
  roles 117
other
  listed 34, 36, 37
Rectangles 137
Smart
  listed 34
SmartDialogs 128
SmartFrames 131
SmartPanel 329
SmartWindows 120
Static Image 341
visible vs non-visible 39
Windows
  basic ABL 134
  Smart 120

Objects Palette 66
ActiveX (OCX) tool 68
cancelling tool selection 70
Check-Box tool
  See Toggle Box
Combo-Box tool
  ActiveX 68
  basic ABL 67
customizing 70
Data-Browser tool
  basic ABL 67
  Smart 68
Data-Fields tool 66
Data-pump tool
  Smart 68
Data-Viewer tool
  basic ABL 66
  Smart 68
Dialog Box tool
  basic ABL 66
  Smart 66
Editor (multi-line) tool 67
Editor (single-line) tool 67
Fill-in tool 67
Frame tool
  basic ABL 67
  Smart 66
hide tool buttons 66, 70
hide/show 63
keep in front 70
multiple placement 70
options 70
pointer tool 66
PushButton tool
  basic ABL 67
  Smart array 68
Query filtering tool
  smart 69
Query tool 66
Radio-Set tool 67
Rectangle tool 67
save current position, shape as default 70
Selection-List tool 67
Slider-Control tool 67
SmartContainer tool 69
SmartDataBrowser tool 68
SmartDataField tool 68
SmartDataObject tool 68
SmartDataViewer tool 68
SmartDialog tool 66
SmartFilter tool 69
SmartFolder tool 68
SmartFrame tool 66
SmartObject tool 68, 338
SmartPanel tool 68
SmartToolbar tool 69
SmartWindow tool 66
Spin-Buttons tool
  ActiveX 68
Static-Image tool 67
Static-Text tool 68
timer tool
  ActiveX 68
toggle-Box tool 67
tool 68
tools not on
  basic ABL Dialog Box 66
  basic ABL Window 66
  SmartDialog 66
  SmartFrame 66
  SmartWindow 66
using 69
Window tool
  basic ABL 66
  Smart 66

OCX (ActiveX) object 339
Open existing object 57
Organizer
  Smart
  example of use 48
Organizers
  Simple SmartContainer 141
OUTMESSAGE SmartLinks 304, 310

P

Page 0 (Zero)
  always displayed 146
  role of 146
Paged layouts
  creating 145
  creating pages 145
Index

deleting pages 145

designing without SmartFolder 151

identifying pages 145

see all pages together 146

using whole windows 153

Paging

ADM Pages dialog

deleting objects 352

moving objects between pages 352

setting the Design Page 352

setting the Startup Page 352

Design Page 145

Design Page, setting 352

listing a page's objects 352

moving objects between pages 352

Page 0 is default page 146

placing objects 145

SmartFolder 148

limitations 148

Startup Page

setting 352

startup page 146

whole-window 153

without SmartFolder 151

Partitions

configuring 179

JMS 305, 308

on AppServers 179

Pasting

Section Editor 100

Persistence

enabling 367

Pick List. See Selection List

Placeholder

design-time 374

SmartObject 374

Pointer 66

Preferences

default function type 88

double-click 88

layout grid 89

printing 90

Section Editor 91

setting 62, 87

Widget IDs 90

Preprocessor names

Section Editor 107

Procedure settings 366

Procedure-based object

AppServer support, enabling 367

descriptive comments field 367

location of ActiveX (OCX) properties 367

location of executable 367

specifying persistence 367

Procedures

files

inspecting code 112

running 113

saving 114

in AppBuilder API 437

marking as modified 456

Section Editor 105

progress.cst 419

sample entry in 431

Properties

viewing and editing 110

Properties Window 368

Property sheet

SmartDataObject 164

Pushbutton 333

creating and placing 333

tool 66

example of use 49, 151, 153

labeling 335

Smart array 329

tool 66

tool 48

example of use 48

tool

Smart AB 67

Smart array 68

types supplied 333

close dialog or window 333

dialog box session 333

generic 333

invoke help system 333

move current-record pointer 333

view ADM page 333

Q

Queries

building 189

establishing join criteria 190, 191

establishing search criteria 192

establishing sort criteria 193

modifying 189

Section Editor 108

setting options 194

Query

allowing user to filter 180

creating 187

filtering tool

Smart 69

tool 66

Query Builder

join mode 191

options mode 194

sort mode 193

OpenEdge Development: AppBuilder
table mode 189
using 188
where mode 192

Query Tuning options panel 195
Query-By-Example 180

R

Radio Set 261
configuring 262
creating and placing 261
equation of use 151
initial value 262
tool 67

Rectangle
configuring 137
creating and placing 137
equation of use 49, 151
tool 67

Remote development
AppBuilder main window 64
saving files 114

Remote file management 451

Reserved names 457

ROUTER SmartLinks 307

Routing incoming documents 297

Run-time customization of user interface 403

Run-time expressions
standard layouts 389

S

Save object 57

Section Editor 99
cutting, copying, pasting 100
database-field names 104
event names in 105
filenames/pathnames 109
invoking 99
navigating code sections 99
object names 108
preprocessor names 107
procedure/function calls 105
query definition 108
text-file insertion 102
using 100

Selection List 264
configuring 264
creating and placing 264

list of choices 265
tool 67
value of selection 265
value types 265

shared.cst 419

Simple SmartContainers 141 to 144

Single-line Editor 258
configuring 258
creating and placing 258

Slider Control 266
bounds, upper and lower 267
configuring 267
creating and placing 266
initial value 267
scale markings 267
tool 67
upper and lower value limits 267

Smart
defined 38
smart.cst 419

SmartB2BObject
tool 69

SmartB2BObjects 274 to 293
ABL/XML 274
configuring instances 288
creating instances 288
creating masters 287
do not use XMLMessage type 306
dynamic master 287
filename convention 288
instance properties
incoming 291
multiple producers 290
outgoing 289
inter-business messaging 274
selecting dynamic version 288
transformation 274

SmartBusinessObject
tool 69

SmartBusinessObjects
and partitions 179
as DATA-TARGETs 176
can reduce complexity 172
configuration tasks 174
configuring 174, 178
creating and placing 173
filename convention 174
in Web applications 172
integration limit 172
whole-stream validation 175

SmartConsumers 303 to 312
configuring instances 308
creating instance 307
in batch mode 310
JMS Partitions 308
shutdown 309
SonicMQ domains 308
stopping when in batch mode 310

SmartContainer
  tool 69

SmartContainers
  design-time appearance 143
  simple
    configuring 142
    creating 141
    instance properties 144
  simple non-visible 141

SmartDataBrowser 200
  creating and placing 211
  dynamic 201
    creating and placing 201
    display/update rules 202
  editing master 211
  navigation in 330
  static 204
    configuring 207
    creating master 204
  tool 68

SmartDataField 225
  example of use 232
  SmartSelect 228
  tool 68

SmartDataObject 157, 158, 164
  as placeholder 166
  configuring 166
  connectionless 166
  creating and placing 165
  data validation limitation 169
  designing 159
  example of use 49
  master
    creating 159
    editing 164
  tool 68

SmartDataObjects
  and DATA links 175
  client-only version 158
  dynamic
    and WebClient 159
    as generic data pumps 159
    limitation 159
  static
    limitation 159
    synchronizing 175

SmartDataViewer 215
  adding/removing fields 219
  configuring 219, 220
  fields layout 220
  help string 224
  initial value 224
  creating master 215
  example of use 48, 151, 232
  state determines appearance 217
  tool 68

SmartDialog
  configuring 128
  creating instance 118

SmartFilter 180
  configuring 181
  displaying in separate window 326
  example of use 326
  tool 69

SmartFolder
  example of use 148
  limitations 148
  paging with 148
  tool 68

SmartFrame
  configuring 131
  creating instance 118

SmartInfo dialog 372

SmartLink types
  DATA 175
  INMESSAGE 307
  OUTMESSAGE 304, 310
  ROUTER 307

SmartLinks
  adding, removing, modifying 369
  API routine to add, remove 438
  example of use 49, 50
  list of 369

SmartLinks editor 369

SmartLOBField
  tool 68

SmartObject
  creating new 57
  placeholder, creating as 374
  property sheet 373
  tool 68, 338

SmartObject template 338

SmartObjects
  advantages in using 38
  creating under program control 453 to 454
  deleting under program control 455
  listed 34
  menu-button menu 39
  multiple layouts 408
  non-visible
    example of 39
    synchronizing 43
Index

ventilator-button menu 39
visible vs non-visible 39
what “Smart” means 38

SmartPanel 329
configuring 330
creating and placing 330
example of use 48, 148, 151
tool 68
types supplied 329

SmartProducer

 tool 69

SmartProducers 303 to 312
JMS Partitions 305
message persistence 306
message types 306
SonicMQ domains 305

SmartReceivers 293 to 296

SmartReciever

 tool 69

SmartRouter

 tool 69

SmartRouters 297 to 303
role in message-handling 299

SmartSelect 228
configuring 229
creating and placing 228
example of use 232
filtering the data 230

SmartSender

 tool 69

SmartSenders 293 to 296
creating instances 294
filename conventions 294

SmartToolbar 323
configuring 324
creating and placing 323
creating new master 326
limitations 323
tool 69

SmartWindow
configuring 120
creating instance 118
example of use 48, 148

Source code

examining 59

Spin Buttons

 tool
ActiveX 68

Spin Control (ActiveX) 269

configuring 269
creating and placing 269

Starting AppBuilder 54

Static Image object 341

Static Text
example of use 49
style selector and editor 381
tool 68

Static Text object 344

Status bar
AppBuilder main window 56

Stop button
AppBuilder main window 113

String literals
specifying space allocation 375

String-Attributes dialog 375

Subscriptions
persistence 306
preserving across sessions 309

Synchronizing
with master layout 396

T

TEMP-DB
defining temp-tables 71

TEMP-DB database 71
control records 75
importing definitions 78
maintaining 72
synchronizing 84

TEMP-DB Maintenance tool 72
using 75

Templates
adding to New-object list 423

Temp-tables
defining and maintaining 378
temp-tables
defining in TEMP-DB 76
importing definitions 78
include files 71
TEMP-DB database 71

Text
tool 68

Text style
choosing 381
defining 382
Index

Timer
  tool
    ActiveX 68

Timer object
  interrupt-driven 345

Toggle Box 271
  configuring 271
  creating and placing 271
  initial value 272
  tool 67

Tool
  ActiveX (OCX) object 68
  Check-Box. See Toggle Box
  Combo-Box
    ActiveX 68
    basic ABL 67
  Data-Browser
    basic ABL 67
    smart 68
  Data-pump
    Smart 68
  Data-Viewer
    basic ABL 66
    Smart 68
  Editor, multi-line 67
  Editor, single-line 67
  Fill-in 67
  Frame
    basic ABL 67
  Image 67
  pointer 66
  Pushbutton
    basic ABL 67
    smart array 68
  Query 66
  Query-filtering
    smart 69
  Radio-Set 67
  Rectangle 67
  Selection-List 67
  Slider-Control 67
  SmartContainer 69
  SmartDataBrowser 68
  SmartDataField 68
  SmartDataObject 68
  SmartDataReader 68
  SmartDataViewer 68
  SmartFilter 69
  SmartFolder 68
  SmartObject 68, 338
  SmartPanel 68
  SmartToolbar 69
  Spin-Buttons
    ActiveX 68
  Text 68
  Timer
    ActiveX 68
    Toggle-Box 67

Tool bar

AppBuilder main window 64

Tool icons
  adding to Objects Palette 420

Tools
  cancelling selection 70
  latching and unlatching 70
  list of 66
  SmartB2BObject 287
  SmartBusinessObject 174
  SmartConsumer 307
  SmartContainer 143
  SmartProducer 304
  SmartSender 294, 295
  using 69
  XML Schema Mapper PRO*Tool 283

Traversal path
  editing 376

Tree view 97

U

Undoing changes
  Section Editor 103

Usability
  avoid cross-connections 272
  be sparing with colors 357
  be sparing with font changes 383
  fonts as corporate-identity signifier 381
  neatness 146
  role of Pushbutton 333
  role of Toggle Boxes vs Radio Set 271
  use fonts sparingly 381
  violating expectations causes confusion 152

W

Web browser 452

Web preferences 451

web.cst 419

WebSpeed
  AppBuilder for 54
  preferences 89

Widget
  open Property Sheet for 61

Widgets
  See also Objects
  adding to custom object file 424
  capturing changes made by user 41
  defined 40
reading & writing 41
showing changes made by program 41

Window
   basic ABL
      configuring 134
      creating new 57
   opening Property Sheet for 120
Smart
   configuring 120
   creating new 57

Workspaces 97
   allowed objects in 354
   for non-visible objects 97
   saving 114
   testing 113

X

XFTRs. See Extended features

.xmc file type 283

XML
   and HTML 274
   and W3C 274
   defined 274
   schema and mapping files 275

   standards 274
   standards committee 275

XML mapping
   consumer map file extension 283
   creating a map file 283
   creating a record 281
   deleting a record 281
   editor 281
   editor PRO*Tool 281
   external references 301
   finding a record 281
   illustration 276, 277
   inbound/outbound files different 281
   internal references 301
   iteration 280
   mapping schema nodes 285
   node to data column 277
      with conversion 278
   node to function 279
   node to procedure 279
   node to whole data object 280
   options 277
   producer map file extension 283
   schema file extension 283
   selecting resources 283
   starting editor PRO*Tool 283

   .xmp file type 283

   .xsd file type 283