OpenEdge® Management and Explorer: Configuring Multi-tenancy
OpenEdge Management and Explorer: Configuring Multi-tenancy
Chapter 1: Introducing multi-tenancy in OpenEdge Management and OpenEdge Explorer

Chapter 2: Configuring database connections

Chapter 3: Managing multi-tenant databases
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chapter 4: Working with tenants</td>
<td>55</td>
</tr>
<tr>
<td>Creating a new tenant for a multi-tenant database</td>
<td>56</td>
</tr>
<tr>
<td>Allocating tenant partitions</td>
<td>56</td>
</tr>
<tr>
<td>Specifying an alternate buffer pool</td>
<td>57</td>
</tr>
<tr>
<td>Using a tenant configuration program</td>
<td>57</td>
</tr>
<tr>
<td>Creating a new tenant or tenant program</td>
<td>57</td>
</tr>
<tr>
<td>Editing a tenant</td>
<td>60</td>
</tr>
<tr>
<td>Adding a tenant domain</td>
<td>61</td>
</tr>
<tr>
<td>Adding a user to a tenant</td>
<td>62</td>
</tr>
<tr>
<td>Generating a tenant program from an existing tenant</td>
<td>63</td>
</tr>
<tr>
<td>Deleting a tenant</td>
<td>64</td>
</tr>
<tr>
<td>Deleting a tenant domain</td>
<td>64</td>
</tr>
<tr>
<td>Deleting a tenant user</td>
<td>65</td>
</tr>
<tr>
<td>Enabling a table for multi-tenancy</td>
<td>66</td>
</tr>
<tr>
<td>Selecting one or more tables to enable for multi-tenancy</td>
<td>66</td>
</tr>
<tr>
<td>Enabling or disabling access to tenant data</td>
<td>67</td>
</tr>
<tr>
<td>Determining if tenant data access is enabled</td>
<td>68</td>
</tr>
<tr>
<td>Enabling or disabling access</td>
<td>68</td>
</tr>
<tr>
<td>Deallocating tenant tables</td>
<td>69</td>
</tr>
</tbody>
</table>
Chapter 8: Working with sequences ................................................................. 99
   Working with sequences and sequence values ........................................... 99
   Types of sequences .................................................................................... 99
   Sequence functionality and user credentials ............................................ 100
   Creating a multi-tenant sequence and loading a data definition file with sequences .................................................. 101
   Exporting current sequence values ............................................................. 101
   Viewing a list of sequences ......................................................................... 101
   Editing sequence values ............................................................................. 102
   Editing the values for all sequences for a tenant ......................................... 103
   Editing the values for all tenants of a sequence .......................................... 103
   Restoring sequence current values ............................................................. 104
   Exporting sequences for a tenant ................................................................. 104
   Exporting sequences for one or more tenants in the database .................. 104
   Exporting sequence current values for a selected tenant ......................... 105

Chapter 9: Working with tenant groups .......................................................... 107
   Using tenant groups .................................................................................. 107
   Guidelines for using groups ...................................................................... 108
   Creating a group or group program ............................................................ 108
   Editing a group .......................................................................................... 110
   Adding a tenant to a group ........................................................................ 110
   Adding a tenant to a group from the tenant .............................................. 110
   Adding a tenant to a group from the group .............................................. 111
   Viewing a list of tenant groups ................................................................. 112
   Viewing group details ............................................................................... 112
   Searching for available groups ................................................................. 112
   Removing a tenant from a group ............................................................... 113
   Removing a tenant from a group using the tenant .................................... 113
   Removing a tenant from a group using the group .................................... 113

Index ............................................................................................................. 115
Preface

For details, see the following topics:

• Purpose
• Audience
• Organization
• Using this manual
• Typographical conventions
• Examples of syntax descriptions
• Example procedures
• OpenEdge messages

Purpose

This manual describes how you can use the Database Administration Console in OpenEdge Management and OpenEdge Explorer to configure and manage OpenEdge databases that are enabled for multi-tenancy. Not only can you manage tenants and multi-tenant data from the management console, you can do so in a newly designed user interface that incorporates efficient and easy-to-use navigational improvements.
Audience

This manual is intended for OpenEdge Management and OpenEdge Explorer users as well as OpenEdge Management database and system administrators.

Organization

Introducing multi-tenancy in OpenEdge Management and OpenEdge Explorer on page 19
Describes how to work with multi-tenancy. The chapter also describes the management console navigational enhancements and defines some commonly used terms related to multi-tenancy.

Configuring database connections on page 25
Describes database connection types, how to establish a connection to a database, and how to filter database connections. The chapter also provides information about providing required user credentials when working with multi-tenancy enabled databases.

Managing multi-tenant databases on page 33
Describes how to enable a database for multi-tenancy and how to manage the database's areas, domains, groups, schemas, and tenants.

Working with tenants on page 55
Describes how to work with tenants, such as creating, editing, or deleting a tenant; enabling a table for multi-tenancy; or enabling or disabling access to tenant data.

Updating tenant schema on page 71
Describes how to upload and commit schema changes to a database enabled for multi-tenancy; how to configure an area working set; and how to edit storage area assignments for regular tenants.

Managing users and domains in a multi-tenant database on page 79
Describes how to manage users and domains, manage multi-tenant database table security for users, and how to configure database security administrators.

Working with tenant templates on page 93
Describes how to create, use, and edit tenant templates; view a list of tenant templates; and create a tenant from a template.

Working with sequences on page 99
Describes how to work with sequences, edit sequence values, and export sequences for a tenant.

Working with tenant groups on page 107
Describes how to create, use, and edit tenant groups or group programs; remove a tenant from a group; and search for and view available groups.
Using this manual

OpenEdge provides a special purpose programming language for building business applications. In the documentation, the formal name for this language is ABL (Advanced Business Language). With few exceptions, all keywords of the language appear in all UPPERCASE, using a font that is appropriate to the context. All other alphabetic language content appears in mixed case.

For the latest documentation updates see the OpenEdge Product Documentation Overview page on Progress Communities:


References to ABL compiler and run-time features

ABL is both a compiled and an interpreted language that executes in a run-time engine. The documentation refers to this run-time engine as the ABL Virtual Machine (AVM). When the documentation refers to ABL source code compilation, it specifies ABL or the compiler as the actor that manages compile-time features of the language. When the documentation refers to run-time behavior in an executing ABL program, it specifies the AVM as the actor that manages the specified run-time behavior in the program.

For example, these sentences refer to the ABL compiler's allowance for parameter passing and the AVM's possible response to that parameter passing at run time: "ABL allows you to pass a dynamic temp-table handle as a static temp-table parameter of a method. However, if at run time the passed dynamic temp-table schema does not match the schema of the static temp-table parameter, the AVM raises an error." The following sentence refers to run-time actions that the AVM can perform using a particular ABL feature: "The ABL socket object handle allows the AVM to connect with other ABL and non-ABL sessions using TCP/IP sockets."

References to ABL data types

ABL provides built-in data types, built-in class data types, and user-defined class data types. References to built-in data types follow these rules:

- Like most other keywords, references to specific built-in data types appear in all UPPERCASE, using a font that is appropriate to the context. No uppercase reference ever includes or implies any data type other than itself.
- Wherever integer appears, this is a reference to the INTEGER or INT64 data type.
- Wherever character appears, this is a reference to the CHARACTER, LONGCHAR, or CLOB data type.
- Wherever decimal appears, this is a reference to the DECIMAL data type.
- Wherever numeric appears, this is a reference to the INTEGER, INT64, or DECIMAL data type.

References to built-in class data types appear in mixed case with initial caps, for example, Progress.Lang.Object. References to user-defined class data types appear in mixed case, as specified for a given application example.
## Typographical conventions

This manual uses the following typographical and syntax conventions:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Bold typeface indicates commands or characters the user types, provides emphasis, or the names of user interface elements.</td>
</tr>
<tr>
<td><em>Italic</em></td>
<td>Italic typeface indicates the title of a document, or signifies new terms.</td>
</tr>
<tr>
<td>SMALL, BOLD CAPITAL LETTERS</td>
<td>Small, bold capital letters indicate OpenEdge key functions and generic keyboard keys; for example, GET and CTRL.</td>
</tr>
<tr>
<td>KEY1+KEY2</td>
<td>A plus sign between key names indicates a <em>simultaneous</em> key sequence: you press and hold down the first key while pressing the second key. For example, CTRL+X.</td>
</tr>
<tr>
<td>KEY1 KEY2</td>
<td>A space between key names indicates a <em>sequential</em> key sequence: you press and release the first key, then press another key. For example, ESCAPE H.</td>
</tr>
<tr>
<td><strong>Syntax:</strong></td>
<td></td>
</tr>
<tr>
<td>Fixed width</td>
<td>A fixed-width font is used in syntax, code examples, system output, and file names.</td>
</tr>
<tr>
<td>Fixed-width italics</td>
<td>Fixed-width italics indicate variables in syntax.</td>
</tr>
<tr>
<td>Fixed-width bold</td>
<td>Fixed-width bold italic indicates variables in syntax with special emphasis.</td>
</tr>
<tr>
<td>UPPERCASE fixed width</td>
<td>ABL keywords in syntax and code examples are almost always shown in upper case. Although shown in uppercase, you can type ABL keywords in either uppercase or lowercase in a procedure or class.</td>
</tr>
<tr>
<td>Period (.) or colon (:)</td>
<td>All statements except <strong>DO, FOR, FUNCTION, PROCEDURE, and REPEAT</strong> end with a period. <strong>DO, FOR, FUNCTION, PROCEDURE, and REPEAT</strong> statements can end with either a period or a colon.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Large brackets indicate the items within them are optional.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Small brackets are part of ABL.</td>
</tr>
<tr>
<td>{ }</td>
<td>Large braces indicate the items within them are required. They are used to simplify complex syntax diagrams.</td>
</tr>
</tbody>
</table>
### Examples of syntax descriptions

In this example, ACCUM is a keyword, and aggregate and expression are variables:

**Syntax**

```
ACCUM aggregate expression
```

FOR is one of the statements that can end with either a period or a colon, as in this example:

```
FOR EACH Customer NO-LOCK:
    DISPLAY Customer.Name.
END.
```

In this example, STREAM stream, UNLESS-HIDDEN, and NO-ERROR are optional:

**Syntax**

```
DISPLAY [ STREAM stream ] [ UNLESS-HIDDEN ] [ NO-ERROR ]
```

In this example, the outer (small) brackets are part of the language, and the inner (large) brackets denote an optional item:

**Syntax**

```
INITIAL [ constant [ , constant ] ]
```

A called external procedure must use braces when referencing compile-time arguments passed by a calling procedure, as shown in this example:

```
{} Small braces are part of ABL. For example, a called external procedure must use braces when referencing arguments passed by a calling procedure.
```

```
| A vertical bar indicates a choice.
```

```
... Ellipses indicate repetition: you can choose one or more of the preceding items.
```
Syntax

{ &argument-name }

In this example, EACH, FIRST, and LAST are optional, but you can choose only one of them:

Syntax

PRESELECT [ EACH | FIRST | LAST ] record-phrase

In this example, you must include two expressions, and optionally you can include more. Multiple expressions are separated by commas:

Syntax

MAXIMUM ( expression , expression [ , expression ] ... )

In this example, you must specify MESSAGE and at least one expression or SKIP \( ( n ) \), and any number of additional expression or SKIP \( ( n ) \) is allowed:

Syntax

MESSAGE { expression | SKIP [ ( n ) ] } ... 

In this example, you must specify \{include-file, then optionally any number of argument or &argument-name = "argument-value", and then terminate with \}: 

Syntax

{ include-file 
  [ argument | &argument-name = "argument-value" ] ... } 

Long syntax descriptions split across lines

Some syntax descriptions are too long to fit on one line. When syntax descriptions are split across multiple lines, groups of optional and groups of required items are kept together in the required order.

In this example, WITH is followed by six optional items:
Syntax

WITH [ ACCUM max-length ] [ expression DOWN ]
[ CENTERED ] [ n COLUMNS ] [ SIDE-LABELS ]
[ STREAM-IO ]

Complex syntax descriptions with both required and optional elements

Some syntax descriptions are too complex to distinguish required and optional elements by bracketing only the optional elements. For such syntax, the descriptions include both braces (for required elements) and brackets (for optional elements).

In this example, ASSIGN requires either one or more field entries or one record. Options available with field or record are grouped with braces and brackets:

Syntax

| { record [ EXCEPT field . . . ] }|

Example procedures

This manual may provide example code that illustrates syntax and concepts. You can access many of the example files, and details for installing them, from the following locations:

- A self-extracting Documentation and Samples file available on the OpenEdge download page of the Progress Software Download Center
- The OpenEdge Product Documentation Overview page on Progress Communities:

https://community.progress.com/technicalusers/w/openedgegeneral/
1329.openedge-product-documentation-overview.aspx

Once installed, you can locate the example files for this manual in the following path under the OpenEdge Documentation and Samples installation directory:

<table>
<thead>
<tr>
<th>This directory . . .</th>
<th>Contains examples for the following documents . . .</th>
</tr>
</thead>
<tbody>
<tr>
<td>src\prodoc\dotnetobjects</td>
<td>OpenEdge Development: GUI for .NET Programming</td>
</tr>
<tr>
<td>src\prodoc\dynamics</td>
<td>The Progress Dynamics documentation</td>
</tr>
</tbody>
</table>
OpenEdge displays several types of messages to inform you of routine and unusual occurrences:

- **Execution messages** inform you of errors encountered while OpenEdge is running a procedure; for example, if OpenEdge cannot find a record with a specified index field value.

- **Compile messages** inform you of errors found while OpenEdge is reading and analyzing a procedure before running it; for example, if a procedure references a table name that is not defined in the database.

- **Startup messages** inform you of unusual conditions detected while OpenEdge is getting ready to execute; for example, if you entered an invalid startup parameter.

After displaying a message, OpenEdge proceeds in one of several ways:

- Continues execution, subject to the error-processing actions that you specify or that are assumed as part of the procedure. This is the most common action taken after execution messages.

- Returns to the Procedure Editor, so you can correct an error in a procedure. This is the usual action taken after compiler messages.

- Halts processing of a procedure and returns immediately to the Procedure Editor. This does not happen often.

- Terminates the current session.
OpenEdge messages end with a message number in parentheses. In this example, the message number is 200:

```
** Unknown table name table. (200)
```

If you encounter an error that terminates OpenEdge, note the message number before restarting.

**Obtaining more information about OpenEdge messages**

In Windows platforms, use OpenEdge online help to obtain more information about OpenEdge messages. Many OpenEdge tools include the following Help menu options to provide information about messages:

- Choose **Help > Recent Messages** to display detailed descriptions of the most recent OpenEdge message and all other messages returned in the current session.
- Choose **Help > Messages** and then type the message number to display a description of a specific OpenEdge message.
- In the Procedure Editor, press the HELP key or F1.

On UNIX platforms, use the OpenEdge pro command to start a single-user mode character OpenEdge client session and view a brief description of a message by providing its number.

**To use the pro command to obtain a message description by message number:**

1. Start the Procedure Editor:

   ```
   OpenEdge-install-dir/bin/pro
   ```

2. Press F3 to access the menu bar, then choose **Help > Messages**.
3. Type the message number and press ENTER. Details about that message number appear.
4. Press F4 to close the message, press F3 to access the Procedure Editor menu, and choose **File > Exit**.
Introducing multi-tenancy in OpenEdge Management and OpenEdge Explorer

OpenEdge Management/OpenEdge Explorer now includes multi-tenancy configuration functionality, which allows you to manage and work with databases enabled for multi-tenancy. From the management console, you can access the Database Administration Console and perform a variety of different tasks, such as adding a local or remote database connection definition; creating new tenants and viewing their areas, domains, and partitions; uploading and previewing schema updates; making storage area and allocation or deallocation decisions; filtering views; and creating and working with tenant templates and tenant groups.

You can also enable local and remote databases for multi-tenancy, convert tables to multi-tenancy, and establish and manage user and table security settings. Support for viewing, exporting, and editing values for sequences is also available. You can commit configuration changes you make and then view the progress of each transaction in a viewlet in the Dashboard page.

For details, see the following topics:

- Working with multi-tenancy in the Database Administration Console
- Common terminology
Chapter 1: Introducing multi-tenancy in OpenEdge Management and OpenEdge Explorer

Working with multi-tenancy in the Database Administration Console

OpenEdge Management and OpenEdge Explorer have been enhanced to introduce support for OpenEdge database multi-tenancy. Through the Database Administration Console, which is incorporated into the management console, you can manage tenants and multi-tenant data from the management console. You can do so in a newly designed user interface that incorporates efficient and easy-to-use navigational improvements.

From the Database Administration Console, you can perform multi-tenancy configuration by:

- **Converting a non-multi-tenant database to one configured for multi-tenancy** — You can quickly enable multi-tenancy for a database.

- **Establishing connections to multi-tenant databases** — You can set up local and remote connections to managed databases or scripted databases. These databases appear automatically in the list of database resources in the management console.

  You can also set up unmanaged local or remote database connections. Depending on the type of connection you define, you can also edit, copy, and/or delete it.

- **Creating new database tenants, deleting tenants, or generating a tenant creation program** — You can create two types of tenants: a regular tenant or a super-tenant. You can also delete a tenant.

  Alternatively, you can generate a tenant program based on preferred settings for either an existing tenant or a new tenant. You can use the resultant generated program in the future to create a tenant quickly, without needing to resupply the settings saved in the program. You can also create a tenant from an existing tenant.

- **Enabling a table for multi-tenancy** — You can enable one or more tables for multi-tenancy and then allocate the table’s partitions.

- **Creating a tenant template** — You can create, view, and edit a template that includes tenant-specific details, such as default storage areas and per-object tenant mapping, so you can reuse the template to create another tenant.

- **Creating a tenant group** — You can create, view, and edit a tenant group and add one or more tenants to it. A group is a partition for a table and partitions for any of the LOB fields and indexes in the table. Each tenant in the group has shared access to the partition and its data.

  You can also generate a group creation program based on preferred settings, and use the program in the future to create a group quickly or that you can use to transfer a group from one database to another database.

- **Working with existing tenants and multi-tenant database objects** — You can work easily with existing tenants to accomplish various tasks related to multi-tenancy configuration, such as:

  - Viewing an alphabetical list of all tenants in the currently selected database.
  
  - Accessing utilities by selecting a tenant.
  
  - Viewing a tenant's layout, including the database object schema, tenant object areas, and object properties. Color coding in the partition layout allows you to see easily each object's allocation state.
You can also view tenant partition details and choose how the data is displayed: within area panels or by columns in a grid format. The grid format allows you to choose the information you want to see (partition name, area, allocation state, and/or object type) and sort the information in ascending or descending alphabetical order.

- Deciding when storage space is to be allocated for a tenant's data: immediately, delayed (for now), or not at all. You can also deallocate a table for a tenant or a group, freeing up storage space.
- Specifying storage area assignments for a tenant's tables (which apply to their indexes and LOB fields). If you choose not to allocate storage space immediately when you create a tenant, you can reorganize the layout of the multi-tenant database objects, such as moving a table from one area to another area.
- Filtering the tenant list so you can focus on specific tenants. For example, you can set up the list so that you see only regular tenants or tenants categorized by allocation rule.
- Adding one or more tenant domains by choosing from a predefined domain list.
- Adding one or more users to a tenant.
- Searching for a particular tenant.
- Selecting which of a tenant's areas you want to see when you look at the tenant's area layout. By choosing the areas you want to see, known as the areaworking set, you can focus only on areas of current interest to you.
- Filtering the partition view by allocation state for a tenant or a tenant template.
- Enabling or disabling access to a regular tenant's data.

**Note:** The OpenEdge Management console displays an error when you update a multi-tenant database object that already has an exclusive lock from another multi-tenant data source.

- **Loading and previewing a data definition file** — You can upload a data definition file (.df) and preview its contents (tables, LOB fields, indexes, and sequences) before you commit the changes.
- **Load database contents** — You can load table and group contents into an active database. The database must have table definitions before you can load table or group contents. The console uses the .d files to load table contents from a directory you specify or to load group contents from the subdirectory for groups you specify.

**Note:** You must have administrator privileges to load table and group contents.

- **Dump database contents** — You can dump table or group data in a text format from the console. The console creates a text file that contains the dump data of each table or group you specify. This file has a .d extension and is stored in the work directory you specify. You can dump data either from a shared table, a multi-tenant table, or both. You can also dump data from a group of tenants sharing a table. You can use these .d files to load data into a database. The console creates a separate contents file for each table or group you dump.

**Note:** You must have administrator privileges to dump table and group contents.
• **Committing and monitoring database updates** — You can commit updates to the database, either from an uploaded data definition file or as a result of other changes you make.

As changes are being saved to the database, the **Dashboard** page opens to allow you to monitor the updates’ progress. The page presents a task viewlet that shows the activity as the updates are being applied.

• **Filtering database connections by AdminServer** — You can view all database connections for all AdminServers, or you can choose which AdminServer’s connections you want to view.

• **Managing domains** — You can create and modify a domain for each tenant.

• **Managing authentication systems** — You can view, create, or delete authentication systems.

• **Establishing and managing user and table security settings** — While you can create and work with users for a particular tenant, you can also create, edit, and delete users at the database level. You can define and review table and field security for the database users, and you can review a summary that provides details about the database’s security.

You can also configure one or more security administrators who have control over authentication and authorization.

• **Managing sequence definitions and values** — You can manage sequences and sequence values by:
  
  • Viewing a list of all sequences in a database. This includes both the sequences enabled for multi-tenancy and those not enabled.
  
  • Viewing and editing the current values for multi-tenant-enabled sequences for a specific tenant.
  
  • Viewing and editing the current values for all tenants of a sequence.
  
  • Exporting sequence current values for one tenant, multiple tenants, or all tenants in a multi-tenant database.

• **Improve database performance** — The performance of a multi-tenant database may be improved by using multi-tenant governors: Login Governor (-nGovernor) and Lock Governor (-LGovernor). These governors limit the amount of each individual tenant's allocation of shared database resources, so that one tenant does not fully control these resources at the expense of all of the other tenants. These governors apply to the default and regular tenants in a multi-tenant database. They do not apply to super-tenants.

*Note:* Full access to a tenant's sequences functionality requires a database connection for a user associated with either a super-tenant or that specific tenant.

**Common terminology**

As you manage multiple tenants and multi-tenant database objects in OpenEdge Management/OpenEdge Explorer, there are several terms with which you will become familiar. These terms are described in the following sections.
**Tenant**

There are three types of tenants: *default*, *regular*, and *super tenant*.

The default tenant in a multi-tenant database is a user who does not establish tenancy as part of authentication to the database. Because the user has not established tenancy, the default tenant can access only shared table data within the database or the default partition of a multi-tenant table. There is only one default tenant per multi-tenant database.

A regular tenant can access its own data, data for any other tenants in the same tenant group, or data in shared tables. (A shared table is one whose data is available to all tenants in the database.)

A super-tenant does not have its own data but can access all shared tables and all multi-tenant data in the database.

**Area**

An *area* is a physical layout on disk and represents physical storage. An area can contain multiple partitions.

**Partition**

A *partition* is a logical organizing of data by tenant and by object (table, index, or LOB field) within an area. A partition is contained inside a single area.

For shared tables there is one partition per table, index, and LOB field. For multi-tenant tables there is one partition for each table, index, and LOB field per tenant.

Tenants in a group share the partitions for the table and each associated LOB field and index.

**Group**

A group is a partition for a table, along with partitions for the table's LOB fields and indexes, that can be shared by tenants. All tenants in a group have access to the same data in the table. When you create a group, you create an independent partition that multiple tenants view.

**Default area**

When you convert an existing shared table to one enabled for multi-tenancy, you can decide whether to save the existing table data, known as the default area. If you are creating a new multi-tenant table, you can also decide whether to create (keep) the area for the default tenant.

**Allocation**

Creating a new tenant in an existing multi-tenant database results in the establishment of a new tenant partition for each existing multi-tenant table defined in the database. You can assign a specific storage area for each table, its indexes, and its LOB fields, or you can use the previously defined default locations.

You can also specify if or when partitions for a table should be allocated. The allocation decision you make for a table also applies to the table's indexes and LOB fields.

You can deallocate a multi-tenant table from a tenant or a group. Deallocation can be helpful in freeing up storage space so that it is available for reuse.
Configuring database connections

The Database Administration Console provides you with the flexibility to work with a database on a machine that is local to or remote from where you have installed OpenEdge Management/OpenEdge Explorer. To perform tasks in the Database Administration Console, you must specify a connection to the database.

For details, see the following topics:

• Understanding database connection types
• Establishing a database connection
• Providing database connection user credentials

Understanding database connection types

The machine on which OpenEdge Management/OpenEdge Explorer is installed is known as the local host. The remote host where the database resides is known as the remote AdminServer.

All databases, whether on the local host or a remote AdminServer, must be OpenEdge Version 11.0.

You can configure the following database connections:

• A managed connection, which refers to a database that is either of the following:
  • Managed database — A database that is being managed by OpenEdge Management or OpenEdge Explorer. The database can reside on the local host or on a remote AdminServer. For a managed database, the connection is made through shared memory.
• **Scripted database** — A database that you start with a script outside of the OpenEdge Management or OpenEdge Explorer environment. The database can reside on the local host or on a remote AdminServer.

• An unmanaged database connection, which refers to a database that:
  • Is not being managed by OpenEdge Management or OpenEdge Explorer.
  • You are using only to perform database administration tasks related to multi-tenancy.

This type of database connection is new in this release of OpenEdge.

You can work with a database on a remote AdminServer by doing the following:

1. **Reviewing the remote configuration requirements** on page 26
2. **Ungluing OpenEdge Management/OpenEdge Explorer from OpenEdge** on page 26

### Reviewing the remote configuration requirements

Remote configuration requires that you have:

• **On the local host** — One OpenEdge installation that includes OpenEdge Management or OpenEdge Explorer

• **On the remote host** — An installation of one OpenEdge product (Release 11.0 onwards)

On the remote host with the OpenEdge installation, neither OpenEdge Management nor OpenEdge Explorer can be enabled. If either is enabled, you must disable it in the OpenEdge product by running a script known as `unglue`.

For more information, see `Ungluing OpenEdge Management/OpenEdge Explorer from OpenEdge` on page 26. If OpenEdge Management/OpenEdge Explorer is already disabled on the remote AdminServer, you can begin setting up remote configuration; see the Setting up a remote AdminServer section of *OpenEdge Management and OpenEdge Explorer: Getting Started*.

### Ungluing OpenEdge Management/OpenEdge Explorer from OpenEdge

If the host machine you plan to use as the remote AdminServer has OpenEdge Management/OpenEdge Explorer installed as part of OpenEdge, you must disable (unglue) it before you can set up remote configuration.

To unglue OpenEdge Management/OpenEdge Explorer from OpenEdge on the remote AdminServer:

1. Shut down the AdminServer.
2. To unglue on a Windows machine, select **Start > Programs (or All Programs) > Progress > OpenEdge > Proenv**. The **Proenv** window opens.

To unglue on a UNIX machine, log in as root in a terminal window and then run **Proenv**. If you do not know the root password for your system, consult with your system administrator.
3. At the prompt or from the bin directory of the OpenEdge installation, type `unglue`, as shown here for a Windows install:

```
install-dir\unglue
```

4. Type `y` at the prompt asking you if you want to continue, and then press **ENTER**.

---

**Establishing a database connection**

OpenEdge Management/OpenEdge Explorer allows you to work with multi-tenant databases and their schema from the Database Administration Console running in a Web browser. From the console, you can establish database connections, create tenants, edit tenant configuration, upload and preview schema updates, create tenant templates, create tenant groups, filter views, and commit updates and monitor their progress.

Once you install and configure OpenEdge Management/OpenEdge Explorer, you are ready to start managing multi-tenant databases and their objects. You begin by establishing a database connection. By default, connections for databases defined in OpenEdge Management/OpenEdge Explorer use the blank user ID.

However, you can set up the connection to provide user credentials (user name and password). The availability of certain features and functionality is dependent upon the permissions that exist for the user whose name and password establish the connection as well as on the type of tenant the user belongs to.

For more information, see Providing database connection user credentials on page 30.

---

**Setting up the connection**

To work with a database’s multi-tenant objects, you must set up a connection to the database and the database’s server must be running. The connection can be:

- To a local or remote managed database resource
- To a local or remote scripted database
- To a local or remote database using an unmanaged connection

**Establishing a connection to a local or remote managed database resource**

If the database is a resource already being managed by OpenEdge Management/OpenEdge Explorer, you can start the database through the management console by doing the following:

1. Log in to OpenEdge Management/OpenEdge Explorer.
2. Click **Resources > Go to Resources** in the management console menu.
   
   All resources managed by your console appear in the grid frame of **Resources** page.
3. Filter or search for, and select the database you want to start.
4. You can start the database by doing either of the following:
Click Start brokers in the Resources page.
Click Start in the Resource Summary section of the Resources page.
Select the database to access the database details page and click Start Database.

Once the database is running, you can select it as a database connection.

For a local or remote managed database in the database connections list, you can also:
• View details about a database connection on the database home page. For more information, see Managing multi-tenant databases on page 33.
• Copy a database connection. When you copy a connection, you are not copying the actual database resource; you are copying only the connection details. The connection copy does not represent a database resource being managed by OpenEdge Management/OpenEdge Explorer.
• Delete a database connection.

Establishing a connection to a local or remote scripted database

If the database is not being managed from within OpenEdge Management/OpenEdge Explorer, you can start the database on the machine where it is located (either the local host or a remote host) using the command line. You can then use the Database Administration Console to work with that database once you define a connection to it.

When you define a scripted database on a remote AdminServer, be sure to use localhost as the database's host. This allows the ABL commands to execute on the remote AdminServer and connect to the database by using shared memory.

When you use localhost, the database is included in both the Resources list in OpenEdge Management/OpenEdge Explorer and the Database Administration Console's Connections list.

If you do not use localhost, the database is still listed as a resource but does not appear in the Connections list.

If you do not define the host as localhost for the scripted database on the remote AdminServer, you must add the database connection manually and specify the host and port required for the connection. In this case, the connection to the database is performed using the -H (host name) and -S (service name or port) parameters, and the database appears in the Connections list but not the Resources list in the management console.

To establish a connection to a scripted database:

1. On the machine where the scripted database resides (either the local host or a remote host), start Proenv (by choosing Start > Programs (or All Programs) > Progress > OpenEdge > Proenv).
2. Type the following command to start the database:

   \[ proserve { db-name | -servergroup [ server-group-name ] [ parameters ] } \]

3. Exit Proenv.
4. To add the database to the list of database resources, perform the following steps on the machine where OpenEdge Management/OpenEdge Explorer is installed.
5. Select Resources > New > Scripted Database in the management console.

The Create Scripted Database Monitor page appears.
6. Complete the page:
   a) Provide the following information:
      • **Name** — Name of the database.
      • **Description** — A description of the database (optional).
   b) Type the host name.
   c) Provide an IP Address (optional).
   d) Select the TCP/IP version (**IPv4** or **IPv6**).
   e) Type the complete path to the database.
   f) To enable the scripted database after creation, select the **Enabled** option.
   g) Click **Save**.

   The **Database** details page appears

7. Click **Control**.

8. Choose one:
   • If you are connecting to a scripted database on the local host:
     1. Copy the command line from the **Command line to start Monitoring Agent**.
     2. Start **Proenv**, and paste the command line details at the prompt.
     3. Exit **Proenv**.
   • If you are connecting to a scripted database on a remote host:
     1. On the local host, note the command line from the **Command line to start Monitoring Agent**.
     2. Start **Proenv** on the remote machine.
     3. Type the command line details at the prompt.
     4. Exit **Proenv**.

9. From the management console on the local host, return to the **Database** details page. The database and the database agent are now running.

   For a local or remote scripted database in the database connections list, you can also:
   • View details about a scripted database connection on the database home page. For more information, see Managing multi-tenant databases on page 33.
   • Copy a scripted database connection.

**Establishing a connection to an unmanaged local or remote database connection**

An unmanaged database connection refers to a database that is not being managed by OpenEdge Management/OpenEdge Explorer and that you are using only to perform database administration tasks related to multi-tenancy.

You can start an unmanaged database connection (located on the local host or a remote host) by using the command line. You can then use the multi-tenancy configuration tool to work with that database once you define a connection to it.
1. On the machine where the scripted database resides (either the local host or a remote host), start Proenv (Start > Programs (or All Programs) > Progress > OpenEdge > Proenv).

2. Type the following command to start the database:

```
proserve { db-name | -servergroup [ server-group-name ] [ parameters ] }
```

3. From the management console menu on the machine where OpenEdge Management/OpenEdge Explorer is installed, choose Database Administration > New > Database Connection.

   The Edit Database Connection page appears.

4. Provide the following information:
   - **Connection name** — Enter the name of the database connection. This is a mandatory field.
   - **Category** — Enter the category of the database connection. You can enter a category name, such as tenant, tp, or oem, to distinguish between the connections.
   - **Database name** — Enter the full path to the database. This is a mandatory field.
   - **Host** — Enter the host (local or remote) location of the database connection.
   - **Service name or port** — Enter the host name port.
   - **AdminServer** — Select an AdminServer from the list. This is a mandatory field.
   - Select the Make database connection visible only to me option to control the visibility of the connection. As an administrator, you can use this option to control which connections you want to share with other administrators or operators.

5. Click Save.

   For a local or remote unmanaged database connection in the database connections list, you can also:
   - View details about an unmanaged database connection on the database home page. For more information, see Managing multi-tenant databases on page 33.
   - Copy an unmanaged database connection.
   - Delete an unmanaged database connection.

### Providing database connection user credentials

Each database connection is based on a set of user credentials. The availability of certain database and multi-tenancy features and functionality is dependent upon the permissions that exist for the user whose credentials establish the connection, as well as upon the type of tenant the user belongs to. For example, certain users can read data and write to the database, but not delete data; and a super-tenant can view and edit sequence values for all tenants, whereas a regular tenant user can do so only for the tenant the user belongs to.

Access to certain multi-tenancy configuration features might be restricted, disabled, or hidden based on the credentials (user ID and password) provided for the database connection.
User credentials considerations

By default, a connection for a database defined in OpenEdge Management/OpenEdge Explorer uses a blank user ID, in which no user name or password is required. However, if you are a database administrator working with multi-tenant databases, you must consider how to manage tenants effectively and the role that user credentials play in the tenants’ successful management.

OpenEdge Management/OpenEdge Explorer permits only one set of user credentials (user ID and password) per database connection; it does not, however, require the credentials. Any user with a login to OpenEdge Management/OpenEdge Explorer can see any database connection defined in it. Passwords are encrypted and stored internally and are not visible in the user interface.

Because of this default structure, you may need to establish or change database connection credentials. You may also need to establish multiple database connections for the same database to allow performance of specific tasks as different users.

Database connection credentials for a regular tenant or super-tenant

In order to access tenant data, you must set up the database connection to use the credentials for either a user for a regular tenant or for a super-tenant. Because super-tenant's can access all users' data, establishing a database connection as a super-tenant will allow you to perform operations such as dumping and loading of data and editing sequences for any tenant. If you establish a connection with the credentials of a user for a regular tenant, you can perform operations for only that tenant.

Regardless of how you set up the connection, the operations you can perform are defined by the user data security permissions defined for the database in a series of Can-* actions. (For more information, see Managing multi-tenant database table security for users on page 85.) You can use wildcards to allow the performance of certain operations that any user would normally be permitted to do. Likewise, you can restrict which users can perform specific tasks. For example, by default any user can create a tenant. You can prevent this by setting up the Can-Create action to permit only a select user to do so.

Security administrators

Keep in mind that a database may have one or more security administrators in place. A security administrator has the authority to create and delete database users, which includes tenant users. If your database has security administrators configured and you must be able to manage users from within OpenEdge Management/OpenEdge Explorer, be sure that the database credentials you use to establish the database connection have security administrator rights.
Managing multi-tenant databases

You can establish a connection to a database that is enabled for multi-tenancy. You can also connect to a database that is not enabled for multi-tenancy, and then enable multi-tenancy for the database from the Database Administration Console.

For details, see the following topics:

• Enabling a database for multi-tenancy
• Managing a multi-tenant database
• Viewing multi-tenant database areas, domains, schemas, tenants, and groups

Enabling a database for multi-tenancy

You can enable a database for multi-tenancy from the Database Administration Console.

To enable a database for multi-tenancy:

1. On the management console menu, select Database Administration > Go to Database Administration.
   The Database Administration page appears.
2. Filter or search for, and select the database connection.
   The database connection home page appears.
3. In the Database Features section, verify the Multi-tenancy status.
   (Note that you can click the Sort arrow to display the features in ascending or descending order.)
If the status is a check mark in a green circle and the word Enable does not appear in the Action column, the database is already enabled for multi-tenancy.

4. Click Enable.

The Enable Multi-tenancy page appears.

5. Click Enable Multi-tenancy.

A message appears confirming that the database is now multi-tenant.

6. Click OK.

The database home page appears, and the multi-tenancy status for the database reflects that the database is now enabled.

Managing a multi-tenant database

Once you establish a connection to a database enabled for multi-tenancy, you can:

• Use the database connection home page to manage and view various details about multi-tenancy users, domains, authentication systems, and security for the database.

To access the database home page:

• Select Database Administration > Go to Database Administration in the management console menu.

• On the Database Administration page, filter or search for, and select the required database connection.

The database connection home page appears.

• View and work with the areas, domains, schemas (tables, LOB fields, indexes, and sequences), tenants, and groups that belong to the database.

Viewing database connection details

From the database home page, you can see various database details that assist you in managing multi-tenancy. The multi-tenancy-related actions you can perform from the home page are dependent upon the type of database connection you define. For a managed database, a scripted database, or an unmanaged database connection, you can:

• Manage and edit a database connection.

• Review database connection features; for example, you can see if the database is enabled for multi-tenancy or has support for 64-bit sequences.

• Manage, edit, and review database security settings for users, and create one or more security administrators.

• View a security summary, which includes details about various characteristics of the database, such as whether establishing user credentials with a blank user id is allowed; how many database users exist; how many tenants are defined in the database; and additional statistics. Once you review the summary information, you can edit certain database options, modify user or domain properties, or create a tenant.
Note that if the database whose summary you are viewing is not enabled for multi-tenancy, the summary does not include any of the details that relate specifically to multi-tenancy.

- Perform data administration by editing sequences and their current values, exporting sequences, or previewing and/or loading a data definition file.

For an unmanaged database, you can also delete the database connection from the database home page.

### Reviewing database features

From the database home page, you can review a database feature status list. The status for each feature that is enabled appears as a check mark in a green circle.

If you are reviewing features for a database that is not enabled for multi-tenancy, you can enable multi-tenancy for the database from the Database Features section. For more information, see Enabling a database for multi-tenancy on page 33.

To review database features:

1. On the management console menu, select Database Administration > Go to Database Administration.
   
   The Database Administration page appears.

2. Filter or search for, and select the required database connection.
   
   The database connection home page appears.

3. Scroll through the entries in the Database Features section to see the status of one or more database features, such as large keys, 64-bit sequences, or 64-bit database keys.
   
   You can click the Sort arrow below the Feature Name column heading to sort the features in ascending or descending order.

   A status appears for a feature as long as the feature is enabled, with the exception of multi-tenancy. The status for multi-tenancy appears whether or not the database is enabled as multi-tenant. If multi-tenancy is not enabled, the Database Features panel provides that detail. You can then enable multi-tenancy for the database directly from that panel. For more information, see Enabling a database for multi-tenancy on page 33.

### Reviewing the database security summary

From the database home page, you can review security information and work with different multi-tenancy components.

Note that if the database whose summary you are viewing is not enabled for multi-tenancy, you do not see any of the details that relate specifically to multi-tenancy. You can enable the database for multi-tenancy by clicking Enable in the Action column in the Database Features section, also on the database home page. For more information, see Enabling a database for multi-tenancy on page 33.

To review the database security summary:
1. On the management console menu, select **Database Administration > Go to Database Administration**.
   
The **Database Administration** page appears.

2. Filter or search for, and select the required database connection.
   
The database connection home page appears.

3. Review the following information about the database provided in the **Security Summary** section:
   
   - **Blank user id access** — Whether users are allowed to connect using the blank user id.
   - **Security administrator** — Whether there is a security administrator defined for the database. You create a security administrator by clicking **Edit security administrator**. For more information, see [Configuring database security administrators](#) on page 88.
   - **Users** — The number of users in the database.
   - **Domains** — The total number of domains (active and disabled) in the database.
   - **Disabled domains** — The number of disabled (inactive) domains in the database.
   - **Tenants** — The total number of tenants in the database. This number includes the default tenant, super-tenants, and named regular tenants.
   - **Super-tenants** — The number of super-tenants in the database.
   - **Named regular tenants** — The number of named regular tenants in the database. This number excludes the super-tenants and the default tenant.

**Working with the database from the security summary**

In addition to reviewing the details in the database security summary, you can also manage database functionality from the summary.

You can select:

- **Edit security options** to define security options for your database.
- **Edit security administrator** to add users and user domains as security administrators.
- **Edit users** to view the **Edit Database Users** page, where you can review, add, or delete users.
- **Edit domains** to view the **Edit Database Domains** page, where you can review, add, or delete domains.
- **Create tenant** to view the **New Tenant** page, where you can create a tenant for the database.
- **Edit authentication systems** to open the **Edit Database Authentication Systems** page, where you can view, create, or delete authentication systems.
- **Edit data security** to access the user data security page and set or remove user permissions for the data.
- **Review user data security** to review the data security permissions for a particular user.

**Reviewing sequences details**

From the **Data Administration** panel in the database home page, you can view and edit sequences and export sequence values.

To review sequence details:
1. On the management console menu, select **Database Administration > Go to Database Administration**.
   The **Database Administration** page appears.

2. Filter or search for, and select the required database connection.
   The database connection home page appears.

3. In the **Data Administration** section:
   - Click **Edit sequences**. The **Edit Database Sequences** properties page appears, with a list of the sequence names and entries for current values for both multi-tenant-enabled and non-multi-tenant-enabled sequences.
     For information about editing sequences, see **Editing sequence values** on page 102.
   - Click **Export sequences**. The **Export Sequence current Values** page appears.
     For information about exporting sequences, see **Exporting sequences for a tenant** on page 104.

---

**Loading a data definition file**

From the **Data Administration** section in the database home page, you can load a data definition file that you can then preview and/or load.

To load a data definition file:

1. On the management console menu, select **Database Administration > Go to Database Administration**.
   The **Database Administration** page appears.

2. Filter or search for, and select the required database connection.
   The database connection home page appears.

3. In the **Data Administration** section, click **Load data definitions (.df file)**.
   For information about loading, previewing, and committing a data definition file, see **Uploading schema for a multi-tenant database** on page 71.

---

**Loading database contents**

The Database Administration console of OpenEdge Management or OpenEdge Explorer enables you to load table and group contents into an active database. The database must have table definitions before you can load table or group contents. The console uses the .d files to load table contents from a directory you specify or to load group contents from the sub-directory for groups you specify. By default, the .d files used for loading table contents is stored in the work directory C:\OpenEdge\WRK and the .d files used for loading group contents is stored in the groups sub-directory of the work directory.

**Note:** You must have administrator privileges to load table and group contents.
Loading table contents to a database

The Database Administration console uses the .d files to load table contents from the sub-directory for tables you specify.

To load table contents:

1. In the management console menu, do one of the following:
   - Select Database Administration > Load > Table Contents (.d files).
   - Select Database Administration > Go to Database Administration. The Database Administration page appears.
     Filter or search for, and select the required database connection. The database connection home page appears.
     In the Data Administration section, click Load table contents (.d file).

     The Load Table Contents page for the selected database connection appears.

2. In the Database connection field, enter a database connection name that contains the database into which you want to load the table contents.

   By default, the last used database connection name appears in the Database connection field.
   
   You can select another database connection by entering a database name in the Database connection field.

   **Note:** If you type the name of the database connection, follow the format used by OpenEdge Management/OpenEdge Explorer to define a connection: AdminServer-name.database-name. A database server must be running for you to connect to the database.

   You can also click the Search icon to choose a database for which you are creating the tenant from the Connection Selection dialog.

   The Connection Selection dialog displays the connections details in a grid. You can perform the following:

   - Filter the connections in the grid by Connection name, AdminServer, and/or Category.
   - Select the column heading and click the drop-down to choose the order (ascending or descending alphabetically) for the connections to appear in the grid.

   **Note:** When you select a database connection name, the Database connection field displays the selected database connection name. Most of the other fields get auto-populated with the default values, based on the selected database connection name.

3. In the Load root directory field, specify a file path of the contents (.d) file. By default, this field displays the work directory C:\OpenEdge\WRK.

4. Select Include LOB to enable importing of large database objects, such as images. By default, this check box is selected.

5. In the LOB sub-directory field, specify a sub-directory name that contains the large database objects that you want to load. By default, this field displays lobs and this sub-directory is contained in the default work directory C:\OpenEdge\WRK.

6. In the Acceptable error percentage field, specify an acceptable error percentage. The default value is 0.
7. In the **Group sub-directory** field, specify a sub-directory name which contains group contents in .d files. By default, this field displays groups and this sub-directory is contained in the default work directory C:\OpenEdge\WRK.

8. Select the **Skip secured tables** check box, if you do not want to load secured tables.

9. Select the **Do not load group tables** check box, if you do not want to load the group tables.

10. Select the **Skip missing directories** check box, to skip validating the missing sub-directories mentioned under the root directory when loading table contents.

11. Select one of the following options for **Tables**:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All $^1$</td>
<td>Load contents to all shared and multi-tenant tables. By default, this option is selected.</td>
</tr>
<tr>
<td>All shared tables</td>
<td>Load contents to all shared tables only.</td>
</tr>
<tr>
<td>All multi-tenant tables</td>
<td>Load contents to all multi-tenant tables only.</td>
</tr>
<tr>
<td>Selected</td>
<td>Load content either to one or many, shared and/or multi-tenant tables. This option appears both for multi-tenant and non-multi-tenant database connections. Selecting this option displays the <strong>Selected Tables</strong> section.</td>
</tr>
</tbody>
</table>

If you choose the **Selected** option for **Tables**, the **Selected Tables** section appears.

In the **Selected Tables** section, do the following:

a) In the **Table name** field, enter a table name. You can specify a keyword, use the wildcard operator *, or a combination of both.

b) In the **Database area** field, specify a database area name which contains the tables you want to view. When you type a keyword in this field, the console lists database areas matching your keyword. You can select a database area name. For example, if you type Cu, the console lists the database areas Cust_Data and Cust_Index.

c) Select one of the following options (available only for multi-tenant databases):

- **Show shared and multi-tenant** — to view tables that are both shared and multi-tenant. By default, this option is selected.
- **Show shared** — to view only shared tables.
- **Show multi-tenant** — to view only multi-tenant tables.

d) Select the **Show hidden** check box to view any hidden tables from the database.

e) Click **Apply Filter**. Based on your search criteria, the **Selected Tables** section lists the table names and displays the following columns:

---

$^1$ Databases that are not enabled for multi-tenancy do not have shared or multi-tenant tables.
12. Select **Tenants** based on whether you access the database as a regular or a super user.

**Note:** In the case of multi-tenant database connections, you must provide either regular or super user credentials to dump or load tenant data. Refer to Managing users in a multi-tenant database on page 79. If you do not provide any credentials for database authentication, you can dump or load only default database tables.

- For regular tenant user credentials, **Tenants** displays a preselected radio button for the regular tenant and you can only load contents to the tables within that specific regular tenant.
- For super-tenant user credentials, **Tenants** displays two options for you to select and load contents to the tables included within these tenants.

You can choose **All** to select all the regular tenants or **Selected** to filter one or more tenants. Upon choosing **Selected**, the console displays the **Selected Tenants** section.

You can enter either a keyword, the wildcard operator *, or a combination of the two in the **Tenant name** field. Click **Apply filter** to view the **Tenant name** and the **Description** in the respective columns. Use the check boxes to select or clear any of the tenant entries.

Optionally, you can click the columns drop-down to select options such as **Type**, **Id**, **External Id**, and **Data Enabled** to display the respective tenant properties. Similarly, you can clear the check box to remove any of the columns from the **Selected Tenants** view.

**Note:** The option for displaying tenants is not available for non-multi-tenant databases.

13. Click **Load**.

A confirmation dialog appears for table data load displaying the number of shared and multi-tenant tables that will be loaded.

14. Do one of the following:
• Click **Commit** to load the contents of the selected tables. You can view status of such a task in the **Database Administration Tasks** page by selecting **Database Administration > View > Database Tasks**.

• Click **Commit & Monitor** to load the contents of the selected tables, and view the task page. This page lists the details of the load activity performed.

• Click **Cancel** to exit the dumping process.

When this operation is successful, the contents from the `.d` file in the load directory that you specify (in this case, the work directory `C:\OpenEdge\WRK`) are imported into the database tables.

### Loading group contents to a database

The Database Administration console uses the `.d` files to load group contents from the sub-directory for groups you specify.

To load group contents:

1. In the management console menu, do one of the following:
   - Select **Database Administration > Load > Group Contents (.d files)**.
   - Select **Database Administration > Go to Database Administration**. The **Database Administration** page appears.
     - Filter or search for, and select the required database connection. The database connection home page appears.
     - In the **Data Administration** section, click **Load group contents (.d file)**.

   The **Load Group Contents** page for the selected database connection appears.

2. In the **Database connection** field, enter a database connection name that contains the database into which you want to load the table contents. By default, the last used database connection name appears in the **Database connection** field.

   You can select another database connection by entering a database name in the **Database connection** field.

   **Note**: If you type the name of the database connection, follow the format used by OpenEdge Management/OpenEdge Explorer to define a connection: `AdminServer-name.database-name`. A database server must be running for you to connect to the database.

   You can also click the **Search** icon to choose a database for which you are creating the tenant from the **Connection Selection** dialog.

   The **Connection Selection** dialog displays the connections details in a grid. You can perform the following:
   - Filter the connections in the grid by **Connection name**, **AdminServer**, and/or **Category**.
   - Select the column heading and click the drop-down to choose the order (ascending or descending alphabetically) for the connections to appear in the grid.

   **Note**: When you select a database connection name, the **Database connection** field displays the selected database connection name. Most of the other fields get auto-populated with the default values, based on the selected database connection name.
3. In the **Load root directory** field, specify a file path of the groups sub-directory which contains the contents (.d) file. By default, this field displays the work directory `C:\OpenEdge\WRK`.

4. Select **Include LOB** to enable importing of large database objects, such as images. By default, this check box is selected.

5. In the **LOB sub-directory** field, specify a sub-directory name that contains the large database objects that you want to load. By default, this field displays `lobs` and this sub-directory is contained in the default work directory `C:\OpenEdge\WRK`.

6. In the **Acceptable error percentage** field, specify an acceptable error percentage. The default value is 0.

7. In the **Group sub-directory** field, specify a sub-directory name which contains group contents in .d files. By default, this field displays `groups` and this sub-directory is contained in the default work directory `C:\OpenEdge\WRK`.

8. Select the **Skip secured tables** check box, if you do not want to load secured tables.

9. Select the **Skip missing directories** check box, to skip validating the missing sub-directories mentioned under the root directory when loading table contents.

10. Select one of the following options for **Groups**:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All ²</td>
<td>Load contents to all groups. By default, this option is selected.</td>
</tr>
<tr>
<td>Selected</td>
<td>Load content either to one or many groups. Selecting this option displays the <strong>Selected Groups</strong> section.</td>
</tr>
</tbody>
</table>

In the **Selected Groups** section, do the following:

a) In the **Group name** field, enter a group name. You can specify a keyword, use the wildcard operator *, or a combination of both.

b) Click **Apply Filter**. Based on your search criteria, the **Selected Groups** section lists the group names and displays the following columns:

<table>
<thead>
<tr>
<th>Column name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group name</td>
<td>Displays the name of groups in an ascending alphabetical order.</td>
</tr>
<tr>
<td>Schema</td>
<td>Displays whether the schema associated with the database table is public or user-defined. The default value is PUB which indicates that the default public schema is assigned to the OpenEdge database.</td>
</tr>
<tr>
<td>Table</td>
<td>Displays the table in the database with which the group is associated.</td>
</tr>
<tr>
<td>Is allocated</td>
<td>Displays true if space is allocated for objects in the group.</td>
</tr>
<tr>
<td>Description</td>
<td>Displays details associated with the group name. This column is optional. To view this column, click any of the column's drop-down and select <strong>Columns &gt; Description</strong> check box.</td>
</tr>
</tbody>
</table>

² Databases that are not enabled for multi-tenancy do not have groups.
11. Click *Load*. A confirmation dialog appears for table data load displaying the number of groups that will be loaded.

12. Do one of the following:
   - Click *Commit* to load contents of the selected groups. You can view status of such a task in the Database Administration Tasks page by selecting Database Administration > View > Database Tasks.
   - Click *Commit & Monitor* to load contents of the selected groups, and view the task page. This page lists the details of the load activity performed.
   - Click *Cancel* to exit the dumping process.

When this operation is successful, the contents from the .d file in the groups sub-directory of the load directory you specify, (in this case, the work directory C:\OpenEdge\WRK) are imported into the database groups.

### Dumping database contents

The Database Administration console of OpenEdge Management or OpenEdge Explorer allows you to dump table or group data in a text format. The console creates a text file that contains the dump data of each table or group you specify. This file has a .d extension and is stored in the work directory you specify. The default work directory is C:\OpenEdge\WRK. You can dump data either from a shared table, a multi-tenant table, or both. You can also dump data from a group of tenants sharing a table. You can use the .d files to load data into a database. The console creates a separate contents file for each table or group you dump.

**Note:** You must have administrator privileges to dump table and group contents.

### Dumping table contents from a database

The Database Administration console allows you to dump table contents in a text format. To dump table contents:

1. In the management console menu, do one of the following:
   - Select Database Administration > Dump > Table Contents (.d files).
   - Select Database Administration > Go to Database Administration. The Database Administration page appears.
     Filter or search for, and select the required database connection. The database connection home page appears.
     In the Data Administration section, click Dump table contents (.d file).

   The Dump Table Contents page for the selected database connection appears.

2. In the Database connection field, enter a database connection name that contains the database into which you want to load the table contents. By default, the last used database connection name appears in the Database connection field.

   You can select another database connection by entering a database name in the Database connection field.
Chapter 3: Managing multi-tenant databases

Note: If you type the name of the database connection, follow the format used by OpenEdge Management/OpenEdge Explorer to define a connection:
AdminServer-name.database-name. A database server must be running for you to connect to the database.

You can also click the Search icon to choose a database for which you are creating the tenant from the Connection Selection dialog.

The Connection Selection dialog displays the connections details in a grid. You can perform the following:

• Filter the connections in the grid by Connection name, AdminServer, and/or Category.
• Select the column heading and click the drop-down to choose the order (ascending or descending alphabetically) for the connections to appear in the grid.

Note: When you select a database connection name, the Database connection field displays the selected database connection name. Most of the other fields get auto-populated with the default values, based on the selected database connection name.

3. In the Dump root directory field, specify a file path for the directory in which you want to store the contents (.d) file. By default, this field displays the work directory C:\OpenEdge\WRK.
4. Select Include LOB to enable exporting of large database objects, such as images. By default, this check box is selected.
5. In the LOB sub-directory field, specify a sub-directory name in which you want to store the large database objects. By default, this field displays lob and this sub-directory is contained in the default work directory C:\OpenEdge\WRK.
6. In the Code page field, specify a value for code page. By default, this field displays ISO8859-1. For more information on code pages, see OpenEdge Development: Internationalizing Applications.
7. In the Group sub-directory field, specify a sub-directory name in which you want to store group contents. By default, this field displays groups and this sub-directory is contained in the default work directory C:\OpenEdge\WRK.
8. In the Character mapping field, specify MAP or NO-MAP for character mapping. For more information about character mapping, PROTERMCAP, and national language support, see OpenEdge Development: Internationalizing Applications.
9. Select the Overwrite existing .d files check box, to overwrite the existing .d file.
10. Select the Do not dump secured tables check box, if you do not want to dump secured tables.
11. Select the Do not dump group tables check box, if you do no want to dump group tables.
12. Select the Do not validate code page check box, to skip validating the value entered in the Code page field.
13. Select one of the following options for Tables:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All 3</td>
<td>Dump contents from all shared and multi-tenant tables. By default, this option is selected.</td>
</tr>
</tbody>
</table>

* Databases that are not enabled for multi-tenancy do not have shared or multi-tenant tables.
Managing a multi-tenant database

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All shared tables</td>
<td>Dump contents from all shared tables only.</td>
</tr>
<tr>
<td>Note:</td>
<td>This option is available only for multi-tenant database connections.</td>
</tr>
<tr>
<td>All multi-tenant tables</td>
<td>Dump contents from all multi-tenant tables only.</td>
</tr>
<tr>
<td>Note:</td>
<td>This option is available only for multi-tenant database connections.</td>
</tr>
<tr>
<td>Selected</td>
<td>Dump content either from one or many, shared and/or multi-tenant tables. This option appears both for multi-tenant and non-multi-tenant database connections. Selecting this option displays the Selected Tables section.</td>
</tr>
</tbody>
</table>

In the Selected Tables section, do the following:

a) In the Table name field, enter a table name. You can specify a keyword, use the wildcard operator *, or a combination of both.
b) In the Database area field, specify a database area name which contains the tables you want to view. When you type a keyword in this field, the console lists database areas matching your keyword. You can select a database area name. For example, if you type Cu, the console lists the database areas Cust_Data and Cust_Index.
c) Select one of the following options:
   - Show shared and multi-tenant — to view tables that are both shared and multi-tenant. By default, this option is selected.
   - Show shared — to view only shared tables.
   - Show multi-tenant — to view only multi-tenant tables.
d) Select the Show hidden check box to view any hidden tables from the database.
e) Click Apply Filter. Based on your search criteria, the Selected Tables section lists the table names and displays the following columns:

<table>
<thead>
<tr>
<th>Column name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Schema</td>
<td>Displays whether the schema associated with the database table is public or user-defined. The default value is PUB which indicates that the default public schema is assigned to the OpenEdge database.</td>
</tr>
<tr>
<td>Table name</td>
<td>Displays the name of tables in an ascending alphabetical order.</td>
</tr>
<tr>
<td>Area</td>
<td>Displays the area in the database in which the table resides.</td>
</tr>
<tr>
<td>Column name</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Multi-Tenant</td>
<td>Displays true for multi-tenant tables and false for shared tables.</td>
</tr>
<tr>
<td>Description</td>
<td>Displays details associated with the table name. This column is optional. To view this column, click any of the column's drop-down and select <strong>Columns &gt; Description</strong> check box.</td>
</tr>
</tbody>
</table>

14. Select **Tenants** based on whether you access the database as a regular or a super user.

**Note:** In the case of multi-tenant database connections, you must provide either regular or super user credentials to dump or load tenant data. Refer to **Managing users in a multi-tenant database** on page 79. If you do not provide any credentials for database authentication, you can only dump or load default database tables.

- For regular tenant user credentials, **Tenants** displays a preselected radio button for the regular tenant and you can only dump contents from the table within that specific regular tenant.
- For super-tenant user credentials, **Tenants** displays two options for you to select and dump contents from the tables included within these tenants.
  - Choose **All** to select all regular tenants.
  - Choose **Selected** to filter one or more tenants. Upon choosing Selected, the console displays the Selected Tenants section. You can enter either a keyword, the wildcard operator *, or a combination of the two in the **Tenant name** field. Click **Apply filter** to view the **Tenant name** and the **Description** in the respective columns. Use the check boxes to select or clear any of the tenant entries.

  Optionally, you can click the columns drop-down to select options such **Type**, **Id**, **External Id**, and **Data Enabled** to display the respective tenant properties. Similarly, you can clear the check box to remove any of the columns from the **Selected Tenants** view.

**Note:** The option for displaying tenants is not available for non-multi-tenant databases.

15. Click **Dump**. A confirmation dialog appears for table data dump displaying the number of shared and multi-tenant tables that will be dumped.

16. Do one of the following:
   - Click **Commit** to dump contents of the selected tables. You can view status of such a task in the **Database Administration Tasks** page by selecting **Database Administration > View > Database Tasks**.
   - Click **Commit & Monitor** to dump contents of the selected tables, and view the task page. This page lists the details of the dump activity performed.
   - Click **Cancel** to exit the dumping process.

When this operation is successful, a contents (.d) file is created for each table in the dump directory you specify (in this case, the work directory C:\OpenEdge\WRK).
Dumping group contents from a database

When you dump group contents using the Database Administration console, the .d file is created in a sub-directory of the work directory you specify. The default work directory is C:\OpenEdge\WRK.

To dump group contents:

1. In the management console menu, do one of the following:
   - Select Database Administration > Dump > Group Contents (.d files).
   - Select Database Administration > Go to Database Administration. The Database Administration page appears.
     Filter or search for, and select the required database connection. The database connection home page appears.
     In the Data Administration section, click Dump group contents (.d file).

   The Dump Group Contents page for the selected database connection appears.

2. In the Database connection field, enter a database connection name that contains the database into which you want to load the table contents. By default, the last used database connection name appears in the Database connection field.
   You can select another database connection by entering a database name in the Database connection field.

   Note: If you type the name of the database connection, follow the format used by OpenEdge Management/OpenEdge Explorer to define a connection: AdminServer-name.database-name. A database server must be running for you to connect to the database.

   You can also click the Search icon to choose a database for which you are creating the tenant from the Connection Selection dialog.

   The Connection Selection dialog displays the connections details in a grid. You can perform the following:
   - Filter the connections in the grid by Connection name, AdminServer, and/or Category.
   - Select the column heading and click the drop-down to choose the order (ascending or descending alphabetically) for the connections to appear in the grid.

   Note: When you select a database connection name, the Database connection field displays the selected database connection name. Most of the other fields get auto-populated with the default values, based on the selected database connection name.

3. In the Dump root directory field, specify a file path of the directory in which you want to store the contents (.d) file. By default, this field displays the work directory C:\OpenEdge\WRK.

4. Select Include LOB to enable exporting of large database objects, such as images. By default, this check box is selected.

5. In the LOB sub-directory field, specify a sub-directory name in which you want to store the large database objects. By default, this field displays lobs and this sub-directory is contained in the default work directory C:\OpenEdge\WRK.
6. In the **Code page** field, specify a value for code page. By default, this field displays **ISO8859-1**. For more information on code pages, see *OpenEdge Development: Internationalizing Applications*.

7. In the **Group sub-directory** field, specify a sub-directory name in which you want to store group contents. By default, this field displays **groups** and this sub-directory is contained in the default work directory **C:\OpenEdge\WRK**.

8. In the **Character mapping** field, specify MAP or NO-MAP for character mapping. For more information about character mapping, PROTERMCAP, and national language support, see *OpenEdge Development: Internationalizing Applications*.

9. Select the **Overwrite existing .d files** check box, to overwrite the existing dump (.d) file.

10. Select the **Do not dump secured tables** check box, if you do not want to dump secured tables.

11. Select the **Do not dump group tables** check box, if you do not want to dump group tables.

12. Select the **Do not validate code page** check box, to skip validating the value entered in the **Code page** field.

13. Select one of the following options for **Groups**:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All ⁴</td>
<td>Dump contents from all groups. By default, this option is selected.</td>
</tr>
<tr>
<td>Selected</td>
<td>Dump content either from one or many groups. Selecting this option displays the <strong>Selected Groups</strong> section.</td>
</tr>
</tbody>
</table>

In the **Selected Groups** section, do the following:

a) In the **Group name** field, enter a group name. You can specify a keyword, use the wildcard operator `*`, or a combination of both.

b) Click **Apply Filter**. Based on your search criteria, the **Selected Groups** section lists the group names and displays the following columns:

<table>
<thead>
<tr>
<th>Column name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group name</td>
<td>Displays the name of groups in an ascending alphabetical order.</td>
</tr>
<tr>
<td>Schema</td>
<td>Displays whether the schema associated with the database group is public or user-defined. The default value is <strong>PUB</strong> which indicates that the default public schema is assigned to the OpenEdge database.</td>
</tr>
<tr>
<td>Table</td>
<td>Displays the table in the database with which the group is associated.</td>
</tr>
<tr>
<td>Is allocated</td>
<td>Displays true if space is allocated for objects in the group.</td>
</tr>
<tr>
<td>Description</td>
<td>Displays details associated with the group name. This column is optional. To view this column, click any of the column's drop-down and select <strong>Columns &gt; Description</strong> check box.</td>
</tr>
</tbody>
</table>

---

⁴ Databases that are not enabled for multi-tenancy do not have groups.
14. Click Dump. A confirmation dialog appears for group data dump displaying the number of groups that will be dumped.

15. Do one of the following:

- Click Commit to dump contents of the selected groups. You can view the status of such a task in the Database Administration Tasks page by selecting Database Administration > View > Database Tasks.
- Click Commit & Monitor to dump contents of the selected groups, and view the task page. This page lists the details of the dump activity performed.
- Click Cancel to exit the dumping process.

When this operation is successful, a contents (.d) file is created for each group in the groups sub-directory of the dump directory you specify (in this case, the work directory C:\OpenEdge\WRK).

Tuning multi-tenant database performance

There are two multi-tenant governors which you can use to improve the performance of multi-tenant databases. These governors limit each tenant's access to the shared database resources. These multi-tenant governors are:

- Login Governor
- Lock Governor

**Note:** These governors are applicable to only the default tenant and regular tenant; these governors do not apply to a super-tenant. Also, these governors do not apply to non multi-tenant databases.

The Login Governor (Tenant Max User Governor) specifies the maximum number of users that may login for each tenant. The Lock Governor (Tenant Lock Table Governor(%) ) specifies the percentage of the lock table that any tenant can occupy. The database startup parameter for Tenant Max User Governor Login Governor is -nGovernor and for Tenant Lock Table Governor(%) is -LGovernor.

When a tenant attempts to acquire more locks than the governor allows, an error message is displayed as: Attempt to exceed tenant lock governor for tenant <tenantID>. Increase -L or -LGovernor.

When a user attempts to login to a database and the available maximum number of logins for that tenant has been exceeded, an error message is displayed as: Attempt to exceed tenant login governor limit for tenant <tenant ID>. Increase -n or -nGovernor.

The Database Administration console and the PROMON utility help you to monitor and change the governor values for these parameters.

To monitor and change the values of these multi-tenant governors using the Database Configuration page, see *OpenEdge Management and OpenEdge Explorer: Configuration*.

To monitor and change the values of these multi-tenant governors using the PROMON utility, see *OpenEdge Data Management: Database Administration*.
Viewing multi-tenant database areas, domains, schemas, tenants, and groups

Once you successfully set up a connection to a multi-tenant database, you can view its contents, specifically its areas, domains, schemas, tenants, and groups.

To view the multi-tenant database contents:

1. Ensure that the database server is running and that you have set up the database connection. (For more information, see Setting up the connection on page 27.)
2. On the management console menu, select Database Administration > Go to Database Administration.
   The Database Administration page appears.
3. Filter or search for, and select the required database connection. The database connection home page appears.
   The database connection home page appears.

You can view domains, tenants, groups, areas, and schemas in the Storage Management section.

You can now click any of the selections to choose the details you want to view, as described in the following sections.

Viewing areas

Select View areas to view all the areas configured for the database. The Database Areas page appears.

To see details about an area and its extents, select the area in the list. The Database Area Extents page appears.

The upper part of the pane provides information about the area. The lower part provides information about extents in a grid. The grid displays the extent number, the file name, the size, and used size of the extent, and whether the extent is fixed (true) or variable (false). You can sort each column to view the information in ascending or descending order. Click the column name and then on the drop-down arrow.

Viewing domains

In the Security Summary section, select Edit domains to view the domains available for the database. The Edit Database Domains page appears.

To see a domain’s details, select the domain in the list.

Viewing schema

Select View schemas to view the schema for the database. The Database Schema page appears.
Viewing tenants

Select View tenants to view the Tenant List page.

From the Tenants list, you can select a particular tenant and view its details.

To see tenant details, find a tenant, or filter tenants in the view from the Tenant name list, do one of the following:

• To see details about a tenant, select the tenant. The tenant home page appears.

• (For a super-tenant, no Tenant data access link is shown.)

• Click Edit tenant in the Manage Tenant section. The tenant's General details appears in the Edit Tenant page.

From this page, you can view the tenant's users, domains, and partitions, as described in Viewing a tenant's users on page 51, Viewing a tenant's domains on page 51, and Viewing and filtering tenant partitions on page 52.

You can also view a tenant's groups; for more information, see Using tenant groups on page 107.

Viewing a tenant's users

You can view a list of a tenant's users; you can also add a user to the tenant.

To see a list of users in the user table for a tenant, select Users in the Edit Tenant page. To sort the information in the grid, click a column name and then click the drop-down arrow.

You can filter the list of users by entering a user name in the User name field, and then clicking the Search icon. You can expand the filter option to search for users using a User ID and/or Domain name.

You can also move forward or backward a page, or specify a particular page, in the list of users by using the Page feature at the bottom of the list.

For information about adding a user to a tenant, see Adding a user to a tenant on page 62.

For information about setting up multi-tenant table security for users, see Managing multi-tenant database table security for users on page 85.

Viewing a tenant's domains

You can view a list of a tenant's domains; you can also add a domain and establish domain security.

To see a list of domains that exist for a selected tenant, select Domains in the Edit Tenant page. From the list, select a particular domain. To sort the information in the grid, click a column name and then click the drop-down arrow.

You can filter the list of domains by entering the domain name in the Domain name field.

You can also move forward or backward a page, or specify a particular page, in the list of domains by using the Page feature at the bottom of the list.

For information about adding a domain for a tenant, see Adding a tenant domain on page 61. For details about adding a domain to the database, see Managing domains in a multi-tenant database on page 82.
Viewing and filtering tenant partitions

From the tenant's general details, you can view more specific information about the tenant. You can also filter the details you see and use the predefined color-coding to provide a quick view of how partitions are allocated.

Viewing partitions

To view details about a tenant's partitions, choose a tenant from the **Tenant name** list, and click **Edit tenant** in the **Manage Tenant** section of the Tenant home page. From the tenant details, click **Partitions**; the partition details appear by default in one or more area panels. The predefined pink color coding indicates that the allocation state for the partitions is **Not allocated**.

(For details about what different predefined colors represent, see **Interpreting the color legend** on page 53.)

To switch from the area panels layout to a grid view, click the view grid icon on the top right corner. The partitions details appear.

From the grid view, you can sort by ascending or descending alphabetical order in each of the following columns: **Partition Name**, **Area**, **Allocation State**, object **Type**, or **Buffer Pool**. You can also choose to hide any of the columns you do not want to view, or move the order of the columns. (If you cannot see the entire grid, adjust the width of the columns in the grid. You can also adjust the width of the other columns in the management console.)

To change the order of items in any column, select the column name and click the drop-down arrow that appears. From the menu, select the sort order as well as which columns to include in the grid, as shown in the following figure.

To see details (in either layout) about the database schema from the **Partitions** view, expand the schema items as necessary; or select one of the partitions in the grid. The properties for the database object appear in the **Properties** pane.

The **Properties** pane allows you to focus on details for one particular object by identifying the object's name, type, the area where the object resides, buffer pool (primary or alternate), and the allocation state. (For more information about allocation state, see Allocating tenant partitions on page 56.)

Filtering partitions for a tenant

You can filter the view of partitions by allocation state from a tenant.

You can also filter the view of partitions by allocation state from a tenant template. For more information, see Filtering partitions from a tenant template on page 96.

To filter partitions by allocation state from a tenant:

1. From the tenant menu bar, click **Filter Partitions**. The filtering options appear.
   All filtering options are selected by default. Click any option to toggle between selected and cleared.
2. Click **Apply filter** to implement the filtering.
Interpreting the color legend

So that you can quickly identify partitions by allocation state, each state corresponds to a particular color.

To access the legend in the management console:

1. From the tenants list, select a tenant.
2. Click Edit tenant in the Manage Tenant section of the Tenant home page.
3. Choose Partitions.
4. From the tenant menu bar, choose Tools > Legends.
Using OpenEdge Management/OpenEdge Explorer, you can create a new tenant for a database enabled for multi-tenancy. You can also manage the tenant’s users and domains and delete a tenant.

For details, see the following topics:

- Creating a new tenant for a multi-tenant database
- Editing a tenant
- Adding a tenant domain
- Adding a user to a tenant
- Generating a tenant program from an existing tenant
- Deleting a tenant
- Deleting a tenant domain
- Deleting a tenant user
- Enabling a table for multi-tenancy
- Enabling or disabling access to tenant data
- Deallocating tenant tables
Creating a new tenant for a multi-tenant database

Using the multi-tenancy configuration tool, you can create a new tenant for a database enabled for multi-tenancy. As you are creating the tenant, you can specify a schema storage area location for each type of multi-tenant database object (table, index, or LOB field). You can also determine if access to the tenant's data should be enabled or disabled.

Once you finish specifying all the tenant's settings, you can either:

- Create the tenant immediately.
- Generate a tenant configuration ABL program that you can use to create a tenant.

You can also create a new tenant from an existing tenant or from a tenant template. A tenant template defines common general and partition settings, making it easier for you to create the new tenant. For more information about working with tenant templates, see Using tenant templates on page 93.

Details related to creating the tenant and generating a tenant program are provided in the following sections.

Allocating tenant partitions

Creating a new tenant in an existing multi-tenant database results in the establishment of a new tenant partition for each existing multi-tenant object defined in the database. You can assign a specific storage area for each table, index, or LOB field, or you can use the previously defined default locations.

You can also specify if or when partitions should be allocated, as long as the following criteria exist:

- The tenant is a regular tenant. You cannot specify the area assignment or allocation setting for partitions for a default tenant or a super-tenant.
- The allocation rule for the tenant is either Set new objects not to allocate space or Set new objects to delay space allocation. If the rule is set to Set new objects to allocate space on tenant creation, partitions are created and allocated at the same time as the tenant is created. You will be unable to change the area assignment for a specific partition when you add a new database object.

You might choose not to allocate space at all when creating a tenant. This can save space if the tenant is not going to be using all of the multi-tenant tables. For example, when a tenant will be using only a subset of the multi-tenant tables, you can delay space allocation for the unused tables. Similarly, you might not be finished making modifications to an object when you create a tenant and prefer not to allocate space now.

For a shared object, you cannot choose not to allocate the object, so its allocation state is immediate. If default allocation is set to immediate, that setting is always applied on new tables (along with the table's indexes and the LOB fields). If the tenant's default allocation is set to delayed or none, then the table's allocation setting applies.

When you set the allocation state for a table, the same state applies to its indexes and LOB fields.
Specifying an alternate buffer pool

As you create a tenant, you can choose between using the primary buffer pool or the alternate buffer pool.

**Note:** Access to the alternate buffer pool feature requires an Enterprise database license. The feature is unavailable with a Workgroup or Personal database license.

The alternate buffer pool is a set of buffers in shared memory that are logically separate from the primary buffer pool. The alternate buffer pool gives the database administrator the ability to modify buffer pool behavior by designating objects or areas to consume buffers from the alternate buffer pool, rather than from the primary buffer pool.

Management of the buffers in the alternate buffer pool is independent of the primary buffer pool. Assigning specific database areas or objects to occupy buffers from the alternate buffer pool might improve your buffer hit rate, thereby reducing the need to read and write buffers to and from disk and possibly improving performance.

For each table, index, and LOB field, you can specify whether to use the primary or the alternate buffer pool.

Using a tenant configuration program

Using OpenEdge Management/OpenEdge Explorer, you can create a tenant for a multi-tenant database. If you prefer, you can, as an alternative, set up the tenant's properties, generate a tenant creation ABL program based on those properties, and save the program so you can run it when you want. Generating the program alone does not create the tenant; you create the tenant when you run the generated program.

Similarly, if you have an existing tenant whose configuration you want to reuse, you can generate a tenant creation program from that tenant. You might also want to use the generated code as a template for writing your own tenant creation program within your own application.

Generating the program for a new or an existing tenant creates a .p file (procedure file) that you then use to create the tenant and all its settings, including partition assignments. If you are generating a program for an existing tenant, you can include domain and user information associated with the tenant. For a new tenant, domain and user details are not yet available in the database; therefore, no user or domain information is included in the program.

When you create and save a tenant program, you can then use that program to create a tenant with the settings you have defined. You can also modify a generated program before you run it.

Creating a new tenant or tenant program

You can create a new tenant or create a tenant based on an existing tenant. You can also generate a reusable tenant ABL program for an online multi-tenant database. Before you begin, you must select a database connection, and the database server must be running, as described in Setting up the connection on page 27.

You can also create a tenant from a tenant template. For more information, see Using tenant templates on page 93.

To create a new tenant or tenant program:

1. In the management console menu, choose one of the following:
• Select **Database Administration > New > Tenant.**

• On the management console menu, select **Database Administration > Go to Database Administration.** The **Database Administration** page appears.

  Filter or search for, and select the required database connection. The database connection home page appears.

  In the **Security Summary** section, click **Create tenant.**

The **New Tenant** page appears.

2. Provide the following information:

• **Tenant name** — The name of the new tenant, which must be unique within the database.
  Do not use spaces or special characters such as an asterisk (*), ampersand (&), or period (.) in this field. You can include the underscore (_).

• **Description** — An optional description of the tenant.

• **External ID** — An optional ID. If you provide an external ID, you can later refer to the ID when you view the progress of transactions being committed.

3. Select the tenant type: **Regular** or **Super**. For more information about each tenant type, see **Common terminology** on page 22.

4. To enable access to the tenant's data, select the **Enable data access** option. If you do not select the option, data access is disabled for any user other than the super-tenant. For more information, see **Enabling or disabling access to tenant data** on page 67.

5. In the **Database connection** name, enter a database connection name to which you want to add the new tenant. By default, the last used database connection name appears in the **Database connection** field.

   **Note:** If you type the name of the database connection, follow the format used by OpenEdge Management/OpenEdge Explorer to define a connection: `AdminServer-name.database-name`. A database server must be running for you to connect to the database.

   You can also click the **Search** icon to choose a database for which you are creating the tenant from the **Connection Selection** dialog.

   The **Connection Selection** dialog displays the connections details in a grid. You can perform the following:

   • Filter the connections in the grid by a **Connection name**, **AdminServer**, and/or **Category**.

   • Select the column heading and click the drop-down to choose the order (ascending or descending alphabetically) for the connections to appear in the grid.

6. If you are creating a super-tenant, go to Step Step 9 on page 59.

   If you are creating a regular tenant, type the name of each of the following areas, and then continue with Step Step 7 on page 59:

   • **Default data area** — The default storage location for the tenant's tables
   • **Default index area** — The default storage location for the tenant's indexes
   • **Default LOB area** — The default storage area for the tenant's LOB fields

   For each of the areas, you can either enter the storage area name in the default area field or click the **Search** icon to choose the storage area name from the **Area Selection** dialog.
The **Area Selection** dialog displays the storage area names in a grid. You can perform the following:

- Filter the storage area name in the grid by **Area name**, **Records per block**, and/or **Cluster size**.
- Move forward or backward a page, or specify a particular page, in the list of domains by using the **Page** feature at the bottom of the list.
- Select the column heading and click the drop-down to choose the order (ascending or descending alphabetically) for the area names to appear in the grid.

7. Choose one of the following object allocation rules for the regular tenant:

- **Set new objects not to allocate space** — Allocate no space for the tenant's objects.
- **Set new objects to allocate space on tenant creation** — Allocate storage space immediately.
- **Set new objects to delay space allocation** — Do not yet allocate storage space. (You can allocate space later when you are ready to do so.)

8. If you selected either **Set new objects not to allocate space** or **Set new objects to delay space allocation** in Step 7 on page 59, select one of these options:

- **Do not use template** — Select this option if you are creating a new tenant without using a template.
- **Tenant** — Select this option if you are creating a tenant by using an existing tenant. You can type the tenant name in the field, or you can click the **Search** icon to open the **Tenant Selection** dialog.

The **Tenant Selection** dialog displays the tenant details in a grid. You can filter the tenants in the grid by **Tenant name** and/or **External ID**.

You can also move forward or backward the page, or specify a particular page, in the list of tenants by using the **Page** feature at the bottom of the grid.

**Note:** You can select the column heading and click the drop-down to choose the order (ascending or descending alphabetically) for the tenants to appear in the grid.

- **Template** — Select this option if you are creating a tenant by using an existing template. You can enter a template name in the field, or you can click the **Search** icon to open the Template Selection dialog. For more information about working with tenant templates, see **Using tenant templates** on page 93.

9. Choose one:

- To create the tenant immediately, click **Create tenant**.

If you are creating a regular tenant, the tenant home page appears. Click **Edit tenant** in the **Manage Tenant** section to see a set of vertical tabs consisting of the following selections in the left pane: **General**, **Partitions**, **Groups**, **Users**, and **Domains**.

OpenEdge Management console submits an asynchronous task to the OpenEdge servers when you create a tenant in a database. You can view status of such a task in the **Database Administration Tasks** page by selecting **Database Administration > View > Database Tasks**.

If you are creating a super-tenant, the tenant home page appears. Click **Edit Tenant** to see a set of vertical tabs consisting of the following selections in the left pane: **General**, **Users**, and **Domains**.
To create a tenant configuration script, click Generate tenant program. Select a location to save the create_tenant.p file.

Editing a tenant

You can make changes to a tenant from the database administration console. For example, you can add it to or remove it from a group, add users, or domains, and rename a tenant (when tenant is a part of a group).

If space for a tenant partition has not yet been allocated, you can alter the allocation state, change the area assignment, and select the buffer pool assignment. You can also enable or disable access to a tenant's data.

Note that:
• You cannot disable access to the tenant you belong to as a user.
• You cannot disable access for a super-tenant. A super-tenant does not have its own data.
• You can rename a regular or super-tenant.
• You can rename a tenant when it is part of a group.
• You cannot rename the default tenant.
• The allocation state you choose for a table applies also to its indexes and LOB fields.

To edit a tenant:
1. On the management console menu, select Database Administration > Go to Database Administration.
   The Database Administration page appears.
2. Filter or search for, and select the required database connection.
   The database connection home page appears.
3. In the Storage Management section, click View tenants.
4. Select the tenant you want to edit. The tenant details page appears.
5. Under Manage Tenant, click Edit tenant. The Edit tenant page appears.
6. In the Tenant name field, replace the existing tenant name with a new tenant name.
7. Choose the appropriate tab to make the changes you want:
   • General — You can enable or disable tenant data access; change the default data area, index area, and/or LOB area; and modify a table's allocation rule. (Note that the modification to the allocation rule affects only the unallocated partitions.)
   • Partitions — For each table or table object, you can modify the buffer pool assignment, choosing either Primary or Alternate. If the partitions have already been allocated, you cannot change the area or the allocation state.
   • Groups — You can add a group, or generate a tenant creation program. For more information, see Creating a group or group program on page 108.
   • Users — You can add a user. For more information, see Adding a user to a tenant on page 62.
Adding a tenant domain

You can add one or more domains for a tenant by selecting from a list of predefined authentication systems that are configured for the database.

You can also add a domain to the database. For more information, see Managing domains in a multi-tenant database on page 82.

To add a domain:

1. On the management console menu, select Database Administration > Go to Database Administration.

   The Database Administration page appears.

2. Filter or search for, and select the required database connection.

   The database connection home page appears.


4. Select the tenant for which you want to add a domain. The tenant details page appears.

5. Under Manage Tenant, click Edit tenant. The Edit tenant page appears.

6. Click Domains.

7. Click New in the tenant menu bar.

8. Provide the following information:

   • **Domain name** — Type the domain name (required). Do not use spaces or special characters such as an asterisk (*), ampersand (&), or period (.) in this field. You can include the underscore (_).

   • The domain name represents the logical name of a single authentication system (domain) that can be used to validate the authentication of a user account.

   • **Authentication system** — From the drop-down list, specify the type of authentication system. (The available types exist in the database in the _sec-authentication-system table.)

   • **Access code** — Type an access code for the domain.

   • The access code you type is then encrypted and used to validate the identity and integrity of any CLIENT-PRINCIPAL issued by the authentication system represented by this domain.

   • **Confirm access code** — Retype the access code.

   • **Description** — Provide a description (optional).

   • **Comments** — Provide comments (optional).

   • **Enabled** — Select the check box to indicate that the domain is enabled (meaning that a user can log in).
• **Auditing context** — Provide the audit record context value.
• **Runtime options** — Provide a comma-delimited list of runtime options for this domain.
• **System options** — Provide the system option value.

9. Click **Commit**.

For more information about auditing and OpenEdge, see *OpenEdge Getting Started: Core Business Services*.

---

## Adding a user to a tenant

You can add one or more users to a tenant. You can also add one or more users to the database. For more information, see *Managing users in a multi-tenant database* on page 79.

To add a user:

1. Click **Database Administration > Go to Database Administration** in the OpenEdge Management console menu.

   The **Database Administration** page appears.

2. Filter or search for, and select the required database connection.

   The database connection home page appears.

3. Click **View tenants** in the **Storage Management** section.

   The **Tenant List** page appears.

4. Select the tenant for which you want to add a user.

   The tenant details page appears.

5. Click **Edit tenant** in the **Manage Tenant** section.

   The **Edit tenant** page appears.

6. Click **Users**.

7. Click **New** in the tenant menu.

8. Provide the following information for the new user:

   • **User name** — Type the user's name (required). Do not use spaces or special characters such as an asterisk (*), ampersand (&), or a period (.) in this field. You can include the underscore (_).

   • **Domain name** — Enter a domain name or click the **Search** icon to open the **Domain Selection** dialog to select a domain name (required).

      The **Domain Selection** dialog displays the details of the domains in a grid. You can search or filter the domains in the grid by **Domain name** and/or **Tenant name**.

      You can also move forward or backward the page, or specify a particular page, in the list of domains by using the **Page** feature at the bottom of the grid.

      **Note:** You can select the column heading and click the drop-down to choose the order (ascending or descending alphabetically) for the domains to appear in the grid.

   • **Password** — Type the user's password.
• **Confirm password** — Retype the user’s password.

• **SQL Only** — Select the check box to indicate that the _user table record can be used only by a SQL connection to authenticate to the database.

  If the check box is enabled, ABL clients cannot authenticate to the database by using user ID and user name.

  If the check box is disabled, both SQL and ABL users can use the record.

• **User number** — Provide a number to identify the user (optional). The number must be a positive integer.

• **Description** — Provide a description (optional).

• **Given name/Middle initial/Surname** — Provide the user’s given name, middle initial, and surname (optional).

• **Telephone** — Type the user’s telephone number (optional).

• **E-mail** — Type the user’s email address (optional).

9. Click **Commit** in the tenant menu.

---

**Generating a tenant program from an existing tenant**

Generating a tenant program for an existing tenant creates a .p file (procedure file) that you then use to create the tenant and all its settings, including partition assignments. You can optionally include user and domain information associated with the tenant.

To generate a tenant program from an existing tenant:

1. Click **Database Administration** > **Go to Database Administration** in the OpenEdge Management console menu.

   The **Database Administration** page appears.

2. Filter or search for, and select the required database connection.

   The database connection home page appears.

3. Click **View tenants** in the **Storage Management** section.

   The **Tenant List** page appears.

4. Select the tenant for which you want to generate a tenant program.

   The tenant details page appears.

5. In the **Manage Tenant** section, choose one:

   • Click **Generate tenant program**.

   • Click **Edit tenant**.

      From the tenant menu bar, select **Tools** > **Generate tenant program**

   You are prompted to save the create_tenant.p file. If you want to create more than one tenant program, provide a unique file name to prevent the overwriting of an existing create_tenant.p file.

6. Click **Save**.
Deleting a tenant

You can delete a tenant, which also deletes the tenant's domains, users, and data, including partition information. Once you delete a tenant, any space that was used for that tenant's data becomes available.

You can delete a tenant and its users, domains, and data in one transaction, or you can delete each user and domain individually. You cannot delete a tenant if it is in use by the current database connection; in other words, you cannot delete a tenant for which you are a user.

**Note:** The default tenant cannot be deleted.

To delete a tenant:

1. Click **Database Administration** > **Go to Database Administration** in the OpenEdge Management console menu.
   The **Database Administration** page appears.
2. Filter or search for, and select the required database connection.
   The database connection home page appears.
3. Click **View tenants** in the **Storage Management** section.
   The **Tenant List** page appears.
4. Select the tenant for which you want to delete.
   The tenant details page appears.
5. In the **Manage Tenant** section, click **Delete tenant** and then click **Yes** to confirm deletion.

**Caution:** When you delete a tenant from the database, all domains, users, sequence current values, and data for the tenant will also be deleted. Should you want to restore the tenant in the future, you can do so only from a backup. Therefore, it is strongly recommended that you back up a tenant before you delete it.

6. Click **Commit**. You can view status of such a task in the **Database Administration Tasks** page by selecting **Database Administration** > **View** > **Database Tasks**.

Deleting a tenant domain

You can delete a tenant domain from the database using the **Edit Tenant** details page. You can also delete a domain from the **Edit Database Domains** page: see Managing domains in a multi-tenant database on page 82.

To delete a tenant domain
Deleting a tenant user

You can delete a tenant user from the database using the Edit Tenant details page. You can also delete a user from the Edit Database Users page: see Managing users in a multi-tenant database on page 79.

To delete a tenant user

1. Click Database Administration > Go to Database Administration in the OpenEdge Management console menu.
   
   The Database Administration page appears.
2. Filter or search for, and select the required database connection.
   
   The database connection home page appears.
3. Click View tenants in the Storage Management section.
   
   The Tenant List page appears.
4. Select the tenant for which you want to add a user.
   
   The tenant details page appears.
5. Click Edit tenant in the Manage Tenant section.
   
   The Edit tenant page appears.
6. Click Users.
   
   The list of tenant users appear in a grid.
7. From the list of tenant users, select a tenant user that you want to delete from the database.
8. Click Delete and then click Yes to confirm deletion.
Enabling a table for multi-tenancy

From the management console, you can choose one or more tables not enabled for multi-tenancy, and enable them. You can then make decisions about partition allocation for the table or tables that have not yet been allocated. The allocation state you choose for a table applies also to the table’s indexes and LOB fields. When you enable a table for multi-tenancy, you are affecting all tenants for a selected database.

**Note:** A table must be in a Type II area in the database to be enabled for multi-tenancy. If a table, or any of its indexes or LOB fields, is not in a Type II area, you cannot enable the table for multi-tenancy.

In such a situation, the Notes column will identify which table, index, or LOB field is not in a Type II area, so you can correct the issue and then enable the table as multi-tenant.

Selecting one or more tables to enable for multi-tenancy

You can easily identify tables not enabled for multi-tenancy in a database connection. The tables appear in a list, and you can select one or more of the tables that you want to enable.

To select a table for enabling as multi-tenant:

1. Select **Database Administration > Configure > Enable Multi-tenancy for Tables** in the management console menu.
   - The **Enable Multi-tenancy for Tables** page appears
2. In the **Database connection** field, enter a database connection name.
   - By default, the last used database connection name appears in the **Database connection** field.

   **Note:** If you type the name of the database connection, follow the format used by OpenEdge Management/OpenEdge Explorer to define a connection: `AdminServer-name.database-name`. A database server must be running for you to connect to the database.

   You can also click the **Search** icon to choose a database for which you are creating the tenant from the **Connection Selection** dialog.

   The **Connection Selection** dialog displays the connections details in a grid. You can perform the following:
   - Filter the connections in the grid by **Connection name**.
     - You can also select the drop down arrow beside the **Search** icon to filter the connections by **AdminServer**, and/or **Category**.
   - Select the column heading and click the drop-down to choose the order (ascending or descending alphabetically) for the connections to appear in the grid.

3. From the list of tables, select one or more tables, or click the **Select All** check box to select all the tables listed in the page.
4. Click **Preview** to make partition allocation decisions, by tenant, for the tables now enabled for multi-tenancy. The schema selection page appears.
5. Select a tenant in the **Tenants** list. (Note that only regular tenants are listed.)

6. Expand the **PUB** node under **Schema Selections**, and expand the table you have enabled for multi-tenancy to view its schema.

   Note that the schema shown in the area panels includes the full schema for the database, not just the schema for the newly enabled tables.

7. Select a table whose area or allocation state you are able to modify, and make the changes to the tenant partition area or the allocation state in the **Properties** pane. If space for a partition has already been allocated, you cannot make changes.

8. Click **Commit** to save the changes. The **Confirm commit enabling multi-tenancy** dialog appears.

9. Choose from the following options:

   - To commit the changes, click **Commit**.
   - To cancel the changes, click **Cancel**.
   - To force allocation of new partitions that otherwise would not be allocated, select that option. This allows you to force allocation of partitions that otherwise would not be allocated when the changes are saved. This option overrides a tenant's default allocation for new partitions, but any changes applied to individual partitions will also be allocated if you select this option.

   If you select this option, you have an additional choice to make between the following two selections:

     - **Force allocation of all partitions with an allocation state of Delayed** — Forces allocation of partitions whose default allocation setting is to delay.
     - **Force allocation of all partitions with an allocation state of Delayed or None** — Forces allocation of all partitions whose default allocation setting is to either delay or not allocate space at all.

   For example, if a tenant has an object allocation default of no allocation (**None**) and a partition for the tenant is changed to delay allocation (**Delayed**), this partition will be allocated if **Force allocation** is specified. If a tenant has its default allocation set to delay and a partition is changed to no allocation, the partition will be allocated only if **Force allocation** is selected.

   Note that it may take some time to commit the changes to the database. The length of time may vary, depending on the complexity of the changes (the number of tables converted to multi-tenancy, for example) as well as the number of existing tenants in the database.

   The dashboard appears and displays a viewlet that allows you to monitor the status of the task. For more information, see **Monitoring data definition file updates to the database** on page 77.

---

**Enabling or disabling access to tenant data**

You can enable or disable access to a regular tenant. You cannot disable access to a default tenant or a super-tenant; a super-tenant does not have its own data and can access data that other tenant types might not be able to access.

From the tenant home page, you can:

- Determine if a tenant's data is accessible.
- Disable or enable access to the tenant data.
You can also create a tenant whose data access is either enabled for disabled. For more information, see Creating a new tenant for a multi-tenant database on page 56.

You cannot disable access to a tenant for which you are a user.

**Determining if tenant data access is enabled**

From the tenant home page, you can determine at a glance if the tenant's data is accessible.

To determine if a tenant's data access is enabled:

1. Click **Database Administration** > **Go to Database Administration** in the OpenEdge Management console menu.
   
   The **Database Administration** page appears.
2. Filter or search for, and select the required database connection.
   
   The database connection home page appears.
3. Click **View tenants** in the **Storage Management** section.
   
   The **Tenant List** page appears.
4. Select the tenant for which you want to manage tenant data access.
   
   The tenant details page appears.
5. Review the **Tenant data access** status in the **Manage Tenant** section, which is either **enabled** or **disabled**.

For information about changing the data access status from enabled to disabled or vice versa, see Enabling or disabling access on page 68.

**Enabling or disabling access**

From the tenant home page, you can enable or disable access to a tenant's data. You cannot disable a tenant for which you are a user.

To enable or disable access to a tenant's data:

1. On the management console menu, select **Database Administration**. The **Database Administration** page appears.
2. Select the database connection. You can filter or search for the required database connection.
   
   The database connection home page appears.
3. Under **Storage Management**, click **View tenants**.
4. Select a tenant for which you want to manage tenant data access. The tenant details page appears.
5. Under **Manage Tenant**, review the **Tenant data access** status, which is either **enabled** or **disabled**.
6. To change the status, click the **Tenant data access** link. Click **Yes** to confirm the decision.
   
   The **Tenant data access** status is updated to reflect the confirmation.
Deallocating tenant tables

You can deallocate a multi-tenant table from a tenant or a group. Deallocation can be helpful in freeing up storage space so that it is available for reuse.

If you are logged in as a user to a regular tenant, you can deallocate one or more tables from the tenant. If you are logged in as a user to a super-tenant, you can deallocate a table for a group or another tenant in the database.

If you attempt to deallocate a tenant table and the table is in use, deallocation waits for the table to be available.

**Note:** Keep in mind that when you deallocate a multi-tenancy-enabled table's partitions, all data in the table is deleted. For this reason, it is advised that you back up a tenant before you deallocate its contents.

Deallocating a tenant table from the tenant

To deallocate a tenant table from the tenant:

1. Click **Database Administration** > **Go to Database Administration** in the OpenEdge Management console menu.
   
   The **Database Administration** page appears.
2. Filter or search for, and select the required database connection.
   
   The database connection home page appears.
3. Click **View tenants** in the **Storage Management** section.
   
   The **Tenant List** page appears.
4. Select the tenant whose table you want to deallocate.
   
   The tenant details page appears.
5. Under **Data Administration**, click **Deallocate tables**.
   
   The **Deallocate Tenant Tables** page appears and provides the table details: **Table**, **Area**, **Allocation State**, **Status**, and **Comments**. You can filter the tables which appear in the grid by a table name. Enter a table name in the **Table name** field and click on the **Search** icon. The grid displays the tables that match the entered criteria.

   You can also move forward or backward a page, or specify a particular page, in the list of tables by using the **Page** feature at the bottom of the list.

   **Note:** You can select the column heading and click the drop-down to choose the order (ascending or descending alphabetically) for the tables to appear in the grid.

6. Select one or more individual tables to be deallocated, or click the **Select All** check box. A warning message appears.
7. To continue, click **Yes**; to cancel the deallocation, click **No**. If you click **Yes**, you see one of the following statuses, depending on the deallocation progress:
• If the deallocation has completed, you see the following confirmation evidence: The Allocation state changes to None; the Status changes to Done; and Task completed successfully appears in the comments for that table.
• If the deallocation is in progress, you see a notation that the Background task has been submitted.
• If the deallocation has timed out, you see the comment Check the logs in the task list. Note that the progress of the task is verified at five-second intervals, up to a maximum of ten minutes.

Deallocating a tenant table from a group

To deallocate a tenant table from a group:

1. Click Database Administration > Go to Database Administration in the OpenEdge Management console menu.
   The Database Administration page appears.
2. Filter or search for, and select the required database connection.
   The database connection home page appears.
3. Under Storage Management, click View groups.
4. Select the group whose table you want to deallocate.
   The group details page appears.
5. Under Mange Group, click Edit group. The Edit Group page appears.
   The table partitions are deallocated.
Updating tenant schema

As you work with databases enabled for multi-tenancy, you may find that you need to update the database's schema, modify the area assignments for a regular tenant's data, and save the changes. Using the multi-configuration tool, you can load and preview a data definition file and then commit the updates to the database, or you can skip the preview and just commit the changes.

For details, see the following topics:

- Uploading schema for a multi-tenant database
- Configuring an area working set
- Editing storage area assignments for regular tenants
- Committing changes to a multi-tenant database
- Monitoring data definition file updates to the database

Uploading schema for a multi-tenant database

As you work with a multi-tenant database, you may find that you need to update its schema. For example, consider the situation in which you have a multi-tenant application in production, serving tenants, and you want to update the application with additional functionality. If the application update also requires you to update the database schema, you can do this while the database is online by loading the data definition (.df) file that contains the schema modifications.

Once you load the data definition file, you can optionally preview the file's contents before applying the changes to the database. If you prefer, you can commit the changes without reviewing the preview.
Selecting and loading the data definition file

You can select and load a data definition file from the Load Data Definitions (.df) page.

1. On the management console menu, choose one of the following:
   - Select Database Administration > Load > Data Definitions (.df) file
   - Select Database Administration > Go to Database Administration. The Database Administration page appears.
     Filter or search for, and select the required database connection. The database connection home page appears.
     In the Data Administration section, click Load data definitions (.df file).

2. Click Browse to locate the file you want to upload.
   The file name appears in the Data definitions (.df file) field.

3. Select an available database connection from the Database connection drop-down list. (Note that a database server must be running for you to connect to the database.)

4. Choose one:
   - Choose Commit. The Confirm Commit database definitions dialog appears. For more information about this dialog, see Committing changes to a multi-tenant database on page 75.
   - Click Preview. The changes are uploaded to the server and the preview appears, as described in Previewing the contents of an uploaded data definition file on page 72.

Previewing the contents of an uploaded data definition file

When you load a data definition file, you can preview the changes contained in the file before you commit the changes to the database. The data definition preview reveals various details about an uploaded data definition.

The preview allows you to see the updates present in the file and make modifications before you commit the updates. The predefined color coding allows you to tell the allocation state at a glance. In the following figure, the color pink indicates that the area's partitions are not allocated.

The data definition file preview includes the following information:

- **Data Definitions** — A treeview list of the contents of the data definition file, along with a notation about which objects in the file have changed, and in what way. The notation can be ADD, DELETE, or MODIFY, or a combination of these, and appears after the object name in the display.

Only those multi-tenant objects that require or are affected by partition assignments appear in the treeview, since those are the only objects you can modify in the console. (However, any and all changes that are included in the data definition file are uploaded.) Consider the following typical updates, how the updates affect partition assignments, and how the updates will appear in the treeview list:
The addition of a table requires partition information for each tenant; therefore, the name of the new table appears in the list and is followed by **ADD**.

A data definition file might drop and re-add an index in order to change the fields that the index comprises. In such an instance—in which two actions relate to one object—both actions follow the object (the index name, for example) and are separated by a comma, as in **DELETE,ADD**.

Any changes to LOB fields are listed. Changes to any other type of field do not appear in the treeview since they do not affect partitioning.

A deleted object is shown with the notation **DELETE**.

An object whose details change (other than **ADD** or **DELETE**) is marked by the notation **MODIFY**.

The drop of a table, index, or LOB field is shown, since the drop causes a removal of partition information from the database. In this case, the name of the table, index, or LOB field is followed by **DELETE**.

**Areas Assignments** — A list of current storage area assignments for each object of the selected tenant as well as each area for any area assignment referenced by a schema object. You can select multiple partitions, and simply drag them from one area and drop them on another area.

**Properties** — Details about a schema object you select in the Data Definitions treeview or a partition object you select in a storage area.

When you select a schema object, details can include:

- **Name** — The name of the object selected in the treeview list
- **Default area** — The area assigned
- **Multi-tenant** — Whether the object is enabled for multi-tenancy
- **Keep default area** — Whether to keep the data in the default tenant upon upload
- **Tenant partition area** — The area where the tenant partition resides
- **Allocation state** — The partition allocation status, which identifies whether space has been allocated for the partition and/or when it will be allocated

For a sequence, the following details appear:

- **Name** — The name of the sequence
- **Multi-tenant** — Whether the sequence is enabled for multi-tenancy. (If it is, the check box is selected.)
- **Initial value** — The current value of the sequence.
- **Increment by** — A positive or negative integer value with which you want to change the sequence value at each increment.
- **Sequence minimum value** — An integer value that represents the lower limit of the sequence.
- **Upper limit** — An integer value that represents the upper limit of the sequence.
- **Cycle at Limit** — Whether a cycling sequence has been activated (**true**) or not (**false**)
• **Area** — The area where the object resides

• **Buffer Pool** — The chosen buffer pool, either primary or alternate.

• **Allocation state** — The partition allocation status, which identifies whether space has been allocated for the partition and/or when it will be allocated

• **Tenants** — A list of tenants in alphabetical order. By default, the first tenant is selected. If you have viewed the tenant already, a green indicator appears in the upper-left corner of the tenant name. If you have altered the tenant through the loading of a data definition file, a red indicator appears instead in the upper-left corner of the tenant name.

## Configuring an area working set

You can review a tenant's area layout in the detail frame. As you work with tenants and upload and commit schema changes, you might find that you cannot see all the database areas at one time. To remedy this, you can configure an area working set, which allows you to specify which areas you want to see in the tenant area layout. This option is useful when you are working with multi-tenancy tables with an allocation status of delayed or none.

To configure an area working set:

1. Click **Database Administration** > **Go to Database Administration** in the OpenEdge Management console menu.
   
   The **Database Administration** page appears.

2. Filter or search for, and select the required database connection.
   
   The database connection home page appears.

3. Click **View tenants** in the **Storage Management** section.
   
   The **Tenant List** page appears.

4. Select a tenant for which you want to configure an area working set.
   
   The tenant details page appears.

5. Click **Edit tenant** in the **Manage Tenant** section.
   
   The **Edit Tenant** page appears.

6. Click **Partitions** > **Configuring working areas**.
   
   The **Select Working Areas** dialog appears and presents a list of all of the Type II areas in the database and the number of partitions currently assigned to that area. (Areas already being shown are preselected.)

7. Click the check box for each area or click the **Select All** check box to select all the areas listed in the dialog box to appear in the area layout.

8. Click **Save** and **Close** when you finish.

9. Click **Partitions** to scroll in the area layout and see all the areas you chose to include in the working set.

10. To save the areas you added to the working set, click **Commit** in the tenant menu bar. (Note that any other pending transactions will also be committed at this time.)
Editing storage area assignments for regular tenants

Once you preview the schema changes present in an uploaded data definition file—but before you commit those changes—you can optionally modify the area assignments for a regular tenant's data provided the object allocation space is not specified to be set immediately. In this case, you cannot modify area settings.

The allocation state is indicated by both the Allocation state choice in the Properties and the predefined yellow color coding in the area panels.

The properties also indicate that the default area is being kept. The Keep default area option is available when you are converting from a shared table to one enabled for multi-tenancy. If you select the option when you create a multi-tenant table, the original table data is not deleted and is retained for the default tenant in the new table.

If you did not select the Keep default area option, a new partition will be created for the default tenant for that shared table in the area specified by the value(s) in the data definition file.

You can edit the area assignment from the drop-down in the Properties pane before you commit the updates contained in the uploaded data definition file. If you want to move Terms8 from Area 100 to Area 101, for example, you can simply drag it from one area and drop it on another area. You can also drag and drop from the Data Definitions treeview to one of the areas.

Committing changes to a multi-tenant database

You can upload a data definition file, preview its contents, make storage area modifications, determine when to allocate partition space, and then commit all the changes. As you do so, you can configure one or more tenants and then commit the changes all at once, rather than needing to commit the updates for each tenant individually.

To commit changes to the database:

1. From the data definition file preview page, click Commit in the tenant menu bar (located above the list of tenants). The Confirm commit database definitions dialog appears.

   The dialog shows the task name, which is the name given to the transaction you are committing. You can later use the task name to verify that the transaction has been applied once you commit the changes.

   If you want, you can modify the task name. By default, the given task name includes the name of the AdminServer and database (nbbedaspauldi.LocalScr), the type of transaction being committed (load database definitions), and the name of the uploaded data definition file (terms8.df).

2. Select from the following options:

   • Add new objects online — Allows you to make the following changes while the database is online:
     • Add new sequences.
     • Add new tables, along with any associated fields, indexes, and database triggers (which must be added within the same transaction).
• Add new fields to an existing table. (Note that you cannot define ASSIGN triggers for new fields while the database is online.)

• Add new inactive indexes to an existing table.

• **Add all new multi-tenant tables as shared tables** — Informs the load process to ignore any allocation settings for multi-tenant tables. Therefore, if a data definition file contains the MULTI-TENANT or KEEP-DEFAULT-AREA setting for a table, multi-tenancy settings are ignored and all objects become shared objects.

In addition, any modification described in the data definition file that would cause the table to become a multi-tenant table is ignored. (Once you enable multi-tenancy for a table you cannot disable it. You would then need to dump and reload the table.) Note that this does not apply to the addition of indexes and fields for existing tables. If an index or a table is being added to an existing multi-tenant table, the table or index is added as a multi-tenant schema object to that table.

Enabling this option can be useful, for example, if you are loading data definitions to a table that is not enabled for multi-tenancy or if you want to defer storage space allocation, particularly if you have many tenants with immediate allocation selected.

• **Force allocation of new partitions that otherwise would not be allocated** — Allows you to force allocation of partitions that otherwise would not be allocated when the data definition file is loaded. This option overrides the tenant's default allocation for new partitions, but changes applied to individual partitions will also be allocated if you select this option.

If you select this option, you have an additional choice to make between the following two selections:

• **Force allocation of all partitions with an allocation state of Delayed** — Forces allocation of partitions for tenants that are created as part of the uploaded data definition file and whose default allocation setting is to delay.

• **Force allocation of all partitions with an allocation state of Delayed or None** — Forces allocation of all partitions created as part of the uploaded data definition file. This includes those whose default allocation setting is to either delay or not allocate space at all.

For example, if a tenant has an object allocation default of no allocation (None) and a new partition for the tenant is changed to delay allocation (Delayed), this partition will be allocated if Force allocation is specified. If a tenant has its default allocation set to delay and a partition is changed to no allocation, the partition will be allocated only if the Force allocation of all partitions option is selected. Note that the forced allocation option also applies to new indexes and LOB fields added to existing multi-tenant tables.

• **Add new indexes in deactivated state** — Allows you to add in a deactivated state all new indexes that are described in the data definition file. This option applies to indexes on both shared and multi-tenant tables; enabling the option can save processing time if the loaded data definition file adds new indexes to tables that contain a large amount of data.

• **Commit changes even when errors are encountered during load** — Specifies that the load of definitions should continue, even if some definitions result in errors that prevent those definitions from being applied to the database. Note that selecting this option might leave the database in a corrupt state. If you have selected the Add new objects online option, this option is invalid and, therefore, unavailable.

3. Click Commit to commit the transactions. The data definitions from the data definition file are applied to the database, partition assignments are made, and allocation settings are applied.
The Dashboard page opens and displays a viewlet that allows you to monitor the status of the load data definition file task by either the default name or the name you assigned using the Task name field. For more information, see Monitoring data definition file updates to the database on page 77.

Monitoring data definition file updates to the database

Once you commit transactions to the database, you can view status of such a task in the Database Administration Tasks page by selecting Database Administration > View > Database Tasks.
Managing users and domains in a multi-tenant database

You can work with users and domains in tenants and in the database by using the multi-tenancy configuration tool.
For details, see the following topics:

• Managing users in a multi-tenant database
• Managing domains in a multi-tenant database
• Managing authentication systems
• Managing multi-tenant database table security for users
• Configuring database security options
• Configuring database security administrators
• Reviewing user access in the Data Administration Console

Managing users in a multi-tenant database

You can create and delete users, and you can make changes to several user-related fields. You can also add users to a particular tenant. For more details, see Adding a user to a tenant on page 62.

You cannot modify the User ID, User name, or Domain name. You can modify the password only if you are the user/password owner.
Adding a user to a multi-tenant database

To add a user to a multi-tenant database:

1. Click **Database Administration > Go to Database Administration** in the OpenEdge Management console menu.

   The **Database Administration** page appears.

2. Filter or search for, and select the required database connection.

   The database connection home page appears.

3. Click **Edit users** in the **Security Summary** section.

   A list of existing database users appears in a grid in the **Edit Database Users** page. If you have a large number of users, you can move forward or backward a page, or specify a particular page, in the list of users by using the **Page** feature at the bottom of the list.

   The list provides the following details:

   - **User ID** — The ID assigned to the user.
   - **User Name** — The user name.
   - **Domain Name** — The domain to which the user belongs.
   - **SQL Only** — If this option is enabled, the `_user` table record can be used only by a SQL connection to authenticate to the database. ABL clients cannot authenticate to the database by using user ID and user name.
     
     If the option is disabled, both SQL and ABL users can use the record.
   - **Description** — Provide a description or notes about a particular user.

4. Click **New**.

5. Provide the following information for the new user:

   - **User name** — Type the user’s name (required). Do not use spaces or special characters such as an asterisk (*), ampersand (&), or a period (.) in this field. You can include the underscore (_).
   
   - **Domain name** — Enter a domain name or click the **Search** icon to open the **Domain Selection** dialog to select a domain name (required).

     The **Domain Selection** dialog displays the details of the domains in a grid. You can search or filter the domains in the grid by **Domain name** and/or **Tenant name**.

     You can also move forward or backward the page, or specify a particular page, in the list of domains by using the **Page** feature at the bottom of the grid.

     **Note:** You can select the column heading and click the drop-down to choose the order (ascending or descending alphabetically) for the domains to appear in the grid.

   - **Password** — Type the user’s password.
Managing users in a multi-tenant database

- **Confirm password** — Retype the user’s password.

- **SQL Only** — Select the check box to indicate that the _user table record can be used only by a SQL connection to authenticate to the database.
  
  If the check box is enabled, ABL clients cannot authenticate to the database by using user ID and user name.
  
  If the check box is disabled, both SQL and ABL users can use the record.

- **User number** — Provide a number to identify the user (optional). The number must be a positive integer.

- **Description** — Provide a description (optional).

- **Given name/Middle initial/Surname** — Provide the user’s given name, middle initial, and surname (optional).

- **Telephone** — Type the user’s telephone number (optional).

- **E-mail** — Type the user’s email address (optional).

6. Click **Save**.

### Modifying a user in a multi-tenant database

To modify a user in a multi-tenant database:

1. Click **Database Administration** > **Go to Database Administration** in the OpenEdge Management console menu.

   The **Database Administration** page appears.

2. Filter or search for, and select the required database connection.

   The database connection home page appears.

3. Click **Edit users** in the **Security Summary** section.

   A list of existing database users appears in a grid in the **Edit Database Users** page. If you have a large number of users, you can move forward or backward a page, or specify a particular page, in the list of users by using the **Page** feature at the bottom of the list.

4. Select a user and make the modifications.

5. Click **Save**.

### Deleting a user from a multi-tenant database

To delete a user from a multi-tenant database:

1. Click **Database Administration** > **Go to Database Administration** in the OpenEdge Management console menu.

   The **Database Administration** page appears.

2. Filter or search for, and select the required database connection.

   The database connection home page appears.

3. Click **Edit users** in the **Security Summary** section.
A list of existing database users appears in a grid in the Edit Database Users page. If you have a large number of users, you can move forward or backward a page, or specify a particular page, in the list of users by using the Page feature at the bottom of the list.

4. Select the user you want to delete from the database, and click Delete.
5. Click Yes to confirm the deletion.

Managing domains in a multi-tenant database

You can work with domains in tenants and in the database by using the Database Administration Console. You can do the following:

• View and filter the existing domains
• Create a domain
• Edit a domain (including renaming a domain)
• Delete a domain (only if the domain has no users)

You can also edit existing authentication systems or create your own. You can also add domain users to a particular tenant. For more details, see Adding a tenant domain on page 61.

Viewing and filtering database domains

To view and filter the database domains:

1. Click Database Administration > Go to Database Administration in the OpenEdge Management console menu.

The Database Administration page appears.

2. Filter or search for, and select the required database connection.

The database connection home page appears.


The database domains grid provides the following details:

• Domain Name — The domain to which the tenant belongs.
• Authentication System — The authentication system; for example, Internal or LDAP.
• Tenant Name — The tenant that the domain belongs to.

Note that you can select the column heading and click the drop-down to choose the order (ascending or descending alphabetically) in which the items appear. This allows you to see which tenants belong to a particular domain.

• Enabled — Whether the domain is currently enabled.

You can filter the database domains which appear in the grid by a Domain name and/or Tenant name. Filtering allows you to focus only on the database domains for a particular tenant.

You can also move forward or backward the page, or specify a particular page, in the list of domains by using the Page feature at the bottom.
Adding a domain to a multi-tenant database

To add a domain to a multi-tenant database:

1. Click **Database Administration > Go to Database Administration** in the OpenEdge Management console menu.
   
   The **Database Administration** page appears.
2. Filter or search for, and select the required database connection.
   
   The database connection home page appears.
4. Click **New**.
5. Enter a new domain name in the **Domain name** field.
6. Click the drop-down arrow in the **Authentication system** field; select one of the predefined options.
7. Click the tenant name's **Search** icon; select a tenant from the **Tenant Selection** dialog, and click **OK**.
8. Type a code in the **Access Code** field. Re-type the access code in the **Confirm access code** field.
9. Enter a description and/or comments in the fields provided (optional).
10. If you want to disable the domain, clear the **Enabled** check box.

**Note:** The **Enabled** check box is selected by default.

11. Enter the audit record context value in the **Audit Context** field (optional).
12. Enter a comma-delimited list of runtime options for the domain in the **Runtime options** field (optional).
13. Enter the system option value in the **System options** field (optional).
14. Click **Commit**.

Modifying a domain in a multi-tenant database

To modify a domain in a multi-tenant database:

1. Click **Database Administration > Go to Database Administration** in the OpenEdge Management console menu.
   
   The **Database Administration** page appears.
2. Filter or search for, and select the required database connection.
   
   The database connection home page appears.
3. Under **Security Summary**, click **Edit domains**. A list of existing database domains appears.
   
   You can move forward or backward a page, or specify a particular page, in the list of domains by using the **Page** feature at the bottom of the list.
4. Select the domain you want to modify, and make the changes. If you want to rename a domain, replace the existing name with a new name in the **Domain name** field.
5. Click **Save**.
If you rename a domain associated with a tenant, the new domain name appears on the list frame for **Domains** after you save your changes.

**Note:** You cannot rename a domain associated with a default tenant.

### Deleting a domain from a multi-tenant database

To delete a domain from a multi-tenant database:

1. Click **Database Administration** > **Go to Database Administration** in the OpenEdge Management console menu.
   
The **Database Administration** page appears.
2. Filter or search for, and select the required database connection.
   
The database connection home page appears.
3. Under **Security Summary**, click **Edit domains**. A list of existing database domains appears.
4. Select the domain you want to delete from the database, and click **Delete**.
   
   **Note:** You cannot delete a domain if it has users.

5. Click **Yes** to confirm the deletion.

### Managing authentication systems

You can manage authentication systems using the multi-tenancy configuration tool. You can use a built-in authentication system, you can create a new authentication system, you can integrate with an ABL-based user authentication plug-in, and you can delete an authentication system as long as no existing domains reference it.

You cannot edit a built-in authentication system.

### Adding an authentication system

To add an authentication system:

1. Click **Database Administration** > **Go to Database Administration** in the OpenEdge Management console menu.
   
The **Database Administration** page appears.
2. Filter or search for, and select the required database connection.
   
The database connection home page appears.
3. Click **Edit authentication systems** in the **Security Summary** section.
   
The **Edit Database Authentication Systems** page appears with a list of existing authentication systems:
   
   You can move forward or backward a page, or specify a particular page, in the list of domains by using the **Page** feature at the bottom of the list.
4. Click **New**.
5. Type a name of the authentication system in the **Name** field.
6. Provide a description and/or comments (optional).
7. Type the path of the callback procedure name in the **Callback** field. The callback procedure file must be a `.p` or `.r` file.

**Note:** The callback procedure file contains the user authentication function which is implemented using the ABL-based authentication plug-ins. For details about the ABL authentication plug-ins, see *OpenEdge Development: Programming Interfaces*.

For the built-in domain types, the **Enabled authentication** and the **Checksum** check boxes are disabled by default. For the user-defined domain types, the check boxes get enabled and selected automatically, when you start typing the callback procedure name in the **Callback** field.

**Note:** The callback procedure must be a compiled version for enabling **Checksum** field.

8. Click **Save**. The new authentication system appears in the list.

---

**Deleting an authentication system**

To delete an authentication system:

1. Click **Database Administration** > **Go to Database Administration** in the OpenEdge Management console menu.

   The **Database Administration** page appears.

2. Filter or search for, and select the required database connection.

   The database connection home page appears.


4. Select the authentication system you want to delete, and click **Delete**.

   **Note:** You cannot delete an authentication system if there are existing domains that reference it.

5. Click **Yes** to confirm the deletion. The authentication system is removed from the list.

---

**Managing multi-tenant database table security for users**

As you work with users in the database, you can define what types of operations the users can perform on tables and fields enabled for multi-tenancy. You can also review at a glance the security settings you have established for the users.

To define security for one or more tables and fields:
Chapter 6: Managing users and domains in a multi-tenant database

1. Click Database Administration > Go to Database Administration in the OpenEdge Management console menu.

The Database Administration page appears.

2. Filter or search for, and select the required database connection.

The database connection home page appears.

3. Under Security Summary, click Edit data security. The schema appears in the list frame, and the list of tables for the database you selected appears.

4. To view or modify permissions for a table or field, select the table or field in the schema.

A list of current user permissions for the selected table or field appears in a permission panel for each of the following options. The default for each permission is an asterisk ( * ), indicating that the permission is currently in place for all users.

<table>
<thead>
<tr>
<th>A user granted this permission . . .</th>
<th>Can . . .</th>
</tr>
</thead>
<tbody>
<tr>
<td>Can-read</td>
<td>Read a table or field.</td>
</tr>
<tr>
<td>Can-write</td>
<td>Write to a table or field.</td>
</tr>
<tr>
<td>Can-create</td>
<td>Create new records in a table. To create a new record, users must also have Can-write privileges.</td>
</tr>
<tr>
<td>Can-delete</td>
<td>Delete records from a table.</td>
</tr>
<tr>
<td>Can-dump</td>
<td>Dump database or table definitions and data with triggers disabled.</td>
</tr>
<tr>
<td>Can-load</td>
<td>Load database or table definitions and data with triggers disabled.</td>
</tr>
</tbody>
</table>

5. To include hidden tables and fields in the list, click the Filter icon. The Show hidden tables and fields check box appears.

6. Select the check box to see the hidden objects, or click the Filter icon again to close the check box.

7. If you want to add to the list of users for a particular permission, click that permission panel. The list of actions to the right of the permission panel reflects the options you have regarding that permission, in addition to providing a link for you to review user data security based on the selected permission.

For example, if you click the Can-create panel, the list of actions appears.

8. Choose one:

- Click Add users to<permission>, from the Actions list. The User Selection dialog appears. Select one or more users in the list, and click OK.

- Type the name of each user you want to add. Follow these conventions:
  - Separate user names by inserting a comma (not a period) between each one.
  - Use an asterisk ( * ) to allow a permission for all users. Remember to remove the asterisk if you do not want a permission to be available for all users.
  - To allow a permission for all users except one—for example user u1—use !u1,*
• To allow a permission for only those users whose names begin with a letter or letters—for example ab—use ab*

• To allow a permission for a user of a domain, separate the user name with the domain name:

  user@domain

• To allow a permission for all users of a domain, put a wild card in front of the domain:

  *@domain

9. Repeat Step 8 on page 86 for each additional permission.

10. Click Commit to save the settings.

**Reviewing user data security permissions**

You can review the permissions that exist for users with regard to data security.

To review user data security permissions:

1. Click Database Administration > Go to Database Administration in the OpenEdge Management console menu.

   The Database Administration page appears.

2. Filter or search for, and select the required database connection.

   The database connection home page appears.


4. To include hidden tables and fields in the permissions details, select the option.

5. Do either of the following to select the user whose permissions you want to view:

   • Type the User ID in the field provided, and click Search.
   • Click Find User. From the Select a User dialog that appears, select the user whose permissions you want to view. Click OK.

   The data security permissions that exist for the user, by table, appear in the Data Security Permissions dialog. Each permission the user has is marked. Where the user has no permission, there is no mark present.

**Configuring database security options**

The Database Security Options page enables you to maintain the security options for a database. Only a user with administrator privileges, can access this page to configure the database security options.

To configure the database security options
1. Click Database Administration > Go to Database Administration in the OpenEdge Management console menu.

The Database Administration page appears.

2. Filter or search for, and select the required database connection.

The database connection home page appears.


4. You can select one or more of the following security options:

<table>
<thead>
<tr>
<th>Security options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trust application domain registry</td>
<td>Overrides the database connection’s domain registry settings and uses the application level domain registry settings. For more information about domain registry settings, see OpenEdge Getting Started: Core Business Services.</td>
</tr>
<tr>
<td>Record authenticated client sessions</td>
<td>Record user login sessions.</td>
</tr>
<tr>
<td>Disallow blank userid connections</td>
<td>Blocks database connection with blank UserId.</td>
</tr>
<tr>
<td>Use runtime permissions checking</td>
<td>Apply CAN-WRITE and CAN-READ permissions at runtime, rather than at compile time.</td>
</tr>
</tbody>
</table>

When you finish, click Commit.

### Configuring database security administrators

You can establish one or more security administrators for a multi-tenant database. You can also identify domains as security administrators; in such a case, everyone in a domain is a security administrator.

To set up a database security administrator:

1. Click Database Administration > Go to Database Administration in the OpenEdge Management console menu.

   The Database Administration page appears.

2. Filter or search for, and select the required database connection.

   The database connection home page appears.

3. Click Edit.

   The Edit Database Connection page appears.

4. In the Database authentication area, select the Log in with these credentials option.

5. Type the User ID, password, and then type the password again to confirm it.

6. Click Save.

7. Under Database Administration, select the database connection you are logged in to.

You can designate one or more security administrators by:

• Typing the login ID for each user in the box provided.

• You can enter multiple user IDs here, but you must include your own user ID. Separate the user IDs with commas, but no spaces.

• Clicking Add users to Security Administrators. A list of users appears; select each user you want to designate as a security administrator. Be sure to select your own ID in the list. Click OK when you finish.

• Click Add domains to Security Administrators. A list of domains appears; select the domains you want to designate. All users in the domains you specify will be security administrators. Click OK when you finish.

9. When you finish, click Save.

Setting up a database connection login

You can set up a database connection login that allows you access to super-tenants.

To set up a login to a database connection:

1. From the list of connections, select the connection for which you want to establish a login.
2. Under Manage Database Connection, click Edit database connection.
3. Select the Log in with these credentials option, and provide the user ID and password. Type the same password in the Confirm password field.
4. Click Save.

Reviewing user access in the Data Administration Console

The access to various options and links available in the database and tenant landing pages depends on the type of user's tenant used for the database connection. There are three types of users associated with a database connection:

• Default user
• Regular user
• Super user

An user can be associated with either the default tenant, regular tenant, or super-tenant. For more information on managing users in a database connection, see Managing users in a multi-tenant database on page 79.

Database landing page options

The following table lists the options available in the Database landing page for the user associated with the database connection. Note that full access to a database landing page requires a database connection for a user with the administrator privileges.
### Table 1: Database landing page

<table>
<thead>
<tr>
<th>Database landing page section</th>
<th>Default User</th>
<th>Regular User</th>
<th>Super User</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manage Database Connection</td>
<td>• Edit database connection</td>
<td>• Edit database connection</td>
<td>• Edit database connection</td>
</tr>
<tr>
<td>Security Summary(^5)</td>
<td>• Edit security options</td>
<td>• Edit security options</td>
<td>• Edit security options</td>
</tr>
<tr>
<td></td>
<td>• Edit security administrator</td>
<td>• Edit security administrator</td>
<td>• Edit security administrator</td>
</tr>
<tr>
<td></td>
<td>• Edit users</td>
<td>• Edit users</td>
<td>• Edit users</td>
</tr>
<tr>
<td></td>
<td>• Edit domains</td>
<td>• Edit domains</td>
<td>• Edit domains</td>
</tr>
<tr>
<td></td>
<td>• Create tenant</td>
<td>• Create tenant</td>
<td>• Create tenant</td>
</tr>
<tr>
<td></td>
<td>• Edit authentication systems</td>
<td>• Edit authentication systems</td>
<td>• Edit authentication systems</td>
</tr>
<tr>
<td></td>
<td>• Edit data security</td>
<td>• Edit data security</td>
<td>• Edit data security</td>
</tr>
<tr>
<td></td>
<td>• Review user data security</td>
<td>• Review user data security</td>
<td>• Review user data security</td>
</tr>
<tr>
<td>Data Administration</td>
<td>• Edit sequences</td>
<td>• Edit sequences</td>
<td>• Edit sequences</td>
</tr>
<tr>
<td></td>
<td>• Export sequences</td>
<td>• Export sequences</td>
<td>• Export sequences</td>
</tr>
<tr>
<td></td>
<td>• Load data definitions (.df file)</td>
<td>• Load data definitions (.df file)</td>
<td>• Load data definitions (.df file)</td>
</tr>
<tr>
<td></td>
<td>• Load table contents (.d file)</td>
<td>• Load table contents (.d file)</td>
<td>• Load table contents (.d file)</td>
</tr>
<tr>
<td></td>
<td>• Load group contents (.d file)</td>
<td>• Load group contents (.d file)</td>
<td>• Load group contents (.d file)</td>
</tr>
<tr>
<td></td>
<td>• Dump table contents (.d file)</td>
<td>• Dump table contents (.d file)</td>
<td>• Dump table contents (.d file)</td>
</tr>
<tr>
<td></td>
<td>• Dump group contents (.d file)</td>
<td>• Dump group contents (.d file)</td>
<td>• Dump group contents (.d file)</td>
</tr>
</tbody>
</table>

**Tenant's landing page options**

The following table lists the options available for each type of user associated with the database connection and the tenant type selected in the Tenant's landing page. Note that full access to a tenant's landing page requires a database connection for a user associated with either a super-tenant or that specific tenant.

---

\(^5\) The **Edit security options** and **Edit security administrator** links are enabled for the default user, a regular user, or a super user with the administrator privileges. For more information on configuring database security administrators, see Configuring database security administrators on page 88.
Table 2: Tenant’s landing page

<table>
<thead>
<tr>
<th>Tenant Type</th>
<th>Tenant’s landing page section</th>
<th>Default User</th>
<th>Regular User</th>
<th>Super User</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default Tenant¹</td>
<td>Manage Tenant</td>
<td>• Edit tenant</td>
<td>• Edit tenant</td>
<td>• Edit tenant</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Generate tenant program</td>
<td>• Generate tenant program</td>
<td>• Generate tenant program</td>
</tr>
<tr>
<td></td>
<td>Database Administration</td>
<td>• Deallocate tables</td>
<td>• Deallocate tables</td>
<td>• Deallocate tables</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Edit sequence values</td>
<td>• Edit sequence values</td>
<td>• Edit sequence values</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Export sequences</td>
<td>• Export sequences</td>
<td>• Export sequences</td>
</tr>
<tr>
<td>Regular Tenant</td>
<td>Manage Tenant</td>
<td>• Edit Tenant</td>
<td>• Edit Tenant</td>
<td>• Edit Tenant</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Delete tenant</td>
<td>• Delete tenant</td>
<td>• Delete tenant</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Tenant data access: enabled</td>
<td>• Tenant data access: enabled</td>
<td>• Tenant data access: enabled</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Generate tenant program</td>
<td>• Generate tenant program</td>
<td>• Generate tenant program</td>
</tr>
<tr>
<td></td>
<td>Data Administration</td>
<td>• Deallocate tables</td>
<td>• Deallocate tables</td>
<td>• Deallocate tables</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Edit sequence values</td>
<td>• Edit sequence values</td>
<td>• Edit sequence values</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Export sequences</td>
<td>• Export sequences</td>
<td>• Export sequences</td>
</tr>
<tr>
<td>super-tenant</td>
<td>Manage Tenant</td>
<td>• Edit tenant</td>
<td>• Edit tenant</td>
<td>• Edit tenant</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Delete tenant</td>
<td>• Delete tenant</td>
<td>• Delete tenant</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Generate tenant program</td>
<td>• Generate tenant program</td>
<td>• Generate tenant program</td>
</tr>
<tr>
<td></td>
<td>Data Administration</td>
<td>• Edit sequence values</td>
<td>• Edit sequence values</td>
<td>• Edit sequence values</td>
</tr>
</tbody>
</table>

¹ The **Delete tenant** link is not available for the default tenant, because the default tenant in a database connection cannot be deleted by either a regular or super user.

² A regular user can export sequences of it own, but cannot export sequences of the default tenant or other regular tenants.

³ The **Delete tenant** link is not available for the tenant to which the logged user belongs to. For example, for a regular user, the **Delete tenant** link is not available for a regular tenant.

⁴ A default user cannot export sequences of a regular tenant.

⁵ The **Edit sequence values**, **Deallocate tables**, and **Export sequences** options are not available for a super user, because super-tenant does not have data of its own.
Edit Tenant's landing page options

The following table lists the options available for each type of user associated with the database connection, and the tenant type selected in the Edit Tenant's landing page. Note that full access to the Edit tenant’s landing page requires a database connection for a user associated with either a super-tenant or that specific tenant.

Table 3: Edit Tenant’s landing page

<table>
<thead>
<tr>
<th>Tenant Type</th>
<th>Default User</th>
<th>Regular User</th>
<th>Super User</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default Tenant 11</td>
<td>• Tabs: General, Partitions, Users, Domains</td>
<td>• Tabs: General, Partitions, Users, Domains</td>
<td>• Tabs: General, Partitions, Users, Domains</td>
</tr>
<tr>
<td></td>
<td>• Configure working areas</td>
<td>• Configure working areas</td>
<td>• Configure working areas</td>
</tr>
<tr>
<td></td>
<td>• Commit</td>
<td>• Commit</td>
<td>• Commit</td>
</tr>
<tr>
<td></td>
<td>• Tools</td>
<td>• Tools</td>
<td>• Tools</td>
</tr>
<tr>
<td>Regular Tenant</td>
<td>• Tabs: General, Partitions, Users, Domains, Groups</td>
<td>• Tabs: General, Partitions, Users, Domains, Groups</td>
<td>• Tabs: General, Partitions, Users, Domains, Groups</td>
</tr>
<tr>
<td></td>
<td>• Configure working areas</td>
<td>• Configure working areas</td>
<td>• Configure working areas</td>
</tr>
<tr>
<td></td>
<td>• Commit</td>
<td>• Commit</td>
<td>• Commit</td>
</tr>
<tr>
<td></td>
<td>• Tools</td>
<td>• Tools</td>
<td>• Tools</td>
</tr>
<tr>
<td>Super-tenant</td>
<td>• Tabs: General, Users, Domains</td>
<td>• Tabs: General, Users, Domains</td>
<td>• Tabs: General, Users, Domains</td>
</tr>
<tr>
<td></td>
<td>• Commit</td>
<td>• Commit</td>
<td>• Commit</td>
</tr>
<tr>
<td></td>
<td>• Tools</td>
<td>• Tools</td>
<td>• Tools</td>
</tr>
</tbody>
</table>

11 As the default tenant and a super-tenant cannot be added to a group, the Groups tab is not available for the default tenant or super-tenant. Also, for a super-tenant, the Partition tab and Configure working areas options are not available, as a super-tenant does not have any data of its own.
As you create and work with regular tenants, you might find that the initial configuration you set up for each tenant is identical. For example, you might recognize that the database connection and the default area assignments for tables, indexes, and LOB fields are the same for many newly created tenants.

To allow you to create regular tenants more efficiently, you can create one or more reusable tenant templates.

For details, see the following topics:

• Using tenant templates
• Creating a tenant template
• Filtering partitions from a tenant template
• Viewing a list of available tenant templates
• Creating a tenant from a tenant template
• Editing a tenant template

Using tenant templates

To allow you to create regular tenants more efficiently, you can create one or more reusable tenant templates. Once you create a tenant template, you can use it as is or later modify it if necessary. Template modifications affect any new tenants you create from the edited template. (Any tenants already created remain unchanged.)
You begin creating a template from **Database Administration** in the management console menu bar. You can work on one or more tenant templates simultaneously.

When you later want to create a regular tenant, you can select the tenant template from a list of available templates.

### Allocation considerations when creating a tenant template

When you create a tenant template, you choose between the following two allocation options:

- Set new objects not to allocate space
- Set new objects to delay space allocation

Note that the option to allocate space immediately is not available, since it would disallow the creation of partition mapping for any tenant you create with the template. A template that stipulates that allocation should be immediate would establish default assignments and ignore any area assignments you try to set, as allocation would already be complete.

### Creating a tenant template

To make creating tenants easier, you can create a tenant template. As you define the template, you must at a minimum provide the name of the template and make an allocation rule selection.

You establish tenant template settings on the **General** tab and the **Partitions** tab. As you select the template settings, you can switch between the two tabs, and then save the template once you finish with all the settings.

### Choosing general tenant template settings

You create a tenant template by making choices about general and partition-related settings.

To choose general tenant template settings:

1. Select **Database Administration > New > Tenant Template** in the management console menu.

   The template creation page opens, with the **General** details in focus.

2. In the **Template name** field, enter a template name.

   Providing the template name is the only requirement on this page; however, you can also choose the database connection, identify default areas, and select an allocation rule if you want.

3. In the **Database connection** field, enter a database connection name to which you want to add the tenant template. By default, the last used database connection name appears in the **Database connection** field.

   **Note:** If you type the name of the database connection, follow the format used by OpenEdge Management/OpenEdge Explorer to define a connection: `AdminServer-name.database-name`. A database server must be running for you to connect to the database.
Creating a tenant template

You can also click the Search icon to choose a database for which you are creating the tenant from the Connection Selection dialog.

The Connection Selection dialog displays the connections details in a grid. You can perform the following:

- Filter the connections in the grid by Connection name, AdminServer, and/or Category.
- Select the column heading and click the drop-down to choose the order (ascending or descending alphabetically) for the connections to appear in the grid.

4. Choose a selection for each of the following:

- **Default data area** — The default area for tenant data
- **Default index area** — The default area for index data
- **Default LOB area** — The default area for LOB field data

For each of the areas, you can either enter the storage area name in the default area field or click the Search icon to choose the storage area name from the Area Selection dialog.

The Area Selection dialog displays the storage area names in a grid. You can perform the following:

- Filter the storage area name in the grid by Area name, Records per block, and/or Cluster size.
- Move forward or backward a page, or specify a particular page, in the list of domains by using the Page feature at the bottom of the list.
- Select the column heading and click the drop-down to choose the order (ascending or descending alphabetically) for the area names to appear in the grid.

5. Optionally select the object allocation rule:

- **Set new objects not to allocate space** — Allocate no space for the tenant's objects.
- **Set new objects to delay space allocation** — Do not yet allocate storage space. (You can allocate space later when you are ready to do so.)

6. Click Save. Additionally, you can choose partition-related template settings.

Choosing partition-related template settings

You create a tenant template by choosing partition-related (and general) settings.

To choose partition-related template settings:

1. Click Partitions. The tenant template's partitions appear.
   
   From this page, you can:

   - Choose to view the partitions in either of two different layouts: by area panels, which is the default and is shown above, or by columns in a grid view. To switch from one layout option to the other, click the View Grid or View Area icon in the upper-right corner of the Template Object Area Assignments panel.
   - Filter the partitions by allocation state. Click Filter Partitions in the tenant menu bar, and select one or more of the filtering options. Then click Apply.
• Make changes to the template object area assignments. This is helpful because when you use the template to create a tenant in the future, any partition changes that you make to individual tenant objects from this page during the template creation are preserved for the individual objects in the new tenant.

For example, consider that you define TenantArea20 (as shown in the General details) as the default data area for the template, but you want one particular table named mtCustomer to be in TenantArea25. You can change the partition assignment for the mtCustomer table from the template default data area of TenantArea20 to TenantArea 25.

Select mtCustomer in the list of template object area assignments. The mtCustomer table properties appear in the Properties pane:

In the Properties pane, click the Search icon for the Area field; select TenantArea 25 in the Area Selection dialog and click OK.

When you use the template to create a tenant in the future, the tenant partition area you explicitly set for any object (such as the mtCustomer table in this example) in the template is preserved.

2. Click Save to maintain the settings. The tenant template is created.

Filtering partitions from a tenant template

You can filter the view of partitions by allocation state from a tenant template. You can also filter the view of partitions by allocation state from a tenant.

To filter partitions by allocation state from a tenant template:

1. Select Database Administration > Configure > Tenant Templates in the management console menu.
2. Select the template in the list, and click Edit template. The Edit Tenant Templates page appears.
3. Click Filter partitions. The filtering options appear:
   - All filtering options are selected by default. You can deselect any of the options. (To close the filtering options box without making any changes, click Filter partitions.)
4. Click Apply filter to begin filtering.

Viewing a list of available tenant templates

You can view a list of available tenant templates and choose one to use as the basis for a new tenant you want to create. If you want to create a tenant that is almost but not exactly identical to one for which there is a template, you can select the template from the list, modify it, save it, and use the edited template as the basis for the new tenant.

To view the list of available tenant templates:

• Select Database Administration > Configure > Tenant Templates in the management console menu. The list of templates appears.

From the tenant template list, you can:
• **Select all the templates** — Select the **Select All** option.

• **Refresh the list of templates** — Click the **Refresh** icon.

• **Copy a template** — Select a template, and click the **Copy** icon. The **Copy tenant template** dialog appears. Type the name of the new template or accept the default name provided, and click **OK**. The copied template appears in the list once you click the **Refresh** icon.

• **Delete a template** — Select a template, and click **Delete**. The template name is immediately removed from the list.

---

**Creating a tenant from a tenant template**

You can create a new regular tenant from a tenant template.

Note that you can open a template only if it is associated with a valid database connection that you can access. If the database connection is no longer valid or accessible, either restore the database connection with the same connection name as required by the template, or delete the template.

To create a tenant from a tenant template:

1. Select **Database Administration > Configure > Tenant Templates** in the management console menu. The list of templates appears.

2. Select the template you want to use, and click **Create tenant from template**. (If you do not see a recently created template in the list, click **Refresh**.) The tenant creation page opens.

   If you defined any of the following settings when you created the selected tenant template, the settings are loaded for you:

   • **Database connection**

   • **Default data area**

   • **Default index area**

   • **Default LOB area**

   • **Object allocation rule**

   • **Template** (from which to copy defaults for the tenant)

   You can use any or all of the template defaults, or you can make changes. The changes you make override any of the default settings for this tenant but do not modify the actual template.

3. Type the tenant name, which is required, and an optional description.

4. Do one of the following:

   • Click **Create tenant**. The tenant is created, and the tenant home page appears.

   • Click **Generate tenant program**. You are prompted to save the `create_tenant.p` file.

---

**Editing a tenant template**

You can edit an existing tenant template.
To edit a tenant template:

1. Select **Database Administration > Configure > Tenant Templates** in the management console menu. The list of templates appears.

2. Select the template you want to edit, and click **Edit template**. The template’s **General** information appears. You can make the required changes here.

3. Click **Partitions**. You can make the required partitions-related changes here.

4. Click **Save**.
Working with sequences

From the database home page, you can work with sequences and their values. For details, see the following topics:

- Working with sequences and sequence values
- Editing sequence values
- Exporting sequences for a tenant

Working with sequences and sequence values

Sequences are database objects that provide incremental values to an application. They can generate sequential values within any range of an ABL integer (–2,147,483,648 to 2,147,483,647) and with your choice of increment (positive or negative).

You can also define sequences to cycle or terminate when a specified limit is reached. A cycling sequence restarts after it reaches the specified limit, providing non-unique values for the life of the sequence. A terminating sequence stops incrementing after it reaches the specified limit, providing unique values for the life of the sequence as long as you do not explicitly reset it.

Types of sequences

A multi-tenant sequence is defined for a database but allows each tenant to view and update its own current value. A shared sequence has one value and is non-multi-tenant enabled.
Each tenant's sequence has its own current value. All other sequence settings are shared, including the minimum, maximum, increment, and rollover values. Changing the increment, therefore, affects the value for all tenants.

Sequence functionality and user credentials

Access to sequences and their values depends on the credentials of the user who has established the database connection. To be able to access and edit the current values, the user whose credentials were supplied at login must be either a super-tenant or a user of the tenant whose sequence values are being accessed. If the user is a super-tenant user, the user can access sequence current values for all tenants.

As a user of the regular tenant whose sequence values you want to work with, you can:

- View a list of sequences with details that include, for example, whether a sequence is enabled for multi-tenancy; a sequence’s initial value; and a sequence’s increment value.
- Edit the current values for shared sequences.
- Edit a tenant's current values for the shared sequences.
- Edit a tenant’s current values for the multi-tenant sequences (provided that the user whose credentials were provided at database connection is a user of that tenant).
- Preview sequence definitions when loading a data definition file.
- Export to a file the current values for all multi-tenant.
- Export to a file the current values for shared sequences for the tenant (provided that the user whose credentials were provided at database connection is a user of that tenant).

Database connection user credentials for a super-tenant user permit the user to do all of the above as well as the following tasks:

- Edit the current values for all tenants of a multi-tenant sequence.
- Export by tenant the current values for all regular tenants to individual files. Each tenant has an individual file that contains the current sequence values for all multi-tenant sequences. For each tenant, an export file is created and holds the current sequence values for that tenant for each multi-tenant sequence.
  
  The super-tenant does not have its own sequence data; therefore, when you export sequence values for multi-tenant sequences, no file is generated.

When a tenant is added to the database, a current sequence value (set to the initial value) is stored for the tenant for each multi-tenant sequence. When a tenant is removed from a database, each multi-tenant sequence and its current value for that tenant is dropped from the database.

You cannot currently convert a shared sequence to a multi-tenant sequence. However, you can add multi-tenant sequences, created in the Data Dictionary tool, to a database by loading a data definition file (.df) that contains them.
Creating a multi-tenant sequence and loading a data definition file with sequences

As has been the case in previous releases of OpenEdge, you create a sequence by using the Data Dictionary tool. With this release of OpenEdge, you can choose to create the sequence as multi-tenant. (If you do not choose the multi-tenant option, you create a shared sequence.)

Although you cannot create sequences from the Database Administration Console, you can use the tool to view and edit them. As you have done in previous releases, you begin by using the Data Administration tool (Start > Programs (or All Programs) > Progress > OpenEdge > Data Administration) to create a data definition file that contains sequences. Using the multi-tenancy configuration tool, you can then load the data definition file that contains the sequences into the database and edit the sequence current values.

Due to the importance of establishing the required user credentials to work with multi-tenancy, many tasks that you perform related to multi-tenancy in the Data Dictionary tool or the Data Administration tool require the user ID and password of a super-tenant user.

Exporting current sequence values

By using the Data Administration tool (Start > Programs (or All Programs) > Progress > OpenEdge > Data Administration) in the current version of OpenEdge, you can export current sequence values to a file. You have the option of doing so for multi-tenant sequences, shared sequences, or all sequences. You can then import the file to the database by using Data Administration or an ABL program. For more information, see the Data Administration online help or OpenEdge Development: ABL Reference.

By configuring multi-tenancy in the Database Administration Console, you can export all current values for all tenants at one time. For more information, see Exporting sequences for a tenant on page 104.

Viewing a list of sequences

You can view a list of sequences for a database from the database's home page. If you have connected to the database as a super-tenant user, you can view a list of multi-tenant enabled sequences for all tenants, since a super-tenant has access to all tenant data. You can also edit and export the sequence current values of multi-tenant enabled tenants.

If you have connected to the database as a regular tenant user, you can view a list of sequences only for the tenant you belong to. You cannot view, edit, or export sequence current values for any other tenants.

To view a list of sequences:

1. Click Database Administration > Go to Database Administration in the OpenEdge Management console menu.
   
   The Database Administration page appears.
2. Filter or search for, and select the required database connection.
   
   The database connection home page appears.
3. Under Data Administration, click Edit sequences. The Edit Database Sequences page appears.
Chapter 8: Working with sequences

Note that if you have a long list of sequences, you can type a particular sequence name in the **Sequence name** field and click the **Search** icon. You can move forward or backward the page, or specify a particular page, in the list of sequences by using the **Page** feature at the bottom of the grid.

**Note:** You can also sort the details by column in either ascending or descending order by clicking the column name and then the **Sort** arrow.

The **Edit Database Sequences** page provides the following details:

- **Sequence Name** — The name of the sequence.
- **Multi-tenant** — Whether the sequence is enabled for multi-tenancy (**true**) or not (**false**).
- **Initial Value** — The value at which a sequence begins to increase (or decrease).
- **Increment by** — The value by which a sequence will increment (or decrement) values from the initial value.
- **Upper Limit** — An integer value that defines the upper (or lower) limit of the sequence.
- **Cyclic at Limit** — Whether a cycling sequence has been activated (**true**) or not (**false**).

A cycling sequence is a sequence that restarts after it reaches the specified limit, providing non-unique values for the life of the sequence. The value of a cycling sequence resets to its defined initial value when the sequence exceeds its upper limit or falls below its lower limit providing non-unique values for the life of the sequence. The terminating sequence stops increasing when it reaches its upper limit or stops decreasing when it reaches its lower limit, providing unique values as long as you do not explicitly reset it.

- **Current Value** — The current value of the sequence.

  For a newly created (not yet committed) sequence, the field is empty. For a shared sequence, the current value for the sequence is shown.

  For a multi-tenant sequence value you can change, an **Edit** link appears. For more information, see **Editing sequence values** on page 102.

4. From the list, you can:

   - Edit a multi-tenant sequence's current value. See **Editing sequence values** on page 102.
   - Restore an edited sequence's current value to its previous setting. See **Restoring sequence current values** on page 104.

---

**Editing sequence values**

You can edit the values for all sequences for a particular tenant or for all tenants of a particular sequence.

If you have connected to the database as a super-tenant user, you can edit and you can export the sequence current values of all multi-tenant enabled tenants.

If you have connected to the database as a regular tenant user, you can view a list of sequences and edit sequence current values for only that tenant you belong to. You cannot edit sequence current values for any other tenants.
Editing the values for all sequences for a tenant

To edit the current values for all sequences for a tenant:

1. Click Database Administration > Go to Database Administration in the OpenEdge Management console menu.
   The Database Administration page appears.
2. Filter or search for, and select the required database connection.
   The database connection home page appears.
4. Select the tenant you want to edit. The tenant details page appears.
5. Select a tenant. The tenant home page appears.
6. Under Data Administration, click Edit sequence values. The Edit Tenant Sequence Current Values page appears.
   If you have a long list of multi-tenant sequences, you can type a particular sequence name in the Sequence name field and click the Search icon. You can also move forward or backward the page, or specify a particular page, in the list of sequences by using the Page feature at the bottom of the grid.

   **Note:** You can also sort the details by column in either ascending or descending order by clicking the column name and then the Sort arrow.

7. To modify the current value of a multi-tenant sequence, select the value for the sequence in the Current Value column.
8. Change the sequence value. A red mark appears in the corner of the column cell to indicate that the value has been changed.
9. Click Commit.

Editing the values for all tenants of a sequence

To edit the values for all tenants of a sequence:

1. Click Database Administration > Go to Database Administration in the OpenEdge Management console menu.
   The Database Administration page appears.
2. Filter or search for, and select the required database connection.
   The database connection home page appears.
3. Under Data Administration, click Edit sequences. The Edit Database Sequences page appears.
4. To modify the current value of a multi-tenant sequence, double-click the field in the Current Value column for the sequence and then update the value.
5. Click in the Current Value column to set or change the sequence value for a tenant. A red mark appears in the corner of the column to indicate that the value has been changed.
6. Click Commit to save the changes.
Restoring sequence current values

You can restore a sequence current value that you have modified.

From the Edit Database Sequences page, select a tenant name and click Restore. The previous value is restored to the Current Value column.

Exporting sequences for a tenant

A super-tenant user can export sequences for one or more tenants; a regular tenant user can export current sequence values only for the tenant the user belongs to.

You cannot export sequences if you are connected to the database with the blank user ID.

Exporting sequences for one or more tenants in the database

To export sequences for one or more tenants in the database:

1. Establish the database connection as a super-tenant user.
2. Click Database Administration > Go to Database Administration in the OpenEdge Management console menu.

   The Database Administration page appears.
3. Filter or search for, and select the required database connection.

   The database connection home page appears.
4. Under Data Administration, click Export sequences.

   If the database connection is a non multi-tenant database, the Export sequence current values page appears.

   **Note:** The tenant selection options do not display for non multi-tenant databases.

   If the database connection is a multi-tenant database, the Export sequences current values page appears.

   The following information is prefilled:

   • AdminServer name — The AdminServer for the connected database.
   • Directory location — Where the exported file will be located.
   • File name — The name of the exported file.

   Note that if you export only non-multi-tenant enabled sequences, all the sequence data will be located in the one file specified in this field. However, if the export includes multi-tenancy enabled sequences and the sequences have different values per tenant, a new directory is created (in the Directory location you specified) for each tenant. Each separate directory contains a file; the file contains the exported sequences and current values specific to that tenant.
• **Code page** — The code page.

5. Select which type of sequence you want to export: All, Shared, or Multi-tenant.
6. Select one or more tenants, or select the Select all option for all the tenants listed.
7. Click **Export**. You can view status of such a task in the **Database Administration Tasks** page by selecting **Database Administration > View > Database Tasks**.

You cannot import the exported file to a database from the Database Administration Console; you can, however, use the Data Administration tool (**Start > Programs (or All Programs) > Progress > OpenEdge > Data Administration**), which has been enhanced to accommodate the inclusion of multi-tenancy-enabled sequences when you are exporting or importing data. For more information, see the Data Dictionary online help.

**Exporting sequence current values for a selected tenant**

To export sequence current values for a selected tenant:

1. Establish the database connection as a regular tenant user.
2. Click **Database Administration > Go to Database Administration** in the OpenEdge Management console menu.
   
   The **Database Administration** page appears.
3. Filter or search for, and select the required database connection.
   
   The database connection home page appears.
4. Under **Storage Management**, click **View tenants**.
5. Select the tenant you want to edit. The template details page appears.
6. Under **Database Administration**, click **Export sequences**. The **Export Tenant Sequence Current Values** page appears and includes the tenant name.
   
   The following information is prefilled:

   • **AdminServer name** — The AdminServer for the connected database.

   • **Use default location** — Indicates if you want to use the OpenEdge Work directory (the default) for the location of the exported file. This option is preselected; to choose an alternate location, clear the check box and provide a new location in the **Directory location** field.

   • **Directory location** — Where the exported file will be located.

   • **File name** — The name of the exported file.

   • **Code Page** — The code page.

7. Select which type of sequence you want to export: All, Shared, or Multi-tenant.
8. Click **Export**. You can view status of such a task in the **Database Administration Tasks** page by selecting **Database Administration > View > Database Tasks**.
Working with tenant groups

A tenant group represents a single partition for a single table, along with the partitions for the table's LOB fields and indexes, that can be shared by tenants. All tenants in a group have access to the same data. When you create a group, you are creating an independent partition that multiple tenants view.

For details, see the following topics:

- Using tenant groups
- Creating a group or group program
- Editing a group
- Viewing a list of tenant groups
- Viewing group details
- Searching for available groups
- Removing a tenant from a group

Using tenant groups

You can create a tenant group, which allows the tenants in the group access to the same data. A group can contain one table and one tenant, multiple tenants, or no tenants at all. You can add only regular tenants to a group.
If you prefer, you can, as an alternative, set up the group's properties, generate a group creation program based on those properties, and save the program so you can run it when you want. Generating the program alone does not create the group; you create the group when you run the generated program.

Guidelines for using groups

Keep in mind the following considerations as you work with tenant groups:

- When you initially create a group, the group has no tenants. You can take a table from an existing tenant's schema and add it to the group.
- You cannot add a tenant to a group if the tenant's partitions are already allocated.
- Once you assign a tenant to a group, that tenant can no longer access any data in the tenant's partition for the table partition associated with the group. In other words, the tenant can have only one partition for each given table.
- A tenant can belong to more than one group but cannot belong to two groups for the same table.
- Removing a tenant from a group restores the tenant's unique partition information for that table based on the defaults that are set up in the tenant record.

Creating a group or group program

You can create a group and then add one or more tenants to it.

1. Select **Database Administration > New > Group** in the management console.

   The **New Group** page appears.

2. Provide the following information:

   - **Group name** — The name of the group, which must be unique within the database. Do not use spaces or special characters such as an asterisk (*), ampersand (&), or period (.) in this field. You can include the underscore (_).
   
   - **Description** — An optional description of the group.

3. In the **Database connection** name, enter a database connection name to which you want to add the new group. By default, the last used database connection name appears in the **Database connection** field.

   **Note:** If you type the name of the database connection, follow the format used by OpenEdge Management/OpenEdge Explorer to define a connection: `adminServer-name.database-name`. A database server must be running for you to connect to the database.

   You can also click the **Search** icon to choose a database for which you are creating the tenant from the **Connection Selection** dialog.

   The **Connection Selection** dialog displays the connections details in a grid. You can perform the following:
Filter the connections in the grid by a Connection name, AdminServer, and/or Category.

Select the column heading and click the drop-down to choose the order (ascending or descending alphabetically) for the connections to appear in the grid.

4. Choose the Table you want to place in the group by either typing the table name or clicking the Search icon to select the table from the Table Selection dialog.

Note: There is one table per group and one or more tenants per group.

5. Select the default data area, default index area, and default LOB area. For each of the areas, you can either type the area name or click the Search icon to select the area from the Area Selection dialog.

The Area Selection dialog displays the storage area names in a grid. You can perform the following:

- Filter the storage area name in the grid by Area name, Records per block, and/or Cluster size.
- Move forward or backward a page, or specify a particular page, in the list of domains by using the Page feature at the bottom of the list.
- Select the column heading and click the drop-down to choose the order (ascending or descending alphabetically) for the area names to appear in the grid.

6. On the Partitions tab, select an item in the table schema to view its properties, which include name, type, area, buffer pool assignment, and allocation state.

7. Set the area for each partition individually by clicking the Search icon and choosing an area from the list.

8. Select a buffer pool assignment of Primary or Alternate.

9. To modify the allocation state, choose from either of the options.

10. You can perform the following actions:

- To add one or more tenants to the group and then create the group immediately:
  1. Click the Tenants tab.
  2. Click Add Tenant.
  3. From the list of tenants that appears, select one or more tenants.
  4. Click OK. The newly added tenants are listed as belonging to the group.
  5. Click Save to save the group. If the partition in the group has already been allocated for a newly added tenant, an error message appears and the group is not created.

- To save the group without adding tenants:
  1. Click Save.
  2. Click Yes to the message confirming that the group has no tenants.

11. To create a group creation script, click Generate group program.

12. From the list of groups, click Refresh. The new group appears in the list of groups.
Editing a group

You can make changes to a group; for example, you can edit the existing group details, add tenants, add partitions, or rename a group (when the group has tenants as members).

To edit a group:

1. Click **Database Administration > Go to Database Administration** in the OpenEdge Management console menu.
   The **Database Administration** page appears.
2. Filter or search for, and select the required database connection.
   The database connection home page appears.
3. Under **Storage Management**, click **View groups**.
4. Select the group you want to edit. The group details page appears.
5. In the **Group name** field, replace the existing group name with a new group name.
6. Modify the description of the group (optional).
7. To make partition changes, select a table in the schema on the **Partitions** tab. Then:
   - Click the **Area** drop-down arrow if you want to choose a different area.
   - Click the **Buffer pool** drop-down to change from **Primary** to **Alternate**, or vice versa.
   - To change the allocation state, select the appropriate option.
8. To add a new tenant, click **Tenants** and then click **Add Tenant**. Click **Remove** to remove an existing tenant from the group.
9. Click **Save** to save the changes.

Adding a tenant to a group

You can add a tenant to a group as long as the partition in the group has not already been allocated as a partition for the same table for the tenant.

For more details about adding a tenant to a group, see **Guidelines for using groups** on page 108.

You can add a tenant to a group in two ways:

- From the tenant
- From the group

Adding a tenant to a group from the tenant

To add a tenant to a group from the tenant:

1. Click **Database Administration > Go to Database Administration** in the OpenEdge Management console menu.
   The **Database Administration** page appears.
2. Filter or search for, and select the required database connection.
   The database connection home page appears.
3. Click View tenants in the Storage Management section.
   The Tenant List page appears.
4. Select a tenant you want to add to a group.
   The tenant details page appears.
5. Click Edit tenant in the Manage Tenant section.
   The Edit Tenant page appears.
6. Click the Groups tab.
7. From the tenant menu bar, click Add Group. The Group Selection dialog appears.
   The Group Selection dialog displays the groups for the selected tenant in a grid. You can perform the following:
   • Filter the groups in the grid by Group name and/or Table name.
   • Move forward or backward a page, or specify a particular page, in the list of tables by using the Page feature at the bottom of the list.
   • Select the column heading and click the drop-down to choose the order (ascending or descending alphabetically) for the groups to appear in the grid.
8. From the list of available groups, select the group you want and click OK. The group name and group title appear for the tenant.
9. Click Commit.

Adding a tenant to a group from the group
To add a tenant to a group from the group:
1. Click Database Administration > Go to Database Administration in the OpenEdge Management console menu.
   The Database Administration page appears.
2. Filter or search for, and select the required database connection.
   The database connection home page appears.
3. Click View groups in the Storage Management section.
   The Group List page appears.
4. Select a group using which you want to add a tenant to a group. The group details page appears.
5. Click Tenants > Add Tenant at the bottom of the page.
6. Select one or more tenants, or click Select All check box to select all the tenants you want to add to the group.
7. Click OK. The names of the tenants appear.
8. Click Save.
   If the partition in the group has already been allocated for a selected tenant, an error message appears and the group is not created.
   If the partition has not yet been allocated, the group is created with the selected tenants.
Chapter 9: Working with tenant groups

### Viewing a list of tenant groups

You can view a list of tenant groups that exist for a multi-tenant database.

To view a list of groups:

1. Click **Database Administration > Go to Database Administration** in the OpenEdge Management console menu.
   
   The **Database Administration** page appears.

2. Filter or search for, and select the required database connection.

   The database connection home page appears.

3. Under **Storage Management**, click **View groups**. A list of groups defined for the selected database appears.

### Viewing group details

You can view details about an existing group.

To view a group's details:

1. Click **Database Administration > Go to Database Administration** in the OpenEdge Management console menu.

   The **Database Administration** page appears.

2. Filter or search for, and select the required database connection.

   The database connection home page appears.

3. Under **Storage Management**, click **View groups**. A list of groups defined for the selected database appears.

4. Select the group for which you want to view details.

### Searching for available groups

You can search for a particular tenant group.

To search for a group:

1. Click **Database Administration > Go to Database Administration** in the OpenEdge Management console menu.

   The **Database Administration** page appears.

2. Filter or search for, and select the required database connection.

   The database connection home page appears.
3. Under **Storage Management**, click **View groups**. A list of groups defined for the selected database appears.

4. Type the name of the group you are searching for in the **Search groups** field. The list of groups appear.

### Removing a tenant from a group

You can remove a tenant from a group. If you later change your mind, you can restore the tenant to the group.

You can remove the tenant from either the tenant itself or from the group.

### Removing a tenant from a group using the tenant

To remove a tenant from a group **using the tenant**:

1. Click **Database Administration** > **Go to Database Administration** in the OpenEdge Management console menu.
   
   The **Database Administration** page appears.

2. Filter or search for, and select the required database connection.
   
   The database connection home page appears.

3. Under **Storage Management**, click **View tenants**.

4. Select a tenant using which you want to remove a tenant to a group. The tenant details page appears.

5. Under **Manage Tenant**, click **Edit tenant**. The **Edit tenant** page appears.

6. Click **Groups**.

7. Select the group name, and click **Remove**.

To restore the tenant to the group, click **Restore**.

### Removing a tenant from a group using the group

To remove a tenant from a group **using the group**:

1. Click **Database Administration** > **Go to Database Administration** in the OpenEdge Management console menu.
   
   The **Database Administration** page appears.

2. Filter or search for, and select the required database connection.
   
   The database connection home page appears.

3. Under **Storage Management**, click **View groups**.

4. Select the group from which you want to remove a tenant. The group details page appears.

5. Click the **Tenants** tab.

6. Select the tenant, and click **Remove**.
Index

A
Allocation 22
Area working set 74
Areas
viewing 50
Authentication systems 84

B
Buffer pool 57

C
Color legend 53
Comitting changes 75
Configuration
  database connections 25
  for remote hosts 26
Connections
  configuring for a database 25

D
Data Definition file
  loading 37, 71
  preview 72
Database Administration Console
  features 20
  working with 20
Database connections
  configuring 25
  setting up 27
Databases
  adding domains 82
  adding users 80
  connection details 34
  deleting domains 84
  deleting users 81
  Dumping data from groups 47
  Dumping data from tables 43
  dumping group contents 47
  dumping table contents 43
  enabling for multi-tenancy 33
  features 35
  filtering domains 82
  Loading data to groups 41
  Loading data to tables 37
  loading group contents 41
  loading table contents 38
  managing multi-tenant 33
  Databases (continued)
    modifying domains 83
    modifying users 81
    security summary 35
    table security for users 85
    viewing domains 82
  Deallocating tenant tables 69
  Default tenant 22
  Disabling access to tenant data 67
  Domains
    adding for a tenant 61
    adding to databases 83
    deleting 84
    filtering database 82
    modifying database 83
    viewing 50–51
    viewing database 82
  Dumping database contents 43

E
editgroup 110
Enabling access to tenant data 67
Enhancements
  Database Administration Console 20
Exporting sequences 101, 104–105

F
Filtering
  tenant partitions 51–52

G
Group Contents
  dumping 47
  Loading 41
Group program
  creating 108
Groups
  adding tenants 110–111
  creating 108
  guidelines for using 108
  removing tenants from 113
  searching for 112
  viewing details 112
  viewing in a list 112
  working with 107
L
Loading a data definition file 37, 71
Loading database contents 37

M
Managed database 25
Managing multi-tenant databases 33
Multi-tenancy
 allocation 22
areas 22
common terminology 22
enabling databases for 33
enabling tables for 66
groups 22
partitions 22
tenants 22
tuning performance 49
Multi-tenancy tasks viewlet 77

P
Partitions
 allocating tenant 56
filtering 51
Permissions
 reviewing for users 87
user 85

R
Regular tenant 22
Remote configuration requirements 26

S
Schema
 updating 71
uploading new 71
viewing 50
Scripted database 25
Security
 for database table users 85
Security administrators 31, 88
Security summary 35
Sequences
 creating multi-tenant 101
details 36
editing values 102–103
exporting current values 101
exporting for a tenant 104
functionality and user credentials 100
loading data definition file of 101
restoring values 104

Sequences (continued)
types 99
values 99
viewing list of 101
working with 99
Storage area assignments 75
Super-tenant 22

T
Table Contents
dumping 43
loading 38
Tables
deallocating 69–70
enabling for multi-tenancy 64
Tenant
creating 57
Tenant configuration program 57
Tenant program
creating 57
Tenant templates
 allocation considerations 94
creating 94
creating tenant from 97
ingiving 97
filtering partitions 96
using 93
viewing in a list 96
working with 93
Tenants
adding domains 61
adding users 62
creating 56
deleting 64
editing 60
enabling or disabling data access for 67
removing from groups 113
viewing 51
working with 55
Terminology
 multi-tenancy 22

U
Ungluing from OpenEdge 26
Unmanaged database connection 25
User credentials
 for database connection 27
Users
 adding to a database 80
adding to a tenant 62
database table security 85
deleting from a database 81
modifying for a database 81
modifying in a database 81
Users (continued)
  reviewing permissions 87
  viewing 51

V
  Viewing
  multi-tenant areas, domains, schemas, tenants, groups 50