Progress® software products are copyrighted and all rights are reserved by Progress Software Corporation. This manual is also copyrighted and all rights are reserved. This manual may not, in whole or in part, be copied, photocopied, translated, or reduced to any electronic medium or machine-readable form without prior consent, in writing, from Progress Software Corporation.

The information in this manual is subject to change without notice, and Progress Software Corporation assumes no responsibility for any errors that may appear in this document.

The references in this manual to specific platforms supported are subject to change.

Third party acknowledgements — See the “Third party acknowledgements” section on page Preface–5.

February 2008

Last updated with new content: Release 10.0A

Product Code: 4496; R10.1C

For the latest documentation updates see the OpenEdge Product Documentation category on PSDN (http://www.psdn.com/library/kbcategory.jspa?categoryID=129).
Contents

Preface ........................................................................................................ Preface–1

1. Overview ............................................................................................... 1–1
   Tool overview ....................................................................................... 1–2
   Task overview ...................................................................................... 1–3

2. Getting Started ....................................................................................... 2–1
   Setting up your environment ................................................................. 2–2
   Starting the Visual Translator ............................................................... 2–2
   Using online help .................................................................................. 2–3
   Installing and opening a kit .................................................................... 2–4
       Installing a Kit .................................................................................... 2–5
       Opening a kit in single-user mode ...................................................... 2–6
   Opening a kit in multi-user mode ......................................................... 2–6
   Returning a kit ....................................................................................... 2–7
   Importing a glossary ............................................................................. 2–8
   Exporting a glossary ............................................................................. 2–11

3. Translating .............................................................................................. 3–1
   Overview ............................................................................................... 3–2
   Pretranslation ....................................................................................... 3–2
   Translating screen by screen ............................................................... 3–6
       Opening a resource procedure ......................................................... 3–6
       Opening the Properties window ....................................................... 3–8
       Selecting an object ............................................................................ 3–9
       Entering a translation ....................................................................... 3–10
Contents

Translating phrase by phrase ................................................. 3–11
  Opening the Translations tab folder .................................. 3–12
  Opening the glossary window ........................................... 3–14
  Entering a translation .................................................... 3–15
  Global translation ......................................................... 3–16
Translation considerations .................................................. 3–18
  Punctuation ................................................................. 3–18
  Accelerator keys ........................................................ 3–18

4. Tracking Your Work ......................................................... 4–1
  Checking status ........................................................... 4–2
    Procedure status ....................................................... 4–2
    Kit status ................................................................ 4–2
  Finding untranslated text phrases ...................................... 4–2
  Monitoring the glossary ................................................... 4–4
  Printing screen captures ................................................... 4–5
  Printing a statistics report ............................................... 4–5

5. Troubleshooting ............................................................... 5–1

A. Visual Translator Interface Reference ................................. A–1
  The main window ......................................................... A–2
    Main window tab folders ............................................. A–2
    Main window menu bar and tool bar .............................. A–7
  Properties window menu options and buttons .................... A–11

Index .............................................................................. Index–1
Figures

Figure 3–1: Properties dialog box . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3–8
Figure 3–2: Long String Translator dialog box . . . . . . . . . . . . . . . . . . . . . . . . 3–15
Figure A–1: Visual Translator tab folders . . . . . . . . . . . . . . . . . . . . . . . . . . A–2
Figure A–2: Procedures tab folder . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . A–3
Figure A–3: Translations tab folder . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . A–4
Figure A–4: Glossary tab folder . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . A–5
Figure A–5: Statistics tab folder . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . A–6
Figure A–6: Visual Translator menu bar . . . . . . . . . . . . . . . . . . . . . . . . . . . A–7
Figure A–7: Visual Translator tool bar . . . . . . . . . . . . . . . . . . . . . . . . . . . . A–10
Tables

Table 2–1: Example imported glossaries ...................................................... 2–9
Table 4–1: Example glossary entries ............................................................ 4–4
Table A–1: Main window menu options and tool bar buttons ...................... A–8
Table A–2: Properties window buttons ....................................................... A–11
Table A–3: Properties window menu options .............................................. A–12
Preface

This Preface contains the following sections:

• Purpose
• Audience
• Organization
• Using this manual
• Typographical conventions
• OpenEdge messages
• Third party acknowledgements
Purpose

This manual describes how to use the OpenEdge™ Visual Translator tool to translate text phrases in Progress 4GL procedures.

Audience

This book is written for the translator—the person who translates the user-interface text phrases, such as labels and messages, from the source language to a target language. The translator must have some experience with personal computers and Microsoft Windows, but might have little or no experience with application development or the procedures in the translation project.

Organization

Chapter 1, “Overview”

Describes the Visual Translator tool and provides an overview of how you can use the Visual Translator to translate the text phrases in a Progress 4GL application.

Chapter 2, “Getting Started”

Describes how to start the Visual Translator; use online help; load, open, and return a language kit; and import your own glossary.

Chapter 3, “Translating”


Chapter 4, “Tracking Your Work”

Describes how to use the Visual Translator to check the status of translations, find untranslated text phrases, monitor glossaries, and print screen captures.
Chapter 5, “Troubleshooting”

Provides answers to some common questions.

Appendix A, “Visual Translator Interface Reference”

Provides reference information for the Visual Translator tool tab folders, menu bar, and tool bar for the main window and the Properties window.

Using this manual

This book is a guide to using the Visual Translator tool. Although you can use it as a reference, it is structured so that each chapter builds on the previous chapters. Therefore, you will learn the most if you start at Chapter 1 and read through until the end.

Chapter 1 provides an overview of concepts and how the Visual Translator works with the Translation Manager tool. Subsequent chapters are task based—providing detailed instructions on how to use the Visual Translator tool. The Appendix contains reference information.

For the latest documentation updates see the OpenEdge Product Documentation category on PSDN http://www.psdn.com/library/kbcategory.jspa?categoryID=129.

Typographical conventions

This manual uses the following typographical conventions:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Bold typeface indicates commands or characters the user types, or the names of user interface elements.</td>
</tr>
<tr>
<td><em>Italic</em></td>
<td>Italic typeface indicates the title of a document, provides emphasis, or signifies new terms.</td>
</tr>
<tr>
<td><strong>SMALL, BOLD CAPITAL LETTERS</strong></td>
<td>Small, bold capital letters indicate OpenEdge™ key functions and generic keyboard keys; for example, <strong>GET</strong> and <strong>CTRL</strong>.</td>
</tr>
</tbody>
</table>
### Conventions

<table>
<thead>
<tr>
<th>Convention</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>KEY1-KEY2</td>
<td>A hyphen between key names indicates a <em>simultaneous</em> key sequence: you press and hold down the first key while pressing the second key. For example, <code>CTRL-X</code>.</td>
</tr>
<tr>
<td>KEY1 KEY2</td>
<td>A space between key names indicates a <em>sequential</em> key sequence: you press and release the first key, then press another key. For example, <code>ESCAPE H</code>.</td>
</tr>
</tbody>
</table>

**Syntax:**

<table>
<thead>
<tr>
<th>Fixed width</th>
<th>A fixed-width font is used in syntax statements, code examples, and for system output and filenames.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixed-width italics</td>
<td>Fixed-width italics indicate variables in syntax statements.</td>
</tr>
<tr>
<td>Fixed-width bold</td>
<td>Fixed-width bold indicates variables with special emphasis.</td>
</tr>
<tr>
<td>UPPERCASE fixed width</td>
<td>Uppercase words are Progress® 4GL language keywords. Although these always are shown in uppercase, you can type them in either uppercase or lowercase in a procedure.</td>
</tr>
</tbody>
</table>

---

**OpenEdge messages**

OpenEdge displays several types of messages to inform you of routine and unusual occurrences:

- **Execution messages** inform you of errors encountered while OpenEdge is running a procedure; for example, if OpenEdge cannot find a record with a specified index field value.

- **Compile messages** inform you of errors found while OpenEdge is reading and analyzing a procedure before running it; for example, if a procedure references a table name that is not defined in the database.

- **Startup messages** inform you of unusual conditions detected while OpenEdge is getting ready to execute; for example, if you entered an invalid startup parameter.
After displaying a message, OpenEdge proceeds in one of several ways:

- Continues execution, subject to the error-processing actions that you specify or that are assumed as part of the procedure. This is the most common action taken after execution messages.
- Returns to the OpenEdge Procedure Editor, so you can correct an error in a procedure. This is the usual action taken after compiler messages.
- Halts processing of a procedure and returns immediately to the Procedure Editor. This does not happen often.
- Terminates the current session.

OpenEdge messages end with a message number in parentheses. In this example, the message number is 200:

```
** Unknown table name table. (200)
```

If you encounter an error that terminates OpenEdge, note the message number before restarting.

**Obtaining more information about OpenEdge messages**

On Windows platforms, use OpenEdge online help to obtain more information about OpenEdge messages. Many OpenEdge tools include the following Help menu options to provide information about messages:

- Choose Help→Recent Messages to display detailed descriptions of the most recent OpenEdge message and all other messages returned in the current session.
- Choose Help→Messages and then enter the message number to display a description of a specific OpenEdge message.
- In the Procedure Editor, press the help key (F2 or CTRL-W).

**Third party acknowledgements**

OpenEdge includes Imaging Technology copyrighted by Snowbound Software 1993-2003.

OpenEdge includes software developed by the Apache Software Foundation
(http://www.apache.org/). Copyright © 1999 The Apache Software Foundation. All rights reserved (Xerces C++ Parser (XML) and Xerces2 Java Parser (XML)); Copyright © 1999-2002 The Apache Software Foundation. All rights reserved (Xerces Parser (XML)); and Copyright © 2000-2003 The Apache Software Foundation. All rights reserved (Ant). The names “Apache,” “Xerces,” “ANT,” and “Apache Software Foundation” must not be used to endorse or promote products derived from this software without prior written permission. Products derived from this software may not be called “Apache”, nor may “Apache” appear in their name, without prior written permission of the Apache Software Foundation. For written permission, please contact apache@apache.org. Software distributed on an “AS IS” basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License for the specific language governing rights and limitations under the License agreement that accompanies the product.


OpenEdge includes software developed by Vermont Creative Software. Copyright © 1988-1991 by Vermont Creative Software.

OpenEdge includes code licensed from RSA Security, Inc. Some portions licensed from IBM are available at http://oss.software.ibm.com/icu4j/.

OpenEdge includes the UnixWare platform of Perl Runtime authored by Kiem-Phong Vo and David Korn. Copyright © 1991, 1996 by AT&T Labs. Permission to use, copy, modify, and distribute this software for any purpose without fee is hereby granted, provided that this entire notice is included in all copies of any software which is or includes a copy or modification of this software and in all copies of the supporting documentation for such software. THIS SOFTWARE IS BEING PROVIDED “AS IS”, WITHOUT ANY EXPRESS OR IMPLIED WARRANTY. IN PARTICULAR, NEITHER THE AUTHORS NOR AT&T LABS MAKE ANY REPRESENTATION OR WARRANTY OF ANY KIND CONCERNING THE MERCHANTABILITY OF THIS SOFTWARE OR ITS FITNESS FOR ANY PARTICULAR PURPOSE.

OpenEdge includes the RSA Data Security, Inc. MD5 Message-Digest Algorithm. Copyright ©1991-2, RSA Data Security, Inc. Created 1991. All rights reserved.

OpenEdge includes software developed by the World Wide Web Consortium. Copyright © 1994-2002 World Wide Web Consortium, (Massachusetts Institute of Technology, European Research Consortium for Informatics and Mathematics, Keio University). All rights reserved. This work is distributed under the W3C® Software License [http://www.w3.org/Consortium/Legal/2002/copyright-software-20021231] in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
OpenEdge includes Sonic software, which includes software developed by Apache Software Foundation (http://www.apache.org/). Copyright © 1999-2000 The Apache Software Foundation. All rights reserved. The names "Ant", "Axis", "Xalan," "FOP," "The Jakarta Project", "Tomcat", "Xerces" and/or "Apache Software Foundation" must not be used to endorse or promote products derived from the Product without prior written permission. Any product derived from the Product may not be called "Apache", nor may "Apache" appear in their name, without prior written permission. For written permission, please contact apache@apache.org.

OpenEdge includes Sonic software, which includes the JMX Technology from Sun Microsystems, Inc. Use and Distribution is subject to the Sun Community Source License available at http://sun.com/software/communitysource.

OpenEdge includes Sonic software, which includes software developed by the ModelObjects Group (http://www.modelobjects.com). Copyright © 2000-2001 ModelObjects Group. All rights reserved. The name “ModelObjects” must not be used to endorse or promote products derived from this software without prior written permission. Products derived from this software may not be called “ModelObjects”, nor may “ModelObjects” appear in their name, without prior written permission. For written permission, please contact djacobs@modelobjects.com.

OpenEdge includes Sonic software, which includes files that are subject to the Netscape Public License Version 1.1 (the “License”); you may not use this file except in compliance with the License. You may obtain a copy of the License at http://www.mozilla.org/NPL/. Software distributed under the License is distributed on an “AS IS” basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License for the specific language governing rights and limitations under the License. The Original Code is Mozilla Communicator client code, released March 31, 1998. The Initial Developer of the Original Code is Netscape Communications Corporation. Portions created by Netscape are Copyright © 1998-1999 Netscape Communications Corporation. All Rights Reserved.

OpenEdge includes software Copyright © 2003-2006, Terence Parr All rights reserved. Neither the name of the author nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission. Software distributed on an "AS IS" basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License for the specific language governing rights and limitations under the License agreement that accompanies the product.

OpenEdge includes ICU software 1.8 and later - Copyright © 1995-2003 International Business Machines Corporation and others All rights reserved. Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, and/or sell copies of the Software, and to permit
persons to whom the Software is furnished to do so, provided that the above copyright notice(s)
and this permission notice appear in all copies of the Software and that both the above copyright
notice(s) and this permission notice appear in supporting documentation.

OpenEdge includes software developed by the OpenSSL Project for use in the OpenSSL
Toolkit (http://www.openssl.org/). Copyright © 1998-2007 The OpenSSL Project. All
rights reserved. This product includes cryptographic software written by Eric Young
eay@cryptsoft.com). This product includes software written by Tim Hudson
tjh@cryptsoft.com). Copyright © 1995-1998 Eric Young (eay@cryptsoft.com) All rights
reserved. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to endorse
or promote products derived from this software without prior written permission. For written
permission, please contact openssl-core@openssl.org. Products derived from this software may
not be called "OpenSSL" nor may "OpenSSL" appear in their names without prior written
permission of the OpenSSL Project. Software distributed on an "AS IS" basis, WITHOUT
WARRANTY OF ANY KIND, either express or implied. See the License for the specific
language governing rights and limitations under the License agreement that accompanies the
product.

OpenEdge includes Sonic software which includes a version of the Saxon XSLT and XQuery
Processor from Saxonica Limited that has been modified by Progress Software Corporation.
The contents of the Saxon source code and the modified source code file (Configuration.java)
are subject to the Mozilla Public License Version 1.0 (the “License”); you may not use these
files except in compliance with the License. You may obtain a copy of the License at
http://www.mozilla.org/MPL/ and a copy of the license (MPL-1.0.html) can also be found
in the installation directory, in the Docs7.5/third_party_licenses folder, along with a copy of the
modified code (Configuration.java); and a description of the modifications can be found in the
Progress SonicMQ and Progress Sonic ESB v7.5 README files. Software distributed under
the License is distributed on an “AS IS” basis, WITHOUT WARRANTY OF ANY KIND,
either express or implied. See the License for the specific language governing rights and
limitations under the License. The Original Code is The SAXON XSLT and XQuery Processor
from Saxonica Limited. The Initial Developer of the Original Code is Michael Kay
http://www.saxonica.com/products.html). Portions created by Michael Kay are Copyright
© 2001-2005. All rights reserved. Portions created by Progress Software Corporation are
Copyright © 2007. All rights reserved.

OpenEdge includes software developed by IBM. Copyright © 1995-2003 International
Business Machines Corporation and others. All rights reserved. Permission is hereby granted,
free of charge, to any person obtaining a copy of this software and associated documentation
files (the "Software"), to deal in the Software without restriction, including without limitation
the rights to use, copy, modify, publish, distribute, and/or sell copies of the Software,
and to permit persons to whom the Software is furnished to do so, provided that the above
copyright notice(s) and this permission notice appear in all copies of the Software and that both
the above copyright notice(s) and this permission notice appear in supporting documentation.
Software distributed on an "AS IS" basis, WITHOUT WARRANTY OF ANY KIND, either
express or implied. See the License for the specific language governing rights and limitations
under the License agreement that accompanies the product. Except as contained in this notice,
the name of a copyright holder shall not be used in advertising or otherwise to promote the sale,
use or other dealings in this Software without prior written authorization of the copyright holder.
OpenEdge includes Sonic software, which includes software developed by ExoLab Project
(http://www.exolab.org/). Copyright © 2000 Intalio Inc. All rights reserved. The names
“Castor” and/or “ExoLab” must not be used to endorse or promote products derived from the
Products without prior written permission. For written permission, please contact
info@exolab.org. Exolab, Castor and Intalio are trademarks of Intalio Inc.

OpenEdge includes Sonic software, which includes software Copyright © 1999 CERN -
European Organization for Nuclear Research. Permission to use, copy, modify, distribute and
sell this software and its documentation for any purpose is hereby granted without fee, provided
that the above copyright notice appear in all copies and that both that copyright notice and this
permission notice appear in supporting documentation. CERN makes no representations about
the suitability of this software for any purpose. It is provided "as is" without expressed or
implied warranty.

OpenEdge includes Sonic software, which includes software developed by the University
Corporation for Advanced Internet Development http://www.ucaid.edu Internet2 Project.
Copyright © 2002 University Corporation for Advanced Internet Development, Inc. All rights
reserved. Neither the name of OpenSAML nor the names of its contributors, nor Internet2, nor
the University Corporation for Advanced Internet Development, Inc., nor UCAID may be used
to endorse or promote products derived from this software and products derived from this
software may not be called OpenSAML, Internet2, UCAID, or the University Corporation for
Advanced Internet Development, nor may OpenSAML appear in their name without prior
written permission of the University Corporation for Advanced Internet Development. For
written permission, please contact opensaml@opensaml.org.

OpenEdge includes DataDirect products for the Microsoft SQL Server database which contains
a licensed implementation of the Microsoft TDS Protocol.

OpenEdge includes Sonic software, which includes code licensed from Mort Bay Consulting
Pty. Ltd. The Jetty Package is Copyright © 1998 Mort Bay Consulting Pty. Ltd. (Australia) and
others.
Overview

This chapter provides a brief overview of the Visual Translator tool and the tasks you can perform with it. The chapter includes these sections:

- Tool overview
- Task overview

The following chapters provide detailed, step-by-step instructions.
Tool overview

The Visual Translator is a tool that helps you translate the text phrases in Progress® 4GL applications. The Visual Translator allows you to:

- **Translate screen by screen** — You can view the user interface for procedures, translate user-interface objects in context, and immediately see how your translations will appear on the screen.

- **Translate phrase by phrase** — You can select and translate a single text phrase from a list of text phrases.

- **Translate globally** — You can make global translations. For example, you can translate all instances of the text phrase “close” to “cerrar.” You can then view a particular instance of the global translation on the screen.

- **Have multiple translators** — You can choose to work in multi-user mode and have more than one translator working on the same project.

- **Use your own glossaries** — You can add your own glossary entries to the glossary provided by the *project manager*—the person who hires you to translate the procedures.

- **Save a screen capture** — You can save and print a copy of a user-interface window showing your translations in context.
Task overview

The following steps outline the basic tasks you perform when you use the Visual Translator to translate text phrases from Progress 4GL procedures:

1. Install and open the kit you receive from the project manager—the person who hires you to translate the text phrases in an application.

   The kit contains:

   - A 4GL database that includes a glossary and the text phrases to translate. The glossary is a list of the pairings of words for two spoken languages—the source and target language. The source language is the language in which the source code was written. The target language is the language to which you translate the source code. You can import your own existing glossary entries into the kit’s glossary if the project manager has given you the appropriate permission.

   - Resource procedures, which are shells or “mock-ups” of the original application source procedures; they do not contain any functionality. You use these shells to display the visual aspects of a procedure’s user interface so that you can see the results of your translation in context.

   - An environment (.ini) file and image files that allow the Visual Translator to accurately display the user interface of the procedure.

   The project manager sends you a kit for each target language. You can open several kits simultaneously.

2. Select each procedure and the text phrases for all procedures globally or phrase by phrase from a list.

3. When you have translated all the necessary text phrases, save the kit into a compressed (.zip) file and return it to the project manager.

The project manager reviews the translations and might return them to you for further modification. If the translations are complete, the project manager uses them to deploy a multi-lingual application.
Getting Started

This chapter explains how to get started with the Visual Translator tool. Specifically, it describes:

- Setting up your environment
- Starting the Visual Translator
- Using online help
- Installing and opening a kit
- Opening a kit in multi-user mode
- Returning a kit
- Importing a glossary
- Exporting a glossary
Setting up your environment

Before beginning, you need to prepare your computer to assure the process works correctly.

To set up the working environment:

1. Create a working directory for the kit on your hard drive.
2. Copy the kit (.db or .zip file) you received from the project manager to the directory you created for the kit.
3. Change the working directory of the OpenEdge icon to the directory you created for the kit. To change the properties for an icon, follow these steps:
   b. Click once to highlight the OpenEdge icon.
   c. Choose File → Properties.
   d. Choose the Shortcut tab folder.
   e. In the Start in field, enter the name of the directory you created for the kit in Step 1.
   f. Choose OK.

Starting the Visual Translator

You must first install a copy of OpenEdge™ that includes the Visual Translator tool before you can start the tool. See OpenEdge Getting Started: Installation and Configuration for information on system requirements and installation.

To start the Visual Translator tool:

1. Double-click the OpenEdge icon to display the Application Development Environment desktop (ADE).
2. Choose Tools→Visual Translator. The Visual Translator window appears:


Using online help

The Visual Translator has an extensive help system that provides information about the interface and simple procedures that tell you how to use the tool to perform tasks.

All help information is organized into discrete units called help topics. A help topic typically contains information about one thing, such as a dialog box or a button in a tab folder.

You can access help information in the following ways:

- Press HELP (the F1 key, by default).
- Use the Help menu.
- Click the Help button then click a button or tab folder.
The help system is hypertext based, that is, help topics not only contain information, but they also provide access to related information. Certain words and phrases in a help topic are selectable and serve as links to related information. These special words and phrases are called **hypertext links**. Help displays hypertext links in color or underlined, depending on your monitor. To access the information associated with a hypertext link, click the hypertext-link word or phrase.

In addition to the help system, interface buttons display ToolTips to assist you with button selection.

## Installing and opening a kit

After you start the Visual Translator, your next step is to install or open the kit that you received from the project manager. The project manager will send you a separate kit for each target language.

You **install** a kit if the project manager sends you the kit as a compressed (.zip) file. The project manager might compress a kit to reduce the size of the database and make it easier to send. When you install a kit, the Visual Translator decompresses it. Therefore, you have to install a kit only when you first receive it from the project manager. After you install a kit, you can close and open it until you have completed translating.

You **open** a kit once you have initially installed it. If the project manager did not compress the kit, you can open it without first installing it. When you open a kit, the Visual Translator connects to the kit database.

The Visual Translator saves any changes as soon as you make them. To close an uncompressed kit, choose **File→Close**. The Visual Translator disconnects the kit database. Choose **File→Return Kit** only when you want to compress the kit before you return it.
Installing a Kit

Next, you need to get the kit onto your computer.

To install a kit on your computer:

1. Choose File→Install Kit. The Install Zip File dialog box appears:

2. In the Project Directory field, type the pathname of the working directory you created for the kit in the “Setting up your environment” section on page 2–2.

3. In the Zip Filename field, enter the name of the kit (.zip) file, then choose OK. The Visual Translator automatically installs and then opens the kit.

After you install and open a kit, you can import a glossary (see the “Importing a glossary” section on page 2–8) or you can start translating procedures right away (see Chapter 3, “Translating”).
Opening a kit in single-user mode

The simplest way to work with a kit is to open it in single-user mode.

To open a decompressed kit or a previously installed kit:

1. Choose the Open button. The Open Kit Database dialog box appears:

2. Select the directory that contains the kit.

3. Select the database (.db) file that contains the kit you want, then choose OK. The Visual Translator displays the names of the application procedure (usually .p and .w) files contained in the kit in the Procedures tab folder.

After you open a kit, you can import a glossary (see the “Importing a glossary” section on page 2–8) or you can start translating procedures (see Chapter 3, “Translating”).

Opening a kit in multi-user mode

To work in multi-user mode, you must start a database server for the kit database. It is easiest if the kit database is created on a system and not moved, but it is possible to relocate the kit by zipping it up, moving the zip file, and unzipping it.

See the OpenEdge Data Management: Database Administration for information on starting up a database server. Use the Progress Explorer or issue the proserve command from a DOS prompt. Typically, no startup parameters are necessary except for the database name, -S (service), and -H (host), and these three are mandatory.
To connect to the kit database in multi-user mode:

1. Start Visual Translator and choose File→Open Multi-User. The Open Multi-User Kit Database dialog box appears:

2. Select the name of the kit database that has a server running. Use the Browse button to find the database.

3. In the Host Name box enter the name of the computer hosting the database.

4. In the Service Name box enter the port of the database server.

5. Enter the translator’s User ID if the kit is password protected.

6. Enter the translator’s Password if the kit is password protected.

7. Enter Other CONNECT Statement Parameters as necessary and choose OK.

When you have filled in the appropriate values, proceed as if in single-user mode.

Returning a kit

When your work is complete, you need to recompress the files into the .zip file.

To compress a kit after translation is complete:


2. Enter the name of the kit database with a .zip extension, then click OK. The Visual Translator compresses the kit database into a zip file.
3. Send the zip file back to the project manager. You can send it over a modem or on a diskette.

**Note:** The tool saves any changes as soon as you make them. Choose **File→Return Kit** only when you want to compress the kit.

---

**Importing a glossary**

A *glossary* is a list of the pairings of phrases for two spoken languages. The kit the project manager gives you includes a default glossary. The *default glossary* might be empty or it might contain a list of suggested pairings to use.

If you already have your own glossary, you can add its contents to the default glossary and use it in the Visual Translator. The tool tags the imported glossary entries with a C (for Custom) in the Type column of the Glossaries tab folder. When you enter your new translations, the Visual Translator adds new custom entries to the glossary.

To make sure you have permission to import a glossary, choose **Options→Preferences**. The **Preferences** dialog box displays the privileges the project manager assigned to you. If the **Must Use Glossary For Translations** toggle box is activated, you cannot import a glossary.

The **Translator Privileges** section is grayed out to show that it is disabled and you cannot change it. The project manager sets privileges with the Translation Manager tool.

The glossary data you want to import must be in a text file, with the source and target phrases separated by commas or spaces.
Table 2–1 shows examples of comma-delimited and space-delimited glossaries. In both examples the glossaries order the text phrases by source language (English).

### Table 2–1: Example imported glossaries

<table>
<thead>
<tr>
<th>Comma-delimited</th>
<th>Space-delimited</th>
</tr>
</thead>
<tbody>
<tr>
<td>add, ajouter</td>
<td>add ajouter</td>
</tr>
<tr>
<td>application, programme</td>
<td>application programme</td>
</tr>
<tr>
<td>apply, appliquer</td>
<td>apply appliquer</td>
</tr>
<tr>
<td>blank space, espace</td>
<td>&quot;blank space&quot; &quot;espace&quot;</td>
</tr>
<tr>
<td>browse, parcourir</td>
<td>browse parcourir</td>
</tr>
<tr>
<td>cancel, annuler</td>
<td>cancel annuler</td>
</tr>
<tr>
<td>capitalize, mettre en majuscules</td>
<td>&quot;capitalize&quot; &quot;mettre en majuscules&quot;</td>
</tr>
<tr>
<td>change, modifier</td>
<td>change modifier</td>
</tr>
<tr>
<td>chart, graphique</td>
<td>chart graphique</td>
</tr>
<tr>
<td>check, cocher</td>
<td>check cocher</td>
</tr>
<tr>
<td>choose, choisir</td>
<td>choose choisir</td>
</tr>
<tr>
<td>click, cliquer</td>
<td>click cliquer</td>
</tr>
<tr>
<td>&quot;city, state&quot;, &quot;ville, department&quot;</td>
<td>&quot;city, state&quot; &quot;ville, department&quot;</td>
</tr>
</tbody>
</table>

You must use quotes in an imported glossary under the following circumstances:

- If you have a comma-delimited glossary and you want to include a comma as part of the text, you must use quotes around the text. For example, to include the comma in an address, you must use quotes:

  "street, city", "calle, ciudad"

- If you have a space-delimited glossary and you want to include a phrase that has more than one word, you must use quotes around the text:

  "capitalize" "mettre en majuscules"
To import glossary entries from a file to a glossary in the project database:

1. Choose the Glossaries tab to open the Glossaries tab folder.

2. Choose File→Import. The Import dialog box appears:

   ![Import dialog box]

3. Enter the name of the text file that contains the glossary.

4. Enter the code page for the glossary entries you want to import. If you need help determining the code page, contact the project manager.

5. Choose the Options button to expand the Import dialog box as shown below:

   ![Expanded Import dialog box]

6. Specify the order in which the glossary organizes the phrases. In some glossaries, the target phrase appears before the source phrase.

7. Specify whether the glossary uses a space or a comma as a delimiter between source and target phrases, then choose OK.
Exporting a glossary

You can copy the contents of the glossary to a text file to use in another kit. When you export a glossary, the Visual Translator saves it as a space-delimited data (.d) file.

To export a glossary:

1. Choose the Glossaries tab to open the Glossaries tab folder.
2. Choose File → Export. The Save As dialog box appears:

   ![Save As dialog box]

3. Specify the directory in which you want to store the file.
4. Type the name of the file with a .d extension, then choose OK.
This chapter describes how to translate text phrases with the Visual Translator tool. It provides an overview of the translation process and step-by-step instructions for several translation techniques. The chapter includes these sections:

- Overview
- Pretranslation
- Translating screen by screen
- Translating phrase by phrase
- Translation considerations
Overview

This is the basic order of tasks for translating all the text phrases in a language kit:

1. Use the pretranslation technique to review and edit translations before you start. Pretranslation lets you perform an automatic translation that uses the defined filters before you start the manual translation process. You can also generate a report of summary information on each text phrase.

2. Use the translating screen-by-screen technique to translate the user-interface objects and text phrases in the resource procedures. Translating screen by screen lets you translate text phrases within the context of the user-interface procedure.

3. Use the translating phrase-by-phrase technique to translate text phrases not shown in the resource procedures, such as error messages. Translating phrase by phrase lets you translate any text phrases from a list of all the text phrases in a kit. Also, it lets you globally translate a source phrase to the same target phrase throughout a kit.

4. Use global translation if you want to translate a text phrase in multiple procedures simultaneously.

You can switch back and forth among the three translation techniques. For example, you can translate all instances of “OK” and “Cancel” globally in the Translations tab folder, then open a resource procedure to translate the visualized text phrases, and then go back to the Translations tab folder to translate text phrases not displayed in the resource procedure.

Chapter 4, “Tracking Your Work,” describes how to verify that you have translated all of the text phrases for the kit.

Pretranslation

Before you start the translation process, you can perform a pretranslation on the text phrases in your kit. Pretranslation is a task you can perform that matches each text phrase with the first possible glossary entry. Visual Translator translates all text phrases at once. This task allows you to review and edit suggested translations before you start the manual translation process. To facilitate the review process, you can generate a hard-copy pretranslation exceptions report or print the information to a text file.
You can generate a pretranslation exceptions report that provides you with the following information about each string within a procedure file:

- Untranslated source strings.
- Translated strings with no glossary match.
- Translated strings that have more than one possible translation.

The pretranslation exceptions report also provides the following summary information, by procedure and by project:

- Total number of translation strings.
- Number of new translation strings.
- Number of new translation strings that have more than one possible translation.
- Number of previously translated strings.

To pretranslate text phrases in a kit:

1. Choose Tools→TranMan Utilities→Pre-translation. The PreTranslation dialog box appears:
2. Select one of these options for pretranslating phrases:

- **Translate case-sensitive matches** — The Translation Manager translates only the text phrases that match a glossary entry exactly. For example, the Translation Manager will not translate “Customer Name” if the glossary entry is “customer name.” Although the text phrase is the same, the case does not match the glossary entry.

- **Use case-insensitive match if necessary** — The Translation Manager searches for an exact match with a glossary entry first. If there is no glossary entry that matches the text phrase exactly, the Translation Manager searches for a match regardless of case. You should select this button if you do not want leading and trailing blanks ignored.

- **Use case-insensitive match and trim phrase if necessary** — The Translation Manager first searches for exact matches with glossary entries, then it searches for a match regardless of case. Finally, it ignores leading and trailing blanks by trimming them from the phrase before looking for a match.

3. Activate the **Exceptions Report** toggle box if you want a hard-copy report (or to save the information to a text file).

4. Select your print options. If you select the **Output To Printer** radio-set button, you do not need to enter a filename. The default filename is `pretrans.log`. If you select the **Output to A Text File** radio-set button, you must either enter a filename or use the default filename, `pretrans.log`.
5. Choose **OK**. A pretranslation report prints:

<table>
<thead>
<tr>
<th>City</th>
<th>Untranslated</th>
</tr>
</thead>
<tbody>
<tr>
<td>Country</td>
<td>Untranslated</td>
</tr>
<tr>
<td>Current record has been changed.</td>
<td>Untranslated</td>
</tr>
<tr>
<td>Name</td>
<td>Untranslated</td>
</tr>
<tr>
<td>Search On Customer Name</td>
<td>Untranslated</td>
</tr>
<tr>
<td>State</td>
<td>Untranslated</td>
</tr>
</tbody>
</table>

You must complete or cancel the update before leaving...

c:\progress\TMsource\b-cuslkp.w should only be RUN PERS...

**SUMMARY:**

<table>
<thead>
<tr>
<th>10 Strings Total</th>
<th>100 %</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 Existing Translations</td>
<td>0 %</td>
</tr>
<tr>
<td>1 Strings Translated</td>
<td>10 %</td>
</tr>
<tr>
<td>9 Strings Untranslated</td>
<td>90 %</td>
</tr>
</tbody>
</table>

**GRAND SUMMARY:**

<table>
<thead>
<tr>
<th>14 Strings Total</th>
<th>100 %</th>
</tr>
</thead>
<tbody>
<tr>
<td>4 Existing Translations</td>
<td>8 %</td>
</tr>
<tr>
<td>1 Strings Translated</td>
<td>1 %</td>
</tr>
<tr>
<td>13 Strings Untranslated</td>
<td>91 %</td>
</tr>
<tr>
<td>0 Strings with Multiple Translations</td>
<td>0 %</td>
</tr>
</tbody>
</table>
Translating screen by screen

Translating within the context of the screen allows you to choose a target phrase that most accurately corresponds to the meaning of a source phrase. For example, you could translate the English source phrase “number” into the German words, “Zahl,” “Ziffer,” “Nummer,” or “Anzahl,” depending on the context. The source word can have different meanings in different procedures. For example, in one procedure you might want to use “Ziffer” for a telephone number. In another procedure you might want to use “Nummer” for a calculated number. By translating in context, you improve the quality of your translation effort.

Opening a resource procedure

First you need to locate the resource procedure.

To open a resource procedure:

1. From the Procedures tab folder, select the name of the procedure file to translate.

   **Note:** You must select a procedure name that has a resource procedure as indicated in the Resource Procedure column. Some procedures do not have resource procedures and you must translate them phrase by phrase in the Translations tab folder.

2. Choose the View button or double-click on the procedure name to display the procedure. The Visual Translator displays a resource procedure window similar to the example shown below:

   ![Resource Procedure Window Example]

   **Note:** If the resource procedure contains more than one frame, an alert box appears stating how many frames the procedure contains. To see the other frames, choose the Next Frame button.
Automatic translation

By default, the Visual Translator displays the source phrases in the resource procedure. You can set the Visual Translator to automatically add the glossary entries as translations for those text phrases displayed in the resource procedure.

To automatically translate the source procedures in a resource procedure, using the glossary translations:

1. Choose Options→Preferences. The Preferences dialog box appears:

2. Activate the Automatic Translations When Visualized toggle, then click OK.

Note: For automatic translation to work, you must activate the Automatic Translations When Visualized toggle box and choose OK. You must then open and close each resource procedure you want to automatically translate.

3. From the Procedures tab folder, double-click a procedure to visualize it. The resource procedure appears with target phrases displayed for all those text phrases that have glossary entries. If the glossary does not contain an entry for the text phrase, the source phrase is displayed instead.

Note: You can visualize the glossary suggestions without saving them as translations by deactivating the Automatic Translations When Visualized toggle box and choosing OK in the Preferences dialog box before you proceed to Step 4.
4. Close the procedure window to automatically save the glossary suggestions as translations.

Note: Automatic translation works only for those text phrases you can visualize in a resource procedure. It does not apply to all the text phrases in the kit. For example, you might have a glossary suggestion for all or part of a message statement, but you cannot automatically save the glossary suggestion as a translation because the message statement does not appear in a resource procedure. For more information on translating all of the text phrases in a kit, refer to the “Pretranslation” section on page 3–2.

Opening the Properties window

To open the Properties window, double-click on an item in the resource procedure window that you want to translate. Figure 3–1 shows the Properties dialog box.

![Properties dialog box](image)

Figure 3–1: Properties dialog box

For information on the menu options and tool bar buttons in this window, click the help button or see the Properties window section of Appendix A, “Visual Translator Interface Reference.”

To always display the Properties window on top of other open windows:

1. Choose Options → Preferences. The Preferences dialog box appears.
2. Activate the Display Properties Window As Always On Top toggle, then click OK.

**Caution:** The Visual Translator displays warning or error message windows in the center of the computer screen. If you specify the Properties window as always on top and you place it in the center of the screen, it will hide any error messages. To work around this behavior, drag the Properties window away from the center of the screen so you can still see important messages.

**Input Method Editors** — If you choose the option to display the Properties window as always on top, it will cover the Input Method Editor. Therefore, do not use this option if you use Input Method Editors.

---

**Selecting an object**

You can use either of the following techniques to select an object from the resource procedure window:

- **Self-guided selection** — Double-click an object in the resource procedure window.
  
  If you use self-guided selection, click the Uncover Object button to expose an object hidden under the currently selected object.

- **Tool-guided selection** — Click the Next Object button. The tool determines which object is the next object according to the order in which the objects were created. If you use tool-guided selection, you do not have to use the Uncover Object button.

The major advantage to tool-guided selection is that it ensures you translate all the user-interface objects in a procedure, including those objects that might be hidden underneath other objects.

In addition to the alert box that appears when you open a resource procedure, the Next Frame button is an indicator of whether there is more than one frame for the procedure. If the Next Frame button is grayed out, there is only one frame; if it is enabled, there are at least two frames for the procedure and you can click the Next Frame button to see the other frames.

**Note:** The Visual Translator treats a menu bar as a separate frame. For example, if the only objects in a resource procedure are a menu bar and a frame, the tool generates an alert box when you open the procedure stating that there are two frames.
**Entering a translation**

Once you select an object, you can enter your own translation, select a suggestion from the glossary, or edit a glossary selection.

**Note:** To enter your own translation, you must have the proper permissions. Choose **Option → Preferences** to check the **Privileges** section of the **Preferences** dialog box. If you want to change the privileges, contact the project manager.

To enter your own translation:

1. In the **Properties** window, type a translation in the **Target** fill-in field. The text appears in red.
2. Choose **File → Save**. The Visual Translator changes the text in the **Target** fill-in field to black to indicate that it saved your translation. It also displays your translation in the resource procedure window. In the example shown below, the Visual Translator displays “Ville” instead of “City” in the resource procedure window:

![Screenshot of the Visual Translator](image)

**Note:** When you type in your own translation, the Visual Translator adds it to the glossary as a custom glossary entry. However, the Translation Manager does not accept glossary entries that begin with a question mark (?).
Selecting a glossary suggestion

In the Glossary field of the Properties window, the tool displays all the glossary target phrases for a source phrase. For example, if “customer number” is the source phrase, the Visual Translator displays target phrases for “customer number,” “customer,” and “number.”

If you activate the Use Word Indexing toggle box, the Visual Translator also displays all the target phrases for those source phrases that contain the word you want to translate. For example, if “customer” is the source phrase and you activate word indexing, the Visual Translator displays target phrases for every source phrase that contains “customer,” such as “customer address” and “customer number.”

Follow these steps to use a glossary suggestion for the target phrase:

1. If you use word indexing, select a source phrase or a word from the Source selection list.

2. Select a suggestion from the Glossary field. The glossary entry appears in the Target fill-in field.

3. Edit the glossary entry in the Target fill-in field if necessary, then press OK. The target phrase appears in the Procedure window.

Translating phrase by phrase

The following types of text phrases are not included in the resource procedures. You must translate them in the Translations tab folder:

- **Dynamic widgets** — User interface components that your application creates or deletes during the execution of a procedure. These components cannot be stored in resource procedures.

- **Text phrases that are not visualized at run time** — For example, in the following code, “Amsterdam” is a text phrase in the 4GL code but it is not a user-interface element such as a label:

  FOR EACH customer-name WHERE city = "Amsterdam"

- **Message statements** — Messages such as errors, warnings, or helpful hints. You can view a message statement in an alert box after you translate it in the Translations tab folder.

**Note:** In the Translations tab folder, you can also make changes to any in-context translations.
You can also use the Translations tab folder for global translation to control consistency of translation throughout the procedures in a kit. You can translate text phrases into a certain target phrase, no matter what the context. For example, in the Translations tab folder, you can globally change all instances of “open” in the English source language to “ouvrir” in the French target language.

Opening the Translations tab folder

The Translations tab folder allows you to translate a text phrase by instance.

To translate a text phrase by instance:

Follow these steps to translate a text phrase by instance:

1. Click the Translations tab to open the Translations tab folder and view the text phrases for the entire kit.

2. Choose View → Sort or click on the Sort button. The Sort dialog box appears:

3. Specify to sort first by target phrase in ascending order, then choose OK. The untranslated text phrases appear at the top of the Translations tab folder.
4. Click in the target phrase column of a row that contains a phrase you want to translate. A box appears around the target phrase fill-in area and a cursor appears in the box, as shown below. If you cannot view the entire phrase, double-click on the phrase to open a larger window:
Opening the glossary window

The Glossary window allows you to view glossary suggestions while you translate in the Translations tab folder.

To open and use the Glossary window:

1. Select a source text phrase in the Translations tab folder.

2. Choose Window→Glossary to open the Glossary window and view the glossary suggestions for the target phrase selected in the tab folder:

3. Select the combo-box button to also display glossary suggestions for each word in the text phrase:

4. Activate the Use Word Indexing toggle box to display all target phrases that contain a translation for one of the words in the source phrase.

Editing a glossary suggestion

To edit a glossary suggestion:

1. In the Glossary window, click a glossary selection. The glossary entry appears in the Target Phrase column of the Translations tab folder.

2. Edit the entry in the Translations tab folder.
Entering a translation

Select a target suggestion from the Glossary window or type a target phrase directly in the target phrase fill-in area, then press RETURN. The Visual Translator saves the target phrase.

To edit a translation, use the Cut, Copy, and Paste buttons. To enable these buttons, select a cell in the Target Phrase column. The Visual Translator cuts and copies the entire contents of a selected cell. You can then manually edit the text using the keyboard.

To view the translation of a message in context, click the View button.

You can view any text phrase in a separate, larger dialog box by double-clicking on any field of the Translation tab folder. Figure 3–2 shows the Long String Translator dialog box.

Figure 3–2: Long String Translator dialog box

The Long String Translator dialog box allows you to view and edit text phrases. If a string is longer than thirty-four characters and does not fit in the Translations tab folder, you can view it in the Long String Translator dialog box. The source string displays in the Source String viewer. The target string displays in the Target String viewer. You cannot edit the source string, but you can edit the target string within the Target String viewer.
Global translation

This section describes how to use the Visual Translator to translate text phrases globally.

To translate text phrases globally:

1. From the Translations tab folder, choose Edit → Replace. The Replace dialog box appears:

2. In the Find What field, type the source phrase you want to translate.

3. In the Find section, activate Source.

Note: Finding by source phrase results in optimum performance.

4. Activate the options you want to use during the Find process:

   - Ignore Leading Spaces — If you activate this toggle box (the default), the Visual Translator finds the phrase you specify in the Find What field even if it has blank spaces in front of it.

   - Case Sensitive — If you activate this toggle box, the Visual Translator finds the phrase only if it exactly matches the uppercase and lowercase letters you specify. For example, if you specify “Close,” it does not find “close” or “CLOSE.”

   - Use Wildcards — If you activate this toggle box, the Visual Translator lets you use an asterisk (*) and a period (.) as wildcards in the Find What field. For example, if you specify “*cat*”, it finds all phrases that contain “cat,” such as “concatenate” and “category.” If you specify “.File,” it finds all phrases that contain “File” preceded by a single character, for example, “_File.”
5. In the **Replace What** field, type the target phrase you want to replace. If you want to replace all target phrases for the specified source phrase, leave the **Replace What** field blank.

6. In the **Replace With** field, type the target phrase you want to use. In the example shown below, the translator is translating all instances of the English source phrase “File” to the German target phrase “Datei”:

   ![Replace Dialog Box](image)

   In the following example, the translator is changing the target phrase to “Datei” only for those instances of “File” that have a target phrase of “Akte”:

   ![Replace Dialog Box](image)

   1. Choose **Replace All**.

   2. If the text phrase is for a user-interface object in a resource procedure or for a message and you would like to see the translation in context, select a row that contains the translation you want to view, then click the **View** button.

      The corresponding resource procedure or an alert box containing the message appears.
Translation considerations

This section describes the considerations you should keep in mind when translating while using Visual Translator.

**Punctuation**

If a source phrase contains punctuation, the Visual Translator does not display the glossary suggestion for the source phrase unless the glossary suggestion also contains the same punctuation. For example, if the source phrase is “Files...”, the Visual Translator does not display the “Files” glossary suggestion because the glossary suggestion does not contain ellipses.

**Accelerator keys**

You should always include accelerator keys as part of your translation. Check with the project manager to determine how you should define accelerator keys in the target language. The project manager might want you to use the same accelerator keys as the source language or might want you to define new mnemonic accelerator keys specifically for the target language.

For Asian target languages, you should provide an additional ASCII character in parentheses as an accelerator key since the 4GL does not support double-byte characters as accelerator keys. For example, (&A) after the translation of an Asian menu item means that &A displays next to the menu item on the interface, and the user can press alt-A to choose the menu item.
This chapter describes how to use the Visual Translator to track your work. Specifically, it discusses the following topics:

- Checking status
- Finding untranslated text phrases
- Monitoring the glossary
- Printing screen captures
- Printing a statistics report
Checking status

You can check the status of your translation effort for the entire kit or for a particular procedure within the kit.

Procedure status

The Visual Translator uses the following terms in the Current Status column of the Procedure tab folder to indicate the translation status for each procedure in the current language kit:

- **Untranslated** — You have not made any translations in the procedure.
- **x of n** — You have translated x phrases out of the n total that are in the procedure.
- **Translated** — You have translated all the text phrases in the procedure.

Kit status

To determine the percentage of the text phrases you have translated in a language kit, open the Statistics tab folder and check the % Translated entry.

Finding untranslated text phrases

This section describes how to find all untranslated text phrases in a procedure and all untranslated text phrases for a kit.

To view all untranslated phrases for a procedure:

1. Click the Translations tab to open the Translations tab folder.
2. Choose View→Order Columns or click the Order button. The Order Columns dialog box appears:

3. Move ProcedureName, then SourcePhrase, then TargetPhrase from the Available selection list to the Selected selection list, then choose OK.

4. Choose View→Sort Rows or click the Sort button. The Sort dialog box appears:

5. Specify to sort by Procedure Name, then by Target Phrase, then choose OK.

The Visual Translator displays all the text phrases alphabetically by procedure. First it displays the untranslated phrases, then the translated phrases.

To find all untranslated text phrases in a kit:

1. Open the Translations tab folder, then choose Edit→Goto. The Goto dialog box appears:
2. Activate the **First Untranslated Target** radio button, then choose **Goto**. The Visual Translator highlights the row in the **Translations** tab folder that contains the first untranslated text phrase. The Visual Translator determines which is the first untranslated text phrase by the original row order.

3. Activate the **Next Untranslated Target** radio button to find all subsequent untranslated text phrases.

**Monitoring the glossary**

The **Modified by Translator** and **Type** columns in the **Glossaries** tab folder help you keep track of changes you make to the default glossary.

While you translate, if you enter a translation instead of selecting a suggestion from the glossary, the Visual Translator adds your translation to the default glossary but marks it with a C (for custom) in the **Type** column of the **Glossaries** tab folder. For example, in Table 4–1, “Cerrar” is entered by the translator.

If you select a default glossary suggestion for a translation and edit it (for example, you change a word), the Visual Translator indicates that you changed the glossary suggestion by entering Yes in the **Modified by Translator** column of the **Glossaries** tab folder. For example, in Table 4–1, “Mapa de bits” is changed by the translator.

**Table 4–1:** Example glossary entries

<table>
<thead>
<tr>
<th>Source phrase</th>
<th>Target phrase</th>
<th>Modified by translator?</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Agregar</td>
<td>No</td>
<td>D</td>
</tr>
<tr>
<td>Bitmap</td>
<td>Mapa de bits</td>
<td>Yes</td>
<td>D</td>
</tr>
<tr>
<td>Close</td>
<td>Cerrar</td>
<td>Yes</td>
<td>C</td>
</tr>
</tbody>
</table>
Printing screen captures

You can take a screen capture of the translated user-interface procedure window to use in a hard-copy document or to illustrate an issue for the project manager.

To take a screen capture:

1. Open the window you want to capture.
2. Choose the Print button. The Select Window dialog box appears:

3. Select the name of the resource procedure window, then click OK.

Printing a statistics report

The statistics report provides you with information on the current project database. The report contains information that helps you keep track of your translations, for example, the name of the project, creation date, date of last update, and the number of procedures.
You can generate a statistics report, or print the report to a text file, from the Statistics tab folder.

To generate or print a statistics report:

1. Choose the Print button or choose File→Print from the Statistics window. The Statistics Report Print Dialog box appears:

2. Select your print options. If you select the Output To Printer radio-set button, you do not need to enter a filename. The filename defaults to status.txt. If you select the Output to A Text File radio-set button, you must either enter a filename or use the default filename, status.txt.

3. Choose OK. A statistics report prints out that is similar to the one shown below:

```
Project: GetStart1              03/10/97          Page1
Project Name                               kfrench
Description                               
Revision                                   1.0
Create Date                                01/10/97
Last Updated                               03/06/97
Database Size (in Bytes)                   458.8K
Display Type                               Graphical
Number of Procedures                       16
Number of Phrases                          164
Number of Unique Phrases                   109
Number of Words                            347
Number of Unique Words                     188
Current Procedure                          None
Current Object                             None
Number of Frames                           0
Number of Objects                          0
% Translated                               9%
# Items In Glossary                        1063
```
This chapter provides answers to some common questions.
Why can’t I install a kit?

You might not need to install the kit. If the kit is not compressed, you can open it without first installing it. A compressed kit has a .zip file extension (for example, kit.zip). A decompressed kit has a .db extension (for example, kit.db).

To open a kit, click the Open button.

Why can’t I open a kit?

If the kit is compressed, you must install it before you can open it. A compressed kit has a .zip file extension (for example, kit.zip). An uncompressed file has a .db extension (for example, kt.db).

To install a kit, choose File→Install.

Why can’t I import glossary entries?

To make sure you have permission to import glossary entries, choose Options→Preferences. The Preferences dialog box displays the privileges the project manager assigned to you. If the Must Use Glossary For Translations toggle box is activated, you cannot import a glossary.

**Note:** The Translator Privileges section is grayed out to show that it is disabled and you cannot change it. The project manager sets privileges with the Translation Manager tool.

Why do the glossary entries I import have only numbers for source phrases?

You probably imported the entries from a dumped data file that contains line numbers in the first data column.

Why can’t I open a resource procedure?

Check the Resource Procedure column in the Procedures folder. If No is specified for the procedure you want to open, a resource procedure does not exist. You must translate all the text phrases in this procedure with the phrase-by-phrase technique.

If Yes is specified in the Resource Procedure column, click the View button to open the resource procedure or double-click on the name of the procedure. If the Properties window is open, drag it away from the center of the screen to look for an error message.
Troubleshooting

Why are the text phrases in the resource procedures in the wrong font?

You might be using the wrong `progress.ini` file or the project manager might have used the wrong environment (.ini) file when creating the resource procedures. Contact the project manager for assistance.

Why is the Visual Translator interface frozen?

The Visual Translator displays warnings or error messages in the center of the computer screen. If you specify the Properties window as always on top and you place it in the center of the screen, the Properties window will hide any error messages. To work around this situation, drag the Properties window away from the center of the screen so you can still see important messages.

Why can’t I type a target phrase?

To make sure you have permission to enter your own translation, choose Options→Preferences. The Preferences dialog box displays the privileges the project manager assigned to you. If the Must Use Glossary For Translations toggle box is activated, you cannot enter your own translation if there is a glossary suggestion. Contact the project manager to change your privileges.

Note: The Translator Privileges section is grayed out to show that it is disabled and you cannot change it. The project manager sets privileges with the Translation Manager tool.
Visual Translator Interface Reference

This appendix provides reference information for user-interface elements in the Visual Translator tool and includes the following sections:

- The main window
- Properties window menu options and buttons

For online reference information for a dialog box, click the Help button on the dialog box.
The main window

This section describes how to use the following user-interface elements of the Visual Translator’s main window:

- Tab folders
- Menu bar
- Tool bar

Main window tab folders

The main interface component of the Visual Translator tool is the tab folder. Figure A–1 shows the Visual Translator tabs.

![Tab folders](image)

**Figure A–1: Visual Translator tab folders**

When you click one of the tabs, the Visual Translator displays a new interface within the folder. The following sections describe the four tab folders.
Procedures tab folder

The **Procedures** tab folder provides a list of the procedures in the kit. Click the **View Procedures** button to view the user interface of a procedure and translate text phrases. Figure A–2 shows the **Procedures** tab folder.

![Procedures tab folder](Image)

Figure A–2:  Procedures tab folder

The **Procedures** tab folder displays the following columns of information for each procedure in the kit:

- **Procedure Name** — Shows the name of the source-code procedure (.p or .w) file.

- **Resource Procedure?** — Indicates whether a resource procedure (.rc) file exists for the source procedure. If yes, you can click the **View Procedure** button to view in-context text phrases.

- **Current Status** — Indicates whether or not you have translated a text phrase in the procedure (untranslated), the number of phrases you have translated out of the total number of text phrases in the procedure (x of n), or whether you have translated all text phrases (translated).

- **Comments** — Presents comments about the procedure written by the project manager.

- **Directory Name** — Shows the name of the directory that contains the source-code procedure (.p or .w) files.
Translations tab folder

The Translations tab folder lets you view the translation data for the entire kit and allows you to translate text phrases globally or by instance. Figure A–3 shows the Translations tab folder.

Figure A–3: Translations tab folder

The Translations tab folder displays the following columns of information for each text phrase:

- **Source Phrase** — The text phrase in the source language.
- **Target Phrase** — The text phrase in the target language.
- **Procedure Name** — The name of the application procedure (.p or .w) file that contains the source phrase.
- **Last Updated** — The date the source procedure was last changed.
Glossary tab folder

The Glossary tab folder lets you view the pairings for source and target phrases in the glossary. Figure A–4 shows the Glossary tab folder.

![Glossary tab folder](image)

The Glossary tab folder displays the following columns of information for each text phrase:

- **Source Phrase** — Shows the text phrase in the source language.
- **Target Phrase** — Shows the text phrase in the target language.
- **Modified By Translator?** — Specifies whether you modified the glossary target phrase.
- **Type** — Indicates whether the glossary entry was in the glossary provided by the project manager (D for default) or added by the translator (C for custom) by hand or through an imported glossary.
Statistics tab folder

The Statistics tab folder provides statistics for the language kit, such as the number of procedures, number of phrases, and number of individual words. Figure A–5 shows the Statistics tab folder.

![Figure A–5: Statistics tab folder](image)

The Statistics tab folder provides the following information to help you keep track of your translation effort:

- **Project Name** — The project database associated with the kit.
- **Description** — A description of the project associated with the kit.
- **Revision** — The revision number for the project associated with the kit.
- **Create Date** — The date the project manager created the project.
- **Last Updated** — The date you last used the kit.
- **Database Size** — The size of the kit database, in bytes.
- **Display Type** — Indicates whether the resource procedures for the kit display in graphical or character mode.
• **Number of Procedures** — The number of source code (.p or .w) files that contain text phrases you have to translate.

• **Number of Phrases** — The number of text phrases (including repetitions) in the kit.

• **Number of Unique Phrases** — The number of unique text phrases in the kit.

• **Number of Words** — The number of individual words (including repetitions) in the kit.

• **Number of Unique Words** — The number of unique individual words in the kit.

• **Current Procedure** — The name of the procedure currently selected.

• **Current Object** — The type of object associated with the currently selected text phrase.

• **Number of Frames** — The number of frames in the current procedure.

• **Number of Objects** — The number of user-interface objects in the current procedure.

• **% Translated** — The percentage of text phrases you have translated in the kit.

• **# Items in Glossary** — The number of entries (pairings) in the glossary.

**Note:** The tool updates the Statistics tab folder whenever you choose a tab folder.

---

**Main window menu bar and tool bar**

The menu bar in the Visual Translator contains menu options that allow you to perform various tasks. The buttons in the tool bar provide quick access to some of the most commonly used menu option functions. When a menu option or tool bar button is grayed-out, it is disabled and you cannot use it.

**Menu bar**

Figure A–6 shows the Visual Translator main window menu bar.

![Figure A–6: Visual Translator menu bar](image)

This manual uses the following notation to represent a menu option: **File→Exit**. This notation tells you to choose the **Exit** option from the **File** menu.
Some menu options have accelerator keys assigned to them that appear to the right of menu options on pull-down menus. Accelerator keys are key combinations you press to select a menu option. For example, when you pull down the File menu, you see `CTRL-o` to the right of the Open option. This means that you can hold down the `CTRL` key and press `o` to open a language kit.

Each menu option has a mnemonic. A mnemonic is a single letter that you can press to select a menu option. The mnemonic for each menu or menu option is underlined in its label. Table A–1 lists the menu-bar options, their associated buttons on the tool bar, descriptions of the tasks you can perform with them, and the tab folders in which they are enabled.

### Table A–1: Main window menu options and tool bar buttons

<table>
<thead>
<tr>
<th>Menu options</th>
<th>Button</th>
<th>Description</th>
<th>Tab folders</th>
</tr>
</thead>
<tbody>
<tr>
<td>File → Install Kit</td>
<td>–</td>
<td>Decompresses and opens a compressed kit.</td>
<td>Procedures</td>
</tr>
<tr>
<td>File → Return Kit</td>
<td>–</td>
<td>Compresses the kit so you can return it to the Project Manager.</td>
<td>Procedures</td>
</tr>
<tr>
<td>File → Open</td>
<td>🔄</td>
<td>Opens a decompressed kit that you installed previously.</td>
<td>All</td>
</tr>
<tr>
<td>File → Import</td>
<td>–</td>
<td>Imports a Glossary.</td>
<td>Glossary</td>
</tr>
<tr>
<td>File → Export</td>
<td>–</td>
<td>Exports a Glossary.</td>
<td>Glossary</td>
</tr>
<tr>
<td>File → Print Screen</td>
<td>📖</td>
<td>Prints a screen capture of a window, for example, a translated user interface procedure.</td>
<td>Procedures, Translations, Glossary</td>
</tr>
<tr>
<td>File → Print</td>
<td>📖</td>
<td>Prints a hard-copy Statistics report or save the report to a text file.</td>
<td>Statistics</td>
</tr>
<tr>
<td>File → Exit</td>
<td>–</td>
<td>Exits the Visual Translator tool.</td>
<td>All</td>
</tr>
<tr>
<td>Edit → Cut</td>
<td>🔨</td>
<td>Cuts selected text.</td>
<td>Translations, Glossary</td>
</tr>
</tbody>
</table>
Table A–1: Main window menu options and tool bar buttons (2 of 3)

<table>
<thead>
<tr>
<th>Menu options</th>
<th>Button</th>
<th>Description</th>
<th>Tab folders</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit→ Copy</td>
<td>![Copy]</td>
<td>Copies selected text.</td>
<td>Translations, Glossary</td>
</tr>
<tr>
<td>Edit→ Paste</td>
<td>![Paste]</td>
<td>Pastes text you cut or copied.</td>
<td>Translations, Glossary</td>
</tr>
<tr>
<td>Edit→ Insert</td>
<td>![Insert]</td>
<td>Inserts a row.</td>
<td>Glossary</td>
</tr>
<tr>
<td>Edit→ Delete</td>
<td>![Delete]</td>
<td>Deletes a row.</td>
<td>Glossary</td>
</tr>
<tr>
<td>Edit→ Find</td>
<td>![Find]</td>
<td>Finds a text phrase.</td>
<td>Translations, Glossary</td>
</tr>
<tr>
<td>Edit→ Replace</td>
<td>–</td>
<td>Finds and replaces a text phrase. Use this option for global translations.</td>
<td>Translations, Glossary</td>
</tr>
<tr>
<td>Edit→ Goto</td>
<td>–</td>
<td>Goes to a specific row in a list of text phrases.</td>
<td>Translations</td>
</tr>
<tr>
<td>Edit→ Exit</td>
<td>–</td>
<td>Exits the Visual Translator tool.</td>
<td>All</td>
</tr>
<tr>
<td>View→ Sort Rows</td>
<td>![Sort]</td>
<td>Sorts text phrases or glossary entries by row.</td>
<td>Translations, Glossary</td>
</tr>
<tr>
<td>View→ Order Columns</td>
<td>![Order]</td>
<td>Arranges the order of columns.</td>
<td>Translations, Glossary</td>
</tr>
<tr>
<td>View→ View Procedure</td>
<td>![View]</td>
<td>Views a resource procedure.</td>
<td>Procedures, Translations</td>
</tr>
<tr>
<td>Options→ Preferences</td>
<td>–</td>
<td>Specifies display and saves preferences for the Visual Translator tool.</td>
<td>All</td>
</tr>
</tbody>
</table>
Table A–1: Main window menu options and tool bar buttons (3 of 3)

<table>
<thead>
<tr>
<th>Menu options</th>
<th>Button</th>
<th>Description</th>
<th>Tab folders</th>
</tr>
</thead>
<tbody>
<tr>
<td>Window → Properties</td>
<td>–</td>
<td>Displays the Properties window when you view a procedure.</td>
<td>Procedures</td>
</tr>
<tr>
<td>Window → Glossary</td>
<td>–</td>
<td>Displays the Glossary window when you view a procedure.</td>
<td>Translations</td>
</tr>
<tr>
<td>Tools → TranMan</td>
<td>–</td>
<td>Removes glossary entries that do not correspond to extracted text phrases.</td>
<td>All</td>
</tr>
<tr>
<td>Utilities → Cleanup</td>
<td>–</td>
<td>Translates all text phrases that have glossary entries.</td>
<td>All</td>
</tr>
<tr>
<td>Glossaries</td>
<td></td>
<td>Prints a report of the Pretranslation results.</td>
<td>All</td>
</tr>
<tr>
<td>Tools → Pre-translation</td>
<td>–</td>
<td>Open various OpenEdge tools based on your license agreement.</td>
<td>All</td>
</tr>
<tr>
<td>Help</td>
<td>![Help]</td>
<td>Provides online help about buttons and folders.</td>
<td>All</td>
</tr>
</tbody>
</table>

**Tool bar**

Figure A–7 shows the tool bar for the Visual Translator main window.

![Figure A–7: Visual Translator tool bar](image)

Click a tool-bar button for quick access to its corresponding menu option.
Properties window menu options and buttons

This section describes the menu options and buttons for the Visual Translator Properties window. Table A–2 describes the functions of the Properties window buttons.

Table A–2: Properties window buttons

<table>
<thead>
<tr>
<th>Name</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Close</td>
<td>🗑️</td>
<td>Close the Properties window and return to the Visual Translator main window.</td>
</tr>
<tr>
<td>Previous Object</td>
<td>🌇️</td>
<td>Move to the previous interface object in the resource procedure window.</td>
</tr>
<tr>
<td>Next Object</td>
<td>🌇️</td>
<td>Move to the next interface object in the resource procedure window.</td>
</tr>
<tr>
<td>Next Frame</td>
<td>📜</td>
<td>Display the next frame associated with the current resource procedure.</td>
</tr>
<tr>
<td>Uncover Objects</td>
<td>🌇️</td>
<td>Display an interface object hidden underneath the currently selected object.</td>
</tr>
<tr>
<td>Switch</td>
<td>🔄️</td>
<td>Switch between displaying the source phrases or all the target phrases in the resource procedure window.</td>
</tr>
<tr>
<td>Help</td>
<td>📚</td>
<td>Provide information about the buttons, tabs, and fill-in fields in the Properties Window.</td>
</tr>
</tbody>
</table>
Table A–3 describes the functions of the *Properties* window menu options.

### Table A–3: Properties window menu options

<table>
<thead>
<tr>
<th>Menu</th>
<th>Menu option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File</strong></td>
<td>Save</td>
<td>Saves the target phrase to the translation and glossary databases.</td>
</tr>
<tr>
<td></td>
<td>Close</td>
<td>Closes the Properties window.</td>
</tr>
<tr>
<td><strong>Edit</strong></td>
<td>Cut</td>
<td>Cuts highlighted text in the Properties window.</td>
</tr>
<tr>
<td></td>
<td>Copy</td>
<td>Copies highlighted text in the Properties window.</td>
</tr>
<tr>
<td></td>
<td>Paste</td>
<td>Pastes text you cut or copied in the Properties window.</td>
</tr>
<tr>
<td><strong>View</strong></td>
<td>Source</td>
<td>Displays the source phrases in the resource procedure window.</td>
</tr>
<tr>
<td></td>
<td>Target</td>
<td>Displays the available target phrases in the resource procedure window.</td>
</tr>
<tr>
<td><strong>Object</strong></td>
<td>Next Frame</td>
<td>Displays the next frame associated with the current resource procedure.</td>
</tr>
<tr>
<td></td>
<td>Next Object</td>
<td>Moves to the next interface object in the resource procedure window.</td>
</tr>
<tr>
<td></td>
<td>Previous Object</td>
<td>Moves to the previous interface object in the resource procedure window.</td>
</tr>
</tbody>
</table>
Index

A

Accelerator keys
 defined A–7
 translating 3–18

Automatic translation 3–7

B

Blanks
 trimming 3–4

C

Capturing screen images 4–5

Closing kits 2–4

Columns
 ordering 4–2

Comma-delimited glossaries 2–8

Comments A–3

Compressing kits 2–7

Covered objects 3–9

D

Decompressing kits 2–4

Dialog boxes
 Install Zip File 2–4
 Long String Translator 3–15
 Open Kit Database 2–6
 Order Columns 4–2
 Preferences 3–7
 Replace 3–16
 Save As 2–11
 Select Window 4–5
 Sort 4–2

Directories
 working 2–2

Display types A–6

E

Editing
 glossary entries 3–14
 text phrases 3–15

Entering translations
 Long String Translator dialog box 3–15
 Properties window 3–10
 tab folder 3–12, 3–15

Environment files 1–3
OpenEdge Development: Visual Translator

Environment setup 2–2
Error messages 5–1
Exporting glossaries 2–11

F

Files
environment 1–3
image 1–3
pretrans.log 3–4
status.txt 4–6

Finding
hidden objects 3–9
text phrases 3–16
untranslated text phrases 4–2

Font issues 5–3

Frames 3–6, 3–9

Frozen interface 5–3

G

Global translation 3–16

Glossaries
default compared to custom entries 2–8
ingediting 3–14
example entries 4–4
exporting 2–11
monitoring 4–4
space-delimited compared to comma-delimited 2–8
using 3–11

Glossaries tab folder A–5

Glossary entries
importing 2–10

Glossary window
opening 3–14

H

Help
see also Online help

Hidden objects 3–9

Hypertext links
defined 2–4

I

Image files 1–3

In-context translation 3–6

Installing kits 2–4

Items A–4

K

Kits
closing 2–4
compressing and returning 2–7
contents 1–3
installing 2–4
opening 2–6

L

Languages 1–3

List translation 3–11

Long String Translator dialog box 3–15

M

Main window 2–2, A–2
menu bar A–7
tool bar A–7
tool bar buttons A–8

Menu bar
main window A–7
Menu bar translation 3–9
Menu options
   Properties window A–12
Mnemonics
   defined A–8
Modified by Translator column A–5

O
Object names A–4
Online help
   how to access 2–3
Opening
   Glossary Window 3–14
   kits 2–6
   Properties window 3–8
   resource procedures 3–6
   tab folders 3–12
Options 2–8
Ordering columns 4–2

P
Percent of phrases translated 4–2
Phrase-by-phrase translation 3–11
Preferences 3–7
Preparation 2–2
   pretrans.log file 3–4
Pretranslation 3–2
Printing a pretranslation exceptions report 3–2
Printing a statistics report 4–5
Printing screen captures 4–5
Privileges 2–8

Problems 5–1
Procedures tab folder A–3
Project manager 1–1
Properties window
   displaying as always on top 3–8
   menu options A–12
   opening 3–8
   tool bar A–11
Punctuation 3–18

Q
Question marks 3–10
Questions and answers 5–1

R
Replacing text phrases 3–16
Reports
   pretranslation exceptions 3–2
   statistics report 4–5
Resource procedures 1–3
   opening 3–6
Returning kits 2–7
Rows
   sorting 3–12

S
Saving
   changes to kits 2–4
   glossaries as files 2–11
   translations 3–10
Screen capture printing 4–5
Screen-by-screen translation 3–6
Searching for text phrases 3–16
Selecting
cells in a tab folder 3–12
objects to translate 3–9
Self-guided object selection 3–9
Setup 2–2
Sorting rows 3–12
Source languages 1–3
Space-delimited glossaries 2–8
Starting the Visual Translator 2–2
Statistics report 4–5
Statistics tab folder A–6
Status of kits 4–2
status.txt file 4–6

T
Tab folders A–2
Target languages 1–3
Target phrases
entering 3–15
Text phrases
editing 3–15
Tool bar
main window A–7
Properties window A–11
Tool-guided object selection 3–9
Translating
globally 3–16
Translating text phrases
preliminary translation 3–2
screen-by-screen 3–6
Translation
automatic 3–7
Translation considerations 3–18
Translations tab folder A–4
Trimming blanks 3–4
Troubleshooting 5–1
Types
Glossaries tab folder A–5
Translations tab folder A–4
Typing translations 3–10

U
Unzipping kits 2–4

V
Viewing resource procedures 3–6

W
Widgets 3–11
Wildcards 3–16
Windows
Glossary 3–14
main 2–2, A–2
Properties 3–8
Word indexing 3–11
Working directory 2–2

Z
Zip files
creating 2–7
installing 2–4