
Corticon Tutorial
Deploying a Progress Corticon
Decision Service inProcess for Java





Copyright

Visit the following page online to see Progress Software Corporation’s current Product Documentation Copyright
Notice/Trademark Legend: https://www.progress.com/legal/documentation-copyright.

Last updated: Corticon 7.2

Updated: 2025/09/05

3Corticon Tutorial: Deploying a Progress Corticon Decision Service inProcess for Java: Version 7.1

https://www.progress.com/legal/documentation-copyright


Corticon Tutorial: Deploying a Progress Corticon Decision Service inProcess for Java: Version 7.14

Copyright



Table of Contents

Tutorial - Deploying a Progress Corticon Decision Service in Process for
Java..............................................................................................................7

Install Corticon components.........................................................................9

Set up the tutorial.........................................................................................11

Create Java classes for the Vocabulary entities.......................................13

Import the JAR file into the Vocabulary.....................................................17

Verify that the Java classes are imported and mapped...........................21

Add the JOM JAR to the package...............................................................23

Package the Project ....................................................................................25

Create the In-Process client app project...................................................27

Write Java Client code to deploy and access the Decision Service.......29

Test the Decision Service............................................................................33

5Corticon Tutorial: Deploying a Progress Corticon Decision Service inProcess for Java: Version 7.1

Contents



Corticon Tutorial: Deploying a Progress Corticon Decision Service inProcess for Java: Version 7.16

Contents



1
Tutorial - Deploying a Progress Corticon
Decision Service in Process for Java

Rule modeling lets you create, analyze, and test your work in a Studio environment, and then deploy them to
a Progress Corticon Server as a Decision Service.

There are several ways you can deploy a Decision Service. You can deploy a Decision Service in-process or
as a Web Service for either Java or .NET. In this tutorial, you will learn how to deploy and access a Decision
Service in-process from a Java client.

Corticon Server is a set of core Java classes that comprises all the functionality required to host and manage
Decision Services. These Java classes can be deployed into an application container together with a Java
application to enable the application to standalone as an in-process server.

To deploy and access a Decision Service from a Java client application, you need to perform the following
tasks:

1. Create Java classes for the Vocabulary entities

2. Import the Java files into the Corticon Studio

3. Package the Ruleflow in Corticon Studio

4. Write Java client code to deploy and access the Decision Service

In this tutorial, you will learn how to perform these tasks.

This tutorial is designed for hands-on use. We recommend that you follow along in your Java editor, and
Corticon Studio, using the instructions and illustrations that are provided.
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About Java
You will use Corticon Studio for Java programming. In the scope of this tutorial, and run the in-process server
project in the Eclipse environment. Eclipse provides solid Java development and runtime functionality, and you
don’t need any additional Java features.

This tutorial uses Corticon 7.1.
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2
Install Corticon components

In this tutorial you will deploy the Cargo sample in process using Corticon Studio and the Java developer
environment that is included in the Eclipse environment that Corticon Studio installed.

The purpose of the Corticon Server for Java in this in-process example is to provide the server libraries that
are used in the in-process server.

To install Corticon components:

1. Download Corticon Studio, and then run it, accepting all defaults.

2. Download Corticon Server, and then run it.

Note: See the Corticon Installation Guide for the requirements and procedures.
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3
Set up the tutorial

1. Choose the Start menu command Progress > Corticon Studio.

2. Choose Help > Samples.

3. On the Samples page, select Tutorial and click Open.
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4. In the Import Projects window, click OK.

The sample rule project opens in Corticon Studio.
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4
Create Java classes for the Vocabulary
entities

The data payloads of the request and response messages that are sent or received by the Java client are in
the form of a collection of Java objects.

You need to create a class for each Vocabulary entity that is used by the rules you want to call. You will create
get and set methods within each class file. Then you will export the code to a JAR file, and place it in a location
where it can be accessed by Corticon Server at run-time.

Switch to the Java Perspective in Corticon Studio
1. Click on the Java option in the top right of your Corticon Studio screen.

If you have not previously opened this perspective, choose:
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2. And then choose Java:

Create Java ‘get’ and ‘set’ methods in a library
You need to create a class for each Vocabulary entity that will be used by the rules you want to call. In this
tutorial, you will create a class for just one entity – Cargo.

1. Click File > New > Java Project.

2. Name the project cargoLibrary.

3. Accept all the default values, and click Finish.

4. In the New module-info.java dialog, click Don't Create:
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5. In the Package Explorer, expand cargoLibrary, right-click on src, and then choose New > Package. Name
the package cargoLibrary, and then click Finish.

6. Right-click on the cargoLibrary package, and then choose New > Class. Name the class Cargo, and then
click Finish. (The class name and the entity name must match exactly, and they are case-sensitive.) The
Java editor opens, ready for your text.

7. Declare the entity’s attributes as variables with the appropriate data type in get and set methods. (The
variable and the attribute names must match exactly, and they are case-sensitive, as shown:

package cargoLibrary;
public class Cargo {

public String container;
public String manifestNumber;
public Boolean needsRefrigeration;
public long volume;
public long weight;

public String getContainer() {
return container;

}

public void setContainer(String container) {
this.container = container;

}

public String getManifestNumber() {
return manifestNumber;

}

public void setManifestNumber(String manifestNumber) {
this.manifestNumber = manifestNumber;

}

public Boolean getNeedsRefrigeration() {
return needsRefrigeration;

}

public void setNeedsRefrigeration(Boolean needsRefrigeration) {
this.needsRefrigeration = needsRefrigeration;

}

public long getVolume() {
return volume;

}

public void setVolume(long volume) {
this.volume = volume;

}

public long getWeight() {
return weight;
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}

public void setWeight(long weight) {
this.weight = weight;

}

}

8. Save the file.

9. Select the project cargoLibrary.

10. Choose Export, and then Java > JAR file.

11. Select cargoLibrary and its related files

12. Name the JAR file Cargo.

13. Save the JAR file at a temporary location. It is a good idea to save it in the project.
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5
Import the JAR file into the Vocabulary

The next step is to map the Java classes and variables you just created to the Vocabulary entities in Corticon
Studio. You need to import the JAR file that you just created.

1. Switch perspective by clicking the Corticon Designer button at the top right of the screen:

2. In the Project Explorer, expand Tutorial > Tutorial-Done, and then open Cargo.ecore.

3. Enable Java Object Mapping by choosing:
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4. On the Java Object Mapping tab added to the Vocabulary root, click METADATA Import:

5. In the Import Java Class Metadata window, select Cargo.jar:

6. Click Next.

7. Select cargoLibrary:

Corticon Tutorial: Deploying a Progress Corticon Decision Service inProcess for Java: Version 7.118

Chapter 5: Import the JAR file into the Vocabulary



8. Click Finish.

9. Save the Vocabulary file.
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6
Verify that the Java classes are imported and
mapped

Once the Java classes and variables have been imported and mapped into the Vocabulary, you can see them
in the Vocabulary. Click on the Cargo entity. You can see the Java properties—Java Package and Java Class
Name. The Java Package name matches the package defined earlier. The Java Class Name is the same as
the entity name.

Click on the manifestNumber attribute. Note that each attribute has the following Java properties—Java Object
Get Method, Java Object Set Method, and Java Object Field Name. The get and set methods were populated
by importing the Java class metadata.
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7
Add the JOM JAR to the package

Before you package the project, you need to add the Java Object class library to the project.

1. Right click on Tutorial, and then choose Properties.

2. In the Properties dialog box, click on Corticon Extensions, and then click Add.

3. Locate and select Cargo.jar:

4. Click Apply and Close.
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8
Package the Project

Now you can compile the project into a Decision Service, ready for deployment.

1. Click on Tutorial, and then select Project > Package and Deploy Decision Services.

2. In the Deployment Target panel, choose Package and save for later deployment.
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3. Click Next.

4. In the Package Ruleflows panel, select the tutorial_example Ruleflow.

5. Edit the Decision Service Name, and change it to Cargo:

6. For the To directory, it is a good idea to save it in the project.

7. Click Finish.
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Create the In-Process client app project

The client is a separate project.

1. Switch to Corticon Studio Java perspective.

2. Choose File > New > Java Project.

3. Name the project myClient_712, and then click Finish.

4. Choose Don't Create on the Create module-info.java dialog.

Add Libraries to the project and the Java Build Path
The JARs in the Corticon Server installation will enable the in-process server’s rule processing engine. While
you could reference the required JARs, adding them into the project will make it clear that the in-process server
is standing on its own. :

1. In the Server installation, navigate to Deploy > Tomcat > 9.

2. Unpack the axis.war file.

3. Navigate to WEB-INF\lib.

4. Copy all the JAR files, and then paste them into the root of myClient_712 project.

5. Remove CcDrivers.jar as it adds a level of complexity not addressed in this tutorial.

6. From [CORTICON_SERVER_WORK_7.1]/license/Server, copy CcLicense.jar (Must be a current,
valid, and unexpired Server license.), and then paste it into the root of myClient_712 project.

7. Copy Cargo.jar, and then paste it into the root of the myClient_712 project.

8. Right-click on myClient_712, choose Properties, and then click Java Build Path.

9. Select the Libraries tab, and then click Add JARs.

10. Add all the JARs in myClient_712 to the Java classpath.
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11. Click OK. The JARs are listed:

12. Click Apply and Close.
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Write Java Client code to deploy and access
the Decision Service

To deploy and access a Decision Service from a Java client, you write Java code that uses Corticon APIs.

1. In the myClient_712 project, choose New > Package. Name the package program, and click Finish.

2. Click on the program package, and then chooseNew >Class. Name the class InvokeDS, and click Finish.
The editor opens for InvokeDS.java.

3. Begin by writing the Java code:

a. In your client program, import the required packages and classes as shown.

package program;

import com.corticon.eclipse.server.core.CcServerFactory;
import com.corticon.eclipse.server.core.ICcServer;
import com.corticon.service.ccserver.*;
import cargoLibrary.*;
import java.util.ArrayList;
import java.util.List;
import java.util.Iterator;
import java.util.Properties;

b. Create a String variable to hold the Decision Service name. Note that the Decision Service name you
provide overrides the name you may have specified earlier, while compiling the Ruleflow.

public class InvokeDS {

private static String decisionServiceName = "Cargo";
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public void callDS(){
}

}

c. Now, write code to create an object of the entity class. In this step, you create an object of the entity
class and populate it with data that you want to test against the Decision Service. In our example, you
will set an input volume of 10 and weight of 1000. You can try various other input combinations, based
on the attributes defined in the rules.

try {
Cargo cargo = new Cargo();
cargo.setWeight(1000);
cargo.setVolume(10);

d. Write code to create an arraylist and add the object to the arraylist.Themethod to send a request message
requires a collection as one of the parameters. So, you must create a collection, such as an arraylist,
and add the entity object to it.

e. In this example, the weight and volume values for Cargo , defined in the Cargo request object, will be
processed and the Cargo’s container variable will be determined by the Decision Service.

List<Cargo> cargoList = new ArrayList<>();
cargoList.add(cargo);

f. Write code to initialize Corticon Server. To do this, you use the ICcServer interface. ICcServer is
implemented by the CcServerFactory class. To instantiate Corticon Server you use a method in
CcServerFactory named getCcServer() to return an object of the type ICcServer as shown in the example.
In the example, the object is assigned to the variable ccServer.

ICcServer server = CcServerFactory.getCcServer();

g. Once you have obtained an object of the type ICcServer, you use it to call the addDecisionService()
method to deploy the Ruleflow. In our example, you will deploy the Cargo.eds file that you packaged
earlier in Corticon Studio. The addDecisionService() method is an overloaded method. However, at
minimum, you must pass three parameters—the Decision Service name, the path to the compiled EDS
file, and a Boolean parameter that specifies whether dynamic reload should be set to true or false. Before
you deploy the decision service, check if the Decision Service is already loaded using an if statement.

Properties p = new Properties();
p.put(ICcServer.PROPERTY_AUTO_RELOAD, false);
if (!server.isDecisionServiceDeployed("Cargo")){

server.addDecisionService(decisionServiceName,"Cargo_v0_16.eds", p);
}

h. Write code to execute the Decision Service. The execute() method accepts two parameters—the Decision
Service name, and the collection that contains the request object. This sends the request object message
to Corticon Server. This message is then processed by the Decision Service that is deployed on the
server. The execute method then updates the Cargo request object in memory and returns rule messages.
You can access the rule messages by creating an object of the type ICcRuleMessages.

ICcRuleMessages msgs = server.execute("Cargo", cargoList);
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i. Next, create a list that will receive the rule messages from the ICcRuleMessages object.

List<ICcRuleMessage> msgList = msgs.getMessages();

j. Write code to iterate through each rule message.

Iterator<ICcRuleMessage> itr = msgList.iterator();
while(itr.hasNext()) {

ICcRuleMessage m = itr.next();
}

k. Now write code to get the rule message’s associated object, and convert the generic object to a Cargo
object.

Object obj = m.getEntityReference();
Cargo x = (Cargo) obj;

l. Write print statements to display the output in the console.

System.out.println("----------");
System.out.println("Cargo weight is "+x.getWeight());
System.out.println("Cargo volume is "+x.getVolume());
System.out.println("Cargo container value is "+x.getContainer());
System.out.println(m.getSeverity());
System.out.println(m.getText());
}

m. Add a catch block for the try block you have used in the code. And finally, write the Java main method.

} catch(Exception e){
System.out.println(e);

}
}

public static void main(String[] args) {
InvokeDS d = new InvokeDS();
d.callDS();

}

}

4. You have now finished writing the Java client code. Save the Java code under an appropriate package and
project name. Here is the complete code used to deploy and access the Decision Service.

package program;
import com.corticon.eclipse.server.core.CcServerFactory;
import com.corticon.eclipse.server.core.ICcServer;
import com.corticon.service.ccserver.*;
import cargoLibrary.*;
import java.util.ArrayList;
import java.util.List;
import java.util.Iterator;
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import java.util.Properties;

public class InvokeDS {

private static String decisionServiceName = "Cargo";

public void callDS(){
try {

Cargo cargo = new Cargo();
cargo.setWeight(1000);
cargo.setVolume(10);
List<Cargo> cargoList = new ArrayList<>();
cargoList.add(cargo);

ICcServer server = CcServerFactory.getCcServer();
Properties p = new Properties();
p.put(ICcServer.PROPERTY_AUTO_RELOAD, false);
if (!server.isDecisionServiceDeployed("Cargo")){

server.addDecisionService(decisionServiceName,"Cargo_v0_16.eds", p); }
ICcRuleMessages msgs = server.execute("Cargo", cargoList);
List<ICcRuleMessage> msgList = msgs.getMessages();
Iterator<ICcRuleMessage>
itr = msgList.iterator();

while(itr.hasNext()) {
ICcRuleMessage m = itr.next();
Object obj = m.getEntityReference();
Cargo x = (Cargo) obj;
System.out.println("----------");
System.out.println("Cargo weight is "+x.getWeight());
System.out.println("Cargo volume is "+x.getVolume());
System.out.println("Cargo container value is " +x.getContainer());
System.out.println(m.getSeverity());
System.out.println(m.getText());

}
} catch(Exception e){

System.out.println(e);
}

}
public static void main(String[] args) {

InvokeDS d = new InvokeDS();
d.callDS();

}
}
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11
Test the Decision Service

Now that you have written the Java client code, you can test it and confirm whether the code accesses the
Decision Service.

1. Copy the Decision Service file, Cargo_v0_16.eds, from the workspace.

2. Paste it into src\program\myClient_712.

3. Run InvokeDS.java.
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The Decision Service updated the container variable based on the values of weight and volume provided
in the request object message. Based on the rules defined for this project in Corticon Studio, for an input
weight of 1000 and volume of 10, the rules respond that a standard container should be used. The Decision
Service is responding to the Java client code and the business rules.

4. Let’s change the value of weight defined in the Java client code to 25000.

try {
Cargo cargo = new Cargo();
cargo.setWeight(25000);
cargo.setVolume(10);

5. Save and run the Java client code.

The rules triggered to prefer a heavyweight container.

The Decision Service is responding to the client code within the Java app.

Congratulations! You have completed this tutorial.

You have created Java Object get and set methods, mapped them to the Vocabulary, packaged the project
as a compiled Decision Service file, and created Java client code to deploy and access the Decision Service.
Finally, you tested the Java client code to confirm that it accesses the Decision Service.

You have created and tested a Corticon Decision Service deployed in-process under Java.
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