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Tutorial - Deploying a Progress Corticon
Decision Service as a Web Service for Java

Once the rules in a Ruleflow are modeled, analyzed and tested, they are ready to be deployed to Progress
Corticon Server as a Decision Service.

There are a number of ways you can deploy a Decision Service. You can deploy Decision Service in-process
or as a Web Service for either Java or .NET. In this tutorial, you will learn how to deploy a Decision Service as
a Web Service for Java.

Corticon Server is a set of core Java classes that comprises all the functionality required to host and manage
Decision Services. These Java classes are deployed on an application server. This tutorial uses the installed
Tomcat application server.

To deploy a Decision Service as a Web Service, you need to perform the following tasks:
1. Prepare Vocabulary for deployment

2. Deploy the Ruleflow as a Decision Service to Corticon Server

3. Test if the Decision Service can be accessed as a Web Service

In this tutorial, you will learn how to perform these tasks.

This tutorial is designed for hands-on use. We recommend that you follow along in Corticon Studio and Corticon
Server, using the instructions and illustrations that are provided.
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Set up the tutorial

Before you work on deploying a Decision Service, you need to set-up your environment for this tutorial.

You must:

1.

Install and start Corticon Studio

2. Install and start Corticon Server
3.
4

. Import a Sample Project into Studio

Install and connect to the Corticon Web Console.

Step 1: Install and start Corticon Studio

First, let’s install the development environment, the Corticon Studio.

o g k~wbdh =

Download and run the Studio installer.

On the Introduction page of the installation wizard, click Next.

On the License Agreement page, select | accept the terms of the License Agreement and click Next.
On the pages that follow, retain the default settings and click Next.

Click Install. When the installation is finished, click Done.

On the Start menu, select Progress > Corticon Studio.

Step 2: Install and start Corticon Server

Now, let’s install the deployment runtime environment, the Corticon Server.

1.
2,

Download and run the Server installer.

On the Introduction page of the installation wizard, click Next.
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Chapter 2: Set up the tutorial

On the License Agreement page, select | accept the terms of the License Agreement and click Next.
On the Corticon Server Install and Work Directory page, retain the default settings and click Next.

On the Choose Server Components page, select Corticon Server for Java, and then click Next.

On the pages that follow, retain the default settings and click Next.

Click Install. When the installation is finished, click Done.

© N o o o

On the Start menu, select Progress > Start Corticon Server.

Note: You will need to use the required Java version and the required Tomcat server, and then tailor them.
See the Corticon Install Guide

Step 3: Install and start Corticon Web Console

Now, let’s install the WebConsole administrative environment, the Corticon WebConsole.
1. Download and run the WebConsole installer.

On the Introduction page of the installation wizard, click Next.

Click Next.

Click Install. When the installation is finished, click Done.

o > 0B

In your browser, use the URL | ocal host : 8080 to connect.

Note: You will need to use the required Java version and the required Tomcat server, and then tailor them.
See the Web Console Installation Guide

Step 4 : Importing a Sample Project into Studio

The Corticon Studio installation includes several sample rule projects. We will use one for this tutorial. To import
the sample:

1. In Studio, choose Help > Samples.

Help
@ Welcome

e

() Help Contents

=",

rd

4 Search

" Samples |
B Tutorials '
" Check for Updates

W Install New Software...

G About Corticon Studio

2. On the Samples page, select Tutorial and click Open.

3. In the Import Projects window, choose Tutorial, and then click OK.
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G Tport
Import Projects —

Following projects will be imported in your workspace,

| Tutorial Select All

Deselect All

@

4. The sample rule project opens in Corticon Studio.
|e orkspace - Corticon 5t .

|Fi|e Edit Mavigate Search Project Run  Window Help

B-HRiGiS - reerD- [ovick Acces] | g |8

— O

[ Project Explorer 52 | 2] Rule Vocabulary = 0 [£2] Welcome 22 = 8
2S ~ = = thy El
L@ Tutorial i} Restore Welcome
Tutorial

| This sample has been
developed from the business
requirement of an airfreight
company. The company loads
cargo of various sizes and
weights into containers, and
then onto its aircraft. For air
safety, the company must
ensure that an aircraft is never
loaded with oversized and
overweight cargo, that will
exceed an aircraft's capacity, A
part of the flight plan involves

= g \rerif'yirjg that no 5afet:l,r or
ents L Rule Messages 23 operational rules are vielated.

| The company wants to
@® Rule Operators 53 = 0 improve the quality and
efficiency of its flight-planning

(= Attribute Operators process by modeling and

(= Entity/Association Operators automating its business rules.
(= General [] Properties &2 Problems [ S |
Tutorial
~
Resource Property Value W
£ >

E Tutorial
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Prepare requests

When a Web Service client sends a request message to a Decision Service that is exposed as a Web Service,
the message contains data enclosed within XML or JSON tags. For this tutorial, our request messages use
JSON and XML.

The JSON request message looks like this:

{
" __metadataRoot": {},
"nane": "Cargo",
"Cbjects": |
{
"vol ume": 10,
"container": null,
"itemAéi ght": 1000,
" __metadata": {
"#type": "Shipment",
"#id": "Cargo_id_1"
}
}
]
}

Copy this code, and then save it as ShipmentPayload.json.

Corticon Tutorial: Deploying a Decision Service as a Web Service for Java: Version 7.2



Chapter 3: Prepare requests

The XML request message looks like this:

<?xm version="1.0" encodi ng="UTF- 8" ?>
<Corti conRequest xm ns="urn: Corticon"
xm ns: xsi ="http://ww. w3. org/ 2001/ XM_Schenma- i nst ance" deci si onServi ceNanme="Car go" >
<Wor kDocumnent s>
<Shi pnent i d="Shi prent _id_1">
<i t em\¢i ght >1000</i t emAéi ght >
<vol une>10</ vol une>
<contai ner xsi:nil="true" />
</ Shi pnent >
</ Wor kDocunent s>
</ Corti conRequest >

Copy this code, and then save it as ShipmentPayload.xml.

14
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Prepare the Vocabulary and mappings

For Corticon to correctly process the request message, you must ensure that XML or JSON tag names map
to entity and attribute names in the Corticon rule Vocabulary.

By default, Corticon Studio specifies the entity or attribute name as the XML Element Name. If XML or JSON
tag names are different from the entity or attribute names, you need to prepare the Vocabulary by manually
mapping them.

Our project Vocabulary looks like this:
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Chapter 4: Prepare the Vocabulary and mappings

i Project Explorer | (Z] Rule Vocabulary 53 = B
4 -
w [2] Cargo
~ = Aircraft

= aircraftType

== maxCargoVolume

= maxCargoWeight

== tailMumber

—£ flightPlan (FlightPlan)
w & Cargo

==| container

= manifestMumber

= volume

= weight

3— flightPlan (FlightPlan)
~ = FlightPlan

= flightNumber

}— aircraft (&ircraft)

£ cargo (Carga)

Notice that the request message contains two tag names ‘Shipment’ and ‘itemWeight' that do not appear in
our Vocabulary. They correspond to the Cargo entity and the Cargo.weight attribute.

You need to prepare the Vocabulary by manually mapping ‘Shipment’ to Cargo and itemWeight to Cargo.weight.

Open the Vocabulary file Cargo.ecore in the Tutorial-Done folder.

Mapping the Vocabulary for JSON requests
1. On the Vocabulary menu, choose Add Document Mapping > Add JSON Mapping.

Vocabulary Window Help
& Add Domain
& Add Entity
Add Attribute > Property Value
weight
Integer
No
Base
Add Datasource >
Datasource Configuration File >
Add Document Mapping > Add XML Mapping
Populate Vocabulary From Datasource... _» Add JSON Mapping
Populate Vocabulary From JSON... Add Java Object Mapping

2. Change the Element Name for the weight attribute in Cargo to itemWeight.

16 Corticon Tutorial: Deploying a Decision Service as a Web Service for Java: Version 7.2



@ *Cargo.ecore *

type filter text

~ U Cargo
> = Aircraft
~ © Cargo
=l container
=l manifestNumber
=l needsRefrigeration
=l volume
=l weight
>~ flightPlan (FlightPlan)
> = FlightPlan

Basic Properties

Property Name Property Value
Attribute Name weight

Data Type Integer
Mandatory No

Mode Base

JSON Properties

JSON Element Name itemWeight

3. Save the file.

You have now prepared the Vocabulary for JSON requests.

Mapping the Vocabulary for XML requests
1. On the Vocabulary menu, choose Add Document Mapping > Add XML Mapping.

Vocabulary Window Help
2 Add Domain
Add Entity

Add Attribute

Add Datasource

Add Document Mapping

Datasource Configuration File

Populate Vocabulary From Datasource...

Populate Vocabulary From JSON...

s

Base Data ... Enum... Constraint Expression
String Yes

Add XML Mapping
Add JSON Mapping
Add Java Object Mapping

2. Click the Cargo entity. In the XML Element Name property, you can see the default name ‘Cargo’ in grey.

=| *CargoPayload.json g *Cargo.ecore &2

w [7] Cargo
= Aircraft

=1 FlightPlan

3. Change the default name by double-clicking the property value and then entering Shipment.

Basic Properties

Property Mame
Entity Marne
Inherits From

XML/ISOM Properties

MNamespace
Element MName

Property Yalue
Cargo

= O

o
Fay

b
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Chapter 4: Prepare the Vocabulary and mappings

[g *Cargo.ecore 32 s
w [ Cargo *  Basic Properties A
= Aircraft Property Name Property Value
v & Carge . Entity Name Cargo
= container Inherits From

= rmanifestMurmber

=] needsRefrigeration
= volume
=] weight

*»

AMLASON Properties

Mamespace
Element Mame [Shipment

W

4. Similarly, change the XML Element Name for the weight attribute in Cargo to itemWeight.

=| *CargoPayload.json (@ *Cargo.ecore i3 - O
v [l Cargo Basic Properties b
=l Aircraft Property Mame Property Value
v & Cargo _ Attribute Name weight
== container Data Type Integer
== manifestMumber Mandatory Mo
= needsRefrigeration Mode Base
== volume HXML/ISON Properties S
= m{aght _ Mamespace
2~ flightPlan (FlightPlan) Elernent Mame itern\Weight
£ FlightPlan

5. Save the file.

You have now prepared the Vocabulary for XML requests.

Mapping the Vocabulary for Java Objects

If you prefer to use Java Objects you have prepared, map them into the Vocabulary.

1. On the Vocabulary menu, choose Add Document Mapping > Add Java Object Mapping.
2. On the Java Object Mapping tab added to the Vocabulary root, click METADATA Import.
3. In the Import Java Class Metadata window, select Car go. j ar .

4. Selectcar golLi br ary, and then click Finish.

5. Save the Vocabulary file.
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Deploy the Decision Service

Now that you have prepared the Vocabulary, you can deploy rules created in Rulesheets, and prepared in a
Ruleflow that uses the Vocabulary. You will package and deploy a Decision Service to Corticon Server.

There are different ways to deploy a Ruleflow to Corticon Server. In this tutorial, you will package the Ruleflow
in a pre-compiled EDS file and then deploy it to Corticon Server using the Web Console.

To learn about other methods of deployment, refer to the Deployment topics in the Corticon Information Hub.

Packaging the Ruleflow into an Decision Service file

Let’s start by packaging the Ruleflow in Corticon Studio into a Decision Service, an EDS file.

1. Open the tutorial_example.erf file, and then click on the tutorial_example box.

Corticon Tutorial: Deploying a Decision Service as a Web Service for Java: Version 7.2
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Chapter 5: Deploy the Decision Service

=| CargoPayload,json [ig Cargo.ecore ‘G “tutonal_example.erf 23 = B
= Palette [
h? I:i'% I‘&Q

= Connection

) E@ Rulesheet
‘e Ruleflow
'i tutorial_example . % Senvice Call-out
=5 Branch
. %8 Subflow
O [terative
E| £ Rule Messages 53 = B
] Properties 23 M = 0O
Rulesheet Activity  MName: |tutu:uria|_examp|e | |:|
Rulesheet: |_a'Tutu:uriaI_a'Tutu:uriaI-DDnaa'Cargn.ers | Browse...

2. The Ruleflow has just one Rulesheet—Cargo.ers—which is renamed to tutorial_example in the Ruleflow.
When you create an EDS file, related Ruleflow, Rulesheet, and the Vocabulary are compiled into a package
that can be deployed to run rules on Corticon Server.

3. To package the Ruleflow, select Project > Package and Deploy Decision Services.
Project Ruletest Run  Window Help

Open Project

Close Project

Validate Project

Package and Deploy Decision Services...
Upgrade Rule Assets..,

&) <«

Properties

4. In the Deployment Target window, choose Package and save for later deployment and click Next.
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e

I Deployment Target
|

| Where de you want to deploy Decision Services? -
() Deploy to a Corticon Server
| Select this option to deploy decision services to running Corticon server and
make them immediately available.
(O Deploy to Corticon Web Console
Select this option to compile and then add decision services to an
application on a web console.
| (®) Package and save for later deployment
Select this option to package decision services into .eds files, which can then
! be deployed with the Corticon Web Console or command line utilities.
< Back MNext » Finish Cancel |

5. In the Package Ruleflows screen:

a. Select the tutorial_example Ruleflow.

b. Click twice on the Decision Service Name, and then type in our preferred name, Car go.

c. Click Finish.
@& Package and Deploy Decision Services O d
Package Ruleflows
Select the ruleflows to be packaged for later deployment -
Select All Deselect All
Decision Service Mame  Version = Database Mode | Ruleflow Root Entities
[Cargo | 4.20 MNone /Tutorial/Tutorial-Done/CargoDecisionService.erf | Cargo
To directory: | Ch\Corticon_Studio_workspaces\workspace_Classic_Samples Browse...
< Back MNext » Cancel

A message indicates that the Ruleflow was successfully compiled into an EDS file and saved in the

location you specified.

Corticon Tutorial: Deploying a Decision Service as a Web Service for Java: Version 7.2
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Chapter 5: Deploy the Decision Service

Compilation Success >

Ruleflows have been successfully compiled into .eds files in
directary
ChCorticon_Studio_workspaces\workspace_Classic_Samples.

We'll deploy the Decision Service to Corticon Server using the Web Console, and then test it there with our
sample requests.

Deploying the Decision Service using the Web Console

The Web Console is the tool for administering and monitoring your Decision Services. Before you launch the
Web Console, ensure that Corticon Server is started.

1. On the Start menu, choose Progress > Start Corticon Server. Wait a minute or so for the server startup
to complete.

2. On the Start menu, choose Progress > Start Web Console.

3. The Web Console login page opens. Enter admin/admin in the User Name/Password fields and click Log

rogress Corticon x -+

' @ localhost8850/corticon/#/sc/

User MName

admin

Password

The Web Console Home page opens.

4. Click on Manage Decision Services.
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Progress Corticon X +
& ® localhost:8850/corticon/#/sc/ o Q '
$ Web Console
= What's New
= What do you want to do?
5
aay
Manage Decision Services View Activity
@ leploy, manage and monitor Corticon ue---- activity history for a Corticon
Decision Services deployme ot -
Manage Servers Manage Users
1anage and monitor Corticon Servers Manage user access to the Cotficon Nyeb
where Decison Services are deployed Console

Manage Batch Configurations

Manage and monitor Corticon Batch
Configurations

Da-not-show this-page-again

5. On the Decision Services page, click + Add Decision Service.

<+ Add Decision Service

6. In the options panel, choose Add a new Decision Service.

Add a new Decision Service

Decision Services can be managed individually or collectively within an Application.

® Adda single Decision Service
Create a new Application and add Decision Services to it

- s
The Add Decision Service dialog box opens:
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Chapter 5: Deploy the Decision Service

Add Decision Service

Decision Service DataSource Advanced Monitored Attributes

When adding a Decision Service you must specify a name, select a server and provide
the EDS file of the Decision Service. Other properties are optional. To add the Decision
Service to an existing Application select "Add to an Existing Application”

Description

The tutorial Cargo sample with XML/JSON mapping of the Cargo entity to
shipment, and the Cargo attribute weight to itemWeight.

EDS File Choose File...
Cargo_v0_16.eds

sServers

local server =

Add to an Existing Application

m Save & Deploy Cancel

7. In the Add Decision Service dialog box:
a. In the Name field, enter Cargo as the name for the Decision Service.

b. Inthe EDS File section, click Choose File. In the window that opens, navigate to the location where you
saved the EDS file and click Open.

c. On the Select Servers pulldown, choose local server.

d. Click Save & Deploy to deploy the Decision Service to the Corticon Server.

Note: The Server's major.minor version must accept the EDS file. Corticon Server will refuse to deploy invalid
versions, and will log or display an error.

When the Decision Service is successfully deployed, you see a green checkmark next to the Decision Service
name:

24
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Decision Services Decision Service: Cargo

il Decision Service : @ Cargo v0.16

You have now successfully deployed the Ruleflow as a Decision Service on Corticon Server.
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Test the Decision Service

After you deploy a Decision Service, you can test the Decision Service to verify that it can be accessed as a
Web Service, and to make sure that the Vocabulary has been properly prepared. The Corticon Web Console
lets you send an XML or JSON request to invoke the deployed Decision Service.

1. On the Decision Service page for Cargo, click Test Execution.

Decision Services Decision Service: Cargo

Decision Service : @ Cargo v0.16 [# Edit & Undeploy P Test Execution <[> WSDL O Delete

The tutorial Cargo sample with XML/JSON mapping of the Cargo entity to Shipment, and the Cargo attribute weight to itemWeight.

¥ General

Servers: @ (ocal server Execution Count: 0

Deployed: Sep 23, 2020 2:41:58 PM Failure Count: 0

Effactive: Average Time: 0 milliseconds
Expires: Rule Count: 4

Version Label: Last Execution Time: Not Yet Executed
Auto Reload: Yes

Maximum Pool Size: 1

Message Style: Auto-detect

2. On the Test Execution page, click Choose File. Let’s try the JSON request first.
3. Locate the JSON request file in the project. The Request Section is now populated.
4. Click Execute.
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Test Execute: Cargo
Request Type
(&) REST/|SON ' SOAP/MXML

Request

Response

{

__metadataRoot™: {},

"Cargo_id_1",
hing <= 20,000 kiles must be packaged in a standard container.”,

"Frype": "#RuleMessage”

__metadata”: {
"#rype": "#RuleMessages'

version™: "0.16"

name": "Carge”,
Objects™:

"wolume": 10,
"container™ "standard”,

etadata”

e": "Shipment”,
"#id": "Carge_id_1"

3

"itemWeight": 1000

majarVersion™ "0"
minorYersion": "16"

You can see the Response field is now populated with a JSON-formatted response message.

5. Now click Choose Request File again to select the XML file you edited. Then click Execute.
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Test Execute: Cargo

Server

ocalhost:8850/axis-
Choose Request File Choose File...
ShipmentPayload.xm

Request Type

REST/JSON @ SOAP/XML

Request

Response

<?xml version="1.0" enceding="UTF-8"7>«<CorticonResponse xmins="urm:Corticon’
decisionServiceName="Cargo" decisicnServiceTargetVersion="0L16">

<WaorkDocuments>
<Shipment id="Shipment_id_1">
<containersstandard<fcontainer>
<itermWeight>1000</itemWeight=
avolume=10</valumes
</Shipment>

rkDocuments>

<severity=Info</severity>
<text>Cargo weighing &= 20,000 kilos must be packaged in a standard container.</text>

P Execute

£ Back

Notice that the request and the response messages contain the terms Shipment and itemWeight. Corticon
translated the Shipment and itemWeight tags in the request message to Cargo and Cargo.weight in the
Vocabulary, and, after processing, translated the results back to Shipment and itemWeight.

You have now successfully tested the deployed Decision Service.

Congratulations! You have completed this tutorial.

You have prepared the Vocabulary for deployment, deployed a Ruleflow as a Decision Service to Corticon

Server, and confirmed that the Decision Service can be accessed as a Web Service.
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