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Tutorial - Deploying a Progress Corticon
Decision Service in Process for Java

Rule modeling lets you create, analyze, and test your work in a Studio environment, and then deploy them to
a Progress Corticon Server as a Decision Service.

There are several ways you can deploy a Decision Service. You can deploy a Decision Service in-process or
as a Web Service for either Java or .NET. In this tutorial, you will learn how to deploy and access a Decision
Service in-process from a Java client.

Corticon Server is a set of core Java classes that comprises all the functionality required to host and manage
Decision Services. These Java classes can be deployed into an application container together with a Java
application to enable the application to standalone as an in-process server.

To deploy and access a Decision Service from a Java client application, you need to perform the following
tasks:

1. Create Java classes for the Vocabulary entities

2. Import the Java files into the Corticon Studio

3. Package the Ruleflow in Corticon Studio

4. Write Java client code to deploy and access the Decision Service
In this tutorial, you will learn how to perform these tasks.

This tutorial is designed for hands-on use. We recommend that you follow along in your Java editor, and
Corticon Studio, using the instructions and illustrations that are provided.
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Chapter 1: Tutorial - Deploying a Progress Corticon Decision Service in Process for Java

About Java

You will use Corticon Studio for Java programming. In the scope of this tutorial, and run the in-process server
project in the Eclipse environment. Eclipse provides solid Java development and runtime functionality, and you
don’t need any additional Java features.

This tutorial uses Corticon 7.0.

8 Corticon Tutorial: Deploying a Progress Corticon Decision Service inProcess for Java: Version 7.0



Install Corticon components

In this tutorial you will deploy the Cargo sample in process using Corticon Studio and the Java developer
environment that is included in the Eclipse environment that Corticon Studio installed.

The only purpose of the Corticon Server for Java in this in-process example is to provide the server libraries
that are used in the in-process server.

To install Corticon components:
1. Download Corticon Studio, then run it, accepting all defaults.
2. Download Corticon Server, then run it.

3. Choose just the component Corticon Server for Java:
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Chapter 2: Install Corticon components

Progress Corticon Server 6.3.%x = *

Choose Server Components

ﬁ.' PFOg ress’ Corticon Server for Java

Install the Corticon Server for Java, Tomcat application server,
and samples. Select this when deploying Corticon as a Java
wehsenvice, or in-process in a Java application.

Progress’

Corticon
Install the Corticon Server for .NET and samples. Select this when
Sr_'\l"\hf"[:,r deploying Corticon as a webservice to IS or in-process in a .NET
== application.

[ corticon Server for .NET

[] corticon Web Console

Install the Corticon Web Console, and Tomcat application server.
Select this to centrally manage and monitor your Corticon Server
deployments through your web browser.

Cancel Previous

Choose the Java Runtime Environment

The Java 11 version bundled with Corticon Studio is not automatically detected by Studio when building Java
projects. You need to add the JRE for use in building Java projects.

To build a Java project in Corticon Studio:

Select Window > Preferences.

In the Preferences window, select Java > Installed JREs.
In the Installed JREs panel, select Add.

Choose Standard VM, and then click Next.

In the JRE Definition window, click Directory.

I

Select the St udi o/ JRE folder in your Corticon install directory, and then click Select Folder. Your selection
is displayed in the JRE Definition window, as illustrated:
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& addIRE O ¥

JRE Definition 7o
Specify attributes for a JRE %\_/

JRE home: | C\ProgresshCorticon 7.0WStudioJRE | | Directory... |
JRE name: | Studio |
Default VM arguments: | | Variables...

JRE system libraries:
@ ChProgress\Corticon 7.00Studic\JRENibYjrt-fs.jar

Add External JARs...

< Back Mext = Finizh Cancel

7. Click Finish.
8. In the Installed JREs panel, select the JRE you just added, and then click Apply and Close.

The JRE is added to your workspace for use in building Java projects.
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Chapter 2: Install Corticon components
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Set up the tutorial

1. Choose the Start menu command Progress > Corticon Studio.
2. Choose Help > Samples.

3. On the Samples page, select Tutorial and click Open.
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Chapter 3: Set up the tutorial

¢

| File Edit Mavigate Search Project Run  Window Help
| 5‘ [£2] welcome 32 A ==
% |

| & |

Samples

This page contains references to samples of the Progress products that you installed on this instance of Eclipse. You can filter these references and group them by
product, topic, and level of complexity.

E

Vi

clipse and Other Samples

All Samples Complexity Tutorial

Training - This sample provides a structured
dictionary for a few business processes. It
contains all the necessary business terms and
maps the relationships between the terms
using the business rules.

This sample has been developed from the business requirement of an airfreight

company. The company loads cargo of various sizes and weights into containers, and
then onto its aircraft. For air safety, the company must ensure that an aircraft is never
loaded with oversized and overweight cargo, that will exceed an aircraft's capacity. A

part of the flight plan involves verifying that no safety or operational rules are violated.
The company wants to improve the quality and efficiency of its flight-planning process
by modeling and automating its business rules.

Tutorial - This sample describes the business
requirement of an airfreight company.

Intermediate

EDC Database Connectivity - This sample
demonstrates the use of Corticon's Enterprize
Database Connectivity (EDC) for accessing a
database from rules.

Reference ID : Not available

GrandParent - This sample has been developed

| to simulate a parent-child relationship or a list Features : Progress Corticon Studio v

» Progress’

4. In the Import Projects window, click OK.
I

¢

Import Projects —

Following projects will be imported in your workspace,

: Tutorial Select All
Deselect All
| |
|
|
'

The sample rule project opens in Corticon Studio.

For details, see the following topics:

* Choose the JRE
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Choose the JRE

Choose the JRE

Note: The Java 11 version bundled with Corticon Studio is not automatically detected by Studio when building
Java projects.

You need to add the JRE for use in building Java projects.

To build a Java project in Corticon Studio:

1. Select Window > Preferences.
2. In the Preferences window, select Java > Installed JREs.
3. In the Installed JREs panel, select Add.
4. Choose Standard VM, and then click Next.
5. In the JRE Definition window, click Directory.
6. Selectthe St udi o/ JRE folder in your Corticon install directory, and then click Select Folder, Your selection
is displayed in the JRE Definition window, as illustrated:
& EditJRE O e
JRE Definition =
(i) You selected a JRE that this version of Eclipse JOT does not yet support fully, %h
Some of the features may not work as expected, o
JRE home: | C\Progress\Corticon 6.445tudic®JRE | Directory...
JRE name: | Studio |
Default VM arguments: | | Variables..,
JRE system libraries:
e ChProgresshCorticon 8.45Studic®JREN by rt-fs.jar Add External JARs...
Javadoc Location...
Source Attachment...
External annotations...
Remowve
Up
Down
Restore Default
Cancel
7. Click Finish

8. In the Installed JREs panel, select the JRE you just added, and then click Apply and Close.
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Chapter 3: Set up the tutorial

The JRE is added to your workspace for use in building Java projects.
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Create Java classes for the Vocabulary
entities

The data payloads of the request and response messages that are sent or received by the Java client are in
the form of a collection of Java objects.

You need to create a class for each Vocabulary entity that is used by the rules you want to call. You will create
get and set methods within each class file. Then you will export the code to a JAR file, and place it in a location
where it can be accessed by Corticon Server at run-time.

Switch to the Java Perspective in Corticon Studio

1. Click on the Java option in the top right of your Corticon Studio screen.

B RE
Bl TaskList {Java | = O

If you have not previously opened this perspective, choose:

Corticon Tutorial: Deploying a Progress Corticon Decision Service inProcess for Java: Version 7.0

17



Chapter 4: Create Java classes for the Vocabulary entities

Window
Mew Window
Appearance H]
Show View ¥
Perspective H]
Mavigation ¥
Preferences

Open Perspective

Customize Perspective...

Save Perspective As..,
Reset Perspective..,
Close Perspective

Close All Perspectives

H] Q Corticon Designer

Other...

2. And then choose Java:

e Open Perspective

Q Corticon Designer (default)

3 Debug

ar] Git

%’Java

5 Java Browsing

EJJEUE Type Hierarchy
') Planning

“P=Plug-in Development

I Resource

£ Team Synchronizing

Use F2 to display the description for a selected perspective,

Cancel

Create Java ‘get’ and ‘set’ methods in a library

You need to create a class for each Vocabulary entity that will be used by the rules you want to call. In this

tutorial, you will create a class for just one entity — Cargo.

1. Click File > New > Java Project.

2. Name the project cargoLibrary.

3. Accept all the default values, and click Finish.

4. In the New module-info.java dialog, click Don't Create:
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& New module-info.java O X
Create module-info.java
Create a new module-info java file o

Maodule narme: || |

I |
| Create | Don't Create

5. Inthe Package Explorer, expand cargoLibrary, right-click on src, and then choose New > Package. Name

the package cargoLibrary, and then click Finish.

6. Right-click on the cargoLibrary package, and then choose New > Class. Name the class Cargo, and then
click Finish. (The class name and the entity name must match exactly, and they are case-sensitive.) The

Java editor opens, ready for your text.

7. Declare the entity’s attributes as variables with the appropriate data type in get and set methods. (The
variable and the attribute names must match exactly, and they are case-sensitive, as shown:

package cargolLi brary;
public class Cargo {
public String container;
public String manifest Nunber;
publ i ¢ Bool ean needsRefrigeration;
public | ong vol une;
public | ong weight;

public String getContainer() {
return container;

}

public void setContainer(String container) {
t hi s. contai ner = contai ner;

}

public String getManifestNunber() {
return mani f est Nunber;

}

public void setManifestNunber (String manifest Nunber) {
t his. mani f est Nunber = mani f est Nunber;

}

publ i ¢ Bool ean get NeedsRefrigeration() ({
return needsRefrigeration;

}

public void set NeedsRefrigeration(Bool ean needsRefrigeration) {
this.needsRefrigerati on = needsRefrigeration;

}

public | ong getVolume() ({
return vol une;

}

public void setVolume(l ong vol une) {
this.volunme = vol une;

}

public |ong getWight() {
return wei ght;

Corticon Tutorial: Deploying a Progress Corticon Decision Service inProcess for Java: Version 7.0
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Chapter 4: Create Java classes for the Vocabulary entities

}

public void setWight(long weight) {
thi s. wei ght = wei ght;
}

8. Save the file.

9. Select the project cargoLibrary.

10. Choose Export, and then Java > JAR file.
11. Select cargoLibrary and its related files
12 Name the JAR file Cargo.

13. Save the JAR file at a temporary location. It is a good idea to save it in the project.

20
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Import the JAR file into the Vocabulary

The next step is to map the Java classes and variables you just created to the Vocabulary entities in Corticon
Studio. You need to import the JAR file that you just created.

1. Switch perspective by clicking the Corticon Designer button at the top right of the screen:
=11

2. In the Project Explorer, expand Tutorial > Tutorial-Done, and then open Car go. ecor e.

3. Enable Java Object Mapping by choosing:

Corticon Tutorial: Deploying a Progress Corticon Decision Service inProcess for Java: Version 7.0
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Chapter 5: Import the JAR file into the Vocabulary

Vocabulary  Run  Window Help

¢ ] Add Domain |
] Add Entity
Add Attnibute >

Add Association...

.. Find References

Refactor...

Add Datasource ¥

Datasource Configuration File -

Add Docurment Mapping » Add XML/ISOMN Mapping
Populate Vocabulary From Datasource Add Java Object Mapping

Set to Read Only
Vo Show Vocabulary Details

Localize...

IE] Report..

Export W5DL...
Export X50...

4. On the Java Object Mapping tab added to the Vocabulary root, click METADATA Import:
Custom Data Types | Java Object Mapping

METADATA MAPPIMNG
|'£| Import || 2 Clear » Clear m Delete

5. In the Import Java Class Metadata window, select Car go. j ar:
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& Import Java Class Metadata O
Java Metadata Sources
Select JARs or classes to be imported, plus any JARs your classes depend on.
From directony: | ChCorticon_Studic_workspaces\workspace_Classic_Samples\ Tutorial  ~ Browse...
[m] .= Tutorial L] E .project
L] EECargn.emre
| £ Cargo.jar
Select All Deselect All
< Back Finish Cancel
6. Click Next.
7. Select cargolLibrary:
@ Import Java Class Metadata O ey

Java Package Selection
Select the packages to be imported.

[] =3 cargoLibrary

Select All Deselect All

@ < Back Next >

8. Click Finish.
9. Save the Vocabulary file.
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Chapter 5: Import the JAR file into the Vocabulary
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6

Verify that the Java classes are imported and

mapped

Once the Java classes and variables have been imported and mapped into the Vocabulary, you can see them
in the Vocabulary. Click on the Cargo entity. You can see the Java properties—Java Package and Java Class
Name. The Java Package name matches the package defined earlier. The Java Class Name is the same as

the entity name.

=21 Cargo
m- Aircraft
= G
..... ==| container
..... == manifestMumber
..... == needsRefrigeration
----- == volume
..... m=| weight
----- P~ flightPlan (FlightPlan)
B-i= FlightPlan

]

Basic Properties

Property Mame
Entity Marne

Inherts From

Property Value
Cargo

b

Java Object Properties

lava Package
lava Class Mame

Click on the manifestNumber attribute. Note that each attribute has the following Java properties—Java Object
Get Method, Java Object Set Method, and Java Object Field Name. The get and set methods were populated

by importing the Java class metadata.

Corticon Tutorial: Deploying a Progress Corticon Decision Service inProcess for Java: Version 7.0
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Chapter 6: Verify that the Java classes are imported and mapped

=-Fl Cargo
E Adrcraft
EE Cargo

----- = container

----- =] ritestiumber

----- = needsRefrigeration

----- = weight
----- 2= flightPlan (FlightPlan)

4]

&= FlightPlan

Basic Properties

Property Mame
Attribute Name
Data Type
Mandatory
Mode

Java Object Properties

Java Object Get Method
Java Object Set Method
Java Object Field Marne

Property Value
manifesthlumber
String

Yes

Base

o

b
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Add the JOM JAR to the package

Before you package the project, you need to add the Java Object class library to the project.

1. Right click on Tutorial, and then choose Properties.
2. In the Properties dialog box, click on Corticon Extensions, and then click Add.

3. Locate and select Car go. j ar:

Project References
Run/Debug Settings

Apply and Close

& Properties for Tutorial O X
type filter text | Corticon Extensions 8
Resource
Builders Add extended operator and service call-out JAR files used in this project.
Corticon Extensions The selected JAR files will be packaged inside EDS files produced by the Package and Deploy wizard.
Project Matures =| ChCorticon_Studio_workspaces\workspace_Classic_Samplesh\ Tutorial\Cargo.jar Add

Add From Project...
Remowve
Select All

Clear All

Cancel

4. Click Apply and Close.
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Chapter 7: Add the JOM JAR to the package
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Package the Project

Now you can compile the project into a Decision Service, ready for deployment.
1. Click on Tutorial, and then select Project > Package and Deploy Decision Services.

2. In the Deployment Target panel, choose Package and save for later deployment.

Corticon Tutorial: Deploying a Progress Corticon Decision Service inProcess for Java: Version 7.0
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Chapter 8: Package the Project

e

I Deployment Target
|

| Where de you want to deploy Decision Services? -

() Deploy to a Corticon Server
Select this option to deploy decision services to running Corticon server and

make them immediately available.

(O Deploy to Corticon Web Console
Select this option to compile and then add decision services to an

application on a web console.

| (®) Package and save for later deployment
Select this option to package decision services into .eds files, which can then

! be deployed with the Corticon Web Console or command line utilities.

< Back Mest > Finich Cancel

3. Click Next.
4. In the Package Ruleflows panel, select the tutorial_example Ruleflow.

5. Edit the Decision Service Name, and change it to Cargo:

€& Package and Deploy Decision Services O >

Package Ruleflows

Select the ruleflows to be packaged for later deployment LA
Select All Deselect All
Decision Service Name  Version = Database Mode Ruleflow Root Entities
[Cargo | 420 Mone /Tutorial/Tutorial-Done/CargoDecisionService.erf | Cargo
To directory: | ChCorticon_Studio_workspaces\workspace_IP_tutorial Browse...

< Back Mext » Cancel

6. For the To directory, it is a good idea to save it in the project.
7. Click Finish.
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Create the In-Process client app project

The client is a separate project.

1.

Switch to Corticon Studio Java perspective.

2. Choose File > New > Java Project.
3.
4

. Choose Don't Create on the Create module-info.java dialog.

Name the project myClient, and then click Finish.

Add Libraries to the project and the Java Build Path

The JARs in the Corticon Server installation will enable the in-process server’s rule processing engine. While
you could reference the required JARs, adding them into the project will make it clear that the in-process server
is standing on its own. Actually, once the Server JARs have been added to the client project, the Server could
be uninstalled:

1.

Copy the following JAR files from Corticon Server’s [ CORTI CON_HOVE] / Server /| i b:

e ant_launcher.jar

* CcConfig.jar

* CcDrivers.jar (Could be skipped as there are no database connections in the example.)
* CcExtensions.jar

* Ccl 18nBundl es. j ar

* Cclicense.jar (Mustbe a current, valid, and unexpired license.)

e CcServer.jar
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Chapter 9: Create the In-Process client app project

* CcThirdPartyJars.jar

Paste them into the root of myClient project.
Copy Cargo.jar, and then paste into the root of the myClient project.
Right-click on myClient, choose Properties, and then click Java Build Path.
Select the Libraries tab, and then click Add JARs.
Add all the JARs in myClient to the Java classpath:
£ AR selection | x

o a0 ~ w b

Choose the archives to be added to the build path:

| type filter text

=2 cargolibrary
v (22 myClient
[ .settings
=| .classpath
=| .project
| & ant-launcher-1.10.12jar
| & Cargo.jar
| % CcConfig,jar
| & CcDrivers jar
| £ CcExtensions,jar
| %[ Ccl18nBundles jar
| £ Celicense.jar
| £ CcServerjar
| &| CcThirdPartylars.jar
L Tutorial

7. Click OK.
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& Properties for myClient O

| type filter text Java Build Path e
Resource o
Builders (® Source [ Projects =\ Libraries % Order and Export @ Module Dependencies
Java Build Path JARs and class folders on the build path:
Java Code ;tyle v ¥, Modulepath Add JARs...
Java Compiler =) JRE System Library [JavaSE-11]
Javadec Location v & Classpath Add External JAF
lava Editor

oo ant-launcher-1.10.12,jar - myClient o
Project Natures o Cargojar - myClient Add Variable..
Project References =

s CoConfig.ar - myClient Add Library...
Run/Debug Settings .

fs CeDrivers.jar - myClient
g CeExtensions,jar - myClient Add Class Folde
e Cel18nBundles.jar - myClient
= € ) n un_ EsJar rjny ten Add External Class
s Celicensejar - myClient
fey CeServer,jar - myClient

(s CcThirdPartylars.jar - myClient Sl

Remove

Migrate JAR File

A

Apply and Close Can

8. Click Apply and Close.
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10

Write Java Client code to deploy and access
the Decision Service

To deploy and access a Decision Service from a Java client, you write Java code that uses Corticon APlIs.

1. In the myClient project, choose New > Package. Name the package program, and click Finish.

2. Click on the program package, and then choose New > Class. Name the class InvokeDS, and click Finish.

The editor opens for InvokeDS.java.
3. Begin by writing the Java code:

a. Inyour client program, import the required packages and classes as shown.

package program

i mport comcorticon. eclipse.server.core. CcServer Factory;
i mport comcorticon. eclipse.server.core. | CcServer;

i mport comcorticon. service.ccserver.*;

i mport cargolLibrary. *;

import java.util.Arraylist;

i mport java.util.List;

import java.util.lterator;

import java.util.Properties;

b. Create a String variable to hold the Decision Service name. Note that the Decision Service name you
provide overrides the name you may have specified earlier, while compiling the Ruleflow.

public class InvokeDS {

private static String decisionServiceNane = "Cargo";

Corticon Tutorial: Deploying a Progress Corticon Decision Service inProcess for Java: Version 7.0
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Chapter 10: Write Java Client code to deploy and access the Decision Service

public void callDS(){

}
}

c. Now, write code to create an object of the entity class. In this step, you create an object of the entity
class and populate it with data that you want to test against the Decision Service. In our example, you
will set an input volume of 10 and weight of 1000. You can try various other input combinations, based
on the attributes defined in the rules.

try {
Cargo cargo = new Cargo();
car go. set Wi ght (1000) ;
car go. set Vol une( 10);

d. Write code to create an arraylist and add the object to the arraylist. The method to send a request message
requires a collection as one of the parameters. So, you must create a collection, such as an arraylist,
and add the entity object to it.

e. In this example, the weight and volume values for Cargo , defined in the Cargo request object, will be
processed and the Cargo’s container variable will be determined by the Decision Service.

Li st <Car go> cargoLi st = new ArrayList<>();
cargoli st. add(car go);

f. Write code to initialize Corticon Server. To do this, you use the ICcServer interface. ICcServer is
implemented by the CcServerFactory class. To instantiate Corticon Server you use a method in
CcServerFactory named getCcServer() to return an object of the type ICcServer as shown in the example.
In the example, the object is assigned to the variable ccServer.

| CcServer server = CcServerFactory. get CcServer();

g. Once you have obtained an object of the type ICcServer, you use it to call the addDecisionService()
method to deploy the Ruleflow. In our example, you will deploy the Cargo.eds file that you packaged
earlier in Corticon Studio. The addDecisionService() method is an overloaded method. However, at
minimum, you must pass three parameters—the Decision Service name, the path to the compiled EDS
file, and a Boolean parameter that specifies whether dynamic reload should be set to true or false. Before
you deploy the decision service, check if the Decision Service is already loaded using an if statement.

Properties p = new Properties();
p. put (1 CcServer. PROPERTY_AUTO RELCAD, fal se);
if (!server.isDecisionServiceDepl oyed("Cargo")){
server. addDeci si onSer vi ce(deci si onServi ceNane, "Cargo_v0_16. eds", p);
}

h. Write code to execute the Decision Service. The execute() method accepts two parameters—the Decision
Service name, and the collection that contains the request object. This sends the request object message
to Corticon Server. This message is then processed by the Decision Service that is deployed on the
server. The execute method then updates the Cargo request object in memory and returns rule messages.
You can access the rule messages by creating an object of the type ICcRuleMessages.

| CcRul eMessages nsgs = server.execute("Cargo", cargolist);
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i. Next, create a list that will receive the rule messages from the ICcRuleMessages object.

Li st <l CcRul eMessage> nsgLi st = nsgs. get Messages();

j- Write code to iterate through each rule message.

Iterator<lCcRul eMessage> itr = nsgList.iterator();
while(itr.hasNext()) {
| CcRul eMessage m = itr.next();

}

k. Now write code to get the rule message’s associated object, and convert the generic object to a Cargo
object.

Obj ect obj = mgetEntityReference();
Cargo x = (Cargo) obj;

. Write print statements to display the output in the console.

Systemout.printin("---------- ");

Systemout. println("Cargo weight is "+x.getWight());
Systemout.println("Cargo volune is "+x.getVolunme());
Systemout.println("Cargo container value is "+x.getContainer());
Systemout. println(mgetSeverity());

System out. printl n(m getText());

}

m. Add a catch block for the try block you have used in the code. And finally, write the Java main method.

} catch(Exception e){
Systemout.println(e);
}

}

public static void main(String[] args) {
I nvokeDS d = new | nvokeDS();
d.cal I DS() ;

4. You have now finished writing the Java client code. Save the Java code under an appropriate package and
project name. Here is the complete code used to deploy and access the Decision Service.

package program

i mport comcorticon. eclipse.server.core. CcServer Factory;
i mport comcorticon. eclipse.server.core. | CcServer;

i mport comcorticon. service.ccserver.*;

i mport cargolibrary. *;

import java.util.ArraylList;

import java.util.List;

import java.util.lterator;
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i mport java.util.Properties;
public class InvokeDS {
private static String decisionServiceNane = "Cargo";

public void callDS(){
try {
Cargo cargo = new Cargo();
car go. set Wi ght (1000) ;
car go. set Vol une( 10);
Li st <Cargo> cargolLi st = new ArrayList<>();
cargolLi st. add(cargo);

| CcServer server = CcServerFactory. get CcServer();
Properties p = new Properties();
p. put (1 CcServer. PROPERTY_AUTO RELQAD, fal se);
if (!server.isDecisionServiceDepl oyed("Cargo")){
server. addDeci si onServi ce(deci si onServi ceNang, "Cargo_v0_16. eds", p); }
| CcRul eMessages nsgs = server.execute("Cargo", cargolist);
Li st <l CcRul eMessage> nsgLi st = msgs. get Messages();
It erator<l CcRul eMessage>
itr = negList.iterator();

while(itr.hasNext()) {
| CcRul eMessage m = itr.next();
oj ect obj = mgetEntityReference();
Cargo x = (Cargo) obj;
Systemout.printin("---------- ");
Systemout. println("Cargo weight is "+x.getWight());
Systemout.println("Cargo volune is "+x.getVolune());
Systemout.println("Cargo contai ner value is " +x.getContainer());
System out. println(mgetSeverity());
Systemout. println(m getText());

} catch(Exception e){
Systemout.println(e);

public static void main(String[] args) {
I nvokeDS d = new | nvokeDS();
d.cal | DS();
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Test the Decision Service

11

Now that you have written the Java client code, you can test it and confirm whether the code accesses the

Decision Service.

1. Copy the Decision Service file, Cargo_v0_16.eds, from the workspace.

2. Paste it into src\program\myClient.

3. Run InvokeDS.java.

[% Package Explorer X

= cargoLibrary

v [ src
w f} cargolibrary
[7] Cargo.java
W ','7‘J myClient
v B src
v [ program
1] InvokeDS.java
=| Cargo_vD_16.eds

=, Referenced Libraries

5| ant-launcher-1.10.12 jar

g Cargo.jar

5| CcConfig.jar

5| CcDrivers jar

| CcExtensions.jar

5| Ccl1@nBundles jar

g5 Celicensejar

5| CcServerjar

5| CcThirdPartylars.jar
1§ Tutorial

= O [ Cargojava i@ Cargo.ecore 7] InvokeDS. java Bl Consale ¥

=

=\ JRE System Library [JavaSE-11]

=\ JRE System Library [JavaSE-11]

g
&

<terminated> InvokeDS [Java Application] C:\Progress\Corticon 7.005tudic'JRE\bin\javaw.exe (Jul 10, 202

% % | B bf & [E]&]

Frogress Corticon Server : 7.8.8.8 -b13136

CeServerSandbox location @

Loglevel : INFO

Logpath :

Cargo
Cargo
Cargo
Info

Cargo

weight is 1leea
volume is 1@
container value is standard

weighing <= 28,888 kilos must be packaged in a standard container.

= 0
- o

C:/Corticon_Studic_workspaces/workspace_IP tutoria.

C:/Corticon_Studic_workspaces/workspace IP_tutorial/myClient/logs

The Decision Service updated the container variable based on the values of weight and volume provided
in the request object message. Based on the rules defined for this project in Corticon Studio, for an input
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weight of 1000 and volume of 10, the rules respond that a standard container should be used. The Decision

Service is responding to the Java client code and the business rules.

4. Let’s change the value of weight defined in the Java client code to 25000.

try {
Cargo cargo = new Cargo();
car go. set Wi ght (25000) ;
car go. set Vol une( 10) ;

5. Save and run the Java client code.

11| InvokeDS.java Info

=| Cargo_v(_16.eds

=, Referenced Libraries

g&| ant-launcher-1.10.12 jar

g5 Cargo,jar

g&| CcConfigjar

| CcDrivers jar

5| Ccbxtensions.jar

g5 Ccl18nBundles jar

g5 Cclicense,jar

5| CcServerjar

g CcThirdPartylars jar
8 Tutorial

Cargo weighing <= 28,880 kilos must be packaged in a standard container.

[ Package Explorer = B [ Cargojava ¢ Cargo.ecore [7] InvokeDS java Bl Console % = B8
5% 8 X% BEDEE -0
v iz cargolibrary <terminated> InvokeDS [Java Application] C:\ProgresshCerticon 7.005tudic'JRE\bin'javaw.exe (Jul 10, 202
=), JRE System Library [JavaSE-11] Frogress Corticon Server : 7.8.8.8 -bl3186
v [ src CcServerSandbox location @ C:i/Corticon_Studic_workspaces/workspace_IP_tuteria
v 8 cargolibrary Loglevel : INFO
; Logpath : C:/Corticon_Studic_workspaces/workspace IP_tutorial/myClient/legs
|1| Cargojava e
oy =1} myClient Cargo weight is l@ee
v B src Cargo volume is 1@
v [ program Carge container value is standard

The rules triggered to prefer a heavyweight container.
The Decision Service is responding to the client code within the Java app.

Congratulations! You have completed this tutorial.

You have created Java Object get and set methods, mapped them to the Vocabulary, packaged the project
as a compiled Decision Service file, and created Java client code to deploy and access the Decision Service.

Finally, you tested the Java client code to confirm that it accesses the Decision Service.

You have created and tested a Corticon Decision Service deployed in-process under Java.
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