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Tutorial - Deploying a Progress Corticon
Decision Service as a Web Service for Java

Once the rules in a Ruleflow are modeled, analyzed and tested, they are ready to be deployed to Progress
Corticon Server as a Decision Service.

There are a number of ways you can deploy a Decision Service. You can deploy Decision Service in-process
or as a Web Service for either Java or .NET. In this tutorial, you will learn how to deploy a Decision Service as
a Web Service for Java.

Corticon Server is a set of core Java classes that comprises all the functionality required to host and manage
Decision Services. These Java classes are deployed on an application server. This tutorial uses the installed
Tomcat application server.

To deploy a Decision Service as a Web Service, you need to perform the following tasks:
1. Prepare Vocabulary for deployment

2. Deploy the Ruleflow as a Decision Service to Corticon Server

3. Test if the Decision Service can be accessed as a Web Service

In this tutorial, you will learn how to perform these tasks.

This tutorial is designed for hands-on use. We recommend that you follow along in Corticon Studio and Corticon
Server, using the instructions and illustrations that are provided.
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Set up the tutorial

Before you work on deploying a Decision Service, you need to set-up your environment for this tutorial.
You must:

1. Install and start Corticon Studio

2. Install and start Corticon Server

3. Import a Sample Project into Studio

Step 1: Install and start Corticon Studio

First, let’s install the development environment, the Corticon Studio.

Download and run the Studio installer.

On the Introduction page of the installation wizard, click Next.

On the License Agreement page, select | accept the terms of the License Agreement and click Next.
On the pages that follow, retain the default settings and click Next.

Click Install. When the installation is finished, click Done.

o g k~wbdh =

On the Start menu, select Progress > Corticon Studio.

Step 2: Install and start Corticon Server

Now, let’s install the deployment runtime environment, the Corticon Server.
1. Download and run the Server installer.

2. On the Introduction page of the installation wizard, click Next.

3. On the License Agreement page, select | accept the terms of the License Agreement and click Next.
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Chapter 2: Set up the tutorial

On the Corticon Server Install and Work Directory page, retain the default settings and click Next.

On the Choose Server Components page, select Corticon Server for Java and Corticon Web Console
and click Next.

On the pages that follow, retain the default settings and click Next.

7. Click Install. When the installation is finished, click Done.

8.

On the Start menu, select Progress > Start Corticon Server.

Step 3 : Importing a Sample Project into Studio

The Corticon Studio installation includes several sample rule projects. We will use one for this tutorial. To import
the sample:

1. In Studio, choose Help > Samples.

Help

23]

Welcome

Help Contents

Search

Samples |
Tutonals |
Check for Updates

Install Mew Software...

About Corticon Studio

2. On the Samples page, select Tutorial and click Open.

3.

In the Import Projects window, choose Tutorial, and then click OK.

10
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G Tport
Import Projects —

Following projects will be imported in your workspace,

| Tutorial Select All

Deselect All

@

4. The sample rule project opens in Corticon Studio.
|e orkspace - Corticon 5t .

|Fi|e Edit Mavigate Search Project Run  Window Help

B-HRiGiS - reerD- [ovick Acces] | g |8

— O

[ Project Explorer 52 | 2] Rule Vocabulary = 0 [£2] Welcome 22 = 8
2S ~ = = thy El
L@ Tutorial i} Restore Welcome
Tutorial

| This sample has been
developed from the business
requirement of an airfreight
company. The company loads
cargo of various sizes and
weights into containers, and
then onto its aircraft. For air
safety, the company must
ensure that an aircraft is never
loaded with oversized and
overweight cargo, that will
exceed an aircraft's capacity, A
part of the flight plan involves

= g \rerif'yirjg that no 5afet:l,r or
ents L Rule Messages 23 operational rules are vielated.

| The company wants to
@® Rule Operators 53 = 0 improve the quality and
efficiency of its flight-planning

(= Attribute Operators process by modeling and

(= Entity/Association Operators automating its business rules.
(= General [] Properties &2 Problems [ S |
Tutorial
~
Resource Property Value W
£ >

E Tutorial
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Prepare requests

When a Web Service client sends a request message to a Decision Service that is exposed as a Web Service,
the message contains data enclosed within XML or JSON tags. For this tutorial, our request messages use
JSON and XML.

The JSON request message looks like this:

{
" __metadataRoot": {},
"nane": "Cargo",
"Cbjects": |
{
"vol ume": 10,
"container": null,
"itemAéi ght": 1000,
" __metadata": {
"#type": "Shipment",
"#id": "Cargo_id_1"
}
}
]
}

Copy this code, and then save it as ShipmentPayload.json.
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The XML request message looks like this:

<?xm version="1.0" encodi ng="UTF- 8" ?>
<Corti conRequest xm ns="urn: Corticon"
xm ns: xsi ="http://ww. w3. org/ 2001/ XM_Schenma- i nst ance" deci si onServi ceNanme="Car go" >
<Wor kDocumnent s>
<Shi pnent i d="Shi prent _id_1">
<i t em\¢i ght >1000</i t emAéi ght >
<vol une>10</ vol une>
<contai ner xsi:nil="true" />
</ Shi pnent >
</ Wor kDocunent s>
</ Corti conRequest >

Copy this code, and then save it as ShipmentPayload.xml.

14

Corticon Tutorial: Deploying a Decision Service as a Web Service for Java: Version 6.3




Prepare the Vocabulary and mappings

For Corticon to correctly process the request message, you must ensure that XML or JSON tag names map
to entity and attribute names in the Corticon rule Vocabulary.

By default, Corticon Studio specifies the entity or attribute name as the XML Element Name. If XML or JSON
tag names are different from the entity or attribute names, you need to prepare the Vocabulary by manually
mapping them.

Our project Vocabulary looks like this:
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i Project Explorer | (Z] Rule Vocabulary 53 = B
4 -
w [2] Cargo
~ = Aircraft

= aircraftType

== maxCargoVolume

= maxCargoWeight

== tailMumber

—£ flightPlan (FlightPlan)
w & Cargo

==| container

= manifestMumber

= volume

= weight

3— flightPlan (FlightPlan)
~ = FlightPlan

= flightNumber

}— aircraft (&ircraft)

£ cargo (Carga)

Notice that the request message contains two tag names ‘Shipment’ and ‘itemWeight' that do not appear in
our Vocabulary. They correspond to the Cargo entity and the Cargo.weight attribute.

You need to prepare the Vocabulary by manually mapping ‘Shipment’ to Cargo and itemWeight to Cargo.weight:
1. Open the Vocabulary file Cargo.ecore in the Tutorial-Done folder.

2. On the Vocabulary menu, choose Add Document Mapping > Add XML/JSON Mapping.
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Vocabulary
%1 Add Domain
%= Add Entity
Add Attribute >

Add Association...

Find References

Refactor...

Add Datascurce )
Datasource Configuration File »
Add Document Mapping »

Populate Vocabulary From Datasource

Add XMLASOMN Mapping
Add Java Object Mapping

Set to Read Only
Vo Show Vocabulary Details

Localize...

2 Report..

Export WSDL...
Export X50...

|=| *CargoPayload.json (g *Cargo.ecore i3

v (2] Cargo Basic Properties
Eﬁurcraf't Property Mame
= Cargo Entity Name
&= FlightPlan Inherits From

AML/ISON Properties

Mamespace
Elernent Mame

[g *Cargo.ecore 32

v [ Cargo *  Basic Properties
=l Aircraft Property Name
v & Carge _ Entity Name
== container Inherits From

=| manifestMlumber

[=| needsRefrigeration
= volume
= weight

Mamespace
Elernent Mame

4. Change the default name by double-clicking the property value and then entering Shipment.

AML/SON Properties

3. Click the Cargo entity. In the XML Element Name property, you can see the default name ‘Cargo’ in grey.

= O
Property Value
Cargo
= B
Property Value
Cargo
[Shiprment
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Chapter 4: Prepare the Vocabulary and mappings

5. Similarly, change the XML Element Name for the weight attribute in Cargo to itemWeight.

=| *CargoPayload.json EE *Cargo.ecore i3 - b
v [l Cargo Basic Properties b
= Aircraft Property Mame Property Value
v (= Cargo _ Attribute Mame weight
== container Data Type Integer
= manifestMumber Mandatory Mo
= needsRefrigeration Mode Base
= volume HML/ISON Properties &
= wje'ght _ Mamespace
3~ flightPlan (FlightPlan) Element Name itemWeight
=1 FlightPlan

6. Save the file.

You have now prepared the Vocabulary.
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Deploy the Decision Service

Now that you have prepared the Vocabulary, you can deploy rules created in Rulesheets, and prepared in a
Ruleflow that uses the Vocabulary. You will package and deploy a Decision Service to Corticon Server.

There are different ways to deploy a Ruleflow to Corticon Server. In this tutorial, you will package the Ruleflow
in a pre-compiled EDS file and then deploy it to Corticon Server using the Web Console.

To learn about other methods of deployment, refer to the Deployment topics in the Corticon Information Hub.

Packaging the Ruleflow into an Decision Service file

Let’s start by packaging the Ruleflow in Corticon Studio into a Decision Service, an EDS file.

1. Open the tutorial_example.erf file, and then click on the tutorial_example box.

Corticon Tutorial: Deploying a Decision Service as a Web Service for Java: Version 6.3
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=| CargoPayload,json [ig Cargo.ecore ‘G “tutonal_example.erf 23 = B
= Palette [
h? I:i'% I‘&Q

= Connection

) E@ Rulesheet
‘e Ruleflow
'i tutorial_example . % Senvice Call-out
=5 Branch
. %8 Subflow
O [terative
E| £ Rule Messages 53 = B
] Properties 23 M = 0O
Rulesheet Activity  MName: |tutu:uria|_examp|e | |:|
Rulesheet: |_a'Tutu:uriaI_a'Tutu:uriaI-DDnaa'Cargn.ers | Browse...

2. The Ruleflow has just one Rulesheet—Cargo.ers—which is renamed to tutorial_example in the Ruleflow.
When you create an EDS file, related Ruleflow, Rulesheet, and the Vocabulary are compiled into a package
that can be deployed to run rules on Corticon Server.

3. To package the Ruleflow, select Project > Package and Deploy Decision Services.
Project Ruletest Run  Window Help

Open Project

Close Project

Validate Project

Package and Deploy Decision Services...
Upgrade Rule Assets..,

&) <«

Properties

4. In the Deployment Target window, choose Package and save for later deployment and click Next.
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¢

I Deployment Target
|

| Where do you want to deploy Decision Services? M-
() Deploy to a Corticon Server
' Select this option to deploy decision services to running Corticon server and
make them immediately available.
() Deploy to Corticon Web Console
Select this option to compile and then add decision services to an
agpplication on g web console.
! (®) Package and save for later deployment
Select this option to package decision services into .eds files, which can then
[ be deployed with the Corticon Web Console or command line utilities,
< Back Mext » Finish Cancel

5. In the Package Ruleflows screen:
a. Select the tutorial_example Ruleflow.

b. Click twice on the Decision Service Name, and then type in our preferred name, Car go.

c. Click Finish.

Corticon Tutorial: Deploying a Decision Service as a Web Service for Java: Version 6.3
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Chapter 5: Deploy the Decision Service

] Package and Deploy Decision Services

Package Ruleflows
Select the ruleflows to be packaged for later deployment

Select All Deselect All
Decision Service Mame Version Databacze Mode | Ruleflow
[Cargo | 0.16 MNone STutorial/Tuterial-Dene/tuterial_example.erf
To directory: | C:\}Nnrkspace Browse...

= Back Mest > Cancel

A message indicates that the Ruleflow was successfully compiled into an EDS file and saved in the
location you specified.

Compilation Success *

Ruleflows have been successfully compiled into .eds files in directory
Chworkspace.

We’ll deploy the Decision Service to Corticon Server using the Web Console, and then test it there with our
sample requests.

Deploying the Decision Service using the Web Console

The Web Console is the tool for administering and monitoring your Decision Services. Before you launch the
Web Console, ensure that Corticon Server is started.

1. On the Start menu, choose Progress > Start Corticon Server. Wait a minute or so for the server startup
to complete.

2. On the Start menu, choose Progress > Start Web Console.

3. The Web Console login page opens. Enter admin/admin in the User Name/Password fields and click Log
in.
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Progress Corticon * -+

O @ localhost:3850/corticon/#/sc/

User Name

admin

Password

The Web Console Home page opens.

4. Click on Manage Decision Services.
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= O pas
Progress Corticon X +
& ® localhost:8850/corticon/#/sc/ o Q '
$ Web Console
= What's New
= What do you want to do?
5
aay
Manage Decision Services View Activity
@ leploy, manage and monitor Corticon ue---- activity history for a Corticon
Decision Services deployme ot -
Manage Servers Manage Users
1anage and monitor Corticon Servers Manage user access to the Cotficon Nyeb
where Decison Services are deployed Console

Manage Batch Configurations

Manage and monitor Corticon Batch
Configurations

Da-not-show this-page-again

5. On the Decision Services page, click + Add Decision Service.

<+ Add Decision Service

6. In the options panel, choose Add a new Decision Service.

Add a new Decision Service

Decision Services can be managed individually or collectively within an Application.

® Adda single Decision Service
Create a new Application and add Decision Services to it

- s
The Add Decision Service dialog box opens:
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Add Decision Service

Decision Service DataSource Advanced Monitored Attributes

When adding a Decision Service you must specify a name, select a server and provide
the EDS file of the Decision Service. Other properties are optional. To add the Decision
Service to an existing Application select "Add to an Existing Application”

Description

The tutorial Cargo sample with XML/JSON mapping of the Cargo entity to
shipment, and the Cargo attribute weight to itemWeight.

EDS File Choose File...
Cargo_v0_16.eds

sServers

local server =

Add to an Existing Application

m Save & Deploy Cancel

7. In the Add Decision Service dialog box:

a. In the Name field, enter Cargo as the name for the Decision Service.

b. Inthe EDS File section, click Choose File. In the window that opens, navigate to the location where you
saved the EDS file and click Open.

c. On the Select Servers pulldown, choose local server.
d. Click Save & Deploy to deploy the Decision Service to the Corticon Server.

When the Decision Service is successfully deployed, you see a green checkmark next to the Decision Service
name:

Decision Services Decision Service: Cargo

Mol Decision Service : @ Cargo v0.16

You have now successfully deployed the Ruleflow as a Decision Service on Corticon Server.
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Test the Decision Service

After you deploy a Decision Service, you can test the Decision Service to verify that it can be accessed as a
Web Service, and to make sure that the Vocabulary has been properly prepared. The Corticon Web Console
lets you send an XML or JSON request to invoke the deployed Decision Service.

1. On the Decision Service page for Cargo, click Test Execution.

Decision Services Decision Service: Cargo

Decision Service : @ Cargo v0.16 [# Edit & Undeploy P Test Execution <[> WSDL O Delete

The tutorial Cargo sample with XML/JSON mapping of the Cargo entity to Shipment, and the Cargo attribute weight to itemWeight.

¥ General

Servers: @ (ocal server Execution Count: 0

Deployed: Sep 23, 2020 2:41:58 PM Failure Count: 0

Effactive: Average Time: 0 milliseconds
Expires: Rule Count: 4

Version Label: Last Execution Time: Not Yet Executed
Auto Reload: Yes

Maximum Pool Size: 1

Message Style: Auto-detect

2. On the Test Execution page, click Choose File. Let’s try the JSON request first.
3. Locate the JSON request file in the project. The Request Section is now populated.
4. Click Execute.
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Test Execute: Cargo
Request Type
(&) REST/|SON ' SOAP/MXML

Request

Response

{

__metadataRoot™: {},

"Cargo_id_1",
hing <= 20,000 kiles must be packaged in a standard container.”,

"Frype": "#RuleMessage”

__metadata”: {
"#rype": "#RuleMessages'

version™: "0.16"

name": "Carge”,
Objects™:

"wolume": 10,
"container™ "standard”,

etadata”

e": "Shipment”,
"#id": "Carge_id_1"

3

"itemWeight": 1000

majarVersion™ "0"
minorYersion": "16"

You can see the Response field is now populated with a JSON-formatted response message.

5. Now click Choose Request File again to select the XML file you edited. Then click Execute.
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Test Execute: Cargo

Server

ocalhost:8850/axis-
Choose Request File Choose File...
ShipmentPayload.xm

Request Type

REST/JSON @ SOAP/XML

Request

Response

<?xml version="1.0" enceding="UTF-8"7>«<CorticonResponse xmins="urm:Corticon’
decisionServiceName="Cargo" decisicnServiceTargetVersion="0L16">

<WaorkDocuments>
<Shipment id="Shipment_id_1">
<containersstandard<fcontainer>
<itermWeight>1000</itemWeight=
avolume=10</valumes
</Shipment>

rkDocuments>

<severity=Info</severity>
<text>Cargo weighing &= 20,000 kilos must be packaged in a standard container.</text>

P Execute

£ Back

Notice that the request and the response messages contain the terms Shipment and itemWeight. Corticon
translated the Shipment and itemWeight tags in the request message to Cargo and Cargo.weight in the
Vocabulary, and, after processing, translated the results back to Shipment and itemWeight.

You have now successfully tested the deployed Decision Service.

Congratulations! You have completed this tutorial.

You have prepared the Vocabulary for deployment, deployed a Ruleflow as a Decision Service to Corticon

Server, and confirmed that the Decision Service can be accessed as a Web Service.
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