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Tutorial - Deploying a Progress Corticon
Decision Service in Process for Java

Rule modeling lets you create, analyze, and test your work in a Studio environment, and then deploy them to
a Progress Corticon Server as a Decision Service.

There are several ways you can deploy a Decision Service. You can deploy a Decision Service in-process or
as a Web Service for either Java or .NET. In this tutorial, you will learn how to deploy and access a Decision
Service in-process from a Java client.

Corticon Server is a set of core Java classes that comprises all the functionality required to host and manage
Decision Services. These Java classes can be deployed into an application container together with a Java
application to enable the application to standalone as an in-process server.

To deploy and access a Decision Service from a Java client application, you need to perform the following
tasks:

1. Create Java classes for the Vocabulary entities

2. Import the Java files into the Corticon Studio

3. Package the Ruleflow in Corticon Studio

4. Write Java client code to deploy and access the Decision Service
In this tutorial, you will learn how to perform these tasks.

This tutorial is designed for hands-on use. We recommend that you follow along in your Java editor, and
Corticon Studio, using the instructions and illustrations that are provided.
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Chapter 1: Tutorial - Deploying a Progress Corticon Decision Service in Process for Java

About Java

You will use Corticon Studio for Java programming. In the scope of this tutorial, and run the in-process server
project in the Eclipse environment. Eclipse provides solid Java development and runtime functionality, and you
don’t need any additional Java features.
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Install Corticon 6.0 components

In this tutorial we will deploy the “Cargo” sample in process using Corticon Studio and the Java developer
environment that is included in the Eclipse environment that Corticon Studio installed.

The only purpose of the Corticon Server for Java in this in-process example is to provide the server libraries
that are used in the in-process server.

To install Corticon 6.0 components:
1. Download Corticon Studio 6.0, then run it, accepting all defaults.
2. Download Corticon Server 6.0, then run it.

3. Choose just the component Corticon Server for Java:
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Chapter 2: Install Corticon 6.0 components

Progress Corticon Server 6.0.0.0 = >

3 Progress

Progress’
Corticon”

Server

Cancel Previous
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Set up the tutorial

1. Choose the Start menu command Progress > Corticon 6.0 Studio.
2. Choose Help > Samples.

3. On the Samples page, select Tutorial and click Open.
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Chapter 3: Set up the tutorial

¢

File Edit Mawigate Search Project Run  Window Hel
| g ) p
| E @Welcc:me =

=

| &

Samples

This page contains references to samples of the Progress products that you installed on this instance of Eclipse. You c:
product, topic, and level of complexity.

View Eclipse and Other Samples

All Samples Complexity Tutorial

Training - This sample provides a structured A
dictionary for a few business processes. It
contains all the necessary business terms and

This sample has been developed from the business rec
company. The company loads cargo of various sizes al

maps the relationships between the terms then cmtcf its airc:riaft. For air safetgff, the company m!.lst
using the business rules. loaded with oversized and overweight cargo, that will e

) _ _ ) part of the flight plan involves verifying that no safety o
Tutorial - This sample describes the business The company wants to improve the quality and efficien

e by modeling and automating its business rules.

Intermediate

EDC Database Connectivity - This sample
demonstrates the use of Corticon's Enterprise
Database Connectivity (EDC) for accessing a
database from rules. Reference ID : Mot available

GrandParent - This sample has been developed

[ to simulate a parent-child relationship or a list Features - Progress Corticon Studio

3 Progress:

4. In the Import Projects window, click OK.
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Import Projects
Following projects will be imported in your workspace, ; ;
-
|
Tutorial Select All
Deselect All

The sample rule project opens in Corticon Studio.
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Chapter 3: Set up the tutorial
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Create Java classes for the Vocabulary
entities

The data payloads of the request and response messages that are sent or received by the Java client are in
the form of a collection of Java objects.

You need to create a class for each Vocabulary entity that is used by the rules you want to call. We will create
get and set methods within each class file. Then we will export the code to a JAR file, and place it in a location
where it can be accessed by Corticon Server at run-time.

Switch to the Java Perspective in Corticon Studio

1. Click on the Java option in the top right of your Corticon Studio screen.

=t | E: %" Quick Access
E] TaskLlist { java } = B

If you have not previously opened this perpective, choose:
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Chapter 4: Create Java classes for the Vocabulary entities

Window
Mew Window
Appearance H
Show View H
Perspective » Open Perspective > Q Corticon Designer
Mavigation H Customize Perspective... Other...
Preferences Save Perspective As...

Reset Perspective...
Close Perspective

Close All Perspectives

2. And then choose Java:

& Open Perspective O ey

Q Corticon Designer (default)
7g'?'lﬁliihs_'l::lug

lerm Git

%JJava

E:;JJaxra Browsing

T_'gj.la*.ra Type Hierarchy

) Planning

“=Plug-in Development

I Resource

EYTeam Synchranizing

Use F2 to display the description for a selected perspective.

Create Java ‘get’ and ‘set’ methods in a library

You need to create a class for each Vocabulary entity that will be used by the rules you want to call. In this
tutorial, we will create a class for just one entity — Cargo.

1. Click File > New > Java Project.
2. Name the project cargoLibrary.

3. Accept all the default values, and click Finish.
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4. In the Package Explorer, expand cargoLibrary, right-click on sre, and then choose New > Package. Name

the package cargoLibrary.

5. Right-click on the cargoLibrary package, and then choose New > Class. Name the package Cargo. (The
class name and the entity name must match exactly, and they are case-sensitive.)The java editor opens,

ready for your text.

6. Declare the entity’s attributes as variables with the appropriate data type in get and set methods. (The
variable and the attribute names must match exactly, and they are case-sensitive, as shown:

package cargolLibrary;

public class Cargo {
public String container;
public String manifestNumber;
public Boolean needsRefrigeration;
public long volume;
public long weight;

public String getContainer () {
return container;

}

public void setContainer (String container) {
this.container = container;

}

public String getManifestNumber () {
return manifestNumber;

}

public void setManifestNumber (String manifestNumber) {
this.manifestNumber = manifestNumber;

}

public Boolean getNeedsRefrigeration() {
return needsRefrigeration;

}

public void setNeedsRefrigeration (Boolean needsRefrigeration) {
this.needsRefrigeration = needsRefrigeration;

}

public long getVolume () {
return volume;

}

public void setVolume (long volume) {
this.volume = volume;

}

public long getWeight () {
return weight;

}

public void setWeight (long weight) {
this.weight = weight;
}

7. Save the file.
8. Select the project cargoLibrary.
9. Choose File > Export, and then Java > JAR file.

10. Select cargoLibrary and its related files

Corticon Tutorial: Tutorial: Deploying a Progress Corticon Decision Service in Process for Java: Version
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Chapter 4: Create Java classes for the Vocabulary entities

11. Name the JAR file Cargo.

12 Save the JAR file at a temporary location. It is a good idea to save it in the project.
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Import the JAR file into the Vocabulary

The next step is to map the Java classes and variables you just created to the Vocabulary entities in Corticon
Studio. You need to import the JAR file that you just created.

1. Switch perspective by clicking the Corticon Designer button at the top right of the screen:
=11

2. In the Project Explorer, expand Tutorial > Tutorial-Done, and then open Cargo.ecore.

3. Enable Java Object Mapping by choosing:
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Chapter 5: Import the JAR file into the Vocabulary

Vocabulary Run  Window Help
¢ ] AddDomain
v Add Entity
Add Attribute »

Add Association...

Find References

Refactor...
Add Datasocurce -
Datasource Configuration File *

o

Add Document Mapping Add XML/ISON Mapping

Set to Read Only Add Java Object Mapping

Vo Show Vocabulary Details
Localize...

=] Report...
Export W5DL...
Export X50...

4. On the Java Object Mapping tab added to the Vocabulary root, click METADATA Import:
Custom Data Types | Java Object Mapping

METADATA MAPPIMNG
m Import || 2 Clear » Clear E Delete

5. In the Import Java Class Metadata window, select Cargo.jar:
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¢ Import Java Class Metadata

Java Metadata Sources

Select JARs or classes to be imported, plus any JARs your classes depend on.

From directony: | Ch_B0x\workspace

V| | Browse...

> (W] (= workspace

[] £ Cargo Shipment Testxml
[] £ cargo Shipment Testtxml
|£ Cargo.jar

L] @ exported,json

O] El outxml

L] E tuterial_example_ v0_16.eds

SelectAll | | DeselectAll |

® < Back

6. Click Next.
7. Select cargolLibrary:

e Import Java Class Metadata

Java Package Selection
Select the packages to be imported.

O >

[«] £ cargolibrary

Select Al | Deselect Al

@

Next > Finish | = Cancel

8. Click Finish.
9. Save the Vocabulary file.
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Chapter 5: Import the JAR file into the Vocabulary
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6

Verify that the Java classes are imported and

mapped

Once the Java classes and variables have been imported and mapped into the Vocabulary, you can see them
in the Vocabulary. Click on the Cargo entity. You can see the Java properties—Java Package and Java Class
Name. The Java Package name matches the package we defined earlier. The Java Class Name is the same

as the entity name.

=21 Cargo
m- Aircraft
= G
..... ==| container
..... == manifestMumber
..... == needsRefrigeration
----- == volume
..... m=| weight
----- P~ flightPlan (FlightPlan)
B-i= FlightPlan

]

Basic Properties

Property Mame
Entity Marne

Inherts From

Property Value
Cargo

b

Java Object Properties

lava Package
lava Class Mame

Click on the manifestNumber attribute. Note that each attribute has the following Java properties—Java Object
Get Method, Java Object Set Method, and Java Object Field Name. The get and set methods were populated

by importing the Java class metadata.
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Chapter 6: Verify that the Java classes are imported and mapped

=-Fl Cargo
§ Adrcraft
EE Cargo

----- = container

----- =] ritestiumber

----- = needsRefrigeration

----- = weight
----- 7~ flightPlan (FlightPlan)

&= FlightPlan

Basic Properties

Property Mame
Attribute Name
Data Type
Mandatory
Mode

Java Object Properties

Java Object Get Method
Java Object Set Method
Java Object Field Marne

Property Value
manifesthlumber
String

Yes

Base

o

b
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Add the JOM JAR to the package

Before we package the project, we need to add the Java Object class library to the project.
1. Right click on Tutorial, and then choose Project > Properties.

Project  Vocabulary Run  Window Help
Open Project
Close Project
ng  Build All Ctrl+B

Build Project
Build Working Set >

Clean...

Build Automatically

Validate Project
Package and Deploy Decision Services...

Upgrade Rule Assets..,

& iy «

Properties

2. In the Properties dialog box, click on Corticon Extensions, and then click Add to locate the Cargo.jar.
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Chapter 7: Add the JOM JAR to the package

K>

type filter text Corticon Extensions =l
Resource
Builders Add extended operator and service call-out JAR files used in this project.
Corticon Extensions The selected JAR files will be packaged inside EDS files produced by the Package and Deploy wizar
Project Natures [=| Ch_elx\workspace\Cargo.jar | Ad
Project References
Run/Debug Settings Add Fron
Task Repository
Ren
Sele
Clez
Ir:?:' Apply and Close G
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Package the Project

Now we can compile the project into a Decision Service, ready for deployment.
1. Click on Tutorial, and then select Project > Package and Deploy Decision Services.

Project Ruleflow Run  Window Help
Open Project

Close Project

oy Build All Ctrl+B
Build Project
Build Working Set H
Clean...

Build Automatically

Validate Project
Package and Deploy Decision Services...

Upgrade Rule Assets...

& <«

Properties

=r

2. In the Deployment Target panel, choose Package and save for later deployment.
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Chapter 8: Package the Project

¢

I Deployment Target
|

Where do you want to deploy Decision Services? -

() Deploy to a Corticon Server
Select this option to deploy decision services to running Corticon server and

make them immediately available.

() Deploy to Corticon Web Console
Select this option to compile and then add decision services to an

agpplication on g web console.

(®) Package and save for later deployment
Select this option to package decision services into .eds files, which can then

be deployed with the Corticon Web Console or command line utilities,

< Back Mext = Finish Cancel |

3. Click Next.

4.,

In the Package Ruleflows panel, select the tutorial_example Ruleflow.

28

Corticon Tutorial: Tutorial: Deploying a Progress Corticon Decision Service in Process for Java: Version



¢

| Package Ruleflows
Select the ruleflows to be packaged for later deployment

Select All Dezelect All
Decizsion Service Mame Verzion Databasze Mode | Ruleflow
tutorial_example 0.6 Mone fTutorial/Tuterial-Doneftuterial_example.erf
To directory: | Ch_&0dworkspace Browse...

Mext = Finish Cance

5. Edit the Decision Service Name, and change it to Cargo
6. Click Finish.
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Chapter 8: Package the Project
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Create the In-Process client app project

The client is a separate project.
1. Switch to Corticon Studio Java perspective.
2. Choose File > New > Java Project.

3. Name the project App, and then click Finish.
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Chapter 9: Create the In-Process client app project
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10

Add Libraries to the project and the Java
Build Path

The JARs in the Corticon Server installation will enable the in-process server’s rule processing engine. While
we could reference the required JARs, adding them into the project will make it clear that the in-process server
is standing on its own. Actually, once the Server JARs have been added to the client project, the Server could
be uninstalled:

1. Copy the following JAR files from Corticon Server’s [CORTICON HOME]/Server/lib:
* ant launcher.jar
®* CcConfig.jar
* CcExtensions.jar
® (CcIl8nBundles.jar
® Cclicense.jar
®* CcServer.jar

®* CcThirdPartyJars.jar
2. Paste them into the root of App Project.

3. Copy Cargo.jar, and then paste into the root of the App Project.
4. Right-click on App, choose Properties, and the click Java Build Path.

Corticon Tutorial: Tutorial: Deploying a Progress Corticon Decision Service in Process for Java: Version
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Chapter 10: Add Libraries to the project and the Java Build Path

type filter et

Resource

Builders

Java Build Path
Java Code Style
Java Compiler
Java Editor
Javadoc Location
Project Matures
Project References
Run/Debug Settings
Task Repository

'
@

Java Build Path

(* Source 1% Projects ®i Libraries "% Order and Export

Build class path order and exported entries:
(Exported entries are contributed to dependent projects)

(] =\ JRE System Library [JavaSE-1.8]
(W] (8 App/src

Top

Bottom

Select All

Deselect All

Apply and Close

C

5. Select the Libraries tab, and then click Add JARs.
6. Add all the JARs in the App to the Java classpath:

34
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Choose the archives to be added to the build path:

[ | type filter text

v 22 App
[= .settings
= .classpath

[l [

Jproject
[£| ant-launcher jar
[£| Cargo.jar
[£: CcConfig.jar
[£: Cchxtensions.jar
[£] Ccl@nBundles.jar
[£| Cclicensejar
[£| Ccherverjar
[£: CcThirdPartylars.jar
=2 cargolibrary

g Tuterial

7. Click OK, and then click Apply and Close.
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11

Write Java Client code to deploy and access
the Decision Service

To deploy and access a Decision Service from a Java client, you write Java code that uses Corticon APlIs.

1.
2
3.
4

. Let’s begin writing the Java code:

In the App project, choose New > Package. Name the package program.

. Click on the program package, and then choose New > Class. Name the class InvokeDS.

The editor opens for InvokeDS.java.

In your client program, begin by importing the required packages and classes as shown.

package program;

import
import
import
import
import
import
import
import

com.corticon.eclipse.server.core.CcServerFactory;
com.corticon.eclipse.server.core.ICcServer;
com.corticon.service.ccserver. *;

cargolLibrary.*;

Jjava.
Jjava.
Jjava.
java.

util

.ArrayList;
util.
util.
util.

List;
Iterator;
Properties;

5. Next, create a String variable to hold the Decision Service name. Note that the Decision Service name you
provide overrides the name you may have specified earlier, while compiling the Ruleflow.

public class InvokeDS {

private static String decisionServiceName = "Cargo";

Corticon Tutorial: Tutorial: Deploying a Progress Corticon Decision Service in Process for Java: Version
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Chapter 11: Write Java Client code to deploy and access the Decision Service

public void callDS() {
}
}

Now, write code to create an object of the entity class. In this step, you create an object of the entity class
and populate it with data that you want to test against the Decision Service. In our example, we will set an
input volume of 10 and weight of 1000. You can try various other input combinations, based on the attributes
defined in the rules.

try {
Cargo cargo = new Cargo();
cargo.setWeight (1000) ;
cargo.setVolume (10) ;

Write code to create an arraylist and add the object to the arraylist. The method to send a request message
requires a collection as one of the parameters. So, you must create a collection, such as an arraylist, and
add the entity object to it.

In this example, the weight and volume values for Cargo , defined in the Cargo request object, will be
processed and the Cargo’s container variable will be determined by the Decision Service.

List<Cargo> cargolList = new ArrayList<>();
cargoList.add (cargo) ;

. Write code to initialize Corticon Server.To do this, you use the ICcServer interface. ICcServer is implemented

by the CcServerFactory class.To instantiate Corticon Server you use a method in CcServerFactory named
getCcServer() to return an object of the type ICcServer as shown in the example. In the example, the object
is assigned to the variable ccServer.

ICcServer server = CcServerFactory.getCcServer () ;

10. Once you have obtained an object of the type ICcServer, you use it to call the addDecisionService() method

1.

to deploy the Ruleflow.In our example, we will deploy the Cargo.eds file that we packaged earlier in Corticon
Studio.The addDecisionService() method is an overloaded method. However, at minimum, you must pass
three parameters—the Decision Service name, the path to the compiled EDS file, and a Boolean parameter
that specifies whether dynamic reload should be set to true or false. Before you deploy the decision service,
check if the Decision Service is already loaded using an ‘if’ statement.

Properties p = new Properties();

p.put (ICcServer.PROPERTY AUTO RELOAD, false);

if (!server.isDecisionServiceDeployed ("Cargo")) {
server.addDecisionService (decisionServiceName, "Cargo v0 16.eds", p);

}

Write code to execute the Decision Service.The execute() method accepts two parameters—the Decision
Service name, and the collection that contains the request object.This sends the request object message
to Corticon Server. This message is then processed by the Decision Service that is deployed on the server.

38
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The execute method then updates the Cargo request object in memory and returns rule messages. You
can access the rule messages by creating an object of the type ICcRuleMessages.

ICcRuleMessages msgs = server.execute ("Cargo", cargolist);

12 Next, create a list that will receive the rule messages from the ICcRuleMessages object.

List<ICcRuleMessage> msglist = msgs.getMessages();

13. Write code to iterate through each rule message.

Iterator<ICcRuleMessage> itr = msglist.iterator();
while (itr.hasNext ()) {
ICcRuleMessage m = itr.next();

}

14. Now write code to get the rule message’s associated object, and convert the generic object to a Cargo
object.

Object obj = m.getEntityReference();
Cargo x = (Cargo) obj;

15. Write print statements to display the output in the console.

System.out.println
System.out.println
System.out.println
System.out.println
System.out.println
System.out.println

"Cargo weight is "+x.getWeight());

"Cargo volume is "+x.getVolume ());

"Cargo container value is "+x.getContainer());
m.getSeverity());

m.getText ());

16. Add a catch block for the try block we have used in the code.And finally, write the Java main method.

} catch(Exception e) {
System.out.println (e);
}

public static void main(String[] args) {
InvokeDS d = new InvokeDS();
d.callDS () ;

}

Corticon Tutorial: Tutorial: Deploying a Progress Corticon Decision Service in Process for Java: Version
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Chapter 11: Write Java Client code to deploy and access the Decision Service

You have now finished writing the Java client code. Save the Java code under an appropriate package and
project name. Here is the complete code used to deploy and access the Decision Service.

package program;

import com.corticon.eclipse.server.core.CcServerFactory;
import com.corticon.eclipse.server.core.ICcServer;
import com.corticon.service.ccserver.*;

import cargolLibrary.*;

import java.util.ArrayList;

import java.util.List;

import java.util.Iterator;

import java.util.Properties;

public class InvokeDS {
private static String decisionServiceName = "Cargo";

public void callDS () {
try {
Cargo cargo = new Cargo();
cargo.setWeight (1000) ;
cargo.setVolume (10) ;
List<Cargo> cargolList = new ArrayList<>();
cargolList.add (cargo) ;

ICcServer server = CcServerFactory.getCcServer();

Properties p = new Properties();

p.put (ICcServer.PROPERTY AUTO RELOAD, false);

if (!server.isDecisionServiceDeployed("Cargo")) {
server.addDecisionService (decisionServiceName, "Cargo v0 16.eds", p); }
ICcRuleMessages msgs = server.execute ("Cargo", cargolist);
List<ICcRuleMessage> msglist = msgs.getMessages();
Iterator<ICcRuleMessage>
itr = msglist.iterator();

while (itr.hasNext ()) {
ICcRuleMessage m = itr.next();
Object obj = m.getEntityReference();
Cargo x = (Cargo) obj;
System.out.println("---------- "y
System.out.println ("Cargo weight is "+x.getWeight());
System.out.println ("Cargo volume is "+x.getVolume()) ;
System.out.println ("Cargo container value is " +x.getContainer());
System.out.println (m.getSeverity());
System.out.println (m.getText ());
} catch (Exception e) {
System.out.println (e);
}

public static void main(String[] args) {
InvokeDS d = new InvokeDS();
d.callDS () ;

}
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12

Test the Decision Service

Now that you have written the Java client code, you can test it and confirm whether the code accesses the
Decision Service.

1. Copy the Decision Service file, Cargo_v0_16.eds, from the workspace.
2. Paste itinto App.

3. Run InvokeDS.java.
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¢

=\ IRE Systern Library [JavaSE-1.2]

=, Referenced Libraries
g2 ant-launcherjar

= Cargo_v0_16.eds
g Cargo.jar

g CcConfig.jar

g Ccll@nBundles jar
g5 Celicensejar

Cargo
Cargo
Info

Cargo

g CcExtensions.jar Prc

File Edit Source Refactor Mavigate Search Project Run Window Help

: 3 ~ | B RiF-O- Q- OG-S V- P APE T E-FH OO
f# Package Explorer &3 = 0O [J] Cargojava li¢ Cargo.ecore ] InvokeDS.java &3
BES ~ package program;
v I App

# import com.corticon.eclipse.server.core.CcServerFactory;[]

v i src public class InvokeDs {
w B program private static String decisionServiceName = "Cargo”;
m InvokeDS.java = public woid callDs(){
try {

Cargo cargoc = new Cargo();
cargo.setheight (1066) ;
cargo.setVolume(18);

Jlems Javadoc Declaration B Console 52 W ﬂ%| ="
<terminated> InvokeD5 [Java Application] C\Progress\ Corticon 6.005tudic!jre\bintjave
Starting Progress Corticon Server @ 6.8.1.8 -ble4ls

g5 CcServer.jar Progress Corticon Server CcServerSandbox location : C:/ e8x/works
g2 CcThirdPartylars jar Loglevel : INFO

= cargolibrary Logpath : C:/ 68x/workspace/App/logs

ﬁTUtDnal Cargo weight is leea

volume is 18
container value is standard

weighing <= 28,888 kilos must be packaged in a standard con

Writable Smart Insert 22:25

The Decision Service updated the container variable based on the values of weight and volume provided
in the request object message. Based on the rules defined for this project in Corticon Studio, for an input
weight of 1000 and volume of 10, the rules respond that a standard container should be used. The Decision
Service is responding to the Java client code and the business rules.

4. Let’s change the value of weight defined in the Java client code to 25000.

try |
Cargo cargo = new Cargo();

cargo.setWeight (25000) ; cargo.setVolume (10) ;

5. Save and run the Java client code.
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=\ IRE Systern Library [JavaSE-1.2]

=, Referenced Libraries
g2 ant-launcherjar

= Cargo_v0_16.eds
g Cargo.jar

g CcConfig.jar

g Ccll@nBundles jar
g5 Celicensejar

g CcExtensions.jar Prc

File Edit Source Refactor Mavigate Search Project Run Window Help

: 3 ~ | B RiF-O- Q- OG-S V- P APE T E-FH OO
f# Package Explorer &3 = 0O [J] Cargojava lig¢ Cargo.ecore ] InvokeDS.java 52
BES ~ package program;
v I App

# import com.corticon.eclipse.server.core.CcServerFactory;[

v i src public class InvokeDs {
w B program private static String decisionServiceName = “"Cargo”;
m InvokeDS.java = public woid callDs(){
try {

Cargo cargo = new Cargo();
cargo.setWeight(25000) ;|
cargo.setVolume(18);

nlems Javadoc Declaration B Console &3
<terminated> InvokeD5 [Java Application] C\Progress\ Corticon 6.005tudic!jrelbi
starting Progress Corticon Server @ 6.8.1.8 -bled4ls

g CcServerjar Progress Corticon Server CcServerSandbox location @ Ci/ 6@x/w
g CcThirdPartylars.jar Loglevel : INFO
22 cargolibrary Logpath : C:/ 68x/workspace/App/logs
ii}WlﬂDnal Cargo weight is 25688
Carge volume is 18
Cargoe container wvalue is heavyweight
Info
Cargoe weighing > 28,888 kilos, with wolume <= 38 cubic meters

Writable Smart Insert 17: 3

The rules triggered to prefer a heavyweight container.

The Decision Service is responding to the client code within the Java app.

Congratulations! You have completed this tutorial.

You have created Java Object get and set methods, mapped them to the Vocabulary, packaged the project
as a compiled Decision Service file, and created Java client code to deploy and access the Decision Service.
Finally, you tested the Java client code to confirm that it accesses the Decision Service.

You have created and tested a Corticon Decision Service deployed in-process under Java.
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