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This Basic Rule Modeling Tutorial provides an introduction to
the Corticon Business Rules Modeling Studio 5.3.

You will learn how to capture rules from business
specifications, model the rules, analyze them for logical errors,
and test the execution of your rules; all without programming.

Your goal is to create a Decision Service: A group of rules that
captures the logic of a single decision-making step completely
and unambiguously. In one sense, a Decision Service (when
managed with Corticon Studio) is a business-friendly model of
your rules (i.e., your decision-making logic). In another sense,
a Decision Service is a powerful asset, allowing you to
automatically process the rules as a part of business
transactions.
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Note

The Decision Services that you build using Studio may
be deployed as executable, standards-based services
available to other software applications via Java, .NET,
or SOAP messaging. Corticon Decision Services are
in use today across the globe, automating many high-
volume decision-intensive processes.

See the Server Integration & Deployment Guide or
the Server Deployment Tutorial for instructions on
how to deploy and integrate the Decision Services you
build here.

© 2014 Progress Software Corporation. All rights reserved.

Note

This Tutorial is designed for hands-on use. We
recommend that you type along with the instructions
and illustrations presented.
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Corticon provides a simple yet powerful methodology for modeling business
rules called the “Corticon Decision Services Methodology”. This
methodology follows the lifecycle of your decision service, and involves the
following steps:

1. Scope the business problem. 2. Discover the business rules.
Ask the question: What decision Ask the question: How do we
are we trying to make? make the decision?

A 3. Model the business rules.
Using Corticon Studio,
logically express the rules.

5. Test the business rules.
Using Corticon Studio, test
rule execution to ensure .
expected business results. AN

Analyze

Note
4. Analyze the business rules. 6. Deploy the business rules.
Steps 2-6 are repeated when rules change. ::Z'Tﬂggﬁogorsnt;fﬁfé i’;sr']‘g;ttehnaét Using Corticon Server,
This tutorial includes two iterations through the and free of logical errors automate the rll_"es_ across
lifecycle, including an initial implementation SRS RS,

and subsequent change cycle. Deployment is
covered in a separate tutorial (see Server
Deployment Tutorial and Server Integration
& Deployment Guide).
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Note

The example used in this Tutorial was developed from a business
problem in which an air cargo company loads cargo of various sizes and
weights into containers, then onto its fleet of aircraft prior to shipment.

To operate safely, the company must ensure that an aircraft is never
loaded with cargo that exceeds an aircraft’s capabilities. Flight plans
are created by the company that assign cargo shipments to containers,
then containers to aircraft. Part of the flight plan creation process
involves verifying that no plan violates any safety or operational rule.

The air cargo company desires to improve the quality and efficiency of
the flight planning process by modeling and automating business rules
using the Corticon Business Rule Management System.
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Complex problems such as flight planning are better described in their component parts. The best
way to do this is by describing the business process for this problem. From a process diagram, we
can easily identify the decision-making activities, which in turn are described by business rules.

Action

First, define your business process as a sequence of activities or
steps:

Collect Package

Action

Next, determine which process steps involve decisions. Any step involving a decision is a candidate for automation using
Corticon.

In this process, all three steps involve decisions, in addition to physical labor. The scope of this tutorial is the “Package
Cargo” step, which involves the decision about what container to use for various cargo, based upon such criteria as the
cargo’s weight, volume and contents.

Today, the packaging decision is made by our shipping personnel based upon their experience. The problem is that some
people make better decisions than others, which leads to inconsistent practices. We want to use Corticon to standardize
and automate the packaging decision.
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Discover

Now that we have scoped our
problem, we need to discover
our business rules.

Note

To discover our business rules, we simply ask: “How do we make
this decision?”

For this case, we ask “How do we package cargo?” We ask this
guestion to the people who perform and manage this step in the
process.

They often provide the answer in the form of a policy or procedure
manual, or simply as a set of rules that they follow. Sometimes the
rules are embedded in the code of our legacy systems. In other
cases, the rules are not documented and found only in the heads
of our people.

In all cases, we will capture the discovered rules directly into
Corticon Studio.

Package

container.

e Cargo weighing <= 20,000 kilos must be packaged in a standard container.

» Cargo with volume > 30 cubic meters must be packaged in an oversize

© 2014 Progress Software Corporation. All rights reserved.
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IMPORTANT

About Corticon licensing

Corticon embeds a timed evaluation license in each Corticon Studio that lets you evaluate Corticon Studio features.
Typically, you do not need to do anything to get started.

But, when you start Studio, if you see a License Warning alert it means that the license file is invalid, corrupted, or

expired. Then, when you create or modify any Corticon files, you get an Asset Locked Warning, indicating that you can just
review existing files.

Contact your Progress Corticon Technical Support or your Progress representative to obtain a workable license. Place the
license file on your Studio machine, then launch Studio.

Choose Window > Preferences, then expand Progress Corticon > Rule Modeling. Click Browse and then navigate to
choose your new, valid, unexpired license. When you click OK, and restart Studio the license update process is complete.

8 © 2014 Progress Software Corporation. All rights reserved.



Action

Double click on the

Open Corticon Studio

For Analysts

Note

You first need to install the software.
Refer to the Studio Installation Guide for

detailed instructions.

If you are using Corticon Studio for
Analysts (the standalone version),
complete the next four slides. If you are

using the Eclipse plug-in version
(Corticon Designer) jump to slide 12 for
setup instructions.

© 2014 Progress Software Corporation. All rights reserved.

vl 1. C:\Program Files (x86)\Progress\Corticon 5.3 for_Analysts\Studio for Analysts

it View Tools Help
Open Burn New folder

Studio iconinyour .
Corticon installation

MName

. configuration

dlreCtory “InSta‘" .. features
Dir>\Studio for de
o plugins

Analysts\Studio.exe” @ cormconico

| Moticestxt
‘ © studiosce
OR 4| Studioiini

Choose the Start e

menu path All -

Programs >

Progress > o Progress
Corticon 5.3 > . Corticon 5.3

Corticon Studio | c Corticon Studio for Analysts |

for Analysts

Note

For further details and reference information not presented
here, you can choose Help > Contents and Index from the

Studio menubar or click the %) icon on the Studio toolbar.




Note

When starting Corticon Studio for Analysts, the screen will look similar to this:

. Progress Corticon Stucio for Analysts
File Edit Project Window Help
i~ B &

(2] Rule Vacabulary &3 =8 =08

L] =

Rule Statements &3 E Rule Messageq =0

? Rule &3 ﬁ Rule 1 =8

= General

(= Attribute Operatars

= Entity/Association Operators
= Extended Operators

M_ﬁ Ploblemq@ Enoll.og] ElE=Ns

Property Value

L] LU 3
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Action

Your initial workspace will be empty. Switch to a new workspace (where this Tutorial’'s
sample files are located) by choosing File > Switch Workspace from the Studio menubar.

|File Edit Mavigate Search Project Run Wind:

MNew Alt+Shift+ M »

Open File...

Close Ctrl+W

Close All Ctrl+Shift+W

Save Ctrl+5

Save As...

Save All Ctrl+5hift+5

Revert

Move...

Rename... F2

Refresh F5

Convert Line Delimiters To 4

Print... Ctrl+P

Switch Workspace b GthT{‘

Restart e
g2y Import..
3 Export...

Properties Alt+Enter

Exit

11 © 2014 Progress Software Corporation. All rights reserved.
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Action

In the navigation window that appears, browse to your Corticon work
directory and select \Samples\Rule Projects. Be sure Rule
Projects appears in the Folder field at bottom. Click OK.

Corticon Studio will automatically close and restart, with the new
workspace open in the Rule Project Explorer window.

Select Workspace Directory @

Select the workspace directory to use,

4 | CorticonWork_5.3_for_Analysts o
L. license
. logs
4 | Samples
= ) Apama Corticon Integration
1. Derived Works
= | Extensicns

m

l» 1. Reports
Congratulations! You have \ 4 . Rule Projects
succeeded in switching to the P .metadata
Tutorial workspace. Proceed \ ‘ f‘”’t T

to slide 17 Opening the
Vocabulary

Falder: Rule Projects

| Make New Folder | ok || cancel
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File Edit Project Window Help
-HE

(2] Rule Vocabulary 2 e = 5

Note

Your screen should now look like this, with the Tutorial project available in the
Rule Project Explorer view.

@ Rule Operators i = B8 Rule Staterments 23 2 Rule Mmagﬁw =40

b i GrandParent;
[+ =% Insurance
i = OrderProcessing

& Sewvice Call-outs Congratulations! You have
[+ =+ TradeAllocation . . .
& Trining SEESEERNELERREEEES  succeeded in switching to the
— S Bropety Tutorial workspace. Proceed
@ Corgeccore to slide 17 Opening the
. Vocabulary

0 items selected
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Action

Open Corticon Studio

Note

You first need to install the software.
Refer to the Studio Installation Guide for
detailed instructions.

If you are using Corticon
Studio, complete the next four

slides. After that the
instructions will be the same
for both Studio installations.

14 © 2014 Progress Software Corporation. All rights reserved.

Tee— e ——
Double CIiCk on the %' .« Program Files (x86) » Progress » Co-rt\:oni.}_ » Studio » ac\ip‘se »

COTtICOﬂ StUdIO File Edit View Tuols Help
a a o Organize « = Open Burn MNew folder
eclipse.exe file in your k ——
Corticon installation e © Cortconico
directory “<Install Dir>/ 40 | Roschgecrs
0 a o 0 | Recent Places 4F | eclipse.ini
Studio/eclipse/eclipse.exe S B ectroe tsamresTELIL
ibraries =77 eclipsec.exe
Eﬁ; :ocumants epl-v10.html
OR
Start menu —_—
path All Programs > >
Progress > Corticon
5.3 > Studio >

Corticon Studio

Note

For further details and reference information not presented
here, you can choose Help > Contents and Index from the
Studio menubar or click the %) icon on the Studio toolbar.
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Corticon Designer - Progress Developer Studio
File Edit Mavigate Search Project Run Ruletest Window Help
{i® Help Nelcome i3 . =8
TO PROGRESS DEVELOPER STUDID
Q Overview
¢. What's New _..’_.!37 Workbench
@ ,{b Samples
v 4 Tutorials
R
Q Documentation
@ Web Resources
|
Copyright ® Progress Software Conp: ion andior its subsidiaries or affiliates. All rights reserved.
n<>
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Corticon Designer - Progress Developer Studio
File Edit Mavigate Search Project Run  Window Help

+ ‘E§$> (A

Samples

This page contains references to samples of the Progress products that you installed on this instance of Eclipse. You can filter these
references and group them by product, topic, and level of complexity.

View Eclipse and Other Samples

All Samples | Group by: Complexity v‘ Tutorial
Training - This sample provides a structured | »
dictionary for a few business processes. It This sample has been developed from the business requirement of an airfreight company. The =
contains all the necessary business terms company loads cargo of various sizes and weights into containers, and then onta its aircraft. For air
and maps the relationships between the safety. the company must ensure that an aircraft is never loaded with oversized and overweight
terms using the business rules. cargo, which exceeds an aircraft's capacity. A part of the flight plan involves verifying that no safety
Tutorial - This sample describes the or operational rules are violated. The company wants to improve the guality and efficiency of its
‘ business requirement of an airfreight ' flight-planning process by modeling and automating its business rules using Corticon Business
company. § Rule Management System (BRMS).

Intermediate

| | mmm) Open
Insurance - This sample describes the

business requirement of a life insurance

company. = | &
OrderProcessing - This sample describes Reference 1D : Mot available

the business requirement of a shipment

company for order processing. Features : Progress Corticon Studio

TradeAllocation - This sample describes

9 PROGRESS

i
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r-* Import uﬂ

Import Projects
Following projects will be imported in your workspace, B

-

] Tutorial | Select Al |

! |
\
|
'

| |

@ mm)| ok || cance |

| - J
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CEdit Nevgate Search Project Fun Window Help

T :Hj o £ __.,. q - 4’“ - | ol - g - -
[ Project Explorer 23 | 0 Rale Vocabulary| = O Note: Eclipse allows you to resize,
8%~ move and close views.

Tip: Drag the Project Explorer view
to the bottom next to Rule

Operators. This way your screen will
look similar to this Tutorial.

You can always select Window >
Reset Perspective... to return to the
default perspective

&P Rule Operators 12 . =8 D Rule Statements 2 | CJ Rule Messages

= General

= Attnbute Operstors

= Entity/Associstion Operators
= Bxtended Operators

st 3] . proens| & rer Lo -0

Properties are not available.
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= Progress Corticon Studio for Analysts
File Edit Project Vocabulary Window Help

Ch~E & Ea'l

| U U S 30 36 () BB B €

(& Rule Vocabulary &2

=

v = H

2] Cargo
= Aircraft
= Cargo
=] FlightPlan

a [Z] Cargo
> E Aircraft
i &= Cargo
i = FlightPlan

@ Rule Operators ﬁ Rule Project Explorer 33\\_

= GrandParent
= Insurance
1= OrderProcessing
1= Service Call-outs
= TradeAllocation
= Training
= Tutorial

= Tutorial-Done

g Cargo.ecore S

Rul

Data Type Ma...
containerType

Customn Data Type

Note

Slides will use Corticon Studio for

Analysts for all screen captures

moving forward. If you are using

Corticon Studio your perspective
might have different default layouts.

The first step in modeling business rules is to build a Vocabulary, which
includes the terms referenced by our business rules (such as ‘aircraft’ and
‘flight plan’). Using Studio, you can define and edit Vocabularies. In this case,
we opened an existing model created in Studio.

Once you open a Vocabulary, you can see it in the upper left Rule
Vocabulary window. In addition, you can edit the Vocabulary in the upper
right editor window. Later in this Tutorial, we will edit the Vocabulary.

First, we will model some rules using the Vocabulary provided. We model
rules using a Rulesheet.

Action

Open an existing Vocabulary by double-clicking Cargo.ecore in the Rule
Project Explorer view.

© 2014 Progress Software Corporation. All rights reserved.
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(& Rule Vocabulary 2
] Cargo
= Aircraft

= Cargo
= FlightPlan

m.

[ = General }

[» = Boolean

[+ = Date

i = DateTime

[+ = Decimal

4 [= Integer
2 o

om0 W A WA
nn

+
n

<% absval
“% toDecimal
<>¢ toString

EFEEEFEFEFEL

ﬁ Rule Project Explorer
Jj P

4 [= Attribute Operators

“% max (compareMumber)
*% min (comparelNumber)
“% div (divisor)

m

© 2014 Progress Software Corporation.

All rights reserved.

Action

Take a moment to explore the Rule Operators,
which are located in a tab to the lower left, adjacent
to the Rule Project Explorer tab.

Note

While the Rule Vocabulary contains our nouns (the things we
reference in our business rules), the Rule Operators contain our verbs
(the actions we take in our business rules).

Corticon Studio comes with a rich set of operators for manipulating
data, similar to the Excel function library. In addition, programmers can
also extend Corticon's built-in Operator Library by implementing a
documented Corticon Operator API (e.g., to perform a new statistical
function or to make a call out). See Appendix D of the Rule Language
Guide for more information.




{_ Progress Corticon Studio for Analysts

| File | Edit Project Rulesheet Window Help

Mew » | Ig¢ Rule Project
Open File... Cg RuleVecabulary Action
' Ruleflow
e S @ Rulesheet < To create a new
Close All Ctrl+Shift+W Rulesheet, select File >
: _ % Ruletest New > Rulesheet from
e T 19 Folder the Studio menubar.
[E] Save As...
.
Save Al Cirl+Shift+s | [0 Other- Curl+N
Revert
Move...
Rename... F2
Refrezh Note
=) Print.. 2
_ You can also right click inside the Project Explorer view to create new
Switch Workspace assets and access other shortcuts.
g2y Import.
gy Export..
Properties Alt+Enter

1 use_cashBack.ers [MyAdvancedTutorial]

2 use_cashBacld.ert [MyAdvancedTutorial]
3 MyAdvancedTutorial.erf [MyAdvancedT...]
4 couponsh.ert [MyAdvancedTutorial]

Exit
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& Create New Rulesheet

Rulesheet

Create a new Rulesheet
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Action

Select Tutorial as the Parent Folder and enter Cargo as the
File name. Click Next.

Now, select Cargo.ecore as the Vocabulary to associate with
your new Rulesheet and click Finish to complete the process.

Enter or select the parent folder:

& Create New Ruleshest

Rulesheet
Select Vocabulary

Lo o =]

Tutarial

e
1= GrandParent
=% Insurance
= OrderProcessing
1=+ Service Call-outs
== TradeAllocati
= Training
== Tutorial

== Tutorial-Done

"4

File name: Cargo|

fir
[» 1= GrandParent
[+ 1=* Insurance
[» 1= OrderProcessing
[+ T= Service Call-outs
|» = Tradelllocaticn
[ = Training
a = Tutorial

Eﬂ Cargo.ecore

[+ [ Tutorial-Done

<Back | Neax |[ Finish ||

Cancel

© 2014 Progress Software Corporation. All rights reserved.

< Back

Next =

Finish

J |

Cancel
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This is an example of a Corticon Rulesheet, the metaphor used to model your business rules.
Based on a decision table, the Corticon Rulesheet has been extended to allow the modeling
of any business rules logic from simple to complex inferencing problems. This tutorial
models only simple rules. See the Advanced Rule Modeling Tutorial and Rule Modeling
Guide for some complex examples.

r’@ riskRating.ers &3 @ a =g
Ceonditions 0 1 2 -
a | Person.skydiver = T |:|
b
c
- d d
-' Actions 4 |l L
1 Post Message(s) |:|i
| A :Persnn.riskﬂating ‘High' -
| B
[ €]
5] -
Overrides
i N
Rule Statements &3 L Rule Messagegl =0
Ref |ID |Post |Alias  Text &) .
1 A person that skydives is rated as high risk. (a

Rulesheets contain sections for specific parts of rules. Sets of Conditions (label 1) and Actions (label 2) are tied together by
the vertical columns on the right to form rules. For example, rule column 1 (label 3) is read as “if a Person’s skydiver value
is true, then assign ‘High’ to that Person’s riskRating. We say that this column provides the model or implementation of

the rule statement (label 4). Column O (label 5) is used to define calculation rules that contain Actions, but no Conditions
(see Rule Modeling Guide for examples).

© 2014 Progress Software Corporation. All rights reserved.



Model the first rule:

» Cargo weighing <= 20,000 kilos must be packaged in a standard

Eﬂ- Cargo.ecore ﬁ *Cargo.ers &3

container.

24

EA-REN WF-RE - -1

Conditions

Enter the plain-language business rule into the Rule
Statements section of the Rulesheet as shown.
You can copy and paste from the text above.

Action

Text

¢

Carge weighing <= 20,000 kilos must be packaged in a standard container.

N \

H

Overrides

4

Ref

i

Rule Statements &3

Post

C3 Rule Messageq

Alias

Text

Cargo weighing <= 20,000 kilos must be packaged in a standard container,

© 2014 Progress Software Corporation. All rights reserved.
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Model the first rule:

The condition of our first rule: “Cargo weighing <= 20,000“ can be
restated as “Cargo.weight <= 20000". Let's model this logic in
Studio.

|2 88|00

Action

9~ E =2 | W] S 5 3 m\ Q| R R
Rule Vocabulz fm = O|E *Cargoers 2
) -
a [Z] Cargo Cenditions
@ » & Aircraft a‘.Cargo.weight
¢ ]
4 (& Cargo .
. . -
= container “‘t .
== manifesthurmber “‘ .
== volume “t‘ f
=] weightb‘ g
[ 3~ flightPlan (FlightPlan) h
i & FlightPlan i
Actions
Post Message(s)
A
B
C
D
E
F
G
H
Note

We'll use an orange dotted line to indicate
dragging and dropping. Drag from the
orange circle, and drop on the orange
diamond.

© 2014 Progress Software Corporation. All rights reserved.

Our first rule evaluates a condition and takes an
action if and only if the condition is satisfied.

Therefore, we will use the Conditions and Actions
panes to model the rule.

Drag the Cargo.weight term from |55
the Vocabulary and drop it in Row
a of the Conditions pane, as
shown. =5
0 1 2 -
Note
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Continue modeling the first rule:

» Cargo weighing <= 20,000 kilos must be packaged in a standard container.

Action

Next we type a value expression for cargo weight in cell 1a (row
a, column 1).

Type <=20000 in the cell.

Don’t use commas in value expressions because commas are

reserved to indicate multiple values.

Conditions
- a Cargo.weight == 20000

= | =k o N |

© 2014 Progress Software Corporation. All rights reserved.



Action

Now drag the appropriate term from the Vocabulary and drop it in row A of
the Actions section.

Next, define the action for rule 1 by selecting “standard” in the drop-down
menu within Actions row A of column (rule) 1. The drop-down menu
options were defined in the Vocabulary, which we will edit later.

This action assigns the value of “standard” to the Cargo.container attribute.

= B
= O || B *Cargo.ers 32
a [ Cargo Conditions
- = Aircraft a | Cargo.weight
4 H Cargo b
| = cuntainerp,. £
= manifesthumber, :
0. e
= volume ‘e, :
=] weight ‘o, ‘;‘T;f
> 3~ flightPlan (FlightPlan) 'h o E“atg_e':ﬂ
argo.container
» E FlightPlan 5 g
C

Chverrides

<= 20000

standard

-

27 © 2014 Progress Software Corporation. All rights reserved.
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Action

above.

Finally, enter the Rule Statement’s
Reference number. This connects the
Rule Statement to the corresponding
model in a column in the Rulesheet

Note

Reference numbers logically link rows
in the Rule Statements section to
columns in the Conditions/Actions
section — notice how clicking on Rule
Statement Ref 1 causes column 1 to
highlight. The highlighting reminds
you that column 1 is the model of the
rule (expressed in plain-language) in
Rule Statement Ref 1.

4 [Z] Cargo
» & Aircraft
4 = Cargo
|==| container|
== manifestMumber
= volume
= weight
i 3~ flightPlan (FlightPlan)
i = FlightPlan

B *Cargo.ers &1 = O
Conditions 0 2 -
a | Cargo.weight <= 20000 [
b
c
d
E -
Actions 4 [ttt b -
Post Message(s) D
A Cargo.container
B
C -
Owverrides
| Rule Statements &2 [ Rule Messageq = 08
Ref 1D Post Alias Text -

© 2014 Progress Software Corporation. All rights reserved.

Cargo weighing <= 20,000 kilos must be packaged in a standard container. H




Model the second rule :

» Cargo with volume > 30 cubic meters must be packaged in an oversize container.

29

0 O ETS = E
i - —
Note | Conditions 0 1 2 B
a | Cargo.weight <= 20000 |:|
b Cargo.wolume = 30
When completed your <
Rulesheet should look d | Al
like this... e £
Actions «[om ] A
Post Message(s) D
A Cargo.container standard OVErsize
. B
Action C 8
Crerrides
Finally, save your Rulesheet - =
y . y Rule Statements % . [ Rule Messageq ET
by selecting File > Save from _
the Studio menubar (or clicking Rlef L Dbl Ze“t — e ——— —— it
the Save bUttOI’\). argowralg ing <= 20, |.os must be packaged in a st;n ar con.talner. .
2 Cargo with volume » 30 cubic meters must be packaged in an oversize container.
Conditions 0 1 2
a | Cargo.weight - <= 20000 - Mgt
b Cargo.wolume = - =30
; When saved, Studio places a dash in the empty cells,
. meaning that the condition is ignored.
;‘d;t“h’:“ “ L The conditions and actions in a column are “anded”
o essage(s . % f
A | Cargo.container tardand oversize together. For example, rule 1_read_s. C_argo weighing
B less than or equal to 20,000 kilos, ignoring volume, must
C be packaged in a standard container.”
Owerrides

© 2014 Progress Software Corporation. All rights reserved.
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Note

Next, we will “Post” the Rule Statements to the “Cargo” entity. This will provide an audit
trail during rule execution, which you will see during rule testing. To preview the end
result of a post, see slide 46 for green Info posts.

i | e |
B¢ *Cargo.ers &2
Conditions 0 1 2 3 4
a | Cargoweight = <= 20000 = [
b | Cargowolume = - =30
c
d
e Note
Actions 4 m |
Post Message(s) i i s — When you define a Post, an
A Cargo.container standard OVErsIZE icon appears in the Post
B Message(s) row of the
¢ Rulesheet.
Overrides
_ B Rule Messages-] -
Ref |ID Text
1 Cargo weighing <= 20,000 kilos must be packaged in a standard container.
2 Cargo with velume > 30 cubic meters must be packaged in an oversize container,

Action

To Post, select the appropriate Severity Level from the drop-down box in the Post column. (in this
case, select “Info”) . You must also select an Alias for the Rule Statement to post. The Alias defines
what Entity the Rule Statement is posted to (in this case, select “Cargo”, which is the only option).

© 2014 Progress Software Corporation. All rights reserved.



Analyze

Now that we have finished modeling our rules, it is time to analyze our rules for logical errors. Very often, initial business rule
specifications are ambiguous and incomplete. By ambiguous, we mean that the rules are conflicting under certain
scenarios. By incomplete, we mean that the rules fail to address all possible scenarios.

Prior to automating your rules, it is critical to eliminate logical errors in order to ensure that our decision service provides correct,
consistent results. We call this “Rule Referential Integrity”. Studio provides unique and powerful features to help you ensure
Rule Referential Integrity. These features will be explored in this Analyze phase of the rule management lifecycle.

Click on the Check
for Conflicts icon
on the toolbar. -.i

. OR
Action
Choose Rulesheet >  [Bulesheet] Window _Help
— LO ica| Ana| SiS > Logical Analysis 3 Execution Sequence Diagram
CB::rSguc:eergl:;b is ChgeCk for CoynﬂiCtS Rule Calumn(s) 4 Logical Dependency Graph
SeleCte.d (COlOfed from the Studio [E Advanced View Clear Analysis Results
blue) then CheCk for menubar. (d  ShowNatural Language & Checkfor Logical Loops
' Filters 3
i Check for C let
ConﬂICtS. Processing Mode » y SerTarTompTEeness
Localize... & Check for Conflicts
|i=| Report . Enable Conflict Filter
htPlan A C Previous Conflict
g Mesxt Conflict
First Conflict
Last Conflict
ule
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Analyze

Note

Columns containing conflicts are shaded in pink. This
indicates that one or more conflicts exist between the pink

rules.
r@ Cargo.ers -EEK‘\ l
Conditions 0 : 1 _ 2 3
a |Cargoweight = <= 20000 = Note
b Cargowvolume - - =30
£
d The total number of conflicts
£ detected is displayed.
Actions 1 m | Cl=
Post Message(s) EA % D
A Cargo.container standard oversize
B
C Progress Corticon Studic E i
Owerrides
& / = T
Rule Statements EEM @ Total conflicts detected: 1 O
Ref |ID Post  Alias -
1 Info  Cargo tckaged in a standard container.
2 Info  Cargo t be packaged in an oversize container.
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Analyze

Click on the Expand
Action Rule_s icon on the QE
Studio toolbar.
Expand the Rules to reveal ———
~ ; OR
sub-rules (rules without
0 q !R lesh Wind Hel
dashes) inside the general fulesheet] Mindow Relp
rules (rules with at least one rogicel Anabys » B 2640
Choose RUIeSheet Rule Column(s) b | =2 Use Conditions as Processing Threshold |
dash value). This hel ’ |
ash value). This helps you >
. p y RUIe COIUmn(S) [E  Advanced View ﬁ@ Expand Rules
more accurately pinpoint the > Expand Rules
fthe amb| Ulty X @ Show Natural Language E@ Collapse Rules
SO © g i from the StUdlo Filters 3 E@ Compress Rules
menUbar- Processing Mode L [ Renurnber Rules
Localize... p— af -
=] Report it Message(s) i
L Cargo.ecore  |0@ *Untitled.ers &
Conditions 0 11 12 13 21 22 23 When the rules are expanded, the source of
Cargo.weight - <= 20000 <= 20000 <= 20000 <= 20000 = 20000 mull the conflict becomes obvious. In scenarios
Cargavalume - <= 30 » 30 mull > 30 > 30 > 30

with cargo weight <=20000 and cargo volume
> 30, our rules are in conflict, defining
Actions L U mutually exclusive actions (assigning both

an oo

Post Messageis) =2 = =2 = = = q .
A Cargo.container standard standard standard oversize oversize oversize standard and oversize contamers).
& ‘ - To get your rules right, this scenario must be
Y Y addressed!

When expanded, rule 1 is represented as three columns (1.1, 1.2 and 1.3), and rule 2 is represented as three columns (2.1, 2.2 and
2.3). Expansion shows all of the logical possibilities for each rule. Rule 1 states Cargo weighing <= 20,000 kilograms, regardless of
volume, must be packaged in a standard container, unless no volume was ever stated (a null value). Corticon Studio recognizes that
there are three possible ranges for volume (<=30, >30, and null), which we see in the expanded state.
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Analyze

Action

To resolve the conflict, you can either change
your original rules, or decide that one rule
should override the other. Let's implement the First, collapse your rules back to the original

override. state by clicking on the Collapse Rules icon E@
on the Studio toolbar.

1

(@ *Cargo.ers i3

Conditions 0 1 2
Action Cargo.weight - <= 20000 -
Cargo.wvolume - - =30

Next, override Rule 1 with Rule 2.

LU = T i B = - )

In the Overrides row, from the overriding ==
rule, select the column number of the rule
to be overridden. Multiple selections can

be made by holding the CTRL key. g Cargo.container oversize
2 C
Chverrnides 1 -
-
B@ *Cargo.ers I3
Action Conditions 0 1 2
a | Cargoweight f 5 * -
Now, click the Check for Conflicts button b Cargo.volume M i 5 > 30
again, and you will see that the conflict £
has been resolved. d . _
& Mo conflicts detected
With the override, Rule 2 now means “Use Actions il
oversized containers when volume is >30, Post Message(s) 1
even when weight is <=20,000.” A Cargo.container oversize
3 B oK
C
) _ Crverrides 1 -
34 © 2014 Progress Software Corporation. All rights reserved.



Analyze

Conflict is one form of logical error. Another form is incompleteness, or loopholes in our logic.

Click on the
Check for ﬁ
Completeness

icon on the Studio

Action toolbar. (Rulesheet] Window _Help
Logical Analysis b Execution Sequence Diagram
ﬁ OR Rule Column(s) 1 Legical Dependency Graph
CheCk fOr |Oglca| errors in the [ Advanced View Clear Analysis Results
RUIeSheet ChOOSG fl‘0m the Q S g @& Checkfor Logical Loops
Stud]o menu Filters ' 45 Check for Completeness
Processing Mode 2
Rulesheet > =l &  Check for Conflicts
Logical Analysis 2 Report & Enable Conflict Filter
> Check for htPlan E Previous Conflict
C Mext Conflict
Completeness First Conflict
Rule Last Conflict

I =

Frogress Corticon Studio E

a e

Completeness check has added 4 missing scenarios which have
= been automatically compressed in to 1 non-overlapping

columns. Action

This message window informs us that
0K our rules were incomplete. We missed
some scenarios.

Click OK to dismiss the window.
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Analyze

The Completeness Checking algorithm
calculates the set of all possible
mathematical combinations of all values in
all conditions. The algorithm then
compares this set of possible
combinations to those already specified in
the Rulesheet and automatically inserts
missing combinations of conditions as
new columns. These new columns are
shaded in green.

=
@ Corgoccore_|@icogoem B,

Conditions ] 1 2 3
a | Cargo.weight - <= 20000 - {= 20000, null}
b | Cargo.welume - - =30 {== 30, null}
C
d
e
.F

Actions 1 I} |

Post Message(s) | |
A | Cargo.container standard OVErSiZe
B
C
D
E

Crwerrides

Note

The Completeness Check
adds condition values, but
does not choose actions —
that’s our job as rule
modelers.

Let’s define a new Rule Statement for this (formerly) missing scenario:

Cargo weighing > 20,000 kilos, with volume <= 30 cubic meters, must be packaged in a heavyweight container.
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Analyze

Action

First, add the new Rule Statement for rule 3. Next, define an action in rule cell 3A. In this case, select
“heavyweight” as the container option. Last, post an Info message to the Cargo entity as we did for the first two
rules. Your Rulesheet should look like the one below after you Clear Analysis Results.

Reference to link it with the corresponding
column.

i = T
B¢ *Cargo.ers 51 8
Conditions 0 1 2 3 4 5 6 -
a | Cargo.weight - <= 20000 - > 20000 [
b | Cargo.wolume = - =30 <=30
€
d -
Actions 1 m | il
Post Message(s) i | EA (4
A Cargo.container standard OVErsize heavyweight
B
c -
Overrides 1
i = T
Rule Statements &3 2 Rule Messages} B
Ref ID Post Alias Text Ri =
1 Info Cargo Cargo weighing <= 20,000 kilos must be packaged in a standard container, |:|
2 Info Cargo Cargo with volume > 30 cubic meters must be packaged in an oversize container.
Info Cargo Cargo weighing = 20,000 kilos, with volume <= 30 cubic meters, must be packaged in a heavyweight container.
Note
|{ Don'tforget to add enter the Rule Statement | | In this example, incompleteness was resolved by

specifying an action for column 3, along with adding a
new Rule Statement. Once resolved, remove the green
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button on the Studio toolbar.

highlighting by clicking the Clear Analysis Results @ |




Analyze

A third form of logical error is circular logic.

Click on the

Check for @

Logical Loops
icon on the Studio

Action toolbar. Rulesheet | Window Help
OR Logical Analysis 3 Execution Sequence Diagram
. . ﬁ 1 Rule Column(s) 2 Logical Dependency Graph
CheCk for IOglcal s I the [ Advanced View Clear Analysis Results
RUIeSheet' ChOOSG j (4 Show Natural Language & Checkfor Logical Loops
Rulesheet > ::I:.i:;sing Mode : y Check for Completeness
Logical Analysis e % Checkfor Conflicts
> Check for 5] | Report & Enable Conflict Filter
Logical Loops hiPlan | O frovouConic
from the Studio RF;”'E First Conflict
menubar- 1 Last Conflict
r !
@ Logical Loops @
Mo logical loops detected. - Note
This is a very simple Rulesheet and contains no
- logical loops. Of note, while unintended logical
4 k

loops are problematic, sometimes logical loops are
a useful technique for solving complex inferencing
Co l | oK problems that require recursive reasoning. You can
Py . : .
learn more in the Rule Modeling Guide.
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Save your Rulesheet.

Action

Click on the Save
icon on the Studio
toolbar.

OR

Choose File > Save
from the Studio
menubar.

=)

Edit Project Ruleshest Window Help

i Progress Corticon Studie for Analysts

New

Open File...

Close

Clese All

H Save

[5]  SaveAs...

Ctrl+W
Ctrl+Shift+W

Ctrl+S

© 2014 Progress Software Corporation. All rights reserved.

Analyze




The Analyze phase helped to ensure the logical integrity of our rules. The Test phase helps to ensure that our

rules give us the correct business results. Let's move on to testing.

First, we're going to define a test case for each one of our rules below by defining some input values and
expected results. Corticon Studio allows us to pre-define our expected results and then highlights any variances

in our test results. The table below defines one test case for each rule.

p
B¢ Cargo.ers &2
Conditions 1 2 3
a | Cargo.weight <= 20000 - = 20000
b | Cargowolume =30 <= 30
C
d
Actions ] | m |
Post Message(s) B | %
A Cargo.container standard oversize heavyweight
B
s
D
Overrides 1
Test Test Test
Rule 1 Rule 2 Rule 3
Input Values
Cargo.weight 1000 1000 30000
Cargo.volume 10 40 20 For test 2, we expect rule 2 to
Expected Results override rule 1.
Cargo.container | standard | oversize heavyweight
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Create a new Ruletest. Select Tutorial as the Parent Folder
and name the file Cargo. All test files are assigned a file
extension of .ert. Click Next > to continue.

Action

VA

Tl .

File | Edit Project Ruleshest Window Help

MNew 3
Open File...

Close Ctrl+W
Close All Ctrl+Shift+W
Save Ctrl+5
Save As...

Save All Ctrl+5Shift+5

1. Select File > New > Ruletest
on the menubar

OR

2. Use the New icon on the
toolbar by selecting the
down arrow to the right
of the icon and select
Ruletest.

Rule Project
Rule Vocabulary
Ruleflow
Rulesheet
Ruletest

Folder

L& éle & &

Other...

-
Lk

Ctrl+N

rc Progress Corticon -S;.ld-io for Analysts N
File Edit Project Rulesheet Window
Cr-He 5G| MWW
rf ¢ RuleProject m
% Project... B
L@ RuleVocabulary
¢ Ruleflow
E@ Rulesheet
[® Ruletest
| % Folder
; % Other. Ctrl+N

{C Create New Ruletest

Ruletest

Create a new Ruletest

= B =]

Enter or select the parent folder:

l)>  Tutorial

B e
=% GrandParent
= Insurance
1= OrderProcessing
= Service Call-outs
=* TradeAllocation
= Training
== Tutarial

© 2014 Progress Software Corporation. All rights reserved.

File name: Cargo
q q

<Back | Net> |[ Fnsn ||

Cancel
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Action

Select the appropriate Rulesheet as your
Test Subject. For our example, we want
to use the Cargo Rulesheet within our
Tutorial project directory.

Click Finish to display the new Ruletest.

(& Create New Ruletest

Ruletest
Select Test Subject

Note

You can disregard the Remote Servers
and Remote Decision Service panes - if
you are interested in those, please refer to
the Server Deployment Tutorial for more
information.

© 2014 Progress Software Corporation. All rights reserved.

Local

i}
= OrderProcessing
=+ Service Call-outs
=+ TradeAllocation
= Training
=% Tuterial

E Cargo.ers
= Tutorial-Done

Remuote Servers

http://localhost:8082/ axis

Update List

Remote Decision Services

[ <Back | Med> |[ Finish

Cancel
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Action

Drag the Cargo entity from the Vocabulary
and drop it anywhere in the Input and
Expected panes of the Cargo Ruletest's
default untitled_1 TestSheet. Cargo [1] on
this TestSheet's Input and Expected
panes represents a single ‘instance’ or

‘example’ of the Cargo entity.

Note

Changes you make to any
Studio file will cause an
asterisk character to
appear in the file’s tab.
This is a reminder to us to
save the file.

Note

As you can see, your new Ruletest is
associated with the appropriate
Rulesheet. This ensures that your
Ruletest scenario will be tested by the
right rules.

—
£ Hule‘u"ﬂcabuly &3 = B8
L ]

=
] Cargo
=] Airdaft
D5
é. lliqlr._lnelr-l-l......
= manifestﬂﬂmhﬁg.
= volume Tra,
= weight
3— flightPlan (FlightPlan)
£ FlightPlan

VL

= untitled_1

/ "8

4

file/Ce/Users/clabarge/Progress/CorticonWork_5.3_for_Analysts/Samples/Rule Projects/Tutorial/Cargo.ers

Input

El Cargo [1]

LN NI E.;chnl:a.iner

= manife.szlql:rﬁﬁér'"'---...,.__
*uy o = volume
= weight

Expected

= Cargo [1]
== container
= rmanifestMumber
= volume

= weight
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Test Test
Rule 1 Rule 2

Input Values
Cargo.weight 1000 1000 30000
Cargo.volume 10 40 20

Expected Results

Cargo.container | standard | oversize heavyweight

Action

First, remove unneeded attributes by selecting them and pressing the Delete key. Shift-click
and Ctrl-click are also supported for multi-selecting contiguous and non-contiguous attributes,
respectively.

We will remove the manifestNumber attribute as it is not needed to test these rules.

KIfﬂ *Cargo.ert &2 = H
= untitled_1
Action : : : :
file:/CifUsers/clabarge/Progress/CorticonWork_5.3_for_Analysts/Samples/Rule Projects/Tuteorial/Cargo.ers
Input Output Expected
Next, add test data for test #1 to
=l Cargo [1] 4 =] Cargo[1]
the TestSheet, per the table . .
- = container ==| container [standard]
above. Double-click on the
. =) volume [10] =] volurne [10]
desired term to open a data entry == = weight [1000] =] weight [1000]|
box. When complete, your -
Ruletest should look like this.
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Action

Enter the remaining test
data as shown to complete
the Input pane of the
Ruletest.

You can easily duplicate the
first test scenario by
selecting Cargo [1], copying
it, then pasting it below.
Repeat for both the Input
and Expected panes

Also, select the expected
container values from the
drop-downs that appear
when the container attribute
is clicked.

Your Ruletest should look
like the one below.

----- = olume [10]

----- =] weight [1000]
= Cargo [7]

----- = container

----- = olume [40]

----- =] weight [1000]
=-E Cargo [3]

----- = container

----- = olume [20]

----- = weight [30000]

Test Test
Rule 1 Rule 2
Input Values
Cargo.weight 1000 1000 30000
Cargo.volume 10 40 20
Expected Results
Cargo.container | standard | oversize heavyweight
Tﬂ argo.ecore E Zargo.ers m
| untitled_1 |
ITukarialfCargo.ers
Inpuk Cakpuk
=& Cargo [1]
----- = container

E'E

Expected
Cargo [1]
= container [standard]
= wolume [10]
B=| weight [1000]
Cargo [Z]
= container [oversize]
= olume [40]
B=| weight [1000]
Cargo [3]
= container [heawwweight]
= wolume [20]
=] weight [30000]

© 2014 Progress Software Corporation. All rights reserved.
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Action

Run the Ruletest.

The rule engine fires the

Running the Ruletest sends the OR
data on the selected Testsheet's B Run Al Tests
input pane to the rule engine.

appropriate rules and displays
the results in the Output pane.

Click on the Run
Test icon on the ﬂ
Studio toolbar.

Ruletest  Window  Help

& Add Testsheet

B Remove Testshest
,Link Lo Previous Testshest
@ | Change Test Subject

Choose Ruletest > | gy rienit
Testsheet > Run

Test from the W Cut Testshiest
Studio menubar. &C':'F":'" Testsheet

. Paste Testsheest

17/ Rename Testsheet

' MMave Backvard
W) 1ove Forward

MR 1ave ko Beginning
..Ml:nve Lo Enid

[Data k

Cuakput Yalidation * |

The first time rules are executed, they are automatically compiled from the rule model into an
optimized executable form, then deployed into the engine, which may take a few seconds. Once
deployed, the rules will execute much faster on subsequent tests.
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Action

Check the outcome of your test in the TestSheet's Output pang

Note

Input
=& Cargo[1]
----- Bl container
----- = wolume [10]
----- B=| weight [1000]
=& Cargo [2]
----- Bl container
----- =] olume [=0]
----- B=| weight [1000]
=& Cargo [3]
----- =] container
----- = wolume [20]
----- = weight [30000]

Qukput
=& cargo[1]
""" ™ container [standard]
""" = volume [10]
----- = weight [1000]
=& cargo [2]
""" ™| container [oversize]
""" B volume [40]
----- B=| weight [1000]
== cargo [3]
""" #=| container [heavyweight]
""" = aolume [20]
----- = weight [30000]

M:

All unchanged terms and values in the
| TestSheet's Output pane are displayed in
normal style.

Any terms altered by rules, including their
parent entities, are shown in bold text.

""" == COMamner [Oversize]

""" B volume [40]

P B=| weight [1000]

=& Cargao [3]

""" B conkainer [heayyweight]
""" = aolume [20]

----- = weight [30000]

ule Statements | & Rule Messages &3 =0
Severity | Message

Info Zargo with wolume > 30 cubic meters must be packaged in an oversize conkainer.

Infa Cargo weighing <= 20,000 kilas must be packaged in a standard container.

Info Cargo weighing = 20,000 kilos, with volume <= 30 cubic meters, musk be packaged in a heawyweight container,

Messages shown in the Rule Messages pane are produced by using the Post command in your Rule Statements.

Severity indicates whether a message contains information, warnings or violations.

Message contains the Rule Statement text.

Entity shows the entity to which this message is bound or linked. When we select the Cargo[1] entity within TestSheet's Output pane,
the third rule message is highlighted, showing the audit trail of rules that fired for that entity (in this case only one rule fired for Cargo[1]).

47
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Action

Next, let's change one of the test cases in the Expected pane to illustrate how variance testing works.
In the Expected pane, change the container value in Cargo[2] to standard. Then, rerun the test.

Your Ruletest should look like this.

Input Cuakput Expected

== Cargo[1]

----- = container

----- = volume [10]
----- = weight [1000]
== Cargo [2]

----- E cankainer

----- = volume [40]
----- = weight [1000]
== Cargo [3]

=& cargo [1]

""" = container [standard]
'''' = olume [10]

----- = weight [1000]

=& cargo [2]

'''' = container [oversize]
""" == volume [40]

----- B weight [1000]

== cargo [3]

=& Cargo[1]

""" ®=| conkainer [skandard]
'''' = olume [10]

----- = weight [1000]
=-E cargo[2]

'''' B container [skandard]
""" == volume [40]

----- B weight [1000]
=& Cargo[3]

----- = container - container [heayyweight] - container [heavyweight]
----- = volume [20] - yolume [20] - yolume [20]
----- B weight [30000] -] weight [30000] -] weight [30000]

Here we see that the Cargo[2] entity and the container attribute are colored red in both the Output and Expected panes, indicating that
our Output results differ from our Expected results. Studio automatically highlights differences in values in red in both the Output and
Expected panes.

Other types of differences are also highlighted. Unexpected entities in the Output pane are highlighted in blue. And missing entities are
highlighted green within the Expected pane. More details about color codes are included in the Studio Quick Reference Guide.

Be sure to change Cargo[2] Expected container value back to oversize before saving the Ruletest on the next page.
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Save the Test for future use.

Action

Click on the Save
icon on the Studio
toolbar.

OR

Choose File > Save
from the Studio
menubar.

=l

Edit Project Ruleshest Window Help

i Progress Corticon Studie for Analysts

New

Open File...

Close

Clese All

H Save

[5]  SaveAs...

Ctrl+W

Ctrl+Shift+W

Ctrl+S
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Discover

When the time comes to change your rules, you'll
be glad you decided to model and manage them
in Corticon Studio.

Let’s go through another development lifecycle,
starting with the discovery of a new business rule.

~
A
N
\
/
/
7

Collect Package

Initial Rules:

» Cargo weighing <= 20,000 kilos must be packaged in a standard container.
» Cargo with volume > 30 cubic meters must be packaged in an oversize container.
Added after Completeness Check:

e Cargo weighing > 20,000 kilos, with volume <= 30 cubic meters, must be packaged in a heavyweight
container.

New Rule (to add now):

» Cargo requiring refrigeration must be packaged in a reefer container.
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Action &® Rule Operators ¢ Rule Project Explorer &2 =08
g ¥
. .- . . . =+ GrandParent
Switch back to your Rulesheet by clicking the Cargo.ers tab. If you closed it earlier, reopen it S Insurance
using the Open menu or by double-clicking the file inside the Rule Project Explorer window. & OrderProcessing
1= Service Call-outs
l 1= Tradehllocation
1= Training
i= Tutorial
== Tutarial-Done
\ [3 Cargo.ecore
B¢ Cargo.ers
2
. B Rule Messageﬂ 48 Cargoert
Ref |ID Post Alias Text -
1 Info Cargo Cargo weighing <= 20,000 kiles must be packaged in a standard container. (d
2 Info Cargo Cargo with volume > 30 cubic meters must be packaged in an oversize container.
E Info Cargo ighi i i i ged in a heavyweight container.
1 m Action

Enter the new Rule Statement from the
previous page. This will guide us when
we model the new rule.

Note

To model this rule, add two terms to the current Vocabulary. First, add a new attribute to the Cargo entity to define
whether the Cargo requires refrigeration or not (call this needsRefrigeration). Second, add “reefer” as another
possible selection option for the container attribute.
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open:

bottom of the File menu

OR

Use the File > Open File menu option
OR

pane.

If already open , select the Cargo.ecore tab. If not

-
¢ Progress Corticon Studio for Analysls‘

I_'_IIE] Edit Project Rulesheet Window Help

Select Cargo.ecore from the Recent File list at the

Double-click on the file in the Rule Project Explorer

-
& Rule Operators

i =% GrandParent
i+ == Insurance
i 1=% OrderProcessing
[+ 1= Service Call-outs
I+ 1= Trade&llocation
I+ 1= Training
4 == Tutorial
[+ = Tutorial-Done
|[§ Cargo.ecore
B¢ Cargo.ers
g Cargo.ert
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Mew

Open File...

Close Ctrl+W
Close All Ctrl+ Shift+W
Save Ctrl+5

Save As,.,
Save All Ctrl+Shift+5
Revert

MMowve...
Rename... F2

Refresh F5
Print... Ctrl+P
Switch Workspace

Import...
Export...

Properties Alt+Enter

1 Cargo.ert [Users/clabarge/Progress/...]
2 Cargo.ers [Users/clabarge/Progress/...]

3 Cargo.ecore [Tutorial]

Exit




Action

Edit the Vocabulary using

Corticon Studio’s Vocabulary

Editor.

Action

Add a new attribute.

Within the Vocabulary editor
window in the upper right
pane (not the Vocabulary
window in the upper left
pane), right click on the Cargo
entity and choose Add
Attribute from the popup
menu.

OR

Highlight the Cargo entity _
and choose the Add e
Attribute icon on the

toolbar.

OR

Highlight the Cargo entity and
choose Vocabulary > Add
Attribute from the Studio
menubar.

Vocabulary | Window Help

Add Dormain
Add Entity

Add Attribute
Add Association

[|| D O

y

Qi

Java Object Messaging »

Localize..

Report

ﬁ

File Edit Project Vecabulary Window Help

9~ & | ERERIEEEREL T
(2] Rule Vocabulary 52 =~ —08
2] Cargo a [Z] Cargo Prop
= Aircraft » & Aircraft Entit
= Carge i+ | Cargo| Entit
= container i = Flight Undo
== manifestMumber Redo
= volume
=] weight of  Cut
)—. flightPlan (FlightPlan) 2 Copy
E4 FlightPlan Paste
¥ Delete
Select All
Insert Row

aRuIe Ope ﬁ Rule Proj &2 =0

2%~

Rule Stateme

1= GrandParent
1=* Insurance

T NrdarDraraccinn

- N

Remove Row
Add Rows to End

Move Up

Move Down
Add Domain
Add Entity

Add Attribute
Add Association

Localize...
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Action

Change the attribute name to needsRefrigeration and
set the data type to Boolean.

e Cogoecore B

a [ Cargo

i B Aircraft

== container

== manifestMumber

= volume

= weight

3~ flightPlan (FlightPlan)
i = FlightPlan

iT = -,
Eﬂ- *Cargo.ecore &4 8
1 Cargo Property Mame Property Value
= Aircraft Attribute Mame needsRefrigeration
= Carge Data Type Boolean
== container ma:ldatm}'
. ode
= manifesthumber Decitnal
= needsRefrigeration DateTime
= volume Date
= weight Intgger
3— flightPlan (FlightPlan) St””% _—
. containerType
£ FlightPlan Time
y 4

First, double click on the
attribute name to type over
its initial default value.

menu.

Next, choose the data type
Boolean in the pull-down
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Action

Add “reefer” as another allowable type of container.

[¢ *Cargo.ecore I3 =0 |
] Carge Property Mame Property Value . .
= Aircraft Attribute Name conta!ner Select the container attribute and note the
= Carge Data Type [containerType - Data Type: containerType. This is a custom
= container Mandatory Yes .
B manifestNumber Made Base data type that defines a set of allowable values
e for container (an enumerated set).
fm *Cargo.ecore &% = 0]
] Cargo Custom Data Types
Aircraft
Cargo Data Type Mame | Base Data Type = Enumeration | Constraint Expression = Label Value -
= Carg yp yp p
=| container containerType String Yes standard ‘standard' D
#=| manifesthumber oversize 'oversize'
B needsRefiigeration heavyweight | ‘heavyweight'
=] volume [ reefer ‘reefer’ |
] vweinht

To define custom data types,
you must first click on the “root”
node of the Vocabulary, noted
by the open book icon ]

Next, click on the containerType
entry. This will display the
enumerated set in the rightmost
table, if available.

| Last, add “reefer” as both a i
Label and a Value, as above.

Custom data types are a powerful capability that allows you to define rules at the level of the Vocabulary that are reused
anywhere the Vocabulary terms are used. You can learn more about custom data types in the Rule Modeling Guide.
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Click on the Save
[
icon on the Studio [ﬁ]
toolbar.

Action OR

Save the Vocabulary and exit

the Vocabulary Editor pane. Choose File > Save ([ pragress Cotcon susiofor Ancists

from the Studio Edit Project Rulesheet Window Help
menubar. New v
Open File...

Close Ctrl+W
Close All Ctrl+Shift+W

[H] save Ctrl+S
[‘a‘] Save As..
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New rule:

e Cargo requiring refrigeration must be packaged in a reefer

container.

Action

Be sure to include
Reference links from the
Rule Statements to the
columns containing the
new rule models.

And, add Post and
Alias.

Action

Now that the Vocabulary contains the
new terms required by the new rule,
complete the model as shown below.

Ea Cargo.ecore

| ee———

Conditions 1 2 3 4
a | Cargo.weight <= 20000 - = 20000
b arooyolume - - =30 <=30
c T
d

Actions 4 1] |

Post Message(s) EA EA EA EA
A Cargo.container standard oversize heavyweight recfer
B
5

Overrides 1

Rule Statements &%

L Rule Messageq

Text

Cargo weighing <= 20,000 kiles must be packaged in a standard container.

Cargo with volume = 30 cubic meters must be packaged in an oversize container.
Cargo weighing = 20,000 kilos, with volume <= 30 cubic meters, must be packaged in

Ref |ID Post Alias
1 Info Cargo
2 Info Cargo
3 Infi Carnn
4 Info Cargo

ICarga requiring refrigeration must be packaged in a reefer container.

—
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Analyze

To review this procedure, Note
_ refer to page 25.
Action Rule analysis is an iterative process. Whenever we add or
change our rules, it is necessary to re-analyze. In this case,
Check for logical errors adding a single new rule has caused three new conflicts, one with
in the Rulesheet. each of our three existing rules.

You can step through multiple conflicts, and filter the Rulesheet to
view only the conflicting rules, via the buttons to the right of the

Conflict Check button:
D000 s

¢ Cargo.ecore =77 *Cargo.ers 23 =0

Conditions 0 1 2 3 4 -
a  Cargo.weight - <= 20000 - » 20000 = |:|
b Cargowolume = = =30 <=30 =
¢ | Cargo.needsRefrigeration - T
d -
Actions L ——| b
Post Message(s) EA A EA EA D
A | Cargo.container standard OVErsize heawvyweight reefer
B
C -
Overrides 1
Rule Statements 2 1 Rule Messages\l =0
Ref |ID Post Alias Text -
1 Info Cargo Cargo weighing <= 20,000 kilos must be packaged in a standard container,
2 Info Cargo Cargo with volume > 30 cubic meters must be packaged in an oversize contai
3 Info Cargo Cargo weighing > 20,000 kilos, with volume <= 30 cubic meters, must be pach
4 Info Cargo Cargo requiring refrigeration must be packaged in a reefer container.

Progress Corticon Studio M

@ Total conflicts detected: 3

O Y A
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Analyze

Action

Reefer containers are only available for standard and heavyweight, but not for oversize
loads. Thus, let’s set rule 4 to override rules 1 & 3, and rule 2 to override rules 1 & 4.

When complete, your Rulesheet should look like this:

. . . . . _
¢ Cargo.ecore (ﬁ *Cargo.ers &3 8
Conditions 0 1 2 3 4 -
a Cargo.weight - <= 20000 - = 20000 - ]
b | Cargowvolume = = = 30 <=30 =
¢ | Cargo.needsRefrigeration = - - - T
d
3
f
g L
:Acﬁcrns 1 LIS | ) ) Al s
_ | Post Message(s) _ _ B | &4 [ | —
A |Cargo.container | standard | OVErsize | heawvyweight .
B You can select multiple
| € | values in the override cell by
[E* | holding down the Ctrl key.
F | | | | | -
Overrides 11,4} | | {1,3}
| E Rule Staternents E@II\M £ Rule Messages
Ref ID  Post Alias Text _
1 Info Cargo Cargo weighing == 20,000 kilos must be packaged in a st
2 Info Cargo Cargo with volurne > 30 cubic meters must be packaged in an oversize contai
3 Info Cargo Cargo weighing = 20,000 kilos, with volume <= 30 cubic meters, must be pacl
4 Info Cargo Carge requiring refrigeration must be packaged in a reefer container.
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Analyze

%
. Ers &% = O
Action
L 1 2 3 * "
; - - == 20000 - = 20000 -
Check for Completeness again ﬁ . . = 30 =30 .
_ _ - - - - T
d
e
f
g il
L
Actions o By | | B | | — he
_ _E_’usl: Message(s) | [ A | % _ 4 _ E4 | |:|
A | Cargo.contaif - ] u oversize | heawvyweight recfer |
'8 | | Progress Corticon Studio [ 5 z [
| € | ] | |
D
E 1 Rulesheet is complete.,
F 1 Mo new rules have been added.
i1, 4} | 1,3 -]
{ | E-\\'

000 kilos must be packaged in a standard container.

' Carge with velume > 30 cubic meters must be packaged in an oversize contai
Cargo weighing = 20,000 kiles, with velume <= 30 cubic meters, must be pacl
Carge requiring refrigeration must be packaged in a reefer container.

2 Info Cargo

E Info Cargo

4 Info Cargo
4 (L

-~

[

© 2014 Progress Software Corporation. All rights reserved.



61

Action

Your last step is to modify your test
case to test the new rule. First
save your rules.

Next, in Ruletest Cargo.ert, first
copy and paste Cargo[1] to create
Cargo[4], in both the Input and
Expected panes.

Next, drag and drop the
needsRefrigeration attribute from
your Vocabulary onto both
Cargo[4] entities. In both panes,
set the value of
needsRefrigeration to “true”.

Next, in the Expected pane,
change the value of container to
“reefer”.

Last, execute the test. Your
Ruletest should look like this:

[3 Cargo.ecore (ﬁ Cargo.ers (IE’Q *Cargo.ert 2 =0
= untitled_1
file:/Ci/Users/clabarge/Progress/CorticonWork_5.3_for_Analysts/Samples/Rule Projects/Tutorial/Cargo.ers
Input Output Expected
= Cargo[1] = Cargo [1] = Carge[1]
== container == container [standard] == container [standard]
== volume [10] = volume [10] = volume [10]
=] weight [1000] =] weight [1000] =] weight [1000]
=l Cargo [2] =l Cargo [2] = Carge [2]
= container == container [oversize] = container [oversize]
=] volume [40] = volume [40] = volume [40]
= weight [1000] = weight [1000] = weight [1000]
=l Carge [3] =l Carge [3] = Carge [3]
== container = container [heavyweight] = container [heavyweight]
== volume [20] = volume [20] == volume [20]
=] weight [30000] =] weight [30000] = weight [30000]
= Cargo [4] =l Cargo [4] = Cargo [4]
== container == container [reefer] == container [reefer]
= needsRefrigeration [true] =] needsRefrigeration [true] =] needsRefrigeration [trug]
== volume [10] = volume [10] == volume [10]
=] weight [1000] =] weight [1000] = weight [1000]
Rule Statements | & Rule Messages 22 = B8

Severity Message Entity

Info Cargo with volume > 30 cubic meters must be packaged in an oversize container. Cargo[2]
Info Cargo requiring refrigeration must be packaged in a reefer container. Cargo[4]
Info Cargo weighing > 20,000 kilos, with volume <= 30 cubic meters, must be package... Cargo[3]
Info Cargo weighing <= 20,000 kilos must be packaged in a standard container. Cargo[l]
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PROGRESS

software

Congratulations! You have now completed two full iterations of the
Corticon development lifecycle, and understand the basic concepts of rule
modeling, analysis, and testing in Studio.

Note

To learn advanced rules modeling
techniques, see the Advanced Rules
\& Modeling Tutorial.

Discover e

Note

To learn how to deploy rules, see the Tutorial for
Corticon Server — Deploying Web Services.
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Corticon Studio and Corticon Studio for Analysts both provide the whole doc set in online help.

PROGRESS

software

i - Pregres Developes Studes
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Introduction

Thus is the Codticon Advanced Rule Modeing Tufors! You can star Io leam about Corboon Siudéo in
this guide, but you might want to start with the Basic Rule Modelng Tolona!, an nfroduction o B
Corticon Studio, The basic utorial walks. theough how o capbure rules from business spedific atons
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» Undaritindesy Collactions
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+ Using Filters
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are tested in Aulstests, and then assembie them nto 3 Rulefow
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Corticon Studies
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The whole doc set is also available as a
package of books in PDF format, available
on the Progress Software download site.

J¢ PROGRESS Corticor

Corticon Studio Tutorial:
Basic Rule Modeling
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